The Creation of Straight and Spiral Toothed Bevel Gears Using the Pro/ENGINEER Design Program

Mark N. McAllister
3 September 2008
Table of Contents:

Table of Contents: ............................................................................................................................. i
Disclaimer ........................................................................................................................................1
Preamble .........................................................................................................................................1
Development Flow Chart..................................................................................................................2
Bevel Gear Foundation ....................................................................................................................2
  Setup ............................................................................................................................................2
  Template Parameters ...............................................................................................................2
  Relations ...................................................................................................................................3
Straight / Spiral Tooth Base ...........................................................................................................3
  Tooth Datums ................................................................................................................................3
    Tooth Coordinate System [TCSYS] ........................................................................................3
  Tooth Datum Planes .................................................................................................................3
    Section Datum Point Layout [SDP] ........................................................................................3
Spiral Gear Specific Features ..........................................................................................................5
  Pitch Cone Surface [PCS] ............................................................................................................5
  Spiral Plane Axis [SPA] ................................................................................................................6
  Spiral Angle Plane [SAP] ..............................................................................................................6
    Post Feature Creation ...............................................................................................................7
  Spiral Curve Path .........................................................................................................................7
  Geometry ..................................................................................................................................8
  Project onto Pitch Cone ..............................................................................................................8
    References ...............................................................................................................................9
  Spiral Curve Datum Points [S#CDP] ........................................................................................9
    References ...............................................................................................................................9
Section Coordinate Datums .............................................................................................................9
  Primary [SXPCSYS] .....................................................................................................................9
    References ...............................................................................................................................9
  Secondary [S#SCSYS] ..................................................................................................................10
    Relation ................................................................................................................................10
  Tertiary [S#TCSYS] .....................................................................................................................10
    Relation ................................................................................................................................10
Proto Tooth ....................................................................................................................................10
Section Curves ..............................................................................................................................10
  Parametric Equations ..............................................................................................................10
    Involute Curve [S#C{1;3}] ....................................................................................................10
    Side (Axis to Involute) Curve [S#C{2;4}] ............................................................................11
Group Section Features .................................................................................................................11
Disclaimer

The templates, supplied with or created using this document, are intended for technical illustrative purposes only. The author lays no claim that the resulting models are true representations of bevel gears produced by gear manufacturers.

Preamble

During the development of this method, the author discovered a problem within the Pro/ENGINEER Wildfire software. When modifying the parameters to create gears, the surface merge features fail. Fixing this and then trying to pattern the tooth, the merges fail again. Pitch cone angles greater than 45° lead to failures. A workaround was devised to circumvent the problem.

The author initially used Empty files to create all templates. All part datum features, coordinate system and datum planes were generated and renamed in accordance to the naming convention displayed in this document. Any default sketch references were deleted.
Development Flow Chart

Bevel Gear Core → Bevel Gear Foundation → Bevel Gear Part Assembly

Straight Tooth Base

- Cup Face Tooth Pinion
- Cup Face Tooth Gear

Spiral Tooth Base

- Flat Faced Tooth Pinion
- Flat Faced Tooth Gear

Left-Hand

- Cup Face Tooth Pinion
- Cup Face Tooth Gear

Right-Hand

- Flat Faced Tooth Pinion
- Cup Face Tooth Gear

Bevel Gear Foundation

SETUP

Template Parameters

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Type</th>
<th>Initial Value</th>
<th>Designate Where Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tooth Parameters</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DIAMETRAL_PITCH</td>
<td>Real Number</td>
<td>10</td>
<td>Pinion</td>
</tr>
<tr>
<td>NUMBER_OF_TEETH</td>
<td>Integer</td>
<td>20</td>
<td>●</td>
</tr>
<tr>
<td>NUMBER_OF_TEETH_MG</td>
<td>Integer</td>
<td>20</td>
<td>●</td>
</tr>
<tr>
<td>FACE_WIDTH</td>
<td>Real Number</td>
<td>0.5</td>
<td>●</td>
</tr>
<tr>
<td>PRESSURE_ANGLE</td>
<td>Real Number</td>
<td>20</td>
<td>●</td>
</tr>
<tr>
<td>SHAFT_ANGLE</td>
<td>Real Number</td>
<td>90</td>
<td>●</td>
</tr>
<tr>
<td>SPIRAL_ANGLE</td>
<td>Real Number</td>
<td>30</td>
<td>●</td>
</tr>
<tr>
<td>CLEARANCE</td>
<td>Real Number</td>
<td>0.01</td>
<td>●</td>
</tr>
</tbody>
</table>

Gear Blank Parameters

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Type</th>
<th>Initial Value</th>
<th>Designate Where Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOUNTING_DISTANCE</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>BORE_DIAMETER</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>BORE_LENGTH</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>HUB_DIAMETER</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>HUB_LENGTH</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>APEX_TO_BACK</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>BOLT_CIRCLE</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>THROUGH_HOLE</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>NUMBER_OF_HOLES</td>
<td>Integer</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>CBORE_DIAMETER</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>CBORE_DEPTH</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
<tr>
<td>WEB_THICKNESS</td>
<td>Real Number</td>
<td>0</td>
<td>●</td>
</tr>
</tbody>
</table>
Relations

\[
\text{CUTTER DIAMETER} = \frac{(\text{NUMBER OF TEETH} + \text{NUMBER OF TEETH MG})}{(2 \times \text{DIAMETRAL PITCH})}
\]

IF \text{NUMBER OF TEETH MG} > \text{NUMBER OF TEETH}

\[
PITCH\_CONE\_ANGLE = \text{ATAN}((\sin(\text{SHAFT\_ANGLE})/((\text{NUMBER OF TEETH MG}/\text{NUMBER OF TEETH}) + \cos(\text{SHAFT\_ANGLE}))\]

ELSE

\[
PITCH\_CONE\_ANGLE = \text{SHAFT\_ANGLE} - \text{ATAN}((\sin(\text{SHAFT\_ANGLE})/((\text{NUMBER OF TEETH}/\text{NUMBER OF TEETH MG}) + \cos(\text{SHAFT\_ANGLE}))\]

ENDIF

\[
PITCH\_DIAMETER = \text{NUMBER OF TEETH/\text{DIAMETRAL PITCH}}\]

\[
\text{ADDENDUM} = \text{DIAMETRAL PITCH}^{\text{+1}}\]

\[
\text{DEEDENDUM} = \text{CLEARANCE} + \text{ADDENDUM}\]

\[
PITCH\_CONE\_RADIUS = \text{PITCH\_DIAMETER}/(2 \times \sin(PITCH\_CONE\_ANGLE))\]

\[
\text{ADDENDUM\_ANGLE} = \text{ATAN}((\text{ADDENDUM}/PITCH\_CONE\_RADIUS))\]

\[
\text{DEEDENDUM\_ANGLE} = \text{ATAN}((\text{DEEDENDUM}/PITCH\_CONE\_RADIUS))\]

\[
\text{ANGULAR ADDENDUM} = \text{ADDENDUM}\times\cos(PITCH\_CONE\_ANGLE)\]

\[
\text{OUTER\_DIAMETER} = \text{PITCH\_DIAMETER} + 2 \times \text{ANGULAR\_ADDENDUM}\]

\[
\text{FACE\_ANGLE} = \text{PITCH\_CONE\_ANGLE} + \text{ADDENDUM\_ANGLE}\]

\[
\text{ROOT\_ANGLE} = \text{PITCH\_CONE\_ANGLE} - \text{DEEDENDUM\_ANGLE}\]

\[
\text{VERTEX\_DISTANCE} = \text{OUTER\_DIAMETER}/(2 \times \tan(\text{FACE\_ANGLE}))\]

\[
\text{PHI} = ((180/\pi) \times (\tan(\text{PRESSURE\_ANGLE}) - \text{PRESSURE\_ANGLE}\times\pi/180))/\cos(\text{PITCH\_CONE\_ANGLE})\]

\[
\text{TCRA} = (90/\text{NUMBER OF TEETH}) + \text{PHI}\]

Straight / Spiral Tooth Base

TOOTH DATUMS

These are the initial datum features used in the primary tooth’s development.

Tooth Coordinate System [TCSYS]

This coordinate system is the only connection for the primary tooth to the rest of the model. All further datums and geometry will be based off of this feature. The single non-zero dimension is used for creating the tooth pattern.

Use the Part CSYS [PCSYS] as the reference. Rotate the feature about the Z-axis an arbitrary angle.

Note: Unless otherwise noted, the author uses 30° for all arbitrary angles.

See Figure 1

Tooth Datum Planes

There are three datum planes needed for referencing later features and geometry. They have a zero (0) offset along each axis of the TCSYS coordinate system.

- X [TYZPLN]
- Y [TXZPLN]
- Z [TXYPLN]

Section Datum Point Layout [SDP]

This is a Sketched Datum Point feature. This feature contains the points and reference dimensions necessary to create the proper tooth cross-sections.

The sketching plane is the TYZPLN plane and the top reference is the TXZPLN plane.
Note: For all “side view” sketches, the author does not use the default references. The user can use the defaults, if so desired, and modify the subsequent instructions accordingly. The reference for the sketch itself is the TCSYS coordinate system.

**SKETCH**

Create a Horizontal Construction Line (CL) through the TCSYS; this is the gear’s ‘Rotation Axis’.

Next, create one more, angled through the TCSYS from the lower left to the upper right; this is the gear’s ‘Pitch Line’ (PL). The dimension should be angular and based from the Horizontal CL. Modify the value to be related to the PITCH_CONE_ANGLE (PCA).

**POINTS ALONG PITCH LINE**

*Heel Pitch Point*

Place a sketch point on the upper portion of the PL. Modify the Weak Dimension to be related to PITCH_DIAMETER/2.

*Toe Pitch Point*

Place another point on the PL between the heel point and the TCSYS. This is to be dimensioned from heel point aligned with the PL. The dimension value is equal to the FACE_WIDTH (FW) \[sd3\].

At this point in the construction, the four variances begin to diverge. See Figure 2.

*Internal Points*

Note: These are not required for the Straight Toothed gears.

The internal points are used for the creation of additional sections so that Spiral Gears are generated with a smoother profile.

For the Spiral Gears, place three (3) points between the Heel and Toe points. See Figure 3. Dimension between them aligned to the PL with the dimensions equal to FW/4. The initial relation can be equal to \(sd3/4\) and the two (2) successive dimensions equal to the initial.

*External Points*

The external points allow the side surfaces to extend past the revolved surface feature to be created later. This can be the next major differentiation point in the development, but the single dimensional modification can be performed at a later time. This allows for a more straightforward development.

One point is to be placed along the PL on the outside of the Heel point. The aligned dimension is equal to \(sd3/4\), the same as the Internal Points above.

Another point is located along the PL between the Toe point and TCSYS. This is the dimension that needs to differentiate. For Parallel teeth, the dimension is the typical \(FW/4\).

See Figures 3& 4.
FLAT FACE TOOTH EXCEPTION

To allow for the tooth sides to pass through the rotated toe end surface, this dimension must be doubled to \( FW/2 \). As stated before, this can be modified post, deviation, after the closed rotated surface is generated.

POINTS ALONG REVOLUTION AXIS

Construction Lines

The construction lines determine the location of the datum points that follow. The points, in turn, will be the location markers for the primary coordinate system used to generate the involute curves.

All construction lines are Normal to the PL.

For Straight Tooth Gears, only the outer points along the PL are used.

For Spiral Tooth Gears, the lines pass through each point along the PL is used.

Points

A sketch point is placed at every intersection of the Construction Lines and Horizontal CL.

REFERENCE DIMENSIONS

The equation used in determining the base radius of the involute requires the pitch diameter. The teeth are not oriented on a cylinder, but rather a cone. These dimensions simplify the development, by giving the proper, required “pitch radius” for the sections.

Go to: Sketch>Dimension>Reference. Dimension between corresponding points and aligned to the CL.

See Figures 5 & 6.

Spiral Gear Specific Features

PITCH CONE SURFACE [PCS]

This is a Revolved Surface Feature. It is revolved through 90° included angle on Both Sides.

For the sketch placement: Use Previous.

The sketch references are the TCSYS and the outer-most datum points along the pitch line.
This sketch consists of a horizontal construction line through the TYSCS and a geometry line between the external endpoints. See Figures 7 & 8.

SPIRAL PLANE AXIS [SPA]
This feature is used to properly locate the Spiral Plane. Create a Datum Axis through the middle datum point along Pitch Line and normal to the PCS. See Figure 9.

SPIRAL ANGLE PLANE [SAP]
This feature is used to properly orient the sketch geometry that will become the curve path. Place the plane through the SPA and angled from the TYZPLN plane, the default value OK. Next edit the dimension so that it is equal to the SPIRAL_ANGLE parameter. See Figure 10.
**Post Feature Creation**

Due to the geometry of the Spiral curve is best at this juncture to diverge the model into the Left Hand/Right Hand spirals.

- Save the file.
- Save a copy to indicate the proper hand, as indicated by the current SAP orientation.
- Comment out the SPIRAL ANGLE relation, place “/∗” at the start of line containing the relation.
- Edit Feature and add a negative “-” sign in front of the value.
- Regenerate.
- Remove the comment, delete the “/∗”.
- Save a copy to indicate the new SAP orientation.
- Erase the template from memory.
- Open one of the diverged models.

**Spiral Curve Path**

The actual curve is an arc segment, which is projected onto the PCS. Use the Sketch Tool to create the sketch [SPCRVSKTCH]. The sketch plane is made ‘on the fly’.

Use the following, in the order indicated, to create it.

1. Middle SDP Point along the Pitch Cone - Thorough (default)
2. TYZPLN - Normal
3. Pitch Cone - Tangent

The orientation reference should default to the TYZPLN. This is OK.

See Figures 11 & 12.
Sketch References

The following is a list for the sketch references.

- SPA or middle SDP point
- SAP
- Inner Arc Edge of PCS

See Figure 13.

Geometry

Place a Construction Line through the SPA / middle SDP reference and normal to the SAP reference.

Place a circle centered on the CL so that the center is located on the arc center reference side of the SAP. The circle can be either Tangent to the SAP or coincident with the SPA reference point.

The diameter dimension is equal to: CUTTER_DIAMETER. Convert the circle into construction geometry, RMB>Construction.

Create an Offset segment using the outer PCS edge. The offset distance is equal to: 2*CLEARANCE. This will allow the arc segment to intersect the outer edge when projected onto it.

Note: This cannot be converted into construction geometry.

Next, draw an arc concentric to the Construction Circle between the intersections of the Construction Circle and the inner arc reference and the offset segment.

The sketch is complete. See Figure 14.

PROJECT ONTO PITCH CONE

The sketch now needs to be projected onto the PCS. Select Edit->Project from the Pull-Down Menu (PDM).

The type of item to be projected is CURVE. Select the concentric arc from sketch feature.

For the direction, select Normal to surface and select the PCS.

Special Note: From this point on, it is best to create each section (marked with S#...) independently from the other sections.

See Figure 15.
Section Planes [S#PDP]
This feature sets up the datum point used to orient the primary coordinate system.

References
Select the Section Pitch Line Point (SDP) then the TXZPLN. It should default to through and parallel respectively.

EXCEPTION
For the Center, FW/2, point, this feature is not created; the point is the reference.
See Figure 16.

Spiral Curve Datum Points [S#CDP]
This is used to orient the section’s primary coordinate system’s ‘X’ axis.

References
Select the S#PDP and the Spiral Curve Path.

Note: The S#PDP should automatically be selected if created immediately after its creation.

EXCEPTION
For the Center, FW/2, point, this feature is not created; the point is the reference.
See Figure 17.

This concludes the Spiral Gear Specific Feature creation.

Section Coordinate Datums
There are three (3) coordinate systems needed to create the tooth. The secondary and tertiary are copies of the primary.

Primary [SXPCSYS]

References
The Origin for all PCSYS’s is the corresponding Axial Datum Point from the SDP feature.
The positive ‘X’ direction is set using the:
    STRAIGHT TOOTH GEARS
    Corresponding SDP point along Pitch Line
    SPIRAL TOOTH GEARS
    Corresponding Primary Datum Plane/Curve Point, S#CDP
The positive ‘Z’ direction is set using the Z-axis of the TCSYS.
See Figure 18 & 19.
SECONDARY [S#SCSYS]
This is a Rotated Copy of the PCSYS. Select Edit>Feature Operations from the PDM. Select Copy, then Move / Dependent / Done.
Pick the S#PCSYS then Done. Select Rotate / CSYS and pick the TCSYS. Select Z axis / Okay.
Enter an arbitrary angle. Select Done Move then Done / OK.
Relation
Edit the feature and set the dimension value equal to TCRA (relation equation).

TERTIARY [S#TCSYS]
This is a Rotated Copy of the PCSYS. Select Edit>Feature Operations from the PDM. Select Copy, then Move / Dependent / Done.
Pick the S#TCSYS then Done. Select Rotate / CSYS and pick the TCSYS. Select Z axis / Flip / Okay.
Enter an arbitrary angle. Select Done Move then Done / OK.
Relation
Edit the feature and set the dimension value equal to TCRA (relation equation).

Proto Tooth
For each section, regardless of tooth type, there are four (4) curves to be generated.

SECTION CURVES
The author employed the following strategy. The involute corresponding to the S#SCSYS was created, followed by the side curve. This was repeated for the opposite side. The curves are numbered 1 through 4.

Parametric Equations

Enter equations, substituting the section’s corresponding SDP reference dimension for the D## in the ‘R=D##…’ part. Add a negative sign (-) in front of the ‘R’ for the ‘Y’ equation so that it resembles ‘Y=-R…’

For the S#SCSYS:

For the S#TCSYS:

Proto Tooth
For each section, regardless of tooth type, there are four (4) curves to be generated.

SECTION CURVES
The author employed the following strategy. The involute corresponding to the S#SCSYS was created, followed by the side curve. This was repeated for the opposite side. The curves are numbered 1 through 4.

Parametric Equations

R=D##*COS(PRESSURE_ANGLE)
THETA=T*45
THETA_RAD=PI/180*THETA
X=R*(COS(THETA)+(THETA_RAD*SIN(THETA)))
Y=R*(SIN(THETA)-(THETA_RAD*COS(THETA)))

Hint: Enter the equations into a text document for easy access.

Involute Curve [S#C{1;3}]
Create this feature with the Datum Curve>From Equation option.
Select the coordinate system from the model tree and use the Cartesian equation style.
For the S#SCSYS:

Enter equations, substituting the section’s corresponding SDP reference dimension for the D## in the ‘R=D##…’ part. Add a negative sign (-) in front of the ‘R’ for the ‘Y’ equation so that it resembles ‘Y=-R…’

For the S#TCSYS:
The ‘D##’ is the same as above for the section being created. The negative sign (-) is not applied in this instance.

**Side (Axis to Involute) Curve [S#C(2;4)]**

This is created with the **Datum Curve>Thru Points** option. The references are from the corresponding Axial Datum Point from the SDP feature to the inner endpoint of the Involute Curve. See Figure 20.

Tangency can be applied, selecting **End** from the menu and pick the involute curve. The tangency arrow should point away from the rotation axis. See Figure 21.

**GROUP SECTION FEATURES**

For organizational purposes, it is a good practice to group specific section features together. For Straight Toothed gears, group the Coordinate Systems plus the Curves. For Spiral Toothed gears, group all features from the S#PDP to S#C4. Collapse the copied coordinate systems if necessary.

**Hint:** Hiding the group after creation allows easier visibility when constructing proceeding sections.

**SIDE SURFACE [T{L/R}S]**

For these surfaces, use the **Insert>Blend>Surface** option from the PDM. Use the **General; Select Sec;** and **Smooth** selections to define the feature.

For each section, select adjoining curves. Repeat as necessary. Then repeat for the opposite side.

**Hint:** Selecting the Side Curve first eliminates the need to modify the start points. See Figure 22.
REVOLVED TUBE SURFACE [RTS]

This feature sets up the surface in which the side surfaces enclose to become the solid tooth. It is a **Revolved Surface Feature** revolved through 90° on **Both Sides**.

For the Placement:

**Straight Tooth Gears:**

Pick the *Use Previous* option.

**Spiral Tooth Gears:**

The sketch plane is defined as the TYZPLN, with the top reference as the TXZPLN.

**Sketch References:**

- **TCSYS**
- Heel Pitch Point (PITCH_DIAMETER/2)
- Toe Pitch Point (FACE_WIDTH)

**Geometry**

Draw a Construction Line (CL) horizontally through the TYSCS reference point. Place another CL through both Pitch Point (PP) references; this defines the Pitch Line.

Add additional CLs through each PP that are normal to the Pitch Line.

On the normal line through the heel PP, place one Sketch Point above the Pitch Line and one below. Dimension the points from the Pitch Line. The upper dimension is equal to the ADDENDUM. The lower is equal to the DEDENDUM.

Through each point, make a CL at an angle with no other constraints. The weak dimensions should be angular from the horizontal CL. Modify the upper point’s dimension to be equal to the FACE_ANGLE and the lower equal to the ROOT_ANGLE.

Trace a geometry line between the sketch points and along the face angle CL to the intersection with the toe PP normal CL.

At this point, the geometry differs for each tooth type.

**CUP FACE TOOTH**

Draw a line along the CL towards the root angle CL.

See Figure 23.

**Tip:** A zoom in may be required for properly constraining the geometry.

**FLAT FACE TOOTH**

Draw a line vertically down towards root angle CL.

See Figure 24.

Close the geometry by drawing a line along the root angle CL to the dedendum point.

---

**Figure 23: Completed Flat Faced Tooth Sketch**

**Figure 24: Completed Cup Faced Tooth Sketch**
SURFACE MERGE

Referring to the Flat Face Tooth Exception in the Section Datum Point Layout section, the modification to the innermost point’s dimension, change to $FW/2$, must be performed before proceeding for that type of gear.

**First Feature**

Select the RTS and one (1) side surface (the order is unimportant). From the PDM, select **Edit>Merge**. Flipping the sides may be necessary for proper closure.

See Figure 25.

**Second Feature**

Select the first merge feature and the remaining surface and repeat the procedure as stated above.

See Figure 26.

**Figure 25: First Surface Merge (Representative)**

**Figure 26: Second Surf. Merge (Rep.)**

Figure 27 shows the final results for the lat Faced Straight Tooth and Cup Faced (right-hand) Spiral Tooth.

**Figure 27 Final Tooth Forms**

**SOLID TOOTH**

Select the second merge feature and from the PDM select **Edit>Solidify**

The Pinion / Miter template is now complete, so save.

**Gear Template**

To make the Gear template it is best to use the Pinion template as a template, doubling the NUMBER_OF_TEETH parameter. Geometry construction failure will occur for the second surface feature, and thus the solidify feature as well.
Choose to **Clip Suppress** the faults.
Redefine the first merge flipping the directions as necessary for proper closure.
Un-suppress the second merge feature and perform the same redefinition routine.
Finally, un-suppress the solidify feature.
The Gear template is now complete, so save.

**Tip:** To display a better mesh representation in use, modify either the Pinion or the Gear TCSYS dimension from the arbitrary angle used upon creation to either 0° or 90/NUMBER_OF_TEETH. The mating gear’s template dimension is then adjusted to the remaining value. An exception pertains when Miter Gears are created since both are derived from Pinion templates.

**Using the Templates**
The following now describes the method to build a gear set.

**INITIAL MODIFICATION**
After opening a new part with a template, Pinion or Gear, it is best to modify any known tooth geometry to the manufacturer’s values.

There are four main values that can be modified to adjust the tooth form.
- ADDENDUM
- DEDENDUM
- FACE_ANGLE
- ROOT_ANGLE

These are the driving dimensions for the RTS, to modify them, open **Tools>Relations** from the PDM. At the beginning of each definition, place ‘/*’ (slash star). This action comments out that line.

Next open **Tools>Parameters** and physically modify the values to the known values and regenerate the model.

Any flats or rounds can be added by modifying the RTS sketch with the appropriate geometry.

**Tip:** A sketch point will need to be placed at the intersection of the toe normal CL and the face angle CL as a dimension reference.

**PINION / MITER**
**Tooth Group**

To efficiently pattern the proto tooth, all features from the TCSYS to the Solidify are grouped. Ensure all branches within these features are collapsed. Select the TCSYS and, with the ‘Shift’ key depressed, select the Solidify feature. Press the Right Mouse Button (RMB) and select **Group**.

See Figure 28.

**Pattern**
Select the group created above and RMB and select **Pattern**. Select the TCSYS z rotational angle as the driving dimension. Enter an arbitrary angle and leave the number of copies at the default value of two (2).

See Figure 29.
RELATIONS
Select the pattern and RMB. Pick Edit from the menu. Select the angle dimension and enter NUMBER_OF_TEETH, agreeing with the relation upon exiting.

From the PDM pick Info>Switch Dims. Note the dimension for the number of copies in the pattern, P##.

Open the Tools>Relations from the PDM. Scroll to the bottom and enter the relation: P##=NUMBER_OF_TEETH. This dimensional type cannot be directly modified into a relation. See Figure 30.

Note: A warning will display informing of disconnection in all copies of the tooth. After the core is built connection will occur.

Core

For clarity of workspace, it would be beneficial to modify the display to “Wire Frame” mode.

The core is a Revolved Solid Feature rotated through 360°.

Note: There are many varieties of gear blanks. For the sake of simplicity, only the basic miter style instructions are given. Other general types are in the example files for reference.

SKETCH PLANE
The sketch plane is the Right (PYZPLN) with the Top (PXZPLN) as the top reference.

REFERENCE GEOMETRY
Select the Part Coordinate System (PCSYS) as the reference.

SKETCH, CONSTRUCTION GEOMETRY
The core sketch begins as a combination of the SPD and RTS sketches. A horizontal CL is placed through the PCSYS reference. A second, angled CL is placed through the TCSYS from the lower left to the upper right, the PL. Modify the weak dimension to be equal to the PCA.

Place a sketch point on the upper portion of the PL, the Heel Pitch Point (HPP). Modify the Weak Dimension to be related to PITCH_DIAMETER/2.

Place another point on the PL between the HPP and the PCSYS, the Toe Pitch Point (TPP). This is to be dimensioned from heel point aligned with the PL. The dimension value is equal to the FACE_WIDTH (FW).

Add additional CLs through each PP that are normal to the PL.

On the normal line through the HPP, place one Sketch Point below the PL. Dimension the point from the PL equal to the DEEDENDUM.

Through the point, make a CL at an angle with no other constraints. The weak dimensions should be angular from the horizontal CL. Modify the point’s dimension to be equal to the ROOT_ANGLE.
Add an additional point above the HPP. The upper dimension is equal to the ADDENDUM. Through the point, make a CL at an angle with no other constraints. The weak dimensions should be angular from the horizontal CL. Modify the point’s dimension to be equal to the FACE_ANGLE. Place a Vertical CL through the intersection the face angle and Toe normal CL.

**SKETCH, FEATURE GEOMETRY**

Draw a horizontal line between the TPP past the HPP, then a vertical line up to about midway to the HPP. Next, draw another horizontal line towards, but not to, the HPP Normal CL.

**Note:** For **Flat Face Gears**, ignore the next instruction.

Modify the first line’s weak dimension to be equal to the BORE_LENGTH.

Modify the last line’s weak dimension (it should be the length from the second line) to be equal to the HUB_LENGTH.

Add a horizontal dimension from the PCSYS reference to the vertical (second) line. This is equal to the MOUNTING_DISTANCE. Be sure that the coordinate reference point is selected. See Figure 31.

Add a diametrical dimension between the Bore Length line and the Horizontal CL. This is equal to the BORE_DIAMETER.

Add a diametrical dimension between the Hub Length line and the Horizontal CL. This is equal to the HUB_DIAMETER.

Draw a line from the appropriate Toe Dedendum Point, for the type being constructed, to the Heel Dedendum Point. Then, draw a line along the HPP normal CL so that the endpoint is constrained collinearly to the Hub Length line. Fill any gap, if one exists, between the endpoints of the two lines.

The sketch is now complete. Save and close the sketch and feature. See Figure 34.
GEAR

Gear Tooth

Use the appropriate tooth template and modify the parameters for the tooth.

Note: The author uses the naming structure: PART-NAME_T.PRT for the tooth. The gear assembly is named: PART-NAME_PRT.PRT. The gear core is named PART-NAME.PRT, since this will be the part used with its mate.

Gear Part Assembly

The only addition, besides the NUMBER_OF_TEETH parameter, to a basic assembly file is the addition of a datum axis used to align the tooth part.

Use the assembly template and modify the NUMBER_OF_TEETH parameter. Assemble the tooth (PART-NAME_T.PRT) using the PCS or RTS axis as an Align option to the GEAR_AXIS axis.

Use the PXZPLN or PYZPLN to mate using the angle align type of constraint to the respective assembly plane. Assemble the PXYPLN to the PAXYPLN with a zero (0) offset.

Pattern the tooth, RMB>Pattern, and use the zero (0) dimension to drive the pattern. The increment is 360/NUMBER_OF_TEETH, agreeing to the relation. Leave the number of copies as the default value (2).

Under Tools>Relations, enter Dy=NUMBER_OF_TEETH, where Dy is the dimension for the number of copies (Info>Switch Dims to verify the dimension number beforehand).

See Figure 35.

Gear Core

Draw the core in a similar manner as that outlined in the Pinion / Miter Core section above, modifying the procedure to suit the type.

See Figure 36.

Insert into the gear part assembly using a coordinate system mate. See Figure 37.
Now the patterned teeth are added to the core.

Under **Edit>Component Operations>Merge**, Select the core part and click **OK**.

In the Model Tree, expand the tooth pattern so that all instances are displayed.

Select first instance, and with the **Shift** key held down, select the last instance and click **OK**.

For the options, select **Reference, OK, and No Datums**.

Select **Done one time for every instance!**

Then select **Done/Return** after the last tooth has been added.

**Mating Pairs**

**ASSEMBLY SETUP**

There are two methods in which the gear pair is used in an overall assembly.

**Existing Shafts**

This is the most likely method to be employed.

Use the bore and the appropriate shaft segment as mating references. Mate the mounting surface to the shaft. Mate one of the part planes perpendicular to the gear axis to a similar shaft plane.

**Tip:** Use an angular type on the last constraint so that an angle is at hand to allow rotational adjustment, if required (see below).

**First Parts**

Two axes are required with the mutual included shaft angle between them. Also required are two planes (or surfaces), each normal to the respective axis for the gear. The planes can be at either the common vertex or the actual mating distance for the gear. It would be beneficial, for rotational alignment, to have a common assembly level plane through both axes.

The author, in test cases, used planes at the common vertex.

**MATING CONSTRAINTS**

Each gear is assembled with a “Pin Connection” constraint. This allows for the application of Behavioral Modeling.

The predefined assembly axis is constrained to the ‘core’ feature axis of the gear for the Axis alignment.

The PXYPLN or the actual mounting surface is the part reference while the prescribed mating surfaces are the assembly reference for the Translation.

The Rotation Axis reference would be the common plane through both axes as mentioned above.

Set the zero position for both gears in the set so that the pair appears in mesh.

Remember to check the “Enable regeneration value” to regain mesh appearance.
On occasion, to display the gear pair in proper mesh, it will become necessary to modify the value for the Rotation Axis to some value other than zero (0). In test cases, the value was 5°. Remember to reset the regen value (make zero). See Figure 38.

**Modifying Gears**

**Zerol Bevel Gears**

By setting the Spiral Angle to zero (0), the gear will generate with “Zerol” style teeth.

**Crowning**

By modifying the rotational angle amount, via percentages, Tooth Crowning can be simulated. See Figure 39.