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Overview
This overview provides the following information:

●     SMARTEAM - CATIA Integration in a Nutshell

●     Getting the Most out of This Guide

●     Conventions Used in this Guide

SMARTEAM - CATIA Integration in a Nutshell

SMARTEAM - CATIA Integration is a seamless, integrated, rapidly implementable drawing and document 
management tool for users of CATIA . It gives you the power to manage your Parts, Products and Drawings 
easily, effectively and affordably, and provides powerful functions to assist you in building Assemblies. 
SMARTEAM together with the CATIA Integration product data management solution (PDM) is designed to give 
you the tools to create, edit, view and control CATIA documents, in an intuitive and friendly way. 

SMARTEAM is a revolutionary, rapidly implementable PDM solution. This philosophy stands behind the product 
and enables users to install, set up and implement a full fledged Product Data Management solution very easily 
and rapidly, while maintaining a broad spectrum of functionality.

SMARTEAM streamlines the flow of documents through an organization's business process, thereby promoting 
communication, cooperation and teamwork. SMARTEAM together with the CATIA Integration provides a 
process-oriented approach which enables individuals to work together as a team throughout a product's life 
cycle.

Data Management Tasks

During the Data Management Process, the designer is required to perform activities such as searching, 
copying, linking, or viewing documents. These sub-tasks are supported in SMARTEAM - CATIA Integration.

The example below illustrates SMARTEAM - CATIA Integration's convenient support for the various data 
management sub-tasks. A designer can view and check revisions, and also perform many other activities by 
clicking one of the tabs provided. He can then evoke the dropdown menu to begin the editing process.

Using SMARTEAM - CATIA Integration, the engineer functions within an open environment, i.e. being able to 
manage all engineering data within the CATIA environment.

The SMARTEAM - CATIA Integration functionality is deeply integrated and eliminates the time-consuming and 
bureaucratic process of opening and closing external software in order to perform design and data 
management tasks.

Features and Benefits 



The seamless integration between CATIA and SMARTEAM enables the CATIA users to streamline their workflow 
in the following manner:

●     Work in concurrent engineering through SMARTEAM

●     Browse through any SMARTEAM window to view a hierarchical listing of SMARTEAM documents. 

●     View the Profile Card of any document. The Profile Card displays file information, revision information, 
linked documents as well as thumbnail images of the Part, Product or Drawing.

●     Perform searches to locate any document saved in the SMARTEAM database.

●     Create and save Assemblies. Links are automatically created between the components of an Assembly to 
reflect their composition in CATIA . During revision management, the integrity of the Assembly and its 
components is easily maintained.
You can view and access these links in the Links page of the Profile card. 

❍     Where Used links list all the parents of a document. These links are extremely useful in locating all the 
Assemblies in which a specific Part is used.

❍     Composed of links list all the children of a document. For example, it lists all the subassemblies (Parts 
and Drawings) of an Assembly.

●     Create and save Drawings. Links are automatically created between the Drawing and the Part/Product on 
which it is based. During revision management, the integrity of the revisions is easily maintained.

Getting the Most out of this Guide
This book is intended for the user who needs to become quickly familiar with the SMARTEAM - CATIA 
Integration product. The user should be familiar with basic CATIA Version 5 concepts such as document 
windows, standard and view toolbars. Prior to reading this book, we recommend that you read the various 
CATIA V5 installation tasks in the CATIA - Infrastructure User's Guide Version 5.

To get the most out of this guide, we suggest you start reading Getting Started. Then we suggest you read the 
Basic Tasks. 

Logging In

In order to use the SMARTEAM - CATIA Integration features, don't forget to log in using your login name and 
password as registered by the system administrator. Demo users should log in asjoe (case sensitive) without 
any password.

Conventions Used in this Guide
To learn more about the conventions used in this guide, refer to the Conventions section. 



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View Mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or Advanced Tasks

Interoperability

Workbench Description

Customizing

Administration Tasks

Reference



Methodology

Frequently Asked Questions

Glossary

Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, 
...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

New Functionality

Analyzing the Impacts of a Change
The Impact Analysis functionality displays all the documents pointing onto a selected object. This tool 
allows you to evaluate the impacts brought by the modifications made to the current object and 
therefore help you choose the solution to implement with the least modification cost. 

Enhanced Functionality

SMARTEAM Document Display
The display of SMARTEAM objects in Check Out, Check Out on the Fly windows and Not Saved warnings 
can be customized thru Tree Properties.



Getting Started

Before getting into the detailed instructions for using SMARTEAM - CATIA Integration capabilities, the following 
tutorial aims at giving you a feel as to what you can do with the product. It provides a step-by-step scenario 
showing you how to use key functionalities. 

Suppose you are a designer and you have to modify a screw included in an assembly. Your work will be made 
up of several tasks letting you work alternatively both in SMARTEAM and CATIA. The different tasks proposed 
in this section are:

Before Performing the Getting Started Scenario
Connecting to the SMARTEAM Database

Copying a Part Stored in the SMARTEAM Database
Editing the Copy in the Part Design Workbench

Storing the New CATPart Document in the SMARTEAM Vault
Modifying a Checked In Assembly
Releasing the Modified Assembly

Prior to starting this tutorial, you should read the information section Before Performing the Getting Started 
Scenario.

All together, the tasks should take about 30 minutes to complete.



Before Performing the Getting Started Scenario

Displaying SMARTEAM Status

The Product Structure tree, the drafting workbenches and the Desk tree show the SMARTEAM status for each 
document. The status is displayed on the icons of the documents.

This section deals with the following information:

●     Product Structure Tree 

●     Drafting Workbench

●     Desk Tree

●     Displayed Statuses

Product Structure Tree

In the Product Structure tree, the SMARTEAM status information is displayed thru icons on nodes corresponding to 
products and subproducts. Part status is displayed at the node corresponding to the Part instance inside the assembly.



Drafting Workbench

SMARTEAM statuses are displayed for each drafting document as illustrated below:

 

Desk Tree 

In the Desk tree, information is displayed on all nodes corresponding to the documents (loaded or not). No information 
is displayed if the document is not found. 



Bear in mind the following:

●     No information is displayed if the user is not connected to the database:



●     If you are connected, the top right corner of the icon indicates the SMARTEAM status of the document.

Displayed Statuses 

The statuses displayed by CATIA are as follows:

●     Unknown  

●     New

●     Checked In

●     Checked In, Not Latest

●     Checked In, Dirty

●     Checked In, Not Latest, 
Dirty

●     Checked Out

●     Released

●     Released, Not Latest

●     Released, Dirty

●     Released, Not Latest, 
Dirty

●     Obsolete

●     Obsolete, Dirty

●     Read-only, Modified



Connecting to the SMARTEAM Database  

Your first task consists in connecting to the SMARTEAM Database.

1.  Launch a CATIA session.

2.  Ensure that the settings dealing with linked document localization strategies as well as the display of the SMARTEAM File-

>Open User Interface are set to define the application's behavior we want.

3.  From the SMARTEAM toolbar, click the Connect icon .

or select SMARTEAM->Connect.

The SMARTEAM User Login window appears:

4.  For the purpose of our scenario, enter joe as the user name, without any password.

5.  Click OK.

Now you are connected, go on to the next task to access the part to be edited.



Copying a Part Stored in the SMARTEAM Database
This task shows you how to access the original screw, then copy it so as to create a new screw for the assembly you are supposed to modify.

This task is made up of the following stages: 

●     Searching for a CATPart Document from a CATIA Products List

●     Creating a Copy from the CATPart Document

Searching For a CATPart Document From a CATIA Products List 

1.  Select SMARTEAM->Find->Find Document.

The Search Editor dialog box is displayed.

2.  Select CATIA Products from the list.

3.  Click Modify to perform the type of search that best meets your needs.

The list of all CATProduct documents contained in the base is displayed in a new window.

4.  In the Description field, enter hack_saw.



5.  Click Run to confirm the search.

A list of CATIA Products referencing the part we want is displayed.

6.  Right-click PN CATPRD-0042 and select Open Views -> Top down tree.

This displays in a new window all documents linked to the product you have just chosen.



7.  Select the + sign to the left of CATPRD-0043 Support to see which documents are associated with it.

8.  Select the CATPRT-0173 vis_F_M3_L5 CATPart document.

Selecting it displays on the right-hand side the corresponding profile card that contains information about it.

9.  Optionally, click the Viewer tab to check that it corresponds to the part you want.



Creating a Copy from the CATPart Document

8.  Right-click on CATPRT-0173 vis_F_M3_L5. and select Design Copy.

The Design Copy dialog box appears.

9.  Click the Copy button.

Note that the CATIA Part window that appears indicates that the part is a new feature:



10.  Right-click and select File Operation->Open to open the copy in the Part Design workbench.

The CATPart document is displayed in the Part Design workbench, ready for being modified.

For more information about the Design Copy command, refer to Copying Documents.



Editing the Copy in the Part Design Workbench
Now that you have loaded the copy in the Part Design workbench, you can modify the part's geometry. This task proposes you to perform 
three modifications, then it shows you how to store this new part in the SMARTEAM database. 

This task is made up of the following stages: 

●     Editing a Sketch

●     Applying a New Color to the Part

●     Applying a Material to the Part 

●     Saving CATIA Properties in SMARTEAM

Editing a Sketch

1.  Double-click Sketch 1 to edit Offset.17.

2.  For example, enter 8 as the new offset value.

3.  Exit the Sketcher and if required, update the part.

Applying a New Color to the Part

4.  Right-click PartBody and select Properties.

5.  Click the Graphic tab and set the red color for this new screw.

6.  Right-click Screw F Z M3 L5 and and select Properties.

7.  Click the Product tab.

8.  Add -2 to the Part Number displayed, and set the Source field to Made.



9.  Click OK to confirm these operations.

The new part now looks like this:

10.  Click the Save icon or select SMARTEAM->Save.

This updates the database information related to the document: take a look at the part number as well as to the Source field.



Applying a Material to the Part 

11.  Back in CATIA, select the part in the specification tree.

12.  Click on the Apply Material icon .

13.  Select the Metal tab from the dialog box that appears, then select Steel as the new material to be applied to the copy.

14.  Select the OK button.

The material is now applied to the part.

Saving CATIA Properties in SMARTEAM 

15.  Click the Save icon  or select SMARTEAM->Save.

In the displayed SMARTEAM: Documents window, you can see that the Material field now shows the name of the selected 

material (Steel).

For more information on how to work in the Part Design workbench, see the CATIA - Part Design User's Guide Version 5.



Storing the New CATPart Document in the SMARTEAM Vault 

Now that you have finished the design of your part, you will store it in the SMARTEAM vault so that: 
●     the document is stored in a safe place

●     it can be used by all other users.

 1.  Click the Check In icon  or select SMARTEAM->Life Cycle->Check In.

The Check In: CATIA Part dialog box is now displayed.

2.  Optionally, enter some notes in the Comment: area.

3.  Click OK to confirm.

When checking in a document, the document is saved in the SMARTEAM vault and then moved from your local disk to the vault. Once in 

the vault, all authorized users can access it.

The SMARTEAM: Revisions of ... window is now displayed. You can check that the status of the document is now Checked In.



4.  In the same way, by selecting the Details tab, you can check that the file has been moved to the "CHECKED IN" vault.



Modifying a Checked In Assembly
This task shows you how to access the assembly to be modified, open it in the Assembly Design workbench and then replace the original screw it 
contains with the new screw you have just designed. 

This task is made up of the following stages: 

●     Looking for the Assembly to Be Modified

●     Opening the Assembly

●     Replacing the Original Screw

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Looking for the Assembly to Be Modified 

1.  Click the Find Document icon  or select SMARTEAM->Find->Find Document. 

2.  From the Search Editor dialog box displayed select CATIA Products as the search class.

3.  Click Run to confirm the search.

The list of all CATProduct documents contained in the base is displayed.

4.  Select CATPRD-0042 Hack_Saw.

5.  Right-click CATPRD-0042 Hack_Saw and select Open Views->Top down tree.

A Documents window is now displayed showing the whole CATPRD-0042 Hack_Saw assembly.

Opening the Assembly

1.  Right-click the assembly and select File Operation-> Open For... . 

The Open CATPRD-0042 dialog box is displayed. By default, the Open as read-only option is selected. 

2.  Because you want to modify the assembly, check the Open for edit option.

3.  Click OK.

The Check Out: CATIA Product dialog box appears to let you check out the documents of interest.



 

Check Out windows display SMARTEAM information as set in the Tree Properties dialog box. For more information, see Customizing 

SMARTEAM Document Display Information.

4.  To check out not only CATPRD-0042 Hack_Saw but also one of its components, you need to click on the icon close to that component. For 

the purpose of our scenario, click the icon  in front of CATPRD-0043 a.0 Support.

Note that a new icon  indicates that the document is selected for being checked out.

5.  Click OK to check out the assembly and its Support component at the same time.

The assembly is now open in the CATIA Assembly Design workbench.



Note that the icons close to Hack_Saw and Support (Support.1) indicate that you can edit these documents, which is not the possible for 

the other documents.

Replacing the Original Screw

1.  Select Screw F Z M3 L5 (Screw F Z M3 L5.1) as the part to be replaced.

2.  Select  SMARTEAM->Assembly Management->Replace Component...

The Replace a Component window displays.

3.  Set the Class name combo list to CATIA Part.

4.  Click Run to launch the query.

5.  Select the part you created.

6.  Click OK.

The Impacts On Replace dialog box appears, showing the elements that will be affected by the change. 



7.  Click OK to confirm the operation. 

Note that you can choose between replacing all instances or not. Because the option Yes is checked, all instances are going to be replaced.

The original screw has been replaced as shown here:

Now let's go on to Releasing the Modified Assembly, which is our last task.



Releasing the Modified Assembly

In this last task, your job consists in creating a new release of the assembly you have just modified. Releasing an assembly means placing it in the 
Released vault. This operation is generally done when a supervisor releases a stage of development of the document.

1.  Select SMARTEAM->Life Cycle->Release.

2.  Select the OK button in the Release dialog box.

The Release: CATIA Product window is now displayed:

Note that the Release operation automatically releases the documents that you did not check out for replacing the original screw, as 

indicated by this icon  displayed close to each document.

3.  Click OK to validate the Release operation.

The SMARTEAM: Revisions of CATPRD-0042-a window appears, confirming that the operation is done. In the State column, you can notice 

that:

❍     the icon for the first document is the one identifying a Checked In, Not Latest document

❍     the icon for the second document is the one identifying a Released document



 



User Tasks
This section presents the tasks you usually perform in the SMARTEAM CATIA Integration product. These tasks 
are the following ones:

Finding and Working with Documents
Managing CATIA Parts
Managing Assemblies
Managing Drawings

Managing the Document Lifecycle
Analyzing the Impacts of a Change



Finding and Working with Documents

Locating Parts, Products and Drawings is an essential task, but it can be time-consuming when creating 
complex Assemblies. SMARTEAM provides a number of powerful functions which enable you to locate a 
document in the SMARTEAM data structure. 

The following SMARTEAM tools work together to help you find and modify any CATIA V5 document:

Find Use the Find options to run a search and locate specific documents that match the search 
criteria. These documents are listed in a search results list. 

Browse Browses through each document in the list. Each time you select a document, its Profile 
Card is displayed. You can view general attributes of the document as well as its revision 
history. In addition, you can view a thumbnail image of the document in the Viewer tab. 

Find Out Where 
a Document Is 
Used

Keeps track of all the Assemblies that use a particular document as a component before 
you begin to modify the Part/Product. 

Open as read- 
only

When you locate the exact document that you were searching for, you can launch it 
directly into CATIA V5, for viewing and inspection.

Open for edit When you locate the exact document that you were searching for, you can launch it 
directly into CATIA V5, and modify it accordingly. See Editing.

View 
temporary 
copy

Use View Temporary Copy to copy your design with all references to a temporary user 
location. Each revision will be copied to a different location, so one revision will not 
override its previous revision. See Viewing "exactly as released".

Save When you have finished your modifications, save the document. The Profile Card (and 
appropriate revision history) is updated accordingly. See Saving a Part, Saving an 
Assembly or Saving a Drawing.

 

Finding/Browsing/Editing
Viewing "exactly as released"

File->Open Integration
Running a Predefined Search

Finding Out Where a Document Is Used
Showing Profile Cards

Duplicating an Existing Document

 



Finding/Browsing/Editing

Finding    
Locating Parts, Products and Drawings is an essential task, but it can be time-consuming when 
creating complex Assemblies. 
SMARTEAM provides a number of powerful functions which enable you to locate and retrieve a 
document from the SMARTEAM data structure:

●     Find Document : This option enables you to view the previously defined searches. From the 
Search Editor window, you can: 

❍     run a previously defined search (see Running a Predefined Search)

❍     modify a search.

❍     create a new search.

●     Each search may contain numerous search criteria. The results of the search are listed in a 
search results list. You can browse through the displayed list and view the Profile Card for each 
one. You can also select a document and launch it into CATIA V5.

Browsing 
After you run a search, the search results are listed in a search results list. You can then browse 
through the list to identify a specific document. 

SMARTEAM enables you to view CATIA Parts, Drawings and Products in the Viewer page. This 
enables you to browse through the database and view the most recent image of a document, as 
displayed in CATIA V5.

Browsing through the Viewer page provides a means of searching for and identifying a specific 
document. For example, after running a search, the search results are displayed in a list. You can 
view the image of each of these documents and launch one into CATIA V5, if you wish.



Editing 
When you have located a document, you can quickly launch it and edit it in CATIA V5 using the Open 
for edit command as described below.

1.  From any SMARTEAM window, select your document.

2.  Right-click to select File Operation-> Open For... .

The Open dialog box that appears, provide three options. 

❍     Open as read only (default option)

❍     Open for edit

❍     View temporary copy

3.  Check the Open for edit option.



 

4.  Click OK.

The Check Out dialog box appears to let you check out the documents of interest.

5.  Select the documents you wish. 

6.  Click OK.

The document is now open in CATIA ready for being modified.



Viewing "exactly as released"

This section describes how to open a drawing or product exactly as it was released with all the references revisions at the time of the release.

Recommendations
●     If you are trying to open the document just for printing or viewing, i.e., not for referencing in other documents or for editing, using the Viewer is 

recommended rather then retrieving all the referenced documents. 

●     If you need to open the document in a full CATIA session, use View Temporary Copy. 

Using View Temporary Copy will copy your design with all references to a temporary user location. Each revision will be copied to a different 
location, so one revision will not override its previous revision. 

Recommendations
●     When working in the user working directory, do not use files from the temporary directory. If you do so, you will not be able to perform 

SMARTEAM operations such SMARTEAM save or check in.

●     Use the SMARTEAM File Explorer to clean up temporary folders.

How to view a temporary copy 

1.  From any SMARTEAM window, select your document.

2.  Right-click to select File Operation-> Open For... . 

The Open dialog box is displayed. 

3.  Check the View temporary copy option.

4.  Click OK.

The document is now open in CATIA. 



File->Open Integration

Many CATIA commands such as File->Open..., Replace Component etc. require to select a document. The SMARTEAM integration 
allows you to select the document from SMARTEAM instead of from the local disk.

A SMARTEAM dialog box can be displayed after running the following commands: 

●     File ->Open, 

●     Assembly Replace Component, 

●     User Defined feature instantiation, 

●     Change Source in Edit Links etc.

1.  Set the appropriate settings as explained in Enabling the Display of the SMARTEAM File Open User Interface.

2.  From the SMARTEAM toolbar, click the Connect icon .

3.  Select File-> Open....



SmarTeam Set as Current
If SmarTeam is set as current in the Document Environments list, Open document dialog box is displayed 

The Open document dialog box is displayed. It enables you to run a quick find according to different fields: ID, Revision, Description, 

File Name, Directory etc. For reference information, refer to the SMARTEAM documentation.

Clicking on Smart Desktop enables you to search from the list of projects:



SmarTeam Query Set as Current

If SmarTeam Query is set as Current in the Document Environment list, a SMARTEAM query user interface is displayed: 



Running a Predefined Search
This option enables you to view the previously defined searches. From the Search Editor window, you can:

●     run a previously defined search.

●     modify a search.

●     create a new search.

Once a search is defined and saved, you can run it over and over again. This powerful search tool can help you find your documents 
quickly and efficiently.

For example, you may have a search called New Parts whose search criteria is based on a specific creation date. Each time you run the 
search, you can locate the newest CATIA Parts. A search may contain several search criteria. The results of the search are displayed in 
a search results list. You can browse through the displayed list and view the Profile Card for each one. You can also launch a document 
straight into CATIA (by right-clicking on the document).

1.  Click the Find Document icon  or select SMARTEAM->Find->Find Document. 

The Search Editor window is displayed, as shown below:

Note that the Folder Document Environment must be set to Allowed to be able to use the Find capabilities. For more 

information, refer to Documents Environments. From the Search Editor window, you can:

❍     Click Run to run the selected search and display the search results, as described in step 2.

❍     Click Add to create a new search, and point to By Attribute or By Example to define a new search.

❍     Click Modify to modify the attributes of a previously defined search.

❍     Click Delete to delete a previously created search.

2.  Choose a search and click Run. 

The results are displayed in a search results list, as shown below:



You can browse through the document displayed in the list. Each time you select a document, its Profile Card is shown on the 

right.



Finding Out Where a Document Is Used  

Hierarchical Links (mainly Product Structure relationships)

When you open a Part or Product in CATIA, it is essential to keep track of all the Assemblies that use this particular document as a 
component before you begin to modify the Part/Product. SMARTEAM enables you to locate all the parents of any document (using the 
Where Used option). This is particularly helpful when working with large Assemblies with many sub-Products and Parts as 
components. 

The Where Used command determines the list of the documents which have a hierarchical link to the selected document. For 
example, it lets you define the list of assembly files using a given part.

1.  Display a Part (or a Product) in CATIA.

2.  Select SMARTEAM -> Where Used.

A window is displayed listing all the parents of the Part.

You can browse through the list to view the Profile Card of each document. You can also double-click on a document to launch the 
document into CATIA, but double-clicking it just opens it: this does not checks it out.

CATIA Technological Links

To retrieve the same information on other types of links, you should look for the CATIA Reverse link information. you need to 
determine the appropriate link type used. For more information about the different types of links, refer to Enriched Decision Support 
with All V5 Links. 

Let's take the example of a CATDrawing referencing a CATProduct document. In that case, the link is a CATIA Downstream 
Application link.



1.  Store a CATDrawing document referencing a CATProduct document inside SMARTEAM.

2.  Locate the CATProduct document inside SMARTEAM.

3.  To determine the documents referencing to the CATPart document, you have two ways to do so:

❍     Thru the contextual menu: Associated Objects->CATIA Links->CATIA Downstream Application Reverse.

or
❍     From the Profile Card, click the Links tab. Select CATIA Links->CATIA Downstream Application  in the Link dialog 

box.



Showing Profile Cards  
If you wish to view the relationships between documents open in your CATIA session and other documents as saved in 
SMARTEAM, you can use Show Profile Card.  This capability provides the database view of the document currently displayed in a 
CATIA session. It is available for all documents and can be accessed:

●     From CATIA specification tree

●     From the CATIA Desk tree

●     From the 3D area

From CATIA Specification Tree

1.  Select the document of interest.

2.  Click the Show Profile Card  icon or select SMARTEAM-> Show Profile Card.

Note that the command applies to multi-selected documents:

A SMARTEAM document window opens, giving access to the Profile Card, Links, Viewer etc (information as saved in the ST 

database), corresponding to the selection. If your selection contains a new entity not saved in SMARTEAM, the application 

informs you.

❍     From V5R15 onward, you can run Show Profile Card via contextual menus available from the documents you select. 
The command applies to the documents you select, not to the current document. Just as a reminder, the application 
distinguishes selected documents from active documents.

■     Selected documents: To select a document, you just need to click it. Once selected, it appears as highlighted.

■     Active documents: double-clicking a document, activates that document, which sets up a working context. For 
example, if you double-click a Part, CATIA opens the Part Design workbench for you to access all different 
capabilities for editing that part.

 

 



 

From CATIA Desk Tree 

The CATIA Desk window lets you view the relationships between different documents and obtain information about their 
properties. Once in the window, you can use the Show Profile Card functionality on all documents.

1.  Right-click the document of interest.

2.  Select Show Profile Card  contextual command:

The profile card of the selected document is now displayed.



From the 3D Area

You can also run Show Profile Card via contextual menus available from the geometry area.

 



Duplicating an Existing Document 

The Design Copy command in SMARTEAM enables you to duplicate a design of an existing product, to be used as 
the design base for a new product. It also enables you to duplicate an existing document and its direct or reverse 
dependencies. It is a key function for re-using components and creating a new design which results in significant 
design phase productivity.

1.  Right-click on the document from which you want to create a copy and select Design Copy.

The Design Copy dialog box appears, displaying all documents linked to the document you selected.

When there are contextual links, if an object is linked to the parent object with a tree link and also with one 

of CATIA links, these two objects will have the same status of checked/not checked. If the status of one of 

them is changed then the other one will be automatically changed. For example, if the CATIA Product 

contains a CATIA Part, which is also designed in the context of the CATIA Product (contextual link to product 

exists), then checking/not checking the CATIA Part will automatically check/not check the CATIA Product. 

This ensures the integrity of the design and prevents cross-references between CATIA Parts and CATIA 

Products.

2.  Check the documents you wish to copy, if not already done.

In our example, the user wants to copy a CATProduct document as well as the three CATPart documents it 

references.

3.  To override the default setting for file names, you can type a new file name for the document selected for 

copying: just highlight the selected object and enter the new name in the lower text field.



4.  After selecting and checking all files and options required to copy to the new assembly structure, click the 

Copy button to perform the copy operation.

A new SMARTEAM - Editor window appears, displaying the new copied document.

Select All
Clicking the Select All button selects all objects to copy to the new structure. When several designs share 

the same components, the Design Copy feature will copy the shared components only one time. The newly 

copied component will be the same in all designs.

Options
5.  Click Options.

The Design Copy Options window appears.

6.  In the Show options area check the relevant options:



❍     Check Show profile card on Copy to get a profile card for each new object. This profile card can be 
modified before creating new objects.

❍     Check Show "Project Manager" to link a new design to the project and set as a desk top object (Note: 
Design copy does not support Project Security and the user will not be able to set Project Security during 
the design copy.

❍     Check Show CFO's to display Common File Objects (CFO) in the Design Copy. When a member of a CFO 
is checked/not checked then all the other members of the CFO will also be checked/not checked. In the 
Design Copy window you can not set a different status for different members of a CFO. For example, if 
you check the CATIA Drawing, then all CATIA Sheets of the drawing will be checked automatically.

7.  Select one of the following radio buttons:

❍     Name all files automatically using sequences in order to generate all the files names automatically.

❍     Add a prefix and/or suffix to the original file name in order to add a prefix and/or suffix to all 
original file names. If you select this option add the required prefix and/or suffix to the Prefix of all file 
names and/or Suffix of all file names fields.

The file is copied to the destination entered in the Copy to field. 

Administrator Options...

The Administrator Options is disabled. It is only enabled if you are an administrator. If so, refer to 

Customizing Design Copy in the Administration Task section for further details.

Legend
Clicking the Legend...  button displays the Design Copy Legend window. This informative window identifies 

dependent object types according to colors set in the Tree Properties, Visual Setting dialog box. 

Design Copy is described in greater detail in the SMARTEAM Editor documentation.

 



Managing CATIA Parts
After you create a Part in CATIA V5, save it in the SMARTEAM database by choosing one of the SMARTEAM 
Save options. This enables you to manage all your Parts using the SMARTEAM tools.

After you save the Part, check the Part into the SMARTEAM vault by choosing the Life Cycle->Check In 
option. The Part is placed into the Checked In vault.

As you design Parts and Products in CATIA, you often need to modify an object again and again. It is essential 
to locate the right document; often a time-consuming task. SMARTEAM enables you to locate a document and 
launch it into CATIA quickly and easily. 

The following steps illustrate how SMARTEAM can assist you in locating and launching documents.

In addition, SMARTEAM enables you to locate all the parents of any document (using Where Used). Refer to 
"Finding Out Where a Document Is Used" for details. 

In order to modify this Part in CATIA you must launch the Part into CATIA by choosing Open For->Open for 
edit. You are prompted to check the Part out of the vault, thereby creating a new version of the Part. When 



you wish to place the Part into the vault for safekeeping, you can check it back into the vault (using Life Cycle-
>Check In).

In this manner, SMARTEAM manages and protects all revisions of a Part.

This section contains the following tasks:

Checking Out a Part
Saving a Part

Checking In a Part
Releasing a Part

Creating a New Release
Using Mapped Product Properties

 



Checking Out a Part    

In order to modify a Part in CATIA, the Part must be checked out of the vault.

SMARTEAM also enables you to copy a file to your desktop without checking it out of the vault. This is useful 
when another user is working with the Part (and has checked it out of the vault), but you wish to view the 
document at your desktop.

SMARTEAM provides two methods for checking a Part out of the vault, as summarized below.

●     Check out a Part (from CATIA): If the Part is currently displayed in your session (in read-only mode), you 

can perform the speedy Check Out operation.

●     Check out a Part (from a SMARTEAM window): If the Part is not currently displayed at your desktop, you 

must find the Part by running a search. From the displayed search results list, select the Part and choose 

File Operation-> Open For...  then the Open for edit option.

Since the Part is currently checked in, a message is displayed prompting you to check out the document. 

Click Yes to display the Check Out window and then check out the document. The Part is immediately 

launched into CATIA.

Checking Out a Part (from CATIA) 

If a Part is displayed at your desktop in read-only mode, you can check it out in order to modify the Part.

When is a Part displayed at your desktop in read-only mode?

●     You previously checked in the Part, and a copy or the Part remained at your desktop in read-only mode, 

as described in Checking In a Part.

●     You previously copied a file to your desktop (using the Copy File contextual command).

To check out a Part from the vault (when the Part is displayed at your 
desktop in read-only mode): 

1.  Activate the document containing the Part.

2.  From the SMARTEAM menu, select Life Cycle->Check Out.

The Check Out window appears. 

Check Out windows display SMARTEAM information as set in the Tree Properties dialog box. For 



more information, see Customizing SMARTEAM Document Display Information.

3.  Fill in the attributes, as described below in Check Out Window, or accept the default attributes.

4.  Click OK. 

The Part is re-displayed at your desktop and it can now be modified.

Checking Out a Part from a SMARTEAM Window 

If a Part is checked in to a vault, and it is not currently displayed at your project desktop, you must locate the 
Part and then check it out in order to modify it in CATIA.

To check out a Part: 

1.  Run a search to locate the document that you wish to check out:

❍     Click the Find Document icon  or select SMARTEAM->Find->Find Document.

❍     Select a search and click Run. The search results are displayed in a search results list.

❍     Browse through the list to locate the document you wish to modify.



2.  Right-click the document and select File Operation->Open For...

A dialog box appears, providing three options for opening the document.

3.  Check the Open for edit option.

4.  Click OK to confirm and close the dialog box. 

The Check Out window appears. Note that this window is also displayed when you choose the Life 

Cycle->Check Out option from the SMARTEAM menu.

 

On the left side of the window, the Check Out icon appears to the left of the selected document. On 

the right side of the window, the revision number is automatically proposed by SMARTEAM although 

you can assign a new revision to the document.



5.  Fill in the fields in the Check Out window (optional).

6.  Click OK. 

The status of the document is automatically changed to Being Modified.

You may now work with the Part in CATIA V5 and modify it. Remember to choose the SMARTEAM 

Save option to save these changes and update the Profile Card.

Check Out Dialog Box

The following describes the fields in the Check Out dialog box:

Attribute Description

General tab

Current revision

Next revision

The current revision field is the source revision identifier and the right field 
is the new revision. You may enter a different revision identifier in this 
field although it is not mandatory.

Create new branch Click this option to enable you to create parallel branches of a revision 
based on the same file. Each branch will be assigned a different revision 
number consisting of 3 characters (a.0.1 and a.0.2 for example) instead of 
the standard revision number consisting of 2 character (a.0 for example). 

For example: You may have a document named Pump*55. If the 
Branching value is Yes, two separate users may check out the file and 
each can create a new revision of this file. Two different revision numbers 
will be assigned to these files respectively (a.0.1 and a.0.2) and they can 
both be modified simultaneously.

Note: This field may be disabled according to the life cycle preferences 
defined by your administrator.

Destination directory The directory path of the vault in which the document will be located is 
automatically displayed. If you are using the vault server, the name of the 
generic server is displayed and the destination vault dropdown menu 
enables you to specify the generic destination vault in which the document 
will be located.

Effectivity tab

Phase Click an option from the dropdown list to define the phase of this revision. 
This field is descriptive only and does not affect revision status.

Comments You may enter a comment in this field.

Options tab



Copy General links 
on Check Out/New 
Release 

Click on this option to copy general links from the previous to the newly 
created revision.

Copy links to 
children on Check 
out 

Click on this option to copy all the links to children in the current revision 
to the new revision.

Replace local files on 
Check Out from 
vault 

Choose an option from the dropdown list: 

●     Yes - to replace all local files that were copied during the Check Out 

operation.

●     Yes for copied files - to replace the file if a copy was made of this 

file during an earlier operation.

●     Ask - to prompt the user before making a copy of the file.

Set Default Click this option to assign the same check out information for all document 
revisions such as phase, effective dates, and notes.

To check the document back into the vault for safekeeping, follow the instructions provided in Checking In a 
Part. 



Saving a Part       

Every CATIA Part should be saved into the SMARTEAM database. After you create a new Part or modify an existing Part, you need to 
choose one of the SMARTEAM Save options:

●     Save: Saves the document into the SMARTEAM database.

●     Save As: Saves the document into the SMARTEAM database and defines the project and the parent folder of the document. For 

example, you can save the new Part as a child of the Beta Parts Folder in the Drive Shaft project.

After you choose a SMARTEAM Save option, a CATIA Part Profile Card is displayed. After you fill in the attribute fields and click OK, the 

Part is saved in the SMARTEAM database.

This section shows you different tasks involved when saving a Part: 

●     Saving a Part for the First Time

●     Saving a Part After Modifications

●     Saving a Part with its Associated Design Table

Profile Card

Your administrator may customize the Profile Card (see Chapter 3, "Modifying a Profile Card" of the SMARTEAM Administrator's Guide). 
This window will reflect the appearance of the Profile Card used in your SMARTEAM application.

If you choose to work in Batch Mode Save mode (by checking the Batch Mode Save option from the SMARTEAM menu), a new Profile 
Card is not displayed. Instead, the Part is saved in the SMARTEAM database with the default attributes. You can update the Profile Card 
attributes at any time.

In the Profile Card, the following information is displayed automatically: 

●     Document ID: This number is assigned by SMARTEAM and it 

must be unique.

●     Values may be entered in some attributes, if your administrator 

defined default values for this class of Profile Cards. These 

attributes may be changed.

●     If a file name already exists in CATIA V5, a thumbnail image is 

displayed.

 



●     In the Details tab, CATIA file information is displayed.

SMARTEAM enables you to define the following information in the Profile Card:



●     You can save the Part to a different SMARTEAM class. A new 

Profile Card for the selected class is displayed.

●     You can link the Part directly to the SMARTEAM project desktop.

●     You can define attributes for the Part.

 

Saving a Part for the First Time 

1.  In CATIA V5, create a new Part.

2.  From the SMARTEAM menu, choose Save.

A Project Manager dialog box appears. In this window you can define the project and the parent folder to which the document 

belongs.

If the document is already saved, the CATIA file name is displayed.

You can define the level of sub-branches displayed in the project selection tree and/or the document selection tree.

If you leave the file name field empty, when clicking Save an automatic file name will be generated.

3.  Click the  icon and choose a project from the Projects Tree dropdown list that appears. 

The Part will be saved as a document in the selected project. 



4.  Choose a parent folder from the Document Tree. The Part will be saved as a child of the selected parent folder. 

The classes displayed in the dropdown list are defined by your administrator.

6.  Check the Add to Desktop checkbox.

7.  Check the Link to Projects checkbox to link the Part directly to a project.

8.  Click Save .

The Profile Card window is displayed with a CATIA Part Profile Card, as shown above.

It is recommended to enter a name for the Part in the Description attribute. 

9.  If you wish to save the Part to a different class, click the arrow to the right of the Save as class field and choose a class. 

10.  Select the tabs to review default information about the file.

11.  Select the Details tab. If the document is new, the File Name field is empty.

There are two ways to save: Either you give your Part a file name or you let the Save function define a name for your Part.

If you leave the field blank, the name is built using the CN_ID attribute.

11.  Specify the attributes for the Part.

12.  Click OK. 

SMARTEAM - CATIA Integration automatically saves your file to the database, giving it a unique identity, where it can be easily 

found for later use.

By default, the text entered in the Description field is displayed in the tree browser next to the ID number. It is useful to assign a 

meaningful name to the document in the Description field.

If you now want to check in the document, see Checking In a Part.

 



Saving a Part After Modifications 

After a Part is added to the SMARTEAM database, you are likely to modify the Part in CATIA many times. Each time you modify the Part, 

you must save it using one of the SMARTEAM Save options.

●     Save: The Part is saved in the SMARTEAM database, with all its 

modifications. Its Profile Card is not displayed at this time.

●     Save As: The SMARTEAM Save As window is displayed. In this 

window, you can define the project and parent to which the Part 

belongs. The Part together with its new links is saved in the 

SMARTEAM database.

 

1.  Open an existing Part in CATIA V5.

You can run a search to locate the Part and then launch it directly into CATIA V5.

2.  From the SMARTEAM menu, choose Save. 

The Part is saved in SMARTEAM and its Profile Card is updated accordingly.

3.  You can define the level of sub-branches displayed in the project selection tree and/or the object selection tree. Click Options to 

display the Save Options window and click the Tree Setting tab.

4.  Check the appropriate checkboxes.

 Alternatively, you can do as follows:

 
1.  Choose Save As. 

The SMARTEAM Save As window is displayed.

2.  Choose a project from the Project Tree. The Part will be saved as a document in the selected project.

 

3.  Choose a parent folder from the Object Tree. 

The Part will be saved as a child of the selected parent.

4.  Click Save. 

The Part (together with its hierarchical links) is saved in SMARTEAM and its Profile Card is updated accordingly.



1.  Create a basic part.

2.  Click the Design Table icon to create a design table for the part.

To know how to create a design table, see the Knowledge User's Guide.

3.  Once created, save the Excel file as well as the design table you generated.

4.  Now, to save these documents in SMARTEAM, click the Save icon  or SMARTEAM->Save.

This declares the two documents i.e. the Part and the Design Table, and saves them in the database. The Project Manager dialog 

box appears.

5.  Click Save.

The Profile Card dialog box appears for the Part.

6.  Click OK.

The Profile Card dialog box now shows information specific to the Design Table: 

7.  Click OK.

8.  By default, you cannot see the link between the part and its design table. To visualize it, right-click the part and select 

Associated Objects -> CATIA Links.

9.  In the window that appears, choose CATIA Design Table.

 

Saving a Part with its Associated Design Table 



You can now see the link between the CATIA Part and the Design Table:

 



Checking In a Part  
 

This page discusses the following subjects:
●     Checking In a Part for the First Time

●     Checking In a Part

●     Check In Dialog Box

 

Checking In a Part for the First Time

When a Part is first saved into the SMARTEAM database, it is automatically assigned the New status. This means 
that the Part has not yet been checked into a SMARTEAM vault. 

To protect the Part from modifications, place the Part into the SMARTEAM vault by checking it in. After the Part is 

checked in, its status is changed to Checked In.

What happens next?

●     To launch the Part into CATIA V5 and modify it, the Part must be checked out.  When it is checked out, a new 
revision number is assigned to it. For more information, see Managing Parts.

●     The Part can be copied in your CATIA session in read-only mode.

Checking In a Part
After a Part has been checked out and modified, it must be placed back into the vault. At this point, you can check 
the document back into the vault in one of two ways: 

●     Check In, as described below, simply places the document back in the Check In vault. You can later apply the 

Check Out operation on the document to make further changes.

●     Release, as described in Releasing a Part, moves the document to the Released vault. Thereafter, you can 

apply the New Release operation on the document to carry out additional changes.



1.  Activate the document containing the Part you want to check in.

2.  In CATIA, select SMARTEAM ->Lifecycle->Check In.

The Check In window is then displayed. 

3.  On the left-hand side of the window, the Checked In icon  appears to the left of the selected document. 

On the right-hand side of the window, the Check In dialog box is displayed.

4.  Fill in the fields in the Check In dialog box, as described in Check In Dialog Box below. These fields are 

optional, and you may keep the default.

5.  Click OK to check in the Part and exit the Check In view, or click Apply to perform the operation and remain 

in the view.

The Part is now placed in the Check In vault for safekeeping. Note that the status of the document is now 

changed to Checked In. A copy of the file remains in your CATIA session in read-only mode. 

You can check it out again in order to edit the Part, as described in Checking Out a Part.



 

Check In Dialog Box

The following describes the attributes in the Check In dialog box: 

Attribute Description

Revision
The left revision field is the source revision identifier and the right field is the new 

revision. You may enter a different revision identifier in this field although it is not 

mandatory.

Directory
The directory path of the vault in which the document will be located is automatically 

displayed. If you are using the vault server, the name of the generic server is displayed 

and the destination vault dropdown menu enables you to specify the generic destination 

vault in which the document will be located.

Comments You may enter a comment in this field.

Set Default
Click this option to assign the same registration information for all document revisions 

such as phase, effective dates, and notes.

Effectivity tab

Phase
Click an option from the dropdown list to define the phase of this revision. This field is 

descriptive only and does not affect revision status.

Effective From / 

Effective Until 

Click the Date button to enter dates in these fields.



Releasing a Part

When a Part is ready to be moved to production, choose the Release option in order to place it in 
the Released vault. This is generally done when a supervisor releases a stage of development of the 
document. The Part is then assigned the Released status. A Part can be released from the Checked 
In status or the Being Modified status. 

Once a Part is placed in the Released vault, it can only be released as a new revision to ensure the 
safekeeping of this version of the document. The Part can be checked out as a New Release with a 
new revision number.

1.  Display the Part in CATIA.

2.  In CATIA, select SMARTEAM ->Lifecycle -> Release.

The Release window is then displayed.

The fields in the Release window are the same as those in the Check In window.

3.  Fill in the fields.

4.  Click OK. 

The status of the document is automatically changed to Released in the State field.

Checking a Part Out of the Released Vault

To check a Part out of the Released vault, you must use the New Release option, as described in 
Checking Out a New Release. A new revision of the document is created and the previously released 
revision remains in the vault.



Creating a New Release 

When a document has the Released status it can only be taken out of the vault by clicking the New 
Release command. This command automatically creates a new revision of the document, thereby 
saving the previously Released revision.

SMARTEAM also enables you to copy a file to your desktop without checking it out of the vault. This 
is useful when another user is working with the Part (and has checked it out of the vault), but you 
wish to view the Part at your desktop. 

SMARTEAM provides two methods for creating a New Release for a released document.

Creating a New Release from CATIA

If the Part is currently displayed at your desktop (in read-only mode), you can perform the New 
Release operation from the SMARTEAM menu.

Creating a New Release from a SMARTEAM menu

1.  If the Part is not currently displayed in your CATIA session, you must find the Part by running 

a search. 

2.  From the displayed search results window, double-click the Part.

3.  Since the Part is currently checked in, a message is displayed prompting you to check out the 

document. Click Yes to display the New Release window.

4.  Check out the document.

The Part is immediately launched into CATIA. 

 



Using Mapped Product Properties 

This section discusses the following topics:
●     Saving Properties in SMARTEAM

●     Updating a CATIA Property Following a Change in SMARTEAM 

Prior to performing the scenarios, some properties will already have been mapped in CATIA and SMARTEAM by the administrator. This is 

described in Defining Property Mapping.

Saving Properties in SMARTEAM 

This task shows you how to define materials and Part Number properties on a CATPart document and to transfer this information from CATIA 
to SMARTEAM. 

1.  Select the Part in your CATIA session.

2.  Click on the Apply Materials  icon to display the Library dialog box.

3.  For example, click on the Plaster item  and click OK. 

Plaster is added to both the specification tree and the geometry area.

4.  Select Edit->Properties.

5.  Select the Product tab from the Properties dialog box that appears.

6.  In the Part Number field, enter the following text PN-0000053-A1: 

7.  Click OK.

8.  Click the Save icon  or select the SMARTEAM->Save command.

9.  From the dialog box that is displayed, select a project and click OK.

The document is now declared and its properties are saved in the database. In the SMARTEAM profile card corresponding to the 

document, you can see that the fields Material and Part Number have been completed: 



Should you subsequently modify any CATIA properties you can update the database using SMARTEAM->Properties->Save in 

Database.

Updating a CATIA Property Following a Change in SMARTEAM 

You must already have performed the task Saving Properties in SMARTEAM described above.
Open the SMARTEAM: Documents dialog box displaying the profile card of the CATPart document. 

 

1.  In the SMARTEAM: Documents dialog box right-click, in the tree, on the document.

2.  Select Update.

The Profile Card is now ready to be changed.

3.  Change the material. For example, enter PVC in the Material field as shown:



The property has been modified in the SMARTEAM database. 

4.  Back in CATIA, select SMARTEAM->Properties->Load from Database.

In the CATIA session, you can now see the new Material attached to the document.

Note that when you edit a CATIA Document from SMARTEAM, its properties are automatically updated to reflect the latest changes in the 
database. 

Reminder 
To update a property value Command to be used

from CATIA to SMARTEAM

●     SMARTEAM->Save (the Save icon )

or

●     SMARTEAM->Properties->Save in Database

from SMARTEAM to CATIA SMARTEAM->Properties->Load from Database



Managing Assemblies
Building Assemblies can be very time-consuming, since much of your time is spent in searching for existing 
components and placing them in Assemblies. SMARTEAM - CATIA Integration provides powerful tools to 
assist you in building your assemblies: 

●     Find: Use SMARTEAM Find to locate Parts and Products.

●     Copy File: As you build your Assembly, you can copy Parts/Products to your desktop to view how they 
fit together with the current Assembly.

●     Assembly Management options: 
❍     When you wish to insert an existing Part or Product as a component of the current Product, use 

Insert Component. 
SMARTEAM inserts the component into the current Product. When you save the Assembly, the 
components are saved as children of the Assembly. In this way, SMARTEAM accurately reflects the 
structure of your Assembly.

❍     When you wish to replace an existing Part or Product or a component of the current Product, use 
Replace Component. 
SMARTEAM replaces the selected component with a SMARTEAM Part or Product. When you save the 
new Assembly, the previously selected components are saved as children of the Assembly. In this 
way, SMARTEAM accurately reflects the structure of your Assembly.

❍     Click Replace with Selected Revision to replace the current revision of a document with another, 
of your choosing. 
This operation can only be performed on a document in Checked In status. You are free to use any 
one of the document's revisions.
Be aware that the revision is replaced at all tree locations.
From V5R15 onward, Replace with Selected Revision is available from contextual menus.

●     Save: If you created new Parts as components of the Assembly, SMARTEAM will save each of these 
Parts/Products into the SMARTEAM database when you save the Assembly. A Profile Card for each 
document is displayed. After these components are saved, the Profile Card for the Product is displayed. 
In this manner, you can save the Product and its components.

●     Batch Mode Save: SMARTEAM provides you with a batch method for saving assemblies. The Batch 
Mode Save does not display a Profile Card during a SMARTEAM Save operation. Instead, each 
component is saved in the SMARTEAM database with a unique ID number. At a later time, you can open 
a Profile Card for a component and enter information in the attribute fields.

In addition, SMARTEAM enables you to locate all the parents of any document using Where Used. 

This section contains the following tasks:



Building an Assembly
Adding a New Assembly

Saving an Assembly
Managing the Revisions of a CATProduct Document

Checking In a Product for the First Time
Checking In/Checking Out/Releasing an Assembly

Lifecycle Options

 



Building an Assembly

This task shows you how to use the Assembly Management commands. These enable you to insert 
existing Parts/Assemblies as components of the current Assembly and to replace an existing Part or 
Product or a component of the current Product.

Inserting a Component  

1.  Display an Assembly structure in CATIA V5.

2.  Click the Insert Component icon .

 
2.  Alternatively, right-click and select Assembly Management->Insert Component.

The Search Editor window is displayed, as shown below: 

3.  Choose a search.

4.  Click Modify.

5.  In the Profile Card enter relevant criteria.



6.  Click Run to confirm the search.

7.  In the displayed dialog box, choose a document.

8.  Click OK.

The document is inserted into the assembly structure.

Replacing a Component 
9.  Perform the same steps as for component insertion described above but this time select 

SMARTEAM->Assembly Management->Replace Component...



Adding a New Assembly to SMARTEAM

This task shows you how to add an Assembly to the SMARTEAM database. The procedure is similar to adding a Part.

1.  Display the Assembly in CATIA.

2.  Select SMARTEAM-> Save. 

3.  In the CATIA Save As dialog box that appears, name the file and click Save.

4.  A SMARTEAM dialog box appears. 

In this window you can define the project and the parent to which the document belongs. 

5.  Choose a project. 

The Assembly will be saved as a document in the selected project. 

6.  Choose a parent folder. 

The Assembly will be saved as a child of the selected folder. The CATIA file name is displayed.

7.  Click Save.

8.  A Product Profile Card is displayed in which you can add relevant information. Enter a name for the Product in the Description attribute. 

By default, this attribute is displayed in the Data Manager tree along with the ID number.

9.  Select the tabs to review default information about the file.

10.  Click OK.

SMARTEAM - CATIA Integration automatically saves your Product in the database, giving it a unique identity where it can be easily found 

for later use.

In the SMARTEAM tree hierarchy, all the components of the Assembly are linked as components (children) of the Product. This hierarchical 

link reflects the structure of the Assembly as designed in CATIA.

11.  If the components of the Assembly have not yet been saved in SMARTEAM, a Profile Card for each component is displayed, one by one.

12.  In each Profile Card, name the component (in the Description field).

13.  Click Add to save the new Parts/Products in the SMARTEAM database.



For example, if a Product has three Parts as its components, and these components have not yet been saved in SMARTEAM, a Profile Card 

for each Part is displayed.



Saving an Assembly

Every CATIA Assembly should be saved into the SMARTEAM database. After you create a new 
Assembly or modify an existing one, choose one of the SMARTEAM Save options. Then, check in the 
Assembly by choosing Lifecycle->Check In. The Assembly is then placed into the Checked In vault. 

The SMARTEAM integrated menu provides two methods for saving Assemblies:

●     Save: Saves the Assembly in the SMARTEAM database. See Saving a Part for details.

●     Save As: Saves the Assembly into the SMARTEAM database and defines the project and the 

parent folder of the document.

For example, you can save the new Assembly as a child of the Technical Assemblies folder in the 

Drive Shaft project.

After you choose a SMARTEAM Save option, a CATIA Product Profile Card is displayed in the 

Object Attributes window. After you fill in the attribute fields, click OK. The Assembly is saved to 

the SMARTEAM database.

Since the process of saving a Part is identical to that of saving an Assembly, refer to the following 
pages for detailed instructions: 

To save a document for the first time, see Saving a Part for the First Time. To save a document for 

subsequent saves, see Saving a Part After Modifications

This section discusses the following topics:

●     Saving the Components of an Assembly

●     Using the Batch Mode

●     Document Content Exposure

Saving the Components of an Assembly 

When you save an Assembly, SMARTEAM - CATIA Integration automatically saves the components of 
the Assembly as well:

●     If the components of the Assembly are already saved into the SMARTEAM database, then the 

Save option updates the Profile Cards for all the components to reflect any modifications that 

were made to the components as well as the hierarchical link between the Assembly and its 



components.

●     If the components of the Assembly are new and have not yet been saved to the SMARTEAM 

database, then each of these components will be saved to SMARTEAM one by one. 

1.  A Profile Card for each component is displayed. Fill in the Profile Cards, and click OK.

After each component is saved, a Profile Card for the Assembly is displayed.

2.  Fill in the Profile Card.

3.  Click OK.

Using the Batch Mode 

SMARTEAM enables you to save the components of an Assembly without displaying each Profile 
Card. This can save you a great deal of time. There are two methods for batch saving components:

1.  Select SMARTEAM->Batch Mode Save. 

2.  Save the Assembly using the Save or Save As option. 

SMARTEAM saves all the components but does not display a Profile Card for each one.

Or

1.  Select SMARTEAM ->Save As.

2.  In the Save As window, click the Options tab to display the Save Option dialog box. 

3.  In the Save tab, check the checkboxes

4.  Click OK.



 

Document Content Exposure 

When you save CATProduct documents, the associated internal components are by default exposed 
in the database:

However, you can expose only the documents and their links as shown below:

Only the administrator can make the necessary modifications using the System Configuration tool. 
For more information, refer to the SMARTEAM documentation.



Managing the Revisions of a CATProduct 
Document

As you work with an Assembly, you can make continuous revisions to it. SMARTEAM protects and 
manages these revisions in the same manner as a Part. 

However, an Assembly is more complex than a Part since it consists of many components. It is 
essential to maintain the integrity of an Assembly by performing life cycle operations on the 
Assembly and its children, in coordination with each other. SMARTEAM ensures that the integrity of 
the Assembly and its children is not jeopardized by disabling life cycle operations.

In addition, SMARTEAM provides several lifecycle options which can help you manage your Assembly. 
For example, you can choose:

●     Propagate Operation
to check in or check out the Assembly and its components at the same time

●     Relatives Being Modified 
to view the parents or children of the document that are currently being modified

●     Show Parents
to display the parents of a document. You can then select parents and check them out as well.

These life cycle commands are only available when you choose Check Out or Check In  
from the SMARTEAM menu. They are not available when you check out/in a document 
from the CATIA menu.

Protecting the Integrity of an Assembly

The following examples show how SMARTEAM protects the integrity of an Assembly. 

●     When you release an Assembly, its children must be Released as well. For example, if an 
Assembly has ten subassemblies, each one must be assigned the Released status.

●     You can only move a subassembly to the Obsolete vault if its parent Assembly is also Obsolete.

●     To perform a revision operation on an Assembly and all its children simultaneously, SMARTEAM 
provides the Propagate Operation option. For example, if you wish to check out a Stump 
Preacher Guitar and all its ten subassemblies, you can check them all out simultaneously.

●     You have the option to perform a revision operation on an Assembly and not on its children, or 
perform a revision operation on a child and not on the parent Assembly.
For example, you can check out a Stump Preacher Guitar Assembly from the vault and leave the 
children in the vault.

●     You can copy the children of an Assembly to your desktop so that you can view them but not 
modify them. The status of the children remains Checked In, while the status of the Assembly is 
Checked Out.

●     You can check a subassembly out of the vault independently and leave the parent Assembly in 
the vault.



Checking In a Product for the First Time
When a Product is first saved into the SMARTEAM database, it is automatically assigned the New status. 
This means that the Product has not yet been checked into a SMARTEAM vault. 

To protect the Product from modifications, place the Product into the SMARTEAM vault by checking it in. 
After the Product is checked in, its status is changed to Checked In.

When you check in the Assembly, you can check in the Product and all its components simultaneously 
using the Propagate Operation.

1.  Select SMARTEAM ->Life Cycle->Check In.

The Check In dialog box is then displayed.

On the left-hand side of the window, the Assembly and its components are displayed with the 

Checked In icon to the left of the selected document. On the right-hand side of the window, the 

Check In window is displayed.

2.  To check in the Assembly and all its components together, right-click the Assembly and select 

Propagate Operation. 

3.  Fill in the fields in the Check In window (optional).

Refer to Checking In Dialog Box for a description of these fields.

4.  Click OK.

The Assembly is now placed in the Checked In vault. Note that the status of the Assembly is 

now Checked In.



Checking In/Checking Out/Releasing a Product 

Since the process of checking in and checking out an Assembly is quite similar to the life cycle operations on a Part, we will only provide a brief 
description of each life cycle operation. Instead, we will describe the unique features provided by SMARTEAM which enable you to manage the 
Assembly, together with its components, as you create revisions. 

For each life cycle operation, you can: 

●     Check out/in an Assembly and all its components together. For example, you can check out the Ski Draft Assembly and its ten components.

●     You can check out/in an Assembly and handle each component individually. For example, you can check out an Assembly and copy all its 

components to your desktop.

This section provides the following information:

●     Handling Components

●     Checking Out an Assembly (from CATIA) 

●     Checking Out an Assembly from a SMARTEAM Window

❍     Checking out All the Components of a Product

❍     Checking out Components Individually

●     Checking In/ Releasing an Assembly

❍     Checking in All the Components of a Product

❍     Checking in Components Individually

 

Handling Components

SMARTEAM enables you to manage an Assembly and its components.

You can:

●     Check out an Assembly and copy all its components to the desktop.

●     Perform the same life cycle operation (Check Out, Check In, Release) on the Assembly and all its children, by choosing Propagate 

Operation, as described in Propagate Operation.

●     Handle each component individually. For each component, you can: 

❍     Check in or check out the component together with its parent Assembly.

❍     Copy the component to the desktop. The child remains in its current state.

❍     Choose No Operation for the component. The No Operation capability enables you to maintain a subassembly in its present state 

while performing a revision operation on the Assembly (or vice versa).

For example: You wish to insert a new Part into an Assembly to replace an existing Part. You can check out the Assembly, and copy all the Parts 

to your desktop, except the Part you wish to replace. For that Part, choose the No Operation icon .

When you click OK, the Assembly will be checked out of the vault, and all the children except one will be copied to your desktop. In SMARTEAM, 

you can replace the old Part with a new Part at your desktop to see how it affects the Assembly as a whole.



Checking Out an Assembly (from CATIA)

If an Assembly is displayed at your desktop in read-only mode, you can choose to check it out in order to modify it. SMARTEAM enables you to 
do so.

1.  Display the Assembly in CATIA (in read-only mode).

2.  To check out a document: Select a document (Assembly or Part), in SMARTEAM menu, select Life-Cycle-> Check Out . 

3.  In the displayed Check Out window, fill in the fields.

Check Out windows display SMARTEAM information as set in the Tree Properties dialog box. For more information, see Customizing 

SMARTEAM Document Display Information.

4.  Click OK.

At your desktop, you can view the assembly and its components. Those documents that were checked out may be modified. After you modify 

the document, remember to apply the SMARTEAM->Save command.

Checking Out an Assembly from a SMARTEAM Dialog Box

If an Assembly is checked in to a vault, and it is not currently displayed at your desktop (in read-only mode), you must locate the Assembly and 
then select File Operation-> Open For... contextual command to launch it into CATIA and modify it.

In the displayed Check Out window, you can right-click to display a dropdown menu which provides several life cycle options. These life cycle 
options can assist you in managing your Assembly. Refer to Life Cycle Options for details.

1.  Run a search to locate the Assembly that you wish to check out. 

2.  Right-click the assembly and select File Operation-> Open For... 

The Open dialog box is displayed. By default, the Open as read-only option is selected. 

3.  Check the Open for edit option.

4.  Click OK.

The Check Out: CATIA Product dialog box appears.
On the left-hand side of the window, the Check Out icon appears next to the Assembly and the Copy File 
icon appears next to the components.



The default operation for the components (Check Out or Copy File) is determined by the administrator.

Checking out All the Components of a Product

5.  To check out not only an assembly (here CATPRD-0042 Hack_Saw) but also all its components, you need to use the Propagate 

Operation contextual command. This checks out all the documents simultaneously. For more information, refer to Life Cycle Options.

Checking out Components Individually

5.  To check out an assembly and some of its components, you can define an operation for each component as follows: 

Either: 

❍     Right-click on the icon of a document to display a list of options.

This list differs for each life cycle operation, as shown below: 

Or, more simply,

❍     Click on the icon of the document to choose an operation.

The icon toggles between three states:



Example

In the following example, double-click the icon  in front of CATPRD-0043 a.0 Support if you wish to check it out: 

Once done, the Check out icon  indicates that the document is selected for being checked out.

6.  Fill in the fields in the displayed revision window, and click OK.

Checking In/Releasing an Assembly

If it is the first time you are checking in the Part see Checking In a Product for the First Time.

SMARTEAM provides two methods for checking in or releasing an Assembly:

●     Check in the Assembly and its components from any SMARTEAM window. You must select each document one by one and check it in (or 

Release it).

This method is identical to the checking in a Part as described in Checking In a Part. Below is a quick summary. 

1.  Select the Part or Assembly and choose SMARTEAM->Life Cycle->Check In or Release.

The Check In (Release) window is displayed, as shown in Checking In a Part.

2.  Fill in the fields and click OK. 

The status of the document is automatically changed to Checked In. The Assembly is now checked into the vault for safekeeping. A 

copy of the file remains at your desktop in read-only mode.

●     Check in the Assembly using the Life Cycle->Check In (or Life Cycle->Release) capability (from the SMARTEAM menu). Instructions 

are provided on the following page.

When you choose the Life Cycle->Check In (or Release) option from the SMARTEAM menu, a Check In (Release) window is displayed. 

In this window you can check in the Assembly and its components at the same time. In addition, you can view life cycle options which help 

you manage your Assembly, as described in Life Cycle Options.

To check in an Assembly

1.  From the SMARTEAM menu, point to Life Cycle and choose Check In.

The Check In window is displayed. On the left side of the window, the Assembly and its components are displayed. 



2.  You can either:

❍     check in all the documents together: 

❍     handle each component individually: 

Checking in All the Components of a Product

3.  To check in all the documents together, right-click and choose Propagate Operation. 

The Check In icon is displayed next to each component in the tree.

4.  Fill in the fields in the Check In window (optional).

5.  Click OK. 

The Assembly and its components are checked in to the vault. A copy of these documents does not remain at your desktop.

Checking in Components Individually

1.  To handle each component individually:

Either:

❍     Click on the icon of a document to display a list of options.

This list differs for each life cycle operation, as shown below: 

Or, more simply,

❍     Click on the icon of the document to choose an operation.

The icon toggles between three states:

2.  Complete the fields in the displayed window.

3.  Click OK.

 



Lifecycle Options 
 

Your Assemblies are often complex with numerous subassemblies. As you manage the revisions of the 
Assembly, you must keep track of the status of the revisions of the parents and children of each 
Assembly. SMARTEAM provides several life cycle options that can assist you in this task.

1.  Select SMARTEAM->Life Cycle and choose a life cycle operation (Check Out 
for example).

2.  In the displayed dialog box, right-click on a document to display a 
dropdown menu.
A list of lifecycle options is displayed. This list differs according to the 
lifecycle window being displayed. 

Lifecycle menus include the following lifecycle options:

Command Description Example

Associated 
Objects

Enables you to view those documents 
that are linked to the selected document. 
You can then perform lifecycle operations 
on these Associated Objects. See 
Managing the Revisions of a Drawing for 
a complete description.

In SMARTEAM, a Drawing (Stump 
Preacher Guitar Drawing) was created 
based on a Stump Preacher Guitar 
Drawing. When you check out the 
Stump Preacher Guitar Drawing you 
can view and manage its link (the Stump 
Preacher Guitar Drawing).

Propagate 
Operation

Performs the same life cycle operation on 
the Assembly and all its children. 

When you check in an Assembly, you can 
check in all the children simultaneously.

Relatives Checked 
Out

Displays the parents or children of a 
document that are currently Checked 
Out. 

When you manage an Assembly, you can 
view a list of its parents or children that 
are currently being modified (checked 
out) in the Relatives Being Modified 
window. This is particularly helpful when 
you wish to release an Assembly, since all 
its documents must first be checked in.



Show Parents Displays the parents of a document in a 
separate window. You can then select the 
parents that you wish to check out as 
well.

When you check out a Part that is a child 
of a few different Assemblies, the Show 
Parent window displays the parents of the 
selected document and their revision 
status. You can then choose the 
Assemblies that you wish to check out 
together with the Part.

Switch to Latest 
Revision

Enables you to check out the latest 
revision of a document.

When you check out a Part that has 
numerous revisions, the Switch to 
Latest Revision option automatically 
checks out the most recent revision.

Replace Revision Enables you to choose a different revision 
of a document and perform a life cycle 
operation on it. This option also enables 
you to link the latest revision of the 
subassemblies to the Assembly being 
checked out. 

When you check out a Part that has three 
revisions, you can replace the displayed 
revision with a different one. 

Also, when you check out an Assembly, 
you can link it to the latest public revision 
of each of its subassemblies.

 

Propagate Operation

Performs the same life cycle operation on the Assembly and all its children.

1.  In any lifecycle window, right-click an Assembly and select Propagate Operation.

The icons of all the children change to reflect the revision operation to be performed.

2.  Complete the fields in the revision window (optional).

3.  Click Apply to perform the operation and remain in the view, or click OK to perform the 

operation and exit the view.

Relatives Being Modified

Displays the parents or children of a document that are currently Checked Out.

1.  From the Check Out/New Release dialog box, right-click a document (not its icon) and select 

Relatives Being Modified.

The relatives (parents or children) that are currently in the Checked Out state are displayed: 

The  icon represents a parent. 



The  icon represents a child.

Show Parents 

Displays the parents of a document in a separate window. You can then select the parents 
that you wish to check out as well.

1.  From any Check Out/New Release dialog box, right-click on a document (not its 

icon) and select Show Parents. 

Note that using the Shift Key lets you select multiple parents.

The Select Parents dialog box displays the parents of the selected document.

2.  To check out the parents, select the parents in the Select Parents dialog box.

3.  Click OK.

The parents are added to the list in the Check Out dialog box and will be checked 

out together with the source document.

Switch to Latest Revision  

Checks out the latest revision of a document.

1.  In the Check Out/New Release dialog box, select Switch to the Latest Revision.

A dialog box opens displaying the newly created revision.

 

 

 



 Replace Revision 

Enables you to choose a different revision of a document and perform a life cycle operation on it. 
Enables you to link the latest revision of the subassemblies to the Assembly being checked out. 

A document can have several revisions as it is checked in and checked out of the vault. If you are 
currently performing a life cycle operation, such as Check Out, on one of the revisions, you can check 
out a different revision of the document in its place.

During the development of an Assembly, its children may undergo several revisions. When you check 
out the Assembly, you can check out the latest revision of its children.

The Replace Revision option enables you to replace the following:

 

●     Replace the document selected for the Check Out/New Release operation, using the Replace 

Revision/Select command. For example, if you selected to check out the Part phone b.1, and then 

choose Replace Revision/Select, you can check out a different revision of the Part, such as b.2 or 

b.3.

●     Replace the children of the Assembly being checked out, using the Replace Revision/Revert to 

Last option. For example, if you selected to check out the Stump Preacher Guitar Assembly, and 

then choose Replace Revision/Revert to Last, all the children of the Assembly switch to the last 

public revision. The newly created revision of the Assembly will be linked to the last public revision 

of the children. This option is particularly helpful when you wish to work with the latest revision of 

all the children of an Assembly.



 
1.  From the Check Out/New Release dialog box, right-click on a document (not its icon) to display 

a dropdown menu and choose Replace Revision.

2.  To replace the document selected for the current Check Out/New Release operation: Choose 

Select to display a list of revisions. 

3.  Choose a revision and click OK.

In the Check Out window, the selected revision will replace the original revision.

or

Choose Revert to Last to check out the last public revision of the children of the Assembly 

currently being checked out. The newly created revision of the Assembly will be linked to the 

latest public revision of all its children.

 



Managing Drawings
SMARTEAM provides powerful tools to assist you in creating, saving and managing your Drawings. 

When you save the Drawing into the SMARTEAM database, a general link is automatically created between the 
Drawing and the Part/Product. This enables you to manage the Drawing together with the Part/Product as you 
create revisions.
In this manner, the status of the Drawing remains parallel with the status of the document on which it was 
based and SMARTEAM protects the integrity of the Drawing. 

This section contains the following tasks:

 

Saving a Drawing
Managing the Revisions of a Drawing

Document Associations and Dependencies
Designing a Title Block

Displaying a CATIA Part SMARTEAM Attribute in a Title Block
Designing the Revision Block

Displaying a CATIA Drawing SMARTEAM Attribute in a Title Block
Creating a Drawing Document from a Template

 



Saving a Drawing

When you save the Drawing, a general link is created between the Drawing and the Part/Assembly on which 
it was based: 

1.  From the SMARTEAM menu, choose Save (or Save As ).

A CATIA Drawing Profile Card is displayed.

2.  Fill in the fields in the Profile Card.

3.  Click OK .

The Drawing is saved to the SMARTEAM database, and a general link is created linking the Drawing to 

the Part/Assembly on which it was based.

In this way, SMARTEAM reflects the nature of the Drawing. As you manage the revisions of the 

Part/Assembly, you can manage the revisions of the Drawing in parallel.



See Saving a Part for the First Time for detailed instructions on using Save or Saving a Part After 

Modifications for detailed instructions on using Save As . 

Document Content Exposure 

When you save CATDrawing documents, the associated sheets are by default exposed in the database:

However, you can expose only the documents and their links as shown below:

Only the administrator can make the necessary modifications via the 
smarteam.std.legacyPreferences.config.xml file. For more information, refer to the SMARTEAM 
documentation.



Managing the Revisions of a Drawing

SMARTEAM manages the special relationship between a Drawing and the Part/Assembly on which it was 
based. When you create a Drawing by inserting a Part/Assembly and you then save it using SMARTEAM-
>Save, a link is created between these two documents in SMARTEAM. These linked documents are called 
associated objects . 

When managing drawings, SMARTEAM lets you expose two types of links:

●     CATIA Downstream Application

●     CATIA Downstream Application-Reverse

As you create revisions, you can view and manage these associated objects using Associated Objects-
>CATIA Links. This command provides options corresponding to the different possible links.

In addition, SMARTEAM color indicates each of the associated objects, so that you can clearly identify a 
document's links and reverse links.

●     Links are displayed in red (default color).

●     Reverse links are displayed in  blue (default color).

The default color settings can be changed, as explained in Customizing color settings for associated objects.

Working with Links and Reverse Links 

Each time you perform a life cycle operation on a document, you can view its associated objects, meaning its 
links and reverse links. You can then manage the revisions of these associated objects by checking the 
associated objects in or out of the vault or copying their files to your desktop.

When you check out (or check in) a Drawing, its associated document (the Part/Assembly) is automatically 
checked out together with the Drawing.

If the administrator sets the default option to Copy File, then the links will be copied to the desktop, not 
checked out.



 

Viewing Associated Objects 

You can view the links of a document and choose a lifecycle operation for each associated document. If you 
do not view the links of a Drawing, the associated documents will automatically be checked out/in together 
with the Drawing (if that is the default setting). 

You can view the reverse links of a document and choose a lifecycle operation for them. If you do not view 
the reverse links of a document, then no lifecycle operation is performed on them. 

For example: A Stump Preacher Explode A4 Drawing was created based on a Stump Preacher Guitar 
Assembly . When you check out the Stump Preacher Explode A4 Drawing , its associated document, the 
Stump Preacher Guitar Assembly will be checked out with it (unless you display the linked document and 
choose a different lifecycle operation). When you check out the Stump Preacher Guitar Assembly , you may 
view and check out its reverse link, the Stump Preacher Explode A4 Drawing .

1.  From any life cycle window (such as Check In or Check Out), right-click a drawing document and 

select Associated Objects->CATIA Links to display the list of view options which are as follows:

2.  For example, select CATIA Downstream Application.

The product to which our drawing is linked is now displayed in red:



 
To manage associated objects: 

When the associated objects are displayed in the tree browser, you can manage them in the same manner 
as any Assembly and its children. You can:

●     copy the associated objects to the desktop, as shown above.

●     Check Out / Check In all the associated objects by choosing the Propagate Operation option.

●     handle each associated object individually. For each associated object, you can: 

❍     Check out or check in the document.

❍     Copy its file to the desktop. The state of the document is not changed.

❍     Choose No Operation for the document.

 

Life cycle operations are always performed on linked documents, even if you do not display them. This is not 
the case for reverse linked documents: You must choose to display reverse links in order to perform lifecycle 
operations on them.

Customizing Color Settings for Associated Objects 

SMARTEAM color indicates each of the associated objects, so that you can clearly view a document's links 
and reverse links.

●     Links are displayed in red.

●     Reverse links are displayed in blue.

To change these default settings:

1.  In any life cycle window, right-click to display a dropdown menu and choose Tree Properties.

2.  Click the Visual Setting tab to display the following dialog box: 



3.  Click the button to the right of the color that you wish to change. 

A color selection dialog box is displayed, as shown below: 



4.  Choose a new color.

5.  Click OK to confirm and close the dialog box.

6.  In the Tree Properties dialog box, click OK.



Document Associations and Links 

This page deals with the following subjects:

●     Links/Reverse Links

●     Revising Associated Objects 

●     Drawing & Link Exposure in Expose Mode

Links/Reverse Links

CATIA V5 enables you to create a Drawing based on a Part or a Product.  When you save the Drawing into the SMARTEAM database, a 
general link is automatically created between the Drawing and the Part/Product on which it was based. This enables you to manage the 
Drawing together with the Part/Product as you create revisions. 

The Drawing and its associated Part/Product are called Associated Objects. SMARTEAM creates the following relationship between the two 
documents:

●     Link: The Part/Product is linked to the Drawing.

●     Reverse Link: The Drawing is a reverse link of the Part/Product.

For example: You create a Drawing named Circuit Drawing based on a Part named Metallic Circuit. SMARTEAM creates a link between these 
two documents as follows:

●     The Metallic Circuit Part is a link of the Circuit Drawing(since the Drawing is dependent on the Part).

●     The Circuit Drawing is a Reverse link of the Metallic Circuit Part.

For more information about CATIA links, refer to Enriched Decision Support with All V5 Links.

Revising Associated Objects
As you revise your documents, SMARTEAM protects the relationship between associated objects: 
A Drawing and its associated Part/Product.

When you perform a lifecycle operation on a document (such as Check In or Check Out), you can display and manage the document's 
associated objects. Each associated object is color-coded for easy recognition.

To display associated objects:

1.  From any life cycle window, right-click to display a dropdown menu.

2.  Point to Associated Objects and choose the type of object you wish to display. 

Each associated object is color-coded as follows:

❍     Links are displayed in red .

❍     Reverse links are displayed in blue .

SMARTEAM protects the relationship between these associated objects as you make revisions:

●     Each time you check out a Drawing from a vault in order to revise it, its dependency (Part/Product) is automatically checked out together 

with it.

●     When you check out a Part/Product from a vault in order to revise it, you have the option of viewing and checking out its associated 

drawing.



Before you can work with associated documents (dependencies, reverse dependencies), an administrator must enable them. The 
administrator can define dependencies based on a customized class structure.

Drawing & Link Exposure in Expose Mode

You can customize the CATIA-SMARTEAM integration product to expose the drawing sheets ("expose mode"). 

In the case of the expose mode, you may choose to expose only the links between the sheets to the external documents and not to expose 
the links of the drawing document to the external documents. 
Here are the options required to customize the drawing link exposition.

●     Links exposed from both Drawing and sheet to the referenced documents

In this case, the sheet will expose its direct dependency links and the drawing will expose all the sheet dependency links. This is the 
default behavior. 
In case of error, the user should check that the variable CATIA_TEAM_PDM_DRLINK is not set.

●     Links exposed only from the Drawing to the referenced documents

In this case, the sheet does not expose any dependency links. 
The variable CATIA_TEAM_PDM_DRLINK should be set to DrOnly 

●     Links exposed only from the Sheet to the referenced documents

In this case, the drawing does not expose any dependency links. The variable CATIA_TEAM_PDM_DRLINK should be set to ShOnly 



Designing a Title Block 

The scenario described below shows you how to design a title block using properties defined in the database. 

This task is divided into the following stages:

●     Creating the Title Block on a New Drawing 

●     Defining the CATIA Formula Property for Each Attribute from the Database 

●     Creating the Text Attributes in the Title Block 

●     Saving the Document in SMARTEAM 

●     Updating a CATIA Property in SMARTEAM   

The properties used for these tasks have already been mapped by the administrator between CATIA and 
SMARTEAM (see Defining Property Mapping for the Title Block). 

Creating the Title Block on a New Drawing 

1.  Create a new CATDrawing document.

2.  In the New Drawing dialog box that appears, make sure the default values (ISO in the Standard field 

and A0ISO in the Format field) are specified and click OK.

3.  Design your title block as shown below: 

For more information about the title block, see "Sheet" in the CATIA - Generative Drafting User's 

Guide. 



Defining the CATIA Formula Property for Each Attribute 
from the Database 

1.  In the CATIA session, click on the Formula  icon.

The Formulas: Drawing dialog box appears.

2.  Select String in the New Parameter of type list.

3.  Click the New parameter of type button.

4.  In the field on the left specifying the name of the current parameter, change the name to Type.

Remember that the mapping property name has already been defined in Defining Property Mapping.

5.  In the field on the right specifying the value of the current parameter, enter <Type>.

Remember that this reflects the value of the attribute in the database. 

6.  Click on the Apply button.

7.  Repeat steps 2 through 6 for all mapped properties. 

Here is a list of the properties defined in the title block and that are still to be mapped: 

Property Name in CATIA 
Property Value Property Type

Type <Type> String

Designer <Designer> String

Date <Date> String

Drawing_Title <Drawing Title> String

8.  Locate the Scale property i.e. Sheet1\ViewMakeUp.1\Scale and rename it to Scale as shown below: 



9.  Click OK.

Creating the Text Attributes in the Title Block 

Here is what you will obtain at the end of this task:  

 

For more information see "Adding Attribute Link to Text" in the CATIA - Interactive Drafting User's Guide. 



1.  Select Insert->Annotations->Texts->Text .

2.  Click inside the drawing to indicate where you want to display the drawing type. (If necessary, refer 

to the title block design.)

A text editor window appears.

3.  Enter Type in this window: 

4.  Right-click on the appropriate location in the title block and select Attribute Links.

5.  In the specification tree of the drawing, click on the Drawing.

The Attribute Link dialog box appears.

6.  Select Type in the attribute list: 

7.  Click OK.

The value of the property i.e. <Type> is now displayed in the Text Editor dialog box: 



8.  Click OK.

9.  Repeat steps 1 through 8 for all texts.

Saving the Document in SMARTEAM 

1.  Click the Save icon  or select SMARTEAM->Save.

This declares the document and saves its properties in the database. In the SMARTEAM profile card 

corresponding to the document, you can see that the fields are completed:



Updating a CATIA Property in SMARTEAM 

1.  Open the SMARTEAM: Documents dialog box.

2.  Right-click on the document and select Update.

The profile card is now ready to be changed.

3.  Modify the values of Drawing Title and Type.

4.  Click OK.

The property has been modified in the SMARTEAM database.

5.  Back in CATIA, select SMARTEAM->Properties->Load from Database.

Still in CATIA, you can now see the new values attached to the Drawing title block.



 



Displaying a CATIA Part SMARTEAM Attribute in a Title Block
The task described below shows how to ensure that the title block is automatically updated to display the part number of the 
associated Part. 

A drawing title block contains information from various sources. It could look something like this, for example: 

●     The contents of the Designer field is a SMARTEAM property. Its source is a field in the CATIA Product profile card. It 
corresponds to the Created by... field.

●     The contents of the Part Number field is defined in CATIA. Property mapping enables this information to be available in the 
CATIA Part profile card as well.

●     The contents of the Material field is also defined in CATIA.

1.  Create a Part in a CATIA session.

2.  Use Edit->Properties to define its part number.

3.  Save the Part in the database.

Default property mapping ensures that the Part Number field is automatically completed in the database.

4.  Create a drawing of the same Part.

5.  Design the title block creating a text with the Part Number information (see Designing the Title Block for more 

information).

6.  Save the Drawing document in the database.

7.  Use SMARTEAM->Properties->Map a Text Value... to link this text to the Part Number property of the Drawing 

document (see Mapping a Text Value for more information).

8.  Launch the AttributesOfLinked.bs script (see Using SMARTEAM Scripts in a CATIA Session for more information).

The title block is updated and now displays the Part Number of the part.

Launching AttributesOfLinked.bs



When you launch the AttributesOfLinked.bs script, it: 

●     analyzes the logical links to other associated documents (i.e. dependencies)

●     retrieves the value of the Part Number attribute for each associated document

●     generates a character string containing a list of all values retrieved (one per line)

●     stores the list of Part Numbers in the current document

●     repeats this procedure on all the children i.e. sheets of the Drawing document.

Customizing the AttributesOfLinked.bs Script 

The AttributesOfLinked.bs script is designed to retrieve Part Number information from the linked documents. However, if you 
wish, you can: 

●     modify the property to be retrieved by editing the script to change the value of the LinkedAttributeName variable

●     modify the property where the retrieved information is to be stored by editing the script to change the value of the 
MainAttributeName variable

●     retrieve more than one property by editing the script to duplicate the section starting with the following comment line: 

●     Display information about the children.



Designing the Revision Block 

The scenario described below shows you how to design a revision block using properties defined in the database. 

This task is divided into the following stages:

●     Creating the Revision Block on a New Drawing 

●     Defining the CATIA Formula Property for Each Attribute from the Database 

●     Creating the Text Attributes in the Revision Block 

●     Associating the RevisionBlock.bs Script with a SMARTEAM Event 

The properties used for these tasks have already been mapped by the administrator between CATIA and SMARTEAM (see Defining Property 
Mapping for the Revision Block). 

Creating the Revision Block on a New Drawing 

1.  Create a new CATDrawing document.

2.  In the New Drawing dialog box that appears, make sure the default values (ISO in the Standard field and A0ISO in the Format field) 

are specified and click OK.

3.  Design your revision block as shown below: 

For more information about the revision block, see the CATIA - Generative Drafting User's Guide. 



1.  In the CATIA session, click on the Formula  icon.

The Formulas: Drawing dialog box appears.

2.  Select String in the New Parameter of type list.

3.  Select the New parameter of type button.

You must now use the name defined in your mapping property. In our example we will use Revision, ApprovalDate, etc.

4.  For example, change the name to Revision1 in the field on the bottom left specifying the name of the current parameter. The numbers 

used must reflect the order in which the revisions were made e.g. : Revision1 = e, Revision2 = d, Revision3 = c, and so on.

5.  In the field on the right specifying the value of the current parameter, enter the "-" symbol. 

6.  Click on the Apply button.

7.  Repeat steps 2 through 6 as often as required for all mapped properties. 

Here is a list of the properties defined in the revision block and that are still to be mapped: 

Property Name in CATIA 
Property Value Property Type

Revision2,

Revision3,

Revision4

- String

Comment1,

Comment2,

Comment3,

Comment4

- String

ApprovalDate1, ApprovalDate2, ApprovalDate3, 

ApprovalDate4,
- String

Authorized1,

Authorized2,

Authorized3,

Authorized4

- String

 

Defining the CATIA Formula Property for Each Attribute from the 
Database 



8.  Click OK.

Creating the Text Attributes in the Revision Block 
Here is what you will obtain at the end of this task: 

 

For more information see "Adding Attribute Links to Text" in the CATIA - Interactive Drafting User's Guide. 



1.  Select Insert->Annotations->Texts->Text.

2.  Click inside the drawing to indicate where you want to display the drawing type. (If necessary, refer to the revision block design.)

A text editor window appears.

3.  Enter Rev: in this window: 

4.  Right-click on the appropriate location in the revision block and select Attribute Links in the contextual menu.

5.  In the specification tree of the drawing, click on the Drawing.

The Attribute Link dialog box appears.

6.  Select Revision1 in the attribute list: 

7.  Click OK.

The value of the property i.e. the "-" symbol is now displayed in the Text Editor dialog box: 

8.  Click OK.

9.  Repeat steps 1 through 8 for all the cells.

Associating the RevisionBlock.bs Script with a SMARTEAM Event 

This step has to be done using the SmartBasic Script Maintenance utility. 



1.  Run the SmartBasic Script Maintenance utility. 

2.  Enter your login and password with administrative privileges. (Note that the SmartBasic Script Maintenance utility runs 

automatically on the default database.) If you want to modify a database other than the default one, you must first set it as the 

default database (using the File->Switch to Database menu item in the SMARTEAM application). 

3.  In the class tree, select the CATIA Drawing class then, on the right-hand side, double-click on the cell at the intersection of the Life 

Cycle Stage 2 row and the Before column.

The Script Browser dialog box is now displayed. 

4.  Select RevisionBlock.bs.

5.  Click on the Compile button. 

6.  Click on the OK button. 

7.  Back in the Script Maintenance dialog box, select File->Exit. 



Displaying a CATIA Drawing SMARTEAM Attribute in a 
Title Block

This task enables the administrator to quickly and easily map a drawing text with any of the CATIA Drawing attributes in 
the SMARTEAM database.
There is no need to perform the two manual operations that consist in: 

●     creating a property f(x) in the drawing then linking it with the text

●     going either to the Property Management or Integration Tool Setup utilities.

1.  In the CATIA session, open a drawing document that has already been saved in the SMARTEAM database.

2.  Select a text of the drawing.

3.  Select SMARTEAM->Properties->Map a Text Value...

The Map a Text Value dialog box appears. 

4.  In this dialog box, select an attribute of the document's class. 

5.  At the bottom of the dialog box, define the update direction by selecting the Enable updating of property 

option: 

The Map a Text Value dialog box shows the current mapping for the selected text. In other words, if you have 

already used the Map a Text Value... command for the same text, the attribute name and the update 

direction(s) you originally selected are kept.

6.  Click OK.

A CATIA property is created inside the drawing as shown in the Formulas dialog box, for example: 



7.  Selecting SMARTEAM->Tools->Property Management, you can see that the newly mapped property looks like 

this: 

and the newly mapped attribute like this: 



From now on, whenever you reopen the document the mapped attribute will appear in the title block.

You can also force the update by selecting SMARTEAM->Properties->Load from Database .



Creating a Drawing Document from a Template 

This task shows you how to draw the views of a CATPart document.

1.  Run a query to access your CATPart document.

2.  Select SMARTEAM->New From...

The New From...Documents dialog box is displayed.

3.  In the displayed tree, double-click on the folder of interest or select the + sign to open the folder.

4.  Select an existing drawing.

Each drawing document is represented in the database as a tree. The root object of the tree represents the drawing itself then each sheet 

of the drawing is represented as a child of the drawing.

If you want to verify the document before opening it, select the Viewer tab to preview it.

4.  Click OK.

A new drawing is created starting from the selected template. 

5.  Insert in your drawing the projection views of the CATPart document and insert the dimensions. 

For more information about projections and dimensions, see the CATIA - Generative Drafting User's Guide.



Managing the Document Lifecycle   

SMARTEAM enables you to maintain and manage any information related to a document throughout its life cycle. By mirroring 
the physical process of document management, SMARTEAM uses vaults, check-in, check-out, and approval functions to 
manage the life cycle of your Product, Part or Drawing. It creates new versions of a document and protects it from 
unauthorized modifications.

All life cycle operations on CATIA documents must be performed in the CATIA session. Operations such as Check-Out, Check-In 
etc. must be explicitly done in CATIA to guarantee data consistency.

Lifecycle Menu Commands

The Lifecycle menu contains the life cycle commands for managing a Part, Product and Drawing as new revisions are 
created. 

1.  From the Life Cycle menu, choose the appropriate operation in accordance with its status in the product life cycle. 

All lifecycle operations are controlled and managed by SMARTEAM, by enabling and disabling different life cycle 

options in the Life Cycle menu. This provides for a logical flow of a Part, Product or Drawing through its life cycle. 

When a new document is first saved in the SMARTEAM database, it has the New status. The document is not placed 

in a vault. 

When you perform the Check In operation on the document, it is placed in a vault and cannot be launched into CATIA 

V5 until it is checked out of the vault.

 
Contextual Commands

From V5R15 onward, you can access the following Lifecycle commands from contextual menus:

●     Check Out

●     New Release

●     Undo Check Out

Whatever the operation you choose, it applies to the document you have selected from the specification tree (or from the 
geometry area).

Just as a reminder, the application distinguishes selected documents from active documents.

●     Selected documents: To select a document, you just need to click it. Once selected, it appears as highlighted.

●     Active documents: double-clicking a document, activates that document. In concrete terms, this sets up a working 
context. For example, if you double-click a Part, CATIA opens the Part Design workbench for you to access all different 
capabilities for editing that part.



-> Selected document

-> Active document

To use Save, Check In and Release via contextual commands, you still need to activate the documents on which you want 
to perform these operations.

Life Cycle Operations

The table below lists the different life cycle operations, the status of the document resulting from each operation, and a 
description of each status.

Life Cycle Command Selected Resulting Status Description

Click Check In to to check a new 
document into the vault or to place a 
document that is being modified back 
in the vault.

Checked In The document is placed in the vault, and it cannot be 
launched into CATIA V5. In order to launch it into CATIA V5, 
the document must be checked out of the vault. You can 
copy the file to your desktop in order to view (but not 
modify) the document in CATIA V5.

Click Check Out to check out a 
document from the vault. 

or

Click New Release to make a new copy 
of a Released document that was placed 
in the Released vault. The resulting 
document is a new revision of the source 
document.

Being Modified This is a temporary state assigned to a document that has 
been checked out. The document can be launched into 
CATIA V5 in order to modify it. No other user can currently 
modify it, but other users can view it or copy the file to their 
desktop. After the document is checked back in or released, 
the status is replaced by Checked In or Released.

Click Release to transfer a document to 
the Released status.

Released The document is saved in the vault of released documents.

Click Undo Check Out to cancel the 
check-out of a document from the vault.

Checked In Any changes made following the check-out are lost. The new 
revision is deleted. The document status reverts to Checked 
In status.



Analyzing the Impacts of a Change

The Impact Analysis function displays all the documents pointing onto a selected object. This tool allows you to evaluate the 
impacts brought by the modifications made to the current object and therefore helps you choose the solution to implement with the 
least modification cost. 

We recommend you use this tool prior to checking out and modifying documents.

This scenario assumes your CATIA session contains a CATProduct document that comprises a CATProduct document including a 
CATPart document. A CATDrawing document was created from the assembly, it is thus also linked to that CATProduct document.

1.  Select Product2 as the document which related documents you want to see.

2.  Click .

Impact Analysis is also available from the SmarTeam menu, contextual menus and in the Desk window.

The Impact Analysis dialog box that appears displays all documents related to the selected product.

Note that you can resize it to improve the view. 

Three options let you choose the way in which the information is displayed.

❍     Latest Revisions only

❍     Grouped Cross Revisions

❍     Cross Revisions

Whatever option you select, the way objects are displayed in the Impact Analysis dialog box depends 
on the way the SMARTEAM tree properties has been customized. For more information, see 
Customizing SMARTEAM Document Display Information.

Latest Revisions only

3.  From the drop-down menu in the lower part of the dialog box, set Latest Revisions only.

This option displays only the latest revisions of the documents that will be impacted by the current revision of the selected 

object.

4.  Click the + sign in front of the Downstream Application Link (Reverse) category.

This category lists the latest revisions of the drawing documents pointing onto the assembly you have selected.

The Parent category is empty since CATPRD-0058 a.0 Product1_1408 CATIA Product is referenced by no document.



By applying Impact Analysis onto the sub-assembly, you could see in the Parent category that CATPRD-0058 a.0 

Product1_1408 CATIA Product is its parent. You would obtain this view:



Grouped Cross Revisions

3.  Still using Product2 as the selected document you are analyzing, from the drop-down menu, set Grouped Cross 

Revisions. 

4.  Click the + sign in front of the Downstream Application Link (Reverse) category.

Grouped Cross Revisions displays also the impacted documents as well as all their revisions. 

You obtain this view:



By applying Impact Analysis onto the sub-assembly, you could see in the Downstream Application Link (Reverse) 

category that an earlier version exists for its parent CATPRD-0058 a.0 Product1_1408 CATIA Product. You would obtain this 

view:



Cross Revisions

3.  Still using Product2 as the selected document you are analyzing, set Cross Revisions.

This option displays the same contents as when using Grouped Cross Revisions, but the presentation of impacted 

documents is slightly different. There is no sub-category within each category. In our example, the display shows that the 

latest revision of the drawing as well as the previous one would be affected by changes to the assembly.



4.  Click Close when done.

Locate Active Document
In case you want to know more information about a document displayed in the Impact Analysis tree, you can:

●     right-click the document and select Locate Active Document

Or

●     directly double-click the document

This opens a SMARTEAM dialog box with detailed information on the document.



Administration Tasks
This section assists administrators in configuring their SMARTEAM CATIA Integration environments to fit their 
specific needs. The following topics are discussed:

Mandatory Settings
Customizing

CATIA Workbenches Integration
Defining Property Mapping

Recommendations
Importing CATIA Data Inside SMARTEAM

SMARTEAM Upgrade/Migration



Mandatory Settings

This section provides information about two major operations a system administrator should perform prior to 
using SMARTEAM CATIA Integration. Both operations deal with the way of accessing documents in CATIA.

Document Localization Strategies
Enabling the Display of the SMARTEAM File->Open User Interface

 

 



Document Localization Strategies

When working with documents from the SMARTEAM database, the documents are first extracted from 
the vault and copied to a local folder then loaded in the CATIA session. 

There are two main folders: 

●     the work directory containing all files that are checked out or copied out of the vault

●     the view directory containing all files that are just viewed.

The consequence of this behavior is that each time a document is linked to another document, the linked 
document should be searched for in the folder containing the pointing document.

This behavior can easily be set in CATIA: 

1.  Select Tools->Options....

2.  In the General category, click the Document tab.

3.  In the Linked Document Localization section, locate and select the SMARTEAM folder of the 

link and folder of the pointing document strategy. Ensure that SMARTEAM is the first item in the 

list and that Folder of Link is the second one.

4.  Use the Activate button to activate this strategy.

5.  Use the Up button to place this strategy at the top of the list.

6.  Ensure that the SMARTEAM Document environment is allowed and is in the current state in the 

Document Environment selection list.



For further information about linked document localization strategies, refer to "Document" in the CATIA - 
Infrastructure User's Guide Version 5. 

Note

When extracting documents from the vault, you can also specify different Work directories for each 
extracted file (by changing the default directory in the life-cycle window). In this specific case, the 
Folder of the pointing document strategy will not be able to recover the linked documents. Another 
strategy, called SMARTEAM Database has to be used. This strategy will ask the SMARTEAM database 
where the linked document has been copied.



Enabling the Display of the SMARTEAM File->Open 
User Interface

 

This task shows you how to enable the display of the SMARTEAM File->Open user interface.

1.  Launch Tools->Options.

2.  Select the General->Document tab.

3.  From the Document environments display list: 

❍     set SMARTEAM as the allowed and current environment

All information related to customizing the session is also described in the CATIA/ENOVIA DMU/DELMIA 
Infrastructure documentation.

Document Environments

There are two possible document environments that allow you to retrieve the document form SMARTEAM during a 
CATIA operation (File->Open, Replace Component etc.).

●     SMARTEAM Document Environment allows you to perform a simple query, or navigate thru a project structure 
or define a precise query to retrieve the document.

●     SMARTEAM Query Document Environment allows you to use the Find user interface to retrieve the document 
(thru predefined queries or precise queries). Additionally, ensure that to be able to use the Find capabilities, the 
Folder Document Environment must be set to Allowed.



Customizing
This section discusses different ways of customizing your SMARTEAM CATIA Integration session.

Customizing SMARTEAM Document Display Information
Configuring the Links Display

System Variables for SMARTEAM CATIA Integration
SMARTEAM CATIA Integration Settings

Customizing Bulk Loading
Customizing Design Copy

Using SMARTEAM Scripts in a CATIA Session
Removing Profile Cards Display
Simplifying Lifecycle Operations



Customizing SMARTEAM Document Display Information 
 

The SMARTEAM document display information can be customized in SMARTEAM by means of the Tree Properties contextual 
command. 

1.  Select your document in SMARTEAM.

2.  Right-click Tree Properties.

The Tree Properties dialog box that appears contains various tab pages to customize the appearance and tree 

content. The Display Attributes tab enables you to specify which attributes will comprise the name of the objects as 

they are displayed in the tree.

Check out, check out on the fly operation and Not Saved warning windows now display SMARTEAM information as set 

in the Tree Properties dialog box.

In the following example, the following attributes have been defined:

❍     ID

❍     Revision

❍     Description

❍     File Type





Configuring the Links Display 
 

This page shows you how to configure the links of the documents in SMARTEAM by means of the 
Tree Properties contextual command. 

1.  Select your document in SMARTEAM.

2.  Right-click Tree Properties.

3.  Click the Visual Setting tab.

This tab enables you to adjust the background color, line color and size, font type and size as 

well as the zoom factor of the displayed tree.



4.  Click on Links.

This dialog box appears.

5.  You just need to check the classes you wish to display.

6.  Click OK to validate and close the dialog box.



System Variables for SMARTEAM CATIA Integration
 

This page shows you how to set the appropriate variables:

1.  Select Start->Settings-> Control Panel.

2.  From the Control Panel dialog box , double-click System.

3.  From the System Properties dialog box that appears, double-click System.

4.  Click the Advanced tab.

5.  Click the Environment Variables... button.

The Environment Variables dialog box is displayed.

The following variables can be set in the Environment Variables of a user's workstation

❍     CATIA_TEAM_PDM_AUTO_CONNECT=1 
Allows automatic login to SMARTEAM when CATIA is launched. 

❍     CNEXTSPLASHSCREEN = NO
This system variable is to be used if you set CATIA_TEAM_PDM_AUTO_CONNECT. 
It prevents CATIA splash screen from displaying while you are connecting

to SMARTEAM.
6.  CATIA_TEAM_PDM_NOCOOTF=1 
Disables check out on the fly operations. It is recommended not to set this variable. 
7.  CATIA_TEAM_PDM_DRLINK = DrOnly/ShOnly 



Specifies how links are exposed in SMARTEAM. 
If you do not use this variable, this is the default display:

❍     DrOnly: The links are exposed only at the document (CATIA Drawing) level. 

❍     ShOnly: The links are only at the sheet level 

For more information, refer to Document Associations and Dependencies.
8.  CATIA_TEAM_PDM_SPCLASS = NO 
The specific class mode is not used (specific class for the internal component or sheet objects). 



SMARTEAM CATIA Integration Settings
 

This page provides the different settings available for working with SMARTEAM CATIA Integration product.

●     Out Of Process
Sets CATIA in a process separate from SMARTEAM. Must be set to YES.
Values: YES/NO

●     Refresh Screen
If set to FALSE, the profile card of the document will not be displayed after:

❍     the first SMARTEAM Save operation performed from CATIA 

❍     Check in of Release operation

Values: TRUE/FALSE

●     Add To Desktop
Specifies whether CATIA documents are placed on the Project Desktop after a Save operation. 
Values: YES/NO

●     Link To Main Class
Specifies whether CATIA documents are linked to the Project after a Save operation. 
Values: YES/NO

●     Batch Mode
Saves the components of an assembly without displaying each profile card.
Values: TRUE/FALSE

●     Expose Mode 
Exposes CATIA internal objects when saving an assembly or drawing inside the system. If set to YES, internal components and 
drawing sheets are saved in SMARTEAM as distinct objects. 
Values: YES/NO



Customizing Bulk Loading
 

The Bulk Loading command enables massive imports of documents into SMARTEAM. When the Batch Mode Save option is 
activated, no profile card is displayed to the user and the default class is used to save the data.

In order to set the classes to be used during the Bulk Loading operation, you should add/modify dedicated SMARTEAM options 
using the SMARTEAM System Configurator tool.

The syntax of the key is Bulk_Loading_CATIAFileType. The value of the key is the class to use for Bulk Loading in batch mode 
save. Ex:Bulk_Loading_CATPart="Standard CATIA Part" entry in SmTeam32 will set the default class for CATPart documents to 
Standard CATIA Part class.

To activate this development, the following environment variable: CATIA_TEAM_PDM_FORCED_CLASS_NAMES_BULK_LOADING 
should be set to 1.

This functionality is useful when saving a large amount of documents of one given file type. When saving lots of documents of 
various CATIA file types, the rule to save the objects will follow the SmTeam32 information. It is up to the user to check that the 
targetted class is consistent. When saving Drawing and a Part (Drawing->Part), the part may be saved to Standard CATIA Part. 
Thus, errors may appear in some cases.

For more information about Bulk Loading, refer to Importing CATIA Data Inside SMARTEAM.

SMARTEAM System Configurator 

In order to set the classes to be used during the Bulk Loading operation, you should add/modify dedicated SMARTEAM options 
using the SMARTEAM System Configurator tool and proceeding as follows:

1.  Prior to launching SMARTEAM System Configurator, ensure that Default Web Site is running.

2.  Now, launch SMARTEAM System Configurator.

3.  Enter Bulk in the Search field.

4.  Click Search.

Many items are found as displayed below: 



5.  Select one item from the list. For instance, CATIA_Bulk_Loading_CATPart.

6.  Set the appropriate value: for example, choose Domain from the Override Level combo box and enter Standard CATIA 

Part in the Value field.

7.  Click the Save Changes button to confirm the changes.

Once saved, the dialog box looks like this:

Note: the current Bulk Loading functionality does not allow you to select projects.



For more information about the SMARTEAM System Configurator, refer to the SMARTEAM documentation.



Customizing Design Copy

 This section describes the different ways of customizing the Design Copy command. The topics 
discussed are:

●     Design Copy Administrator Options

●     Displaying CATIA links

●     Reverse Links

Design Copy Administrator Options

The Design Copy Administrator Options enables you to customize the Design Copy window for the 
user. In addition, you can assign a script to run before the Design Copy window appears. 

1.  Customization of Design Copy is done through the Design Copy Administrator Options 

window. To display this window, click Administrator Options in the Design Copy Options 

window (for further details see Duplicating an Existing Document).

2.  In the Before DesignCopy script name field click Assign to enter a script.

This script will run before the Design Copy window appears.

3.  Click Add... to include a class to the Exclude classes list.



By default the added class is not checked. When checked the system disables the facility to 

allow the user to copy objects of a class. For example, if Standard CATIA Part is disabled 

(checked) then the user cannot create a new document based on Standard CATIA Part but 

only as is. 

❍     If it is checked in the Design Copy Administrator Option Exclude Classes List, then it is 
protected and not checked in the Design Copy window. You will not be able to change the 
status in the Design Copy window. 

❍     If it is not checked in the Design Copy Administrator Option Exclude Classes List, then it 
not checked in the Design Copy window. You can change the status to checked in the 
Design Copy window.

4.  Restart the Design Copy tool to apply the changes made to the Design Copy Administrator 

Options. 

Displaying CATIA links
When you launch the Design Copy, the Design Copy window displays all tree links, except for 

CATIA links. With CATIA links (both normal and reverse direction) only the CATIA links, which 

appear in the check out operation and where the Propagation Allowed check box is 

checked in the lifecycle rules setup, are displayed. 

For example, every product needs to have a drawing in the Design Copy. To do this a rule 

needs to be defined for the Check Out Operation in the Lifecycle Rules Setup for CATIA 

Downstream Application link, reverse direction. 

Note: If you have a rule but do not want it to be applied to the actual Check Out operation, 

then you must select No operation in the Destination Operation field of the SMARTEAM 

Lifecycle Rule Properties window.



Reverse Links
For reverse links the structure of the object, which appears as a reverse link, is not displayed 

in the Design Copy. 

It is highly recommended not to display the structure as it can bring additional objects and an 

unclear structure to the Design Copy window. If it is necessary to display the structure, then 

set the DesignCopy.ShowHierarchicalLinksOfReverseDependencies key to Yes in SMARTEAM's 

System Configuration Editor. 



Using SMARTEAM Scripts in a CATIA Session
You can already adapt SMARTEAM to your particular requirements by writing and delivering scripts that 
modify or replace existing functions or even create new ones. Typical uses would be to check data 
produced or generate data (for a BOM or an export operation for example).
Such scripts can be: 

●     attached to events in SMARTEAM and be triggered before, after or instead of the action concerned

●     placed in the Graphic User Interface (GUI):
❍     by default, in the Tools->User Defined Tools menu item

❍     anywhere in the GUI by means of the Menu Editor. 

You can also launch as many as ten SMARTEAM scripts from a CATIA session using the ten associated 
commands. There are already six sample scripts delivered in the form of ready-to-run samples (see the 
List of Sample Scripts below). These scripts as well as any others you decide to write must be assigned 
to one of the ten associated commands. You then only have to place the corresponding commands 
where it suits you best in the GUI. 

This task is made up of the following stages: 

●     Defining the SMARTEAM Scripts to be Accessed from the CATIA Session

●     Placing the Commands in the CATIA Graphic User Interface

●     List of Sample Scripts 

Defining the SMARTEAM Scripts to be Accessed from the 
CATIA Session 

1.  Run a CATIA session.

2.  Select Tools->Options....

The Options dialog box appears with the category tree in the left-hand column. 

3.  In the General category of the Options tree, select Compatibility.

4.  Click on the SMARTEAM Scripts tab.

 

Make sure you are connected to SMARTEAM before accessing the Options dialog box.

Otherwise, an error message will appear prompting you to do so.

 

5.  In the fields containing the command you want to use, open the combo box to display the list of 

scripts and select one of the scripts in the list to assign it to the command. In this way, you can 



associate one of ten scripts with each of the ten commands available: 

6.  Click OK to confirm.

Placing the Commands in the CATIA Graphic User 
Interface 

You must now decide where you want to put the SMARTEAM commands in the CATIA GUI. You can, for 
example, create a SMARTEAM toolbar containing the commands. To do this, do as follows: 

1.  Select Tools->Customize... or View->Toolbars->Customize...

The Customize dialog box appears. 

2.  Select the Toolbars tab: 



3.  Click on the New... button to create a new toolbar (see "Managing User-Defined Toolbars" in the 

CATIA - Infrastructure User's Guide).

4.  Click on the Commands tab and select the All Commands category on the left-hand side of the 

dialog box.

5.  From the Commands list, find the ten SMARTEAM commands:



6.   Drag and drop the command(s) onto the toolbar you just created.

For more information on toolbar customization, see "Customizing a Toolbar by Dragging and Dropping" 

in the CATIA - Infrastructure User's Guide. 

List of Sample Scripts 
●     About.bs

Provides information about the current database and current user.

●     AttributesOfLinked.bs
Retrieves attributes from a linked object (e.g. retrieves the part number of the documents displayed 
in the drawing sheets and updates the sheet profile card)

●     BottomUp.bs
Displays a bottom-up view of the selected object.

●     DisplayView.bs
Displays a stored view.

●     LocateInCATIA.bs
Highlights the document in the CATIA session, assuming that the object selected in the SMARTEAMs 
window is open in the CATIA session.

●     QuickFindCATIA.bs
Presents a quick find interface.

●     RevisionBlock.bs  
Inserts required information in a revision block in the drawing.



●     SmartBox.bs
Opens the SmartBox window.

●     StartProcess.bs
Initiates a new process and attaches the current item to it.



Removing Profile Cards Display

 The main function of Profile Cards being to describe the general properties of documents, most of the time end users do 
not need to display them when saving their documents for the first time. To make end users gain time, system 
administrators therefore can now prevent the application from displaying profile cards that appear during first save 
operations.

To ensure that profile cards are not displayed during save operations, proceed as follows:

1.  Launch SMARTEAM System Configurator.

To know how to use this tool, refer to the SMARTEAM documentation.

2.  Search for CATIA application.

3.  Set CATIA.Refresh_Screen to FALSE. 

4.  Click the Save Changes button to confirm the changes.

Once saved, the dialog box looks like this:



Simplifying Lifecycle Operations

 To make end users gain time, system administrators can now prevent the application from displaying all 
windows that appear during lifecycle operations (Check In, Check Out, Release, New Release, Undo 
Check Out) performed in CATIA or SMARTEAM. This capability is available from SMARTEAM V5R14 SP5 
onward.

For example, suppose you need to create a new release for CATPRD-0042. As you can see, this implies 

a certain number of interactions that would result in a tedious operation: 

To eliminate the display of the different lifecycle windows, proceed as follows:

1.  Click the  icon to switch to SMARTEAM if not already done.

2.  Select Tools-> Administrator Options...

3.  From the Administrator Options dialog box that appears, click Life Cycle Options...



4.  From the Life Cycle Options dialog box now displayed, select No Dialog from the drop-down list 

as the  Life Cycle Dialog Type option.

5.  Click OK to validate.

It is not necessary to restart SMARTEAM services, nor to reconnect to SMARTEAM to take this 

change into consideration.



CATIA Workbenches Integration

This section provides the methodology for the management of data specific to a few CATIA workbenches. The 
steps described are necessary to manage documents and to manipulate them in the most appropriate way.

Managing Catalogs
Creating and Saving a Catalog

Modifying a Catalog
Managing Sheet Metal Tables

Integrating CATIA Sheet Metal Tables
Saving/Displaying the Mass Attribute in SMARTEAM

Managing CATAnalysis Documents



Managing Catalogs
Many engineering groups use catalogs of standard parts. This section describes the necessary steps a 
librarian should follow to enable engineers manipulate catalogs as necessary in CATIA and provides a 
few recommendations.

●     Authorization Setting for Standard CATIA Parts 

●     Setting Up a Shared Directory for CATIA Catalogs 

●     Creating and Saving CATIA Catalogs

●     Product Resource Management (PRM)

Instructions for design engineers who need to access catalog components are described in Accessing 
CATIA Catalogs. 
For reference information about catalogs, see the CATIA Component Catalog Editor User's Guide.

SMARTEAM may help you manage your catalogs, however, instantiating parts from the catalog must be 
done while creating a reference and not through creating a new instance (as multiple documents will be 
stored in the SMARTEAM database for each instantiation). 

When you perform lifecycle operations on the catalog, SMARTEAM may attempt to retrieve all catalog 
components from the vault. In the Lifecycle dialog set only the relevant parts of the catalog to copy. 

 

Authorization Setting for Standard CATIA Parts 
Remove permissions for all lifecycle operations for design engineers. 

Only a librarian must have permissions for lifecycle operation on Standard CATIA Parts. 

Setting Up a Shared Directory for CATIA Catalogs 
Assign a shared directory for which all design engineers have read-only permission. 

Only a librarian must have full permission for the shared directory. Users should not have permission to 

delete files from the shared directory.



Creating and Saving CATIA Catalogs

The procedure described below is a simplified version of the process. For detailed instructions, refer to 
Creating and Saving a Catalog.

1.  Create CATIA catalogs

2.  Resolve the catalogs

3.  Save the catalogs into SMARTEAM using Bulk Loading

4.  Release all CATIA Parts related to your catalog

5.  Copy the catalogs and standard parts to the shared directory

CATIA Standard Parts Class

6.  Save catalog parts to CATIA Standard Parts class.



Product Resource Management (PRM)

Catalogs allow a certain number of CATIA workbenches such as Piping Design, Tubing Design etc. to 
manage specific components. To integrate SMARTEAM into these workbenches, librarians must specify 
the paths of the shared directories they create for their catalogs in their Product Resource Management 
(PRM) files (Project.xml files).



Creating and Saving a Catalog
When managing catalogs, the first step a librarian must perform is creating a catalog in CATIA. Then he 
needs to save it in SMARTEAM and make it available to users by copying it into in a shared directory.

This task gives you the main instructions to follow for integrating CATIA catalogs into your SMARTEAM 
database. This procedure can be divided in the following main steps:

●     Creating a Catalog

●     Resolving Part Families and Part Family Components

●     Saving a CATIA V5 catalog inside SMARTEAM

●     Releasing a CATIA V5 catalog inside SMARTEAM

●     Setting Up a Shared Directory for the Catalog

●     Copying the Catalog in the Shared Directory

Steps in CATIA

Creating a Catalog

1.  From the CATIA Start menu, select Infrastructure->Catalog Editor to open the Catalog Editor 

workbench .

2.  Create a catalog from scratch using one of both methods available:

❍     Using the Catalog Editor interactive commands: Activate the chapter under which you want to 
create a chapter or a subchapter.

❍     In Batch mode: Open the BatchCatalog.csv file with an editor like Microsoft Excel. This file file 
contains the information required to create a complete chapter referencing subchapters

For more about the Catalog Workbench, refer to the CATIA Component Catalog Editor User's Guide.

Resolving Part Families and Part Family Components 

Resolving a part family or a part family component means generating the .CATPart documents referred 
to by the part family or the part family component. These documents are generated in a specific folder 
(you specify in the catalog settings) and each generated document is a copy of the generative part 
configured with the matching row in the design table. 

3.  In the specification tree, select the part family to be resolved. 



4.  Right-click then select xxx object->Resolve. 

The corresponding reference documents are generated in the folder you specified in the catalog 

settings. To access these settings, use Tools-> Options-> Infrastructure-> Catalog Editor-

>Catalogs tab.

Note:

Prior to resolving catalogs, also make sure that the Allow family component dynamic 

resolution in catalog option available too from the Catalogs tab is on.

Steps in SMARTEAM

Saving a CATIA V5 catalog inside SMARTEAM

5.  Define classes in which you will save your documents. 

For detailed instructions, refer to Customizing the Bulk Loading Command

6.  Connect to SMARTEAM.

7.  Select SMARTEAM->Bulk Loading...

8.  Choose the path to find all Standard Parts.

9.  Multi-select all documents you wish to save as Standard Part documents.

10.  Still in the catalog, select SMARTEAM->Save.

SMARTEAM prompts you to save the Generic Part. At this stage, you need to switch the class to 

Standard Parts. SMARTEAM will promote to save the Design Table.

SMARTEAM will automatically generate reference links between all saved parts and the catalog.

Releasing a CATIA V5 catalog inside SMARTEAM

11.  Release the catalog.

The Release operation automatically releases all documents. The catalog and all its children are 

now saved and released in SMARTEAM.

Setting Up a Shared Directory for the Catalog

12.  Set up a shared directory folder as default. 



To keep this shared directory clean and secured, it is strongly recommended to assign the 

Windows permissions as below:

❍     Keep administration rights

❍     Assign engineer designers read-only rights only.

Copying the Catalog in the Shared Directory

13.  Search for your catalog.

14.  Right-click and select Copy File.

15.  Propagate this operation on all standard parts to perform the operation on the catalog and all its 

children.

The librarian's work is now complete: the catalog is in the electronic vault and the shared directory 

contains a copy of it. Design engineers can then access CATIA Catalogs.



Modifying a Catalog

This task explains the necessary steps a librarian should follow whenever he wishes to modify CATIA 
catalogs saved in SMARTEAM. 

Whatever modifications required (deletion or modification of a pointed document for instance), proceed 

as follows:

●     Modify the Documents

●     Release the CATIA V5 catalog inside SMARTEAM

●     Copy the Catalog in a Shared Directory

Modifying the Documents

1.  Check out the catalog containing the documents to be modified.

2.  Check out the documents you wish to modify.

3.  Modify the documents in your CATIA session.

4.  Save the documents in the SMARTEAM database.

Releasing the CATIA V5 catalog inside SMARTEAM

5.  Release the catalog.

The Release operation automatically releases all documents. The catalog and all its children are 

now saved and released in SMARTEAM.

Copying the Catalog in a Shared Directory

6.  Set the shared directory folder as the default shared directory folder.

7.  Search for your catalog using the Find command.

8.  Right-click and select Copy File.

9.  Propagate operation on all standard parts.



Managing CATIA Sheet Metal Tables
This section aims at giving you a general overview of the necessary information for managing CATIA 
sheet metal bend tables. For detailed instructions, refer to Integrating CATIA Sheet Metal Tables. Design 
engineers who need to access CATIA Sheet Metal Tables will find operating instructions in Accessing 
Sheet Metal Bend Tables. 

The instructions provided below also apply to thread tables used in the Part Design workbench.

For reference information about sheet metal design, refer to the CATIA Sheet Metal Design User's Guide.

Sheet Metal Bend Tables

SMARTEAM supports sheet metal bend tables. These are made of two kinds of files:

●     A thickness table includes material, thickness, bend radius and the path to the bend deduction file

●     A deduction table includes the angle and the deduction value.

Bend tables can be:

●     .txt files

●     .xls files

In a company, there is usually a unique thickness table but several deduction tables. These tables 
seldom change but are widely used by design engineers. 

 



Link between CATPart Documents and Bend Tables

Bend tables are recognized in CATPart documents as design tables. Each sheet metal CATPart document 
points towards two bend tables:

●     One thickness table

●     One deduction table 
❍     The thickness table is pointed by all Sheet Metal CATPart documents

❍     One deduction table is pointed by some Sheet Metal CATPart documents only

Assigning Authorizations for Bend Tables

To avoid unnecessary lifecycle operation for tables, assign a class for these tables and remove 
permissions to perform check out and new release operations for this class. Only an authorized person, 
such as a librarian must have permissions for all lifecycle operations. 

Rights to update or check-out documents can be managed by:

●     User, role and group

●     document class

●     projects 

Setting Up a Shared Directory for Bend Tables

To allow design engineers to use (view and copy) the same tables, tables can reside in a shared 
directory.



Integrating CATIA Sheet Metal Tables
This task provides the main instructions for integrating CATIA sheet metal bends into your SMARTEAM database. This 
procedure can be divided into the following main steps, all of them to be performed in SMARTEAM.

●     Creating a role

●     Creating a project

●     Assigning authorizations 

●     Saving bend tables inside SMARTEAM

●     Bend tables Inside SMARTEAM

●     Associating the design tables to the project

●     Setting up a shared directory

●     Copying the bend tables into the shared directory

Creating a Role

You need to create a role for which you will then assign some authorizations.

1.  From the SMARTEAM User Maintenance tool, display the Administration dialog box to access the command for 

creating roles.

2.  Click the role icon to display the Roles dialog box:

3.  Create the role of interest. For example, name it as "Read Only on Standards". 



For more information on defining roles, refer to SMARTEAM Editor Administration Guide.

 

Creating a Project

Create a project on which you will restrict design engineers authorizations. Attaching documents to projects is a good way 
of sharing and controlling these documents.

4.  Add a project to which standard sheet metal tables will be linked.

Assigning Authorizations 

You need to assign authorizations for design engineers. 

5.  Define appropriate authorizations for the Read Only on Standards role, including:

❍     View Object on project



❍     View Object, View, Print, On Viewer and Copy File only for Design Tables:



❍     View Object,  on Projects Projects, Documentation Projects and Documents Documents relations

Assigning a Specific Role to Design Engineers for the Project

6.  Use the Project Security command to set the project specific for bend tables as Restricted.



7.  Click Edit... to apply the Read Only on Standards local role to all designers who need to have read access to the 

bend tables.



Refer to the SMARTEAM Editor Administration Guide for further information.

Saving Bend Tables inside SMARTEAM

8.  Save the bend tables in the "Design Table" class.

9.  Link the bend tables to the "Sheet metal Bend Tables" project.

Releasing Bend Tables Inside SMARTEAM

10.  Release the bend tables.

This is optional: Keeping them as checked-in documents should be sufficient.

The Release operation automatically releases all documents. 

Associating the Bend Tables to the Project

11.  To secure the bend tables thru the "Sheet metal Bend Tables" project, associate the bend tables to the project. To 



do so, use Associate with project.

Setting Up a Shared Directory for CATIA Bend Tables

Sheet metal bend tables being meant to be widely used, a good way to dispatch them is to place them in a shared 
directory.

12.  Set up a shared directory folder as default. 

A shared directory is just a directory on a server accessible to everybody. To keep this shared directory clean and 

secured, it is strongly recommended to assign the Windows permissions as below:

❍     The administrator has administration rights

❍     Users are assigned read-only rights.

Copying the Bend Tables into the Shared Directory
Copying the Bend Tables into the shared directory is the final step you need to do. 

1.  Search for your bend tables in SMARTEAM.

2.  Multi-select the tables to be copied.

3.  Right-click and select File Operation-> Copy File.



4.  Paste the files into the shared directory.

The administrator's work is now complete: the bend tables are in the electronic vault and the shared directory contains a 

copy of them. Design engineers can then access Sheet Metal Bend Tables to design sheet metal parts.

Refer to the SMARTEAM Editor Administration Guide for further information.



Saving the Mass Attribute in SMARTEAM
This section provides operating instructions to system administrators who need to integrate CATIA mass attributes in the 
SMARTEAM database. System administrators need to perform three main operations:

●     Creating the CN_Mass Attribute

●     Customizing CATIA Profile Cards

●     Mapping CATIA Mass Attribute

Instructions for designers working in the Generative Sheet Metal workbench are provided in Creating the Mass Parameter in 
the Generative Sheet Metal Workbench.

Creating the CN_MASS Attribute

First of all, as a system administrator you need to create a new relationship between CATIA and SMARTEAM. To do so, use 
the Data Model Designer utility to define an attribute related to the mass property.

1.  From the SMARTEAM Data Model Designer window, create the CN_MASS attribute for any CATIA object class. You 

can create the attribute on CATIA Part class if necessary.

For reference information about SMARTEAM Data Model Designer, refer to the SMARTEAM-Editor documentation.

Customizing CATIA Profile Cards

Showing the CN_MASS attribute to designers means displaying values in profile cards. This involves customizing CATIA 



Profile Cards. To do so, use the Form Designer utility. 

1.  Once the Form Designer utility is launched, from the Open Profile Card window select the CATIA Part class.

2.  Add a new TextEdit field to CATIA Profile cards.

When done, when opening a CATIA Profile Card, the linked information (CN_MASS attribute) from the database is 

automatically displayed in this field. 

For reference information about Form Designer, refer to the SMARTEAM-Editor documentation.

Mapping CATIA MASS Attribute

The final step consists in mapping the CATIA MASS attribute with ST attribute CN_MASS. To do so, use the Integration 
Tools Setup utility. 

1.  From the Integration Tool Setup window, select CATIA Part and run Open groups tree.



2.  Once in the Mapping Groups Tree window, use the add contextual command to add the MASS attribute.

3.  Map the MASS attribute with SMARTEAM CATIA Part.CN_MASS attribute.

For reference information about the Integration Tools Setup, refer to the SMARTEAM-Editor documentation.



 Managing CATAnalysis Documents
This section is dedicated to system administrators who need to integrate CATAnalysis documents into the 
SMARTEAM database. Instructions for design engineers are documented in Handling CATAnalysis 
documents. 
For information about mechanical analyses for 3D systems, refer to the CATIA Generative Structural 
Analysis User's Guide.

Setting Directory for CATAnalysisResults and 
CATANalysisComputations files.

It is highly recommended to change the CATIA default setting for the location of the CATIA 
CATAnalysisResults and CATANalysisComputations files. This is performed as follows: 

1.  Select Tools-> Options.

2.  From the Options dialog box that is displayed, click the Analysis & Simulation category to the 

left, and then the External Storage tab.

The first two options let you specify the directories in which you want to save the 

CATAnalysisResults and CATAnalysisComputations files. By default, the Last used preferences 

are enabled in both cases. Using these default options, you would save the analysis files in a 

temporary directory, which is not recommended for working with SMARTEAM.

3.  For each option, check Always... 

4.  And click the icon to the right to navigate and select the directory of interest.

When done, the paths to the new directories are displayed:



5.  Just click OK to confirm and close the dialog box.



Defining Property Mapping 
This section shows you how to read or set a property both on the CATIA and the SMARTEAM side.

Three scenarios show you how to define property mapping between CATIA and SMARTEAM, based on the 

CATIA Formula property  and the SMARTEAM attribute. You will learn how to map the set of CATIA 

properties of a CATDrawing document with the corresponding SMARTEAM attributes of a SMARTEAM CATIA 
Drawing class. 

For quick, easy mapping of a drawing text with any of the CATIA Drawing attributes in the SMARTEAM 
database you are better advised to follow the steps contained in Displaying a CATIA Drawing SMARTEAM 
Attribute in a Title Block. This particular task can be performed only by the user with administrative privileges. 
However, there are other tasks dealing with property mapping for which such privileges are not required 
(Using Mapped Product Properties for example).

Property Mapping Basics
Defining Property Mapping for the Title Block

Defining Property Mapping for the Revision Block
Defining Property Mapping for CATIA Products and CATIA Parts



Property Mapping Basics 
The Integration Tool Setup utility enables the administrator to map properties from CATIA directly to an object's Profile 
Card. This provides users with the highest level of integration, enabling a bi-directional link from a CATIA property to the 
object's Profile Card and from a Profile Card to CATIA property.

This section provides an overview of property mapping. It deals with the following topics:

●     Integration Tool Setup Utility 

●     Mapping Direction

●     Hardcoded Property Names

●     Map a Text Value...

●     Performances and Attribute Mapping

For reference information on the Integration Tool Setup utility, refer to the SMARTEAM documentation.

Integration Tool Setup Utility

The Integration Tool Setup Utility is used to: 

●     Define new relationships between SMARTEAM and CATIA.

●     Add, update and delete mapping groups, mapping properties and mapping attributes.

●     CATIA Product: This indicates that the associated set of mappings are related to documents stored in the CATIA 
Product class.

●     Read only : when you define a mapping you also define its direction. Read only is one of the options determining 
the mapping direction.



 

Mapping Groups Tree Window

Properties are mapped from the Mapping Group Tree window.

1.  To access the Mapping Group Tree window, select SmarTeam->Tools-> Property Management.

All property types (or group types) are mapped in the same way. 

❍     CN_DEFINITION: The mapping property name corresponds either to a CATIA formula or a hardcoded CATIA 
attribute.

❍     Enable updating of property: This is one of the options determining the  mapping direction.

Mapping Direction 

For each mapped property, the mapping direction has to be defined: 

●     Database->CATIA i.e. CATIA property values come from the database

●     CATIA->Database i.e. CATIA property values are written to the database

Note that you can select both mapping directions.



These options determine the mapping direction: 

●     the CATIA value is stored in the SMARTEAM database or,

●     The SMARTEAM values are applied to CATIA

●     The mapping is bidirectional

In the table below you will notice that the property mapping information relates to both the title block and the revision 
block.

Property Name 

in CATIA 

Attribute Name 

in SMARTEAM

Attribute Type in 

SMARTEAM
Update Direction

Type Document Type character Database->CATIA

Designer ID character Database->CATIA

Date Creation Date character Database->CATIA

Drawing_Title Title character Database->CATIA

Scale Scale character CATIA->Database

Revision Revision character Database->CATIA

Comment Note character Database->CATIA

ApprovalDate Approval Date character Database->CATIA

Authorized Approved By character Database->CATIA

 

Hardcoded Property Names 

Here is a list of the hardcoded names accessing product properties and sheet information.

Some of them can only be read from the CATIA document. In other words, defining a mapping from SMARTEAM to CATIA 
will not work because these properties are read only on the CATIA side.



CN_PART_NUMBER read/write Contents of the Part Number field CATIA Part and CATIA Product

CN_REVISION read/write Contents of the Revision field CATIA Part and CATIA Product

CN_DEFINITION read/write Contents of the Definition field CATIA Part and CATIA Product

CN_NOMENCLATURE read/write Contents of the Nomenclature field CATIA Part and CATIA Product

CN_SOURCE read/write Contents of the Source field CATIA Part and CATIA Product

CN_DESCRIPTIONREF read/write Contents of the Description field CATIA Part and CATIA Product

CN_CONTEXTUAL read File name of the referenced
CATIA Product for a contextual Part CATIA Part

CN_SHEET_NAME read Name of the sheet CATIA Sheet

CN_SHEET_FORMAT read Format of the sheet CATIA Sheet

Note that surface, mass and volume mapping are no longer documented as it has a negative effect on saving 
performance. 

If such mapping has already been done, remove it from the database as follows: 

1.  Run the Integration Tools Setup utility.

2.  In the tree displayed, select CATIA then right-click on Mapping group types.

3.  Right-click on each class one by one (such as CATIA Product or CATIA Part) and select Open Group Tree.

4.  Check that neither CN_MASS nor CN_VOLUME nor CN_SURFACE are under Engineering Information. If they 

are, delete the appropriate mapping property information.

Map a Text Value...

Before using SmarTeam->Properties->Map a Text Value (for an example, see Displaying a CATIA Drawing 
SMARTEAM Attribute in a Title Block), create a group-type corresponding to the name of the class used to store the 
drawing (this group-type is created using Integration Tools Setup).

Property Name Read/Write? Description Relevant Class



●     The user should determine whether each type of mapping is needed from CATIA to SMARTEAM, from SMARTEAM to 
CATIA or from both directions: 

●     If it is really required, the revision should be mapped only from SMARTEAM to CATIA

●     The parameter attributes can be mapped from (and to) CATIA to (and from) SMARTEAM but most often only the 
CATIA to SMARTEAM mapping direction is needed.

●     The same consideration can be performed on the CN_MATERIAL attribute. Most often, only the CATIA to SMARTEAM 
mapping direction is needed.

Attribute mapping is one of the major element in terms of performances implied for the Save and Open transactions.

Thus, it is advised to clearly identify the needed mapping:

●     A previous section describes the importance not to map the mass, volume and surface

Performances and Attribute Mapping



Defining Property Mapping for the Title Block 
This section shows you how to define property mapping for title blocks.

1.  Launch the Integration Tool Setup utility.

The Integration Tool Setup dialog box appears:

A mapping group type i.e. a set of mapping groups, applicable to a specific SMARTEAM class must now be defined that 

corresponds to the CATIA Drawing class. 

2.   In the tree displayed, right-click on Mapping Group Types and select Add mapping group type.

The Map Group Type dialog box appears.

3.  In the Name: field, enter the group type name CATIA Drawing as shown:

The name of the mapping group type must be identical to that of the SMARTEAM Class it applies to. 



4.  Click OK.

5.  In the tree, right-click on the CATIA Drawing item and select Open groups tree.

The Mapping Groups Tree window appears.

6.   In the tree, right-click on CATIA Drawing groups and select Add.

The Manage group type window appears.

7.  In the Name: field, enter a meaningful name, for example Title Block Information:

The name used should help you organize the different mapped properties you have to manage. 

8.  Click OK.

9.  To define the CATIA Formula property  as Type, go to the tree and right-click on Title Block Information 

10.  Select Add.

The Add Title Block Information property dialog box appears.

11.  Enter Type in the Name: field.



The name of the mapping property must be identical to the corresponding CATIA Formula property .

12.  Select Enable updating of property if not already selected.

A CATIA Formula property  can thus be updated after a change to a SMARTEAM attribute.

13.  Click OK.

14.  Go to the tree and right-click on Type then select Add. 

This defines as Drawing Type the SMARTEAM attribute to be linked to the CATIA Formula property . 

The Attribute mapping dialog box appears.

15.  Click the button to the right of the Class name field and select the class name CATIA Drawing from the Class Tree 

window that appears.



16.  Repeat the previous operation for the right of the Attribute name field: select the attribute name Document Type from 

the Select Attribute window that appears.

Note that the list of the possible attributes is specific to the selected class name.

  



 

17.  Click OK.

The Mapping Groups Tree window appears:

The following table is a summary of the steps that have just been performed.

Mapping 

Property Name
Enable Property Update Mapping Attribute Name Enable SMARTEAM Update

Type yes Document Type

18.  Repeat steps 9 through 16 for all other mapped properties. 

Here is a list of all the other properties to be mapped:



Property Name 

in CATIA 

Enable Property Update Attribute Name in SMARTEAM
Enable 

SMARTEAM Update

Designer yes ID

Date yes Creation Date

Drawing_Title yes Title

Scale Scale yes

Once this has been done the CATIA Drawing Mapping Groups tree dialog box should look like this: 

As you can see, mapping of the CATIA properties and the SMARTEAM attributes has now been completed. 



Defining Property Mapping For the Revision Block
This section describes how to define property mapping for revision blocks.

1.  Launch the Integration Tool Setup utility.

The Integration Tool Setup dialog box appears:

A mapping group type i.e. a set of mapping groups, applicable to a specific SMARTEAM class must now be defined that corresponds to the 

CATIA Drawing class. 

2.   In the tree displayed, right-click on Mapping Group Types and select Add Mapping group type.

The Map Group Type dialog box appears.

3.  In the Name: field, enter the group type name Revision Block as shown:

The name of the mapping group type must be identical to that of the SMARTEAM Class it applies to. 

4.  Click OK.

5.  In the tree, right-click on the Revision Block item and select Open Groups Tree.

The Mapping Groups Tree dialog box appears.



6.  In the tree, right-click on Revision Block groups and select Add.

The Manage Group Attribute dialog box appears.

7.  In the Name: field, enter a meaningful name, for example Engineering Information:

The name used (Engineering Information in this particular case) is referenced in the RevisionBlock.bs script. If you want you can 

subsequently change this name. 

8.  Click OK.

9.  To define the CATIA Formula property  as Type: Go to the tree and right-click Engineering Information 

10.  Select Add.

The Attribute property dialog box appears.

11.  Enter Revision in the Name: field.

12.  Check the box Enable updating of property.

A CATIA Formula property  can thus be updated after a change to a SMARTEAM attribute.



13.  Click OK.

14.  Go to the tree and right-click on Revision then select Add. 

This defines as Drawing Type the SMARTEAM attribute to be linked to the CATIA Formula property  

The Attribute Mapping dialog box appears.

15.  Select the class name CATIA Drawing.

16.  Select the attribute name Revision.

Note that the list of the possible attributes is specific to the selected class name.

17.  Click OK.

The Revision Block Mapping Groups tree dialog box appears:



The following table is a summary of the steps that have just been performed.

Mapping 

Property Name
Enable Property Update Mapping Attribute Name Enable SMARTEAM Update

Revision yes Revision

18.  Repeat steps 9 through 16 for all other mapped properties. 

Here is a list of all the other properties to be mapped:

Property Name 

in CATIA 

Enable Property Update Attribute Name in SMARTEAM
Enable 

SMARTEAM Update

Comment yes Note

ApprovalDate yes Approval Date

Authorized yes Approved By

Once this has been done the Revision Block Mapping Groups tree dialog box should look like this: 



As you can see, mapping of the CATIA properties and the SMARTEAM attributes has now been completed. 



Defining Property Mapping For CATIA Products and CATIA 
Parts 

This section describes how to define property mapping for CATIA Products and CATIA Parts.

It is assumed that the properties used for this task have already been created in the database under the CATIA Product and 
CATIA Part classes.

1.  Launch the Integration Tool Setup utility.

The Integration Tool Setup dialog box appears.

2.  Double-click on CATIA or select the "+" sign to display the options associated with CATIA.

3.  Double-click Mapping Group Types or select the "+" sign in front of it.

4.  Select the CATIA Product mapping group type then right-click and select Open groups tree: 

5.  In the Mapping Groups Tree window, select the Engineering Information item then right-click and select Add. 



6.  In the Attribute Properties dialog box, complete all fields as shown below, then click on OK:

7.  Back in the Mapping Groups Tree dialog box, right-click CN_REVISION then select Add.



8.  In the Attribute Mapping window, complete the Class name and Attribute name field as shown below then click on 

OK.



Recommendations

The purpose of this section is to provide a certain number of recommendations to system administrators so as 
to facilitate the integration of SMARTEAM with CATIA.

Lifecycle Settings
Lifecycle Rules Setup
Lifecycle Operations

Reviewing Lifecycle Rules for CATIA Links
Last Public Revision Setting
Override Previous Revision

Link to Parents of Previous Revision
Rules for Overwriting Local Files

File Naming
Data Model Considerations: Defining Classes

Data Model Considerations: Defining Attributes

 



Lifecycle Settings

Lifecycle in SMARTEAM   
SMARTEAM enables you to maintain and manage any information related to a revision manageable 

object throughout its Lifecycle. By mirroring the physical process of product management, 

SMARTEAM uses vaults, check in, check out, and release functions to manage the Lifecycle revision 

manageable objects. It creates new versions of a file and protects it from unauthorized modifications. 

Lifecycle for CATIA Designers

CATIA Designers use lifecycle for a number of purposes:

1.  Sharing between members of a Design group.

2.  Saving of modification history.

3.  Approving and releasing.

SMARTEAM lifecycle has been designed to allow working with large assemblies with various 
references between different CATIA documents. It takes into consideration the designer's need to 
receive the necessary documents with the correct revisions. 

Lifecycle Settings

In the Lifecycle Settings, you can define different company rules for designers. These rules define 
how designers should perform lifecycle operations for their design and reference documents. 

The following preferences can be defined within the Lifecycle Settings: 

General Settings 

●     Enable/disable user-defined revisions. 

●     Lifecycle dialog type (no dialog, light lifecycle screen, advanced lifecycle screen)

●     Last public revision note 

In Vault Operations 

●     Allow replacement of previous revision

●     Enable/disable the Always Check in/Release of the latest available revision



●     Show/hide the revision report when a revision is replaced in the lifecycle

Out of Vault Operations

●     Restrict new release operation when derived revision exists

●     Allow branching

●     File override policy in user's work directory 

●     Enable/disable check out of latest available revision 

Defining Lifecycle Settings

CATIA users depend on the document lifecycle and therefore proper settings for the lifecycle 
management will assist in streamlining and optimizing their work. 

To obtain optimum behavior for file dependencies, is recommended to work with SMARTEAM CATIA 
Integration V5R12 or later. 

Lifecycles are part of the daily work of a CATIA user. The correct setting of lifecycle parameters can 
greatly assist the streamlining of engineers work.

Lifecycle Settings Review

Working with latest revision

Depending on the user's role and stage of the product development, users might have a different 
requirement for seeing by default a revision of a CATIA document. For example, design engineers 
usually need to see the latest revision, where production engineers needs to see the latest released 
revision. 

If the Always Check in Latest Available Revision preference is selected, automatic replacement 
will be done. However, the CATIA Product will reference the components that may never have been 
saved in CATIA. This may lead to problems at the CATIA level. 

Recommendation: To ensure integrity of the vaulted CATIA Products documents, do not allow 
automatic Replace to Latest Revision for check in and release operations. The user should update his 
product to the latest revisions of the sub-components before checking it into the vault.  Before 
performing a check in/release operation, the user can replace all Not Latest products/parts in the 
product using Replace with selected revision operation from SMARTEAM/Assembly Management 
menu in CATIA. 

How to setup Latest Revision Options

1.  From Administrator Options, select Lifecycle Options.

The Life Cycle Options dialog box is displayed.



2.  Click the Into vault tab.

3.  Click Latest Revision... 

The Latest Revision Options dialog box is displayed.

4.  Unselect:

❍     Always Check In latest available revision

❍     Always Release latest available revision. 



Lifecycle Rules Setup

The Lifecycle Rules Setup defines rules for the Lifecycle operations on linked objects throughout a 
Lifecycle Operation (as a result of an operation performed on a specific object). For example, an 
administrator can define that if a user performs a check in operation on a CATIA Drawing, the CATIA 
Part will automatically be set to check in.

The Lifecycle Rules Setup is an administrative application tool that enables users to define and 
manage rules for operations performed on linked objects. 

 

Using this tool, you can: 
●     Review default rules 

●     Modify rules provided by specific Integration applications 

●     Add, remove or modify custom rules 

Lifecycle rules depend on customer processes and have to match and reflect these processes. To 
know the different types of lifecycle operations which can be performed on a CATIA object, refer to 
Lifecycle Operations.



Lifecycle Operations

All life cycle operations on CATIA documents must be performed through CATIA user interface. Life Cycle 
operations from SMARTEAM are not supported and can affect the session and data consistency.

As defined via the Lifecycle Rules Setup tool, the following types of lifecycle operations (as shown in the Lifecycle Rule 
Properties window) can be performed on a CATIA object:

These properties are described below: 

Field Description 

Link Class Defines the link between two SMARTEAM classes.

Direction Defines the direction of the link object, which can be:

●     Normal or 

●     Reverse

Original Component Type

or SMARTEAM Class Destination 
Component Type 

or SMARTEAM class Original 
Operation 

Defines the class or component type of the object on which you perform the 
Lifecycle operation. 
Defines the class or component type of the dependent object 

Defines the operation on the source object. All SMARTEAM Lifecycle 
operations are available.



Destination Operation Defines the operation on the dependent object as a result of the operation 
on the original object. The availability of the destination operation depends 
on the selected original operation. For example, if the original operation is 
Check Out then the available destination operations are Check Out, Copy 
File or No Operation.

Link Operation (Copy Link / No 
operation)

This parameter specifies how the system should handle linked objects 
between two objects when new revisions are created. Copy Link means 
copy the link between old revisions with all its attribute values to new 
objects, and No operation means create new revisions without creating a 
link between them. 

This option is available only when the original operation is in Check Out or 
New Release mode. 

●     When you define No operation, SMARTEAM will not link between the 
original and destination object. This option works in addition to 
SMARTEAM options for Copy hierarchical link and Copy general link.

●     When you set set Link Operation to Copy Link, SMARTEAM enables 
you to perform this operation between the original and the destination 
objects. 

Link Operation (Copy link / No 
operation)

This parameter specifies how the system should handle linked objects 
between two objects when new revisions are created. Copy Link means 
copy the link between old revisions with all its attribute values to new 
objects, and No operation means create new revisions without creating a 
link between them. 

This option is available only when the original operation is in Check Out or 
New Release mode. 

●     When you define No operation, SMARTEAM will not link between the 
original and destination object. This option works in addition to 
SMARTEAM options for Copy hierarchical link and Copy general link. 

●     When you set Link Operation to Copy Link, SMARTEAM enables you to 
perform this operation between the original and the destination objects. 

Switch to Latest Defines whether to allow switching to the latest revision of the object. If a 
new revision already exists, this option works in addition to SMARTEAM 'S 
Lifecycle options (Check In and Check Out from the vault). When this option 
is set to Allowed, SMARTEAM allows you to switch to the latest revision of 
the object. 

This option is not available when the original operation is Obsolete.



Propagation Allowed Defines whether to allow the Propagation operation to the destination 
object, if you want to perform a propagation operation during the Lifecycle 
operation.

This option is not available when the original operation is Obsolete.

Check Destination Object Status Defines whether to check the status of the destination object. This option 
replaces previous versions of SMARTEAM Lifecycle options, of the Child 
level. This option is available only when the original operation is Check In 
or Release mode. 



Reviewing Lifecycle Rules for CATIA Links

Types of Links

There are different types of links in the lifecycle rules:

●     Documents Tree

●     Design Link

●     Contextual Link

●     Downstream Application

Documents Tree

The Documents Tree builds the product structure and links between the CATIA product and the CATIA sub-products and parts. 

●     Check Out: When a user checks out a CATIA product, all CATIA parts and sub-products that build the structure of the 
product must to be copied. To do this, the administrator needs to set the designation operation to Copy File. 

●     Check In: When a user checks in a CATIA product, all parts and sub-products in this structure must be checked in. To do 
this, the administrator needs to set the designation operation to Check In.

●     Release: When a user releases a CATIA product, all parts and sub-products in this structure must be released. To do this, 
the administrator needs to set the designation operation to Release.
Scenario:
In a company, an individual user uses parts of a CATIA product that belong to other users. 

If the user performs a Release operation on a product, it automatically performs a Release operation on the downstream 
parts, and this may lead to the release of CATIA parts or products designed by another user. 

In order to avoid this situation, upon a Release operation, set the designation operation to No Operation and mark the 
Designation Status check box. When the user tries to perform a Release operation, he is informed that he must manually 
release each downstream part. If he does not do this, an error will appear. 

This ensures that the user is aware of each document he releases and is not simply performing an automatic release. 

●     New Release: When a user performs a new release a CATIA product, all CATIA parts and sub-products that build the 
structure of the product must be copied. To do this, the administrator needs to set the designation operation to Copy File.

●     Copy File:  When a user performs a Copy File of a CATIA product, the administrator needs to set the designation operation 
to Copy File. 

Design Link: 
●      Check Out: When a user checks out a CATIA document, all related documents must be copied. To do this, the 

administrator needs to set the designation operation to Copy File. This ensures that the latest revisions of the files are 
received. 

●     Check In: When a user checks in a CATIA product, all parts and sub-products in this structure must be checked in. To do 
this, the administrator needs to set the designation operation to Check In. This ensures that both documents will be 
checked in. In some organizations, this constraint is too high as they need to check in the CATIA document without 
checking in related documents. In this case, the administrator can set the designation operation to No Operation.

●     Release: When a user checks in a CATIA product, all parts and sub-products in this structure must be checked in. To do 
this, the administrator needs to set the designation operation to Check In. This ensures that both documents will be 
checked in.

●     New Release: When a user checks out a CATIA document, all related documents must be copied. To do this, the 
administrator needs to set the designation operation to Copy File. This ensures that the latest revisions of the files are 
received. 



Contextual Link

CATIA contextual links create dependencies between files such that a part feature may be dependent on information stored in 
a product.

In the example above, notice that a check out operation in the normal direction  results in the linked object being copied (Copy 
File). In the reverse direction, the check out operation results in no operation on linked object (No Operation).

The Copy Link setting allows you to establish a link to the object in the context of the  component built. This is important if you 
want to automatically replace the object with the latest revision of the linked component.

●     Check Out: When checking out, set the designation operation to Copy File to ensure that links will not be lost when 
checking in again.

●     Check In: When a user checks in a CATIA product, all parts and sub-products in this structure must also be checked in. To 
do this, the administrator needs to set the designation operation to Check In. This ensures that both documents will be 
checked in. In some organizations, this constraint is too high as they need to check in the CATIA document without 
checking in related documents. In this case, the administrator can set the designation operation to No Operation.

●     Release: When a user checks in a CATIA product, all parts and sub-products in this structure must also be checked in. To 
do this, the administrator needs to set the designation operation to Check In. This ensures that both documents will be 
checked in. 

●     New Release: When checking out, set the designation operation to Copy File to ensure that links will not be lost when 
checking in again.

Downstream Application
●     Check Out: When a user checks out a CATIA Drawing, all CATIA parts and sub-products that build the structure of the 

drawing must be copied. To do this, the administrator needs to set the designation operation to Copy File. 

●     Check In: When a user checks in a CATIA product, all parts and sub-products in this structure must be checked in. To do 
this, the administrator needs to set the designation operation to Check In.

●     Release: When a user releases a CATIA product, it is necessary to release all parts and sub-products in this structure. To 
do this, the administrator needs to set the designation operation to Release.

●     New Release: When a user checks out a CATIA Drawing, all CATIA parts and sub-products that build the structure of the 
drawing must be copied. To do this, the administrator needs to set the designation operation to Copy File.

●     Copy File:  When a user performs a Copy File of a CATIA product, the administrator needs to set the designation operation 
to Copy File. 

●     Reverse Link: Some organizations require that when a user checks out a CATIA part or product, the related drawings 
must also be checked out to reflect modifications in the drawing. To ensure this, the administrator can set reverse links for 
Check Out and new release operations for downstream applications. For downstream applications, if a check out or new 
release operation is performed on a part; its drawings must also be checked out automatically. Therefore, the designation 
operation must be set to to Check Out for checking out and to New Release for new release.

CATIA Link Default Settings

The following settings are defined in the supplied SmDemo database.    



CATIA Design

CATIA Contextual



CATIA Downstream Application

CATIA Design Table 



CATIA Result

CATIA Reference



CATIA Documents Tree

CATIA Rule Base



Managing Contextual Links

Here are the settings we recommend for working with reverse contextual links:

 

 





Last Public Revision
When working as a team on a large design, users need to access each other's documents. When a team 
member checks out a document, other team members who need to reference it will use an earlier 
revision by copying it to their private work areas. 

When a checked out model is checked in (or released), other team members who might be referencing 
an older revision of it, can get the latest copy.

You can update your local copies to the latest available when performing a lifecycle operation as well as 
directly from within the CATIA session.

The definition of the last public revision influences the user experience relating to loading the most 
recently available revisions of sub-components.

Recommendation

Set up the Last Public Revision Mode to Check In and Release .

Since a document can have numerous revision numbers, SMARTEAM - Editor enables you to define 
which revision is considered the last revision. For example, you can define that only objects that are 
Released (using the Release option) are assigned the last revision status. 

The last revision status affects the following SMARTEAM - Editor operations: 

●     Tree Properties

●     Searches

●     Branching 

Setting up Last Public Revision Mode

1.  In SMARTEAM, select Administrator Options-> Lifecycle Options.

For Last public revision mode, three options are available from the dropdown list in order to 

determine the last revision status of all objects in SMARTEAM - Editor: 

❍     Release Only

❍     Check In

❍     Check In and Release 

Check In and Release

2.  Select Check In and Release.

The last revision status is assigned to both a Released and Checked In revision of an object. If 



you select this option, then two revisions of a document (Released revision and Checked In 

revision) may be displayed in a tree browser or Search window.

Release Only 

The last revision status is assigned to the last Released revision of an object. In cases where a 
Released revision does not yet exist, the last revision status is assigned to the last Checked In 
revision of that object. If an object was Released (as b.0 for example) and then checked back 
into the vault (as b.1), the last revision status is assigned to the former revision (b.0), even 
though it is an earlier revision. Choose this option if you wish to display only those objects that 
were Released.

Check In

The last revision status is assigned to the last Checked In revision of an object. If an object was 
Released (as b.0 for example) and then checked back into the vault (as b.1), the last revision 
status is assigned to the latter revision (b.1), even though it has not been Released. 

Note: The last revision of an object is significant in the following operations:

Tree Properties

You can define that the tree will only display the last revision of a document, by proceeding as follows:

1.  In SMARTEAM, select Tree->Tree Properties...

2.  From the Tree Properties dialog box that appears, click the Tree Filter tab.



3.  Click in the Latest Revision option button located in the Revision Filter section. 

Lifecycle Options General window

If in the Lifecycle Options General window you selected:

●     Release Only, the tree will display the last Released revision of an object.

●     Check In, the tree will display the last Checked In revision of an object. 

●     Check In and Release, the tree will display both the last Released revision and the last Checked In 
revision of an object.



Override Previous Revision

This option enables you to determine whether a file that is copied to a user's desktop will override a 
duplicate copy of the same file. For example, a user can be modifying an object called oil232.drw. The 
user can then copy an Assembly to the desktop that contains the same object as one of its sub-
Assemblies.

This option determines if the second copy of this object will overwrite the existing copy of the object. 
Click on the dropdown arrow to select one of the following 

SMARTEAM - Editor will overwrite a read-only file. If the file on the user's desktop is a read-only file, 
then the new copy of the file will overwrite the existing copy. For example, a user could have copied an 
Assembly to the desktop that contains the object oil.drw as a sub-Assembly. This sub-Assembly file is a 
read-only file, as it was copied to the desktop as part of an Assembly only. If the user then decides to 
check out and modify this specific object (oil.drw), the new file will overwrite the existing one.



Link to Parents of Previous Revision

Upon check in, a user may request to link the checked in, new revision to the parents of its previous 
revision. This allows the updating of referencing documents with the new updates.

Recommendation

Use Replace in parents of previous revision only in the WIP (Work In Process) stage of the design. This 
functionality also makes all referencing documents dirty. Therefore, as soon as these are opened in 
CATIA, a rebuild is needed (check out). 

This advanced feature is not for daily use, it involves same issues as Overwrite Previous Revision 
regarding the updating of private working areas of other team members.

Setting up Replace in parents of previous revision 

Starting from SMARTEAM V5R13, the administrator can set automatic replace in parents of previous 
revision as shown below. 

1.  From Administrator Options, select Lifecycle Options.

2.  Click the Into Vault tab.

3.  Check Released Parents of Previous Revision and Cheked-in Parents of Previous 

Revision.



❍     If Allow replacement of previous revision is checked, the user can ask the system to 

automatically replace the previous revision by the new one in the current operation using the 

Set Default dialog.

❍     If Automatically replace in is checked, the system will automatically set this option in the 

Set Default dialog.   



Rules for Overwriting Local Files
One of the cornerstones of CATIA usage is the re-usability of components. Additional advantages are the 
ability to create revisions throughout time, the need to work concurrently with other members of the 
team, in-context modeling and other features. This sometimes results in a situation where a file that is 
brought from the vault already exists in the destination directory.

When the file that is brought from the vault differs from the one in the directory, a question arises 
whether or not SMARTEAM should overwrite the local copy. The answer depends on the context of the 
operation you are performing and the reason why the local copy already exists.

If you are trying to print or view a drawing exactly as it was released, you need the exact copies of 
referenced documents as at the time of the release. When one of the referenced documents already 
exists in the destination directory, you should answer yes to overwrite the local copy. However, the local 
copy that is in your working area is probably there due to a different referencing product or model, and 
copying an older version of the document may affect that parent. In certain cases, the local copy may be 
checked out and worked on, and overwriting it may cause the loss of valuable work.

Due to the fact that products may include hundreds to thousands of sub-components, it is not 
recommended to setup SMARTEAM to prompt you each time it runs into the overwriting problem. To 
solve the 'multiple questions' scenario, there is an error report that summarizes all the issues 
encountered. 

There are several SMARTEAM preferences that affect the system behavior regarding the overwriting of 
local files. 

Recommended Setup

The recommended setup is based on the following two assumptions: 

1.  A local file that is checked out or has been modified compared to its vaulted version will NOT be 

overwritten (this ensures that you do not lose any valuable work you have done). To overwrite 

the local file, the user has to respond to the prompt.

2.  Newer versions take priority over older versions, i.e., by default an older version does not 

overwrite a newer, local version. In these cases, a user can request to be notified in order to take 

an action that overrides this 'default' rule.

The recommended setup is: 

●     If a mandatory rule in your CATIA design is to work with the latest revision of all sub-components at 
all times, setup the out of vault preferences to automatically switch to latest revisions.
In this setup, SMARTEAM overwrites local copies only if the retrieved copy is newer. No prompt or 
warning is presented. 

●     If users want to be able to define whether a local copy should be overwritten only if it is newer, set 
up the preferences to compare revisions.



●     If users want to be able to define whether a local copy should be overwritten or not (whether it is 
newer or older), setup the system to ask on replacing local copy on copy and on check out new 
release.



File Naming

CATIA documents often reference other CATIA documents. A simple example may be a part drawing, 
where the drawing document points to the part document. A more complex example is file 
relationships created from contextual design. 

The fact that document references are based on file names puts a strong emphasis on proper naming 
of your CATIA files. 

An example of a problematic scenario is a situation where one designer, Joe, creates a bearing and 
names its part file Bearing while another designer, Mark, creates a different bearing size, yet still 
names its file as Bearing. Everything may work well, until both bearings have to be placed in the 
same product. This causes a conflict at the CATIA level and the user will have to rename one of the 
files. As mentioned above, renaming files can cause many problems. Documents that are looking for 
the file name may lose the link to this renamed part. 

Recommendation

Therefore, it is recommended that SMARTEAM generates the file name. It is also recommended that 
the filename includes a sequential number that ensures uniqueness. 

 

 



Data Model Considerations: Defining Classes 
 

The system data model is a key factor in the ease of use, performance and usability of the system. The fact that the SMARTEAM system 
has a flexible data model is a huge advantage, but this advantage should be used correctly, taking into consideration how the CATIA 
Integration is affected. 

This page deals with the definition of classes. For information about attributes, refer to Defining Attributes.

Number of Classes 
A CATIA class represents data of CATIA documents in SMARTEAM database. The following table describes the CATIA component types 

treated by SMARTEAM - CATIA Integration: 

CATIA Component Type Description Remarks

CATIA Product CATIA Product

CATIA Internal Component CATIA Internal Component Use only if Exposed Mode set to TRUE

CATIA Part CATIA Part

CATIA Drawing CATIA Drawing

CATIA Sheet CATIA Sheet Use only if Exposed Mode set to TRUE

CATIA Catalog CATIA Catalog

CATIA Material CATIA Material

CATIA Process CATIA Process

NC NC

CATIA V4 Model CATIA V4 Model

CATIA Representation CATIA Representation

CATIA Analysis Results CATIA Analysis Results

CATIA Analysis CATIA Analysis 

CATIA Analysis Computations CATIA Analysis Computations

CATIA Analysis Input CATIA Analysis Input

CATIA System CATIA System

CATIA Feature Dictionary CATIA Feature Dictionary

CATIA Document CATIA Document

CATIA Process Library CATIA Process Library

Design Table Design Table

CATIA CADAM CATIA CADAM

We recommend to avoid a large number of classes, as it affects general performance and from the point of view of usability and 

understanding by the user, the interface may become too complicated. In the case of a specific data model for a customer, use only the 

classes that the user needs and remove unused classes in SmDemo (in case this database is used as a starting point for the 

implementation).

Recommendation

●     Define only SMARTEAM classes that correspond to component types that you use in CATIA.

●     Alternatively, if certain component types may be used in the future; remove user's permissions from these classes to ensure that 
they do not confuse the end users.



 

Defining Composition Rules

The SMARTEAM Data Model Designer allows you to define composition rules. It is recommended to allow only the relevant compositions 
as this has direct effect on performance. The following table displays the recommended composition for CATIA classes. For component 
types that do not appear in the table, do not set any composition. 

Class CATIA Product Standard 
CATIA Product

CATIA Internal 
Component CATIA Part Standard CATIA 

Part 

CATIA

Model

Class Component 
Type       

CATIA 
Product

CATIA 
Product V V V V V V

Standard 
CATIA 
Product

CATIA 
Product X V X X V X

CATIA 
Internal 
Component

CATIA 
Product V V V V V V

CATIA Part CATIA Part X X X X X X

Standard 
CATIA Part CATIA Part X X X X X X

CATIA 
Model CATIA Model X X X X X X

How to define composition 

In the Data Model Designer, define the link classes, their attributes and class composition. To do this, proceed as follows:

1.  From the SMARTEAM Data Model Designer window, select Document Tree.

2.  Click the Composition tab.

3.  Set the appropriate compositions. 

Defining Classes as Desktop Objects 

When defining classes in the Data Model Designer, you may allow/not allow associating objects of this type with the project desktop by 
setting the Add as Top Level flag. 

Assigning a Class to be top level has performance implications due to the special actions executed by SMARTEAM during a lifecycle. 
When Out of Vault operations (Check Out, New Release) are performed on objects of classes that may be desktop objects, the system 



checks whether the particular object is a desktop object and re-link the newly-created version to the root of the projects to which it was 
previously linked. 

Recommendation

Decide which classes should be allowed on the desktop and define only these classes as desktop objects. Try to minimize the number of 
classes allowed to be desktop objects. 

 How to allow a class to be a desktop object

1.  Check Add as Top Level for the classes as illustrated below: 

Standard Parts 
Standard parts are widely used by designers. The major advantage of using standard parts in CATIA is the reusability of the parts and 

the time it saves. It is critical that parts that fall into the category of standard parts do not change often, and will be correctly managed 

and controlled as they may affect almost all your designs 

For more details, refer to the Standard Parts Library Methodology Guide. See also Managing Catalogs. 

STANDARD PARTS REVISION MANAGEMENT 

The following table provides a brief summary of the advantages and disadvantages of revision management of standard parts. 

Using revision-managed parts 

Advantages Disadvantages 

Secure vault storage Need to always copy standard part along with assembly to user 
work area

Multi-site replication along with vault

Using non-revision-managed parts 

Advantages Disadvantages 

No need to move standard parts to user work area Standard parts reside in non-secure area, where users need write 
permission

 Cannot replicate standard parts in the Multi-site, as the parts do 
not reside in the vault

Recommendation

Although there are advantages and disadvantages to each approach, the most effective way to handle standard parts is in a revision-
managed fashion even if no new revisions are generated for the standard part.



 Assigning a Dedicated Class for Standard Parts 

The SMARTEAM administrator can assign either standard part class or distinguished standard parts by attributes. The following table 

summarize of advantages and disadvantages of both methods.

Standard part class 

Advantages Disadvantages 

Lifecycle rules can be set differently for standard parts to support 
company rules Cannot transfer regular parts to standard parts 

To avoid unauthorized modification, authorization can be applied 
for standard parts  

Visualization by icon in the SMARTEAM tree for standard class part  

Attribute based standard parts 

Advantages Disadvantages 

Any type of part can be transferred to a standard part Cannot define Lifecycle rules for standard parts 

 No authorization for standard parts

 No visualization in the SMARTEAM tree

Recommendation

Currently, it is recommended to use the standard parts class to be able to define lifecycle rules for standard parts.

 

File Control Mechanism
In some cases, objects in certain classes are not file-managed, for example, folders in the documents tree. Removing the file control 

mechanism from a superclass and assigning file control to relevant classes only may have serious performance implications. 

Recommendation

To ensure good performance for the CATIA integration, it is highly recommended that file management is defined at the super-class 

level. This should also be done for classes in your Documents super class, that do not manage any files. (These classes will not have any 

file attributes filled and the attributes will not be shown on the profile card). 

How to define the File control mechanism 

1.  In the Data Model Designer, set the File Control class mechanism for the Documents super class.



The SMARTEAM - CATIA integration allows the creating of distinct objects for internal components in CATIA Product, and sheets in CATIA 
Drawing. In some cases, sheets and internal documents do not need to be managed separately.

Recommendation

Unless there is a specific need to manage internal components and/or drawing sheets as distinct objects, it is recommended to disable 

creating objects. 

How to disable creating objects for internal components and drawing sheets

1.  Using the System Configuration Editor, set CATIA.ExposeMode to FALSE.

2.  Disable the CFO mechanism for CATIA Product and CATIA Drawing file types as follows: in SmarTeam, select Tools-

>Applications Setup.

This displays the Application Tools window:

3.  For CATIA Product and CATIA Drawing file types, click the Tools button.

4.  From the dialog box that appears, click Modify.

5.  From the Update dialog box that appears, click the Advanced Setup tab and just unselect Enable CFO for life cycle operations 

to disable the CFO mechanism for CATIA Product and CATIA Drawing file types.

Working with Sheets and Internal Components 





Data Model Considerations: Defining Attributes

This page deals with attribute sizes and provides information on the TDM_CAD_DIRTY_FLAG Attribute. For 
information about classes, refer to Data Model Considerations: Defining Classes.

 

Attribute Sizes 
The size of certain attributes in the system is critical. The methods your company uses for file naming may 

require fine-tuning of these attribute sizes. 

File names and directory path attributes (FILE_NAME, DIRECTORY, CAD_REF_FILE_NAME, 

CAD_REF_DIRECTORY) must be long enough to store data about your files. If the field size is too small, the 

system may fail to function properly. 

However a long field size influences the performance in a negative way, so try to find an optimum solution. 

Examine the naming conventions and directory structure that the users will be using carefully before deciding 

the field size for file-managed attributes. 

TDM_CAD_DIRTY_FLAG Attribute 
The dirty flag attribute is assigned automatically to all classes that are defined as file-managed. Existing 

customers should check that the TDM_CAD_DIRTY_FLAG exists in their system, and that it is used in the 

Integration Tools Setup as shown below. 



For large assemblies, dirty flag mapping increases the SMARTEAM save time in CATIA, in cases in which some 

components were not modified. 



Importing CATIA Data Inside SMARTEAM

This task shows you how to use the Bulk Loading command which allows you to save a large number of files in the database. The advantages 
of this are as follows: 

●     The save operation is quick.

●     Links between documents are kept.

●     The attribute mapping mechanism is used during the save operation.

●     Only a limited number of user interactions are required regardless of the number of files.

You are already connected to SMARTEAM.

1.  In your CATIA session, Select SMARTEAM->Bulk Loading...

2.  In the Bulk Loading dialog box that appears, multi-select the files you want to save.

3.  Click on Open.

4.  In the Project Manager dialog box that appears, select the project with which you wish to associate the selected files: 



5.  Click Save. 

The operation you have just launched is in fact a batch mode save. A progress bar appears showing the number of files still to be 

processed and the estimated time required for completion. If no problem is encountered during the save operation, the following 

message is displayed: 

Should any problems arise during the save operation such as: 

❍     a document that cannot be opened in CATIA

❍     no file-type integration can be defined

a dialog box appears, showing the status: 



6.  Once the operation is completed a dialog box appears showing you what documents have been saved and what links exist between the 

different documents: 

Once your documents have been correctly saved you can: 

●     subsequently retrieve them without any difficulty as they are located in a single project or folder

●     apply a lifecycle operation to all of them.



Customizing the Bulk Loading Command

You can customize the Bulk Loading command as explained in Customizing the Bulk Loading Command.



SMARTEAM Upgrade/Migration

This section provides operational instructions for updating the CATIA-SMARTEAM system when used with Oracle databases on Windows 
machines. It covers migrations from releases that are still supported by the vendors to the newest ones or intermediate ones, ranging 
today from SMARTEAM V4.0.5.5/CATIA V5R9 to CATIA/SMARTEAM V5R13 or R14.

Compatibility Matrix

This simplified compatibility matrix corresponds to recommended configurations. It assumes that for each release, the last service pack is 
used.

  2002 2002 2003 2003 

CATIA V5R9 V5R10 V5R11 V5R12 

SMARTEAM V4.05.5 V5R10 V5R10/R11/R12/R13 V5R10/R11/R12/R13/R14 

ORACLE 8.1.6+ (for ST V4.05.5) 8.1.6+ (for ST R10) 8.1.7+ (for ST R11) 8.1.7+ (for ST R12) 

OS WIN 2000 (for ST V4.05.5) WIN 2000 (for ST R10) WIN 2000 (for ST R11) WIN 2000/3
(for ST R12) 

 

  2004 2004 2005 

CATIA V5R13 V5R14 V5R15 

SMARTEAM V5R11/R12/R13/R14   V5R12/R13/R14 V5R13/R14 

ORACLE 9.2 (for ST R13) 9.2 (for ST R14) 9.2 (for ST R14) 

OS WIN 2000/3
 (for ST R13) 

WIN 2000/3 
(for ST R14) 

WIN 2000/
 (for ST R14) 

Reference documents

The following reference documents provide more information about the different topics of the procedure described here. You can access 
them on the SMARTEAM documentation which is available on GA CDs or in SMARTEAM. 

●     Oracle Installation

●     Oracle Fine Tuning for SMARTEAM Implementers

●     SMARTEAM Hardware and Software requirements 

●     SMARTEAM Releases upgrade & What's New documents 

Steps to follow

Depending on your present configuration and the targeted one for the update you will need to apply the migration tasks related to CATIA, 
SMARTEAM and possibly Oracle. If so, the Oracle update is the first step to perform (See Oracle Migration) . CATIA software update is not 
so critical, we recommend to install the targeted release just after Oracle Migration, and then to continue with SMARTEAM update (See 
SMARTEAM Migration) . If you install CATIA R12 you will have advantage to proceed to the files update to take full benefits of this release. 
This is explained on the last paragraph, as the last step to perform.
The tasks described are as the following ones:

●     Oracle Migration 

❍     Export the SMARTEAM database to a dump file 

❍     Create the new database 

❍     Import the SMARTEAM dump file to the new database

●     SMARTEAM Migration 

❍     V5R10+ specific upgrade

❍     V5R11+ specific upgrade

❍     V5R12+ specific upgrade

 



❍     V5R13+  specific upgrade

❍     Post-activities

Time critical points

These tasks are time-consuming activities and are given with typical delays: SMARTEAM automatic database upgrade: about 2 hours for 
10000 Db objects. Test the expected delay with your data, because this depends of the files and the database complexity. Then schedule 
your production migration taking these constraints into account.

Prerequisites

1.  SMARTEAM scripts are written using COM SMARTEAM API, API functions and low-level database objects used are still supported 

(see appendix of upgrade documents). 

2.  LUM licenses for SMARTEAM are available through server or node-locked. 

3.  Check-in all in-work files in the vault. 

4.  Disconnect all clients from SMARTEAM Servers. CATIA should be used in local during this migration period 

5.  Up to date Production database, SMARTEAM directory, and vaults are backup. 

6.  Apply first the following procedure to a test environment (including database and vaults) that is a copy of the production one. 

7.  Modify the test database to point to the test vaults (use Vault Server Setup utility). 

Oracle Migration

The chosen update procedure consists of installing the totally new database on another directory on the server, and then migrating the 
data from the former database to the new one. The old database should be deleted only at the end of the migration process. This method 
allows us to go directly to V9.2 when coming from v8.1.6.

To migrate the data, we choose to use the standard Export and Import mechanisms of Oracle.

Export the SMARTEAM database to a dump file

Oracle Setting for data management

1.  First verify that Oracle Enterprise Management Tools are installed.

2.  Verify the Oracle Management Server service is running under a user who is granted the Log On as a service right.

3.  Run Oracle Enterprise Manager Console.

4.  Set System/Preferences/Preferred Credentials user for your database or default value for Node Service Type. 

The user should be the same as the one declared to run the Oracle Management Server service. It must have the right to the 

directory where the file you want to import resides. User information should be entered without domain information.

Export Operation

1.  Right-click Database / Data Management/ Export.

2.  In the Export File window, set the dump filename you want to export to.

3.  In the Export Type window, select Table.

4.  In the Table selection Window, click on the user that host the current SMARTEAM schema, and select all tables under him.



5.  In the Associated Objects window, disable Indexes on Tables.

6.  In the schedule window, run the job immediately then finish.

7.  Verify on the job window the status of the job. Wait for it to be completed.

For further information on exports, refer to SMARTEAM - Editor Administration Guide.

Create the new database

1.  Install the software components of the new Oracle database engine. Refer to the instructions of the Oracle Installation Guide 

provided in the SMARTEAM documentation. If you change the block size as recommended from 8 to 4096, do not forget to change 

the units too: Kbytes to bytes.

2.  Create a new database following the instruction of the same guide.

3.  Create a user to host the schema of the SMARTEAM data (Go to the Security tab). Grant him the Resource role. Assign it the same 

table space as that used in the previous database.

4.  Verify that you can access this newly created database by using the SmartDBExplorer utility. This database is empty at this point.

Import the SMARTEAM dump file to the new database

Oracle Setting for data management

Apply the same setting that the ones explained in the export paragraph (see Oracle Setting for data management)

Import Operation

1.  Right-click database->data Management->Import.

2.  In the Import File window, Set Dump directory and filename. 

3.  Read Import File and select what objects you want to import.

4.  In the Import Type window, select Table.

5.  In the Tables selection window, select all tables from the shown user.

6.  In the User mapping window, map old user with the new one.

7.  On the Associated objects, disable indexes import.

8.  On the schedule window, run job immediately, then finish.

9.  Verify on the job window the status of the job. Wait it to be completed.

10.  Create New Database registration for the new database using DBRegistration.exe in the bin folder of your SMARTEAM directory.

11.  Repair DB indexes using SmartDBRepairing. Apply Indices Repairing.

12.  Open the new database with SMARTEAM and verify that all is OK.



SMARTEAM Migration

Each specific release upgrade procedure is not cumulative. It means that if you are running SMARTEAM V4 and plan to migrate to V5R12, 
you have to apply R10 specific task, R11 specific tasks then R12 specific tasks. One chosen client machine will be dedicated to these 
migration tasks.

V5R10+ specific upgrade

We assume that your current version of the SMARTEAM database is at least 4.0.3, look at the TDM_DB_UPGRADES and 
TDM_DB_VERSION tables to check this point with the SmartDBExplorer utility. 

Product Installation

1.  Install R10 GA on the identified upgrade machine (Select Editor Installation).

>What you' need to check 

Case 0, you're using PartNumbers to localize documents (CATIA_TEAMPDM_UUID=NO in environment variables) 

If CATIA_TEAMPDM_UUID=YES in your environment variables or does not exist at all, launch SMARTEAM data model designer

1.  Do File / Modify database structure and choose your database.

2.  Go to Define class attributes and indexes.

3.  Check the fields below CATIA class.

Case 1, Feature ID does not exist below this class. 



Case 2, the Feature ID has existed below CATIA class

or even below since you began to use the CATIA Integration (ie your database has always been designed like that):

What you' need to do 

Case 0

In this part, we will delete the CATIA component unique identifier (UUID or Feature ID, named CN_FEAT_ID in the database) from all 
CATIA classes. And map this again to CATIA class to delete all the records to PartNumbers.

1.  Launch the SMARTEAM Data Model Designer.

2.  From the File menu, select the Modify Database Structure option and choose your database. Then Go to the Define Class 

Attributes and Indexes. Identify all CATIA Classes where the Feature ID attribute appears (e.g., CATIA Product, CATIA Internal 

Component, CATIA Drawing, CATIA Sheet).

3.  Remove now the CN_FEAT_ID attribute from any of the previously selected  classes.

4.  Recreate this attribute directly on the Documents super class (Name = CN_FEAT_ID, type = char, length = 127, Display Name and 

Description = Feature ID) 

 

5.  Click on Create to save the changes to the database.

6.  Concerning the drawings, check if CATIA Sheet class exists. If not ensure that CATIA Drawing class supports CATIA Sheet class 

behavior and that you have the EXPOSEMODE=NO in CATIA section of SmTeam32.ini.

7.  Concerning the drawings, verify the existence of the two attributes:

CN_SHEET_NAME ( type = char, length = 127, Display Name and Description = Sheet Name ) and CN_SHEET_FORMAT (type = 

char, length = 20, Display Name and Description = Sheet Format) under the CATIA Sheet class or under the CATIA Drawing class 

if the CATIA Sheet class doesn't exist. 



8.  In the Integration Tools Setup, select CATIA / Mapping group types / Special Attributes.

9.  Create or modify the following mapping: Additional Identifier with CATIA-Feature ID (Class = Catia, Attribute = Feature ID). 

Enable update of SMARTEAM.

10.  Modify or create now the mappings relative to the new drawing attributes: 

Catia CN_SHEET_NAME with SMARTEAM CN_SHEET_NAME and Catia CN_SHEET_FORMAT with SMARTEAM CN_SHEET_FORMAT in 

CATIA / Mapping Group Types / CATIA Sheet (or CATIA Drawing if CATIA Sheet class doesn't exist). For these mappings, enable 

update of SMARTEAM.

Case 1

In this part, we will transfer the CATIA component unique identifier (UUID or Feature ID, named CN_FEAT_ID in the database) from the 
CATIA leaf classes to the Documents superclass. And map this to CATIA class.

1.  Launch the SMARTEAM Data Model Designer.

2.  From the File menu, select the Modify Database Structure option and choose your database.

3.  Then go to the Define Class Attributes and Indexes. 

4.  Identify all CATIA Leaf Classes where the Feature ID attribute appears (e.g., CATIA Product, CATIA Internal Component, CATIA 

Drawing, CATIA Sheet). 

5.  For each of these classes note the table name  (it is indicated on the right dialog box, typically, TN_CATIA_PRODUCT, 

TN_CATIA_DRAWING, TN_CATIA_SHEET).

6.  Apply the following SQL statements for each of the selected tables (Launch your SQL command Interpreter (e.g. SQL + ), and type 



or copy and paste the following text , replacing table_name by the actual table name, if necessary replace also the table name of 

the Documents super-class here TN_DOCUMENTATION by the actual one):

ALTER TABLE TN_DOCUMENTATION ADD CN_FEAT_ID_TEMP VARCHAR(127); 

CREATE VIEW MY_VIEW AS SELECT TN_DOCUMENTATION.OBJECT_ID, CN_FEAT_ID_TEMP, CN_FEAT_ID FROM 
TN_DOCUMENTATION LEFT OUTER JOIN table_name ON TN_DOCUMENTATION.OBJECT_ID = table_name.OBJECT_ID; 

UPDATE MY_VIEW SET CN_FEAT_ID_TEMP = CN_FEAT_ID WHERE CN_FEAT_ID IS NOT NULL; 

DROP VIEW  MY_VIEW; 

7.  Coming back to the Data Model Designer, remove now the CN_FEAT_ID attribute from any of the previously selected  classes.

8.  Recreate this attribute directly on the Documents super class ( Name = CN_FEAT_ID, type = char, length = 127, Display Name 

and Description = Feature ID ) 

 

9.  Click on Create to save the changes to the database.

10.  To finish this UUID migration, type the following statements in SQL+ 

UPDATE TN_DOCUMENTATION SET CN_FEAT_ID = CN_FEAT_ID_TEMP; 

ALTER TABLE TN_DOCUMENTATION DROP COLUMN CN_FEAT_ID_TEMP ; 

11.  Concerning the drawings, check if CATIA Sheet class exists. If not ensure that CATIA Drawing class supports CATIA Sheet class 

behavior and that you have the EXPOSEMODE=NO in CATIA section of SmTeam32.ini.

12.  Concerning the drawings, verify the existence of the two attributes 

CN_SHEET_NAME ( type = char, length = 127, Display Name and Description = Sheet Name ) and CN_SHEET_FORMAT (type = 

char, length = 20, Display Name and Description = Sheet Format) under the CATIA Sheet class or under the CATIA Drawing class 

if the CATIA Sheet class doesn't exist. 

13.  In the Integration Tools Setup, select CATIA / Mapping group types / Special Attributes.



 

14.  Create or modify the following mapping: Additional Identifier with CATIA-Feature ID (Class = Catia, Attribute = Feature ID). 

Enable update of SMARTEAM.

 

15.  Modify or create now the mappings relative to the new drawing attributes: 

Catia CN_SHEET_NAME with SMARTEAM CN_SHEET_NAME and Catia CN_SHEET_FORMAT with SMARTEAM CN_SHEET_FORMAT in 

CATIA / Mapping Group Types / CATIA Sheet (or CATIA Drawing if CATIA Sheet class doesn't exist). 

16.  For these mappings, enable update of SMARTEAM.

Case 2.

1.  Launch the SMARTEAM Data Model Designer.

2.  From the File menu, select the Modify Database Structure option and choose your database.

3.  Go to the Define Class Attributes and Indexes window and from the CATIA class, check if CATIA Sheet class exists. If not ensure 

that CATIA Drawing class supports CATIA Sheet class behavior and that you have the EXPOSEMODE=NO in CATIA section of 

SmTeam32.ini.

4.  Concerning the drawings, verify the existence of the two attributes:

CN_SHEET_NAME ( type = char, length = 127, Display Name and Description = Sheet Name ) and CN_SHEET_FORMAT (type = 

char, length = 20, Display Name and Description = Sheet Format ) under the CATIA Sheet class or under the CATIA Drawing class 

if the CATIA Sheet class does not exist. 

5.  In the Integration Tools Setup, select CATIA->Mapping group types->Special Attributes.

6.  Modify or create now the mappings relative to the new drawing attributes: Catia CN_SHEET_NAME with SMARTEAM 

CN_SHEET_NAME and Catia CN_SHEET_FORMAT with SMARTEAM CN_SHEET_FORMAT in CATIA / Mapping Group Types / CATIA 



Sheet (or CATIA Drawing if CATIA Sheet class doesn't exist). For these mappings, enable update of SMARTEAM.

V5R11+ Specific upgrade

If you already are running V5R11 or a more recent version, skip this paragraph and go directly to the V5R12 specific upgrade.

Product installation on the upgrade machine

1.  Install R11 standalone and administrative tools (select Editor Installation)

2.  Install last available service pack (at least SP8)

3.  Install SmartDBUpgradeV5R11SPx from your Kits\SmartDBUpgrade folder of your service pack disk.

4.  Install SmartDBRepairingV5R11SPx from your Kits\SmartDBRepairing folder of your service pack disk (at least SP8, oracle issue 

with previous releases)

Automatic Database upgrade

Once R11 upgraded the database schema will be compatible with R12 as well as with R13.

Prepare ini files

1.  Copy the reference SMASSCLS.INI to the SMARTEAM directory of the upgrade machine.

2.  Copy the reference SmTeam32.ini file to the LocalConfig folder of the SMARTEAM directory of your upgrade machine. This file is 

the relevant merge of admin and client files. Include also the [Tree-VisualSetting] section of the reference user ini file (located in 

the LocalConfig\[db]\[username] subfolder)

3.  If you use customized integration for specific files, register these files in the [AdditionalFileTypes] section of the 

UpgradeSmartDatabase.ini file located in the SMARTEAM LocalConfig directory by specifying corresponding CAD Component Type. 

Add a line under the section using this convention:

Customized File Type = CAD Component Type

NB: the list of all available component types may be found in the Integration Tool Setup, and correspond  to the class behaviors of 

the Data Model designer, while Customized File Type is a custom entry of the SMARTEAM File Type lookup table.

Oracle server temporary Tuning for upgrade

1.  Check the database for compliance with the memory specifications in the Oracle Fine Tuning for SMARTEAM Implementers Guide.

2.  Set SORT_AREA_SIZE = 524288 (for 8.1.7) (Instance / Edit Database / General / Initialization Parameters

3.  Turn ARCHIVE mode OFF.

4.  Check that your SMARTEAM related tablespace and SYSTEM tablespace have at least 40% free space. The TEMP tablespace must 

have at least 100 MB. Check you have sufficient disk space on the database server.

5.  Type In SQL+ as SYSTEM ( TABLESPACE_NAME is the name of your SMARTEAM related tablespace): 

 ALTER TABLESPACE TABLESPACE_NAME NOLOGGING 

6.  In SQL+ as a SMARTEAM user, set the following statement: 

spool c:\nologging.sql 



select 'ALTER TABLE '||TABLE_NAME||' NOLOGGING;' from USER_TABLES; 

spool off 

@c:\nologging; 

/ 

Automatic upgrade of the database

1.  Launch UpgradeSmartDatabase.exe from the Upgrade folder of your SMARTEAM directory. Warning: this step may be more than 

one hour long.

Oracle server tuning after upgrade

1.  Type In SQL+ as SYSTEM (Where TABLESPACE_ NAME is your SMARTEAM related database tablespace) 

ALTER TABLESPACE TABLESPACE_NAME LOGGING; 

2.  In SQL+ as a SMARTEAM user, set the following: 

spool c:\nologging.sql 

select 'ALTER TABLE '||TABLE_NAME||' LOGGING;' from USER_TABLES; 

spool off 

/ 

3.  Turn ARCHIVE mode ON if necessary. 

Indices repairing

1.  Perform now SmartDBRepairing.exe from your bin folder of your SMARTEAM directory, choose indices Repairing.

WizSrc Upgrade

1.  Run SMARTEAMWizSrcUpgradeWizard.exe from the upgrade folder of your SMARTEAM directory.

Registering Files out of the vault

This step is only needed if you use File control-classes that are not revision managed or if you performed the migration with remaining 
new or checked out files (which was not recommended)

1.  In the SmTeam32.ini file located in <SMARTEAM>\LocalConfig\<database>\SmTeam32.ini, add the following entry:

[Migration]

ImportStandardParts=TRUE

2.  Ensure that the Administrator has read-write permissions in the area where the files of non-revision managed object reside.

3.  Administrator should log into SMARTEAM, the file catalog is created then once. This may take some time, depending on the 

number of files.

Viewer Setting and CGR generation



Change the file type to be viewed for CATIA Part and CATIA Product classes.

1.  Select SMARTEAM->Tools->Applications Setup.

2.  From the Applications Setup window that is displayed, select CATIA class.

3.  Click on Tools.

4.  Click the Embedded Viewer tab.

5.  Select Modify.

6.  Replace .CATProduct.hcg with .CATProduct.cgr.

Setting Update Rights to SMARTEAM users

Users need update rights to ensure that CATIA can upgrade TDM_COMPONENT_NAME on the fly when opening any CATIA document.

1.  Launch Users Maintenance.

2.  Click the Authorization icon.

3.  For users likely to use CATIA documents, set update rights for all states on CATIA documents. 

V5R12+ Specific Upgrade

If you are already running V5R12 skip this paragraph and go to V5R13 specific upgrade, otherwise:

Important note: if R12 is not your target release, but R13 is, the best is to apply the following with SMARTEAM R13 installed rather than 
R12.

Product Installation

1.  Install R12 core services on a server (dedicated or not) (select foundations).

2.  Install last available SP (currently SP6) on this server.

3.  Install R12 GA on the upgrade machine.

4.  Install last available SP (currently SP6) on this machine.

5.  Install SmartDBUpgradeV5R12SPx.exe from the kits\SmartDBUpgrade directory of the service pack CD (to run later Wizsrc update 

only)

Session Management Configuration

1.  On the server Run the Authentification Manager Utility (SMARTEAM \ bin \ SMARTEAM.Std.AuthenticationManager.exe), choose 

SMARTEAM Authentification protocol, check "Authentificate using the following database"  and select your database in the list.

NLS Configuration

1.  Verify that the reference tdmerror.err, tdmwizard.err, tdmvlsrv.msg are on the SMARTEAM root directory of the upgrade machine.

2.  Run the NLS Extractor Utility smartNLSextractor.exe from the upgrade machine (Note: Data will be extracted to XML files in the 

…\SMARTEAM\NLS\<language RFC id>\CUSTOM folder. For example <language RFC id> = fr for the French language. For further 

information on RFC codes, and the official list of language codes, refer to: http://www.oasis-open.org.



3.  Copy the NLS folder created by the NLS Extractor Utility (located under SMARTEAM) to the Core Services Server.

4.  Define the copied folder as Shared for Read/Write access for all users of SMARTEAM products.

5.  In the System Configuration Utility, update the location of the <rootPath> key for the copied NLS folder, located in: 

\SMARTEAM\ConfigurationSettings\Data\Domain\SMARTEAM.std.nls.xml to point to the NLS folder of the core services server.

WizSrc Upgrade

This step is optional if your target release is R13 and not R12.

1.  Run SMARTEAMWizSrcUpgradeWizard.exe from the Upgrade Folder of your SMARTEAM directory.

V5R13+  specific upgrade

Product Installation

1.  Install R13 core services on a server (dedicated or not) (select foundations).

2.  Install last available SP on this server.

3.  Install R13 GA on the upgrade machine.

4.  Install last available SP on this machine. 

5.  Install SmartDBUpgradeV5R13SPx.exe from the kits\SmartDBUpgrade directory of the service pack CD (to run later Wizsrc update 

only).

System Configuration

1.  Get the reference configuration files and put them on the upgrade machine:

SmTeam32.ini - genrep.ini - ServerSafeScripts.ini - SmarDESK.ini 

SmartDbExplorer.ini - SmartQuickReport.ini - SmERPSyncServer.ini 

Smupgsrc.ini - Smvlt32.ini - SMWIZA32.INI - SmWorkFlow.ini 

Note 1 :If you are using both administrator and client SmTeam32.ini, merge the two on one single reference file.

Note 2 : The user specific configuration will be automatically migrated on first user log-on. 

2.  Upgrade the system configuration using the Configuration migration wizzard.

3.  Verify the migration with the Configuration Manager Editor (Start \ Program Files \ SMARTEAM \ Administrator Tools). 

WizSrc Upgrade

1.  Run the SMARTEAMWizSrcUpgradeWizard.exe.program from the Upgrade folder of your SMARTEAM directory.

Web Editor

The user-defined configuration in Web Editor must be redefined manually in R13

Web Viewer/Markup monitor



Uninstall then reinstall these components.

Post-activities

Deployment

1.  Upgrade now all server and client machines by installing all pre-installed products of your SMARTEAM target release.

2.  Install on all SMARTEAM machine the last available service pack.

Verifying functionality

1.  Check CAD Integration existing and new objects with links, including drawings, large assemblies, parts within assembly and single 

parts,  design tables - 

2.  Check Data Model Designer, browse your updated database schema.

3.  Check Sequence Designer, create and test new objects that uses sequences.

4.  Check user scripts functionality.



Methodology
Methodology and conceptual information on the following topics are provided in this section.

Concurrent Engineering
Enriched Decision Support with All V5 Links

CATIA Workbenches Integration
The User Working Area



Concurrent Engineering
SMARTEAM - CATIA Integration facilitates working concurrently. This section discusses the different tools 
provided to help you work in a collaborative environment.

Tools For Working in a Concurrent Engineering Environment
Using Global Refresh

Keeping the Integrity of Vaulted CATIA Documents

 



Tools For Working in a Concurrent Engineering 
Environment

 

 

 

 

 

 

 

 

SMARTEAM - CATIA Integration facilitates working concurrently. This is performed by:

●     displayed information:

❍     non-latest revision status

❍     modified and read-only status

●     operations:

check-out on the fly

Thus, working concurrently is easier:

●     by promoting:

❍     the opening of documents without any check-out (View)

❍     the check-out using the CATIA SMARTEAM->LifeCycle->Check-Out command or by means 

of a check-out on the fly

❍     the use of the Refresh command (to update the Product Structure and Desk tree icons)

❍     the use of the Global Refresh command (to reload the latest versions of documents from the 

SMARTEAM database).

●     through easy access to the Product Structure tree and, in File Desk, to the read-only and 
modified status. 

Displayed Information

Non-Latest Revision Status

If a document is opened in CATIA with a revision that is not the latest, the SMARTEAM information is 
displayed in the Product Structure and File-Desk trees.

Modified and Read-Only Status

If a check-in or release document is opened in CATIA and is modified, a specific icon mask is 



displayed in the CATIA Product Structure and File Desk trees.

Operations

Tree Refresh

The CATIA SmartTeam->Tools->Refresh command  updates the Product Structure 
and File Desk icons with regard to SMARTEAM information.

This is particularly useful for concurrent engineering. For instance, if you are using checked-in parts 
within their assembly, you can use the Tree Refresh command to check whether its loaded parts 
correspond to the latest revision. Another user may have performed a check-out, modifications and a 
check-in while the first user is still using the old file revision.

The Tree Refresh capability updates the display of icons representing documents in the specification 
tree, not your session, contrary to the Global Refresh capability.

Check-Out on the Fly

After an initial modification on a checked-in or released document, a window is displayed asking you 
if you want to perform a check-out on the fly operation. This functionality enables you to perform 
check-outs only when necessary and thus contributes to concurrent engineering.

 



Check out on the fly windows displays SMARTEAM information as set in the Tree Properties dialog 
box. For more information, see Customizing SMARTEAM Document Display Information.

Global Refresh

The Global Refresh capability enables design engineers to update their CATIA sessions to reflect the 
latest versions of the documents as saved in the SMARTEAM vault.



Using Global Refresh  

In most enterprises, design engineers work concurrently to design their products. Working concurrently often means that they are 
responsible for subassemblies which they will all gather later on to constitute their final assembly. 

Some designers need to reference to the latest documents available they are not responsible for. In fact, a certain number of these 
documents will be delivered by other designers in real time.

Because they need to benefit from the most recent versions of these documents, SMARTEAM CATIA Integration provides a 
dedicated tool to help them work in a collaborative environment: the Global Refresh capability enables them to update their 
CATIA sessions to reflect the latest versions of the documents as saved in the SMARTEAM vault. Among the benefits provided by 
this new tool is a significant rework costs reduction.

The following illustration shows when a Global Refresh Operation is to be performed:

 

 In this section, you will find the following information:

●     Basic Concepts

●     How to use Global Refresh

●     After a Global Refresh

●     Note

Basic Concepts

Global Refresh ensures that all the documents in the CATIA session are having the latest available revisions in SMARTEAM 
database. The tedious process of manually managing the documents in the session is made one click away, which saves efforts and 
improves efficiency by reducing risks arising due to human interaction.

To take full advantages of Global Refresh, you should keep in mind that the capability enables you to update your session provided 
that the latest revisions of documents are placed in the vault. 

For example, if a member of your team is modifying a document he/she checked it out, performing a Global Refresh in your CATIA 
session containing a reference to that document, proves useless as long as the modified document is not placed back in the vault 
via a Check out or New Release operation. Once you are informed thru the red dot on the document's icon that your document is no 
longer the latest one, you just have to wait for the user to check in or release the document. Then, at that point, you will be able to 
perform a successful Global Refresh.



How to Use Global Refresh

The scenario below provides the necessary steps to follow to perform a Global Refresh operation. It assumes that the assembly 
displayed in your CATIA session is made of different sub-assemblies, some of which were modified by other members of your team 
and then checked-in in SMARTEAM. You want your session to contain the most recent versions of these documents.

1.  Prior to running Global Refresh, take a closer look at the icons in your specification tree .

There are two possible displays:

❍     Dedicated icons indicate that some documents are no longer up-to-date. 

or

❍     apparently, your session is up-to-date, but because you need to be sure of that, you prefer to Refresh that display. To 

do so, just select SmartTeam->Tools->Refresh . For more information, refer to Tree Refresh.

At this point, you know that your session does not use the latest revisions of all of your documents and therefore you decide 

to refresh it to reflect the changes made by other users.

2.  Click the Global Refresh  icon or select SMARTEAM -> Collaboration-> Global Refresh.

The Global Refresh dialog box is displayed.



Action

The Action column displays the different operations that will be performed for each document. These operations can be:

None

 

The document in the current CATIA session is the latest and no modifications are done on it. So, no 
action is required on this document.

Note: Though the action is None, sometimes, it may require to Check Out the document. For 
example, the Product document is identical in CATIA session and SMARTEAM. But since the child 
part document is updated, the product needs to be checked out to save the modifications in 
SMARTEAM.

Refresh
 More recent revision is available in the SMARTEAM database than that present in the current CATIA 

session. So the document will be refreshed with the available latest revision from the database.

Reload

 

The more recent revision of the document is available in the shared workspace than that present in 
the current CATIA session. So the current document will be reloaded with the latest revision of the 
document from the shared workspace. This typically happens when two or more designers are 
modifying the same document. Reload action is not related with SMARTEAM. Currently, it supports 
only those documents that are stored in SMARTEAM.

Documents you can reload 

Global Refresh enables you to reload CATPart, CATShape or CATProduct documents imported inside CATProduct 
documents. The following documents cannot be reloaded from SMARTEAM database:

❍     MODEL, cgr or multiCAD referenced document,

❍     CATPart pointed by a CATPart (i.e. Ref link), 

❍     Design Tables, CATMaterial documents, jpeg files (referenced by a CATPart or CATProduct document)

Part Number

The Part Number column displays the Part number of the document

File Type

The File Type column displays the type of the document. This type can be:

Product For CATProduct document

Part For CATPart document

Shape For CATShape document

State

The State column displays the SMARTEAM state of the document. Following are the valid values for State: 

New The document is saved in SMARTEAM. No Life Cycle operation is performed on it.

Checked In The document is in Checked-In state in SMARTEAM database.

Checked Out The document is Check-In in SMARTEAM database and is currently checked out for modifications.

Released The document is in released state in SMARTEAM database.

New Release The document is in New Release state in SMARTEAM database.

Obsolete The document is in obsolete state in SMARTEAM database.

Not in Database The document is not stored in SMARTEAM.



Revision in Session

The Revision in session column displays the SMARTEAM revision of the document present in the current CATIA session. 

Revision in Database

The Revision in Database column displays the latest available revision of the document present in the current CATIA session.

Unloadable State

The Unloadable State column displays the document state with respect to the CATIA session. Valid values are as follows:

Up-to-date  The document is up-to-date and does not need to be unloaded from the session.

Unloadable  The document is not the latest one and can be loaded in order to reload the latest revision of 
the document.

Modified  
The document needs to be unloaded but cannot be unloaded because it is under modification 
in the current session. To make it unloadable, you need to save the document. Otherwise, the 
document will be skipped from the refresh list.

Undo/Redo  
The document is present in the Undo log and Undo Redo mechanism hence cannot be 
unloaded. In order to make it unloadable, user has to clear the Undo log history. Otherwise, 
document will be skipped from the refresh list.

File Name

The File Name column displays the name of the document.

3.  Click More.

The dialog box expands and displays additional information on session documents requiring a particular attention.

 

Messages that can be displayed are as follows:

Msg Type Message

Error Document modified in Shared workspace, but not stored in SMARTEAM. Therefore it will not be taken 
into consideration during the Global Refresh operation.

Error Document modified or locked in session and cannot be unloaded from session. Therefore it will not be 
taken into consideration during the Global Refresh operation.

Information Document is going to be refreshed with the latest available revision

Warning Document new in assembly

Information Document does not exist in SMARTEAM database.

4.  Click Refresh to run the operation.

Once the operation is complete, the Global Refresh Report dialog box is displayed.

 



The Action column displays the results of the operation for each document concerned. These results can be:

None  No action was required on the document

Refreshed The document in the current CATIA session has been replaced with the latest available document in the 
SMARTEAM database

Reloaded The document in the current CATIA session has been replaced with the latest available document in the 
shared workspace.

State

The State column displays the new state of documents once the global refresh is complete.

Revision in Session

The Revision in session column displays the SMARTEAM revision of the document in the current CATIA session after the 

global refresh. For a SMARTEAM object, the value should be the same as the value in the Revision in Database column.

5.  Click More.

The dialog box expands and provides a report on the global refresh operation. Warning or error messages can be displayed.

When the operation is complete, the changes won't be saved automatically but then the command prompts for prompts for 

a Check Out on the fly operations. Performing the Check Out changes the revision if the product and this needs not to be 

saved.

After a Global Refresh
Once you have applied a Global Refresh to your CATIA session, you cannot undo the operation.

Note

When manipulating your documents in a collaborative environment, you should remember two key ideas:

●     The Global Refresh capability affects your CATIA session only.

●     To control the integrity of your data in SMARTEAM, when the CATIA specification tree indicates that one or more documents are 
"dirty", keep in mind that to make changes to the SMARTEAM database, you need to check-out and then perform a SMARTEAM 
save on the appropriate documents.

 

Action



Keeping the Integrity of Vaulted CATIA 
Documents

Because collaborative design frequently involves a large number of designers, it is important to ensure 
that the designer's team can share documents efficiently. 

Most of the time, sharing documents means that design team members reference each other's designs. 
Although they work on different parts of the final assembly, they need to be informed about the different 
versions of documents that gradually become available. This is particularly true when certain phases of 
design require that a large number of lifecycle operations is carried out.

Tracking Link Modifications

From V5R15 onward, each designer can track in their sessions link modifications resulting from lifecycle 
or replace with selected revision operations carried out by another member of the team. This is now 
made possible by CATIA which performs a document link analysis across revisions helping you verify 
version reliability. 

Concretely speaking, the gray read-only modified symbol  appears 

on documents' icons in CATIA specification tree whenever the status of these documents as shown in 
your CATIA session is not consistent with the SMARTEAM database contents. 

Displaying this type of information ensures that designers are informed that they need to perform check 
out operations to receive the most updated version of documents referencing sub-components.

Example

To better comprehend when the application behaves as explained above, suppose a CATIA session 
displays an assembly, Product1, which is made of two sub-components referencing the same part, Part1. 
When opening the assembly document, red dots on Part.1's icon indicate that this document is not the 
latest revisions available in SMARTEAM.

 The assembly displayed in CATIA The assembly displayed in SMARTEAM

 



 
To make SubProduct 1 points to the latest revision available in SMARTEAM, it is necessary to apply the 

Open For Edit command onto Product1.

This operation establishes a link between SubProduct 1 and the latest revision of Part1, restoring 

therefore the integrity of data in SMARTEAM. Once the checkout operation is complete, this is the 

database status, where you can notice that SubProduct 2 still points to an old version of Part 1:

Applying the Open for Edit command on Product 1 both checks out the document and opens it in 

CATIA. Only one revision of Part1 is loaded in CATIA (only one revision is located in the work directory): 

this is the last revision, that is Part a.1. Consequently, SubProduct2 a.0 is in a state different from the 

database one: In CATIA, SubProduct2 points to Part1a.1 whereas it points to Part1a.0. in SMARTEAM.

To warn the user of that difference, the application proposes a Check Out on the fly operation for 

SubProduct 2:

Accepting a Check Out on the fly operation allows to create a new revision of SubProduct2 pointing to 

Part1a1.

After performing the check-out operations, CATIA specification tree eventually shows that all products 

point to the latest revision of Part 1..



 

Not Performing the Check-out on the fly

In case the Check Out on the fly operation is not accepted, the read-only modified icon appears on 
SubProduct2 in CATIA specification tree. SubProduct2 will not be linked to the latest revision of Part.1 
until the user performs a checks out SubProduct2.

 

 

 Authorizing Check Out on the Fly

The ability for the user to perform a check-out on the fly is defined by the system administrator. For 
more information, refer to System Variables for CATIA and SMARTEAM.



Enriched Decision Support with All V5 Links 

Interdocument relations are part of the CATIA/DELMIA/ENOVIA V5 architecture. (There is a large number of 
documents and types of relations between these documents).
The native SMARTEAM integration of CATIA link semantics enables dedicated behavior on each link type:

●     easier navigation:

❍     link type display (icon)

❍     filter document relation filtering by link type

●     improved impact analysis capabilities

●     lifecycle rules

●     key operations:
Edit/Check-Out, View, Check-In, Release, New Release, Obsolete.

The benefits are as follows:

●     easier manipulation

●     fewer interactions

●     reduced data flow between vault & local disk

●     reduction of the file brought onto the local disk

●     facilitation of concurrent engineering.

Examples 

●     The view of a .catalog document will not bring onto the local disk the referenced Parts.

●     The edit of a CATAnalysis file will by default check-out and copy to the local disk the results (CATAnalysisResult 

& CATAnalysisComputation).

 



Enriched decision support is provided by means of the native SMARTEAM support of V5 links.

Here is the list of CATIA links natively supported in SMARTEAM:

●     Product Structure

●     Is Composed of

●     Design

●     Downstream Application

●     Contextual 

●     Design Table

●     Result

●     Rule Base

●     Reference

●     Product Structure link

The Product Structure link plays a part in the BOM structure. It is displayed as a standard hierarchical link.
Example:
CATProduct->CATProduct, CATProduct->CATPart, CATProduct->Internal Component...

 

 CATIA Links

The ability for the user to perform a check-out on the fly is defined by the system administrator. For 
more information, refer to System Variables for CATIA and SMARTEAM.



●     Is Composed Of link
 

The Is Composed Of link is an aggregation link but which plays no part in the BOM structure. It is displayed as a 

standard hierarchical link.

Example:
CATDrawing->Sheet, Catalog->catalog

●     Design link

The Design link plays a direct part in the design process.

Example:
copy-paste with link & import link (CATPart->CATPart, CATPart->model), link to external parameters (formulas), 
MultiCAD links (CATProduct/CATPart->MultiCAD document) etc.

●     Downstream Application link

The Downstream Application link is a link between a downstream application and the design data

Example:
CATDrawing->CATProduct/CATPart, CATProcess->CATProduct/CATPart, CATAnalysis->CATProduct/CATPart



●     Contextual link

The Contextual link is a link between the contextual Part and its product context (CATPart->CATProduct).

●     Design Table link

The Design Table link is a link between a CATIA document and its design table (Excel or text file).

●     Result Link

The Result link corresponds to CATIA output links:

Example:
CATAnalysis->CATAnalysisResult, CATAnalysisComputation...
CATProcess->NC (aptsource, CATNCCode, tlp)
CATProcess documentation link (html)
Knowledge optimization link (CATIADocument->excel/text)

●     Rule Base link

The Rule Base link describes a link between an instance of a rule base and its reference.

●     Reference link

The Reference link includes all the CATIA links which do not correspond to the other eight link types:

Example:
CATDrawing->Image/OLE
CATProduct/CATPart->CATMaterial
CATProcess->NC Manufacturing Part (CATPart)



The impact analysis can be performed by displaying the links of a given object.
You can decide to display/filter CATIA links within SMARTEAM by means of  the SMARTEAM Tree Properties 
command. For more information, refer to Customizing the Links Display. 

Display Impact



CATIA Workbenches Integration 
Intended to design engineers, this section provides the methodology for working with data specific to certain 
CATIA workbenches. The following topics are illustrated:

Accessing CATIA Catalogs
Accessing Sheet Metal Bend Tables

Creating a Mass Parameter in the Generative Sheet Metal Workbench
Handling CATAnalysis Documents

Instructions for system administrators are described in the CATIA Workbenches Integration chapter of the 
Administration Tasks.



Accessing CATIA Catalogs

Design engineers who need to instantiate catalog components (parts, products, V4 model etc.) can 
access their catalogs using one of the following methods: 

●     Searching in the Shared Directory defined by your librarian

●     Searching in the SMARTEAM Vault

Searching in the Shared Directory

Because most of the time catalogs include massive data, we recommend librarians to set create 
shared directories. Searching in the Shared Directory therefore is the method we recommend for 
accessing catalogs. 

1.  To search for your catalog in a shared directory, click the  Catalog Browser  icon.

Available in several CATIA workbenches, the Catalog Browser provides interactive commands 

to browse catalogs and lets you instantiate components.

2.  If the default catalog displayed in the Catalog Browser is not the one you are searching for, 

depending on how your administrator configured your CATIA session:

❍     click the Browse another catalog icon  to open the File Selection dialog box that 
enables you to navigate to the shared directory containing your catalog.

❍     or from the Browse dialog box, click the File icon  to open the File Selection dialog 
box.



3.  From the File Selection dialog box, navigate to access the shared directory.

4.  Open the document of interest.

Using this method, the CATIA Product creates a reference to Standard CATIA Parts in the 

shared workspace. 

For information about shared directories, refer to Creating and Saving a Catalog. To get 

precisions about instantiating catalog components, refer to the Component Catalog Editor 

User's Guide.

Searching in the SMARTEAM Vault

Searching in the SMARTEAM Vault is an alternative way of accessing catalogs. Although we do not 
recommend this method, we comment it for users who need to work in nomad mode.

1.  Click the Catalog Browser  icon.

2.  Perform a SMARTEAM query: just click the SMARTEAM Query  icon from the Browse 

dialog box.

Depending on on how your administrator configured your CATIA session, the File Selection 

dialog box may appear. In this case, just click the Cancel button to close it and enable the 

SMARTEAM Query capability in the Browse dialog box.

3.  Open the document of interest.



The CATIA Part will be copied into your working directory and the CATIA product in your 

assembly session will reference it. However, once the CATIA Product is checked-in into the 

SMARTEAM vault, the next time you retrieve a CATIA Product into the working directory (check 

out operation), standard CATIA Parts will not be copied into your working directory and will not 

be referenced to the shared workspace.



Accessing Sheet Metal Bend Tables

While creating Sheet Metal parts as explained in the Generative Sheet Metal User's Guide, design engineers need to use bend 
tables defined for their companies. This task shows how to access them.

1.  Once in the Sheet Metal workbench , from the Browse dialog box, click the File icon  to open the 

File Selection dialog box.

2.  From the File Selection dialog box that appears, navigate to access the bend tables saved in the shared directory 

defined by your system administrator.

3.  Open the bend table of interest.

As soon as you save your Sheet Metal part, SMARTEAM creates a link between this part and the bend table you used to 

create it.

The links to the thickness table and the bend table are saved.



Creating a Mass Parameter in the Generative Sheet 
Metal Workbench

This section shows you how to create a mass parameter in the Generative Sheet Metal workbench. This 
involves three operations:

●     Calculating a Mass Value

●     Creating a Formula

●     Saving the Part

Calculating a Mass Value

1.  Once you have created your part, click the Measure Inertia icon .

The dialog box that appears lets you measure several properties of the geometrical element you want. 

The mass property is one these properties that can be calculated.

2.  Ensure that the Keep Measure option in the dialog box is selected. This lets you keep measures as 

features in the specification tree. The mass measure kept as a feature can be used as a parameter.

3.  From the Measure Inertia dialog that appears, click Customize... to indicate that you want to compute 

and display the Mass parameter in the Measure Inertia dialog box.



When done, the Mass value is displayed in the dialog box.

Creating a Formula

Using the measure you have just created, you need to define a formula parameter that you will rename as 
Mass.

4.  Click the Formula  icon.

5.  From the Formulas dialog box that appears, click Add Formula and create the Mass.1 parameter in the 

Formula Editor window:

When done, as you checked the Keep measure option in the Measure Inertia dialog box, the mass is 

kept as a feature and your specification tree will look something like this:



Saving the Part

As soon as you save the part in SMARTEAM, the MASS attribute is displayed in the Profile Card corresponding to 
this part. 



Handling CATAnalysis Documents
This scenario outlines the different operations you need to perform when handling CATAnalysis documents in the Generative Structural 

Analysis workbench . 

As you know, these documents are linked to specific files. These require some customizations from your system administrator, but you also 
need to rename them as explained below. 
The different steps described are the following:

●     Performing an Analysis in CATIA Generative Structural Analysis

●     Renaming the Files Generated

●     Saving the CATAnalysis Document in SMARTEAM

●     Checking Out the CATAnalysis Document

Performing an Analysis in CATIA Generative Structural Analysis

1.  Retrieve the part to which a material has already been assigned.

2.  For example, from the New Analysis Case dialog box, select Static Analysis as the type of analysis you wish to perform.

3.  Define restraints and distribute the forces you want. 

Refer to the CATIA Generative Structural Analysis Guide for reference information about mechanical analyses for 3D systems.

4.  Launch the computation .

Among other things, two files are generated and their paths are also displayed in the specification tree. You obtain a result similar 

as this: 

E:\users\slg\AnalysisOutput\Analysis1_1.CATAnalysisResults

E:\users\slg\AnalysisOutput\Analysis1_1.CATAnalysisComputations

You can notice that the Results as well as the Computations files:

❍     are located in the appropriate directory defined by the system administrator, not in a temporary one. Refer to CATAnalysis 
Documents Management for further information.

❍     have a name which will not be unique in the SMARTEAM database.



Renaming the Files Generated
You may have noticed that the application provides names that cannot be easily reused in the SMARTEAM database.

5.  To ensure that both files will be identified with a unique name in the database, you need to rename them. To do so, right-click the 

file to be renamed and select Results object->Definition...

The External Storage dialog box is displayed. It is recommended to place the files in the user's workspace.

6.  Press Modify and enter a unique name.

We recommend you use the names of the referenced Part or Product. 



When done, the specification tree reflects the modifications. The name you have just modified are displayed.

Saving the CATAnalysis Document in SMARTEAM

7.  Prior to saving CATAnalysis documents in SMARTEAM, if you wish not to save the computation data in the vault, click  to clear 

this data.

8.  Save the documents in the SMARTEAM database.

As soon as you save your CATAnalysis file, SMARTEAM creates a link between this document and:

❍     the CATPart document 

❍     the two files generated after computation.

Notice the link icons to the CATAnalysisResults & CAtAnalysisComputations. It is indeed stored as a CATIA Result Link as these two 

files are a result of the analysis.



9.  To secure the documents in the electronic vault, select SMARTEAM->Life Cycle->Check-In.

Checking Out the CATAnalysis Document

9.  In case you wish to modify the CATAnalysis document later on, perform an Open for Edit operation.

You will note that a check-out of the analysis proposes by default the check-out of the result files. 





The User Working Area

Single Directory vs. Multiple Directories 

As mentioned earlier, CATIA document references are to the physical file name. When a document is 
opened by CATIA, it searches for its references. When CATIA identifies that it needs to load a reference 
into memory, it starts to search for the referenced document by name according to the search rules. 

This fundamental file-referencing behavior requires clear and reliable methodology for the users working 
areas. In cases where multiple copies of documents are spread across the network, document references 
may be loaded from unexpected or inconsistent locations. 

CATIA may not allow you to open the same filename from two different directories. Therefore, if a part or 
product is already loaded from a given directory, this loaded instance will be used for all referencing 
documents (other drawings, products or parts), even if these referencing documents would have 
attempted to load the reference from a different directory. Due to this behavior, we recommend that the 
user's working area is well defined. If you decided to enable more than one area, check your 
methodology to ensure that a single CATIA session will load documents from the correct location 

Recommendations 
●     Use a dedicated location as a working area

●     Do not allow access to the working directory of other users. Sharing files between users must be 
done using vault (check in/ check out) or shared workspace (if collaborative design is enabled) 

Location of Working Directories

Administrators sometimes need to choose between configuring the user's working area locally (on the 
user's local hard drive) or setting up the working areas on the network. 

As far as CATIA is concerned, loading documents from the local hard drive may be faster than loading 
from the network. Configuring the working directories of the users on the network usually provides: 

●     Easier ways to backup the working areas (preventing the need to perform check in for backup 
purposes)

●     Better performance copy files from the vault (the working directories are on the same server as the 
vault server, or the vault server to the file server channel is significantly robust). 

SMARTEAM supports both configurations. However, it is common to find that users who work with local 
directories perform check in operations on a daily basis in order to back up their work. Sometimes this 
also applies when the working directories are on the network. 

We suggest consulting your system/network administrator and a SMARTEAM consultant regarding to this 
issue. It has been proven that correct setup can significantly improve performance. 



●     It is highly recommended to perform a backup of the users working directories, whether on the 
network or local drive. This can be done using one of the various tools available to enable remote 
backup.

●     Check in operations for backup purposes only are problematic from the performance, as well as the 
usability point of view, due to the redundant revisions that are exposed to team members.

Recommendations



Workbench Description
The SMARTEAM - CATIA Integration user interface looks something like this:

For more information about the items of the SMARTEAM menu bar or toolbar, either click on the item concerned in 
the image above or go into one of the sections below.

SMARTEAM Menu
SMARTEAM Toolbar

SMARTEAM Collaboration Toolbar  



SMARTEAM Menu 

Start SMARTEAM File Edit View Insert Tools Windows Help

SMARTEAM

See Connecting to the SMARTEAM Database.

In a CATIA session, disconnects the SMARTEAM database. 

Creates, in the CATIA session, a new document based on an existing SMARTEAM database document.
For an example of use, see Creating a Drawing Document from a Template.

●     Find Document
See Finding.

See Saving a Part, Saving an Assembly or Saving a Drawing.

See Importing CATIA Data Inside SMARTEAM.

See Saving a Part or Saving an Assembly.

●     Load from Database
Forces the update of all the mapped properties of the document in the 
CATIA session.

●     Save in Database
Forces the update of all the mapped attributes of the document in the 
SMARTEAM database.

●     Map a Text Value...
For an example of use, see Displaying a CATIA Drawing SMARTEAM 
Attribute in a Title Block.

Provides the database view of the document currently displayed in a CATIA session.
See Showing Profile Cards.

See Analyzing the Impact of a Change

See Finding Out Where a Document Is Used.

Switches from the CATIA session to the SMARTEAM application.



 

●     Insert Component...
Inserts a Part or Product stored in the SMARTEAM database 
into an Assembly. For an example of use, see Building an 
Assembly.

●     Replace Component...
Replaces an existing Part or Product or a component of the 
current Product. For an example of use, see Modifying a 
Checked In Assembly

●     Replace with Selected Revision
Replaces the current revision of a document with another. 
For more information, see Managing Assemblies.

See Using Global Refresh

See Lifecycle Menu Commands.

 
●     Refresh 

Updates the Product Structure 
and File Desk icons with 
regard to SMARTEAM 
information. See Tree 
Refresh.

●     SmarTeam Files Explorer 
Lists all files copied to the 
view and work directories. For 
more information, refer to the 
SMARTEAM documentation.

●     Default Link Settings
Allows you to set the default 
project that is proposed when 
storing a new document.

●     Property Management
Manages mapping group 
types and associated 
information.

●     Class Management
Declares all classes that can 
be used when saving a 
document of the 
corresponding file type.

●     Current Template Project 
Sets the template project as 
current

 



SMARTEAM Toolbar

See Connecting to the Database

See Finding

See Saving a Part, Saving an Assembly or Saving a Drawing

 
See Checking In a Part, Checking In an Assembly

See Showing Profile Cards

See Building an Assembly

See Tree Refresh Command

Switches from the CATIA session to the SMARTEAM application

Analyzing the Impact of a Change

 



SMARTEAM Collaboration Toolbar

See Using Global Refresh

 



Glossary

           

B  

bend table A table defining standards for sheet metal parameters in CATIA Generative Sheet Metal Design 
workbench. They are used to reflect what can be manufactured in a given company. 

C  

catalog A CATIA tool storing and classifying objects, each with its own specific characteristics (such as 
shape, color, size, diameter, length, standard, etc.) so that they can be retrieved fast and easily.

check in 
operation

A lifecycle operation that checks in:

●     a new object and places its file in the SMARTEAM Checked In vault, or 

●     a Checked Out object (being modified) and places the file back in the SMARTEAM Checked In 
vault. 

check out 
operation

A lifecycle operation that retrieves files from the SMARTEAM Checked In vault. It is the first 
operation to do prior to making modifications to a file that is checked in to the SMARTEAM vault.

class A set of objects that share common structure and common attributes. Every engineering entity is an 
object that can be classified. 

D  

default An operation or value that the system or application assumes, unless a user makes an explicit 
choice.

desk A CATIA tool that lets you view the relationships between different documents and obtain 
information about their properties.

design table A table containing values to be potentially applied to a document to manage its parameter values. It 
can be created from the document parameters or from an external file. A design table is a feature. 
In the document specification tree, it is displayed as a relation that can be activated or deactivated. 
Like any feature, a design table can be manipulated from its contextual menu. The evaluation 
method is based on a table (Excel or .txt file).

dialog box A window that gathers additional information from a user. A dialog box usually contains one or more 
controls, such as buttons, list boxes, combo boxes, and edit boxes, with which the user enters text, 
chooses options, or directs the action of the command.

document A common unit of data (typically a file) used in user tasks and exchanged between users. 



G

geometry area Area of a document window in which application data are displayed and edited.

M

model A CATIA Version 4 document.

O

object An entity or component identifiable by a user that can be distinguished by its properties, operations, 
and relationships.

obsolete An object assigned as Obsolete can no longer be activated, released or modified.

P

part A 3D entity obtained by combining different features.

R

release 
lifecycle 
operation

A lifecycle operation that changes the revision designation of a part.

resolve
operation

A CATIA operation that generates the .CATPart documents referred to by part families or part family 
components.

S

specification 
tree

Area of the document window reserved for viewing the design specifications of a part, presented in 
the form of a tree structure.
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