CATIA V5 Fundamentals

Version 5 Release 16

Infrastructure
Sketcher
Part Design
Assembly Design
The Workbench Concept

Each workbench contains a set of tools that is dedicated to perform a specific task. The following workbenches are the commonly used:

- **Part Design**: Design parts using a solid modeling approach
- **Sketcher**: Create 2D profiles with associated constraints, which is then used to create other 3D geometry.
- **Assembly Design**: Assemble parts together with constraints
- **Drafting**: Create drawings from parts or assemblies
- **Generative Shape Design**: Design parts using a surface modeling approach
Below is the layout of the elements of the standard CATIA application.

A, Menu Commands
B. Specification Tree
C. Filename and extension of current document
D. Icon of the active workbench
E. Toolbars specific to the active workbench
F. Standard Toolbar
G. Compass
H. Geometry area
The common documents are:
A. A part document (.CATPart)
B. An assembly document (.CATProduct)
C. A drawing document (.CATDrawing)
Display Settings

To improve the 3D surface accuracy,

Use the **Tools->Options...** Command, then open the tab page **Display->Performances**

Then lower the **fixed sag value** to make the surface look smoother

You can also change the background color on the tab page **Display->Visualization**
View & Hide Toolbars

- Select “View > Toolbars”. The list of current toolbars is displayed. Currently visible toolbars are indicated by a tick symbol to the left of the toolbar name.

In the list, click the toolbar you want to view or hide.

- You can detach toolbars from the application window border by dragging the double line to the left of the toolbar: you can drag the toolbar anywhere around the screen, then dock the toolbar in the same or in another location by dragging it onto the application window border.

- To restore the original positions of the toolbars on the current workbench, select “View>Customize>Toolbars>Restore position”;
Change the view with the mouse

A. Panning enables you to move the model on a plane parallel to the screen. Click and hold the middle mouse button, then drag the mouse.

B. Rotating enables you to rotate the model around a point. Click and hold the middle mouse button and the right button, then drag the mouse.

C. Zooming enables you to increase or decrease the size of the model. Click and hold the middle button, then click ONCE and release the right button, then drag the mouse up or down.
Rendering Styles

A. Shading
B. Shading with Edges
C. Shading with Edges but without smooth edges
D. Shading with Edges with hidden edges
E. Shading with Material
F. Wireframe

More:- To change the color or the degree of transparency, right-click on the element
Show & Hide

A. Hide/Show
   (Hide an element by transferring it to the “No Show” space)

B. Swap visible space
   (Swap the screen from “Show” to “No Show” or vice versa)

You can select any elements in the “No Show” space and transfer it back to the “Show” space by clicking the “Hide/Show” icon

For the hidden elements, their icons are shaded.
Reference Planes

The default reference planes are the first three features in any part file. Their names are derived from the plane they are parallel to, relative to the part coordinate system:

- XY plane
- YZ plane
- ZX plane

It is impossible to move or delete the planes.

The planes can provide a planer support on which to create a 2D sketch.
Create a Sketch

1. Select a planer support (e.g. datum plane, planer solid face) from the specification tree or by clicking the support directly.

2. Select the Sketcher Icon from any workbench where is possible to create a sketcher (e.g. Part Design workbench).

3. CATIA switches the current workbench to the sketcher workbench; The viewpoint is now parallel to the selected plane.
Toolbars in sketcher

A. Profile: Create 2D elements, such as points, lines, arcs, circles and axes.
B. Operation: Modify the existing elements, such as chamfer, fillet, trim, and mirror.
C. Sketch tools: Provide option commands
D. Constraint: Set various dimensional constraints (e.g. length, angle & radius) & geometrical constraints (e.g. coincidence, concentric, horizontal and symmetric)
E. Visualization: Simplify the view
Construction geometry is created within a sketch to aid in profile creation. Unlike standard geometry, it does not appear outside the sketcher workbench.

Construction geometry is shown in dashed format. When the “Construction/Standard element” icon is on, all sketched elements will be created as construction elements.

You can also toggle any elements from standard to construction, or vice versa by clicking the “construction/standard element” icon.
Sketch Assistant

**CASE-1**

This is a line on the sketch.

When the cursor is on the line, the line will turn in orange and an empty circle appears next to the cursor.

When the cursor is at the endpoint of the line, a solid circle appears next to the cursor.

**CASE-2**

We are going to draw a line, which is tangent to the arc.

Before clicking the second point of the line, move the cursor until the system can detect that the line is tangent to the arc. Click and confirm the position.
Constraining the sketch

- **Dimensional Constraints**
  (click the icon, then select the element(s))
  - Length
  - Distance
  - Angle
  - Radius/Diameter

  Remark: To create the dimensions continuously, double-click the icon so that the icon is always on until you re-click it again

- **Geometrical Constraints**
  (multi-select the two elements by pressing “CTRL” key and click the icon)
  - Perpendicularity
  - Horizontal/Vertical
  - Concidence
  - Tangency
  - Symmetry (multi-select the elements on both sides and then select the axis)

You can also create constraints with other sketches and 3D elements out of the sketch
Controlling the direction of a dimension constraint

The default dimension direction is parallel to the line between the circle centre. To change the direction to horizontal or vertical, right mouse click and select the desired orientation.
Color and Diagnostic

1. White: Under-constrained
2. Green: Fixed/Fully constrained
3. Purple: Over-constrained
4. Red: Inconsistent

Only case 1 & 2 are allowable in CATIA; for case 3 & 4, you must fix the error before quitting the sketcher workbench, otherwise a warning message will pop-out.
View Orientation

- By default, the screen is parallel to the sketch support.

- To make constraints between the sketch geometry and the 3D element, you may need to rotate the model into a 3D view.

- To return the default orientation, select the “Normal View” icon.

We can create a distance constraint between the circle centre and the solid edge.
Exiting the Sketcher

- To exit the sketcher workbench, select “Exit Workbench” icon.

- After that, the screen will be back to 3D view and the workbench will be switched back to the original.
EXERCISE 1

- Create a sketch on xy plane
- Circle centre at (0,0,0)
- The geometry is symmetrical along both x, y axes.
- R40 must be tangent to R16
- No endpoint is isolated
- Useless elements must be cleared
Part Design

- Feature-Based Solid Modeling

If deleting Hole, we get:

If deleting Fillet, we get:

If deleting Pad, we get:

Parent and Children Relation
Toolbars in Part Design

A. **Sketch-Based Features**: Create a solid feature from a 2D sketch/profile

B. **Dress-Up Features**: Add fillets/chamfers on the solid edge, add a draft onto the solid faces, Hollow the solid, offset faces…

C. **Transformation Features**: Change the 3D position of the solid, duplicate the solid by mirroring/patterning, scale up/down the solid…

D. **Surface-Based Features**: Split the solid with a surface/plane, adding material onto surfaces…

E. **Reference Elements**: Create a point, a line or a plane in the 3D space.

F. **Boolean Operations** – not covered in class

G. **Analysis (Draft analysis)** – not covered in class

C-2
Type of limit are:
A. Dimension
B. Up to Next
C. Up to Last
D. Up to Plane
E. Up to Surface

A new plane
Pad & Pocket

A. **Pad** (material added by extruding a sketch)
B. **Pocket** (material removed by extruding a sketch)

You can define the extrusion direction by selecting a datum plane, a line, a planar surface, and a straight solid edge.
Shaft & Groove

A. Shaft (material added by rotating a sketch)

B. Groove (material removed by rotating a sketch)

You can draw the rotation axis in the profile sketch or draw another straight line as the axis.
Rib & Slot

A. **Rib** (material added by sweeping a profile along a center curve)

B. **Slot** (material removed by sweeping profile along a center curve)

Profile Control

- **Keep Angle**
  keeping the angle value between the sketch plane used for the profile and the tangent of the center curve

- **Pulling Direction**
  Sweeping the profile with respect to a specified direction
Multi-sections Solid

A. Multi-sections Solid (material added by sweeping one or more planar section curves along one or more guide curves)

B. Removed Multi-sections Solid (material removed in the same way)

- You can use an additional guide curve to control sweeping path

- If sections do not have the same number of vertices, use “ratio coupling”

- You can always create another plane other than xyz planes
# Comparison of common features

<table>
<thead>
<tr>
<th></th>
<th>Add/Remove material</th>
<th>Section along the guide</th>
<th>Guide/Center curve</th>
<th>Section profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pad</td>
<td>Add</td>
<td>Same</td>
<td>Straight line</td>
<td>Planar</td>
</tr>
<tr>
<td>Pocket</td>
<td>Remove</td>
<td>Same</td>
<td>Straight line</td>
<td>Planar</td>
</tr>
<tr>
<td>Rib</td>
<td>Add</td>
<td>Same</td>
<td>Curve</td>
<td>Planar</td>
</tr>
<tr>
<td>Slot</td>
<td>Remove</td>
<td>Same</td>
<td>Curve</td>
<td>Planar</td>
</tr>
<tr>
<td>Multi-section solid</td>
<td>Add</td>
<td>Various</td>
<td>Curve</td>
<td>Planar</td>
</tr>
<tr>
<td>Removed multi-section solid</td>
<td>Remove</td>
<td>Various</td>
<td>Curve</td>
<td>Planar</td>
</tr>
</tbody>
</table>
A. **Hole** (circular material removed from the existing solid);

Several types of holes are available: Simple, Tapered, Counterbored, Countersunk, Counterdrilled.

To locate the center of the hole precisely inside the sketcher workbench, Select the “positioning sketch” icon.

Positioning the hole center
A. **Fillet** (creating a curved face of a constant or variable radius that is tangent to, and that joins, two surfaces.)

- With the Tangency mode, a fillet is applied to the selected edge and all edges tangent to the selected edge.
- With the minimal mode, a fillet is applied only to the selected edge.
A. **Chamfer** (removing & adding a flat section from a selected edge to create a beveled surface between the two original faces common to that edge.)

Two Dimensioning Modes

Length1

Length1

Length2

Angle

C- 11
A. **Basic Draft** (adding or removing material depending on the draft angle and the pulling direction)

Remark: Neutral element always keeps unchanged after a draft is created.
Shell

A. Shell (empty a solid while keeping a given thickness on its sides)

The face-to-remove cannot be tangent to the nearby faces.
All edges around the face should be sharp edges.
Translation & Rotation

A. Translation (translating a solid along a direction)

B. Rotation (rotating a solid about an axis by a certain angle)

Be careful, the sketch won’t move with the solid.
Symmetry & Mirror

A. **Symmetry** (translating a solid to the other side of the mirror plane)

B. **Mirror** (duplicating a solid on the other side of the mirror plane)
Patterns

A. Rectangular Pattern
B. Circular Pattern
C. User Pattern

(duplicate the features at the points created in sketcher workbench)

To duplicate a list of features, multi-select the features before clicking the icon “pattern”
A. **Split** (splitting a solid with a plane, a face or a surface)

The arrow is pointing to the material to keep; you can click on the arrow to reverse the direction.

You can hide the cutting surface after the operation.
Part Design - exercise

• EXERCISE 2-

STEP 1

☞ Open the CATPART file done in Exercise 1

☞ Make sure that the current workbench is PART DESIGN

☞ Create a “Pad” with the height 5.5mm (first limit)
Part Design - exercise

STEP 2

Create another sketch on zx-plane

The sketch should have an axis and a triangle with these dimensions (45deg, 35deg, 2.5mm High)

One edge of the triangle should sit on the bottom side of the pad and its peak should not be inside the pad

Exit Sketcher

Create a “Groove” with First Angle Limit 360deg
Part Design - exercise

STEP 3

Create the 3rd Sketch on yz-plane
The sketch should have an axis and two lines, which are symmetrical
One end point sits on the axis and the other sits on the outermost plane of the solid
Exit Sketcher
Create a “Pocket” and select “Up to Last” for limits on both sides
Part Design - exercise

STEP 4

 créer la 4ème esquisse (un cercle de diamètre 28mm) sur la surface plane supérieure de la masse

 créer un “Pocket” avec une profondeur de 1.5mm

STEP 5

 créer une surface offset “Plane” (15mm du plan yz)
Part Design - exercise

STEP 6
Create the 5th sketch on the offset plane
Draw a circle (Dia 3.0mm; distance between the solid base and the circle center is 2.5mm)
Exit Sketcher
Create a “Pocket” with first limit “Up to Last”

STEP 7
Create “EdgeFillet” (2mm) at the 4 corners
Part Design - exercise

STEP 8

>Create another “EdgeFillet” (5mm) to remove the four sharp edges on the top surface

STEP 9

>Create a “Chamfer” on both sides

>Length1= 1mm; Angle= 45deg

- END of Exercise 2
A Product stores a collection of components (parts or sub-products). The file extension is .CATProduct.

Storing the constraints between parts or sub-products
Create a New Product

Create a New Product by:

A. Switching to Assembly Design workbench; or

B. Clicking File/New/Product

You can change the Product’s properties (e.g. name) by right-clicking here

Or
Insert an existing component

Right-click the product tree, then select "Components">"Existing component...”

OR

Drag the part tree onto the product tree
-or

Use “copy & paste” function
Move components by Compass

Drag the compass from the top-right corner of the window to the component you want to move; the Compass will turn in green color.

Remark:
1. You can only move the components of the active product.
2. To reset the compass, drag it onto the global coordinate system at the bottom-right corner of the window.
Constraints between components

A. Coincidence Constraint
B. Contact Constraint
C. Distance Constraint
D. Angle Constraint
E. Fix Component (fix a component in space; normally we’d fix at least one component)

When the cursor is pointing at the curved surface of the hole, its axis is highlighted.
Updating Constraints

Use compass to drag a component to another position.

After selecting “Update” icon, the component is back to its original position.

The constraints need to be “Updated”.

CATIA V5R16 Fundamentals
Drag the compass while pressing "shift" key on the keyboard; you will see that other components will move with the active component with respect to constraints.

Their axes are coincided. The base is fixed.
Interference check

Select Type “Contact & Clash”; “Between all components”; then “apply”

Clash: RED
Contact: Yellow
Clearance: Green
Sectioning

After clicking "sectioning" icon, a section plane will be automatically created parallel to the yz plane at the product origin.

You can orient the section plane by dragging the red-line of the plane.

Volume Cut; When activated, one side of the volume will be hidden.
Assembly Design - exercise

**EXERCISE 3**-

- Build the rest of components, such as ring, button, chain as the separate parts
- Assemble them together
- Check any interference after assembly