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Overview
Welcome to the Generative Drafting User's Guide. This guide is intended for users who need to become quickly 
familiar with the Generative Drafting Version 5 product. 

This overview provides the following information:

●     Generative Drafting in a Nutshell

●     Before Reading this Guide

●     Getting the Most Out of this Guide

●     Accessing Sample Documents

●     Conventions Used in this Guide

Generative Drafting in a Nutshell

Version 5 Generative Drafting  is a new generation product that provides users with powerful 
functionalities to generate drawings from 3D parts and assembly definitions.

The Generative Drafting User's Guide has been designed to show you how to generate drawings of varying 
levels of complexity, as well as apply dimensions, annotations and dress-up elements to these drawing. 

Before Reading this Guide
Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, 
standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that 
describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 
and the interoperability between workbenches.

You may also like to read the following complementary product guides, for which the appropriate license is 
required: 

●     Interactive Drafting User's Guide: explains how to create drawings of varying levels of complexity.

●     Data Exchange Interface User's Guide: describes how to import and export external files in 
miscellaneous formats, including DXF/DWG and CGM.

●     V4 Integration User's Guide: presents interfaces with standard exchange formats and most of all with 
V4 data.

 



To get the most out of this guide, we suggest that you start reading and performing the step-by-step 
Getting Started tutorial. This tutorial will show you how to define a drawing sheet and create views from a 
3D part. 

Once you have finished, you should move on to the Basic Tasks section, which deals with handling 
drawings and sheets, creating and modifying views, generating dimensions, etc. 

If you are an administrator, the Administration Tasks section is specifically aimed at you. You will see how 
to manage and customize generative view styles.

The Workbench Description section, which describes the Generative Drafting workbench, and the 
Customizing section, which explains how to customize the Generative Drafting workbench, will also 
certainly prove useful. 

 

Accessing Sample Documents
To perform the scenarios, you will be using sample documents contained in the 
online\cfysa\samples\Drafting folder. For more information about this, refer to Accessing Sample 
Documents in the Infrastructure User's Guide.

 

Conventions Used in this Guide
To learn more about the conventions used in this guide (as well as in other user's guides), refer to the 
Conventions section.  

 

 

Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, 
standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that 
describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 
and the interoperability between workbenches.

You may also like to read the following complementary product guides, for which the appropriate license is 
required: 

●     Interactive Drafting User's Guide: explains how to create drawings of varying levels of complexity.

●     Data Exchange Interface User's Guide: describes how to import and export external files in 
miscellaneous formats, including DXF/DWG and CGM.

●     V4 Integration User's Guide: presents interfaces with standard exchange formats and most of all with 
V4 data.

 

Getting the Most Out of this Guide
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Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and understand important concepts and 
specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task

functionalities that are new or enhanced with this Release.

allows you to switch back the full-window viewing mode.

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:



This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary

Index

Text Conventions

The following text conventions are used:

  The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.
  File -> New identifies the commands to be used.
  Enhancements are identified by a blue-colored background on the text. 

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.



Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, ...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

New Functionalities

Views

New absolute mode for view positioning
You can now choose the positioning mode for generative views, via the sheet properties. The view 
positioning mode can either be based on the center of gravity of the 3D geometry or on the 3D axis 
system. Depending on the chosen mode, either the center of gravity, or the projection of the 3D axis, 
will be maintained at a fixed position on the sheet at update.

View-specific icons in Drafting specification tree
A number of new icons are used in the Drawing specification tree to represent the view type (Section 
view, Projection view, etc).

CATIA/ENOVIA Interoperability

Update status for assembly drawing in ENOVIA VPM and ENOVIA LCA
The update status given when loading an assembly drawing in CATIA V5 via ENOVIA reflects the 
modifications performed on the assembly, which means that the drawing will be shown as being not up-
to-date if either the assembly or the parts in the assembly have been modified.

Impact graph for assembly drawing in ENOVIA VPM and ENOVIA LCA
Links between drawing & assembly part instances in explode mode now appear in the impact graph.

Warning when trying to create views that cannot be saved in ENOVIA VPM and ENOVIA LCA
Views referencing the following elements from exploded products prevent the drawing from being 
correctly saved in ENOVIA:
- different instances of exploded products (VPM/LCA context)
- DMU components, i.e. 3D box or section (VPM/LCA context)
- DMU components, i.e. scenes (LCA context)
An error message is now displayed when trying to create such views.

Enhanced Functionalities

View Creation

Patterns on breakouts and uncut elements
When creating breakouts on isometric views, in the case of overlapping faces, the pattern area is now 
limited to the face sectioned on the part (it does not go over the projected faces and edges anymore). 
The same behavior also applies to assembly elements which are not cut in projection views. 

Integration of V4 *FAC and *SKIN elements
V4 Face (*FAC) and Skin (*SKIN) elements are now projected in section views and section cuts created 
from V4 .model documents.

Customizing Settings

View axis system based on 3D axis system
A new setting lets you specify that the axis system of the view should be based on the axis system of 
the 3D part when creating views. 
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Getting Started
 Before getting into the detailed instructions for using Generative Drafting, the following tutorial aims at 

giving you a feel of what you can do with the product. It provides a step-by-step scenario showing you 
how to use basic capabilities and key functionalities. Simply follow the instructions as you go along.

The main tasks covered in this section are the following: 

Defining the Drawing Sheet
Opening a Part

Creating a Front View
Creating a Projection View
Creating a Section View
Creating a Detail View
Creating a Section Cut

 At the end of this tutorial, you will be able to print the following sheet:
 

 

Before discovering this tutorial, you should be familiar with the basic commands common to all 
workbenches, which are described in the  Infrastructure User's Guide.



Defining the Drawing Sheet

This task shows you how to define the drawing sheet that will be used for creating the views described in the next tasks.

1.  Select File -> New... from the menu bar, or click the New icon  from the Standard toolbar. 

 

 

 
The New dialog box is displayed.

2.  Select Drawing from the List of Types, and click OK. 

3.  From the New Drawing dialog box, select the ISO standard, and the A0 ISO format.

 

 We will use the ISO standard for the purpose of this tutorial, as well as all along the guide.

You can add an unlimited number of customized standards using Standard files that you will create and/or, if 
needed, modify. Once created, this standard will appear in the New Drawing dialog box. For more details on 
standards and particularly generative view styles, see the Standards Administration section in this guide. For more 
details on standard, standard parameters and styles, see the Standards Administration section in the Interactive 
Drafting User's Guide. Care that any user-defined standard is based on one of the four international standards 
(ANSI, ISO, ASME or JIS) as far as basic parameters are concerned.



 

4.  Click OK.

5.  In the Generative Drafting workbench, a grid is set by default. For the purpose of this tutorial, you will not use the 

grid. To hide it, de-activate the Grid icon  from the Tools toolbar (bottom right). 

The drawing sheet appears as shown here:

 

From now on, you will work on the created sheet. Note that you can define a new, additional sheet at any time.

 



Opening a Part

This task will show you how to open the 3D part from which you will create views in the Generative Drafting 
workbench. 

Note that you may create views from both 3D parts and assemblies: later on in this tutorial, you will see how 
to use assemblies.

1.  Select File ->Open... from the menu bar, or click the Open icon  from the Standard toolbar. 

 

 The File Selection dialog box appears.

2.  Select the part to be opened, the GenDrafting_part.CATPart document.

Note that this sample documents is to be found in the C:\Program Files\Dassault 
Systemes\Bxxdoc\English\online\cfysa\samples\Drafting folder (where xx in Bxxdoc stands for the 
current release number).

 

3.  Click Open. The part is opened and a message appears, informing you that it is read-only. Simply 

close it. The part will remain displayed in the window, whatever views you create from it. 

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/GenDrafting_part.CATPart


 



Creating a Front View
This task will show you how to create a front view on the sheet you defined, from the 3D part you opened. 

At this step, it will be more convenient if you tile the drawing and the part windows horizontally. To do 
this, click Window -> Tile Horizontally from the menu bar.

In the Generative Drafting workbench, the view name, scaling factor and view frame are set by default in 
views. Throughout this Getting Started, we decided not to display view names and scaling factors. To 
deactivate them, go to Tools -> Options -> Mechanical Design -> Drafting, click on the Layout tab 
and un-check the View name and Scaling factor options.

You can also specify what geometrical and dress-up elements should be generated on views, such as 
axes, center lines, fillets, 3D points, etc. Still in Tools -> Options -> Mechanical Design -> Drafting, 
click on the View tab and choose your options in Geometry generation / Dress-up. For example, 
check Generate center lines, and un-check Generate fillet.

If you do not want to have the specification tree displayed, press the F3 key.

1.  Click the drawing window to activate it.

2.  Click the Front View icon  from the Views toolbar (Projections sub-toolbar).

 

 
3.  Now, in the part window, select the desired planar surface of the 3D part.

 



On the sheet, a blue knob appears, as well as a green frame containing a preview of the view to 
be created. 

The knob lets you define the location and orientation of the view to be created. As long as the 
green frame is displayed, you can define the frame position using the blue manipulators: top, 
bottom, left, right or rotated according to a given snapping, or according to a specified rotation 
angle.

 
4.  Click on the drawing sheet or at the center of the blue knob to generate the view. 

 



 A progress bar appears temporarily, showing the view creation progress. The front view is 

created.

 



Creating a Projection View

This task will show you how to create projection views on the sheet.

1.  Click the Projection View icon  from the Views toolbar (Projections sub-toolbar).

 

 A preview of the view to be created appears. By default, the projection view is aligned to the 
front view. 

As you move the cursor, a preview of the view to be created appears, as long as you keep the 
cursor positioned at a possible projection view location (at the left, right, top or bottom of the 
red frame). 

 

 
2.  Define the projection view position, for example the right view position, using the cursor.



 

 Note that the left view shown here was created and therefore positioned according to ISO 
standards and the First Angle Projection method. For more information, refer to Creating 
Views via the Wizard. 

3.  Click to generate the view. A progress bar appears while the view is being created.

 

 

4.  Click the Projection View icon  once again.

5.  Use the cursor to define the projection view position, for example the bottom view position, and 

click to generate the view. Once again, a progress bar appears during the view creation process. 

The views result as shown here.



 

 



Creating a Section View
This task will show you how to create a section view using the front view you previously generated. 

Section views make drawings more readable by replacing the hidden elements of parts, including holes, 
with filled areas.

To perform this scenario, it is recommended that you tile the drawing and the part windows horizontally. 

1.  In the drawing window, click the Offset Section View icon  from the Views toolbar 

(Sections sub-toolbar).

 

 
2.  Select the holes and points to define the cutting profile on the view. SmartPick assists you when 

creating the profile.

Note that selecting a circular edge, a linear edge, an axis line or a center line (for example, a 
hole) makes the view callout associative by default to the corresponding 3D feature. If you 
select a circle, the callout will go through the circle center. If you select an edge, the callout will 
be parallel to the selected edge. 

 

 

http://chir1dsy/lgkr13/DysEnglish/dysug.doc/src/dysugbt0800.htm


If you are not satisfied with the profile you create, you can, at any time, use the Undo  or 

Redo  icons. 

As you select the second point, the section plane appears and moves dynamically on the 3D 
part while you define the profile on the drawing. This section plane will automatically disappear 
when you double-click to end the callout definition.

 

 

 

 



 

 

 

 

3.  Double-click to end the cutting profile creation. A preview is displayed.

4.  Define the section view position using the cursor.



Positioning the view also defines the section view direction, as if it were a left or a right 

projection view. The direction of the callout blue arrows changes as you change the cursor 

position. 

 
 

 
5.  Click to generate the view. A progress bar appears while the view is being created.

Using the cursor, you can then position the section view in order to align it, or to not align it, to 
the front view.

 



●     The patterns which are used to represent sections are defined in the standards. For more information, 
refer to Pattern Definition in the Interactive Drafting User's Guide. 

●     You may modify the pattern (hatching, dotting, coloring or motif). For more information, refer to 
Modifying a Pattern. 
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Creating a Detail View

This task will show you how to create a detail view from the front view you previously generated.

1.  Click the Detail View icon  from the Views toolbar (Details sub-toolbar).

 

 
2.  Click where you want to position the callout center. 

3.  Drag the cursor to define the callout radius, and click when you are satisfied.

 
 

 A dashed, blue circle appears at the position of the cursor.

4.  Move this circle to where you want to position the detail view, and click to generate the view.



 

 
A progress bar appears while the view is being created.

5.  If you are not satisfied with the position of the detail view, you can drag it to a new position.



 

  

 Simply drop it to its new position.



 

As in step 4, the scale is, by default, twice that of the active view. You can modify this scale.

6.  To do so, right-click the detail view, select Properties from the contextual menu and then click 

the View tab. 

7.  Enter 4 in the Scale field and click OK. 

 



 For the purpose of this exercise, you will now add a dimension to the detail view. 

8.  To do so, click the Dimension icon  from the Dimensioning toolbar. 

 

9.  Click two elements in the view, as shown here.

 

 The dimension is created: 



 

 

  



Creating a Section Cut

This task will show you how to create a section cut from the detail view you just created.

The scale of the section cut will depend on the scale of the view this section cut is generated from. In this 
case, the section cut is generated from a detail view with a scale 4, so the section cut scale will also be 4.

1.  Right-click the detail view and select the Activate View option from the contextual menu.

2.  Click the Aligned Section Cut icon  from the Views toolbar (Sections sub-toolbar).

 

 
3.  Select the holes and points to define the cutting profile.

 

 Note that selecting a circular edge, a linear edge, an axis line or a center line (for example, a 
hole) makes the cutting profile associative by default to the 3D feature. If you select a circle, 
the profile will go through the circle center. If you select an edge, the profile will be parallel to 
the selected edge. 



 

 Also note that SmartPick assists you when creating the profile. For more information, refer to 
Using SmartPick.
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If you are not satisfied with the profile you create, you can, at any time, use the Undo  or  

Redo  icons. 

 
4.  Double-click to end the cutting profile creation. 

A preview of the view to be created appears. Positioning the section cut either to the right or to 
the left defines the section cut direction (as if it were a projection view). 

5.  Click to generate the section cut. A progress bar appears while the view is being created.

 



●     Once the section cut has been generated, you can modify its position relatively to the detail view: 
right-click the section cut and select View Positioning -> Position Independently of Reference 
View from the contextual menu.

●     Selecting an existing edge within the view lets you define automatically the direction of the cutting 
profile. You can also select a reference plane in 3D or a 3D wireframe plane. For more information, 
refer to Creating an Offset Section Cut/Section View. 

●     The patterns which are used to represent the section cut are defined in the standards. For more 
information, refer to Pattern Definition in the Interactive Drafting User's Guide. 

 
 For the purpose of this tutorial, you will now add a dimension to the section cut. 

6.  To add a diameter dimension to the section cut, click the Dimension icon  and click one edge 

only. 

 

 
In our example, a larger font size has been applied to the dimension value.

 The resulting sheet now appears similar to what is shown here. Note that in this case, we re-
positioned the views. 
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7.  You can now print this sheet. To do so, select File -> Print from the menu bar. Make sure the 

print format you set when defining the sheet is the same as the print format of the printer. 

 



Basic Tasks
The Generative Drafting workbench provides a simple method to create and modify views on a 
predefined sheet. You may also add, modify and/or delete dress-up and 2D elements to these views. All 
this is performed on a sheet which may include a frame and a title block and will eventually be printed.

 

Before you begin, we recommend you de-activate the Grid icon  from the Tools toolbar.

Drawing Management
Sheets

View Creation
View Modification

Generative View Styles
Dimension Generation

Dimension Manipulation
Technological Feature Dimensions

Annotations
Dress-Up Elements

Properties
Images
Printing

Interoperability
File Export and Import 



Drawing Management 
The Generative Drafting workbench lets you manage CATDrawing documents.

 

Create a new drawing: create a CATDrawing document.

Open a drawing: open a CATDrawing document.

Edit drawing links: edit the links which exist from a CATDrawing document to an existing CATPart document, 
CATProduct document, sheet metal part or a .model V4/V5 document.

Update drawings via the batch monitor: update a list of CATDrawing documents using the batch monitor.



Creating a New Drawing

This task will show you how to create a new drawing with pre-defined views generated from a part.

Open the GenDrafting_part.CATPart document. Make sure no drawing is already open.

1.  From the menu bar, select Start -> Mechanical Design. 

2.  Select the Drafting workbench. 

The New Drawing Creation dialog box appears with information on views that can possibly be 
created, as well as information on the drawing standards.

You can modify the drawing standards. For this, click the Modify button.

The New Drawing Creation dialog box will not appear if you did not previously open a CATPart or a CATProduct 
document.

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/GenDrafting_part.CATPart


 
3.  Select the views to be automatically created on your drawing from the New Drawing Creation dialog 

box, for example the Front, Bottom and Right icon. 

4.  Click OK. A progress bar appears while the views are being generated from the opened CATPart.

 

If the color of the part is white and the Inherit 3D Colors option is checked in Tools -> Options -> 
Mechanical Design -> Drafting -> View tab, the generated views will result white and therefore not 
necessarily properly visualized. 

 

The resulting view position will depend on the CATPart you loaded before starting the Drafting workbench. In 
other words, the views will be positioned according to: 

●     a plane you possibly selected in the part.

●     a planar surface you possibly selected in the part.

●     xy coordinates, in case you did not open a CATPart beforehand. In this case, you will only be able to define 
the drawing standards via the New Drawing dialog box.



Opening a Drawing 

This task will show you how to open a CATDrawing document. For more details on opening documents, 
refer to the Infrastructure User's Guide.

1.  Click the Open icon  from the Standard toolbar, or select File -> Open. 

2.  Select the document to be opened. In this case, open GenDrafting_part.CATDrawing.

The GenDrafting_part.CATDrawing document opens as shown below:

http://chir1dsy/lgkr13/BasEnglish/basug.doc/src/basugbt0404.htm
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Editing Drawing Links
This task will show you how to edit the links which exist from a CATDrawing document to an existing CATPart document. Use the same 
methodology for links to a CATProduct, a sheet metal Part or a .model V4/V5 document.

There are two possibilities: 

●     Editing drawing links with the reference document loaded

●     Editing drawing links with the reference document not loaded

 

Editing drawing links with the reference document loaded
Go to Tools -> Options -> General, click on the General tab, and make sure the Load referenced documents option is checked (this 
option is set by default). Then, click OK to validate.

 
When opening a drawing, if the referenced CATPart does not exist, a message will appear, mentioning that the links could not be found or 
contain wrong information.  

 

1.  Open the GenDrafting_part_links.CATDrawing document.

 

2.  Select Edit -> Links.

The Links dialog box appears with the existing links between the CATDrawing and  its related CATPart. In our example, this 

corresponds to links applied to the front, top and right views which are found and loaded (currently displayed in our session).

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/GenDrafting_part_links.CATDrawing


 

 3.  Click OK to validate and exit the dialog box.

 

Editing drawing links with the reference document not loaded
Go to Tools -> Options -> General, click on the General tab, and uncheck the Load referenced documents option (this option is set 
by default). Then, click OK to validate.

1.  Open the GenDrafting_part.CATDrawing document.

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/GenDrafting_part.CATDrawing


2.  Select Edit -> Links. 

The Links dialog box appears, showing the existing links between the CATDrawing and  its related CATPart. In this example, this 

corresponds to links applied to the front, rear, top, bottom, left, right and isometric views, which are found but not loaded 

(although currently displayed in our session).

Note that when the reference document is not loaded, a number of command can no longer be used, such as projection, dress-

up  and dimension commands. You can still modify the graphic properties of the elements in the views.

3.  You can perform the following operations:

●     use the Load button to load parts (and parts only) that are not loaded. The status will change from "Document not loaded" 

to "Loaded" 

●     use the Replace button to replace the selected link with another one. This button opens the File Selection dialog box to let 

you navigate to the desired file. Once the element has been replaced, the new element name is displayed along with its 

status in the Links dialog box. 

●     use the Refresh button to update the links related to the document without having to close then re-open the Links panel.

This is especially useful when trying to re-access pointed documents that are not found (for instance, after a network 

disconnection): in that case, clicking the Refresh button avoids you to re-select the Edit->Links... command to display an 

updated view of the links.

For more details:

●     For information on the other capabilities available with the Links dialog box (such as selecting a feature and opening or changing the 
corresponding source (CATPart)), refer to Editing Document Links in the Infrastructure User's Guide.

●     The Search Order capability allows you to solve links. For more details, see Infrastructure User's Guide. 



Loading/Saving a Drawing (Unresolved Link)

 This task will show you how to load and save a CATDrawing document from an existing CATPart document. Use the same 
methodology to load a CATProduct, a sheet metal Part or a .model V4/V5 document.
In this particular case, all the links that exist between the CATDrawing document and the CATPart will be unresolved as you will 
choose not to load the referenced document.
You can now modify your CATPart  choosing not to update the related CATDrawing document. 

 
 Go to Tools->Options-> General, click on the General tab, and uncheck the Load referenced documents option (option 

set by default). Click OK and re-start the software.

  

 
1. 
 

Open the GenDrafting_part.CATDrawing document. 

 

If the CATPart does not exist at all, the following message will appear simultaneously: "The following links could not be found or 
contain wrong information".  
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Make sure the specification tree actually appears as shown here. In other words, the specification tree shows that the links 
between the CATPart and the projection views are not resolved. 

  

2. 
 

 

Select the Edit->Links command.
The Links dialog box appears with the existing links between the CATDrawing and  its related CATPart. In this example, this 
corresponds to links applied to the front, rear, top, bottom, left, right and isometric views. These links are not found (although 
currently displayed in our session).
This means the following commands are no longer available: Projection View, Dressup  and Dimension.

Still, you can modify the graphic properties of the elements.

 
3. 
 

Select the line corresponding to the link to be solved.

 



4. If needed, click the  button from the Links dialog box.

You can now solve the links in the current session.

What you can also do is change the source in order to re-define the link and assign it to an equivalent part.

 
5. Press OK.

For more details:

●     At any time, you can select one feature and open or change the source (CATPart) corresponding to this feature. For more 
details, see Infrastructure User's Guide. 

●     The Search Order capability allows you to solve links. For more details, see Infrastructure User's Guide. 



Updating Drawings Via the Batch Monitor  

This task will show you how to update a list of CATDrawing documents. To do this, you will use the batch monitor. 

The batch monitor lets you create as many batch configurations as required, and follow the progress of an update. 
Updating drawings via the batch monitor will be particularly helpful if you need to update a great number of drawings 
(but do not need to visualize them while doing so), or drawings which require large CPU resources.

For more details on using the batch monitor, refer to Using the Batch Monitor in the Infrastructure User's Guide.

1. Run the CATUTIL command, using one of the methods described in the Infrastructure User's Guide. For example, 
from a V5 session, choose Tools -> Utility. The batch monitor appears, listing available batches.

At this point, you either need to define the batch parameters that will be used to launch drawing update (this is the 
case if this is the first time you are using the batch monitor for drawing update), or you can run the batch directly (this 
is the case if you already defined all the necessary data).

 

Defining the batch parameters

Defining the update batch parameters consists in selecting the files to update, optionally specifying the files for which 
you want to force the update, and indicating the directory where the updated files should be saved. 

2. From the list of available batches, double-click UpdateBatch (you can also right-click UpdateBatch and select New 
parameters file). The UpdateBatch dialog box is displayed.



 3. Click the Choose Files button to select the files that you want to update by batch. A selection dialog box is 
displayed. 

4. Browse to the directory (on your computer or on your network) which contains the files that you want to include, 
select these files, and click Open.  The selected files are now listed in the UpdateBatch dialog box.

5. Repeat steps 3 and 4 if you want to include files from another directory.

You can remove files from the list of the files to update. To do so, select the unwanted file and click the Remove Files 
button. 

 

6. By default, the files which do not need to be updated will not be. However, you can decide to force the update for 
certain files, or for all of them. To do this, double-click on No in the Force Update colum for each file for which you 
want to force the update. The value is now set to Yes, which means the update will be forced.

7. Click the [...] button next to the Target field to select the directory in which you want the updated files to be 
saved. A dialog box is displayed.

8. Browse to the directory in which you want to save the updated files, select it and click OK. Your update batch 
parameters are now defined.

Each time you run the update batch, updated files present in this target directory will be overwritten by the newly 
updated files.

 



 9. Click the Save button to specify where you want to save your batch parameters. A dialog box is displayed. 

10. Browse to the directory in which you want to save the batch parameters file, specify a file name in the appropriate 
field, and click Save. Your parameters are saved in an xml file.

11. You can now either click Run to run the batch immediately or click Cancel to close the UpdateBatch dialog box 
and run the batch later. For the purpose of this scenario, click Cancel.

You can now exit the batch monitor. To play the scenario below, however, you will need to re-open the batch monitor.

 

 Running the batch

Once you have defined batch parameters in an xml file, you can run the batch.

2. From the list of available batches, right-click UpdateBatch and select Associate a parameters file.

 

 A selection dialog box is displayed. 

3. Browse to the directory in which you previously saved the xml batch parameters file, select this file, and click Open 
to validate.

4. Access the Start tab which now displays the name and location of the file you just associated to the batch.

 

 5. Right-click the batch and select Run. The batch execution starts.

6. During or after the batch execution, you can get more information on the process in the Processes tab: the batch 
name, the batch identification number, the status (in progress or ended) as well as the start and end time.

When the batch execution is over, you can exit the batch monitor.



Sheets 
The Generative Drafting workbench provides a simple method for managing a sheet. 

A sheet contains:

●     a working view, which supports the geometry directly created in the sheet.

●     a background view, which is dedicated to frames and title blocks.

●     interactive or generated views.

 

Define a Drafting sheet: Define the sheet using commands and dialog boxes.

Modify a Drafting sheet: Modify the sheet orientation using the Page Setup dialog box.

 
Create a frame and title block: Create a background sheet and insert a frame and a title block into it using 
the Frame and Title Block dialog box.

Insert an image into a frame and title block: Insert a .gif image into a title block.

Manage a background view: Add to a sheet the background view (title block plus elements) from another 
drawing.

 



Defining a Sheet 

This task will show you how to define the sheet for a new CATDrawing document and, if needed, add 
more sheets.

This task is divided into the following sub-sections:

●     Defining a new sheet

●     Adding a sheet

Defining a new sheet

1.  Click the New icon  from the Standard toolbar or select File -> New... from the menu bar. 

 

 
2.  Select Drawing, and click OK. The New Drawing dialog box is displayed.

 



3.  From the New Drawing dialog box, select the ISO standard, and the A0 ISO format. 

4.  Select the Landscape orientation. 

5.  Select the 1:1 scale, and then click OK.

 

●     The sheet scale is a scaling factor which applies to all views in a given sheet. It does not determine 
the position of the views (or any other object) contained in the sheet. 
When the grid is displayed, the position of the view in the sheet is not determined by the grid, which 
only deals with what is drawn directly in the sheet. To see the real position of a given view in a sheet, 
you need to use the ruler. It is the only way to see the real coordinates in a sheet referential.

●     The sheet size depends on the standard type. For example, if you choose the ISO standard, the sheet 
will automatically be assigned the A0 format. You can choose another format if you want.

●     At any time, you can change the standard (which you can update), sheet format, orientation and/or 
scale. To do this, select File -> Page Setup from the menu bar.

If you select a new standard, the value in the Apply on field becomes All sheets and the new 
standard is applied to all drawing sheets.

 

Adding a sheet
You can add new sheets at any time. These new sheets will be assigned the same standard, format and 
orientation as the sheet first created and defined using the New Drawing dialog (default setting). 

6.  Click the New Sheet icon  from the Drawing toolbar. 

 

 The new sheet automatically appears as follows:



●     If you now delete Sheet.1, the newly created sheets will keep the same name. In other words, even 
if Sheet.1 has been deleted, Sheet.2 will remain named Sheet.2.

●     The F3 key lets you show/hide the specification tree.

●     Once you have created more than one sheet, you can activate one of the sheets by selecting it from 
the Drafting window or from the specification tree.

 



Modifying a Sheet 

This task will show you how to modify the standard, format, orientation and/or scale of a sheet. Doing 
this amounts to modifying the options you selected in the New Drawing dialog box when defining the 
sheet.

 

Create a sheet using the ISO standard, the A0 ISO format, and the Landscape orientation.

 

1.  Select File -> Page Setup from the menu bar.

2.  From the Page Setup dialog box, select the ANSI standard, and the A ANSI format.

You can update the current standards by clicking the Update button. This copies the most 

recent version of the standard file in the drawing, thus reflecting the latest changes an 

administrator may have performed in the standard file.

 



3.  Select the Portrait orientation, and then click OK.

 

At this step, you can also insert a background view into the sheet you are currently modifying. For more 
information, refer to Managing a Background View.

The Page Setup dialog box also let you modify the sheet format and set it to the printer format. For 
more information, refer to Printing a Document.

 



Creating a Frame and Title Block 

This task shows you how to insert a frame and a title block in the background of a sheet.

 

Open the GenDrafting_part.CATDrawing document. 

 

1.  Select Edit -> Background from the menu bar.

2.  Click the Frame Creation icon  from the Drawing toolbar. 

 OR 

2.  Select the Insert -> Drawing -> Frame and Title Block items from the menu bar.

The Insert Frame and Title Block dialog box is displayed: 
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3.  Enter the desired options from the Insert Frame and Title Block dialog box. 

The frame and title block result as shown below:

 

When the Frame Creation icon  is activated you cannot edit the views. Use Edit -> Working 
Views when you need to work on views.



If you want the frame and title block to appear in the newly created sheets when adding sheets, go to 
Tools -> Options -> Mechanical Design -> Drafting -> Layout tab. Check the Copy background 
view option and the First sheet option. This will insert the frame and title block from the sheet you 
previously created on the current drawing.

 



Inserting an Image Into a Frame and Title Block

This task will show you how to insert a .gif image into a frame and title block.

 

Open the GenDrafting_part_titleblock_insert.CATDrawing document. Make sure you are in the 
background view (go to Edit -> Background from the menu bar).

 

1.  Select Insert -> Object from the menu bar. The Insert Object dialog box appears.

You can either create a new object or re-use an existing file.

2.  Activate the Create from File option from the Insert Object dialog box.
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3.  Browse your disk and select a .gif image from the Insert Object dialog box.

4.  Click OK to validate and exit the dialog box.

5.  If needed, modify the position of the newly inserted object by dragging it with the cursor.

Remember that you can modify the position as long as you remain in the background view.

You can get something like this, for example:

To go back to the working views and create a front view, for example, go to Edit -> Working views 
before clicking the Front View icon. 

If you want the frame and title block to appear in the newly created sheets when adding sheets, go to 
Tools -> Options -> Mechanical Design -> Drafting -> Layout tab. Check the Copy background 
view option and the First sheet option. This will insert the frame and title block from the sheet you 
previously created on the current drawing.

If you have a viewer installed with the gif type associated to the viewer, you will not visualize the 
inserted image properly (an icon appears instead). If so, click on the displayed icon to get the image.

 



Managing a Background View

This task will show you how to add to a sheet the background view (title block plus elements) from the 
sheet of another drawing.

 

Before you begin, de-activate the Grid icon  from the Tools toolbar (bottom right).

 

1.  Select the Tools -> Options command to display the Options dialog box.

2.  Click Mechanical Design -> Drafting -> Layout tab, and check the Copy background view 

and Other drawing options.

 

●     If you un-check Copy background view, only the sheet properties will be copied from one sheet to 
another.

●     If you check the First sheet and the Copy background view options, the background view of the 
first sheet  will become the reference.

●     If you check the Other drawing and the Copy background view options, the background view of 
the sheet you will select later will become the reference.



 

3.  Click OK in the Options dialog box.

4.  Click the New Sheet icon  from the Drawing toolbar. The Insert Elements into a Sheet 

dialog box appears.

5.  Click the Browse button in the Insert Elements into a Sheet dialog box. The File Selection 

dialog box appears. 

6.  Browse to select the drawing which you will use the background view from.

In this particular case, select the GenDrafting_part_titleblock_insert.CATDrawing document.

7.  Activate the Show Preview option in order to preview the selected CATDrawing document.
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8.  Click Open in the File Selection dialog box. 

The preview of the frame and title block of the selected CATDrawing is now displayed in the 

Insert Elements into a Sheet dialog box.

 

At any time you can decide that you do not want the preview to appear. For this, de-activate the 

Preview On or Off button . 

 
9.  Click the Insert button.

The title block now appears on a new sheet named Sheet 2. 



 

 Each time you need to insert a new sheet with a given frame and title block, go to Tools -> Options -
> Mechanical Design -> Drafting -> Layout tab, and check the Copy background view option and 
the Other drawing option.

 

 



View Creation 

 The Generative Drafting workbench provides a simple method to create views on a predefined sheet. 

 
In this chapter, most of the tasks illustrate how to create views from parts. These views can also be 
created from assemblies (exploded or not). Views created from assemblies are illustrated only whenever 
specific points need to be mentioned.

 

Before you begin: You should be familiar with important concepts.

Create a front view: Use a reference plane on the 3D part to create a front view. If needed, use the 
manipulator to assign the right position to the view.

Create an advanced front view: Create advanced front views to configure such elements as the view 
name, view scale, etc. Whenever possible, a pertinent projection plane is automatically offered.

Create projection views: Use the green frame to automatically generate the projection views as desired.

Create an unfolded view: Create an unfolded view from a Sheet Metal part.

 
Create a view from 3D: Generate a view and the associated annotations from the 3D.

Create an auxiliary view: Define a plane that will be used to generate the auxiliary view.

Create an offset section view: Use a cutting profile to define and position the offset section view.

Create an offset section cut: Use a cutting profile to define and position the offset section cut.

Create a section view (Planar Surface): Use a cutting profile to define and position the offset section view.

Create a section cut (Planar Surface): Use a cutting profile to define and position the offset section view.

Create an aligned section view: Use a cutting profile to define and position the aligned section view.

Create an aligned section cut: Use a cutting profile to define and position the aligned section cut.

Create a section view with profile defined in 3D: Create a section view using a 3D profile as cutting plane.

Create a section cut with profile defined in 3D: Create a section cut using a 3D profile as cutting plane.

Create a detail view: Use a callout to create a detail view via a boolean operator from the 3D.

Create a detail view profile: Use a polygon to create a detail view via a boolean operator from the 3D.

Create a quick detail view: Use a callout to create a detail view by computing the view directly from 2D 
projection.

Create a quick detail view profile: Use a polygon to create a detail view by computing the view directly 
from 2D projection.



Create a clipping view: Create a clipping view with a circle as callout.

Create a clipping view profile: Create a clipping view with a sketched profile as callout.

Create an isometric view: Create an isometric view using a 3D part.

Generate an exploded view: Create an isometric view, and then, projected views from an assembly 
previously exploded via Digital Mock-up workbench (DMU Navigator).

 

Create a broken view: Create a broken view from an active and up to date generative view using two 
profiles corresponding to the part to be broken from the view extremities.

Create a breakout view: Remove locally material from a left generated view, in order to visualize the 
remaining visible internal part.

Create views via the wizard: Create views using a wizard by defining options in the Pre-Defined 
Configurations dialog box.

Create views via the wizard: Automatically create front, bottom and right views using a wizard.

Create views via the wizard: Automatically create front, left and top views using a wizard.

 
Create views via the wizard: Automatically create all the views using a wizard.



Before You Begin
 Before you start creating views, this section provides you with information on the following topics:

●     What is the active view?

●     Defining the view orientation

●     Generated geometry/dress-up settings

●     Generated geometry/dress-up properties

●     Constraints

●     2D/3D associativity

●     3D elements generated in views

●     Callout representation

 
 Note: Views as discussed in this section are created on a pre-defined sheet, and should not be confused 

with working views and background views, which are components of the sheet. For more information on 
these, refer to Sheets. 

 
 

What is the Active View?

 

The active view is the view from which other views will be generated. This is also the view in which all the 
modifications will be performed. For instance, all the 2D geometry and dress-up elements that will be 
added to the draft views to be created.

Open the GenDrafting_part.CATDrawing document.
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 The active view is framed in red. Non-active views are framed in blue.

When you create a view, until you click at the desired view location, the view to be created is framed in 
green. If you click this view, it becomes the active view and is framed in red. 

The active view is underlined in the Drafting specification tree, and specific icons are used to represent the 
view type (Front view, Projection view, Isometric view, etc). Refer to CATDrawing Specification Tree Icons 
for more information. 

 

 

 



 

Activating a view

1. Double-click the frame of the view you want to activate.

OR

1. Right-click the view you want to activate. The contextual menu appears. 

2. Select Activate View. 

Axes are taken into account on active views. As a result, the frame of an active view will adapt to the 
elements included in this view.

 

 

Defining the View Orientation

You can redefine the reference plane orientation of a view to be created using the available blue arrows. 
This is the case when generating a front view, an isometric view or when generating views using the 
wizard.

  

 

Open the GenDrafting_part.CATPart document and start creating a front view.

 

1. Start creating the view. 

2. Click the right or left arrow to visualize the right or left side, respectively.
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 3. Click the bottom arrow to visualize the bottom side.
 

 4. Click the counterclockwise arrow to rotate the reference plane.
 

 5. Drag the green knob to redefine the rotating angle. The default increment value is 30 degrees.
 



 6. You can modify the increment value using the green knob contextual menu. To do this, right-click on 
the knob and select the desired option from the contextual menu. 

 
 

 
●     Free hand rotation: Rotation is not snapped to a given increment but totally free.

●     Incremental hand rotation: This is the default value: the rotation is snapped to a given increment 
(from 30 to 30 degrees, between zero and 300).

●     Set increment...: The Increment Setting dialog box is displayed. Enter the Increment value 
you need. For example 5 deg (5 degrees).

 

 
●     Set current angle to: If you select the Set angle value... option, the  Angle Setting dialog box 

appears.  

 
 

  

Enter the current angle (deg)  you need. For example, 30.
 

  



 

Generated Geometry/Dress-Up Settings

You can generate a number of geometry or dress-up elements, depending on the options you select in 
Tools -> Options -> Mechanical Design -> Drafting -> View tab.

For example, if you want the colors of a part to be automatically generated onto the views, check the 
Inherit 3D colors option. 
If the color of the part is white and the Inherit 3D colors option is checked, the generated views will be 
white and you may not be able to visualize them properly.

 

●     Note that if you modify the graphical properties (color, line type, line thickness) of generated 
geometry or dress-up elements, such modifications associative, i.e. they are kept when updating the 
view later on. Also note that once you have overloaded the original properties of a geometry or a 
dress-up element, you cannot reset it to its original properties. 

●     Note that threads are generated on the condition they are defined on 3D holes. 

●     To project sketches, you need to select the Project 3D wireframe option. However, note that a 
sketch cannot be projected if it is currently being edited in the Sketcher workbench. To project 
sketches, you need to exit the Sketcher workbench before launching the view creation.

 
 

Generated Geometry/Dress-Up Properties

You can change the properties of some geometry and dress-up elements after the view has been 
generated, provided you check the desired options from the Properties dialog box. To display it, choose 
Properties from the contextual menu and select the View tab.

The graphical properties of generated geometry and dress-up elements are kept after you update views. 
This is also true if you delete one or more elements.

 
Note that if you modify the graphical properties (color, line type, line thickness) of generated geometry or 
dress-up elements, such modifications associative, i.e. they are kept when updating the view later on. 
Also note that once you have overloaded the original properties of a geometry or a dress-up element, you 
cannot reset it to its original properties. 

 
 

Constraints

Constraints detected when views are generated from the 3D do not appear on the drawing.

 



 

2D/3D Associativity

... On Views

A generative view results from specifications in a 3D document. This specification corresponds either to 
the whole document or to a feature in the document. This feature can be: 

1.  a .model document
2.  a part document (the whole document or still one or more bodies)
3.  a product document (the whole document or still one or more assemblies)

Any modification applied to the specifications, before the generated view(s) is/are updated, is detected. 
You can perform an update. You can update all views or a selection of views:

●     The Update icon  is active in the Update toolbar when a sheet (or drawing) contains views that 

need to be updated (this can be all views in the sheet or some of them only). You can update all views 
in the active sheet by clicking this icon. 

●     An update symbol  appears in the specification tree for the views that need to be updated. You 
can update a selection of views by selecting and right-clicking the view(s) you want to update and 

choosing Update Selection  from the contextual menu. Only the items you 
select are updated. Update symbols remain in the specification tree for the items that have not been 
updated, so you always know which items are up-to-date and which are not.

●     Update symbols also appear in the specification tree to indicate drawings  and sheets  
containing views that need to be updated. You can update all views in a given sheet (or in a selection 
of sheets), by selecting and right-clicking the sheet(s) and then choosing Update Selection. You can 
also use the same method for a drawing: this will update all sheets (and therefore all views) in the 
drawing. 

●     During an update process, a dialog box is displayed to show the progress of the update. 
When the update involves several views, a Cancel button is available in this dialog box. This allows 
you to interrupt the update. The view that is being processed at the time you click this button will be 
updated (i.e. the update of the current view will finish), and then the update will stop. The subsequent 
views will not be updated.

 

... And View Positioning

Generative views are positioned according to the center of gravity of the 3D part. If you modify a 3D part 
in such a way that the center of gravity of the part changes, then, when updating the view, the position of 
the view will be re-computed according to the new center of gravity of the part and will be modified 
accordingly. 

 



 

... After Updating

Use the following commands to update views:

●     Click the Update icon  to update all views in the active sheet.

●     Select and right-click the views you want to update and choose Update Selection 

 from the contextual menu to update a selection of views. 

●     Type C:Force Update  to update the drawing in accordance with the 3D. Be careful 
when doing this, as you may loose manual modifications applied to the drawing.

During view update, the following operations are performed: 

●     associative section/auxiliary view profiles are re-computed

●     the geometry is re-generated

●     any annotation/dimension/dress up element linked to the generated geometry is re-computed

●     in the case of elements (one or more) that have been graphically modified or deleted, these 
modifications/deletions are preserved, on the condition the view was up-to-date when you deleted or 
modified it.

 

●     Note that you can restore deleted elements at any time by selecting the Restore Deleted option from 
the contextual menu and then updating the view. You can either use the Update icon if you modified 
the 3D part, or key in C:Force Update if you did not modify the 3D part.

●     If you delete a generated item and subsequently perform an update, all items that have the same 3D 
origin as the deleted item will not be generated. Likewise, if you transfer a generated item to No Show 
and subsequently perform an update, all items that have the same 3D origin as the item in No Show 
will be transferred to No Show.

 

... On Generated Dimensions

Generated dimensions are associative with the 3D part constraints on the condition you checked the 
Generation dimensions when updating the sheet option from the Options dialog box (Tools -> Options -
> Mechanical Design -> Drafting  -> Generation tab). 



Note that these dimensions will be re-generated in accordance with the other options checked/un-checked 
in the Options dialog box. 

 

... On Color

When you refresh a generated view you have modified, the colors are re-generated with the geometrical 
information from the part, and you might obtain unexpected results.

As an example, if you create this part...
 

  
 ...and then modify an element in the following generated view, such as the color of line "a" as in this 

example:



 

  
 ...then, when updating the generated view, lines a and b will be red: 
 

  
 The reason is that the view is refreshed with the part information and a and b lines are considered as the 

intersection of two planes and not as two different elements of the generative view. 

Note that modifications performed on the graphical properties (color, line type, line thickness) of a 
generated geometrical element (as is the case in our example above) are associative, i.e. such 
modifications are kept when updating the view later on. Also note that once you have overloaded the 
original properties of an element, you cannot reset it to its original properties. 

 

...On Show / No Show

When a part body is swapped to visible or invisible space, the corresponding generated views are 
updateable (Update function button activated).

Note that elements swapped to visible or invisible space remain so when you update the view later on. 



 

3D Elements Generated in Views

3D elements are handled differently depending on their type and on the type of view you are generating.

Section cuts, section views, and breakout views

All CATPart elements, as well as Exact Solid and Skin elements from .model documents are supported in 
exact mode.

Projections, quick detail views, clipping views and broken views

Exact mode

●     All CATPart elements are supported.

●     Exact Solid and Skin elements from .model documents are supported.

CGR and raster mode

●     All CATPart elements except wireframe and 3D points are supported.

●     All elements from .model documents are supported.

●     External MultiCAD components are supported.

  
 

Callout Representation

You can specify that the size of callout elements should not be dependent on the view scale. You have two 
ways of doing this:

●     After callout creation, right-click on the callout, select Properties in the contextual menu and check 
Size not dependent on view scale on the Callout tab.

or

●     Before callout creation, in Tools -> Options -> Mechanical Design -> Drafting -> Layout tab, 
check the Size not dependent on view scale option. This option will apply to newly created callouts, 
i.e. selecting this option will not have any impact on existing callouts.

Note that this option only applies to drawings created with versions prior to V5 R11 (i.e. versions up to 
V5 R10).

 



Creating a Front View  

This task will show you how to create a front view either from a part or from the sub-part of a product. 
You will use a reference plane. You will also learn how to create a front view with local axis system, 
and how to create a front view from specific sub-bodies/sub-products.

 

 

A front view is a projection view obtained by drawing perpendiculars from all points on the edges of the 
part to the plane of projection. The plane of projection upon which the front view is projected is called 
the frontal plane.

 

Creating a front view

 
Open the GenDrafting_part.CATPart document. Define a new drawing sheet.

 
1. Click the Front View icon  from the Views toolbar. 

2. Select one plane of the 3D part or a plane surface, to define the reference plane.
Blue arrows appear. 

 

If you select a plane surface, the reference orientation will be the external normal of the planar 
surface.
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To define the reference plane, you can also select: 
●     Two edges: these edges correspond to both axes defining the reference plane according to which 

the front view will be generated. The first edge determines the horizontal axis.

●     A point and an edge, or three points: you will thus define a plane.

In other words, you will select, in the geometry, one of the followings:

●     a plane

●     a point and then an edge

●     an edge and then a point

●     two edges

●     two points and then an edge

●     three points

 

Note that you can redefine the projection plane using the arrows at any time before the view 
generation.

 3. Click inside the sheet to generate the view.

 

Right-click the frame of the view, select the Properties option from the contextual menu, Generation 
tab and check the required options in the  Properties dialog box. By default, the axis and center lines 
are generated. You can also view hidden lines, threads, fillets, project 3D points, etc.

●     In the case of an assembly view, you can insert Bill of Material information into the active view.

●     In a Product Structure context, if you create a front view from a scene of a product, you can 
directly select the Scene object in the specification tree. You do not necessarily need to select the 
Product and sub-products any more. 



 

Creating a front view with a local axis system 
This functionality allows you to take into account a local axis system when creating a view. That way, 
the origin of the generated view is the projection of the origin of the local axis system selected in the 
view plane. 

 
Open the Axisprojection.CATPart document. Define a new drawing sheet.

1. Select the drawing to activate it and click the Front View icon  from the Views toolbar.

2. In the Part tree, select the local axis system, i.e. Axis System.1. 
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3. Select one plane of the 3D part or a plane surface, to define the reference plane. 

4. Click in the drawing to end the view creation. The part local axis system appears in the view. 



When creating views with a local axis system, only the origin of the axis system is taken into account 
and respected in the generated view. The orientation is not taken into account.

 

 

Create a front view from specific sub-bodies/sub-
products 

  

 

You can multi-select specific sub-products in a product and/or several sub-bodies in a part to create 
front views displaying the selected elements only. These multi-selected 3D elements will be previewed 
and then used as reference planes for generating several front views.

Open the Product_Balloon.CATProduct document. Double-click Scene1 at the down left of the screen.

1. Click the Front View icon  from the Views toolbar. 

 

 2. Select one body or press the Ctrl key and then multi-select the desired elements in the specification 
tree.
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 3. In the 3D, point to the geometry to choose a projection plane. As you go over the geometry with the 
cursor, the oriented preview automatically appears on the 3D document.

 



 

Be careful: once you multi-select bodies or sub-products, and go further into the procedure, you 
cannot select or de-select any more bodies or sub-products.

 
●     As you highlight a 3D element (going over it with the cursor), you can preview and then select the 

plane corresponding to this highlighted element.

●     As you highlight and select one or more elements defining the final plane, you can preview and 
assign a given orientation to this final plane.

●     Once you defined the plane, you can preview the front view within the 3D document.

Note that once an element is selected, this element becomes gray colored.

In addition, you can only work in one 3D document. If you try selecting another document, you 
automatically leave the Front View command. 

 



 4. When the oriented preview corresponds to the projection plane you want, click on the plane to 
validate. 

The front view is previewed. At this point, you can still modify its orientation: 

 

 5. Click on the drawing to generate the view. 

 



 

 

 

Creating a front view using selection sets  

You can also use selection sets to select the sub-bodies and/or sub-products from which you want to 
generate the front view. 

 

Selection sets let you gain in productivity, particularly in the case of large assemblies, when generating 
several views with numerous common features: you can select and store these features once and 
reuse the selection set as often as necessary without having to select the features again. 

 

Open the Product_Balloon.CATProduct document. 

 

1. Before you start creating views from selection sets, you first need to create one or more selection 
sets for this product. For more information, refer to Storing Selections Using Selection in the 
Infrastructure User's Guide. For example, create a selection set to store the product screws.

2. Click the Front View icon  from the Views toolbar. 
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 3. Activate the CATProduct document and select Edit -> Selection Sets...

4. In the Selection Sets Selection dialog box that is displayed, select a selection set and click the Select 
button. The selection set items are highlighted in the 3D and in the specification tree. 

For more information, refer to Selecting Selection Sets in the Infrastructure User's Guide.

 

Once you have selected a selection set, you can use the Ctrl key to select additional sub-bodies or sub-
products.

 

 5. In the 3D, point to the geometry to choose a projection plane. As you go over the geometry with the 
cursor, the oriented preview automatically appears on the 3D document.
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 6. When the oriented preview corresponds to the projection plane you want, click on the plane to 
validate.

The front view is previewed. At this point, you can still modify its orientation:

 

 7. Click on the drawing to generate the view. 



 

●     You can also use selection sets when creating isometric views and advanced front views. 

●     Views created from selection sets are not associative with the selection sets themselves: if you 
modify a selection set after having created a view from it, the view will not be seen as needing an 
update, and if you do update the view, its definition will not change. You have to create the view 
over again in order for your modifications to be taken into account.

 



Creating an Advanced Front View   

 

This task will show you how to create an advanced front view. Creating advanced front views lets you 
configure such elements as the view name, view scale, etc. Whenever possible, a pertinent projection 
plane is automatically offered. 

For more information on front views in general, refer to Creating Front Views.

 

Open the Pinmounting.CATPart document. Define a new drawing sheet. Activate the drawing by 
selecting the drawing window. 

1.  Click the Advanced Front View  icon. A dialog box appears: 

 

 2. Name the view in the associated field:
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 3. Modify the scale value in 1:2

 

 4. Click OK to validate your settings.

5. Select one plane of the 3D part or a plane surface, to define the reference plane.
Blue arrows appear, you can still choose a plane and an orientation before view generation.

6. Click inside the sheet to generate the view.

 

The DMU Space Analysis workbench lets you create section boxes in 3D. When generating advanced 
views from the DMU Space Analysis workbench, you can select this section box to generate a view 
displaying only the box content. If you then modify the section box in 3D, the view will be shown as 
needing an update in the drawing. If you destroy the section box in 3D, the box definition will remain in 
the drawing. For more information on section boxes, refer to Creating Section Boxes in the DMU Space 
Analysis User's Guide.

 

You can use selection sets to generate advanced front views displaying a selection of elements only. 
Selection sets let you select the sub-bodies and/or sub-products from which the view will be generated. 
Refer to Creating a front view using selection sets for more information.

 



Creating a Projection View 

This task will show you how to create projection views on the sheet, relatively to the front view 
previously generated. 

Projection views are views conceived to be drawn or projected onto planes known as planes of 
projection. A transparent plane or pane of glass representing a plane of projection is located parallel to 
the front surfaces of the part.

 

Open the GenDrafting_front_view.CATDrawing document.

 

1. Click the Drawing window, and double-click the Projection View icon  from the Views toolbar 
(Projections sub-toolbar). 

 As you move the cursor, a previewed projection view in a green frame appears on the sheet.

2. Define the projection view position by positioning the cursor at the desired view location, for example 
the right view position. 

3. Click inside the green frame to generate the view. 
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Note that the left view above was created and therefore positioned according to the first projection 
method. Projection methods are described in Creating Views via the Wizard.

 4. Define the bottom view position. 

5. Click inside the sheet to generate the view. 

 

 6. Click on the Projection view icon to end the projection view creation.



Creating an Unfolded View  

This task shows how to create an unfolded view from a sheet metal part. An unfolded view is a 
projected view that is created from a sheet metal part in order to include in a section certain angled 
elements. As a result, the cutting plane may be bent so as to pass through those features.

In other words, you will extract drawings from the SheetMetal Design or the Generative Sheetmetal 
Design workbench or the Aerospace SheetMetal Design workbench. For more information, refer to the 
appropriate user's guide.

The Unfolded View command is active in the Generative Drafting workbench with a Version 5 
SheetMetal Design, Generative Sheetmetal Design or Aerospace SheetMetal Design license.

 

Open the GenDrafting_sheet_metal.CATPart document. 

Tile the windows horizontally to see both your drawing sheet and your sheet metal part at the same 
time.

 

1. From the Drafting workbench, click the Unfolded View icon  from the Views toolbar 
(Projections sub-toolbar). 

 

2. Select a surface on the part. This will automatically use the sheet metal reference wall plane. 

If you prefer to specify which plane should be used, select the plane in the Sheet Metal specification 
tree. 

3. Click on the sheet. 

The unfolded view is displayed. It shows the axis lines resulting from bend axes, as well as bend limits. 
These axis lines and bend limits are represented as dashed lines.

With sheet metal parts containing holes, the hole axes (center line) are also represented on the view.
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The unfolded view looks like this: 

 



4. Select one of the axis lines. Manipulators appear, allowing you to modify this line. 

 

 



Creating a View from 3D 

This task shows how to generate views and the associated annotations from the 3D (Functional Tolerancing and Annotation 
workbench). 

A view from 3D is extracted from a 3D part, product or process that is assigned 3D tolerance specifications and annotations. 
The master document is the 3D part, product or process, which means that everything is handled at the 3D level: view 
definition (projection view, section view, section cut), annotation content and graphism. For this reason, it is recommended to 
perform modifications directly in  3D.

You can generate the following types of view from 3D: 

●     projection views, section views, section cuts

●     aligned section views, aligned section cuts, offset section views, offset section cuts

 

Creating projection views, section views, section cuts
Open the 3DViews.CATPart document. Tile the screen horizontally by selecting Window -> Tile Horizontally from the menu 
bar.

In addition, make sure that the parent standard used in the CATDrawing document and in the CATPart (annotations) is the 
same. Otherwise, both the view and the annotations may not be generated. In our scenario, the parent standard used in the 
3DViews.CATPart document is ISO. Therefore, the parent standard used in the CATDrawing document should be ISO.

 

1.  Click the View From 3D icon  from the Views toolbar (Projections 

sub-toolbar).

 

2.  Select a view from the 3D, either in the specification tree or on the part. In this case, select Projected View.1 in the 

specification tree.
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The view to be created is previewed (included annotations) on the sheet. You cannot modify the view orientation, but 
you can modify the view position by dragging it using the right mouse button.

3.  Click on the sheet to create the new view. 

 

 You can notice that one of the extracted annotations (datum B) bears a red cross mark, which indicates that the 
leader cannot be extracted linked to the geometry. This is because the 3D annotation leader is linked to 3D geometry 
which is not visible in the 2D view (i.e. hidden geometry). 

Such a red cross mark will be used for any annotation or dimension with a leader linked to hidden geometry (i.e. 3D 
geometry which is not visible in a 2D view). You can either change the properties of the view from 3D (Edit -> 
Properties) to display hidden lines, or transfer the marked annotations to a 3D view where the associated geometry 
will be visible when extracted.



 

4.  Repeat the first two steps, this time selecting Projection View.2 as the view to be created.

5.  Once again, repeat the first two steps, this time selecting Section Cut View.1. The preview is displayed on the sheet.

6.  On the sheet, click Projection View.2 to specify that the callout for the section cut should be positioned in that view. 

Note that it works the same for section views. 

 

In views from 3D, the axis can only be that of the sheet: the H and V axis of the view must correspond to X and Y 
axis of the sheet.
For this reason, the choice of the view in which to add a section cut callout is limited.
In particular, the profile of the section cut must be horizontal on the chosen view.
In the case of extraction views, the first line of the profile (i.e. corresponding to the first compounding view) must be 
horizontal.

 

7.  Click on the sheet to create the view. 



 

 

Creating aligned section views/section cuts and offset section 
views/section cuts
Open the 3DViews_AlignedSectionView.CATPart document. Tile the screen horizontally by selecting Window -> Tile 
Horizontally from the menu bar. Make sure that the parent standard used in the CATDrawing document and in the CATPart 
(annotations) is the same.

1.  Click the View From 3D icon  from the Views toolbar (Projections 

sub-toolbar).

 

2.  Select the aligned section view from the 3D, either in the specification tree or on the part. In this case, select Projected 

View.1 in the specification tree.
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 The view to be created is previewed (included annotations) on the sheet. You cannot modify the view orientation, but 
you can modify the view position by dragging it using the right mouse button.

3.  Click on the sheet to create the new view. 

 



More About Views from 3D
●     Only the elements visualized in the 3D (i.e. in Show mode) at the time of extraction are extracted in the view from 3D. In 

other words, any element hidden in the 3D will not appear in the view. If you then show this element in the 3D part, it will 
be displayed in the view from 3D after you update it.

●     You can move or modify annotations in views from 3D. However, if the part is modified and you subsequently update the 
view, any modification applied to the annotations in the drawing will be lost. We advise you perform modifications on the 3D 
part directly. 

●     Extracted annotations are not associative to the geometry. 

●     2D annotations can be added to views from 3D.

●     Views from 3D cannot be rotated. In other words, when you edit the properties of this view (Edit -> Properties), the 
Angle field is grayed out and cannot be edited.

●     In views from 3D, the horizontal axis of the view is parallel to the horizontal axis of the sheet.

●     You can create views from 3D from a part (Functional Tolerancing and Annotation workbench), a product (Product 
Functional Tolerancing and Annotation workbench) or a process (Process Tolerancing and Annotation workbench). It is 
currently impossible to extract views from part, product and process at once. However, you can superpose views as a 
bypass (using the View Positioning -> Superpose contextual command).

●     Views from 3D are not associative to the geometry of the 3D view. So, if you modify the geometry of a 3D view, the 
definition of the corresponding 2D view will not be modified at the next update, even if the 3D view is associative to the 
geometry. 

 
●     The Note Object Attribute (NOA) from a ditto (2D component) is now extracted in views from 3D. However, if a frame is 

defined in 3D, this frame is not displayed in the 2D view. To work around this, do not use the 3D annotation frame when 
defining the NOA reference; instead, have your administrator define the frame as part of the 2D component geometry.

 



Creating an Auxiliary View 

 

This task will show you how to create an auxiliary view.  

Many objects are of such shape that their principal faces cannot always be assumed parallel to the 
regular planes of projection. Creating an auxiliary view allows showing the true shapes by assuming 
a direction of sight perpendicular to planes that are perpendicular of the curves. This auxiliary view, 
together with the top view, completely describes the object.

 

 

 

Open the GenDrafting_part.CATDrawing document. Make sure the right view is active (double-click 
to activate it).

 

1.  Click the Auxiliary View icon  from the Views toolbar 

(Projections sub-toolbar).

 

 

2.  Sketch the representation of the plane. In this case, click 
an edge on the right view. 

You could also click a point and then an edge.

Both the 3D surface and the sketched plane are 
associative.

The selected edge becomes a line that you can position 
where desired using the cursor. This line/callout will be 
automatically used as the plane. 
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3.  Click to position the callout. 

The reference plane is automatically positioned 
according to the selected edge.

Positioning the auxiliary view callout amounts to defining 
the auxiliary view direction.

. 

4.  Click to position the auxiliary view. 

Before clicking, as you move the cursor 
within a zone perpendicular to the plane, a 
preview of the auxiliary view to be created 
simultaneously appears. This view will be 
automatically positioned accordingly. This is 
also true when creating a section view or a 
section cut.

You can also move the cursor outside the 
zone perpendicular to the plane and position 
the view where you want.

Note that the callout can be inverted or 
graphically modified. 



●     You can move the view freely after it has been created, providing you position it independently 
of its reference view. For this: 

1. Right-click the frame of the view you want to move.

2. Select the View Positioning -> Position Independently of Reference 
View from the displayed contextual menu. 

3. Drag the view to the desired location. 

  

 

●     You can choose the auxiliary view axis orientation. For this go to Tools -> Options -> 
Mechanical Design -> Drafting -> Layout and check the Auxiliary and/or section views 
orientation according to profile option.

 



Creating an Offset Section View / Cut 

 This task will show you how to create an offset section view/cut using a cutting profile as cutting plane. In sectioning 
through irregular objects, it is often desirable to show several features that do not lie in a straight line by offsetting or 
bending the cutting plane.

 

 Open the GenDrafting_section_view02.CATDrawing and GenDrafting_section_view.CATDrawing documents. 

Make sure the front view is active (use double-clicking). 

Delete the text assigned to the front view (right-click on the text and select Delete option from the contextual menu).

 

1. 
 

Click the Drawing window, and click the Offset Section View icon  or the Offset Section Cut icon  from the Views 

toolbar (Sections sub-toolbar). 

 
 2. Select the elements required for sketching the cutting profile: points, edges (linear or circular), center lines, axes. 

  
If you are not satisfied with the profile you create, you can, at any time, use Undo  or  Redo  icons. Note that 
SmartPick assists you when creating this profile.

The section plane appears on the 3D part and moves dynamically on the part.

3. 
 

Double-click to end the cutting profile creation.

  Offset section view

Positioning the section view using the cursor amounts to defining the section view direction. The cutting profile is hole 
associative.
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4. Click to define the section view direction and to position the view on the sheet. 

The view name and scale appear on the generated view as you checked the View name and Scaling factor options in the 
Options dialog box.

Even when the view is generated, you can edit and modify the section profile. For this double-click this profile and either 
invert or replace it. 

 



 

  Offset Section Cut 

Positioning the section cut using the cursor amounts to 
defining the section cut direction. The cutting profile is hole 
associative.

For the purpose of this scenario, select a circular edge and 
double-click when you are satisfied with the position of the 
rotating profile that automatically appears on the 3D view. 

 

 

 

  

 

  

 



4. Click to define the section cut direction and to position the 
view on the sheet.

 

  

 

 
 

The view name and scale appear on the generated view as you checked the View name and Scaling factor options in the 
Options dialog box. 

 

 

●     The frame of the active view adapts to the length of the cutting profile. 

●     You can insert Bill of Material information into the active view.

●     You can assign a line type to the view to be generated. For this, go to Tools -> Options -> Mechanical Design -> 
Drafting -> View tab, click the Configure button next to View Linetype and select the desired option from the dialog 
box.

 

 

 

Pattern

The patterns which are used to represent the section are defined in the standards. For more information, refer to Pattern 
Definition in the Interactive Drafting User's Guide. 

 You may modify the pattern (hatching, dotting, coloring or motif) by right-clicking the pattern and selecting Properties 
from the contextual menu. This will display the Properties dialog box in which you may either select a new pattern or 
modify some graphical attributes of the existing pattern. For more information, refer to Modifying a Pattern. 

 
Patterns will not be applied to offset sections which are tangent to 3D faces.

 

Apply uncut specification

In an assembly, you can define that given parts will or will not be sectioned when generated into section views or breakout 
views.
In the Assembly Design workbench, select one part, then the Edit -> Properties command from the menu bar from and 
either activate or de-activate the Do not cut in section views options.
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Creating a Section View / Cut (Planar Surface)

This task will show you how to create a section view / section cut using a planar surface or a wireframe 
plane in the 3D.  

A section view / section cut is a view that allows sectioning through irregular objects, and thereby allows 
showing several features that do not lie in a straight line by offsetting or bending the cutting plane.

 

 

Open the GenDrafting_part.CATPart and the GenDrafting_front_view.CATDrawing documents. 

Make sure the front view is active on the drawing (double-click to activate it).
Tile your windows vertically to see both your part and the related drawing.

 

1.  Click the Drawing window, and click the Offset Section 

View icon  or the Offset Section Cut icon  from 

the Views toolbar (Sections sub-toolbar).

2.  Select a planar surface on the 3D part. This planar surface 

need to be perpendicular to the projection plane of the active 

view.

The section plane appears on the 3D part and moves 

dynamically on the part.

The cutting profile is automatically displayed on the front 

view as well as a preview of the view to be generated.
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3.  Click to generate the view.

●     The patterns which are used to represent the section are defined in the standards. For more 
information, refer to Pattern Definition in the Interactive Drafting User's Guide. 

 
●     You may modify the pattern (hatching, dotting, coloring or motif) by right-clicking the pattern and 

selecting Properties from the contextual menu. This will display the Properties dialog box in which 
you may either select a new pattern or modify some graphical attributes of the existing pattern. For 
more information, refer to Modifying a Pattern. 
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Creating an Aligned Section View / Cut

This task will show you how to create an aligned section view and/or aligned section cut using a cutting 
profile as cutting plane.  

An aligned section view / cut is a view created from a cutting profile defined from non parallel planes. In 
order to include in a section certain angled elements, the cutting plane may be bent so as to pass 
through those features. The plane and feature are then imagined to be revolved into the original plane.

 

Open the GenDrafting_aligned_view02.CATDrawing document.

 

1. Click the Drawing window, and click the Aligned Section Cut 

. 

If desired, you can also click the Aligned Section View  icon 
from the Views toolbar (Sections sub-toolbar).

 

 

 2. Select the elements required for sketching the cutting profile: points, edges (linear or circular), center 
lines, the axis.  

 
If you are not satisfied with the profile you create, you can, at any time, use Undo  or  Redo  
icons. Note that SmartPick assists you when creating this profile.
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The section plane also appears on the 3D part and moves dynamically on the part.

3. Double-click to end the cutting profile creation. 

 

Positioning the section view amounts to defining the section cut direction. The cutting profile is hole 
associative.

 



4. Click to generate the view. 

 

 

The patterns which are used to represent the section are defined in the standards. For more information, 
refer to Pattern Definition in the Interactive Drafting User's Guide. 

 You may modify the pattern (hatching, dotting, coloring or motif) by right-clicking the pattern and 
selecting Properties from the contextual menu. This will display the Properties dialog box in which 
you may either select a new pattern or modify some graphical attributes of the existing pattern. For 
more information, refer to Modifying a Pattern. 

Patterns will not be applied to aligned sections which are tangent to 3D faces.
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Creating a Section View / Cut with Profile 
Defined in 3D 

In this task, you will learn how to create a section view or a section cut using a 3D profile as cutting 
plane. 

Section views / section cuts are usually created using a cutting profile as the cutting plane; such a 
profile is typically driven using concentricity or parallelism constraints. Defining a profile in 3D to create 
a section view / section cut enables you to make the profile associative with the geometry, and therefore 
to drive this profile using dimensional constraints, for example.

 

 

Open the GenDrafting_part.CATPart and the GenDrafting_front_view.CATDrawing documents. 
Tile your windows vertically to see both your part and the related drawing. 

 

1. In the Part window, click the Sketcher icon  and select the xy plane as the reference plane. You 
are now in the Sketcher workbench.

2. Click the Profile icon  and sketch the 
profile you will use as cutting plane. For the 
purpose of this exercise, make sure you sketch 
your profile using orthogonal lines. 
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3. You can now create dimensional constraints 
between your profile and other elements. Click 

the Constraint icon .  

4. Now, click a vertical line and the edge of the 
part to create a dimensional constraint between 
them.

 
5. Exit the Sketcher workbench. 

6. In the Drawing window, click the Update icon  to update the view.

7. Click the Offset Section View icon  from the Views toolbar (Sections sub-toolbar). 

 

Depending on the type of profile you sketched and on the type of section (offset or aligned) you want, 
you can select another icon on the Sections sub-toolbar. If the 3D profile is not valid for generating the 
appropriate view, you will not be able to select it. In this case, you will need to select another icon.



8. Select the profile on the 3D part. 

The cutting profile is automatically displayed on 
the front view as well as a preview of the view to 
be generated. Positioning the section view 
amounts to defining the section view or the 
section cut direction.

 

9. Click to generate the view.

 

●     You can modify the section view / section cut by editing the 3D profile. After doing so, don't forget to 
update the drawing.

●     When editing a 3D profile, make sure that you modify it in accordance with the type of section 
(offset or aligned) you created: if an edited profile is invalid when you update a drawing, the 
associated section view / section cut will not be displayed (an error symbol will appear instead).

●     If you delete the 3D profile and then update the drawing, the section view / section cut will not be 
deleted. The profile will no longer be associated with the geometry. You can subsequently edit the 
profile directly in the drawing by double-clicking it.

●     The patterns which are used to represent the section are defined in the standards. For more 
information, refer to Pattern Definition in the Interactive Drafting User's Guide. 

●     You may modify the pattern (hatching, dotting, coloring or motif) by right-clicking the pattern and 
selecting Properties from the contextual menu. This will display the Properties dialog box in which 
you may either select a new pattern or modify some graphical attributes of the existing pattern. For 
more information, refer to Modifying a Pattern.

●     Patterns will not be applied to aligned sections which are tangent to 3D faces.

http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugsa0413.htm


Creating a Detail View / Detail View Profile 

This task will show you how to create from the 3D a detail view using either a circle as callout or a 
sketched profile. Note that the procedure varies slightly depending on the method you choose.

A detail view is a partial generated view that shows only what is necessary in the clear description of 
the object. Note that the Detail view command uses a Boolean operator from the 3D whereas the Quick 
Detail view command computes the view directly from the 2D projection. The representation is 
therefore different.

 

Open the GenDrafting_isometric_view.CATDrawing document.

 

To create a detail view (this is the method illustrated here):

1. Click the Drawing window, and click the Detail View icon 

 from the Views toolbar (Details sub-toolbar).

2. Click the callout center.

3. Drag to select the callout radius and click a point to 
terminate the selection. 

 

OR 

To create a detail view using a sketched profile:

1. Click the Drawing window, and click the Detail View Profile icon  from the Views toolbar (Details 

sub-toolbar).

2. Create  the points required for sketching a polygon used as profile.

3. Double click to end the cutting profile creation. 

 

●     SmartPick assist you when sketching the profile.

●     You do not necessarily need to close the profile: the profile will  automatically be closed.
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The dress-up elements generated from the 3D are identified and represented in the generated detail 
view whereas it is not when generating quick detail views. 

4. Click to generate the detail view. 

The default scale is 2 (twice the scale of the active view). You can modify this scale.

5. Right-click the detail view and select the Properties option from the contextual menu, View tab. 
Enter the desired Parameters Scale, for example 3 and then click OK in this Properties dialog box.

 



 

 

●     You can also modify the detail view boundary (Properties dialog box).

●     You can assign a line type to the view to be generated. For this, go to Tools -> Options -> 
Mechanical Design -> Drafting -> View tab, click the Configure button next to View Linetype 
and select the desired option from the dialog box.

●     In the isometric view, you can move the detail text ("A" in this example) after detail view creation.

●     If you create a detail view from a section view and subsequently modify the cutting profile in the 
section view, in such a way that the detail view is no longer accurate, the detail view cannot be 
updated so as to take into account the changes in the cutting profile.

●     If you create a broken view from a view which contains a detail view callout, the detail view callout 
will not be broken in the broken view. In other words, the circular shape of the callout will not be 
modified, even if the callout overlaps the break profile. As for the detail view, it will not modified by 
the break operation.

 



Creating a Quick Detail View / Quick Detail View 
Profile 

This task will show you how to quickly create a detail view using either a circle as callout or a sketched 
profile. In this particular case, we create a quick detail view using a sketched profile as we create this 
detail view from an oblong part. Note that for creating a detail view using a circle, the dialog is exactly 
the same. 

A detail view is a partial generated view that shows only what is necessary in the clear description of 
the object. Note that, the Quick Detail view command computes the view directly from the 2D 
projection whereas the Detail view command uses a Boolean operator from the 3D. The representation 
is therefore different.

 

 

 

Open the GenDrafting_isometric_view.CATDrawing document. 

 

1. Click the Drawing window and click the Quick Detail 

View Profile icon  from the Views toolbar (Details 
sub-toolbar). 

If you create a detail view using a sketched profile, 

you will click the Quick Detail View icon .

 

2. Select  the points required for sketching a polygon. 

3. Double click to end the cutting profile creation. 

Note that you do not necessarily need to close the profile. If so, the profile will  automatically be closed. 
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4. Click to generate the quick detail view.

Unlike a detail view , the boundary is entirely 

closed. You can modify this detail view boundary 
(Properties dialog box).

 

 



●     The default scale is 2 (twice the scale of the active view). You can modify this scale. For this, right-
click the detail view and select the Properties option from the contextual menu, View tab. Enter 
the desired Parameters Scale and then click OK in this Properties dialog box.

●     You can insert Bill of Material information into the active view.

●     You can assign a line type to the view to be generated. For this, go to Tools -> Options -> 
Mechanical Design -> Drafting -> View tab, click the Configure button next to View Linetype 
and select the desired option from the dialog box.

 



Creating a Clipping View and/or a Clipping View 
Profile 

 

This task will show you how to create a clipping view using a circle as callout. You can also use a 
roughly sketched profile.

A clipping view is a partial view that shows only what is necessary in the clear description of the object. 
This operation is applied directly onto the active view.

 
Open the GenDrafting_clipping_view.CATDrawing document. 

 
1. Click the Drawing window, and click the Clipping View icon  

from the Views toolbar (Clippings sub-toolbar).   

If you create a clipping view using a sketched profile, you will 

select the Clipping View Profile icon .

 

 
2. Select the center of the circle, or select the required points for sketching a polygon if you are creating a 

clipping view using a sketched profile. 
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3. To end the clipping profile creation, release the mouse in the case of a circle, or double-click in the case 

of a polygon.

The clipping view and the associated profile result as shown here:

 

 



 

Note that the generated dimensions that are not in the clipping view and the annotations that are not 
linked to the generated clipping view anymore are automatically turned into the NoShow mode. 

 
 4. Click the Swap visible space icon  from the View toolbar.

 
  

 
  You can now visualize the dimensions and annotations that do not appear on the clipping view anymore 

and, if needed, make them appear again on the clipping view.

 

 

 

You can select the Unclip option from the contextual menu. However, selecting this option will not 
make the dimensions re-appear on the unclipped view. 

 

 5. 

 

Click the Hide/Show icon  from the View toolbar. 

 



 6. Select the dimension you want to display on the clipping view. 

 
 7. Click the Swap visible space icon  from the View toolbar.

The selected dimension now appears on the clipping view again.

 

 

●     You can insert Bill of Material information into the active view.

●     Once a clipping has been applied onto a view, it is impossible to create detail views, breakout views 
and broken views from this view.

 



Creating an Isometric View 

 

This task will show you how to create an isometric view from a 3D part.  

The Isometric View command enables you to create a 2D view with any orientation, this orientation 
being the same as the one in the 3D viewer. Among other results, and depending on how the 3D viewer 
is oriented when you create the view, you can obtain a regular X-Y-Z isometric view.

Isometric means "equal measure". To produce an isometric projection, it is necessary to place the object 
so that its principal edges make equal angles with the plane of projection and are therefore 
foreshortened equally. Note that an isometric view created from a product can be re-used for generating 
an exploded view.

 

 

Open the GenDrafting_part02.CATPart document. Start creating a new drawing (and this case, create an 
empty sheet). Tile your windows vertically to visualize the 3D part and the sheet at the same time.

 

In a Product Structure context, if you create a front view from a scene of 
a product, you can directly select the Scene object in the specification 
tree. You do not necessarily need to select the Product and sub-products.

1.  Click the Drawing window, and click the Isometric View icon  from the Views toolbar 

(Projections sub-toolbar).

 

 
2.  Define the 3D viewer orientation according to the result you want to obtain in the view. For this, 

you can either manipulate the viewer directly, or use the View > Named Views command in 3D 

to define your orientation precisely.
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Prior to defining your orientation, it may be useful to use different canonical points of view by defining 
the corresponding local axis systems in 3D. For more information, refer to Axis System in the Part 
Design User's Guide. 

 

3.  Click the 3D part.

 A green frame with the preview of the isometric view to be created, as well as blue 
manipulators, appear. You can re-define the position of the view to be created using these 
manipulators: to the bottom, the left, the right, the top, or rotated using a given snapping or 
according to an edited rotation angle. For more information, refer to Before you begin.

 

You can use selection sets to generate isometric views displaying a selection of elements only. Selection 
sets let you select the sub-bodies and/or sub-products from which the view will be generated. Refer to 
Creating a front view using selection sets for more information.

 



Creating an Exploded View

This task will show you how to create an isometric view, and then, projected views from an assembly previously exploded via 
Digital Mock-up workbench (DMU Navigator).

 

Open Gun_Body.CATProduct.

 

1.  Go to the Digital Mock-up workbench (DMU Navigator) and define the Scene with the adequate orientation and with 

the instances properly positioned. 

 

 

2.  Explode the view as shown here: 
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 3.  Go to the Drafting workbench and click the Isometric View icon  from the Views toolbar (Projections sub-toolbar). 

 

4.  Select the scene (Scene 1) either in the specification tree or in the geometry area, and then select a plane on the 

product. 

5.  Click in the drawing to position the resulting exploded view. 

Non exploded product:           Exploded product: 

You can insert Bill of Material information into the active view.

 



Creating a Broken View 

This task will show you how create a broken view from an active and up-to-date generated view. You 
will define two profiles corresponding to the part to be broken from the view extremities.

A broken view is a view that allows shortening an elongated object.

 

 

Open the GenDrafting_part_Broken_View.CATDrawing document. 

 

1. Click the Broken View icon  from the Views toolbar.

2. Click a first point corresponding to the first extremity of the 
first profile.
A green dotted profile appears which allows you to position the 
profile either vertically or horizontally. 

3. Click a second point corresponding to the profile second 
extremity. In this example, click a point so that the profile 
appears horizontally. 

OR

3. Drag the cursor over the green horizontal profile that 
appears as you create a first point and, if needed, click to 
locate the second point on this first profile. 
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4. If needed, translate the profile.
Red zones appear. These red zones correspond to the zones 
out of which the view cannot be broken.
Note that the orientation of the second profile is the same as 
the orientation of the first profile. 

5. Click a point for defining the position of the second green 
profile that appears.

6. Click on the sheet.
The broken view appears.

 

 

 
●     You can create new breaks in a broken view, but in the same direction and providing the two breaks 

do not overlap.

●     You can remove created breaks via the contextual menu.

●     It is impossible to create breakout views, offset section views, detail views and clipping views from a 
broken view. 

More on Broken Views

Propagating a broken specification

To propagate the broken specification during the creation of a projection or auxiliary view, go to Tools -
> Options -> Drafting from the menu bar (Layout tab) and activate the Propagation of broken 
and breakout specifications option.

Propagating a specification means generating a view (B) from another view (A) on which you previously 
performed an operation, and obtaining a view (B) which includes this operation.

For example, (i) you create a broken view (view A) and activate the Propagation of broken and 
breakout specifications option, you then (ii) generate a projection view (view B). As a result, the 
projected view (view B) will appear with the broken area.

You can only perform a propagation from a broken view if the projection direction is perpendicular to 
the direction of the broken view.

 About line types

You can assign a line type to the view to be generated. For this, go to Tools -> Options -> 
Mechanical Design -> Drafting -> View tab, click the Configure button next to View Linetype and 
select the desired option from the dialog box.



Creating a Breakout View  

 

This task will show you how to create a breakout view. In other words, you will remove locally material from a generated view 
in order to visualize the remaining visible internal part. 

A breakout view is one not in direct projection from the view containing the cutting profile. In other words, it is not positioned 
in agreement with the standard arrangement of views. A breakout view is often a partial section.

 

Open the GenDrafting_part.CATDrawing document. For the purpose of this scenario, you will create the breakout on the left 
view: therefore, make sure the left view is active by double-clicking it.

1.  Click the Drawing window, and click the Breakout View icon  from the Views toolbar (Break View sub-toolbar).

 

 

 
2.  Click the first point of the breakout profile.

3.  Click as many points as desired for creating the profile.

4.  If needed, double-click to end the profile creation and close this profile automatically.

OR

4.  Click on the profile first point to close and end the profile creation.
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The 3D Viewer window appears, displaying the 3D part corresponding to the generated view. A green arrow indicates 
in which direction the breakout will be created. 

This window lets you position the 3D part according to a view you go over (on the drawing), provided the Animate 
option is checked. 

This window also lets you visualize a view plane and use it to define the depth of the breakout. You can move this 
plane using one of these methods:

●     directly in the 3D Viewer window, drag the plane to the desired location. This method does not let you define the 
depth of the breakout precisely. The breakout will not be associative with any element.

●     in the drawing, place the cursor over an axis, a center line or an edge (circular or linear) of a perpendicular view. 
The plane will be moved accordingly. This method lets you break the view through a hole or a face, for example. 
The breakout will be associative with the selected element.

●     in the drawing, select the edge which corresponds to the face that you will use as a reference element to define 
the depth of the breakout, and enter the depth in the appropriate 3D Viewer field. This method lets you define 
the depth of the breakout precisely. The breakout will be associative with the selected reference element and with 
the depth value.

 
5.  Check the Animate option to visualize the 3D part in accordance with the position of the cursor on a generated view.

6.  In the CATDrawing document, place the cursor over the front view (which is perpendicular to the left view).

7.  In the CATDrawing document, place the cursor over the center line that will be used as an extremity plane, as shown 

below. 

 



 OR

7.  In the 3D Viewer window, click the Reference element field to select it. Then, in the CATDrawing document, select the 

edge which corresponds to the face that will be used as a reference element, and enter the breakout depth in the 

Depth (in mm) field (you can also define the depth by moving the red plane with the mouse).

 

 
8.  Then, click OK in the 3D Viewer window. The breakout view is created.

 



 

●     You can create a breakout on a view that already contains breakouts.

●     You can generate the following types of views from a breakout view:  
❍     projection views, 

❍     auxiliary views, 

❍     section views 

❍     section cuts.

●     Once the breakout view is created, you can right-click the view, and select the Remove Breakout option.

●     You can also right-click the view, select the Apply Breakout To option and click another view you want to apply the 
breakout to. 

 

●     Once created, the breakout view profile cannot be modified.

●     You cannot apply a breakout and a break to the same view.

More on Breakout Views

Propagating a breakout specification

To generate views (projection, auxiliary, section and section cut) with this breakout, go to Tools -> Options -> Mechanical 
Design -> Drafting from the menu bar, click on the Layout tab, and activate the Propagation of broken and breakout 
specification option. 

Propagating a specification means generating a view (B) from another view (A) on which you previously performed an 
operation and including this operation in the generated view (B).

For example, (i) you create a breakout view (view A) and activate the activate the Propagation of broken and breakout 
specification option, you then (ii) generate a projection view (view B). As a result, the projected view (view B) will display this 
breakout area.



 About line types

You can choose the line type you want to assign to the breakout view. To do this, go to Tools -> Options -> Mechanical 
Design -> Drafting -> View tab, click the Configure button next to View Linetype and select the desired option from the 
dialog box. 

If you choose the zigzag linetype (linetype #8), note that this linetype is just a graphical dress-up of the 
view. This means that if one line is relimited on the breakout line, then it will be relimited on the 
theoretical line as shown here, and not on the visualized zigzag line.

 About patterns

The patterns which are used to represent the breakout are defined in the standards. For more information, refer to Pattern 
Definition in the Interactive Drafting User's Guide. 

 You may modify the pattern (hatching, dotting, coloring or motif) by right-clicking the pattern and selecting Properties from 
the contextual menu. This will display the Properties dialog box in which you may either select a new pattern or modify some 
graphical attributes of the existing pattern. For more information, refer to Modifying a Pattern. 

About patterns in breakouts from isometric views

In versions prior to V5 R13, when creating breakouts on isometric views, in the case of overlapping faces, the pattern area 
used to go over the projected faces and edges. From R13 onwards, the pattern area is now limited to the face sectioned on the 
part, as shown below. 

 Previous behavior New behavior
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Creating Views via the Wizard

This task will show you how to create views using a wizard. These views are views that are generated 
automatically once the CATDrawing document is opened. These views can then be modified as if they had 
been manually created one after the other.

 
Open the GenDrafting_part.CATPart document. 

Start creating a new drawing (and this case, create an empty sheet).

 
Before you begin, make sure you select the projection mode you need. If you want to change the method 
you use as you pre-define your configurations, what you need to do is:

1. Right-click the sheet.
2. Select the Properties option from the displayed contextual menu.
The Properties dialog box appears with Projection Method options.
3. Check the Create projection view using first angle standard option.

●     Create projection views using first angle standard: Orthographic representation comprising the 
arrangement, around the principal view of an object, of some of all of the other five views of that 
object. With reference to the principal view, the other views are arranged as follows:
- the view from above is placed underneath
- the view from below is placed above
- the view from the left is placed on the right
- the view from the rear is placed on the left or on the right, as convenient.
(Ref. No. ISO 10209-2:1993)

●     Create projection views using third angle standard: Orthographic representation comprising the 
arrangement, around the principal view of an object, of some of all of the other five views of that 
object. With reference to the principal view, the other views are arranged as follows:
- the view from above is placed above
- the view from below is placed underneath
- the view from the left is placed on the left
- the view from the rear is placed on the left or on the right, as convenient.
(Ref. No. ISO 10209-2:1993)

 

1. Click the Drawing window, and click the Wizard icon  from 

the Views toolbar (Wizard sub-toolbar).
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2. Select the desired view configuration from the View Wizard (1/2) : Predefined Configurations 
dialog box. 

 

In this case, ISO standard / First angle projection method is used and the following configurations are 
available: 

●      front, bottom and left

●      front, bottom and right

●      front, top and left

●      front, top and right

●      projection and isometric



●      projection, rear and isometric

  

 
If you use the ANSI standard (Third angle projection method), in the dialog box the configuration symbol 

displayed , as well as the configuration options will be different. To have the projection views linked 

to the main view click the  option. 

You can can define the Minimum distance between each view. For this, enter the desired value in the 
modifiable field available in the View Wizard dialog box.
  

A preview is available:

●     The main view corresponds to the view which any other view will be linked to. This main view can be 
either a front or an isometric view. It is squared in the green color. This is the view that will become 
the active view when you will generate the desired views.
Any other view (front and/or isometric view) that can possibly become the main view is squared in 
the black color.
To make a view become the main view, right-click this view and select the Set as main view option 
from the contextual menu.

●     At any time, you can delete one view you inserted.
For this, right-click the desired view and select the Delete option from the contextual menu. 

●     Once you generate the views, if you move the main view, all the child views will move accordingly. 
You can right-click one view and select the Position Independently of Reference View option 
from the contextual menu, if you need to move one child view independently from the reference view.

  

3. Click the NEXT> button from the View Wizard (1/2) : Predefined Configurations dialog box.

 



The View Wizard (2/2) : Arranging the Configuration dialog box is now displayed with a new set of 
view buttons: 

●      front view

●      rear view

●      top view

●      bottom view

●      left view

●      right view

●      isometric view

●      clear preview

  

 

4. Click the Isometric View button . 



 

5. Position the isometric view onto the Preview window by dragging and clicking it as desired. 

6. Click the FINISH button from the View Wizard (2/2) : Arranging the Configuration dialog box. 

 
7. Select the CATPart document.

 



8. Click on the desired 3D part plane to be used as reference plane.

If the plane can be computed, the Oriented Preview of the 3D part appears as you move the cursor 
over the 3D part (planes).

The views now appear on the CATDrawing document: they are previewed in green frames and can be re-
oriented thanks to the blue arrows that appear.

9. Go over the view frames with your cursor to have these views visualized.

 



 

 

 

 
10. Use the blue arrows to have the views re-oriented as desired and then go over the views with the 
cursor, if you need to check the preview of the other views. 

For more details, see chapter called Before You Begin.

 



 

 

 

 



You can also modify the increment value using the green knob contextual menu. For this, right-click on 
the knob and select the desired option from the contextual menu. For more details, see chapter called 
Before you begin. 

 

11. Once you are satisfied, click on the sheet to make the views be actually created.

The front view is actually the main view and the isometric view is added to the predefined configuration. 

 

The ISO and ANSI standards are independent from the angle projection method. 

 



View Modification 
The Generative Drafting workbench provides a simple method to modify previously created views.

 

Before you begin: Learn how to edit the properties of multi-selected views.

Move a view: Drag a view to a new location.

Position a view: Position Generative or Interactive views either by aligning them, superposing them and setting 
relative view position.

Position a view independently of its reference view: Position a view independently of its reference view.

Locate reference/resulting views: Navigate easily between reference/resulting views in the case of section 
views, section cuts, auxiliary views or detail views.

Isolate generated views: Remove associativity between an existing CATPart (or CATProduct or CATModel) and 
the corresponding generated views.

Restore deleted generated elements: Restore generated elements that have been deleted from a view.

Lock a view: Use the contextual menu (Properties option) to lock a view.

Scale a view: Modify the scale of a view.

Rename a view: Give a new name to an existing view.

Add a generative bill of material: Insert Bill of Material information into the active view.

Generating balloons on a view: enerate balloons on the active view.

Show geometry in views: Visualize geometrical elements in all viewpoints as well as in a 3D viewer 
corresponding to the views analyzed.

Modify a callout graphism: Modify the graphical attributes of one or more callout used when generating 
auxiliary, section or detail views.

Modify a callout geometry: Modify the geometrical properties of a callout used when creating detail views, 
section views and section cuts.

Overloading element properties: Overload the properties of generated elements in a view.

Modify a pattern: Modify the pattern of a view and apply a material to this pattern.

Duplicating generative geometry: Duplicate a generative view sub-element in order to modify a generated view 
sub-part independently from the part linked to the drawing.



Before you begin

Editing Multi-Selected Views (Properties)

You can modify the properties of a group of views of different kinds (interactive, generative or detail 
views), either on a single sheet or on different sheets. These modifications will be applied to the 
properties values common to the selected views.

In other words, when you will edit the properties values of different views, only the properties values of 
the views with the same parameters will be modifiable.

Still, mixed properties values will be modifiable. Mixed properties values meaning values which are not 
common to the selected views.

You can select the views from different sheets.

 

Open the GenDrafting_part_Move_View02.CATDrawing document. 
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2. Select Edit -> Properties command from the menu bar.

The Properties dialog box appears: de-activate the options as shown here: View Frame option 
unlocked.

1. Multi-select views from the specification tree. In this particular case, select all the views.

Remember that you can use the Shift or the Ctrl key.



 

3. Multi-select views from the specification tree. In this particular case, select the top, bottom, left and 
right views. Activate the Properties options as shown here: activate the options as shown here: Hidden 
Lines option unlocked. 

 

The views result as shown here:



 

The views result as shown here:



 

●     If the view name is not common, no View name and no Name Editor With Formula appear by 
default.

●     If the view scale is not common, no Scale appears by default.

●     In the case of a mixed values, the modifiable fields appear white and empty.

●     If one view is locked and mixed properties values will also be locked.

If you modify one view (view A) and then select another view (view B), click the Apply switch button if 
you do not want to loose the modifications first applied on the view A.

 

 



Moving a View

This task will show you how to move one or more views by dragging them.

 

Moving One View

You can move one view by selecting or more views (implicitly) by dragging the parent view.

 

Open the GenDrafting_part_Move_View.CATDrawing document.

 

1. Click the view to be moved. 

2. Drag the clicked view to the new location.
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3. Release the mouse button when you want to position 
the view. 

The view is re-positioned.

 

 

Moving More Than One View Explicitly

You can move more than one view explicitly (generative and interactive views). These views can be:

●     child views that are linked to a single parent view (and constrained to this parent view)

●     child views that are linked to different parent views (be careful: constrained views remain so by 
default ; not constrained views move in accordance with the position of the cursor)
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1. Multi-select the views to be moved. 

2. Drag the selected views to the new location.

 

 

3. Release the mouse button when you want to position the views. 

There are different cases: 

●     You multi-select views that are independent (not linked to a parent view):
When you move the views with the cursor, all these views are translated into the same direction.

●     You multi-select views that are linked to different parent views which are not selected:
When you move the views with the cursor, all these views are translated into a direction that 
depends on the constraints between the parent and the child views. In other words, two child views 
may be moved into two new locations which are not synchronized (for example, one according to x, 
the other according to y). 

●     You multi-select views that are linked to different parent views which are also selected:
When you move the views with the cursor, all these views are translated into a direction that 
depends on the constraints between the parent and the child views. As a result, all the child views 
(with an active link), be they selected or not,are translated into the same direction as the parent 
views.

 

Open the GenDrafting_part_Move_View02.CATDrawing document.



Positioning a View 

The purpose of this task is to position Generative or Interactive views: you will learn how to align 
views, superpose views and set relative view position. 

 

 

Aligning Views Using Elements  

You will learn how to align a view with another one using geometrical elements (lines, circles or points). 

Open the GenDrafting_part_Align_Views.CATDrawing document. Go to Tools -> Option -> 
Mechanical Design -> Drafting -> General tab and in the View axis area, unselect Display in the 
current view.

1. Right-click the view that you want to re-position, the unfolded view for example. A contextual menu 
is displayed. 

2. Select View Positioning -> Align Views Using Elements. 

3. On this view, select the first geometrical element that you want to align. 

 

 4. On the other view, select the second geometrical element that you want to align. 
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The first view is moved, and both views are aligned according to the elements you selected.

5. Click in the drawing, outside the views, to validate the alignment. 

 

When aligning views, remember that:
●     if you select a circle as one of the elements to align, this circle will be aligned according to its 

center. 

●     if you select lines as the two elements to align, these lines must be parallel.



If you want to align two views which are not directly linked to each other (i.e. which are not a parent 
view and its child view), you will first need to position a view independently of its reference view. For 
example, if view A (a front view) is the reference for view B (a projection view), and if view B  is the 
reference for view C (a section view), then to align view A and view C, you first need to position view C 
independently of view B. Refer to Positioning a View Independently of its Reference View for more 
information. 

 

 

Superposing Views  

You will learn how to superpose a view with another one according to their origins. 

Open the GenDrafting_Superpose_Views.CATDrawing document.

1. Right-click the view that you want to superpose, the front view with dress-up, for example. A 
contextual menu is displayed. 

2. Select View Positioning -> Superpose. 

3. Click the view on which you want to superpose the first view. The first view is moved and 
superposed to the second one.

 

 4. Click in the drawing, outside the views, to validate the superposition. 
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If you want to superpose two views which are not directly linked to each other (i.e. which are not a 
parent view and its child view), you will first need to position a view independently of its reference 
view. For example, if view A (a front view) is the reference for view B (a projection view), and if view B  
is the reference for view C (a section view), then to superpose view A and view C, you first need to 
position either view B independently of view A, or view C independently of view B. Refer to Positioning a 
View Independently of its Reference View for more information. 

 

Setting Relative View Position  

You will learn how to re-position a view relatively to various elements (a line/callout, a point or the 
frame of a view).

Open the GenDrafting_part_positioningview.CATDrawing document.

  

1. Right-click the view that you want to re-position, the isometric view for example. A contextual menu 
is displayed.
2. Select View Positioning -> Set Relative Position.
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A direction positioning line appears that is related to the isometric view. This isometric view can be 
positioned as desired and relatively to the front view. 

Note that the isometric view is assigned anchor points. 

3. Select the direction positioning line end black square point.

Once you have clicked the end square point, this point becomes a blinking red end point and remains so 
until you select a point or a view frame. 

You can also click the direction positioning line. In this case, the positioning line becomes a blinking line 
and remains so until you select a line (callout line). 

Press the Ctrl key to move the positioning line according to a direction that is perpendicular to the 
positioning line.

 

4. Click the edge according to which you want the isometric view to be aligned.

5. Click one anchor point, for example, the bottom right one. The view anchor point is aligned 
according to the green point and thereby to the direction positioning line.

6. As you move the cursor over the direction positioning line, the position and length coordinates of the 
line appear.



 

Note that you may also select the front view frame and align the isometric view to the front view 
according to the barycenter.

 

 7. Using the green point, you can rotate the isometric view around the front view. 



 8. Using the direction positioning line, translate the isometric view along the direction line and locate it 
at the desired distance. 



If you happen to modify the length of the direction positioning line, this new length will be kept 
whatever positioning modifications you may apply to the isometric view.

Note that if you had previously positioned this isometric view according to a point, not only the line 
length but also the line angle will be kept.

9. Click in the free space to validate and leave the relative positioning mode.

 

As you use relative positioning, do not try to move the view outside of the anchor point frame. If you 
do so, you will leave the relative positioning mode.

 

You can also align a view relatively to one of the edges that are within this view. To do this, first select 
the direction positioning line, and then select an edge on the view to be aligned. As a result, the 
manipulators automatically align according to this selected edge.



 

 



Positioning a View Independently of its 
Reference View 

At creation, views are by default positioned according to the parent (reference) view. This task will 
show you how to position a right projection view independently of its parent front view. 

 

This functionality was called Do not align view up until V5 R10.

 

Open the GenDrafting_part.CATDrawing document.

1. Right-click the frame of the view that you want to position 
independently of its reference view. A contextual menu is displayed.

2. Select View Positioning -> Position Independently of Reference 
View. 

 

3. Drag the view to the required location. 

4. Click to position the view.
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●     The Position Independently of Reference View command can be performed on one particular 
view at a time (you cannot multi-select views in this case).

●     If you want to reposition independently-positioned views according to their reference view, repeat 
the scenario described above, this time selecting the Position According to Reference View 
command from the displayed contextual menu.

 

 



Locating Reference/Resulting Views 

This task shows how to navigate easily between reference/resulting views in the case of section 
views, section cuts, auxiliary views or detail views: 

●     You can locate the reference (i.e. parent) view of a resulting view. 

●     You can locate the resulting (i.e. child) view of a reference view. 

Open the GenDrafting_view_navigation.CATDrawing document. 

Locating a Reference View
 

1.  Right-click the detail view. 

 

 
2.  In the contextual menu, select Locate Reference View. The application window is 

reframed on the view where the detail view callout is defined.
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Locating a Resulting View
 

1.  Right-click the detail view callout.

 



 
2.  In the contextual menu, select Locate Resulting View. The application window is 

reframed on the detail view.

 

 



Isolating Generated Views 

This task will show you how isolate either a selection of generated views (one or more), or all views in 
the drawing. 

Isolating a view amounts to:

●     suppressing associativity between an existing CATPart (or CATProduct or CATModel) and the 
corresponding generated view,

●     transforming a generated view into an interactive view.

 

Open the GenDrafting_part.CATDrawing document. 

 

Isolating a selection of views 

1. Select the views you want to isolate (for example, the Top view, Bottom view, Left view and Right 
view), and right-click them. 

2. From the contextual menu, select Selected objects -> Isolate. 

In this particular case, we selected several views but if you select only one view, the left view for 
example, then you need to select Left view object -> Isolate from the contextual menu.
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The selected views are now isolated. If you perform one or more modifications on the CATPart, you will 
not be able to update the isolated views. 

 

  

 
Isolating all views in the drawing 

1. From the specification tree, right-click the drawing object (GenDrafting_part in this case).

2. From the contextual menu, select Drawing object -> Isolate. 



 

All views in the drawing are now isolated. If you perform one or more modifications on the CATPart, you 
will not be able to update the drawing.

●     A view that has been isolated cannot be de-isolated.

●     Center lines in isolated views are no longer associated to geometry, but just to a point.

●     Axis lines in isolated views are no longer associated to geometry, but just to 2 points.

●     Dimensions in isolated views are no longer associated to geometry.

 



Restoring Deleted Generated Elements 

In this task, you will learn how to restore generated elements that have been deleted from a view.

 

Open the GenDrafting_Restore_Deleted.CATDrawing document.  

The view in this drawing was generated from a 3D part, GenDrafting_Restore_Deleted.CATPart. You do not 
need to open the part.

 

1. In the Drawing window, select the circle shown on the view and 
press the Del key. The circle is now deleted from the view. 

For the purpose of this exercise, you will now immediately restore 
the circle you deleted, but you could perform other operations 
before doing this (like save and close the drawing, or add 
annotations, for example).

 

2. Select the view and right-click the view frame. 

3. In the contextual menu, choose Object Front View -> Restore Deleted. 

4. You now have two possibilities:
●     If you did not modify the part between the moment you deleted 

the circle and now (which is the case in this exercise): in the 
Power Input Field on the status bar, type the following 
command: c:force update. 
This updates the drawing in accordance with the 3D part, and 
restores the deleted item on the view.

●     If you modified the part between the moment you deleted the 

circle and now: click the Update icon . This updates the 
drawing with the latest changes on the part, and restores the 
deleted item on the view.  

 

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/GenDrafting_Restore_Deleted.CATDrawing
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Locking a View

This task will show you how to lock views. This may be useful if you need to modify a part without 
modifying the generated views. For example, when you need to modify a constraint in the 3D but not 
the generated views.

 

Locking a view means you are not allowed to: 
●     create views from a locked view

●     create either annotations or dimensions on this locked view

●     update, delete or cut the locked view.

The move command is still available when views are locked.

 

Open the GenDrafting_front_view.CATDrawing document. 

 

1. Right-click the view to be modified (either the 
view frame or the view itself). 

2. Select the Properties option from the contextual 
menu.
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The Properties dialog box appears:

3. Select the View tab and select the Lock View 
check box.

The other fields appear in gray indicating that you 
can no longer edit them.

The views are locked as soon as you check the 
Lock View view button. The options OK, Apply 
and Cancel buttons (in the Properties dialog box) 
have no  impact on the status of the view that is 
being locked.

4. The view is automatically locked. This is 
indicated in the specification tree:

 



Scaling a View

This task will show you how to modify the scale of a view.

 

Open the GenDrafting_detailview_scale.CATDrawing document.

 

1. Right-click the frame of the view to be modified. In this case, right-click the detail view. 

2. Select the Properties option from the displayed contextual menu. 

3. Enter the new Scale value in the Properties dialog box. For example, 3.
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4. Click OK.

The detail view is updated. Note that only the generative elements (axes included) are scaled, neither 
the view name nor the dimension.

 

 

 



Renaming a View

This task will show you how to rename an existing view.

Open the GenDrafting_Rename_View.CATDrawing document.

1. Right-click the frame of the view to be modified. 

2. Select the Properties option from the displayed contextual menu.

 

3. Enter the new View Name in the Properties dialog box. For example, B as identifier (Ident). 

4. Click OK.

 

 

●     You can also access the Properties dialog box selecting the Edit->Properties commands.

●     Note that the callout in the mother view also is now assigned a new identifier (B-B).
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Adding a Generative Bill of Material 
This task will show you how to insert Bill of Material information into the active view. The Bill of Material corresponds to 
information on the product element which the views were generated from. The Bill of Material, or parts list, consists of an 
itemized list of the parts of a structure shown on a drawing or on an assembly. The Bill of Material can also include a 
recapitulation of the total number of parts used in a product.

Choose a task:

●     generating a bill of material,

●     modifying a bill of material: 

❍     modifying the contents,

❍     modifying the contents visualization,

❍     updating a Bill of Material after part modification.

Generating a Bill of Material
Open the Product_Balloon.CATDrawing document. Open the Product_Balloon.CATProduct document. 

 
●     If the active view has no link with the product, a message will state whether the insertion is all right.

●     If the active view has a link with a product, the Bill of Material can be inserted.

●     Whether the active view has a link with a product or not, you can go into an open product and click on this product 
before clicking on the CATDrawing in which you want to insert the Bill of Material. Note that you can perform this as 
often as you need.

 

You are in the background view

You first selected Edit -> Background View from the toolbar.

1. Click the Insert Bill of Material icon  from the Drawing toolbar. 

2. Click the Product from the specification tree in the CATProduct document. 

3. Position the Bill of Material by clicking the point where you want to insert it. 

OR

You are in the working views

You first selected Edit -> Working Views from the toolbar.

1. Select Insert -> Generation -> Bill of Material. 

2. Position the Bill of Material by clicking the point where you want to insert it. In our example, click at the bottom right of 
the isometric view. 

  

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/Product_Balloon.CATDrawing
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Whether you are in the background view or in the working views: 
●     Before positioning the Bill of Material, you can pre-define the anchor point position: this will determine the position of 

the Bill of Material in relation to the anchor point. For this, use the Text Properties toolbar and select either one of the 
top or one of the bottom anchor points. 

●     When positioning the Bill of Material, you can select a line, in a title block for example. In this case, the Bill of Material 
will be inserted according to the position and orientation of this element, and without including a recapitulation table.

  

 

  

 

Note that, if no Product is or several Products are opened, you will first select the Product source.

The Bill of Material automatically appears: 



 

 

Modifying a Bill of Material

Modifying the contents
To modify the contents of the Bill of Material and display given properties, go to the Product Structure workbench, and 
select Analyze->Bill of Material ->Listing Report from the menu bar.

Modifying the contents visualization
To modify the way you visualize the contents, modify the file called CATAsmBOM.CATRsc. 

It allows you to modify the columns size:



 

Bill Of Material cells are associated to the Product Structure Attributes.

Updating a Bill of Material after Part Modification



Open the Product_Balloon.CATDrawing document. Open the Product_Balloon.CATProduct document. Add a bill of material. 

You obtain the following Bill of Material: 

 
1. Replace the Part Number "pm6-7b-1e shunt to body washer" by "New Name" (for this edit Part Properties in the Part 
contextual menu, and change the Part Number in Product tab).
2. Update the drawing. The Bill of Material has changed, "pm6-7b-1e shunt to body washer" is replaced by "New Name". 

 

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/Product_Balloon.CATDrawing
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3. Add a new product and a new part in this product (see Part Design user's guide and Assembly Design User's Guide): 

4. Update the drawing, the Bill of Material is updated: 

The New product and its part appear in the Bill Of Material.

 



5. Remove the Product you have added in step 3 and update the drawing one more time: 

As Bill of Material-related information is retrieved from the 3D, if you update a Bill of Material after having modified it 
directly in the drawing (e.g. if you changed the column size, edited text, etc.), all manually-applied changes are lost.

 



Generating Balloons on a View 

This task will show you how to generate in the active view balloons corresponding to references defined 
on the different parts of an assembly. 

 

Open the Product_Balloon_Gen.CATProduct and Product_Balloon_Gen.CATDrawing documents. 

 

1. Double-click the view in which you want to generate the balloons. In this particular case, double-click 
the front view. This view is now active.

 

4. Select the Generate Balloons icon  on the Dimension Generation toolbar. 

 

The balloons that were previously created on the CATProduct are automatically generated onto the 
active view.

5. If needed, multi-select these balloons and modify the font size from the Text Properties toolbar. You 
can also select and drag a balloon to change its position.

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/Product_Balloon_Gen.CATProduct
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Balloons generated 

Balloons after the font size and position were modified:

6. If needed, insert a bill of material into the active view (Insert -> Generation -> Bill of Material 
from the menu bar).





  

The part numbers appear in the bill of material on the condition you specified it previously (Product 
Structure workbench: Analyze -> Bill of Material -> Listing Report from the menu bar).

 

 



Showing Geometry in Views

This task will show you how to visualize geometrical elements in all viewpoints as well as in a 3D viewer 
corresponding to the views analyzed.

Note that you can analyze both text/dimension and edge type elements on all the views of a 
CATDrawing document. These views can be views generated from an assembly, a part or a .model. 
These views can also be interactive views.

 

Open the GenDrafting_part.CATDrawing document. 

 

1. Go to Tools -> Analyze -> Show Geometry in All Viewpoints menu  bar command.

Provided there is at 
least one link between 
the CATDrawing 
document and a 
CATPart (or assembly, 
part or .model), a 
window appears with 
the 3D model 
corresponding to the 
CATDrawing views.

2. Move the cursor 
over the geometrical 
elements on one view.

All the views are 
analyzed. The blue 
color corresponds to 
the immediate edge. 
The red color 
corresponds to the 
adjacent faces.
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If the Animate option 
is on, the part 
automatically appears 
with the optimal 
position (visually 
speaking).

 



Modifying a Callout Graphism

This task will show you how to modify the graphical attributes of one (or more) callout used when 
generating auxiliary, section or detail views.

 

Callouts represent an operation that has been performed on a generative view (such as a section cut 
for example) and consequently do not behave as geometry. As a result, you cannot isolate callouts, nor 
can you apply transformation or symmetry operations to callouts.

 

Open the GenDrafting_part_Callout.CATDrawing document.

1. Multi-select the callout to be modified.
In this example, we select both a section view callout and a detail callout. 

2. Right-click these callout and select the Properties option from the contextual menu.

3. Select the Callout tab. 
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The preview displays both selected callouts with attributes corresponding to the generated views. 



 

The options you select in the Graphic Properties toolbar also influence the graphical attributes you 
apply to the selected callout (line color, line type, line weight, Copy Object Format icon, Pattern 
Chooser option).

 

 

In this dialog box, you can set the following parameters:
●     Auxiliary/Section Views: 

❍     Switches for pre-defined types:
continuous lines, mixed lines, elbows and extremities only or one arrow only.

❍     Line thickness

❍     Line type

❍     Extremity thickness

❍     Length

❍     Anchor point (head or tail)

●     Detail Views: 
❍     Thickness

❍     Type

❍     Extremity thickness

❍     Length

❍     Anchor point

●     Arrows on Auxiliary/Section Views and Detail Views: 
❍     Arrow length

❍     Head type

❍     Head length

❍     Head angle

 



You can specify that the size of callout elements should not be dependent on the view scale. For this:
●     After callout creation, check Size not dependent on view scale in the previous dialog box.

or

●     Before callout creation, in Tools -> Options -> Mechanical Design -> Drafting -> Layout tab, 
check the Size not dependent on view scale option. This option will apply to newly created 
callouts, i.e. selecting this option will not have any impact on existing callouts.

Note that this option only applies to drawings created with versions prior to V5 R11 (i.e. versions 
up to V5 R10).

4. Modify the callout graphical attributes as shown above. 

5. Click OK.

 

 

 



Modifying a Callout Geometry

 This task will show you how to modify the geometrical characteristics of a callout used when 
creating detail views, section views and section cuts. 
For modifying the detail and section callout, you will go through some kind of a sub-workbench 
and modify the existing callout geometry, reverse the callout direction or replace the callout.

 

 Callouts represent an operation that has been performed on a generative view (such as a section 
cut for example) and consequently do not behave as geometry. As a result, you cannot isolate 
callouts, nor can you apply transformation or symmetry operations to callouts.

 

Open the GenDrafting_part_Callout.CATDrawing document. 

 

1. Double-click the 
callout to be 
modified. 

The Edit/Replace 
toolbar appears. 

 

 

2. Drag one of the 
element components 
to the desired 
location. In this 
particular case, drag 
one  segment 
extremity of the 
callout. 

By default and in 
order to modify more 
easily and more 
precisely the callout, 
the  segment 
extremities are 
fixed.
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 To make one 
segment no more 
constrained, right-
click this segment 
and select the 
Line.object -> 
Unfix option from 
the contextual 
menu.

3. Click the End Profile 

Edition icon  

from the 
Edit/Replace toolbar. 

The callout arrow is 
now properly 
positioned and the 
section view (B-B) is 
automatically 
updated.

   

Open the GenDrafting_part_Callout.CATDrawing document.

 

1. 

2.

Double-click the 
callout to be 
reversed. 

Click the Invert 
Profile Direction icon 
from the 
Edit/Replace toolbar 
that now appears.

The callout is 
automatically 
inverted.
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●     At any time, you 
can stop editing 
the callout. For 
this, click the 
End Profile 
Edition icon from 
the Edit/replace 
toolbar. 

●     You cannot 
reverse the 
callout of a 
detail.

 
●     If after modifying a view containing a callout, the projection planes of the defining and the 

resulting views are inconsistent, the callout color is modified to show that there is an 
inconsistency in the drawing. For example, if you create a detail view from a section view and 
subsequently invert the direction of the section view profile in such a way that the projection 
plane of the detail view becomes inconsistent, then the callout color of the detail view will be 
modified. 

 

3. Click the Replace 
Profile icon from the 
Edit/Replace toolbar 
now appears. 

 

4. 

 

Start creating the 
new profile. 



5. Double-click to end 
the new profile 
creation.

The new profile 
automatically 
appears and the old 
one disappears.

 

 



Overloading Element Properties

This task will show you how to overload the properties of elements in a view generated from a CATProduct.

Open the GEAR-REDUCER.CATDrawing document.

1.  Right-click the section view A-A.

2.  In the contextual menu, Section view A-A object, select Overload properties. 

 The Characteristics dialog box is displayed.

 Select the element (part instance) that you want to edit. This element is highlighted in the drawing and 
listed in the dialog box.
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●     You can also select several elements, if you want to overload their properties in the same way.

●     In the case of several elements generated from a single part instance, all these elements are highlighted when 
you select one.

3.  Select the element you want to edit (as there is just one in our example, it is already pre-selected) in the 

dialog box and click the Edit button. 

The Editor dialog box is displayed.

 

You can modify the following parameters: 

●     Cut in section views: specifies that the 3D element will be cut in the section view, section cut or 
breakout view. 

●     Use when projecting: specifies that the 3D element will be projected in the view. 
Uncheck this option if you don't want an element to be represented in the view (other 3D elements 
possibly hidden by this element in the view will then be visible in the view). 

●     Represented with hidden lines: specifies that 3D hidden lines will be represented. 

●     Shown: specifies that the dress-up (color, line type, etc.) associated to the 2D generated element will 
be shown. The view is not re-computed.

●     Graphic Properties area: lets you modify graphic properties such as element color, line type and line 
thickness. 

The Cut in section views, Use when projecting and Represented with hidden lines properties are originally 
defined as properties of the 3D product component. So it is actually the properties of the 3D component that you are 
overloading. In this case, the view is re-computed. For more information on specifying the properties that should be 
used for a 3D component when generating views, refer to Modifying Component Properties in the Product Structure 
User's Guide.

Graphic Properties are defined in generative view styles (View Dress-Up parameters) or in the view properties. In 
this case, the view is not re-computed.
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4.  Uncheck Cut in section views.

5.  Click OK to validate and exit the dialog box.

6.  Back in the Characteristics dialog box, click OK again. A dialog box is displayed while the view is being re-

computed.

The selected element is not cut anymore.

●     In the Characteristics dialog box, the Reset button allows you to recover the values you had before changing 
information in the Editor dialog box.

●     In versions prior to V5 R13, in the case of faces overlapping with un-cut elements, the pattern area used to go 
over the projected faces and edges. From R13 onwards, the pattern area is now limited to the face sectioned on 
the part, as shown below.  

 Previous behavior New behavior

 

 



Modifying a Pattern 

This task will show you how to modify the pattern of a view. Patterns are used for area fills or, as is the 
case in this scenario, when cutting through material in section views/cuts or breakout views, for 
example. 

 

Open the GenDrafting_exploded_isometric.CATDrawing document. 

 

1. Right-click the pattern to be modified.  For the purpose of our scenario, select the hatching pattern in 
the Section view.

 

 2. Select Properties from the displayed contextual menu. The Properties dialog box displays the view 
current pattern.

3. In the Properties dialog box that appears, click the Pattern tab.
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 4. If you want to define your own pattern, choose a pattern type from the Type drop-down list: 
●     Hatching

●     Dotting

●     Coloring

●     Image

 Or if you want to choose from the various patterns available, click the [...] button. This will display the 
pattern chooser, from which you can make your selection. 

For the purpose of this scenario, select Dotting from the  Type drop-down list.



 5. In the Pitch field, type 5 mm.

6. From the Color drop-down list, select black, for 
example.

7. Uncheck the Zigzag field, and then click OK.

The pattern is modified.

 

Each part is assigned a specific pattern. Therefore, each time you modify a pattern using the Properties 
dialog box, all the patterns of the views generated from this part will be modified. These modifications 
will be applied to all existing sheets.



 

About part material patterns
●     Depending on the standard used by the drawing, you may be able to recover the pattern which is 

associated to a part material on a section view/cut or breakout view. For more information about 
associating a pattern to a material, please refer to the Real Time Rendering User's Guide.

●     When editing the properties of a pattern associated with a part material, the software offers its own 
selection of patterns, and not the patterns defined in the standard.

●     When editing the properties of a pattern associated with a part material, a specific button is available 
in the Properties dialog box: Reset using Part Material Pattern. When the original properties of 
the part material are modified, this button is activated to let you revert to the original part material 
pattern. For example, if you replace a pattern associated with a part material by a pattern from the 
standard, then the generated pattern is considered as overloaded, and will not be updated if you 
modify the properties of the part material. In this case, you can always revert to the original part 
material pattern using the Reset using Part Material Pattern button. 

 

 



Duplicating  Generative Geometry

This task will show you how to duplicate a generative view sub-element in order to modify a generated 
view sub-part independently from the part linked to the drawing. 

 

Open the GenDrafting_part.CATDrawing document. 

 

1. Double-click the view you want to modify to activate it.
The view is automatically highlighted. 

2. Select the elements you want to modify and right-click them.

3. Choose Duplicate Geometry in the contextual menu.
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The selected geometry is duplicated on the view at the same position. It is highlighted after creation. 
Click on the drawing to de-select it.

The resulting geometry is under the generative one. To workaround this problem, you can hide the 
corresponding generative geometry.



Generative View Styles 
The Generative Drafting workbench lets you use generative view styles, which are administrator-defined and 
specify the appearance and behavior of a generated view. 

For more information on the administration of generative view styles, refer to the Administration Tasks chapter.

 

Create views using generative view styles: Create views using generative view styles.

Switch a view to another generative view style: Switch a view which uses a given generative view style to 
another style.

Apply the generative style of a view to another view: Apply the generative view style used to create a given 
view to another view.

Apply a generative view style to a view: Apply a generative view style to a view which was created without one.



Creating a View using Generative View Styles  

This task will show you how to create a view using generative view styles. Generative view styles are 
defined by an administrator and specify the appearance and behavior of a generated view.

For the purpose of this scenario, you will create a front view using generative view styles, but you can 
use generative view styles to create any type of view.

 
Open the GenDrafting_part.CATPart document. Define a new drawing sheet.

1.  Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and 

uncheck the Prevent generative view style creation option. This activates the generative 

view style functionalities.

 

 

2.  Click the Front View icon  from the Views toolbar. The Generative View Style toolbar is 

automatically displayed.

 

 

 
3.  Select one of the generative view styles available from the list. For example, select 

DefaultGenerativeStyle. The parameters defined in this file will be used when creating the 

view.
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●     The generative view styles available in the list depend on what your administrator 
specified.

●     The Generative View Style toolbar is displayed when creating most view types. However, 
when creating advanced front views, this toolbar is not displayed. Instead, the View 
Parameters dialog box (which is displayed when creating advanced front views) features 
an additional list, which enables you to select a generative view style.

 

 

4.  In the 3D window, select a plane of the 3D part or a plane surface, to define the reference 

plane.

5.  Click inside the sheet to generate the view.



 

The view is created using the selected generative view style.

In our example, hidden edges are projected in orange. Note that you may 
obtain a different result. This result depends on the parameters defined in 
the generative view style you selected. 

 

Using the standards editor, you can check the parameters defined in the generative view style you 
selected. To do this, go to Tools -> Standards. In the standards editor, choose the 
generativeparameters category, and then open the DefaultGenerativeStyle.xml file from the drop-
down list. Then, for example, go to DefaultGenerativeStyle -> Drafting -> ViewDressup -> 
GeneratedGeometry -> HiddenEdges, and select the Color parameter. You will see the what color is 
specified in your generative view style for the projection of hidden edges. 

 

 



Switching a View to Another Generative View 
Style  

In this task, you will learn how to switch a view which uses a given generative view style to another 
style.

Generative view styles are defined by an administrator and specify the appearance and behavior of a 
generated view.

 

 

Open the GenDrafting_GVS.CATDrawing document. This view was created using a specific generative 
view style which specifies that hidden edges should be displayed in orange, using a specific linetype and 
thickness. 

 

1.  Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and 

uncheck the Prevent generative view style creation option. This activates the generative 

view style functionalities.
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2.  Right-click the front view to display the contextual menu. 

3.  Select Front view object -> Generative View Style -> Change View Style. The Change 

Style dialog box appears, displaying the list of generative views styles available.

 

The generative view styles available in the list depend on what your administrator specified.

4.  Select a style, DefaultGenerativeStyle for example, and click OK. 

5.  Update the view by clicking the Update icon , for example. 



 

The view is updated and the parameters defined in the 
selected style are applied to the view.

In our example, hidden edges are projected in black, with a 
different linetype and thickness than previously. Note that 
you may obtain a different result. This result depends on the 
parameters defined in the generative view style you selected. 

 



Applying the Generative Style of a View to 
Another View  

In this task, you will learn how to apply the generative view style used to create a given view to 
another view. 

Generative view styles are defined by an administrator and specify the appearance and behavior of a 
generated view.

 

 

Open the GenDrafting_GVS02.CATDrawing document. The front view was created using a specific 
generative view style (which specifies that hidden edges should be displayed in orange, using a specific 
linetype and thickness), while the isometric view was created without a generative view style.

 

1.  Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and 

uncheck the Prevent generative view style creation option. This activates the generative 

view style functionalities.
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2.  Right-click the front view to display the contextual menu. 

3.  Select Front view object -> Generative View Style -> Apply View Style to. 

4.  Click on the isometric view to indicate that you want to apply to it the generative style of the 

front view.

 

5.  Update the view by clicking the Update icon , for example. 

 



The isometric view is updated and the generative view style of 
the front view is applied to it.

 



Applying a Generative View Style to a View  

In this task, you will learn how to apply a generative view style to a view which was created without 
one. 

Generative view styles are defined by an administrator and specify the appearance and behavior of a 
generated view.

 

 

Open the GenDrafting_front_view.CATDrawing document. This view was created without a generative 
view style.

 

1.  Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and 

uncheck the Prevent generative view style creation option. This activates the generative 

view style functionalities.

 

 
2.  Right-click the front view to display the contextual menu. 

3.  Select Front view object -> Generative View Style -> Change View Style. The Change 

Style dialog box appears, displaying the list of generative views styles available.
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The generative view styles available in the list depend on what your administrator specified.

 
4.  Select a style, DefaultGenerativeStyle for example, and click OK. 

5.  Update the view by clicking the Update icon , for example. 

 

The view is updated. However, the selected style is not visible 
in the view yet. For the moment, the geometry is displayed in 
a specific color, because the original parameters of the view 
"overload" the generative view style parameters. (This means 
that the parameters of the selected generative view style have 
taken on the value of the parameters that were defined in the 
view before you applied the style to it.)

You now need to reset the parameters of the generative view 
style to their original values in order for the new style to be 
visible in the view.

 
6.  Right-click the front view to display the contextual menu once again. 

7.  Select Properties. The Properties dialog box is displayed.

8.  On the View tab, in the Dress-up area, an asterisk * appears in front of the parameters which 

are considered as being overloaded.



 

 The list in the Generative view style area shows the generative view style which is applied to 
the view.

 

 
9.  Click the Reset to style values button, and then click OK to validate and exit the Properties 

dialog box. 

 

The view is updated once again and the parameters defined in 
the selected generative view style are reset to their original 
values and are applied to the view.

In our example, hidden edges are projected in orange, with a 
different linetype and thickness than previously. Note that you 
may obtain a different result. This result depends on the 
parameters defined in the generative view style you selected. 



Dimension Generation 
The Generative Drafting workbench provides a simple method for generating dimensions. Generated 
dimensions are associative to the elements created from a part or an assembly. 

 

Before you begin: All you need to know before you start generating dimensions.

Generate dimensions in one shot: Generate dimensions in one shot from the constraints of a 3D part 
(distance, length, angle, radius and diameter constraints). 

Filter dimensions to be generated: Set filters before dimension generation using the Dimension Generation 
Filters dialog box.

Generate dimensions semi-automatically: Generate dimensions step by step from the constraints of a 3D 
part (distance, length, angle, radius and diameter constraints). 

Analyze generated dimensions: Perform an analysis of generated dimensions via the Generated 
Dimensions Analysis dialog box.

 
Position dimensions: Position dimensions (either generated dimensions or interactive dimensions) in a 
better way and on the active view exclusively.

 
Analyze interfering dimensions: Analyze dimensions that were generated and possibly re-positioned  
(Positioning icon) on the active view.

Driving 3D constraints via generated dimensions: Drive a 3D constraint via a 2D dimension that was 
generated from it.

 



Before you begin 

 This section provides the relevant information you need when performing dimensions generation, 
whichever command you activate to do so. In other words, the rules described in the following section 
are valid either when performing a Dimension Generation in One Shot or a  Semi-Automatic Dimension 
Generation.

 

First of all, make sure you customize the dimension generation settings settings via Tools -> Options -
> Mechanical Design -> Drafting -> Generation tab.

 

How are Generated Dimensions Positioned?

Generated dimensions are positioned according to the views that are most representative. In other 
words, a dimension will appear on a view so that this dimension needs not be also created on another 
view. Generated dimensions will be positioned according to the following criteria:

1. on the view on which the dimension may be generated.
2. on the view on which the dimension is better visualized. For example, a view on which 
elements are visualized in non-hidden lines instead of hidden lines.
3. on the view with a bigger scale. 
4. on views including more dimensions. 

The dimensions are generated on the views on the condition the appropriate settings were previously 
activated in Tools -> Options -> Mechanical Design -> Drafting -> Generation tab.

 

What About the Dimensions that may be Generated 
from Constrained 3D Elements?

To make sure the dimensions you need to handle in your session are those expected, here is a list 
presenting the constrained 3D elements and the resulting associated dimensions after generation. 

Note that for views that are generated from surfaces, only sketched constraints are generated.

 

Constrained 3D Elements Generated Dimension Types
Sketcher All dimensions: angle, distance, radius, diameter
3D part  Angle, distance
Features: The dimensions below:

 User-defined  All published dimensions of elements included in the user-defined 
feature

 Pad  Distance
 Pocket  Distance
 Shaft/Groove  Angle



Hole: Constraints and associated dimensions:

 
- Simple

 
 

 

 - Tapered

 

 - Counterbored  

  

 - Countersunk

 

 - Counterdrilled

 

 - Threaded  

 Fillet constraint variable  Radius/Radii
 Shell  Distance
 Thickness  Distance
 Stiffener  Distance
Assembly constraints  All assembly dimensions

 

 About threaded hole dimensions

A fractional dimension is generated for threads/taps defined in a 3D part which use standards 
with fraction as a symbolic representation (e.g. G1/8). This dimension is a fake dimension. It will 
be displayed using the color configured for fake dimensions in Tools -> Options -> Mechanical 
Design -> Drafting -> Dimension tab, Analysis Display Mode category.



Generating Dimensions in One Shot 

Before you begin, make sure you customized the following settings: 

Dimension generation:
Go to Tools->Options->Mechanical Design->Drafting, and click on the Generation tab. Check the 
Analysis after generation option.

 

This task will show you how to generate dimensions in one shot from the constraints of a 3D part. Only 
the following constraints can be generated: distance, length, angle, radius and diameter.

Constraints may be of three kinds: created manually (i) via the sketcher or (ii) via the 3D part, or else 
(iii) automatically created via internal parameters. 

 

Open the GenDrafting_front_view.CATDrawing document. Open the GenDrafting_part.CATPart 
document.

1. Click the Generate Dimensions icon  from the Generation toolbar (Dimension Generation sub-
toolbar). 

The dimensions are automatically generated on the front view, which in this particular case, is the only 
view in the drawing. 

In the case of drawings with several views, by default, dimensions are generated on all the views. To 
generate dimensions on specific views, simply select these views prior to generating dimensions. The 
selected views will be automatically highlighted, and dimensions will be generated on the selected views 
only.

 

Drawing view with generated dimensions and one selected 
dimension:

3D part with displayed dimension 
corresponding to the dimension selected on 
the drawing view:
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The Generated Dimensions Analysis dialog box showing the dimensions and constraints generated for 
each part (in this case, there is only one) is automatically displayed. 

 

 

Drawing view with generated dimensions and one selected 
dimension:

3D part with displayed dimension 
corresponding to the dimension selected on 
the drawing view:



2. Click OK to close the dialog box.

 

The generated dimensions are positioned according to the most representative views. In other words, a 
dimension will appear on a view so that this dimension needs not be also created on another view.

 

 



Filtering Dimension Generation 

This task will show you how to set filters before dimension generation using the Dimension Generation Filters dialog 
box. 

 
Open the GEAR-REDUCER.CATProduct and the GEAR-REDUCER.CATDrawing documents. 

Tile your windows horizontally to view both your drawing and the related part. To do this, select Window -> Tile 
Horizontally from the menu bar.

Go to Tools->Options->Mechanical Design->Drafting, and click on the Generation tab. Check the Filters 
before generation option. This automatically launches the dimension generation filters before generating 
dimensions. 

 

 
1. By default, dimensions will be generated on all views. If you want to generate dimensions on a specific view, 
select this view.  

2. Click the Generate Dimensions icon  from the Generation toolbar (Dimension Generation sub-toolbar). 

 

 

 

 
The Dimension Generation Filters dialog box is automatically displayed.
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The Dimension Generation Filters dialog box displays the parameters and filters that you can use for dimension 
generation, lists the elements for which dimensions will be generated, and specifies how many constraints there are 
for each listed element. 

Let's describe the dialog box more precisely:

Type of constraint

These options let you specify what type of constraints you want to generate dimensions from in your drawing. 

●     Sketcher constraints: generates dimensions from constraints created in the Sketcher workbench.

●     3D constraints: generates dimensions from 3D constraints  (for instance an Offset between two planes).

●     Assembly constraints: generates dimensions from assembly constraints. This option is active only in the case of 
products or assemblies.

●     Measured constraints: generates dimensions from measured constraints.

Options

These options let you generate additional dimension types.

●     ...associated with un-represented elements: generates dimensions from constraints associated with 
elements that are not represented on the drawing (i.e. which are not visible in the various views your drawing 
may contain). In this case, the generated dimensions will appear as not attached to any element in the drawing.



●     ...with design tolerances: generates dimensions from constraints with design tolerances, and applies the 
constraint tolerance to the corresponding generated dimension.

Other

●      Retrieve excluded constraints: retrieves all the constraints which you previously excluded (either using 

the Not Generated icon  when performing a step by step generation, or by removing a generated dimension 
from the drawing), and re-generates the dimension. This icon is active only when there are dimensions to 
retrieve. 

●     Add all parts: adds all parts that belong to the selected product or assembly to the list. This button is active only 
in the case of products or assemblies.

●     Remove: removes the selected element from the list. Dimensions will not be generated for this element.

By default, only the product is displayed in the list of elements for which dimensions will be generated, and only the 
Assembly constraints and Measured options are active: if you left the dialog box as is, dimensions would only be 
generated from the product assembly constraints and measured constraints.

3. You will now add additional elements to generate dimensions for. You have two possibilities:

●     If you want to generate dimensions for specific elements only: in the drawing, select each element for which you 
want to generate dimensions. The elements you select are added to the list. 

●     If you want to generate dimensions for all elements, click the Add all parts button to add to the list all the parts 
belonging to the product. 

For the purpose of this exercise, click the Add all parts button. All elements are added to the list. You can notice 
that the Sketcher constraints and 3D constraints options are now active and selected.  



 

 
When the same part is used several times within a given product (as is the case for Bearing (Part1.1) in this 
scenario), generations for this part are generated only once, for a single part instance (instead of being generated for 
all part instances). By default, dimensions are generated on the part instance which is the first in the product 
specification tree. If you want to generate dimensions on a specific part instance, you need to select this instance. 

4. Unselect the 3D constraints option to specify that dimensions from 3D constraints should not be generated. You 
can notice that the list is updated with the proper number of constraints for each element.



 

 
5. Click OK. The dimensions are generated on the drawing. 



 
Depending on whether the Analysis after generation option was selected in Tools->Options, the Generated 
Dimension Analysis dialog box may now appear. 

 

 
5. Click OK to close the Generated Dimension Analysis dialog box.



Generating Dimensions Semi-Automatically

Before you begin, make sure you customized the following settings: 

Dimension generation:
Go to Tools->Options->Mechanical Design->Drafting, and click on the Generation tab. Check the 
Analysis after generation option. 

This task will show you how to generate dimensions step by step from the constraints of a 3D part. 
Only the following constraints can be generated: distance, length, angle, radius and diameter. 
Constraints may be of three kinds: created manually (i) via the sketcher or (ii) via the 3D part, or (iii) 
automatically created via internal parameters.

Open the GenDrafting_part.CATDrawing.
In this sample, constraints were manually created. You will then go to Generative Drafting workbench 
and create views from this part. 

 

1. Select the views on which you want to generate dimensions. For example, the front view.

2. Click the Generate Dimensions Step by Step icon  from the Generation toolbar (Dimension 

Generation sub-toolbar).  

   

The Step-by-step generation dialog box displays and will remain displayed until the end of the 
dimension generation. 
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3. Check the Visualization in 3D button to see the constraints corresponding to the dimensions to be 
created on the views.

4. Check the Timeout option. 
The default timeout is set to two seconds (2s).
Enter the timeout value you need for example, three seconds (3s). 

5. Click the Next Dimension Generation switch button  to start the dimension generation. 

Dimensions appear one after the other on the views.

Now, you might need to pause the generation for modifying the dimension position for example.

6. Click the Pause in Dimension Generation switch button . The generation is paused.

7. Select  the dimension to be modified.

 

8. Drag the dimension to its new position.



 

 

Note that, at this step (pause), you can perform all kinds of modifications before the dimension 
generation. 

 

●     You want the dimension last generated before you clicked the Pause switch not to be generated 
on the view? Perform as follows:

1. Click the Not Generated option  in the Step by Step Generation dialog box. 

The constraint  is automatically excluded and the dimension will not generated. 

  

●     You want the currently generated dimension to be transferred (via Transfer icon)? Perform as 
follows:
1. Click the Transfer icon from the Step-by-Step Generation dialog box.
2. Click the Pause switch.
3. Select the frame of the view in which the current dimension, or the dimension last created, is to 
be pasted.

 

●     You want to modify the graphical attributes of the current dimension? Perform as follows:

You simply need to apply the desired attributes in the required Properties toolbar.



9. Click again the Next Dimension Generation switch button  and continue the process.

The dimensions are automatically generated on all the views.

The dimensions appear as shown, for example, on the front view documented in this particular case. 

 

The Generated Dimensions Analysis dialog box showing the dimensions and constraints generated 
for each part (in this case, there is only one) is automatically displayed. This dialog box is described in 
detail in Dimension Generation Analysis. 



 

Note that you can stop at anytime the generation by clicking  or, on the contrary, accelerate the 

process by clicking .

 



Analyzing Generated Dimensions 

This task will show you how to analyze generated dimensions via the Generated Dimension Analysis 
dialog box. 

 

Open the GenDrafting_part.CATPart and then the GenDrafting_front_view.CATDrawing documents. 

Tile your windows horizontally to view both your drawing and the related part. To do this, select 
Window -> Tile Horizontally from the menu bar.

Go to Tools->Options->Mechanical Design->Drafting, and click on the Generation tab. Check the 
Analysis after generation option. This automatically launches the generated dimensions analysis after 
dimension generation. 

 

 

1. Click the Generate Dimensions icon  from the Generation toolbar (Dimension Generation sub-
toolbar). 
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The dimensions are generated on the view. You can select a dimension in the drawing to highlight the 
corresponding constraint in the 3D, and vice-versa. 

 
The Generated Dimension Analysis dialog box is automatically displayed. 



 
 

The Generated Dimension Analysis dialog box displays the number of constraints available in the 3D, as 
well as the number of dimensions generated on the drawing, for each part or product in the drawing (in 
this case, there is only one part). You can use the options in this dialog box to highlight the dimensions 
in the drafting sheet as well as the associated 3D constraints you can visualize in your Part or Product 
document. 

Let's describe the dialog box more precisely:

Constraint Analysis in 3D 

These options let you highlight specific constraints on the 3D part.

●     Generated constraints: highlights all the constraints which are associated with the dimensions 
generated on the drawing. 

●     Other constraints: highlights all the constraints for which dimensions have not been generated on 
the drawing.

●     Excluded constraints: highlights all the constraints which have not been taken into account during 
the dimension generation (this can be because you previously excluded them using the Not 

Generated icon   when performing a step by step generation, or because you removed a 

generated dimension from the drawing).

Dimension Analysis in 2D



These options let you highlight specific dimensions on the drawing.

●     New Generated Dimensions: highlights the dimensions which were generated during the latest 
dimension generation (this is useful if you generate dimensions several times).

●     Generated Dimensions: highlights all the generated dimensions.

●     Other Dimensions: highlights the dimensions created manually via the Interactive Drafting 
workbench.

  

 

2. Check the Generated constraints and Generated Dimensions options. The generated dimensions 
are highlighted on the drawing, and the constraints associated with the generated dimensions are 
highlighted on the 3D part. 

 

 

2. Click OK to close the dialog box. 

 



●     The Analysis after generation option automatically displays the Generated Dimension Analysis 
dialog box (after dimension generation), each time you generate dimensions either automatically 

(Generating Dimensions icon ) or semi-automatically (Generating Dimensions Step by Step icon 

). 

●     By default, the Analysis after generation option in Tools->Options is checked, and the 
Generated Dimension Analysis dialog box is automatically displayed at the end of dimension 
generation. You can deactivate this default by unselecting the Analysis after generation option.

●     You can also launch an analysis explicitly when needed. To do this, go to Tools->Dimension 
Generation->Analysis. The Generated Dimension Analysis dialog box will be displayed 
immediately.

 



Positioning Dimensions (View per View)

This task will show you how to position distance and length dimensions (either generated dimensions or 
interactive dimensions) in a better way. These dimensions will be positioned on the active view 
exclusively. 

 

Open the GenDrafting_part_ positioningdim.CATDrawing document. 

 

In addition, select the View -> Toolbar -> Positioning option from the menu bar in order to have the 
necessary toolbar (Positioning toolbar) displayed in the workbench.

 

1. Click the Dimension Positioning icon  from the Positioning toolbar.

 
OR 

1. Select Tools -> Positioning -> Dimension Positioning... from the menu bar.

The dimensions are automatically re-positioned.
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If you want to have dimension interferences analyzed, use the Dimension Analysis icon  (or select 
Tools->Analyze->Dimension Analysis from the menu bar). You will thus be able to visualize and 
manage interfering dimensions.

 

 



 Analyzing Interfering Dimensions

This task will show you how to analyze dimensions that were generated and possibly re-positioned  
(Positioning icon) on the active view.

 

Open the GenDrafting_part_ positioningdim02.CATDrawing document. 

In addition, select the View -> Toolbar -> Analyze option from the menu bar.

 

1. Click the Dimension Analysis icon  from 
the Analyze toolbar.

 
OR  

1. Select Tools -> Analyze -> Dimensions Analysis from the menu bar.

  

The Analyze dialog box appears with the 
following options:

 

●     List with all the annotations badly 
placed/Optimized list with the 
annotations badly placed
You can choose to have either a whole or a 
filtered list with the interfering elements
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●     Total number of elements in the current list
As you choose the above list type, the total number of interfering elements is automatically updated

●     Number of the pointed element
You are provided a number for the element currently pointed as an interfering element

●     Scanner (Start, Before, Update, Next, End)
You can navigate among the list of interfering elements

 

 

  

The interfering dimensions are automatically 
displayed in the red orange color. 

Small circles allow visualizing the interference 
location.

 

 



2. Select Optimized list with the 
annotations badly placed option.

3. Click the Next switch .

4. Start modifying the dimension positions one 
after the other.

Note that you may either re-position one 
dimension or either delete or copy this 
dimension, if needed.

 

 

View with interfering dimension
 (Number 3): View once the interfering dimension has been deleted:

 

 



Driving 3D Constraints via Generated 
Dimensions 

 

In this task, you will learn how to drive 3D constraints via generated dimensions. 

Go to Tools -> Options -> Mechanical Design -> Drafting.  

On the Dimension tab, select Activate analysis display mode. Then, click the Types and colors 
button to define the characteristics that will be assigned to constrained geometry.

The Types and colors of dimensions dialog box lets you select the colors you want to assign to driving 
dimensions. Select the colors shown below, for example.

On the Administration tab, make sure that the Prevent dimensions from driving 3D constraints 
option is not selected.

Open the Pinmounting.CATPart document.

http://chir1dsy/lgkr13/CfyEnglish/cfysa.doc/src/samples/Drafting/Pinmounting.CATPart


 

 
Open the GenDrafting_drive_3dconstraints.CATDrawing document.

1. On the front view, double-click the dimension which defines the top radius (Dimension.5 object). The 
Constraint Definition dialog box appears.
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2. Type 30 in the radius field to change the 
radius definition, and click OK.  

The dimension is edited.

 

 

3. On the top view, double-click the dimension which defines the rounded corner radius (Dimension.1 
object). The Parameter Definition dialog box appears.



 

 

4. Type 30 in the value field, and click OK. 

The dimension is edited.

 

 

5. In the CATPart window, click the Update button  to update the part. The part is updated and 
reflects your modifications:

 



6. In the CATDrawing window, click the Update button  to update the drawing. The drawing is 
updated with the latest modifications in the part:

 



Dimension Manipulation 
 

The Generative Drafting workbench enables you to create and modify dimensions. 

Note that dimension commands are actually provided with the Interactive Drafting workbench. 
Therefore, this section of the documentation actually points to the Interactive Drafting User's 
Guide. As such, the information detailed in this section is presented in an Interactive Drafting context.  

 
If you want to manipulate dimensions in a Generative Drafting context, you can open the 
GenDrafting_part.CATDrawing document. 

These dimensions will be associative to the elements created from a part or an assembly. When 
created, these elements are associated with a view.
Note that for views that are generated from surfaces, only sketched constraints are generated.

 

Before you begin: You should be familiar with basic concepts.

Create dimensions: Create dimensions by clicking elements.

Create half-dimensions: Create half dimensions on distance, angle, diameter, cylinders, diameter edges 
and diameter tangents but not on cumulate dimensions.

Create cumulated dimensions: Create cumulated dimensions on a view using selection.

 
Create stacked dimensions: Create stacked dimensions using selection.

 

Create explicit dimensions: Create dimensions using explicit selection both of the desired icon and of the 
required geometrical elements.

Create/modify angle dimensions: Create an angle dimension and perform the following kinds of 
modifications: new angle sector or turn an angle sector into a supplementary sector.

 
Create chamfer dimensions: Create a chamfer dimension using selection.

Create associative thread dimensions: Create associative thread dimensions.

Create/modify coordinate dimensions: Automatically create coordinate dimensions on elements.
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Create a holes dimensions table: Create a table containing holes dimensions (diameter and center 
coordinates).

Create points coordinates table: Create a table containing 2D and  3D points coordinates.

Create/modify radius curvature dimensions: Create and modify a radius curvature dimension. This lets 
you know the curvature radius at a given point on a curve (spline, ellipse, etc.).

Create overall curve dimensions: You can create dimensions on the overall size of any kind of curve, 
whether it is canonical or not (e.g.: line, circle, ellipse, spline, etc.). You can also create dimensions on 
the overall size between 2 curves, or between a curve and a line, for example.

 Create curvilinear length dimensions: You can create dimensions for the curvilinear length of a curve, i.e. 
measure the overall length of a curve. 

 Create dimensions along a reference direction: You can create dimensions along a direction of measure. 
In other words, you can measure the projection of a segment/distance onto a direction. 

Create dimensions between intersection points: You can create dimensions between an intersection point 
and an element or between two intersection points.

Create dimensions between an element and a view axis: Create dimensions between an element and a 
view axis (one of the two axes or the origin). 

Modify the dimension type: Modify the dimension type as you create a dimension. On other words, you 
modify the dimension attributes.

 

Re-route dimensions: Re-route dimensions, i.e. recalculate dimensions taking into account new geometry 
elements.

Interrupt one or more extension lines: Interrupt manually one or more extension lines of one or more 
dimensions, either using the contextual menu or the Insert menu bar option.

Modify the dimension line location: Use the mouse to modify dimension line location either before or 
after creating dimensions.

Modify the dimension value text position: Use the cursor to modify dimension value text position.

Specify the dimension value position: Automatically or explicitly position the dimension value inside or 
outside the area between extremity symbols.

Add text before/after the dimension value: Insert text before or after the dimension value.

Modify the dimension overrun/blanking: Use the Blanking Edition dialog box to modify dimension overrun 
or blanking.

Line up dimensions (free space): Line up dimensions relatively to a point in the free space.

Line up dimensions (reference): Line up dimensions according to a given reference.

Create a datum feature: Use the Datum Feature Creation dialog box to create a datum feature.

Modify a datum feature: Modify a datum feature by editing it.

Create a geometrical tolerance: Use the Geometric Dimensioning And Tolerancing Parameters dialog box 
to create geometrical tolerances.

Modify a geometrical tolerance: Use the Geometric Dimensioning And Tolerancing Parameters dialog box 
to modify geometrical tolerances.

Copy a geometrical tolerance: Copy an existing geometrical tolerance and then edit the content for 
creating a new one.

Create driving dimensions: Create dimensions that will drive associated constrained geometry.
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Creating Associative Thread Dimensions

This task will show you how to create associative thread dimensions.

Open the thread.CATDrawing document. 

 

1. 
 

Click the Thread Dimension icon 

 from the Dimensioning toolbar 

(Dimensions sub-toolbar).
 

 

2. 
 

Select the thread to be dimensioned in the front view. The diameter dimension appears.

3. 
 

Click the Thread Dimension icon .

4. 
 

Select the only one of the thread 
elements in the section view, two 
dimensions appear:

●     the thread diameter

●     the thread depth 
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In the top views you can modify threads dimensions orientation.

 



Technological Feature Dimensions
The Interactive Drafting workbench lets you create dimensions for technological features such as electrical 
harness, or between technological features such as structural plates.

 

 Before you Begin: You should be familiar with basic concepts.

Creating Intra-Technological Feature Dimensions: Create dimensions for technological features such as 
electrical harness.

Creating Inter-Technological Feature Dimensions: Create dimensions between technological features such 
as structural plates.



Before you Begin  

There are a few things you should know before you begin creating technological feature dimensions. 

Technological feature dimensions let you create dimensions for technological features such as electrical 
harness or structural stiffeners, or between technological features such as structural stiffeners. 

Technological feature dimensioning relies on the fact that technological features can specify the way 
they should be dimensioned, which allows you to create only realistic and customized dimensions, 
based on the know-how of a given discipline.

Depending on the type of feature that you will be dimensioning, you need specific product licenses to 
create technological feature dimensions. For more information on the availability of technological 
feature dimensioning for a given workbench, refer to the related documentation. 

 

Action/object and Object/action Mode
 Technological feature dimensioning is available in action/object mode (i.e. selecting the command first 

and then the feature to dimension) and in object/action mode (i.e. selecting or multi-selecting the 
feature(s) to dimension and then selecting the command). 

 

Technological Feature Dimensions icons
 Several Technological Feature Dimensions icons are available from the Technological Feature 

Dimensions sub-toolbar.

●     Technological Feature Dimensions  creates any type of technological feature dimension 
(intra or inter) specified by the feature, depending on the option selected in the Tools palette.

●     Multiple Intra Technological Feature Dimensions icon  create either the intra-technological 
feature dimension type specified by the feature when only one is specified, or the preferential intra-
technological feature dimension type specified by the feature when several are specified.

●     Chained Technological Feature Dimensions icon  create either the inter-technological 
feature dimension type specified by the feature when only one is specified, or the preferential inter-
technological feature dimension type specified by the feature when several are specified.

●     Length Technological Feature Dimensions , Angle Technological Feature Dimensions 

, Radius Technological Feature Dimensions  and Diameter Technological Feature 

Dimensions  create a specific dimension type when the feature specifies several dimension 
types. Using one of these options is particularly useful when you want to create a dimension type 
other than the preferential type specified by the feature.

 

Contextual menu



 At any time during the dimension creation, you can right-click a technological feature to display a 
contextual menu. 

 This contextual menu is particularly useful when several dimension types can be created for a given 
feature. This depends on what is specified by the feature.

●     Optional choices, available when several dimension types are available for the selected feature or 
features, let you specify a single dimension type that you want to create, out of all the types 
available.

●     The All option creates all available dimensions for all selected features. 

●     The None option creates none of the available dimensions for all selected features.

●     The Show Panel option lets you display the Technological Feature Dimensioning Selection dialog 
box. 

 

Technological Feature Dimensioning Selection dialog 
box

 The Technological Feature Dimensioning Selection dialog box lets you select precisely the types of 
dimensions that you want to create for a given feature. This dialog box is particularly useful when 
several dimension types are available for a given feature (especially when creating inter-feature 
dimensions).

●     From the list area, you can select the types of dimension that you want to create for a given feature 
or de-select those that you want to delete.  

●     You can also use the Create drop-down list. The default option, (Selected), creates the dimension 
types selected from the list area above. The All option creates all available dimensions for all 
selected features.  The None option deselects all available dimensions for all selected features.

●     The Hide button lets you hide the Technological Feature Dimensioning Selection dialog box.

When a feature is checked and grayed out as shown below, it means that not all dimensions available 
for this feature have been selected.



 

You can also show or hide the Technological Feature Dimensioning Selection dialog box using the Show 

Panel icon  available in the Tools Palette.

 

Limitations
 You cannot create coordinate, stacked and curvilinear dimensions for technological features.

 



Creating Intra-Technological Feature 
Dimensions  

This task will show you how to create dimensions for technological features such as electrical harness. 

You need an Electrical Harness Assembly license for the purpose of this scenario as we will be 
dimensioning Electrical Harness Assembly features. Intra-technological feature dimensioning is also 
available for other applications such as Structure Functional Design or Ship Structure Detail Design. For 
more information on the availability of technological feature dimensioning for a given workbench, refer 
to the related documentation. 

Refer to Before you Begin for general information about technological feature dimensions.

Open the ElectricalAssembly.CATProduct document and make sure it is loaded in the Electrical Harness 
Assembly workbench (if necessary, select Start -> Equipment & Systems -> Electrical Harness 
Assembly to launch the workbench). Open the ElectricalAssembly.CATDrawing document.

1.  Click the Multiple Intra Technological Feature Dimensions icon  from the Dimensioning 

toolbar, Technological Feature Dimensions sub-toolbar. 

 

 

 

You can also click the Technological Feature Dimensions icon  and then select the 

Multiple Intra Technological Feature Dimensions icon   from the Tools Palette. 

 
2.  Select the feature that you want to dimension. Note that the name of a feature is displayed as a 

help as you move the cursor over it.
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 The dimension is created as specified by the feature. In this specific example, the bundle 
segment specifies that the dimension should provide its overall length.

The dimension creation command remains active.

 



 
3.  Repeat step 2 for each additional feature that you want to dimension.

4.  End the dimension creation by clicking anywhere in the drawing (but not on a technological 

feature) or by lining-up the dimension. The intra-feature dimensions are created as specified by 

the feature. 

You can now handle the dimension(s) just like any other dimension.

 

 



 Creating Inter-Technological Feature 
Dimensions 

This task will show you how to create dimensions between technological features such as structural stiffeners. 

You need a Structure Functional Design or a Ship Structure Detail Design license for the purpose of this 
scenario as we will be dimensioning Structure features. Inter-technological feature dimensioning may also be 
available for other applications. For more information on the availability of technological feature dimensioning 
for a given workbench, refer to the related documentation. 

Refer to Before you Begin for general information about technological feature dimensions.

Open the MemberForDim.CATDrawing document. 
For your information, this document references the MemberForDim.CATProduct document. You do not need to 
open this product. 

1.  Click the Chained Technological Feature Dimensions icon  from the Dimensioning toolbar, 

Technological Feature Dimensions sub-toolbar. 

 

 

 

You can also click the Technological Feature Dimensions icon  and then select the Chained 

Technological Feature Dimensions icon  from the Tools Palette. 

 

 

2.  Select Ref_FunStiffener_002 as the first feature for dimensioning. Note that the name of a feature is 

displayed as a help as you move the cursor over it.

3.  Select Ref_FunStiffener_001 as the second feature.
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 A preview of the dimension is displayed. The dimension creation command remains active.

4.  Right-click to display the contextual menu.

5.  Select Angle between supports (true dimension).

The next dimension will be created between the previously selected feature (i.e. the second feature 
you selected) and the next feature you select.

6.  Select the third feature. 

 



 

You can also right-click to view the various types of dimensions you can create between the 

features. For the purpose of this scenario, leave Distance between parallel supports (true 

dimension) selected.

7.  Optionally move the dimension to position it as wanted.

8.  When done, click in the drawing (but not on a technological feature) to create the dimension. The inter-

feature dimensions are created as specified by the feature. 

You can now handle the dimensions just like any other dimension. 

 



 

Note that the dimension arrow is automatically oriented according to the direction of material (in 

this case, the stiffener's molded side), which is the case when dimensioning structural features.

 

 



Annotations 

 

 

The Generative Drafting workbench lets you manipulate annotations.

Note that annotation commands are actually provided with the Interactive Drafting workbench. Therefore, 
this section of the documentation actually points to the Interactive Drafting User's Guide. As such, the 
information detailed in this section is presented in an Interactive Drafting context.  

 
If you want to manipulate annotations in a Generative Drafting context, you can open the 
GenDrafting_part.CATDrawing document. 

 
In order to be consistent with the way commands have been grouped in toolbars and sub-toolbars, the 
following tasks are documented in the Manipulating Dimensions chapter:

●     Datum Feature Creation and Modification

●     Geometrical Tolerance Creation, Modification and Copy

See Before you begin to learn about important concepts, including setting text properties.

 

Before you begin: You should be familiar with basic concepts such as setting the properties of a text (font 
style, size, justification, etc.), using default values, and specifying the position and/ or orientation of a 
text.

Create a free text: Create a text that either wraps or not, that is assigned an unlimited width text frame, 
even though this text may reach the frame boundary.

Create an associated text: Create a text which you want to be and remain associated to an existing 
element.

Make an existing annotation associative: At any time and once an annotation has been created, you can 
add a link between an annotation and another element.

Create a text with a leader: Create a text with a leader either in the free space or associated with an 
element.

Add a leader to an existing annotation: Add a leader to an annotation that was previously created.

Handle annotation leaders: Add or remove breakpoints, extremity or interruptions. Move and position 
leader breakpoints.

Add frames and sub-frames to existing text: Add a frame or a sub-frame to a text that was previously 
created.

 
Replicate a text and attribute: Replicate text as well as the corresponding text attribute.

Copy text graphical properties: Copy the text graphical properties of an annotation or element to other 
elements.

Create a datum target: Create a datum target on a view.
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Modify a datum target: Modify a datum target by editing it in a dialog box.

Create a balloon: Create a balloon using a dialog box. 

Creating an associative balloon on a generated product view: Create associative balloons on views 
generated from a product.

Modify a balloon: Modify a balloon using a dialog box.

Create a roughness symbol: Create a roughness using a dialog box.

Create a welding symbol: Create a welding symbol using a dialog box.

Create a geometry weld: Create a geometry weld symbol.

Modify annotation positioning: Assign new positioning to existing annotations.

 
Create/modify a table: Create, edit and modify a table.

Find/replace text: Locate and then, if needed, replace  strings of characters.

Perform an advanced search: Use the advanced search command.

Query object links: Query object links in a drawing.

Adding attribute links to text: Add one or more attribute links between text that was previously created.
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Dress-Up Elements

The Generative Drafting workbench enables you to create a number of view dress-up elements on 
existing 2D elements. 

Note that dress-up commands are actually provided with the Interactive Drafting workbench. 
Therefore, this section of the documentation actually points to the Interactive Drafting User's 
Guide. As such, the information detailed in this section is presented in an Interactive Drafting context.  

 
Still, you can open the GenDrafting_part.CATDrawing document and thus manipulate dress-up 
elements in a Generative Drafting context. 

This dress-up will be associative to the elements created from a part or an assembly. When created, 
these elements are associated with a view. 

 
Note that if  you delete generated center lines, threads or axis lines, you will NOT be able to generate 
them again (by updating the drawing). It is impossible to restore generated center lines, threads or 
axis lines that have been deleted. 

 

 

Create center lines (no reference): Apply a center line to one or more circles.

Create center lines (reference): Apply a center line to one or more circles with respect to a reference 
(linear or circular).

Modify center lines: Modify one or more center lines at one or more end(s) of this/these center lines.

Create threads (no reference): Create a thread without a reference.

Create threads (reference): Create a thread with a reference, either circular (circle or point) or linear 
(line).

Create axis lines: Create an axis line by selecting lines.

 
Create axis lines and center lines: Create an axis line by selecting lines.

Create an area-fill: Create an area fill, i.e. a closed area on which you will then apply graphical dress-up 
elements called patterns (these can be hatching, dotting or coloring). Patterns can be applied to area fills 
created from both sketched and generated elements.

Create arrows:Create an arrow.
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Properties 
This section discusses how to quickly access and edit information on 2D geometry, dress-up elements, 
annotations and dimensions in a single dialog box, provided you use the Edit -> Properties contextual 
command. 

The data you can access (tabs) depends on the element you select. Note that clicking the More switch gives 
you access to more tabs.

Note that properties are actually documented in the Interactive Drafting User's Guide. As such, the information 
detailed in this section is presented in an Interactive Drafting context. When information specific to Generative 
Drafting is introduced, this will be specified.

 

Edit sheet properties: Access and edit sheet properties.

Editing view properties: Access and edit view properties.

Editing 2D geometry feature properties: Access and edit information on 2D geometry features (name and 
stamp).

Editing 2D element graphic properties: Access and edit graphic properties.

Editing annotation font properties: Access and edit annotation font properties.

Editing text properties: Access and modify text color, position and/or orientation.

Editing dimension text properties: Access and edit dimension text properties.

Editing dimension value properties: Access and edit dimension value properties.

Editing dimension tolerance properties: Access and edit dimension tolerance properties.

Editing dimension extension line properties: Access and edit dimension extension line properties.

Editing dimension line properties: Access and edit information on dimension line properties.

Editing 2D component instance properties: Access and edit 2D component instance properties.
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Images
The Generative Drafting workbench lets you add images to Drafting sheets as well as edit them. 

Note that image commands are actually provided with the Interactive Drafting workbench. Therefore, this 
section of the documentation actually points to the Interactive Drafting User's Guide. As such, the information 
detailed in this section is presented in an Interactive Drafting context.  

 

Insert images: Insert raster or vector images in a drawing.

Edit images: Edit raster images using the raster editor, or view information about vector images.

http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugbt1401.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugbt1402.htm


Printing 
The Generative Drafting workbench provides a simple method for printing one or more sheets inserted in your 
document.

Note that print is actually documented in the Interactive Drafting User's Guide. 

 

Print a sheet: Quickly print a given sheet.
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Interoperability
The Generative Drafting workbench provides a simple method to create and modify views from a .model.

 

Create and modify views from a .model: Use a master model exact solid to create and modify views from a 
.model.



Creating and Modifying Views from a .Model

This task will show you how to create and modify views from a .model document on the condition this model 
contains Exact Solids, Skins or Faces in the master workspace.

 
Open pm6-7b-1e_gun_body_draw.model. This model contains an Exact Solid in the master workspace.

Tile the windows vertically to see your drawing sheet and your model at the same time.

 

1.  Create a front view from the .model document. 

2.  Create projection views. 

The views are generated.

 

  

●     The only modifications you can perform on views generated from .model documents are dress-up 
modifications.

●     In certain cases, dress-up modifications applied to .model documents are not associative.

  

Elements from .model documents are handled differently depending on their type and on the type of view you 
are generating:
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●     In section cuts and section views: Exact Solid, Face and Skin elements from .model documents are supported 
in exact mode.

●     In breakout views: Exact Solid elements from .model documents are supported in exact mode.

●     In projection views, quick detail views, clipping views and broken views: Exact Solid, Face and Skin elements 
from .model documents are supported in exact mode. All elements from .model documents are supported in 
CGR, approximate and raster mode.

 



File Export and Import 
The Generative Drafting workbench lets you export and import different types of files.

Note that these tasks, which deal with data exchange, are actually documented in the Data Exchange Interfaces 
User's Guide. 

 

DXF/DWG: Import: Import or insert the 2D geometric data contained in a DXF or DWG file into a CATDrawing 
document.

DXF/DWG: Export: Export the data contained in a CATDrawing document into a DXF file.

DXF/DWG: Report File: Learn more about the report file.

DXF/DWG: Trouble Shooting: Learn how to troubleshoot DXF/DWG import and export.

DXF/DWG: Best Practices: Learn best practices for DXF/DWG import and export.

DXF/DWG: FAQ: Get answers to Frequently Asked Questions about DXF/DWG import and export.

DXF/DWG: VBScript Macros: Learn about DXF/DWG import and export macros.

CGM: Insertion: Insert a CGM file into a CATDrawing document.

CGM: Export: Export the data contained in a CATDrawing document into a CGM file.
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Administration Tasks
In the Generative Drafting workbench, administration tasks deals with the administration of generative view 
styles. 

You can manage and customize the styles that will be used to generate views using the Standards Editor.  

Before you begin
Administering Generative View Styles and Standards

Setting Generative View Style Parameters 

 



Before you begin  

About Generative View Styles

Generative view styles let you customize the appearance and behavior of a generated view via a set of 
pre-defined parameters and options. 

Administrators can create one or several generative view styles from which users can choose when 
creating a generative view. 

Generative view styles are defined in an XML file. 

 
Some workbenches (such as the Structure Functional Design workbench, for example) also offer the 
possibility of configuring generative view styles. These styles will be specific to views generated from 
this workbench, and will specify the appearance of the geometry to be generated.  To know if a given 
workbench supports generative view styles, refer to its documentation.

 

Management of Generative View Styles

One generative view style per view

When you create a view using a generative view style, you specify the XML file that will be associated 
with this view. Within a drawing, you can only associate one generative view style to a given view, but 
you can use several generative view style files by associating different files to different views.

 
Standalone drawings

The values of the parameters in the specified XML file are then copied into the CATDrawing document. 
Each drawing contains an embedded copy of the generative view style(s) it uses. The drawing is 
therefore standalone. This makes it possible for users, projects, or companies to exchange CATDrawing 
documents without needing to send the generative view style file along.



 Administrator-controlled access and modification

The administrator defines and controls the location of the generative view style files as well as the 
ability to modify existing ones. For example, the administrator can define a single generative view style, 
and prevent users from modifying it. 

Administrator-controlled authorized styles

The administrator defines the list of authorized generative view styles, in the Drafting standards XML 
file.

A generative view style file available by default

By default, a pre-defined generative view style file is delivered. This file is located in 
install_root/resources/standard/generativeparameters/DefaultGenerativeStyle.xml. 

Administrators can customize this file to define their default generative view styles. They can also use 
this file as a template for creating new generative view styles.
They can add as many generative view style files as needed. Refer to Administering Generative View 
Styles for more information.

 

Do not delete the DefaultGenerativeStyle.xml file: it contains all generative view style parameters. 
Furthermore, it is used as a default if a parameter happens to be missing from a custom view style file 
(in this case, the corresponding parameter defined in DefaultGenerativeStyle.xml will be used 
instead). In case the DefaultGenerativeStyle.xml file cannot be found, then the application will use 
its own default parameter instead. 

 
Editing the generative view style file

The generative view style files can be edited using an interactive editor. This editor provides an easy-to-
use graphic interface to let you customize the parameters included in the generative view style file. For 
information on how to customize the parameters included in the generative view style file, refer to 
Setting Generative View Style Parameters.

The interactive editor is available in Tools -> Standards. (It is the same editor with which you can 
customize the Drafting standards). For more information on how to use this editor, refer to the 
Customizing Standards chapter in the Infrastructure User's Guide. 

 
Make sure you use the Standards editor available in Tools -> Standards when modifying and 
customizing the XML generative view style files. Using other editors (such as text editors) may alter the 
consistency of the generative view style XML files, and may make them unusable.
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 Import of a newer version of a generative view style file

Once a generative view style has been assigned to a view, it is embedded into the drawing. This means 
that if you update the generative view style file that was used to create the view, the style of the view 
itself will not be modified and will remain as it was when the view was created. 

To modify the style used by the view, you need to import the newer version of the generative view style 
XML file into the drawing. To do so, select Tools -> Import a generative view style. In the dialog 
box which is displayed, select the generative view style to import and click OK.  

Note the following points:

●     The newer, imported generative view style will completely override the older version of the 
generative view style in all views which use this generative view style. 

●     If the drawing contains views which use other generative view styles, these views will not be 
affected by the import. 

Importing a newer version of a given generative view style file will be useful to ensure that views 
created on a previous release using the generative view styles provided by default with the application 
benefit from the new styles parameters that were added in the latest release.

 

Using Generative View Styles

Creating views using generative view styles

When generating a view from the 3D, users can choose to use one of the styles defined by the 
administrator. Refer to Creating Views Using Generative View Styles.

Switching a view to another generative view style

Once a view has been created using a specific generative view style, it is possible to switch this view to 
another view style. Refer to Switching a View to Another Generative View Style. 

Applying the generative style of a view to another view

You can apply the generative view style used to create a given view to another view. Refer to Applying 
the Generative Style of a View to Another View.

Applying a generative view style to a view

You can apply a generative view style to a view which was created without one. Refer to Applying a 
Generative View Style to a View After its Creation.



Administering Generative View Styles and 
Standards 

 This task documents the administration of both generative view styles (Generative Drafting workbench) 
and standards  (Interactive Drafting workbench), as the procedure is basically the same whether you 
are administering generative view styles or standards. The examples provided in this task specifically 
deal with the administration of generative view styles. 

For more information on customizing and administering standards, refer to the Administration Tasks 
chapter in the Interactive Drafting User's Guide.

 

Location of generative view style files or standard files

The location of generative view style files or standard files is defined by two environment variables 
which can be set during installation or modified afterwards:

Variable name Description

CATCollectionStandard Path and name of the directory (or directories) which contains: 
●     the generativeparameters sub-directories (which themselves 

contain the customized generative view styles). It is in these 
generativeparameters sub-directories that you should 
add the generative view styles customized for a 
company, project or user. 

●     the drafting sub-directories (which themselves contain the 
customized drafting standards). It is in these drafting sub-
directories that you should add the drafting standards 
customized for a company, project or user. 

 

CATDefaultCollectionStandard Path and name of the directory (or directories) which contains: 
●     the generativeparameters sub-directories (which themselves 

contain the predefined generative view styles delivered by 
Dassault Systemes). 

●     the drafting sub-directories (which themselves contain the 
predefined drafting standards delivered by Dassault 
Systemes).  

The default location for this directory (set during the installation 
process) is the installation directory 
install_root\resources\standard.

Setting the location of generative view style files



Refer to the Administration Tasks chapter in the Interactive Drafting User's Guide for specific 
information on how to set the location of generative view style files. 

There are two possibilities:
●     If you want to place all customized generative view styles in a custom directory, named 

mydirectory for example, you need to proceed as follows:

 
1.  Create a directory named as you like (mydirectory, for example).

2.  Create a sub-directory under this directory, which needs to be named 

generativeparameters.

3.  Place the XML files containing your customized generative view styles in 

mydirectory\generativeparameters. 

●     If you have not yet customized your XML generative view style files, then proceed as follows: 

1.  Create a directory named as you like (mydirectory, for example).

2.  Create a sub-directory under this directory, which needs to be named 

generativeparameters.

3.  Set the CATCollectionStandard variable to mydirectory. After you have customized 

the XML generative view style files, the standard editor will then save them in  

mydirectory\generativeparameters.

●     If the CATDefaultCollectionStandard and the CATCollectionStandard variables both contain an 
identically-named generative view styles, it is always the style found in  CATCollectionStandard  
which will be used. 

●     If two directories referenced by the CATCollectionStandard and/or 
CATDefaultCollectionStandard variables contain identically-named generative view style files, it is 
always the style in the directory listed first which will be used.

 

Customizing and defining generative view styles or 
standards 

To edit and save generative view style files or standard files in Tools -> Standards, you must be 
running the V5 session in administrator mode (-admin). 

The recommended method for customizing generative view style files or standard files is the following: 



1.  You need to work in administrator mode. To do this, proceed as follows:  

a.  Set up the CATReferenceSettingPath variable.

b.  Start a V5 session using the -admin option. 

For more information, refer to the Managing Environments chapter in the Infrastructure 

Installation Guide.

2.  Set up the CATCollectionStandard environment variable as explained above.

If none of the conditions are respected, a warning message will appear to let you know that you 

will neither be able to modify nor save the XML files.

3.  Modify the generative view styles or the Drafting standards as appropriate.

4.  Use the Save As or the OK button to store your modifications.

5.  To exit, use the Cancel button.

Once the generative view style files or the standard files have been customized and saved, they can be 
used in a V5 session in normal mode.

 



Setting Generative View Style Parameters
The Generative Drafting workbench lets you set generative view style parameters that are specific to Drafting 
applications. 

 

Before you begin: You should be familiar with important concepts such as the structure of generative view 
styles and how to customize generative view style parameters.

Generate parameters: Specifies whether the elements will be projected in the view or not.

View dress-up parameters: Defines the style of the various parameters which deal with the dress-up of the 
view.



Before you begin 

Structure of the Generative View Styles

A generative view style file is structured as a tree, as it appears in the Standard Definition dialog box 
(available via Tools -> Standards). It contains several main sections, one of which is specifically 
devoted to customizing generative view styles for Drafting: Standard -> DefaultGenerativeStyle -> 
Drafting.

This section contains sub-sections, each dealing with a specific aspect of drafting customization:

●     Generate parameters: specifies whether the elements will be projected in the view or not.

●     View dress-up parameters: defines the style of the various parameters which deal with the dress-up of 
the view.

The other sections are specific to certain workbenches. For more information about these, refer to the 
corresponding documentation (e.g. for information regarding the parameters under the SheetMetal node, 
see the Generative Sheetmetal Design User's Guide). 

 
 



  

Customizing Generative View Style Parameters
In this scenario, you will learn how to customize generative view style parameters using a specific 
example.

The pre-defined DefaultGenerativeStyle.xml file specifies that hidden edges should be displayed in 
black, using a specific linetype and thickness. You will modify these parameters so that hidden edges are 
displayed in orange, for example, and using a different linetype and thickness.

 
Open the GenDrafting_part.CATPart document. 

Select Tools -> Standards to launch the Standard Definition dialog box. Choose the 
generativeparameters category, and then open the DefaultGenerativeStyle.xml file from the drop-
down list.
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1.  In the editor, expand the following nodes successively: Standard -> DefaultGenerativeStyle -> 

Drafting -> ViewDressup -> GeneratedGeometry -> HiddenEdges.

2.  Select the Color parameter. 

3.  Set the color to orange, for example by choosing another color from the drop-down list in the right-

hand pane.

4.  Select the Linetype parameter.

5.  Set the linetype to 4, for example by choosing another linetype number from the drop-down list in 

the right-hand pane.

Note: Linetypes are defined in Tools -> Options -> General -> Display -> Linetype tab.

6.  Select the Thickness parameter.

7.  Set the thickness to 2, for example by choosing another thickness number from the drop-down list 

in the right-hand pane.

Note: Thicknesses are defined in Tools -> Standards -> Drafting category -> [StandardFile] -

> Linethickness node. 

8.  Click OK to save your modifications and exit the standards editor.

9.  Define a new drawing sheet.

10.  Create a front view. The view is generated, taking into account the parameters you defined.

 



Generate Parameters 

Generate parameters are located in the Drafting -> Generate nodes of the generative view style XML 
file. They specify whether the elements should be projected in the view.

  
Parameter Value Description

AxisLines Yes/No Specifies whether axis lines 
should be projected. 

CenterLines Yes/No Specifies whether center lines 
should be projected. 

Fillets None / Boundaries / OriginalEdges / 
ProjectedOriginalEdges

Defines the fillet representation 
mode. 

HiddenLines Yes/No Specifies whether hidden lines 
should be projected. 

Threads Yes/No Specifies whether threads should 
be projected. 

3DPoints Yes/No Specifies whether 3D points 
should be projected. 

Wireframe Yes/No Specifies whether wireframe 
should be projected. 

Using3DColors Yes/No Specifies whether colors defined 
in 3D should be kept. 

Using3DSpec Yes/No
Specifies whether 3D 
specifications (cut, use, hidden 
lines) should be used.

 



View Dress-Up parameters 
View dress-up parameters are located in the Drafting -> ViewDressup nodes of the generative view 
style XML file (available in Tools -> Standard -> generativeparameters category -> *.XML file). 

They define the style of the various parameters which deal with the dress-up of the view.

There are various kinds of dress-up parameters: 

●     Operators

●     3D Inheritance

●     GeneratedGeometry

 

Operators
Parameter Parameter Name Value Description

Section

Color color Determines the color of the section profile.

Linetype integer Determines the linetype used for the section 
profile.

Thickness integer Determines the line thickness used for the section 
profile.

Section -> SkinSection

Color color Determines the color of the skin section profile.

Linetype integer Determines the linetype used for the skin section 
profile.

Thickness integer Determines the line thickness used for the skin 
section profile.

Section -> SolidSection

Color color Determines the color of the solid section profile.

Linetype integer Determines the linetype used for the solid section 
profile.

Thickness integer Determines the line thickness used for the solid 
section profile.

Detail

Color color Determines the color of the detail profile.
Linetype integer Determines the linetype used for the detail profile.

Thickness integer Determines the line thickness used for the detail 
profile.

Break

Color color Determines the color of the break profile.
Linetype integer Determines the linetype used for the break profile.

Thickness integer Determines the line thickness used for the break 
profile.

Breakout

Color color Determines the color of the breakout profile.

Linetype integer Determines the linetype used for the breakout 
profile.

Thickness integer Determines the line thickness used for the 
breakout profile.

  



 

3DInheritance 
Parameter Parameter Name Value Description

Wireframe

Color yes/no Specifies whether wireframe color should be inherited from 3D.

Linetype yes/no Specifies whether wireframe linetype should be inherited from 
3D.

Thickness yes/no Specifies whether wireframe thickness should be inherited from 
3D.

Solid
Color yes/no Specifies whether solid color should be inherited from 3D.
Linetype yes/no Specifies whether solid linetype should be inherited from 3D.
Thickness yes/no Specifies whether solid thickness should be inherited from 3D.

3D Points
Color yes/no Specifies whether 3D points color should be inherited from 3D.
Symbol yes/no Specifies whether 3D points symbol should be inherited from 3D.

  
 

GeneratedGeometry
Parameter Parameter Name Value Description

VividEdges
Color color Determines the color of vivid edges.
Linetype integer Determines the linetype used for vivid edges.
Thickness integer Determines the line thickness used for vivid edges.

HiddenEdges
Color color Determines the color of hidden edges.
Linetype integer Determines the linetype used for hidden edges.
Thickness integer Determines the line thickness used for hidden edges.

Fillets
Color color Determines the color of fillets.
Linetype integer Determines the linetype used for fillets.
Thickness integer Determines the line thickness used for fillets.

Wireframe
Color color Determines the color of wireframe.
Linetype integer Determines the linetype used for wireframe.
Thickness integer Determines the line thickness used for wireframe.

3DPoints Symbols integer
Determines the symbol used for 3D points. 
Use O to inherit from the 3D symbol, 
use 1 to 8 to choose a custom symbol.



Drafting Interoperability
In this section, you will find information on working with Drafting and the PDM systems listed below.

Working with ENOVIA LCA
Working with ENOVIA VPM 



Working with ENOVIA LCA
Managing CATDrawing Documents in ENOVIA LCA

Optimal CATIA PLM Usability for Drafting



Managing CATDrawing Documents in ENOVIA LCA

This task shows you how to manage the integration between CATIA V5 Drafting and ENOVIA LCA. You will learn how to:
●     create a CATDrawing document and save it in ENOVIA LCA

●     retrieve the CATDrawing document in ENOVIA LCA

●     view the documents which impact the CATDrawing in ENOVIA LCA

●     open the CATDrawing document in CATIA V5

This task uses an assembly drawing (i.e. a drawing with views generated from a CATProduct document) as an example, but 
the same possibilities apply to part drawings as well.

  
For more information about interoperability between CATIA and ENOVIA LCA, refer to the ENOVIA-CATIA Interoperability 
User's Guide. For more information on using ENOVIA LCA, refer to ENOVIA V5 LifeCycle Applications documentation.

  

Have a CATIA V5 and an ENOVIA LCA sessions running.

   
 

Creating a CATDrawing document and saving it in ENOVIA LCA

1.  In ENOVIA LCA Product Class View, select a product and send it to CATIA V5. 

For more information, refer to Sending an ENOVIA LCA Document to CATIA V5 in the ENOVIA-CATIA Interoperability 

User's Guide.

2.  In CATIA V5, select Start -> Mechanical Design -> Drafting. The New Drawing Creation dialog box is displayed.

3.  Select the views to be automatically created on your drawing, for example the Front, Top and Left icon. 

4.  Click OK. A progress bar appears while the views are being generated from the opened CATProduct. 

The views are then displayed in the CATDrawing document.



5.  Click the Save Data in ENOVIA LCA Server...  icon to save the drawing in ENOVIA LCA. The Save in ENOVIA 

LCA dialog box is displayed. 

For more information, refer to Saving an ENOVIA LCA Document from CATIA V5 in the ENOVIA-CATIA Interoperability 

User's Guide.

6.  Click OK to validate. The drawing is vaulted in ENOVIA, as well as the parts and products from which the views were 

generated. Note that the drawing is saved as a document in ENOVIA, it is not attached to a part at this moment.

Retrieving the CATDrawing document in ENOVIA LCA

1.  In ENOVIA LCA, click the Search  icon in the left-hand pane to perform a query in order to retrieve your 

CATDrawing document.

2.  Select Content Management -> Documents -> Documents. The Search panel is displayed.

3.  In the Search panel, enter the name of your CATDrawing document and click OK. The search results are displayed in 

the bottom pane.

4.  Right-click the CATDrawing document and select Copy from the contextual menu. 

5.  In ENOVIA LCA Product Editor, paste the document under the PRC.

 
Viewing the documents which impact the CATDrawing in ENOVIA LCA



 

1.  In ENOVIA LCA Content Management, right-click the CATDrawing document (it can be either a part drawing or an 

assembly drawing) and select Send To -> Impacted By. The Impacted By Tree View is displayed.

2.  Double-click the CATDrawing document (here P2) to expand the whole view of the product. 

The drawing dependencies are displayed, letting you view the links between the CATDrawing document 

and the CATPart and/or CATProduct documents it references. This also lets you know whether the drawing 

is up-to-date or not.

In the examples below, P2 identifies the drawing, and the ENOVIA_VPMTPDependence object identifies 

the drawing dependence(s).

 Example 1

The color of the ENOVIA_VPMTPDependence object relates to the status of its dependences (here P1 and 
Property of P1): ENOVIA_VPMTDependence is green, which means that it is synchronized with its 
dependences. 

The thumb relates to the status of the branch: here the thumbs are up and green, which means that P1 
and Property of P1 are synchronized with the ENOVIA_VPMTPDependence object. 

Since all elements are synchronized, the drawing is up-to-date.

 

 Example 2

You can see that ENOVIA_VPMTDependence is red, which means that it is not synchronized with its 
dependences. 

Here, the red thumb down for P1 shows that it has been modified: it is not synchronized with the 
ENOVIA_VPMTDependence object. Therefore, ENOVIA_VPMTDependence is not synchronized with P1 
either: it is red.

Since not all elements are synchronized, the drawing is not up-to-date.

 



3.  If the drawing is not up-to-date, you can update it using the following method: 

a.  Open the CATDrawing document in CATIA V5 (as described in Opening the CATDrawing document in CATIA V5 

below).

b.  Refresh it using the update  icon.

c.  Save it using the Save Data in ENOVIA LCA Server...  icon.

d.  Perform a local refresh in ENOVIA LCA using the Refresh  icon.

If you now go back to the Impacted By Tree View in ENOVIA LCA, the drawing is indicated as being up-to-date.

For more information, refer to Publishing Links in ENOVIA LCA in the ENOVIA-CATIA Interoperability User's Guide.

Opening the CATDrawing document in CATIA V5

To be able to open only the CATDrawing document in CATIA V5, you need to send it from ENOVIA Content Management for 
example.
To illustrate this task, you should use an assembly drawing (rather than a part drawing).

1.  In ENOVIA LCA Product Editor, right-click the CATDrawing document and select Send To -> Content Management.

2.  In Content Management, right-click the CATDrawing document and select Send To -> CATIA V5. The drawing is 

displayed in CATIA V5. In the case of an assembly drawing, the drawing links are broken.

3.  To solve the links, perform as follows, depending on the save mode you chose when saving the assembly in ENOVIA 

LCA: 

●     For an exploded assembly (i.e. saved as Document not kept & Product Structure Exposed): right-click 

the drawing in the specification tree and select Load PDM Context (you can also go back to ENOVIA 

LCA, right-click the associated CATProduct and CATPart documents in Content Management, and 

select Send To -> CATIA V5). This loads the assembly drawing context (i.e. the CATProduct and 

CATPart documents used for the assembly drawing creation or for the last assembly drawing update) 

in the Product Structure editor in CATIA V5. Note that the part instances which were not referenced by 

the drawing when you last saved it are not loaded. 

●     For a "black box" or "work package" assembly (i.e. saved as Document kept in vault & Publications 

Exposed): select Edit -> Links... and choose the Pointed documents tab to visualize the links 

between the CATProduct and CATDrawing documents. From the list of pointed documents, select the 

CATProduct and/or CATPart documents you want to open, and click the Open button. This loads the 

selected documents in the Product Structure editor in CATIA V5. 



Note that you need to load all the parts which make up a given product if you want them to be included in the drawing views 

at the next update.

The drawing links are now solved. The Drafting specification tree indicates whether the drawing is up-to-date or not, 

whether the drawing is a part drawing or an assembly drawing. 

 

If a 3D element (product or part) has been modified before launching the drawing, the 
update mask appears in front of the drawing elements which need an update (all, in our 
example):

  

 
If no modification has been performed in 3D before launching the drawing, the various 
drawing elements in the specification tree are shown as being up-to-date:



Optimal CATIA PLM Usability for Drafting
When working with Drafting in an ENOVIA LCA context, there are a few circumstances under which a 
drawing cannot be correctly saved in ENOVIA LCA. 

More specifically, a drawing from an exploded product (i.e. an assembly saved as Document not kept & 
Product Structure Exposed) cannot be saved in the following cases: 

●     when the drawing contains views referencing different instances of the exploded product: indeed, all 
generated views in the drawing must reference the same 3D elements.

●     when the drawing contains views referencing the following DMU components: 3D box, section or 
scene.

An error message is now displayed when trying to create views referencing such elements.

Note that this message is only displayed if the product from which you are trying to create the view has 
already been saved in the ENOVIA LCA database.



Working with ENOVIA VPM
Managing CATDrawing Documents in ENOVIA VPM

Optimal CATIA PLM Usability for Drafting



Managing CATDrawing Documents in ENOVIA VPM
This task shows you how to manage the integration between CATIA V5 Drafting and ENOVIA VPM. You will learn how 
to:

●     create a CATDrawing document and save it in ENOVIA VPM

●     view the documents which impact the CATDrawing in ENOVIA VPM

●     open the CATDrawing document in CATIA V5

  
For more information about interoperability between CATIA and ENOVIA VPM, refer to the ENOVIA-CATIA 
Interoperability User's Guide. For more information on using ENOVIA VPM, refer to ENOVIA VPM documentation.

  

Have a CATIA V5 and an ENOVIA 3d com Navigator sessions running.

Creating a CATDrawing document and saving it in ENOVIA VPM

1.  From the ENOVIA 3d com Navigator, right-click a CATPart or a CATProduct document and select CATIA_V5 -

> Load to load this document into CATIA V5.

For more information, refer to the CATIA V5 / ENOVIA VPM Interoperability via ENOVIA 3d com on Windows 

chapter in the ENOVIA-CATIA Interoperability User's Guide.

Note that to create a subassembly drawing, the ENOVIA VPM subassembly has to be loaded into CATIA V5 from its 
own bookmark in the ENOVIA 3d com Navigator web tree.

 
2.  In CATIA V5, select Start -> Mechanical Design -> Drafting. The New Drawing Creation dialog box is 

displayed.

3.  Select the views to be automatically created on your drawing, for example the Front, Top and Left icon. 

 



 
4.  Click OK. A progress bar appears while the views are being generated from the opened CATPart or 

CATProduct document. 

The views are then displayed in the CATDrawing document.

 

  
 

5.  Create an ENOVIA VPM document with the CATDrawing document, as explained in Creating an ENOVIA VPM 

Document in CATIA V5 in the ENOVIA-CATIA Interoperability User's Guide.

 



 
Viewing the documents which impact the CATDrawing in ENOVIA 
VPM

 

1.  From the ENOVIA 3d com Navigator, right-click the CATDrawing document  (it can be either a part drawing 

or an assembly drawing) and select Impact As Reference. An impact graph for the drawing is launched in 

the ENOVIA 3d com Navigator webspace.

2.  Double-click the drawing box (here 2BB-DWG --- AC) to visualize reference-to-reference links for the 

CATDrawing document. 

The drawing dependencies are displayed, letting you view the links between the CATDrawing 

document and the CATPart and/or CATProduct documents it references.

The impact graph also lets you know whether the drawing is up-to-date or not: 

●     a green thumb up  means that the drawing is synchronized with the documents it 

references, and therefore up-to-date. 

For example, in the case of an up-to-date part drawing, you may get something like the 

following impact graph:



 

 
●     a red thumb down  means that the drawing is not synchronized with the documents it 

references, and therefore not up-to-date. 

For example, in the case of a not-up-to-date part drawing, you may get something like the 

following impact graph:

 

3.  If the drawing is not up-to-date, you can update it using the following method: 

a.  Open the CATDrawing document in CATIA V5 (as described in Opening the CATDrawing document in 

CATIA V5 below).

b.  Refresh it using the update  icon.

c.  Save it in ENOVIA VPM using File -> Save.

If you now go back to the Impacted By Tree View in ENOVIA LCA, the drawing is indicated as being up-to-

date.

For more information, refer to Using CATIA V5 Multimodel Link Dependencies in the ENOVIA-CATIA Interoperability 
User's Guide. 

 

Opening the CATDrawing document in CATIA V5
To illustrate this task, you should use an assembly drawing (rather than a part drawing).



1.  From the ENOVIA 3d com Navigator, right-click the CATDrawing document and select CATIA_V5 -> Load to 

load this document into CATIA V5. The drawing is displayed in CATIA V5. In the case of an assembly 

drawing, the drawing links are broken.

2.  To solve the links, perform as follows, depending on the save mode you chose when saving the assembly in 

ENOVIA VPM: 

●     For an exploded assembly: right-click the drawing in the specification tree and select Load 

PDM Context (you can also go back to ENOVIA 3d com Navigator, right-click the 

associated CATProduct and CATPart documents in Content Management, and select 

CATIA_V5 -> Load). This loads the assembly drawing context (i.e. the CATProduct and 

CATPart documents used for the assembly drawing creation or for the last assembly drawing 

update) in the Product Structure editor in CATIA V5. Note that the part instances which 

were not referenced by the drawing when you last saved it are not loaded. 

●     For a "black box" or "work package" assembly: select Edit -> Links... and choose the 

Pointed documents tab to visualize the links between the CATProduct and CATDrawing 

documents. From the list of pointed documents, select the CATProduct and/or CATPart 

documents you want to open, and click the Open button. This loads the selected documents 

in the Product Structure editor in CATIA V5. 

Note that you need to load all the parts which make up a given product if you want them to be included in the 

drawing views at the next update.

The drawing links are now solved. The Drafting specification tree indicates whether the drawing is up-to-

date or not, whether the drawing is a part drawing or an assembly drawing. 

 

If a 3D element (product or part) has been modified before launching the drawing, 
the update mask appears in front of the drawing elements which need an update 
(all, in our example):

  



 
If no modification has been performed in 3D before launching the drawing, the 
various drawing elements in the specification tree are shown as being up-to-date:



Optimal CATIA PLM Usability for Drafting
When working with Drafting in an ENOVIA VPM context, there are a few circumstances under which a 
drawing cannot be correctly saved in ENOVIA VPM. 

More specifically, a drawing from an exploded product (i.e. an assembly saved as Document not kept & 
Product Structure Exposed) cannot be saved in the following cases: 

●     when the drawing contains views referencing different instances of the exploded product: indeed, all 
generated views in the drawing must reference the same 3D elements.

●     when the drawing contains views referencing the following DMU components: 3D box or section.

An error message is now displayed when trying to create views referencing such elements.

Note that this message is only displayed if the product from which you are trying to create the view has 
already been saved in the ENOVIA VPM database.



Workbench Description 
This section contains the list of the icons and menus specific to Generative Drafting workbench.

You may read these pages whenever you require more detailed information on these commands which have 
been documented in other parts of the guide.

 

 
Menu Bar
Toolbars

CATDrawing Specification Tree Icons

  

http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0204.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0203.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0205.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0209.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0208.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0206.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0207.htm
http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugwd0211.htm


Menu Bar
In this chapter we will describe the various menus, submenus and items specific to the Generative Drafting 
workbench.

File

 

   For...   See... 

   

  Page Setup...   Defining the Drafting Sheet 

  Print...   Printing a Sheet 

  Printer Setup...   Printing a Sheet 

Edit
  For... See...

  Links Editing Drawing Links

Not Aligning a View

http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugbt0901.htm
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Properties Access and edit information on 2D geometry, dress-up 
elements, annotations and dimensions in a single dialog box

Background Creating a Frame Title Block

 

Insert
    For... See...

  Views Creating  Views 

  Drawing Creating Sheets

  Dimensioning Creating Dimensions

  Generation Generating Dimensions

  Annotations Annotations

http://chir1dsy/lgkr13/DriEnglish/driug.doc/src/driugbt1000.htm
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  Dress Up Dress-Up Elements

 

New sheet Define a Drafting Sheet

New Detail Sheet Create a 2D component

New View Create views

Instantiate Detail Re-use a 2D component
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Dimensions Create dimensions 

Cumulated Dimensions Create cumulated dimensions 

Stacked Dimensions Create stacked dimensions 

Length/Distance Dimensions Create explicit dimensions

Angle Dimensions Create explicit dimensions

Radius Dimensions Create explicit dimensions

Diameter Dimensions Create explicit dimensions
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Chamfer Dimensions Create chamfer dimensions 

Coordinate Dimensions Create coordinate dimensions

Create Interruption Interrupt one or more extension lines

Remove Interruption Interrupt one or more extension lines

Remove all Interruptions 

 

Interrupt one or more extension lines 

 

 

Datum Feature Create a datum feature 

Geometrical Tolerance 

 

Create a geometrical tolerance 
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Generating Dimensions Generate dimensions in one shot

Generating Dimensions Step by Step Generate dimensions semi-automatically

Balloon generation Generating Associative Balloons

Bill of material 

 

Add a generative Bill of Material 

 

 

Text Create a free text 

Text with Leader Create a text with a leader 

Text Replicate Replicate a text attribute 

Balloon Create a balloon 

Datum Target 

 

Create a datum target 

 

 

Roughness Symbol Create a roughness symbol 
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Welding Symbol Create a welding symbol 

Weld 

 

Create a geometry weld 

 

 

Center Line Create center lines (no reference) 

Center Line with Reference Create center lines (reference) 

Thread Create threads (no reference) 

Thread Create threads (reference) 

Axis Line Create axis lines 

Axis Line and Center Line Create axis lines and center lines 

Tools
    For...   See...
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  Positioning   Further down

  Analyze   Further down

  Reset All Defaults   Before You Begin:

  Insert File Exporting and Importing a File

  

 

Element Positioning Modifying annotation positioning 

Line-up 
Line up dimensions (free space)
Line up dimensions (reference) 

Dimension Positioning Position dimensions 
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Show Geometry in All Viewpoints Showing Geometry in Views

Dimensions Analysis Analyzing Interfering Dimensions



Generative Drafting Toolbars 

This section describes the various icons of the Generative Drafting workbench. The toolbars are located on 
each side of the workbench in the default set-up.

A number of toolbars available in the Generative Drafting workbench are actually part of the Interactive 
Drafting workbench. These toolbars are also listed below but they are documented in the Interactive Drafting 
User's Guide.

 

Generative Drafting Toolbar Purpose

Drawing Create sheets, views, 2D components and frame title blocks

Views Create different kinds of views

Generative View Style Specify the generative view style that should be used when creating 
views

Dimension Generation Generate dimensions and balloons

Interactive Drafting Toolbar Purpose

Dimensioning Create all types of dimensions needed for your drawing

Annotations Add annotations to existing views by creating them

Dress-Up Add dress-up elements on the drawing

Tools Activate display and positioning tools

Tools Palette Use specific options or value fields available for a given command

Properties  

Text Properties Modify the text properties

Graphic Properties Modify the graphic properties of all kind of features

Dimension Properties Modify the dimensions properties

Style Set the style that will be used to create a new object
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Drawing  

  

  See Manipulating the Drafting Sheet

 
 See Creating a 2D Component

 
 See Re-using a 2D component

 
 See Creating a 2D Component

 
 See Add a generative Bill of Material
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Views 

 

  

 

 

 

See Creating a Front View 

See Creating an Advanced Front View

See Creating an Unfolded View

See Creating Projection Views 

See Creating an Auxiliary View 

See Creating an Offset Section View/Offset Section Cut

See Creating an Offset Section View/Offset Section Cut

See Creating an Aligned Section View/Aligned Section Cut

See Creating an Aligned Section View/Aligned Section Cut

See Creating a Quick Detail View/Quick Detail View Profile

See Creating a Detail View/Detail View Profile

See Creating a Detail View/Detail View Profile

See Creating a Clipping View

See Creating a Clipping View

See Creating an Isometric View

 
See Creating a Broken View 

See Creating a Breakout View



See Creating Views via the Wizard 

See Creating Views via the Wizard 



Generative View Style 

 

See Creating a View using Generative View Styles 



Dimension Generation

 

 

 
See Dimensions Generation in One Shot 

See Semi-automatic Dimension Generation 

See Generating Balloons



CATDrawing Specification Tree Icons
This section describes the various icons of the Interactive Drafting and Generative Drafting workbenches. 

 Current drawing

 Design sheet

 Detail sheet

 2D component

 View. Applies to interactive views only (whatever the view type is).

Front view. Applies to generative views only.

 Projection view. Applies to generative views only.

 Auxiliary view. Applies to generative views only.

 Isometric view. Applies to generative views only.

 Section view. Applies to generative views only.

 Section cut. Applies to generative views only.

 Detail view. Applies to generative views only.

 Unfolded view. Applies to generative views only.

Refer to Icon Masks for information on the various masks that can apply to Drafting icons.

http://chir1dsy/lgkr13/BasEnglish/basst.doc/src/basstmask.htm#hj-drafting


Customizing for Drafting
These sections explain how to customize settings for Drafting.

 

Customizing for Interactive Drafting

Customizing for Generative Drafting

http://chir1dsy/lgkr13/BasEnglish/bascudr.doc/src/bascudri0000.htm
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General Settings 

This task shows you how to set general settings to be used in the Interactive Drafting workbench.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the General tab. It contains several categories of options:

●     Ruler

●     Grid

●     Rotation

●     Colors

●     Tree

●     View Axis

 

 
Ruler  

 

 

Show ruler

Check this option to display the ruler in your sheet. It means you visualize the cursor 
coordinates as you are drawing. 

Grid  

 



Display

Check this option to display the grid in your session. You will note that this capability is also 
available via the Drafting Options toolbar.

Snap to point

You need to check this option if the geometry needs to begin or end on the points of the grid.

Allow Distortions

Check this option to apply different graduations and spacing between H and V.

H; V; Primary spacing; Graduations

To define your grid, enter the values of your choice in the H and V  fields. The Primary 
spacing option lets you define the spacing between the major lines of the grid. The 
Graduations field lets you set the number of graduations between the major lines of the 
grid, which actually consists in defining a secondary grid.

Rotation  

 

 

Rotation Snap Angle 

Specify the angle that should be used when rotating text elements (text, frame, or leader) 
using snapping. In other words, this option defines the snapping value used when rotating an 
element using the Select or Rotate commands.

Automatic Snapping 

This option automatically uses snapping when rotating an element.

 
Colors  

You can customize a number of options for modifying the drawing background color. You can do this at 
any time.



 

Sheet background

Choose the color that will be used for the sheet background.

Detail background

Choose the color that will be used for the background of 2D components.

Graduated color

If you want the sheet background and/or the detail (i.e. 2D component) background to be 
graduated, check the associated box.

For example, if you customize the color type as shown below:

 

You will get this result:

 



 Tree 

You can choose whether or not parameters and relations should be displayed in the specification tree.

 

 

Display parameters

Check this option to display in the specification tree the formula parameters used in the 
drawing.

Display relations

Check this option to display in the specification tree the relation parameters used in the 
drawing.

View axis 

 

Display in the current view

Check this box if you want the view axis to be displayed when you activate a view. 

Zoomable

Check this box if you want to be able to zoom view axes (as you can do with geometry).

Reference size 

Enter the size that you want to use as a reference to display view axes size.

4. Choose the options you want and then click OK to validate your settings.



View and Sheet Layout Settings 

You can customize given options when creating views or when adding sheets.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Layout tab. It contains the following sets of options:

●     View Creation

●     New Sheet 

●     Background View

●     Section / Projection Callout

 
View creation 

 

View name

Check this box if you want the view name to be created automatically when creating views.

Scaling factor

Check this box if you want the scaling factor to be created automatically when creating views.

View frame

Check this box if you want the view frame to be created automatically when creating views.

Propagation of broken and breakout specifications

Check this box if you want broken and breakout specifications to be reproduced.



Auxiliary and section views orientation according to profile

You can decide if auxiliary and section views will be oriented according to the profile. In this 
case, the X axis will be parallel to the profile. 

View axis system based on 3D axis system

Check this box if you want the axis system of the generated view to be based on the axis 
system of the 3D part. This enables you to create views with the same orientation if, when 
creating two views in the same projection plane by selecting two different faces, the axis 
systems which are specific to these faces are different.

For example, take the following part:

 

 With the View axis system based on 3D axis system option not checked, the view 
orientation will be different depending on the element selected in the 3D when creating the 
view:

 

 View orientation when a face of 
the rectangular pad is selected

View orientation when 
a face of the elliptic 
pad is selected

View orientation when the 
absolute XY plane is selected

 

With the View axis system based on 3D axis system option checked, the view orientation 
will always be the same, no matter what element is selected in the 3D when creating the 
view:



 View orientation when either a face of the 
rectangular pad, a face of the elliptic pad, or 
the absolute XY plane is selected

 

New sheet 
 

 Copy background view

Check this box if you want a background view to be copied into newly created sheets.

Source sheet

Specify whether you want the source sheet for the background view to be the first sheet of 
the current drawing, or a sheet from another drawing by selecting the appropriate option.

Background view 
 

  

 Directory for frame and title block

You can specify the path to the directory containing the frame and title block macros.

Section/Projection Callout 
 



Size not dependent on view scale

Check this option if you do not want the size of projection and section callout elements to be 
dependent on the view scale. This option will apply to newly created callouts, i.e. selecting 
this option will not have any impact on existing callouts.

Note that this option only applies to drawings created with versions prior to V5 R11 (i.e. 
versions up to V5 R10).

4. Choose the options you want and then click OK to validate your settings.



View Generation Settings 

 

You can customize given options for controlling geometry and dress-up behavior when generating views, 
as well as view generation. 

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the View tab. It contains several categories of options:

●     Geometry generation / Dress-up

●     View generation

Geometry generation / Dress-up 

 

 

This category of options lets you specify what kind of geometry and dress-up elements you want to 
generate when generating views.

Generate axis

Check this option to generate axis lines.

Generate threads

Check this option to generate threads.

Generate center lines



Check this option to generate center lines.

Generate hidden lines

Check this option to generate hidden lines.

Generate fillets

Check this option to generate fillets. Additionally, click the Configure button to configure fillets 
generation. You can choose to generate either of the following types of fillets:

 
Boundaries
Thin lines, representing the mathematical limits of the fillets. 

Boundaries will not be projected if they correspond to two faces 
which are continuous in curvature. They will be projected only if they 
correspond to a smooth edge which is situated between two faces 
whose curvature radii vary. 

This mode will be used automatically to represent a connection 
between two faces which are not joined by a fillet, no matter what 
option you select.

 

Symbolic 
Original edges, projected in a direction that is normal to each 
corresponding surface.

 

Approximated Original Edges
Original edges, at the intersection of the two surfaces joined by the 
fillet.

 

Projected Original Edges 
Original edges, projected on fillet surfaces in the direction of the view 
projection. 



This projection mode is equivalent to the CATIA V4 fillet projection 
mode.

Dimensions on Symbolic, Approximated Original Edges and Projected Original Edges are not 
associative.

  

 

Inherit 3D colors

Check this option if you want the colors of a part to be automatically generated onto the views.

In the case of white parts, the views generated with this option selected will be white, and will 
therefore not be properly displayed.

 
 Project 3D Wireframe

Check this option to visualize both the wireframe and the geometry on generated views. 
Additionally, click the Configure button to configure the 3D wireframe projection mode. You 
can choose whether projected 3D wireframe can be hidden (in some cases, depending on the 
projection angle, part or all of 3D wireframe will possibly be hidden) or is always visible (3D 
wireframe will be visible in all cases, independently of the projection angle).

 

Project 3D Points

Check this option to project points from 3D (no construction element). Additionally, click the 
Configure button to select the type of points visualized in the projected drawing. In the 3D 
Point Projection dialog box, you can choose between keeping the symbols that are used in the 
3D or using a new symbol.



 

 
Apply 3D specification

Check this option to specify that, in an assembly, given parts will or will not be sectioned into 
section views or breakout views (Generative Drafting workbench). For this, you select one view, 
then the Edit -> Properties command from the menu bar from the Assembly Design 
workbench (Mechanical tab, Drafting properties options) and either activate or de-activate 
the Not cut in section views option.

 
View Linetype

Click the Configure button to configure linetypes for specific types of views: section view, 
detail view, broken view, breakout view, skin section view (in the case of wireframes and 
surfaces). In the Linetype and Thickness dialog box, select the line type and the thickness you 
want for each type of view, from the associated fields. Click Close when you are done.



If you choose the zigzag linetype (linetype #8), note that this 
linetype is just a graphical dress-up of the view. This means that if 
one line is relimited on the breakout line, then it will be relimited on 
the theoretical line as shown here, and not on the visualized zigzag 
line.

 View generation 

 

View generation mode

From this list, select how you want to generate views. 

Exact view

Generates exact views from the Design mode, i.e. views for which the geometry is available. 
The exact generation mode will be the best option in most cases:

●     This is the fastest generation mode. 

●     All types of views can be generated using this option.

●     All functionalities (dress-up, dimensions, annotations, etc.) are available.

However, there are a few cases in which choosing the exact generation mode will not be 
appropriate:

●     In the case of sophisticated products or assemblies involving large amounts of data, 
generating exact views may consume too much memory.

●     Polyhedral elements (such as dittos, surfaces, etc.) from V4 .model documents are not 
supported. 

CGR 

Generates views using the CGR format (CATIA Graphical Representation). CGR corresponds to a 
data format containing a graphical representation of the geometry only, which is available with 
the Visualization mode (as opposed to the exact geometry, which is available with the Design 



mode). With CGR, only the external appearance of the component is used and displayed; the 
geometry is not available. The corresponding .cgr file, if it exists, is inserted from the cache 
system. 

CGR views are not as high in quality as exact views, but they consume much less memory 
during the generation. This may be useful when dealing with sophisticated products or 
assemblies involving large amounts of data. However, this generation mode is rather slow. 

For more information about the advantages and restrictions associated with the CGR generation 
mode, see Advantages and restrictions common to CGR and Approximate modes below.

 Approximate 

You can now generate views in Approximate mode. Although Approximate views are not as high 
in precision and quality as exact views, this generation mode dramatically reduces memory 
consumption. Performances may also be improved, depending on how you fine-tune precision. 
Therefore, the Approximate mode is particularly well-adapted to sophisticated products or 
assemblies involving large amounts of data. 

The Approximate mode offers about the same advantages and restrictions than the CGR 
generation mode (see above). However, there are some differences: 

●     Approximate consumes even less memory than CGR. 

●     Approximate is faster than CGR, but performances largely depend on fine-tuning. 

●     Approximate provides more approximate results than CGR, but these results largely depend 
on how you fine-tune precision. 

You can fine-tune the generation options according to your needs. Click the Configure button. 
In the dialog box, move the cursor to set the precision (i.e. the level of detail - LOD) with 
respect to the performances (i.e. generation time - Time). The level of detail corresponds to the 
precision with which the application determines which edges are hidden and which are not. As a 
result, decreasing this precision may lead to smaller geometry being visible whenever it should 
not be, and vice-versa.
The higher the precision, the lower the performances. In any case, memory consumption will 
not be impacted. Click Close when you are done. 

For more information about the advantages and restrictions associated with the Approximate 
generation mode, see Advantages and restrictions common to CGR and Approximate modes 
just below. 



Advantages and restrictions common to CGR and Approximate 

Using CGR or Approximate to generate views offers the following advantages: 

●     Optimize memory consumption when generating and handling projection views for large 
products or assemblies. 

●     Generate views from third-party data (such as MultiCAD), as well as from polyhedral 
elements (such as dittos, surfaces, etc.) in V4 .model documents. 

However, the CGR or Approximate generation mode involves a number of restrictions: 

●     You cannot generate section views, section cuts, detail views, detail view profile, breakout 
views, unfolded views and views from 3D. 

●     You cannot project 3D elements such as wireframe, points, etc. on CGR or Approximate 
views. 

●     CGR or Approximate views cannot contain dress-up elements (axis, center lines, threads). 

●     Auxiliary view profiles, annotations, dimensions, etc. are not associative on CGR or 
Approximate views.  

●     CGR or Approximate views being only a graphical representation of the geometry, only line 
segments are generated in such views. As dimensions are not associative, the only 
elements that can be dimensioned are these line segments. 
As a result, it is impossible to create certain types of radius or diameter dimensions in such 
views; to put it simply, you cannot create radius and diameter dimensions on elements 
other than these line segments. 

As a consequence of these restrictions, selecting either the CGR or the Approximate option 
disables a number of other options on the View and on the Generation tab. 

 Raster

Generates views as images. This enables you to quickly generate overall views for large 
products or assemblies, regardless of drawing quality. Such views are associative to the 3D 
geometry and can be updated when the part or product changes. 

Raster views offer a number of restrictions: 

●     You cannot generate the following types of views using this option: view from 3D, section 
views, section cuts, detail views, breakout views, unfolded views. 

●     Raster views cannot contain dress-up elements (axis, center lines, threads).

●     Creating dimensions is impossible. 

●     Generally speaking, all commands requiring the selection of geometry are not available. 

●     Raster views cannot be edited (you can work around this by isolating the view: double-
clicking the image will then launch an image editor). 

As a consequence of these restrictions, selecting this option disables a number of other options 



on the View and on the Generation tab. 

To optimize disk space and memory consumption, it is recommended that you do not select the 
Inherit 3D colors option when generating views as images.

 Click the Configure button to configure the raster mode options. 

From the Mode list, select the mode that you want to use: Dynamic Hidden Line Removal, 
Shading, Shading with edges. These modes are equivalent to the 3D rendering styles. For more 
information, refer to Using Rendering Styles in the Infrastructure User's Guide. 

Now, set the level of detail (i.e. the definition, in dpi) that will respectively be used to visualize 
and to print the drawing. You can choose between three pre-defined modes (Low quality, 
Normal quality and High quality) and a custom mode (Customize). If you choose to customize 
the definition yourself, set the dpi for visualization and for print in the appropriate fields. 

Click Close when you are done. 

 

The level of detail applies to the scale of the view. In some cases (when the view would print 
with a considerable height or width), there may be too many pixels to generate the view. In 
this case, the view will be displayed as a red cross-mark. If this happens, try to reduce the 
scale of the view and/or the level of detail. 

If you want the colors of a part to be used when generating Raster views using the Shading or 
Shading with edges mode, remember to select the Inherit 3D Colors option. Otherwise, the 
view will be generated using shades of grey. 

To further improve performance when generating Raster or CGR views, we recommend you work in 
Visualization mode: to do this, in the Options dialog box, go to Infrastructure -> Product Structure -> 
Cache Management tab and select Work with the cache system. (For more information, see 
Customizing Cache Settings in the Infrastructure User's Guide and Visualization mode in the Product 
Structure User's Guide.)  

 

http://chir1dsy/lgkr13/BasEnglish/bascupst.doc/src/bascupst0100.htm
http://chir1dsy/lgkr13/BasEnglish/bascupst.doc/src/bascupst0100.htm


 Exact preview for view generation

Make sure this option is selected if you want an exact preview when generating views. As a 
result, the part or product will be loaded in Design mode when previewing the view to generate, 
even if you are working in Visualization mode. Deselect this option to get a quick preview of the 
3D document when generating views. In this case, a part or product open in Visualization mode 
will not be loaded in Design mode for the preview, which optimizes memory consumption.

 
 Only generate parts larger than

To specify that you only want to generate parts which are larger than a certain size, select this 
option and indicate the appropriate size by providing a value in millimeters in the appropriate 
field.

 
 Enable occlusion culling

Select this option if you want to save memory when generating exact views from an assembly 
which is loaded in Visualization mode (i.e.  when the Work with the cache system option is 
active). This will load only the parts which will be seen in the resulting view (instead of loading 
all of them, which is the case by default), which optimizes memory consumption and CPU 
usage.
To ensure the efficiency of this option, make sure that the Exact preview for view 
generation option is not selected.
In the case of an assembly which is loaded in Design mode, or in the case of a part, the Enable 
occlusion culling option will help increase performance by reducing CPU usage.

Keep the following restrictions in mind when selecting the Enable occlusion culling option:

●     The Project 3D points option will be disabled.

●     The only option available for Project 3D wireframe is Can be hidden. 

●     If you choose to project 3D wireframe, you will need to make sure that your wireframe 
elements have been taken into account when the CGR data was created: this is the case if 
you activated the Save lineic elements in cache option from Tools -> Options -> 
General -> Display -> Performances before the creation of CGR data (i.e. before you 
launched the part or product in Visualization mode). If not, you need to activate the Save 
lineic elements in cache option and then re-create the CGR data. To do this: 

1.  Close all open parts and products and exit the application. 
2.  Delete your CGR data from the cache. (The cache location is specified in Tools -> 

Options -> Infrastructure -> Product Structure -> Cache Management tab, Path 
to the local cache field.)

3.  Re-open the product in Visualization mode. 

4. Choose the options you want and then click OK to validate your settings.

 



These options are also available in the Properties dialog box for each view: from the contextual menu, 
click Properties, click the View tab and then select the desired options.



Generation 
You can customize given options for controlling dimension and balloon generation in generative views. 

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Generation tab. It contains several categories of options:

●     Dimension generation

●     Balloon generation

Dimension generation 
 

Generated dimensions are positioned according to the most representative views. In other words, a 
dimension will appear on a view so that it does not need to be created on another view. 

The dimensions are generated on the views on the condition the settings were previously switched to the 
dimension generation option.

Generate dimensions when updating the sheet 

Check this option to generate dimensions automatically each time you update the sheet.

Filters before generation

Check this option to display the Dimension Generation Filters dialog box before generation. This 
enables you to specify what type of dimensions you want to generate. Also, in assembly or 
product views, this lets you indicate what parts you want to generate dimensions for. 

Automatic positioning after generation

Check this option if you want the dimensions to be automatically positioned after generation. 



Allow automatic transfer between views

Check this option if you want dimensions to be automatically transferred to the most 
appropriate view when regenerating dimensions.

Analysis after generation

Check this option to display the Generated Dimension Analysis dialog box after generation. 

Generate dimensions from parts included in assembly views

Check this option to extract 3D part constraints (on top of assembly constraints) when 
generating product dimensions.

This option is particularly useful if you want to generate dimensions for all parts included in 
assembly or product views, without displaying the Dimension Generation Filters dialog box 
before dimension generation. Note that if you display the Dimension Generation Filters dialog 
box before generating dimensions, you will need to indicate what parts you want to generate 
dimensions for (whether this option is selected or not).

Delay between generations for step-by-step mode

Specify the delay between each dimension generation when generating dimensions step by 
step. 

 

Balloon generation 
 

 Creation of a balloon for each instance of a product

If you select this option, a balloon will be generated for each instance of a component: 
therefore, if a component is used two times within a product, then the balloon will be generated 
twice. 

If you leave this box unselected, a single balloon will be generated for all instances of the same 
component, when a component is used several times within a part or product.

4. Choose the options you want and then click OK to validate your settings.



Geometry Creation 

You can customize given options when creating 2D geometry, either or not using autodetection (or 
SmartPick), or still adding constraints to this geometry.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Geometry tab. It contains several categories of options:

●     Geometry

●     Constraints creation

●     Constraints Display

●     Colors

Geometry 

 

 

Create circle and ellipse centers

You can decide whether or not you want to create centers when creating circles or ellipses. 
By default, this option is activated. Just uncheck it if you do not need to create circle and 
ellipse centers.

Allow direct manipulation

Select this option to be able to move geometry using the mouse. When moving geometry, 
you can move either the minimum number of elements, the maximum number of elements, 
or still the minimum number by modifying the shape of elements, if needed. Click the 
Solving mode... button to configure manipulation. 



 

 

The dialog box that appears offers the following options as regards the solving mode:

Solving mode for moving elements

Standard mode 
You move as many elements as possible and also respect existing constraints.

Minimum move
You move as few elements as possible and also respect existing constraints.

Relaxation
You move elements by re-distributing them over the sketch, globally speaking. This method 
solves element moving by minimizing energy cost. 

Drag elements end points included

Furthermore, you can choose to drag elements along with their end points by checking this 
box.

 Show H and V fields in the Tools Palette

You can show the H and V fields in the Tools Palette when creating 2D geometry or when 
offsetting elements. Leaving the option unchecked enables you to directly enter the value 
corresponding to the type of element you are creating: for example, the length when creating 
a line, the radius when creating a circle or the offset value when offsetting elements. 

When a command (such as the Point creation command) does not have any parameters other 
than H and V, then these two fields will remain in the Tools Palette, whether you select this 
option or not.

 



 

Create end points when duplicating generated geometry

When duplicating geometry that was generated from the 3D, you can choose to create end 
points for these geometrical elements. 

 
Constraints creation 

 

 

Create detected and feature-based constraints 

Select this option if you want to create the geometrical or dimensional constraints detected 
by the SmartPick tool. If all of the detection options are unchecked, the Create detected 
and feature-based constraints option is not available.

If this detection option is unchecked, the Create detected constraints option will be 
inactive by default in the Tools toolbar. You will be able to activate it at any time.

SmartPick... (switch button)

As you create more and more elements, SmartPick detects multiple directions and positions, 
and more and more relationships with existing elements. This may lead to confusion due to 
the rapid highlighting of several different detection possibilities as you point the cursor at 
different elements in rapid succession. Consequently, you can decide to filter out undesired 
detections by clicking the SmartPick... button.

 



 

The SmartPick dialog box provides these options:

●     Support lines and circles

●     Alignment

●     Parallelism, perpendicularity and tangency

●     Horizontality and verticality

Uncheck the elements you do not wish to detect when sketching. 

Disabling SmartPick completely (i.e. unchecking all options in the SmartPick dialog box) is 
particularly useful when your screen is full of elements: in this case, it may be a good idea to 
disable SmartPick to concentrate only on the geometry.

Constraints Display 

 

Display constraints

Check this option to visualize the logical constraints specific to the elements. Note that if the 
Display constraints option is unchecked, the other options in this category are not 
available.

Reference size

Specify the size that will be used as a reference to display constraints symbols. Changing this 
reference size will modify the size of all constraints representations.

Constraints color

Choose the color that will be used to display constraints.

Constraints types... (switch button)

Click this button to define which types of constraints you will visualize as you create the 
geometry.



 

 

The Constraints types dialog box provides these options:

●     Horizontal

●     Vertical

●     Parallelism

●     Perpendicularity

●     Concentricity

●     Coincidence

●     Tangency

●     Symmetry

Uncheck the types of constraints you do not want to visualize as you create the geometry.

 
Colors 

 



 

Two types of colors may be applied to sketched elements. These two types of colors correspond to 
colors illustrating:

●     Graphical properties
Colors that can be modified. These colors can therefore be modified using the Tools->Options 
dialog box.

OR

●     Constraint diagnosis
Colors that represent constraint diagnoses are colors that are imposed to elements whatever the 
graphical properties previously assigned to these elements and in accordance with given diagnoses. 
As a result, as soon as the diagnosis is solved, the element is assigned the color as defined in the 
Tools->Options dialog box.

Visualization of diagnosis

Select this option if you want over-constrained, inconsistent, not-changed or iso-constrained 
elements to be identified using specific colors. Then, click the Colors... button to configure 
these colors.

 

 

In the dialog box that appears, you can configure colors for the following types of elements:

Over-constrained elements
The dimensioning scheme is over-constrained: too many dimensions were applied to the 
geometry.

Inconsistent elements
At least one dimension value needs to be changed. This is also the case when elements are 
under-constrained and the system proposes defaults that do not lead to a solution.

Not-changed elements
Some geometrical elements are over-defined or not-consistent. As a result, geometry that 
depend(s) on the problematic area will not be recalculated.

Iso-constrained elements



All the relevant dimensions are satisfied. The geometry is fixed and cannot be moved from its 
geometrical support.

Other color of the elements 

Click the Colors... button to configure the colors of other elements.

 

In the dialog box that appears, you can configure colors for the following types of elements:

Isolated elements
Use-edge (projection, intersection, etc.) that does not depend on the 3D anymore.

Protected elements
Non-modifiable elements.

Construction elements
A construction element is an element that is internal to, and only visualized by, the sketch. 
This element is used as positioning reference. It is not used for creating solid primitives.

SmartPick 
Colors used for SmartPick assistant elements and symbols.

When opening a drawing, colors are not recomputed. Colors will not be displayed until you create 
another element or move the geometry. 

 

4. Choose the options you want and then click OK to validate your settings.

 



Dimension Creation 

You can customize given options when creating or re-positioning dimensions.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Dimension tab. It contains several categories of options:

●     Dimension Creation

●     Move

●     Line-Up

●     Analysis Display Mode

Dimension Creation 

 

Dimension following the mouse (ctrl toggles) 

You can decide that the dimension line is positioned according to the cursor, following it 
dynamically during the creation process.

Constant offset between dimension line and geometry

The distance between the created dimension and the geometry remains the same when you 
move the geometry.

Default dimension line/geometry distance

If you position the dimension according to the cursor, you can define the value at which the 
dimension is created. If you create associativity between the dimension and the geometry, 
you can define the value at which the dimension will remain positioned.



Associativity on 3D

If you click the switch button, the Dimensions associativity on 3D dialog box appears.

A link can be applied between a dimension and the 3D part. As a result, when you update the 
drawing, the dimension is automatically re-computed. If you do not check this option, when 
you perform the update, you need to re-create the dimension afterwards.

 

Create driving dimensions

The dimensions you will create will drive the geometry.

A new field will appear in the Tools Palette during the creation process, allowing you to enter 
the driving dimension value.

 Detect chamfer

Automatically detects chamfers so that you can create chamfer dimensions in a single click. 
As chamfer detection may slow performance down, you may want to deactivate this option 
for large products or assemblies.

 By default, create dimensions on circle's

Specify whether the dimension you will create between a circle and another element should 
be on the circle center or on the circle edge.

Move 



 

Activate Snapping (shift toggles)

Select to activate the snapping option. Click the Configure button. In the dialog box, specify 
whether the dimension should be snapped on the grid, or whether the dimension value 
should be located at its default position between symbols (it will work only if the cursor is 
between the symbols), or both.

 

Pressing the Shift key allows you to temporarily deactivate or activate this mode.

Move only selected sub-part

Activate this option if you want to move only a dimension sub-part (text, line, etc.).

Line-Up 

 



You can organize dimensions into a system with a linear offset. The offset will align the dimensions to 
each other as well as the smallest dimension to the reference element.

Default offset to reference

This allows you to set the offset between the smallest dimension and the reference element.

Default offset between dimensions

This allows you to set the offset between dimensions.

Align stacked dimension values

Lets you align all the values of a group of stacked dimensions on the value of the smallest 
dimension of the group. 

Align cumulated dimension values

Lets you align all the values of a group of cumulated dimensions on the value of the smallest 
dimension of the group. 

Automatically add a funnel

Whenever the value of a cumulated dimension requires a funnel to be displayed correctly, 
lets you have one added automatically.

Analysis Display Mode 

 

Activate analysis display mode 

Colors can be customized with this option. To activate this mode, select this option and then 
click the Types and colors button. The Types and colors of dimensions dialog box lets you 
assign the desired color(s) to the selected dimension types. You will then be able to visualize 
the different types of dimensions using their assigned colors.  



4. Choose the options you want and then click OK to validate your settings.



Manipulators 
These options apply to the Interactive Drafting workbench only.

You can decide that you will visualize given manipulators whenever creating or modifying dimensions.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Manipulators tab. It contains several categories of options:

●     Manipulators

●     Dimension Manipulators

Manipulators 

 

 

These settings can be used for any type of manipulator (texts, leaders, center lines, dimensions and so 
forth). 

Reference size

Specify the reference size that should be used for manipulators. In the case of texts, for 
example, this reference size corresponds to the diameter of the rotation manipulators. 

 

Zoomable

Check this box if you want to make manipulators zoomable.

Dimension Manipulators  



 

 These settings let you define which manipulators you will visualize and therefore use when creating and/or 
modifying dimensions:
 

  

Modify overrun

If you drag select one overrun manipulator, both overrun extension lines are modified. To 
modify only the selected overrun extension line, use the Ctrl key. You can also double-click on 
the manipulator and enter the new value in the dialog box that appears.

Modify blanking

If you drag select one blanking manipulator, both blanking are modified. To modify only the 
selected blanking, use the Ctrl key.  You can also double-click on the manipulator and enter the 
new value in the dialog box that appears.



Insert text before 

Allow inserting a text before, without using the Properties dialog box. For this, you will click on 
the manipulator and enter the new text in the dialog box that appears.

Insert text after

Allows inserting a text after, without using the Properties dialog box. For this, you will click on 
the manipulator and enter the new text in the dialog box that appears.

Move value 

Allows moving the dimension value and only it.

Move dimension line

Allows moving the dimension line and only it by dragging to the new location.

Move dimension line secondary part

Allows moving the dimension line secondary part and only it by dragging to the new location.

4. Choose the options you want and then click OK to validate your settings.



Annotation and Dress-up 

You can customize given options that will be used when creating annotations.

1. Select Tools->Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Annotation and Dress-Up tab. It contains the following sets of options:

●     Annotation Creation

●     Move

●     2D Component Creation

●     Balloon Creation

Annotation Creation 
 

In order for these options to be taken into account, the Activate Snapping (SHIFT toggles) box 
must be checked. Note that the option selected in the Activate snapping dialog box will be taken into 
account. See the Move section.

Create text along reference

Select this option if you want to create annotation texts along a reference direction. For 
example, if you select a line when creating a text, the text will be oriented parallel to the line. 

Text

Select this option if you want to create the extremity of text leaders normal to a reference 
direction. For example, if you select a line when creating a text with leader, the leader will be 
normal to the line.  

Geometrical tolerance

Select this option if you want to create the extremity of geometrical tolerance leaders normal 
to a reference direction. For example, if you select a line when creating a geometrical 



tolerance, the leader will be normal to the line.  

Move 
 

 Activate Snapping (SHIFT toggles)

Select this option to activate snapping. Click the Configure button.

In the dialog box that appears, specify whether you want the annotation to be snapped on 
the grid, according to the orientation, or both. This will apply to the annotations selected in 
the Annotation Creation area. To deactivate snapping when creating or moving annotations, 
press the Shift key.

 

 

2D Component Creation 
 

Create with a constant size

Select this option if you want all 2D component instances to have the same size when you 
create them, no matter what the view scale is. 

This lets you create 2D component instances whose size is independent from the view scale 
so that they always look the same. You can use them as symbols, for example. 

If you want to use as symbols 2D components with text, activate both the Create with a 
constant size setting and the Apply Scale property for the text (in Edit -> Properties): 
the size of both the 2D component and its text will then be independent from the view scale.



 

Balloon Creation 
 

 3D associativity

You can specify what kind of balloons you want to create (using the Balloon command from 
the Annotation toolbar) or to generate (using the Generate Balloons command from the 
Generation toolbar).
First, select the 3D associativity box to indicate that you want to associate balloons with 
information from the 3D. Then, select from the list the kind of balloons you want to create or 
generate: the numbering of parts within an assembly (default option), the instance name or 
the part number. 

4. Choose the options you want and then click OK to validate your settings.



Administration Settings 

You can customize settings for the management of drawings.

1. Select Tools -> Options. The Options dialog box appears.

2. Click Mechanical Design -> Drafting in the list of objects to the left of the Options dialog box.

3. Select the Administration tab. It contains the following sets of options:

●     Drawing management

●     Style

●     Generative view style

●     Dress-up

Drawing management 

 

Prevent File>New

Check this box to make it impossible to create drawings using the File -> New command. All 
drawings will be created using the File -> New From... command instead.

Prevent switch of standard

Check this box to make it impossible to change standards, i.e. to use a standard other than 
the one currently defined in the Page Setup dialog box.

Prevent update of standard

Check this box to make it impossible to update standards for the current document in the 
Page Setup dialog box.

Prevent background view access

Check this box to make it impossible to access the background view.



Style 
 

 Use style values to create new objects

Check this box if you want dialog boxes, Properties toolbars and the Tools Palette to be pre-
filled with custom style values (as defined in the Standards Editor) when creating new 
annotations. In this case, Properties toolbars and the Tools Palette will be disabled during the 
creation of the annotation. 
If you leave this box unchecked, annotation dialog boxes, Properties toolbars and the Tools 
Palette will be pre-filled with the last entered values (except for Texts, Texts with leader, 
Balloons and Datum features). In this case, Properties toolbars and the Tools Palette will be 
active during the creation of the annotation.

If you check this box, you will be able to reset the current style values in dialog boxes at any 
time using the Reset button. 

 Create new sheet from

This setting lets you specify if the properties used for creating new sheets should be those 
defined in the standards or those defined in the first sheet in a drawing. These properties are 
the scale and the projection method (first or third angle).  

Select Style if you want the sheet to use the style defined in the standards (in Tools -> 
Standards -> Drafting -> [StandardName] -> Styles -> Sheet).

Select First sheet if you want the sheet to use the properties defined in the first sheet in a 
drawing. For example, you can use this option if you use an existing drawing to create a new 
one (i.e. when you want the new drawing to have the same properties as the existing 
drawing).



 Lock "User Default" Style

Check this box to make it compulsory to use User Defaults (i.e., user-defined values set as 
default). The Styles drop-down list will be set to Only User Defaults and will be inactive so 
that Original Defaults or User Defaults cannot be selected. 

This option applies only to drawings created with versions up to V5 R10 whose standard has 
NOT been updated or changed in V5 R11 and later. 

Prevent "Set As Default" and "Reset All Defaults"

Check this box to use the current defaults and to make it impossible to create, change and 
reset user defaults (i.e. user-defined values). This disables the Set as Default and the 
Reset All Defaults commands. 

This option applies only to drawings created with versions up to V5 R10 whose standard has 
NOT been updated or changed in V5 R11 and later.

 

 

Generative view style 
 

 Prevent generative view style creation

Check this box if you do not want to use generative view styles when creating views. In this 
case, you will not be able to select a generative view style after having selected a view 
creation command, which means that the Generative View Style toolbar will not be displayed. 
(In the case of advanced front views, it is the Generative view style list in the View 
Parameters dialog box which will not be displayed).

 

Dress-up 
 



 Prevent dimensions from driving 3D constraints

Check this box to make it impossible to modify a 3D constraint via a 2D dimension that was 
generated from it.

4. Choose the options you want and then click OK to validate your settings.



Customizing Toolbars

 

You can customize the appearance of some fields in the following properties toolbars: Styles, Graphic 
Properties, Text Properties, Dimension Properties.

 

1. Right-click the toolbar field you want to customize. A contextual menu is displayed. 

2. If necessary, scroll down this contextual menu to display the toolbar customization options.

 

 The customization options that you can apply to the selected field are displayed.  

 

The options available depend on the selected field. For more information on what options will be 
available for each field, see the table below.

3. Click the option you want. Depending on the option you selected, the corresponding dialog box 
appears. 

4. Enter the appropriate value in the dialog box.

 ●     Set text width: sets the width used to display the field in the toolbar, in number of characters to 
be displayed (based on 'W').

●     Set list width: sets the width used to display the drop-down list, in number of characters to be 
displayed (based on 'W').

●     Set list height: sets the height used to display the list, in number of lines to be displayed (up and 
down arrows will make it possible to scroll within the list).

●     Icons display: defines whether icons should be displayed in this field, or only in the list, when the 
list is collapsed.

●     Precision: sets the precision used to display a numerical value in this field, in number of digits after 
the separator. 

5. Click OK to validate.

 

The table below indicates which fields you can customize in each toolbar, along with what you can 
customize for each field.



 

 Set text 
width

Set list 
width

Set list 
height Icons display Set precision

Style toolbar

Style Yes Yes Yes Yes No

Text Properties toolbar

Font Name Yes Yes Yes Yes No

Font Size Yes Yes Yes No Yes

Dimension Properties toolbar

Tolerance 
Description Yes Yes Yes Yes No

Tolerance Yes Yes Yes No No

Numerical Display 
Description Yes Yes Yes No No

Precision Yes Yes Yes No Yes

Graphic Properties toolbar

Color Yes No No No No

Thickness Yes No Yes No No

Linetype Yes No Yes No No

Point type Yes No Yes No No



Glossary

                   

A

absolute position A sheet coordinates.
active view A view from which you create any element: another view or 2D dress-up. The 

view from which section views, section cuts and detail views will be created. 
This view generally corresponds to either the front view or the isometric view.

aligned section view A section view created from a cutting profile defined from non parallel planes. 
In order to include in a section certain angled elements, the cutting plane may 
be bent so as to pass through those features. The plane and feature are then 
imagined to be revolved into the original plane.

approximate mode One of the various modes that can be used to generate views. The 
Approximate mode is particularly well-adapted to sophisticated products or 
assemblies involving large amounts of data. Although Approximate views are 
not as high in precision and quality as exact views, this generation mode 
dramatically reduces memory consumption and performances may also be 
improved. 

associative detail
view

A detail view associated with a 3D element.

associativity In the Drafting workbench, the ability of child view(s) to follow the behavior of 
the parent view: moving, scaling.

attribute In the Drafting workbench, the graphical and/or geometrical properties 
inherited from 3D element.

auxiliary view A view in a direction not necessarily vertical or horizontal. In order to show 
the true shapes, it is necessary to assume a direction of sight perpendicular to 
planes that are perpendicular of the curves. This auxiliary view, together with 
the top view, completely describes the object.

B

background sheet A sheet dedicated to frames and title blocks.
background view A sheet dedicated to frames and title blocks.
back-clipping A back-clipping removes all the elements behind a pre-defined plane. It can 

only be applied on an extracted view. Aback-clipping plane is a plane used for 
generating a back-clipping.

bill of material
A piece of information inserted into the active view of a CATDrawing 
document. For this, you can be either in the working view or in the 
background view.

breakout A breakout is a partially removed section which allows visualizing a particular 
element in the view. A breakout view is one not in direct projection from the 
view containing the cutting profile. In other words, it is not positioned in 
agreement with the standard arrangement of views. A breakout view is often 
a partial section.

broken view A view that allows shortening an elongated object, using two profiles 
corresponding to the part to be broken from the view extremities.



C

callout A graphical representation of a cutting profile.
CGR mode One of the various modes that can be used to generate views. CGR (CATIA 

Graphical Representation) corresponds to a data format containing a graphical 
representation of the geometry only, which is available with the Visualization 
mode (as opposed to the exact geometry, which is available with the Design 
mode). CGR views are not as high in quality as exact views, but they consume 
much less memory during the generation. This may be useful when dealing 
with sophisticated products or assemblies involving large amounts of data. 

child view A view generated from a parent view.
clipped view A view modified via a clipping profile.
clipping profile A zone to be kept and visualized in a view.
cross hatching A symbolic representation in the form of a pattern used to display a cut area.
cut area The cut surfaces on a section view or section cut.
cutting profile A set of planes used to define a section view or section cut.

D

datum feature An element defining a contacting surface on a part.
datum target An element defining a contacting surface on a part and represented by 

spherical or pointed locating pins.
design tree Area of the document window reserved for viewing the design specifications of 

a drawing, presented in the form of a tree structure.
detail view A view corresponding to a zoomed particular area to be visualized. This area 

to be visualized is defined by a circle or a given polygon. This view is 
computed using a boolean operator from the 3D

drawing The root feature. Sheets are aggregated in the drawing. Views are aggregated 
in the sheets.

dress-up A graphical attribute of a 2D element.

E

exact view
One of the various modes that can be used to generate views. Exact views are 
generated from the Design mode, i.e. they are views for which the geometry 
is available.

F

FD&T view A view that is extracted from a 3D part that is assigned 3D tolerance 
specifications and annotations.

filter A restriction on elements to be cut in a section view or section cut, or 
elements to be seen in a projection view.

first angle projection method An orthographic representation of the views comprising the arrangement, 
around the principal view of an object, of some of all of the other five views of 
that object. With reference to the principal view, the other views are arranged 
as follows: the view from above is placed underneath, the view from below is 
placed above, the view from the left is placed on the right and then the view 
from the rear is placed on the left or on the right, as convenient.
(Ref. No. ISO 10209-2:1993)



frontal plane A plane of projection upon which the front view is projected.
front view A projection view obtained by drawing perpendiculars from all points on the 

edges of the part to the plane of projection. The plane of projection upon 
which the front view is projected is called the frontal plane.

G

generative view style A set of pre-defined parameters and options which let you customize the 
appearance and behavior of a generated view. 

I

isometric view A 3D view that represents a part according to a given projection plane. This 
view allows a perspective visualization. To produce an isometric projection 
(isometric means "equal measure"), it is necessary to place the object so that 
its principal edges make equal angles with the plane of projection and are 
therefore foreshortened equally.

L

lock A locked view is a view in which any graphical modification of the generated 
2D elements is forbidden.

M

main view The view which supports the geometry directly created in the sheet.

O  

object In the Drafting workbench, there are two kinds of object: activated and 
selected. The view frame of an activated object is displayed in red.

offset section view /cut A section view created from a cutting profile defined with several parallel 
planes. In sectioning through irregular objects, it is often desirable to show 
several features that do not lie in a straight line by offsetting or bending the 
cutting plane.

overlay In a multi-model context, all passive elements are called overlayed elements.

P

parent view A reference view from which another view is generated (for example a front 
view from which a section view will be created). The view frame of the parent 
view is displayed in red. Typically the front view is a parent view. See also 
child view.

part A 3D entity obtained by combining different features in the Part Design 
workbench.

pattern
A graphical representation used to represent a sectioned/cut part. A same 
representation is used for the different parts of the resulting section or section 
view.



projection view A view conceived to be drawn or projected onto planes known as planes of 
projection. A transparent plane or pane of glass representing a plane of 
projection is located parallel to the front surfaces of the part.

Q

quick detail view A view corresponding to a zoomed particular area to be visualized. This area 
to be visualized is defined by a circle or a given polygon. This view is directly 
computed from the 2D projection.

R

raster mode One of the various modes that can be used to generate views. The raster 
mode generates views as images.

S

section cut A view representing the intersection between the 3D geometry and the cutting 
profile.

section profile See cutting profile.
section view In the Drafting workbench, a view representing the intersection between the 

3D geometry and the cutting profile, and all the 3D geometry located behind 
the cutting profile.

simple breakout A simple breakout removes locally a sectioned part perpendicularly to the 
current view plane. You will then be able to visualize the remaining visible 
inside part.

sheet A set of views. Several sheets may be created in the Drafting workbench.
standard The international conventions that are supported in the Drafting workbench: 

ANSI, ISO and JIS.

T

template In the Drafting workbench, an object that is included in the document (for 
example, the title block).

third angle projection method

An orthographic representation of the views comprising the arrangement, 
around the principal view of an object, of some of all of the other five views of 
that object. With reference to the principal view, the other views are arranged 
as follows: the view from above is placed above, the view from below is 
placed underneath, the view from the left is placed on the left and the view 
from the rear is placed on the left or on the right, as convenient.
(Ref. No. ISO 10209-2:1993)

title block A frame which contains the title block.

U

unspec breakout An unspec breakout operation removes locally a 3D part. It allows visualizing 
the inside of a 3D part. It can only be applied to an extracted view.

unfolded view A projected view that is created from a Sheet Metal part in order to include in 
a section certain angled elements. As a result, the cutting plane may be bent 
so as to pass through those features.



V

view frame A square or rectangular frame that contains the geometry and dimensions of 
the view.

W

wizard An assistant for views to be automatically generated once the CATDrawing 
document is opened. These views can then be modified as if they had been 
manually created one after the other.



Index 

                      

Symbols
.model  

Numerics
2D component creation (annotation and dress-up settings)  

2D/3D associativity  
3D constraints 

driving via dimensions  

generating dimensions from  

A
active view  

administration settings  

aligned section cuts, creating  

aligned section views, creating  

aligning views  

analysis display mode (dimension settings)  
analyzing 

generated dimensions  

interfering dimensions  

annotation creation (annotation and dress-up settings)  

annotation settings  
annotations 

overview  

Approximate views  

associativity (2D/3D)  



B
background view (view and sheet layout settings)  

background views, managing  

balloon creation (annotation and dress-up settings)  

balloon generation (generation settings)  
balloons 

generating on a view  

batch, updating drawings  

bill of material  

BOM  

breakout views  

broken views  

C
callouts 

modifying geometry  

modifying graphism  
CATDrawing 

managing documents in VPM  
CATDrawing documents 

creating  

editing links  

loading and saving with unresolved link  

managing  

opening  

updating via the batch monitor  

CATDrawing specification tree icons  
CGM 

export  



import  

CGR views  

clipping view profiles, creating  

clipping views, creating  

colors (geometry creation settings)  
command 

Advanced Front View  

Align Views Using Elements  

Aligned Section Cut  

Aligned Section View  

Auxiliary View  

Breakout View  

Broken View  

Clipping View  

Clipping View Profile  

Detail View  

Detail View Profile  

Dimension Positioning  

Exploded View  

Frame and Title Block  

Frame Creation  

Front View  

Generate Balloons  

Generate Dimensions  

Import a generative view style  

Invert Profile Direction  

Isolate  

Isometric View  

Locate Reference View  

Locate Resulting View  

Offset Section Cut  

Offset Section View  



Position Independently of Reference View  

Projection View  

Quick Detail View  

Quick Detail View Profile  

Restore Deleted  

Set Relative Position  

Show Geometry in All Viewpoints  

Superpose  

Thread Dimension  

Unfolded View  

View From 3D  

Wizard  

constraints creation (geometry creation settings)  

constraints display (geometry creation settings)  
creating 

advanced front views  

aligned section cuts  

aligned section views  

associative thread dimensions  

auxiliary views  

breakout views  

broken views  

clipping view profiles  

clipping views  

detail view profiles  

detail views  

exploded views  

frame and title blocks  

front views  

generative view styles  

inter-technological feature dimensions  

intra-technological feature dimensions  



isometric views  

offset section cuts  

offset section views  

projection views  

quick detail view profiles  

quick detail views  

section cuts (planar surface)  

section cuts with profile defined in 3D  

section views (planar surface)  

section views with profile defined in 3D  

technological feature dimensions  

unfolded views  

views  

views from 3D  

views from a .model  

views using generative view styles  

views via the wizard  

creating drawings  
customizing 

administration settings  

annotation and dress-up settings  

dimension creation settings  

general settings  

generation settings  

generative view styles  

geometry creation settings  

manipulators settings  

toolbars  

view and sheet layout settings  

view generation settings  



D
defining sheets  
Design mode 

defining  

using  

detail view profiles, creating  

detail views, creating  

dimension creation (dimension settings)  

dimension creation settings  

dimension generation (generation settings)  

Dimension Generation toolbar  

dimension manipulators (manipulators settings)  
dimensions 

analyzing generated dimensions  

analyzing interfering dimensions  

driving 3D constraints  

filtering dimension generation  

generate dimensions in one shot  

generate dimensions semi-automatically  

generating from 3D constraints  

generation overview  

inter-technological feature dimensions  

intra-technological feature dimensions  

overview  

positioning (view per view)  

technological feature dimensions  
documents 

managing CATDrawing documents in VPM  

Drafting interoperability  

drawing management (administration settings)  

Drawing toolbar  
drawings 

creating  



editing links  

loading and saving with unresolved link  

managing  

managing documents in VPM  

opening  

updating via the batch monitor  
dress-up 

overview  

settings  

dress-up (administration settings)  

dress-up generation (view generation settings)  

driving 3D constraints  

duplicating generative geometry  
DXF/DWG 

export  

import  

E
ENOVIA LCA 

interoperability  

managing CATDrawing documents  
ENOVIA VPM 

interoperability  

managing CATDrawing documents  

exact views  

exploded views  
export 

CGM  

DXF/DWG  

file  



F
file 

export  

import  

filtering dimension generation  
frame and title blocks 

creating  

inserting an image in  
front views 

creating  

creating from sub-bodies/sub-products  

creating with local axis system  

creating with selection sets  

G
general settings  

generated dimensions, analyzing  
generating 

balloons  

bill of material  

dimensions  
generation 

overview  

settings  

generative view style (administration settings)  

Generative view style toolbar  

generative view styles  

applying to other views  

applying to views  

concepts  

creating  



creating views  

generate parameters  

importing newer versions  

structure of  

switching view styles  

view dress-up parameters  

views  
geometry 

duplicating  

showing in views  

geometry (geometry creation settings)  

geometry creation settings  

geometry generation (view generation settings)  

grid  

I
import 

CGM  

DXF/DWG  

file  

importing a generative view style  
inserting 

images into a frame and title block  

interfering dimensions, analyzing  

interoperability  

ENOVIA LCA  

ENOVIA VPM  

for Drafting  

managing CATDrawing documents in ENOVIA LCA  

managing CATDrawing documents in ENOVIA VPM   

saving data in ENOVIA LCA   



inter-technological feature dimensions  

intra-technological feature dimensions  

isolating views  

isometric views  

L
line-up (dimension settings)  

links, editing for drawings  
loading and saving drawings 

with unresolved link  

local axis system, creating front views with  

locating views  

locking views  

M
managing 

CATDrawing documents in VPM  

drawings  

generative view styles  
managing CATDrawing documents 

ENOVIA LCA  

ENOVIA VPM  

manipulators (manipulators settings)  

manipulators settings  
modifying 

callout geometry  

callout graphism  

patterns  

views   

views from a .model  



move (annotation and dress-up settings)  

move (dimension settings)  

moving views  

N
new sheet (view and sheet layout settings)  

O
occlusion culling  

offset section cuts  

offset section views  

opening drawings  

orientation of views  

overloading element properties  

P
patterns 

modifying  
positioning 

dimensions (view per view)  
positioning views 

aligning  

independently of reference view  

methods  

relatively  

superposing  
printing 

overview  

properties  



Q
quick detail view profiles, creating  

quick detail views, creating  

R
raster views  

relative position for views  

renaming views  

restoring deleted elements  

ruler (general settings)  

S
saving 

drawings (unresolved link)  

scaling views  

section cuts (planar surface)  

section cuts with profile defined in 3D  

creating  

section views (planar surface)  

section views with profile defined in 3D  

creating  

section/projection callout (view and sheet layout settings)  

selection sets, creating front views with  

setting relative position for views  
settings 

administration  

annotation and dress-up  



dimension creation  

general  

generation  

geometry creation  

manipulators  

view and sheet layout  

view generation  

sheet layout settings  

sheets  

managing background views  

modify  

sheets, defining  

showing geometry in views  

standards  

style (administration settings)  

sub-bodies/sub-products, creating front views from  

superposing views  

T
technological feature dimensions 

before you begin  

inter  

intra  
threads 

associative thread dimensions  
toolbars 

customizing  

Dimension Generation  

Drawing  

Generative view style  

Views  



U
unfolded views, creating  

updating drawings via the batch monitor  
utility 

UpdateBatch  

V
view axis (general settings)  

view creation (view and sheet layout settings)  
view generation 

settings  

view generation (view generation settings)  

view layout settings  
views 

active view  

advanced front views  

aligned section cuts  

aligned section views  

aligning  

applying generative view styles  

applying generative view styles to other views  

auxiliary views  

breakout views  

broken views  

clipping view profiles  

clipping views  

creating  

creating and modifying from a .model  

creating via the wizard  



detail view profiles  

detail views  

dress-up  

exploded views  

front views  

front views from sub-bodies/sub-products  

front views with local axis system  

front views with selection sets  

generating Approximate views  

generating balloons on  

generating CGR views  

generating exact views  

generating raster views  

generative view styles  

isolating  

isometric views  

locating views  

locking  

managing background views  

modifying  

moving views  

offset section cuts  

offset section views  

orientation  

overloading element properties  

positioning  

positioning independently of reference view  

projection views  

quick detail view profiles  

quick detail views  

renaming views  

restoring deleted elements  



scaling views  

section cuts (planar surface)  

section cuts with profile defined in 3D  

section views (planar surface)  

section views with profile defined in 3D  

setting relative position  

showing geometry in views  

superposing  

switching generative view styles  

unfolded views  

using generative view styles  

view from 3D  

Views toolbar  
Visualization mode 

improving performance  

saving memory  

W
wizard for creating views  


	Numbx: 
	R: 

	PageText: 
	R: 

	ProductName: 
	L: 

	Version: 
	P1: 
	Numbers: 
	Numbx: 
	R: 1

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P2: 
	Numbers: 
	Numbx: 
	R: 2

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P3: 
	Numbers: 
	Numbx: 
	R: 3

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P4: 
	Numbers: 
	Numbx: 
	R: 4

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P5: 
	Numbers: 
	Numbx: 
	R: 5

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P6: 
	Numbers: 
	Numbx: 
	R: 6

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P7: 
	Numbers: 
	Numbx: 
	R: 7

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P8: 
	Numbers: 
	Numbx: 
	R: 8

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P9: 
	Numbers: 
	Numbx: 
	R: 9

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P10: 
	Numbers: 
	Numbx: 
	R: 10

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P11: 
	Numbers: 
	Numbx: 
	R: 11

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P12: 
	Numbers: 
	Numbx: 
	R: 12

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P13: 
	Numbers: 
	Numbx: 
	R: 13

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P14: 
	Numbers: 
	Numbx: 
	R: 14

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P15: 
	Numbers: 
	Numbx: 
	R: 15

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P16: 
	Numbers: 
	Numbx: 
	R: 16

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P17: 
	Numbers: 
	Numbx: 
	R: 17

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P18: 
	Numbers: 
	Numbx: 
	R: 18

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P19: 
	Numbers: 
	Numbx: 
	R: 19

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P20: 
	Numbers: 
	Numbx: 
	R: 20

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P21: 
	Numbers: 
	Numbx: 
	R: 21

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P22: 
	Numbers: 
	Numbx: 
	R: 22

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P23: 
	Numbers: 
	Numbx: 
	R: 23

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P24: 
	Numbers: 
	Numbx: 
	R: 24

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P25: 
	Numbers: 
	Numbx: 
	R: 25

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P26: 
	Numbers: 
	Numbx: 
	R: 26

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P27: 
	Numbers: 
	Numbx: 
	R: 27

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P28: 
	Numbers: 
	Numbx: 
	R: 28

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P29: 
	Numbers: 
	Numbx: 
	R: 29

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P30: 
	Numbers: 
	Numbx: 
	R: 30

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P31: 
	Numbers: 
	Numbx: 
	R: 31

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P32: 
	Numbers: 
	Numbx: 
	R: 32

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P33: 
	Numbers: 
	Numbx: 
	R: 33

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P34: 
	Numbers: 
	Numbx: 
	R: 34

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P35: 
	Numbers: 
	Numbx: 
	R: 35

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P36: 
	Numbers: 
	Numbx: 
	R: 36

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P37: 
	Numbers: 
	Numbx: 
	R: 37

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P38: 
	Numbers: 
	Numbx: 
	R: 38

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P39: 
	Numbers: 
	Numbx: 
	R: 39

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P40: 
	Numbers: 
	Numbx: 
	R: 40

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P41: 
	Numbers: 
	Numbx: 
	R: 41

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P42: 
	Numbers: 
	Numbx: 
	R: 42

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P43: 
	Numbers: 
	Numbx: 
	R: 43

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P44: 
	Numbers: 
	Numbx: 
	R: 44

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P45: 
	Numbers: 
	Numbx: 
	R: 45

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P46: 
	Numbers: 
	Numbx: 
	R: 46

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P47: 
	Numbers: 
	Numbx: 
	R: 47

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P48: 
	Numbers: 
	Numbx: 
	R: 48

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P49: 
	Numbers: 
	Numbx: 
	R: 49

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P50: 
	Numbers: 
	Numbx: 
	R: 50

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P51: 
	Numbers: 
	Numbx: 
	R: 51

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P52: 
	Numbers: 
	Numbx: 
	R: 52

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P53: 
	Numbers: 
	Numbx: 
	R: 53

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P54: 
	Numbers: 
	Numbx: 
	R: 54

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P55: 
	Numbers: 
	Numbx: 
	R: 55

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P56: 
	Numbers: 
	Numbx: 
	R: 56

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P57: 
	Numbers: 
	Numbx: 
	R: 57

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P58: 
	Numbers: 
	Numbx: 
	R: 58

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P59: 
	Numbers: 
	Numbx: 
	R: 59

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P60: 
	Numbers: 
	Numbx: 
	R: 60

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P61: 
	Numbers: 
	Numbx: 
	R: 61

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P62: 
	Numbers: 
	Numbx: 
	R: 62

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P63: 
	Numbers: 
	Numbx: 
	R: 63

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P64: 
	Numbers: 
	Numbx: 
	R: 64

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P65: 
	Numbers: 
	Numbx: 
	R: 65

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P66: 
	Numbers: 
	Numbx: 
	R: 66

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P67: 
	Numbers: 
	Numbx: 
	R: 67

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P68: 
	Numbers: 
	Numbx: 
	R: 68

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P69: 
	Numbers: 
	Numbx: 
	R: 69

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P70: 
	Numbers: 
	Numbx: 
	R: 70

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P71: 
	Numbers: 
	Numbx: 
	R: 71

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P72: 
	Numbers: 
	Numbx: 
	R: 72

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P73: 
	Numbers: 
	Numbx: 
	R: 73

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P74: 
	Numbers: 
	Numbx: 
	R: 74

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P75: 
	Numbers: 
	Numbx: 
	R: 75

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P76: 
	Numbers: 
	Numbx: 
	R: 76

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P77: 
	Numbers: 
	Numbx: 
	R: 77

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P78: 
	Numbers: 
	Numbx: 
	R: 78

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P79: 
	Numbers: 
	Numbx: 
	R: 79

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P80: 
	Numbers: 
	Numbx: 
	R: 80

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P81: 
	Numbers: 
	Numbx: 
	R: 81

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P82: 
	Numbers: 
	Numbx: 
	R: 82

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P83: 
	Numbers: 
	Numbx: 
	R: 83

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P84: 
	Numbers: 
	Numbx: 
	R: 84

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P85: 
	Numbers: 
	Numbx: 
	R: 85

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P86: 
	Numbers: 
	Numbx: 
	R: 86

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P87: 
	Numbers: 
	Numbx: 
	R: 87

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P88: 
	Numbers: 
	Numbx: 
	R: 88

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P89: 
	Numbers: 
	Numbx: 
	R: 89

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P90: 
	Numbers: 
	Numbx: 
	R: 90

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P91: 
	Numbers: 
	Numbx: 
	R: 91

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P92: 
	Numbers: 
	Numbx: 
	R: 92

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P93: 
	Numbers: 
	Numbx: 
	R: 93

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P94: 
	Numbers: 
	Numbx: 
	R: 94

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P95: 
	Numbers: 
	Numbx: 
	R: 95

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P96: 
	Numbers: 
	Numbx: 
	R: 96

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P97: 
	Numbers: 
	Numbx: 
	R: 97

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P98: 
	Numbers: 
	Numbx: 
	R: 98

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P99: 
	Numbers: 
	Numbx: 
	R: 99

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P100: 
	Numbers: 
	Numbx: 
	R: 100

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P101: 
	Numbers: 
	Numbx: 
	R: 101

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P102: 
	Numbers: 
	Numbx: 
	R: 102

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P103: 
	Numbers: 
	Numbx: 
	R: 103

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P104: 
	Numbers: 
	Numbx: 
	R: 104

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P105: 
	Numbers: 
	Numbx: 
	R: 105

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P106: 
	Numbers: 
	Numbx: 
	R: 106

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P107: 
	Numbers: 
	Numbx: 
	R: 107

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P108: 
	Numbers: 
	Numbx: 
	R: 108

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P109: 
	Numbers: 
	Numbx: 
	R: 109

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P110: 
	Numbers: 
	Numbx: 
	R: 110

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P111: 
	Numbers: 
	Numbx: 
	R: 111

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P112: 
	Numbers: 
	Numbx: 
	R: 112

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P113: 
	Numbers: 
	Numbx: 
	R: 113

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P114: 
	Numbers: 
	Numbx: 
	R: 114

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P115: 
	Numbers: 
	Numbx: 
	R: 115

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P116: 
	Numbers: 
	Numbx: 
	R: 116

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P117: 
	Numbers: 
	Numbx: 
	R: 117

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P118: 
	Numbers: 
	Numbx: 
	R: 118

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P119: 
	Numbers: 
	Numbx: 
	R: 119

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P120: 
	Numbers: 
	Numbx: 
	R: 120

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P121: 
	Numbers: 
	Numbx: 
	R: 121

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P122: 
	Numbers: 
	Numbx: 
	R: 122

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P123: 
	Numbers: 
	Numbx: 
	R: 123

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P124: 
	Numbers: 
	Numbx: 
	R: 124

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P125: 
	Numbers: 
	Numbx: 
	R: 125

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P126: 
	Numbers: 
	Numbx: 
	R: 126

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P127: 
	Numbers: 
	Numbx: 
	R: 127

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P128: 
	Numbers: 
	Numbx: 
	R: 128

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P129: 
	Numbers: 
	Numbx: 
	R: 129

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P130: 
	Numbers: 
	Numbx: 
	R: 130

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P131: 
	Numbers: 
	Numbx: 
	R: 131

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P132: 
	Numbers: 
	Numbx: 
	R: 132

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P133: 
	Numbers: 
	Numbx: 
	R: 133

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P134: 
	Numbers: 
	Numbx: 
	R: 134

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P135: 
	Numbers: 
	Numbx: 
	R: 135

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P136: 
	Numbers: 
	Numbx: 
	R: 136

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P137: 
	Numbers: 
	Numbx: 
	R: 137

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P138: 
	Numbers: 
	Numbx: 
	R: 138

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P139: 
	Numbers: 
	Numbx: 
	R: 139

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P140: 
	Numbers: 
	Numbx: 
	R: 140

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P141: 
	Numbers: 
	Numbx: 
	R: 141

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P142: 
	Numbers: 
	Numbx: 
	R: 142

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P143: 
	Numbers: 
	Numbx: 
	R: 143

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P144: 
	Numbers: 
	Numbx: 
	R: 144

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P145: 
	Numbers: 
	Numbx: 
	R: 145

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P146: 
	Numbers: 
	Numbx: 
	R: 146

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P147: 
	Numbers: 
	Numbx: 
	R: 147

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P148: 
	Numbers: 
	Numbx: 
	R: 148

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P149: 
	Numbers: 
	Numbx: 
	R: 149

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P150: 
	Numbers: 
	Numbx: 
	R: 150

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P151: 
	Numbers: 
	Numbx: 
	R: 151

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P152: 
	Numbers: 
	Numbx: 
	R: 152

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P153: 
	Numbers: 
	Numbx: 
	R: 153

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P154: 
	Numbers: 
	Numbx: 
	R: 154

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P155: 
	Numbers: 
	Numbx: 
	R: 155

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P156: 
	Numbers: 
	Numbx: 
	R: 156

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P157: 
	Numbers: 
	Numbx: 
	R: 157

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P158: 
	Numbers: 
	Numbx: 
	R: 158

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P159: 
	Numbers: 
	Numbx: 
	R: 159

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P160: 
	Numbers: 
	Numbx: 
	R: 160

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P161: 
	Numbers: 
	Numbx: 
	R: 161

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P162: 
	Numbers: 
	Numbx: 
	R: 162

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P163: 
	Numbers: 
	Numbx: 
	R: 163

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P164: 
	Numbers: 
	Numbx: 
	R: 164

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P165: 
	Numbers: 
	Numbx: 
	R: 165

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P166: 
	Numbers: 
	Numbx: 
	R: 166

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P167: 
	Numbers: 
	Numbx: 
	R: 167

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P168: 
	Numbers: 
	Numbx: 
	R: 168

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P169: 
	Numbers: 
	Numbx: 
	R: 169

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P170: 
	Numbers: 
	Numbx: 
	R: 170

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P171: 
	Numbers: 
	Numbx: 
	R: 171

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P172: 
	Numbers: 
	Numbx: 
	R: 172

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P173: 
	Numbers: 
	Numbx: 
	R: 173

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P174: 
	Numbers: 
	Numbx: 
	R: 174

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P175: 
	Numbers: 
	Numbx: 
	R: 175

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P176: 
	Numbers: 
	Numbx: 
	R: 176

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P177: 
	Numbers: 
	Numbx: 
	R: 177

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P178: 
	Numbers: 
	Numbx: 
	R: 178

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P179: 
	Numbers: 
	Numbx: 
	R: 179

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P180: 
	Numbers: 
	Numbx: 
	R: 180

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P181: 
	Numbers: 
	Numbx: 
	R: 181

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P182: 
	Numbers: 
	Numbx: 
	R: 182

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P183: 
	Numbers: 
	Numbx: 
	R: 183

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P184: 
	Numbers: 
	Numbx: 
	R: 184

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P185: 
	Numbers: 
	Numbx: 
	R: 185

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P186: 
	Numbers: 
	Numbx: 
	R: 186

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P187: 
	Numbers: 
	Numbx: 
	R: 187

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P188: 
	Numbers: 
	Numbx: 
	R: 188

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P189: 
	Numbers: 
	Numbx: 
	R: 189

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P190: 
	Numbers: 
	Numbx: 
	R: 190

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P191: 
	Numbers: 
	Numbx: 
	R: 191

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P192: 
	Numbers: 
	Numbx: 
	R: 192

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P193: 
	Numbers: 
	Numbx: 
	R: 193

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P194: 
	Numbers: 
	Numbx: 
	R: 194

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P195: 
	Numbers: 
	Numbx: 
	R: 195

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P196: 
	Numbers: 
	Numbx: 
	R: 196

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P197: 
	Numbers: 
	Numbx: 
	R: 197

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P198: 
	Numbers: 
	Numbx: 
	R: 198

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P199: 
	Numbers: 
	Numbx: 
	R: 199

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P200: 
	Numbers: 
	Numbx: 
	R: 200

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P201: 
	Numbers: 
	Numbx: 
	R: 201

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P202: 
	Numbers: 
	Numbx: 
	R: 202

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P203: 
	Numbers: 
	Numbx: 
	R: 203

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P204: 
	Numbers: 
	Numbx: 
	R: 204

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P205: 
	Numbers: 
	Numbx: 
	R: 205

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P206: 
	Numbers: 
	Numbx: 
	R: 206

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P207: 
	Numbers: 
	Numbx: 
	R: 207

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P208: 
	Numbers: 
	Numbx: 
	R: 208

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P209: 
	Numbers: 
	Numbx: 
	R: 209

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P210: 
	Numbers: 
	Numbx: 
	R: 210

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P211: 
	Numbers: 
	Numbx: 
	R: 211

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P212: 
	Numbers: 
	Numbx: 
	R: 212

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P213: 
	Numbers: 
	Numbx: 
	R: 213

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P214: 
	Numbers: 
	Numbx: 
	R: 214

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P215: 
	Numbers: 
	Numbx: 
	R: 215

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P216: 
	Numbers: 
	Numbx: 
	R: 216

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P217: 
	Numbers: 
	Numbx: 
	R: 217

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P218: 
	Numbers: 
	Numbx: 
	R: 218

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P219: 
	Numbers: 
	Numbx: 
	R: 219

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P220: 
	Numbers: 
	Numbx: 
	R: 220

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P221: 
	Numbers: 
	Numbx: 
	R: 221

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P222: 
	Numbers: 
	Numbx: 
	R: 222

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P223: 
	Numbers: 
	Numbx: 
	R: 223

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P224: 
	Numbers: 
	Numbx: 
	R: 224

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P225: 
	Numbers: 
	Numbx: 
	R: 225

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P226: 
	Numbers: 
	Numbx: 
	R: 226

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P227: 
	Numbers: 
	Numbx: 
	R: 227

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P228: 
	Numbers: 
	Numbx: 
	R: 228

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P229: 
	Numbers: 
	Numbx: 
	R: 229

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P230: 
	Numbers: 
	Numbx: 
	R: 230

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P231: 
	Numbers: 
	Numbx: 
	R: 231

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P232: 
	Numbers: 
	Numbx: 
	R: 232

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P233: 
	Numbers: 
	Numbx: 
	R: 233

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P234: 
	Numbers: 
	Numbx: 
	R: 234

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P235: 
	Numbers: 
	Numbx: 
	R: 235

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P236: 
	Numbers: 
	Numbx: 
	R: 236

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P237: 
	Numbers: 
	Numbx: 
	R: 237

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P238: 
	Numbers: 
	Numbx: 
	R: 238

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P239: 
	Numbers: 
	Numbx: 
	R: 239

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P240: 
	Numbers: 
	Numbx: 
	R: 240

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P241: 
	Numbers: 
	Numbx: 
	R: 241

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P242: 
	Numbers: 
	Numbx: 
	R: 242

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P243: 
	Numbers: 
	Numbx: 
	R: 243

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P244: 
	Numbers: 
	Numbx: 
	R: 244

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P245: 
	Numbers: 
	Numbx: 
	R: 245

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P246: 
	Numbers: 
	Numbx: 
	R: 246

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P247: 
	Numbers: 
	Numbx: 
	R: 247

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P248: 
	Numbers: 
	Numbx: 
	R: 248

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P249: 
	Numbers: 
	Numbx: 
	R: 249

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P250: 
	Numbers: 
	Numbx: 
	R: 250

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P251: 
	Numbers: 
	Numbx: 
	R: 251

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P252: 
	Numbers: 
	Numbx: 
	R: 252

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P253: 
	Numbers: 
	Numbx: 
	R: 253

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P254: 
	Numbers: 
	Numbx: 
	R: 254

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P255: 
	Numbers: 
	Numbx: 
	R: 255

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P256: 
	Numbers: 
	Numbx: 
	R: 256

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P257: 
	Numbers: 
	Numbx: 
	R: 257

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P258: 
	Numbers: 
	Numbx: 
	R: 258

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P259: 
	Numbers: 
	Numbx: 
	R: 259

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P260: 
	Numbers: 
	Numbx: 
	R: 260

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P261: 
	Numbers: 
	Numbx: 
	R: 261

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P262: 
	Numbers: 
	Numbx: 
	R: 262

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P263: 
	Numbers: 
	Numbx: 
	R: 263

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P264: 
	Numbers: 
	Numbx: 
	R: 264

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P265: 
	Numbers: 
	Numbx: 
	R: 265

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P266: 
	Numbers: 
	Numbx: 
	R: 266

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P267: 
	Numbers: 
	Numbx: 
	R: 267

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P268: 
	Numbers: 
	Numbx: 
	R: 268

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P269: 
	Numbers: 
	Numbx: 
	R: 269

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P270: 
	Numbers: 
	Numbx: 
	R: 270

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P271: 
	Numbers: 
	Numbx: 
	R: 271

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P272: 
	Numbers: 
	Numbx: 
	R: 272

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P273: 
	Numbers: 
	Numbx: 
	R: 273

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P274: 
	Numbers: 
	Numbx: 
	R: 274

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P275: 
	Numbers: 
	Numbx: 
	R: 275

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P276: 
	Numbers: 
	Numbx: 
	R: 276

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P277: 
	Numbers: 
	Numbx: 
	R: 277

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P278: 
	Numbers: 
	Numbx: 
	R: 278

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P279: 
	Numbers: 
	Numbx: 
	R: 279

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P280: 
	Numbers: 
	Numbx: 
	R: 280

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P281: 
	Numbers: 
	Numbx: 
	R: 281

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P282: 
	Numbers: 
	Numbx: 
	R: 282

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P283: 
	Numbers: 
	Numbx: 
	R: 283

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P284: 
	Numbers: 
	Numbx: 
	R: 284

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P285: 
	Numbers: 
	Numbx: 
	R: 285

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P286: 
	Numbers: 
	Numbx: 
	R: 286

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P287: 
	Numbers: 
	Numbx: 
	R: 287

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P288: 
	Numbers: 
	Numbx: 
	R: 288

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P289: 
	Numbers: 
	Numbx: 
	R: 289

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P290: 
	Numbers: 
	Numbx: 
	R: 290

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P291: 
	Numbers: 
	Numbx: 
	R: 291

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P292: 
	Numbers: 
	Numbx: 
	R: 292

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P293: 
	Numbers: 
	Numbx: 
	R: 293

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P294: 
	Numbers: 
	Numbx: 
	R: 294

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P295: 
	Numbers: 
	Numbx: 
	R: 295

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P296: 
	Numbers: 
	Numbx: 
	R: 296

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P297: 
	Numbers: 
	Numbx: 
	R: 297

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P298: 
	Numbers: 
	Numbx: 
	R: 298

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P299: 
	Numbers: 
	Numbx: 
	R: 299

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P300: 
	Numbers: 
	Numbx: 
	R: 300

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P301: 
	Numbers: 
	Numbx: 
	R: 301

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P302: 
	Numbers: 
	Numbx: 
	R: 302

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P303: 
	Numbers: 
	Numbx: 
	R: 303

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P304: 
	Numbers: 
	Numbx: 
	R: 304

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P305: 
	Numbers: 
	Numbx: 
	R: 305

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P306: 
	Numbers: 
	Numbx: 
	R: 306

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P307: 
	Numbers: 
	Numbx: 
	R: 307

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P308: 
	Numbers: 
	Numbx: 
	R: 308

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P309: 
	Numbers: 
	Numbx: 
	R: 309

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P310: 
	Numbers: 
	Numbx: 
	R: 310

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P311: 
	Numbers: 
	Numbx: 
	R: 311

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P312: 
	Numbers: 
	Numbx: 
	R: 312

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P313: 
	Numbers: 
	Numbx: 
	R: 313

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P314: 
	Numbers: 
	Numbx: 
	R: 314

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P315: 
	Numbers: 
	Numbx: 
	R: 315

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P316: 
	Numbers: 
	Numbx: 
	R: 316

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P317: 
	Numbers: 
	Numbx: 
	R: 317

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P318: 
	Numbers: 
	Numbx: 
	R: 318

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P319: 
	Numbers: 
	Numbx: 
	R: 319

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P320: 
	Numbers: 
	Numbx: 
	R: 320

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P321: 
	Numbers: 
	Numbx: 
	R: 321

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P322: 
	Numbers: 
	Numbx: 
	R: 322

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P323: 
	Numbers: 
	Numbx: 
	R: 323

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P324: 
	Numbers: 
	Numbx: 
	R: 324

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P325: 
	Numbers: 
	Numbx: 
	R: 325

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P326: 
	Numbers: 
	Numbx: 
	R: 326

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P327: 
	Numbers: 
	Numbx: 
	R: 327

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P328: 
	Numbers: 
	Numbx: 
	R: 328

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P329: 
	Numbers: 
	Numbx: 
	R: 329

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P330: 
	Numbers: 
	Numbx: 
	R: 330

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P331: 
	Numbers: 
	Numbx: 
	R: 331

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P332: 
	Numbers: 
	Numbx: 
	R: 332

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P333: 
	Numbers: 
	Numbx: 
	R: 333

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P334: 
	Numbers: 
	Numbx: 
	R: 334

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P335: 
	Numbers: 
	Numbx: 
	R: 335

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P336: 
	Numbers: 
	Numbx: 
	R: 336

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P337: 
	Numbers: 
	Numbx: 
	R: 337

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P338: 
	Numbers: 
	Numbx: 
	R: 338

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P339: 
	Numbers: 
	Numbx: 
	R: 339

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P340: 
	Numbers: 
	Numbx: 
	R: 340

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P341: 
	Numbers: 
	Numbx: 
	R: 341

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P342: 
	Numbers: 
	Numbx: 
	R: 342

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P343: 
	Numbers: 
	Numbx: 
	R: 343

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P344: 
	Numbers: 
	Numbx: 
	R: 344

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P345: 
	Numbers: 
	Numbx: 
	R: 345

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P346: 
	Numbers: 
	Numbx: 
	R: 346

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P347: 
	Numbers: 
	Numbx: 
	R: 347

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P348: 
	Numbers: 
	Numbx: 
	R: 348

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P349: 
	Numbers: 
	Numbx: 
	R: 349

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P350: 
	Numbers: 
	Numbx: 
	R: 350

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P351: 
	Numbers: 
	Numbx: 
	R: 351

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P352: 
	Numbers: 
	Numbx: 
	R: 352

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P353: 
	Numbers: 
	Numbx: 
	R: 353

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P354: 
	Numbers: 
	Numbx: 
	R: 354

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P355: 
	Numbers: 
	Numbx: 
	R: 355

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P356: 
	Numbers: 
	Numbx: 
	R: 356

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P357: 
	Numbers: 
	Numbx: 
	R: 357

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P358: 
	Numbers: 
	Numbx: 
	R: 358

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P359: 
	Numbers: 
	Numbx: 
	R: 359

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P360: 
	Numbers: 
	Numbx: 
	R: 360

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P361: 
	Numbers: 
	Numbx: 
	R: 361

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P362: 
	Numbers: 
	Numbx: 
	R: 362

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P363: 
	Numbers: 
	Numbx: 
	R: 363

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P364: 
	Numbers: 
	Numbx: 
	R: 364

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P365: 
	Numbers: 
	Numbx: 
	R: 365

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P366: 
	Numbers: 
	Numbx: 
	R: 366

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P367: 
	Numbers: 
	Numbx: 
	R: 367

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P368: 
	Numbers: 
	Numbx: 
	R: 368

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P369: 
	Numbers: 
	Numbx: 
	R: 369

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P370: 
	Numbers: 
	Numbx: 
	R: 370

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P371: 
	Numbers: 
	Numbx: 
	R: 371

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P372: 
	Numbers: 
	Numbx: 
	R: 372

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P373: 
	Numbers: 
	Numbx: 
	R: 373

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P374: 
	Numbers: 
	Numbx: 
	R: 374

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P375: 
	Numbers: 
	Numbx: 
	R: 375

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P376: 
	Numbers: 
	Numbx: 
	R: 376

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P377: 
	Numbers: 
	Numbx: 
	R: 377

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P378: 
	Numbers: 
	Numbx: 
	R: 378

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P379: 
	Numbers: 
	Numbx: 
	R: 379

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P380: 
	Numbers: 
	Numbx: 
	R: 380

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P381: 
	Numbers: 
	Numbx: 
	R: 381

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P382: 
	Numbers: 
	Numbx: 
	R: 382

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P383: 
	Numbers: 
	Numbx: 
	R: 383

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P384: 
	Numbers: 
	Numbx: 
	R: 384

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P385: 
	Numbers: 
	Numbx: 
	R: 385

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P386: 
	Numbers: 
	Numbx: 
	R: 386

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P387: 
	Numbers: 
	Numbx: 
	R: 387

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P388: 
	Numbers: 
	Numbx: 
	R: 388

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P389: 
	Numbers: 
	Numbx: 
	R: 389

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P390: 
	Numbers: 
	Numbx: 
	R: 390

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P391: 
	Numbers: 
	Numbx: 
	R: 391

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P392: 
	Numbers: 
	Numbx: 
	R: 392

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P393: 
	Numbers: 
	Numbx: 
	R: 393

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P394: 
	Numbers: 
	Numbx: 
	R: 394

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13


	P395: 
	Numbers: 
	Numbx: 
	R: 395

	PageText: 
	R: Page 

	ProductName: 
	L: Generative Drafting 

	Version: Version 5 Release 13




