
Parametric Technology Corporation  
Getting Started with Pro/TOOLKIT®

for Pro/ENGINEER® Wildfire® 5.0



Copyright © 2009 Parametric Technology Corporation and/or Its Subsidiary 
Companies. All Rights Reserved.
User and training guides and related documentation from Parametric Technology 
Corporation and its subsidiary companies (collectively "PTC") are subject to the copyright 
laws of the United States and other countries and are provided under a license agreement 
that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the 
licensed software user the right to make copies in printed form of this documentation if 
provided on software media, but only for internal/personal use and in accordance with 
the license agreement under which the applicable software is licensed. Any copy made 
shall include the PTC copyright notice and any other proprietary notice provided by PTC. 
Training materials may not be copied without the express written consent of PTC. This 
documentation may not be disclosed, transferred, modified, or reduced to any form, 
including electronic media, or transmitted or made publicly available by any means 
without the prior written consent of PTC and no authorization is granted to make copies 
for such purposes.

Information described herein is furnished for general information only, is subject to change 
without notice, and should not be construed as a warranty or commitment by PTC. PTC 
assumes no responsibility or liability for any errors or inaccuracies that may appear in this 
document.

The software described in this document is provided under written license agreement, 
contains valuable trade secrets and proprietary information, and is protected by the 
copyright laws of the United States and other countries. It may not be copied or distributed 
in any form or medium, disclosed to third parties, or used in any manner not provided for 
in the software licenses agreement except with written prior approval from PTC.

UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN 
CIVIL DAMAGES AND CRIMINAL PROSECUTION. PTC regards software piracy as the 
crime it is, and we view offenders accordingly. We do not tolerate the piracy of PTC 
software products, and we pursue (both civilly and criminally) those who do so using all 
legal means available, including public and private surveillance resources. As part of these 
efforts, PTC uses data monitoring and scouring technologies to obtain and transmit data 
on users of illegal copies of our software. This data collection is not performed on users of 
legally licensed software from PTC and its authorized distributors. If you are using an 
illegal copy of our software and do not consent to the collection and transmission of such 
data (including to the United States), cease using the illegal version, and contact PTC to 
obtain a legally licensed copy.

For Important Copyright, Trademark, Patent, Licensing and Data Collection Information: 
For Windchill products, select About Windchill at the bottom of the product page. For 
InterComm products, on the Help main page, click the link for Copyright 20xx. For other 
products, click Help > About on the main menu for the product.



UNITED STATES GOVERNMENT RESTRICTED RIGHTS LEGEND
This document and the software described herein are Commercial Computer 
Documentation and Software, pursuant to FAR 12.212(a)-(b) (OCT’95) or DFARS 
227.7202-1(a) and 227.7202-3(a) (JUN’95), and are provided to the US Government under a 
limited commercial license only. For procurements predating the above clauses, use, 
duplication, or disclosure by the Government is subject to the restrictions set forth in 
subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software Clause at 
DFARS 252.227-7013 (OCT’88) or Commercial Computer Software-Restricted Rights at 
FAR 52.227-19(c)(1)-(2) (JUN’87), as applicable. 01162009

Parametric Technology Corporation, 140 Kendrick Street, Needham, MA 02494 USA





Contents
Introduction 
Intended Audience vii
Scope and Purpose vii
Comments viii

Chapter 1  Pro/TOOLKIT Concepts 

What Can You Do with Pro/TOOLKIT? 1-2
Communication Modes for Pro/TOOLKIT 1-2

Chapter 2  Installing and Testing the Pro/TOOLKIT 
Development Environment 

Installing Pro/TOOLKIT 2-2
Setting Up the Development Environment 2-3

Platform and Compiler Support 2-3
Licensing for Pro/TOOLKIT 2-3

Testing the Pro/TOOLKIT Installation 2-4
Makefiles 2-4
Using the Microsoft Visual Studio Solution 2-4
Creating Your Own Microsoft Visual Studio Project 2-7

Chapter 3  Using the Pro/TOOLKIT Documentation 

Using the Pro/TOOLKIT APIWizard 3-2
Using the Selection Frame 3-2
Using the Display Frame 3-3
v



Viewing the PDF Version of the User's Guide 3-4
Using the Release Notes 3-4

Chapter 4  Using Extended Resources 

Locating Example Code 4-2
pt_userguide 4-2
pt_examples 4-2
pt_async 4-2
Other Sample Applications 4-3

Using the User's Guide 4-3
Contacting PTC Technical Support 4-4
Joining the PTC/USER Community 4-4

Index Index-1
vi Getting Started with Pro/TOOLKIT



Introduction
Getting Started with Pro/TOOLKIT introduces the techniques and practices 
of developing applications with Pro/TOOLKIT for Pro/ENGINEER 
Wildfire 5.0. Pro/TOOLKIT is supported on all platforms, but this guide 
deals only with Windows-specific information. This guide outlines the 
installation procedure for Pro/TOOLKIT and helps you locate the 
Pro/TOOLKIT functions and documentation. Familiarity with the basics 
of Pro/TOOLKIT will help you understand and create advanced 
applications.

Intended Audience
This guide is for programmers experienced with C/C++ programming 
prior to working with Pro/TOOLKIT. The experience of the programmer 
should include:

• Training in fundamentals of Pro/ENGINEER Wildfire 4.0 or later, or 
equivalent

• Good experience with using Pro/ENGINEER in the areas being 
customized

• C/C++ experience with knowledge of pointers, data structures, and 
dynamic memory management

• Use of Microsoft Visual Studio

In addition, you must have the Pro/TOOLKIT development license to 
develop, build, and test applications.

Scope and Purpose
This guide is not a complete summary of Pro/TOOLKIT techniques. It 
directs you through the process of building and testing a simple 
Pro/TOOLKIT application. It introduces the basic concepts of 
vii 



Pro/TOOLKIT to new users. It also provides pointers to resources that 
enhance your knowledge about Pro/TOOLKIT.

The guide focuses only on running a Pro/TOOLKIT DLL application in 
an interactive session of Pro/ENGINEER. It does not cover any other 
application configuration.

Comments
PTC welcomes your suggestions and comments on its documentation. 
You can send comments to the following e-mail address:

doc-webhelp@ptc.com

Please include the name of the application and its release number with 
your comments. For online books, provide the book title.
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Pro/TOOLKIT Concepts
Pro/TOOLKIT is the customization toolkit for Pro/ENGINEER. 
Customers and partners can expand the capabilities of Pro/ENGINEER 
by writing C or C++ programming language code using Pro/TOOLKIT 
and then seamlessly integrating the resulting application into 
Pro/ENGINEER. PTC provides new releases of Pro/TOOLKIT 
concurrently with releases of Pro/ENGINEER. 

Pro/TOOLKIT uses an object-oriented design. A library of C functions 
provides safe and controlled access to the Pro/ENGINEER database and 
applications. Many data structures for transfer of information between 
Pro/ENGINEER and the application are not directly visible to the 
application. Contents of these data structures are accessible only with 
Pro/TOOLKIT functions. The sections in this chapter describe the 
capabilities and modes of communication of Pro/TOOLKIT.
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What Can You Do with Pro/TOOLKIT?
With Pro/TOOLKIT you can: 

• Automate modeling for derived or single-use models driven by 
geometric or parametric constraints

• Monitor the state of the user's interactive session to enforce company 
rules or offer design advice

• Integrate external applications requiring access to Pro/ENGINEER 
data or operations

• Extend the Pro/ENGINEER user interface with custom processes 
seamlessly embedded into the interface

• Automate tedious or difficult Pro/ENGINEER operations with 
applications designed to save design time and prevent mistakes.

• Create processes to run automatically without a user interface on 
demand or at designated times.

Communication Modes for Pro/TOOLKIT
Pro/TOOLKIT supports synchronous applications that are invoked from 
commands within a session of Pro/ENGINEER. Modes of 
communication for synchronous applications may be:

• DLL mode—A dynamically-linked library (DLL) is loaded by the 
Pro/ENGINEER executable at runtime. Communication between the 
DLL and Pro/ENGINEER is as fast as possible and hence the DLL 
mode is the preferred mode for application development.

• Spawn (multiprocess) mode —A separate executable is spawned by 
Pro/ENGINEER. Spawn-mode applications interact with 
Pro/ENGINEER through interprocess communications and hence 
are slower than the DLL mode. This mode is typically used as a part 
of asynchronous mode applications, where the external application 
starts or connects to external sessions of Pro/ENGINEER as needed.

Another mode available is asynchronous mode applications, where the 
external application starts or connects to external sessions of 
Pro/ENGINEER as needed.
1-2 Getting Started with Pro/TOOLKIT
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Installing and Testing the

Pro/TOOLKIT Development
Environment
This chapter discusses the process to install Pro/TOOLKIT and to test the 
development environment. The test application and other sample code 
described in this guide assume the use of a Windows environment.
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Installing Pro/TOOLKIT
Pro/TOOLKIT is on the Pro/ENGINEER CD-ROM. When you install 
Pro/ENGINEER, select API Toolkits to install Pro/TOOLKIT.
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An installation of Pro/TOOLKIT contains directories under the 
Pro/ENGINEER load point.

Setting Up the Development Environment
Before you build your first Pro/TOOLKIT application, set up the 
supported compilers, sample make files, and the appropriate licensing for 
your application development environment.

Platform and Compiler Support
Pro/TOOLKIT runs on the same platforms as Pro/ENGINEER. The 
Platform Support notes at 
www.ptc.com/partners/hardware/current/support.htm describes the 
compilers supported by PTC.

Licensing for Pro/TOOLKIT
Pro/TOOLKIT requires a license for developing and testing applications. 
To check if you have the Pro/TOOLKIT license option, run the 
Ptcstatus utility from the Pro/ENGINEER load point. Check for the 
license option 14, or contact your system administrator.

When you first build an application using Pro/TOOLKIT, the application 
is considered "locked." The application requires the Pro/TOOLKIT 
development license when you test it in Pro/ENGINEER. Loading a 
locked application into a session of Pro/ENGINEER that lacks the 
Pro/TOOLKIT license causes an error as the application starts.

Before you distribute an executable for a Pro/TOOLKIT application to 
your end user, you must unlock it. Unlocking allows the end user to run 
the application without having the Pro/TOOLKIT license. The unlocking 
process is initiated with the following command:

<proe_loadpoint>/bin/protk_unlock <filename>

In the previous command, filename is the full path to the 
Pro/TOOLKIT application.

Directory Description

protoolkit Top-level directory

protoolkit/includes Include files

protoolkit/<machine_type>/obj Library files and sample makefiles

protoolkit/protk_appls Sample application source and message files
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Testing the Pro/TOOLKIT Installation
After you have installed Pro/TOOLKIT, compile, link, and run a simple 
Pro/TOOLKIT application on each computer for development use. This 
process provides an independent test of the following items:

• The installation of Pro/TOOLKIT is present, complete, and visible.

• The version of Pro/ENGINEER has the Pro/TOOLKIT license option 
added to it.

• All the necessary C development tools, especially the C compiler and 
linker, are present in versions supported by Pro/TOOLKIT.

Makefiles
PTC provides sample makefiles for each platform. These makefiles:

• Document the compiler and linker flags to be used for each platform

• Serve as templates for structuring your own application makefiles

Refer to these makefiles when creating a new application. Update the 
flags in your application makefiles when moving to a new release of 
Pro/ENGINEER.

Using the Microsoft Visual Studio Solution
PTC provides a ready-to-use Visual Studio solution on the Windows 
platform to build and test Pro/TOOLKIT applications by using an 
appropriate makefile. For the version of Visual Studio compatible with 
the release of Pro/TOOLKIT, refer to the hardware notes at 
http://www.ptc.com/partners/hardware/current/support.htm.

This ready-to-use Visual Studio solution has the following advantages:

• Provides an effective way to build and test sample applications 
provided by PTC.

• Provides a preconfigured Visual Studio development environment 
for use with Pro/TOOLKIT.

• Supports Intellisense for Pro/TOOLKIT functions.

Note
The supported version of Visual Studio changes with every release of 
Pro/TOOLKIT, and hence the compiler flags and libraries also 
change. For every release, you must download the latest version of 
the ready-to-use solution from the Pro/TOOLKIT load point.
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When you install Pro/TOOLKIT, the file protk_install_example.zip is 
installed under the Pro/TOOLKIT load point at 
protoolkit/<machine_type>/obj. To use this solution:

1. Unzip protk_install_example.zip. The following files and directories are 
available:

2. Set the environment variable PROE_INSTALL_PATH to point to the 
Pro/ENGINEER installation directory.

3. Open Microsoft Visual Studio. 

4. Click File > Open > Project/Solution. The Open Project dialog 
opens.

5. Browse the protk_install_example directory and select 
make_install.sln.

6. Click Open to access the solution file.

The make_install makefile project is available in Visual Studio.

Running the Makefile Project
1. Click Build > Build make_install. The application should build 

without errors. This creates the Pro/TOOLKIT DLL file called 
pt_inst_test.dll. If the application fails, check that the environment 
variable PROE_INSTALL_PATH is set correctly.

2. Modify the exec_file and text_dir fields in the protk.dat file located in 
the make_install directory to specify the full path to pt_inst_test.dll 
and “\text”, respectively. For example,

exec_file <full_path>\pt_inst_test.dll
text_dir <full_path>\text

3. Start Pro/ENGINEER and click Tools>Auxiliary 
Applications>Register to register the updated protk.dat file. The 
Register Auxiliary application dialog box opens.

4. Browse to the <full_path> and select protk.dat. The Pro/TOOLKIT 
application adds the command Install Test to the Pro/ENGINEER 
File menu.

Directory or File Description

make_install.sln Specifies the ready-to-use Visual Studio solution file.

make_install Contains the makefile project and the protk.dat file.
Installing and Testing the Pro/TOOLKIT Development Environment 2-5 



5. Click File > Install Test. The Pro/TOOLKIT Install Test Results 
message window opens, indicating that the installation test has 
succeeded.

6. Click OK.

To run other sample applications provided by PTC, follow these steps:

1. Copy the required makefile from 
<proe_loadpoint>\protoolkit\i486_nt\obj to the 
make_install directory of the ready-to-use Visual Studio solution. 

If you are working on a 64-bit Windows platform, copy the file from 
<proe_loadpoint>\protoolkit\x86e_win64\obj.

2. Copy the text directory associated with the sample application from 
<proe_loadpoint>\protoolkit to the make_install directory.

3. Open Visual Studio and set the values of the following variables in 
the the makefile:

PROTOOL_SRC = $(PROE_INSTALL_PATH)/protoolkit
PROTOOL_SYS = $(PROTOOL_SRC)/$(PRO_MACHINE_TYPE)
PRODEV_SRC = $(PROE_INSTALL_PATH)/prodevelop
PRODEV_SYS = $(PROTOOL_SRC)/$(PRO_MACHINE_TYPE)

4. Click Project > Properties to update the NMake properties of the 
project.

5. Click Build > Rebuild make_install. The application builds and 
creates a new .dll file.
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6. Update the protk.dat file located in the make_install directory with 
the name of the sample application and the DLL file.

7. Modify the exec_file and text_dir fields in the protk.dat file to specify 
the full path to the .dll file and “\text” directory, respectively.

8. Start Pro/ENGINEER and click Tools>Auxiliary 
Applications>Register to register the updated protk.dat file. The 
Register Auxiliary application dialog box opens.

9. Browse to the full path and select protk.dat. The Pro/TOOLKIT 
application runs.

Creating Your Own Microsoft Visual Studio Project
The Pro/TOOLKIT load point includes the source of a simple application 
called pt_install_test designed specifically to help you test the 
installation. The steps to build and run the test application follow.

1. Open Microsoft Visual Studio.

2. Create a project named ProTOOLKITInstall in an empty directory. 
Set this project to be a makefile project.
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3. Set the Debug Configuration Settings to run the Pro/ENGINEER 
makefile as shown in the following table and figure:

Setting Value

Command line nmake /f make_install dll

Output pt_inst_test.dll

Clean/rebuild all commands nmake /f make_install clean_dll

Include search path <proe_loadpoint>\protoolkit\includes
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4. Set the Release Configuration Settings to the same settings as the 
Debug Configuration Settings. Click Finish.

5. Copy the file make_install from 
<proe_loadpoint>\protoolkit\i486_nt\obj to your project 
directory, that is, the directory ProTOOLKITInstall that also 
contains ProTOOLKITInstall.vcproj. If you are working on a 
64-bit Windows platform, copy the file from 
<proe_loadpoint>\protoolkit\x86e_win64\obj.

6. Click Project > Add Existing Item to add the makefile to the project. 
In the Add Existing Item window, view all files and select the file 
make_install.

7. Edit the setting for PROTOOL_SRC (EXTERNAL USE - DEFAULT) in 
make_install to point to the Pro/TOOLKIT installation directory, that 
is, <proe_loadpoint>\protoolkit.
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Note
If the Pro/ENGINEER load point is in a directory containing spaces, 
use the DOS short names, for example:

c:/Progra~1/proeWi~1.0/protoolkit

8. Click Build > Rebuild Solution.

The application should build without errors. This creates the 
Pro/TOOLKIT DLL file called pt_inst_test.dll. If it fails, check that the 
path to the Pro/TOOLKIT installation directory is set correctly in the 
makefile in step 7.

9. In the install_test directory, create a text file called protk.dat. This 
registry file provides Pro/ENGINEER information about the 
Pro/TOOLKIT application. The protk.dat file should contain the 
following lines:

name install_test
startup dll
exec_file pt_inst_test.dll
text_dir <proe_loadpoint>/protoolkit/protk_appls/pt_install_test
end

10. Run Pro/ENGINEER from the directory that contains the protk.dat 
file. The Pro/TOOLKIT application adds the command Install Test to 
the Pro/ENGINEER File menu.

If you encounter an error, or if the Pro/TOOLKIT command does not 
appear in the Pro/ENGINEER File menu, verify if the 
Pro/ENGINEER version that you ran has the Pro/TOOLKIT license 
included.

11. Click File > Install Test. The Pro/TOOLKIT Install Test Results 
message window opens, indicating whether the installation test has 
succeeded.
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 3
Using the Pro/TOOLKIT

Documentation
The previous chapters assisted you with the setup of the Pro/TOOLKIT 
development environment. You will learn how to effectively use the 
documentation and extended resources in this chapter. PTC includes the 
following documentation with Pro/TOOLKIT:

• Pro/TOOLKIT APIWizard—An online document with cross-links 
between the user's guide, function descriptions, and sample 
applications.

• Pro/TOOLKIT User's Guide—A PDF version of the Pro/TOOLKIT 
User’s Guide.

• Pro/TOOLKIT Release Notes—A printable document that provides 
release-specific information for Pro/TOOLKIT.
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Using the Pro/TOOLKIT APIWizard
The Pro/TOOLKIT APIWizard is installed in the directory 
<proe_loadpoint>/protoolkit/protkdoc. Start the APIWizard by 
pointing your browser to the index.html file. The Pro/TOOLKIT 
APIWizard starts. With the APIWizard, you can browse documentation 
for objects, functions, and the Pro/TOOLKIT User’s Guide. The following 
sections describe how to display and use the APIWizard frames in your 
Web browser.

Using the Selection Frame
The selection frame on the left of the Pro/TOOLKIT APIWizard, controls 
what data appears in the display frame on the right. Specify the data to 
view by choosing Pro/TOOLKIT Categories, or Pro/TOOLKIT Objects, 
or Pro/TOOLKIT User's Guide menu items as shown below.

• Categories—Displays an alphabetical list of the Pro/TOOLKIT 
function categories. Pro/TOOLKIT objects and functions are 
displayed as subnodes of the categories.

• Objects—Displays an alphabetical list of the Pro/TOOLKIT objects. 
Pro/TOOLKIT functions are displayed as subnodes of the objects.

• User's Guide—Displays the Pro/TOOLKIT User's Guide table of 
contents in a tree structure. All chapters are displayed as subnodes of 
the guide.
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Use the Find button in the left selection frame to search for data from the 
Pro/TOOLKIT User's Guide or for API specifications from the header files.

Using the Display Frame
The display frame on the right of the Pro/TOOLKIT APIWizard is as 
shown below.
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It presents the following items:

• User's guide contents

• Object and object hierarchy descriptions

• Function descriptions

• Header files

• Code examples for functions

Viewing the PDF Version of the User's Guide
Pro/TOOLKIT User's Guide introduces you to Pro/TOOLKIT, the features 
it offers, and techniques and background knowledge required to use the 
Pro/TOOLKIT functions effectively. To view and print the PDF book, you 
must have Adobe Acrobat Reader installed. See 
www.adobe.com/supportservice/custsupport/download.html to 
download a free version of Acrobat Reader. The Pro/TOOLKIT User’s 
Guide is installed at <proe_loadpoint>/protoolkit/protkdoc. Open the 
file tkuse.pdf using Acrobat Reader.

Using the Release Notes
Pro/TOOLKIT Release Notes provides release-specific information for 
Pro/TOOLKIT. It describes new functions of Pro/TOOLKIT and also 
includes critical functions that require adjustment of existing code. It also 
lists the changes in Pro/ENGINEER that can affect behavior in 
Pro/TOOLKIT. The release notes is installed at 
<proe_loadpoint>/protoolkit. Use Acrobat Reader to open the file 
Protoolkit_Wildfire40_RelNotes.pdf.
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Using Extended Resources
This chapter provides the resources for support in working with 
Pro/TOOLKIT for the following areas:

• Example code provided

• Tips for optimum use of the Pro/TOOLKIT User's Guide 

• Technical Support

• PTC User Community

As you become more familiar with these resources, you'll find that they 
overlap in areas of expertise. A PTC online account is required to access 
PTC documentation from the Web. Register for an account at 
www.ptc.com/appserver/common/account/basic.jsp.
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Locating Example Code
PTC provides many sample applications with Pro/TOOLKIT in 
directories under the path protoolkit/protk_appls. This section 
describes some of the sample applications. You can refer to the 
APIWizard and the protoolkit/protk_appls directory for other 
sample applications.

pt_userguide

Consolidates examples that access the user interface. All these examples 
are also in the Pro/TOOLKIT User's Guide.

pt_examples

Consists of examples of Pro/TOOLKIT applications. It provides a user 
interface to access many areas of Pro/TOOLKIT. This application covers 
Pro/TOOLKIT functions and modules, including user interface functions 
based on ProMenubar and ProMenu. The directory pt_examples 
includes subdirectories containing utility functions.

pt_async

Provides an example application for simple and full asynchronous mode.

Location Makefile

protoolkit/protk_appls/pt_userguide make_userguide

Location Makefile

protoolkit/protk_appls/pt_examples make_examples

Location Makefile

protoolkit/protk_appls/pt_async make_async
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Other Sample Applications
The following table lists all the sample applications available with the 
Pro/TOOLKIT installation. Please refer to the Pro/TOOLKIT User’s Guide 
for more information.

Using the User's Guide
The Pro/TOOLKIT User's Guide is the primary resource to extend your 
knowledge of Pro/TOOLKIT. Tips on how to use the guide follow:

• Chapter 1 deals with fundamentals. Beginners should study it 
thoroughly.

• Next, complete chapters 4-21 grouped under the Core and User 
Interface functional areas. They contain basic information useful to 
almost all Pro/TOOLKIT users.

• After that, you can jump to any of chapters 22-64 that describes the 
functionality in the areas that you intend to customize.

Sample 
Application Location Makefile

pt_inst_cxx protoolkit/protk_appls/pt_install_cxx make_install_cxx

pt_inst_test_md protoolkit/protk_appls/pt_install_test make_install_md

pt_autoaxis protoolkit/protk_appls/pt_autoaxis make_autoaxis

pt_geardesign protoolkit/protk_appls/pt_geardesign make_geardesign

pt_async_md protoolkit/protk_appls/pt_async make_async_md

pt_async_mt protoolkit/protk_appls/pt_async make_async_mt

pt_async_pic protoolkit/protk_appls/pt_async_pic make_async_pic

pt_simple_async protoolkit/protk_appls/pt_simple_async make_simple_async

pt_basic protoolkit/protk_appls/pt_basic make_basic

pt_af_examples protoolkit/protk_appls/pt_af_examples make_af_examples

pt_udf_examples protoolkit/protk_appls/pt_udf_examples make_udf_examples

pt_mech_examples protoolkit/protk_appls/pt_mech_examples make_mech_examples
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Contacting PTC Technical Support
Technical support for Pro/ENGINEER and Pro/TOOLKIT is available 24 
hours a day, 7 days a week. You can contact Technical Support by phone, 
fax, e-mail, or FTP. You can easily access the most current technical 
support contact information from within Pro/ENGINEER by clicking the 
Support link on the Pro/ENGINEER homepage.

Joining the PTC/USER Community
PTC/USER Community provides education and communication services 
for users of PTC software. This nonprofit corporation offers an annual 
international conference and connects you to more experienced PTC 
software users, including Pro/TOOLKIT developers. Visit 
www.ptcuser.org for more details.
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