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Preface
The Wireframe and Surface workbench allows you to create wireframe construction 
elements during preliminary design and enrich existing 3D mechanical part design 
with wireframe and basic surface features. As a complement to Part Design,  this 
product meets the requirements of solids-based hybrid modeling.

The features-based approach offers a productive and intuitive design environment to 
capture and re-use design methodologies and specifications.

As a scalable product, Wireframe and Surface can be used in cooperation with 
companion products such as Part Design, Assembly Design and Generative Drafting. 
The widest application portfolio in the industry is also accessible through 
interoperability with CATIA Solutions Version 4 to enable support of the full product 
development process from initial concept to product in operation.

The Wireframe and Surface User's Guide has been designed to show you how to 
create and edit wireframe and surface features as well as hybrid parts. There are 
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often several ways to reach the final result. This guide aims at illustrating these 
various possibilities. 

Using This Guide
More Information
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The Wireframe and Surface workbench allows you to create wireframe construction elements 
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requirements of solids-based hybrid modeling.

The features-based approach offers a productive and intuitive design environment to capture 
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Using This Guide

Using This Guide
This guide is intended for the user who needs to become quickly familiar with the Wireframe 
and Surface product. The user should be familiar with basic Version 5 concepts such as 
document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-
step tutorial Getting Started. This tutorial will show you how to create a basic part. 

The next sections deal with the creation and modification of various types of wireframe and 
surface geometry you will need to construct parts. 

You may also want to take a look at the section describing the Wireframe and Surface 
workbench menus and toolbars. 
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More Information

Where to Find More Information
Prior to reading this guide, we recommend that you read the Infrastructure User's Guide.

The Part Design User's Guide and Assembly Design User's Guide may prove useful. 
Conventions 
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What's New?

What's New?
This table identifies what new or improved capabilities have been documented in Version 5 
Release 12 of the Wireframe and Surface workbench.

New Functionalities

Creating an Axis

Creating a Cylinder

Enhanced Functionalities

Creating Wireframe Geometry

Creating Points

Extremum points are now aggregated under the command that created them
New Projection option allowing to specify a surface on which the point is projected 
normally to the plane

Creating Circles
Possibility to compute the default plane when one of the inputs is a planar curve for 
the following types: Bi-tangent and radius, Bi-tangent and point, Tri-tangent, Center 
and tangent

Performing Operations on Shape Geometry

Joining Geometry

No propagation option: only the elements explicitly selected are part of the 
propagation

Splitting Elements

New Automatic extrapolation option allowing the automatic extrapolation of the 
cutting curve to be optional

Trimming Elements

New Automatic extrapolation option allowing the automatic extrapolation of the 
elements to trim to be optional

Creating Boundary Curves
Possibility to select a boundary type before selecting an edge

Extracting Geometry

Possibility to select the part to keep when the result of an extract is not connex
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What's New?

Translating Geometry

Two options (Creation or Modification) are now available to modify the translation 
behavior

Rotating Geometry

Two options (Creation or Modification) are now available to modify the rotation 
behavior

Performing a Symmetry on Geometry

Two options (Creation or Modification) are now available to modify the symmetry 
behavior

Transforming Geometry by Scaling

Two options (Creation or Modification) are now available to modify the scaling behavior

Transforming Geometry by Affinity

Two options (Creation or Modification) are now available to modify the affinity behavior

Transforming Elements From an Axis to Another

Two options (Creation or Modification) are now available to modify the axis behavior

Using Tools

Working With A Support

Possibility to retrieve the features created on a single or a multi-selection works on 
support
Features are now aggregated under the command that created them

Stacking Commands

Features are now aggregated under the command that created them

Editing Parameters

New commands are now concerned with the edition of parameters in the 3D geometry

Selecting Using Multi-Selection

Multi-selection is available when editing a single feature

Selecting Using Multi-Output

Multi-selection is available when editing a single feature
In case an update error occurs, a dialog box displays the features in error
New behavior for shared and unshared features aggregated under the parent 
command
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Getting Started

Getting Started
Before getting into the detailed instructions for using CATIA Version 5 Wireframe and 
Surface, the following tutorial aims at giving you a feel about what you can do with the 
product. It provides a step-by-step scenario showing you how to use key functionalities.

The main tasks described in this section are:

Entering the Workbench
Creating Wireframe Geometry

Creating a First Multi-section Surface
Creating Swept Surfaces

Creating the Second Multi-section Surface
Joining the Surfaces
Closing the Surfaces 

This tutorial should take about ten minutes to complete.
 

The final part will look like this:
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Entering the Workbench

Entering the Workbench
 
This first task shows you how to enter the Wireframe and Surface workbench and open a  
design part.

 Before starting this scenario, you should be familiar with the basic commands common to 
all workbenches. These are described in the Infrastructure User's Guide.

 1.  Select Mechanical Design -> Wireframe and Surface Design from the Start 
menu.

The Wireframe and Surface workbench is displayed.
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Entering the Workbench

2.  Select File -> Open then select the GettingStartedWireframeAndSurface.CATPart 
document.

The following  design part is displayed.

In the rest of this scenario, you will add to the existing elements of this part to complete 
the design.
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Creating Wireframe Geometry

Creating Wireframe Construction Elements

This task shows you how create wireframe construction elements using the vertices of 
solids.

1.  Click the Line icon .

The Line Definition dialog box appears.

2.  Create a line by selecting a vertex on Pad 1 
and the corresponding vertex on Pad 2. 
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Creating Wireframe Geometry

3.  Repeat this steps to create four lines as 
shown in the opposite figure.
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Creating First Loft

Creating a First Multi-section Surface

This task shows how to create a multi-section surface.

1.  Click the Multi-section surface 

icon .

The Multi-section Surface 
Definition dialog box 
appears. 

2.  Select the curved edge on each 
pad as sections for the multi-
section surface.
Arrows must point the same way 
on each side of the multi-section 
surface.
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Creating First Loft

3.  Click OK to create the multi-
section surface.
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Creating Swept Surfaces

Creating Two Swept Surfaces
 
This task shows how to create two swept surfaces between opposite edges of the two 
pads.

1.  Click the Sweep icon .

The Swept Surface 
Definition dialog box 
appears.
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Creating Swept Surfaces

2.  Select the vertical edge of Pad 
2 as profile.

3.  Select the bottom line as first 
guide curve.

4.  Click the Second Guide tab 
then select  the inclined line as 
second guide curve.

5.  Click OK to create the swept 
surface.

6.  Repeat these steps on the 
other side to create a second 
swept surface.

In the opposite figure the previously 
created lofted surface is hidden in 
order to illustrate the swept surfaces 
better.
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Creating Second Loft

Creating a Second Loft Surface

This task shows how to create the second lofted surface at the bottom of the part. 

In the illustrations below, the first loft and both sweeps have been hidden.

1.  Click the Loft icon .

The Lofted Surface 
Definition dialog box 
appears.

2.  Select the horizontal edges on the 
pads as sections for the loft.

Make sure arrows point the 
same way.
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Creating Second Loft

3.  Click OK to create the surface.

The specification tree is 
updated to show the 
created surfaces. 
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Joining the Surfaces

Joining Surfaces
 
This task shows how to join the lofted and swept surfaces.

1.  Click the Join icon  .

The Join Definition dialog box appears. 

2.  Select the two lofted surfaces and the two swept surfaces.

3.  Click OK to create the joined surface

The specification tree is updated to include the 
joined surface.
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Joining the Surfaces
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Closing the Surfaces

Closing the Surfaces

This task shows you how to create a solid by closing the joined surface.

For this you must call up the Part Design workbench.

 1.  Select Part Design from the Start -> Mechanical Design menu.

The Part Design workbench is displayed.

2.  Click the Close Surface icon .

This icon is available from the Split 
sub-toolbar:

Note that the Join element should be 
active in tree.

The CloseSurface Definition dialog 
box appears. 

3.  Click OK to create the closed surface 
feature.

The specification tree is updated.
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Basic Tasks

Basic Tasks
The basic tasks you will perform in the Wireframe and Surface workbench are mainly the 
creation of wireframe and surface geometry you will use to build your part design.

This section will explain and illustrate how to create and manage various kinds of wireframe 
and surface geometry. 

Creating Wireframe Geometry
Creating Surfaces

Performing Operations
Using Tools 

 When creating a geometric element, you often need to select other elements as 
inputs. When selecting a sketch as the input element, some restrictions apply, 
depending on the feature you are creating.  

You should avoid selecting self-intersecting  sketches as well as sketches containing 
heterogeneous elements such as a curve and a point for example. 

However, the following elements accept sketches containing non connex elements (i.e. 
presenting gaps between two consecutive elements) as inputs, provided they are of 
the same type (homogeneous, i.e. two curves, or two points):

●     Intersections

●     Projections

●     Extruded surfaces

●     Surfaces of revolution

●     Joined surfaces

●     Split surfaces

●     Trimmed surfaces

●     All transformations: translation, rotation, symmetry, scaling, affinity 
and axis to axis.
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Creating Wireframe Geometry

Creating Wireframe Geometry
Wireframe geometry is the geometry that helps you create features when needed. Creating 
this geometry is a simple operation you can perform at any time.

Two creation modes are available: either you create geometry with its history or not. 
Geometry with no history is called a datum. Please refer to Creating Datums for more 
information.

 
Create points by coordinates: enter X, Y, Z coordinates.

Create points on a curve: select a curve and possibly a reference point, and enter a 
length or ratio.
Create points on a plane: select a plane and possibly a reference point, then click the 
plane.
Create points on a surface: select a surface and possibly a reference point, an element 
to set the projection orientation, and a length.

Create points as a circle center: select a circle

Create points at tangents: select a curve and a line.

Create point between another two points: select two points

Create multiple points: select a curve or a point on a curve, and possibly a reference 
point, set the number of point instances, indicate the creation direction or indicate the 
spacing between points.

Create lines between two points: select two points

Create lines based on a point and a direction: select a point and a line, then specify 
the start and end points of the line.
Create lines at an angle or normal to a curve:  select a curve and its support, a point 
on the curve, then specify the angle value, the start and end points of the line.
Create lines tangent to a curve:  select a curve and a reference point, then specify the 
start and end points of the line.
Create lines normal to a surface: select a surface and a reference point, then specify 
the start and end points of the line.

Create bisecting lines: select two lines and a starting point, then choose a solution.

Create an axis: select a geometric element, a direction, then choose the axis type.

Create polylines: select at least two points, then define a radius for a blending curve is 
needed
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Creating Wireframe Geometry

Create an offset plane: select an existing plane, and enter an offset value.

Create a parallel plane through a point: select an existing plane and a point. The 
resulting plane is parallel to the reference plane and passes through the point.
Create a plane at an angle: select an existing plane and a rotation axis, then enter an 
angle value (90° for a plane normal to the reference plane).

Create a plane through three points: select any three points

Create a plane through two lines : select any two lines

Create a plane through a point and a line : select any point and line

Create a plane through a planar curve: select any planar curve

Create a plane normal to a curve: select any curve and a point

Create a plane tangent to a surface: select any surface and a point

Create a plane based on its equation: key in the values for the Ax + Bu + Cz = D 
equation 

Create a mean plane through several points: select any three, or more, points

Create n planes between two planes: select two planes, and specify the number of 
planes to be created
Create a circle based on a point and a radius: select a point as the circle center, a 
support plane or surface, and key in a radius value. For circular arcs, specify the start 
and end angles.
Create a circle from two points: select a point as the circle center, a passing point, and 
a support plane or surface. For circular arcs, specify the start and end angles.
Create a circle from two points and a radius: select the two passing points, a support 
plane or surface, and key in a radius value. For circular arcs, specify the arc based on 
the selected points.
Create a circle from three points: select three points. For circular arcs, specify the arc 
based on the selected points.
Create a circle tangent to two curves, at a point: select two curves, a passing point, a 
support plane or surface, and click where the circle should be created. For circular 
arcs, specify the arc based on the selected points.
Create a circle tangent to two curves, with a radius: select two curves, a support 
surface, key in a radius value, and click where the circle should be created. For circular 
arcs, specify the arc based on the selected points.

Create a circle tangent to three curves: select three curves.
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Creating Wireframe Geometry

Create splines: select two or more points, if needed a support surface, set tangency 
conditions and close the spline if needed.

Create a helix: select a starting and a direction, then specify the helix parameters.

Create corners: select a first reference element (curve or point), select a curve, a 
support plane or surface, and enter a radius value.  

Creating connect curves: select two sets of curve and point on the curve, set their 
continuity type and, if needed, tension value.
Create projections: select the element to be projected and its support, specify the 
projection direction, 

Create intersections: select the two elements to be intersected

 
[ Up ] [ Next ]
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Creating Points

Creating Points 
 This task shows the various methods for creating points: 

●     by coordinates

●     on a curve

●     on a plane

●     on a surface

●     at a circle center

●     tangent point on a curve

●     between

 
Open the Points3D-1.CATPart document.

 
1.  Click the Point icon  .

The Point Definition dialog box appears.

2.  Use the combo to choose the desired point type.

Coordinates 
●     Enter the X, Y, Z coordinates in 

the current axis-system.

●     Optionally, select a reference 
point.

The corresponding 
point is displayed.
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Creating Points

 When creating a point within a user-defined axis-system, note that the Coordinates 
in absolute axis-system check button is added to the dialog box, allowing you to be 
define, or simply find out, the point's coordinates within the document's default axis-
system.
If you create a point using the coordinates method and an axis system is already 
defined and set as current, the point's coordinates are defined according to current the 
axis system. As a consequence, the point's coordinates are not displayed in the 
specification tree.
The axis system must be different 
from the absolute axis.  

On curve 
●     Select a curve

●     Optionally, select a reference 
point.

If this point is not on 
the curve, it is 
projected onto the 
curve.
If no point is selected, 
the curve's extremity 
is used as reference.

 

●     Select an option point to 
determine whether the new 
point is to be created: 
❍     at a given distance along the 

curve from the reference point

❍     a given ratio between the 
reference point and the 
curve's extremity.
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Creating Points

●     Enter the distance or ratio value.
If a distance is specified, it can 
be: 
❍     a geodesic distance: the 

distance is measured along 
the curve

❍     an Euclidean distance: the 
distance is measured in 
relation to the reference point 
(absolute value).

The corresponding point is 
displayed.

You can also: 
●     click the Nearest extremity button to display the point at the nearest extremity of 

the curve.

●     click the Middle Point button to display the mid-point of the curve.

●     use the Reverse Direction button to display: 
❍     the point on the other side of the reference point (if a point was selected 

originally)

❍     the point from the other extremity  (if no point was selected originally).

●     click the Repeat object after OK if you wish to create equidistant points on the 
curve, using the currently created point as the reference, as described in Creating 
Multiple Points in the Wireframe and Surface User's Guide . 

You will also be able to 
create planes normal 
to the curve at these 
points, by checking 
the Create normal 
planes also button, 
and to create all 
instances in a new 
Open Body by 
checking the Create 
in a new open body 
button.
If the button is not 
checked the instances 
are created in the 
current Open Body.
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Creating Points

 
●     If the curve is infinite and no reference point is explicitly given, by default, the 

reference point is the projection of the model's origin

●     If the curve is a closed curve, either the system detects a vertex on the curve that 
can be used as a reference point, or it creates an extremum point, and highlights it 
(you can then select another one if you wish) or the system prompts you to 
manually select a reference point.

Extremum points created on a 
closed curve are now aggregated 
under their parent command and 
put in no show in the specification 
tree.

 

   

On plane 
●     Select a plane.

●     Optionally, select a point to 
define a reference for computing 
coordinates in the plane.

If no point is selected, 
the projection of the 
model's origin on the 
plane is taken as 
reference. 

 

 

●     Optionally, select a surface on 
which the point is projected 
normally to the plane.

If no surface is 
selected, the behavior 
is the same.
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Creating Points

Furthermore, the 
reference direction (H 
and V vectors) is 
computed as follows: 
With N the normal to 
the selected plane 
(reference plane), H 
results from the 
vectorial product of Z 
and N (H = Z^N). 
If the norm of H is 
strictly positive then V 
results from the 
vectorial product of N 
and H (V = N^H).
Otherwise, V = N^X 
and H = V^N.

Would the plane move, 
during an update for 
example, the reference 
direction would then 
be projected on the 
plane. 

●     Click in the plane to display a point.

On surface 
●     Select the surface where the 

point is to be created.
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Creating Points

●     Optionally, select a reference 
point. By default, the surface's 
middle point is taken as 
reference. 

●     You can select an element to 
take its orientation as reference 
direction or a plane to take its 
normal as reference direction.
You can also use the contextual 
menu to specify the X, Y, Z 
components of the reference 
direction.

●     Enter a distance along the 
reference direction to display a 
point.

 
      

Circle center 
●     Select a circle, circular arc, or 

ellipse.

A point is displayed at 
the center of the 
selected element. 

      

Tangent on curve 
●     Select a planar curve and a 

direction line.

A point is displayed at 
each tangent. 
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Creating Points

The Multi-Result 
Management dialog 
box is displayed 
because several points 
are generated. 

●     Click YES: you can then select a 
reference element, to which only 
the closest point is created.

●     Click NO: all the points are 
created.

Between
●     Select any two points.

●     Enter the ratio, that is the 
percentage of the distance from 
the first selected point, at which 
the new point is to be.
You can also click Middle Point 
button to create a point at the 
exact midpoint (ratio = 0.5).

     

●     Use the Reverse direction 
button to measure the ratio from 
the second selected point.

 
If the ratio value is greater than 1, the point is located on the virtual line beyond the 
selected points.

3.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.
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Creating Points
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Creating Multiple Points

Creating Multiple Points
 
This task shows how to create several points at a time.

 Open the MultiplePoints1.CATPart document.
Display the Points toolbar by clicking and holding the arrow from the Point icon.

1.  Click the Point & Planes 

Repetition icon  .

2.  Select a curve or a Point on curve.

The Multiple Points Creation 
dialog box appears.
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Creating Multiple Points

3.  Define the number or points to be 
created (instances field).
Here we chose 5 instances.

You can choose the side on 
which the points are to be 
created in relation to the 
initially selected point on a 
curve. Simply use the 
Reverse Direction button, 
or clicking on the arrow in 
the geometry.

If you check the With end 
points option, the last and 
first instances are the curve 
end points.

4.  Click OK to create the point 
instances, evenly spaced over the 
curve on the direction indicated 
by the arrow.

The points (identified as Point.xxx as for 
any other type of point) are added to 
the specification tree.
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Creating Multiple Points

 
●     If you selected a point on a curve, 

you can select a second point, thus 
defining the area of the curve where 
points should be created.
Simply click the Second point field 
in the Multiple Points Creation dialog 
box, then select the limiting point. 
If you selected the Point2 created 
above as the limiting point, while 
keeping the same values, you would 
obtain the following:

 If the selected point on 
curve already has a 
Reference point (as 
described in Creating Points 
- on curve), this reference 
point is automatically taken 
as the second point.
By default, the Second 
point is one of the 
endpoints of the curve. 

●     When you select a point on a curve, 
the Instances & spacing option is 
available from  the Parameters field.
In this case, points will be created in 
the given direction and taking into 
account the Spacing value.
For example, three instances spaced 
by 10mm.
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Creating Multiple Points

 
●     Check the Create normal planes 

also to automatically generate planes 
at the point instances.

●     Check the Create in a new open 
body if you want all object instances 
in a separate Open Body.
A new Open Body will be created 
automatically.

If the option is not checked the 
instances are created in the current 
Open Body.

 

 

 
[ Back ] [ Up ] [ Next ]
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Creating Lines

Creating Lines 
This task shows the various methods for creating lines: 

●     point to point

●     point and direction

●     angle or normal to curve

●     tangent to curve

●     normal to surface

●     bisecting

 Open the Lines1.CATPart document.

1.  Click the Line icon  .

The Line Definition dialog box appears.

2.  Use the combo to choose the desired line type.

 
A line type will be proposed automatically in some cases depending on your first 
element selection.

Point - Point 
 
This command is only available with the 
Generative Shape Design 2 product.

●     Select two points.
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Creating Lines

A line is displayed between 
the two points.
Proposed Start and End 
points of the new line are 
shown.

●     If needed, select a support surface.
In this case a geodesic line is 
created, i.e. going from one point to 
the other according to the shortest 
distance along the surface geometry 
(blue line in the illustration below).
If no surface is selected, the line is 
created between the two points 
based on the shortest distance.

If you select two points on closed 
surface (a cylinder for example), the 
result may be unstable. Therefore, it is 
advised to split the surface and only 
keep the part on which the geodesic 
line will lie. 

 
The geodesic line is not available with the Wireframe and Surface workbench.
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Creating Lines

 ●     Specify the Start and End points of the new line, that is the line endpoint location 
in relation to the points initially selected. These Start and End points are 
necessarily beyond the selected points, meaning the line cannot be shorter than the 
distance between the initial points.

●     Check the Mirrored extent option to create a line symmetrically in relation to the 
selected Start and End points.

 The projections of the 3D point(s) must already exist on the selected support. 

Point - Direction 
 
●     Select a reference Point and a 

Direction line.
A vector parallel to the direction line 
is displayed at the reference point. 
Proposed Start and End points of 
the new line are shown.
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Creating Lines

●     Specify the Start and End points of 
the new line.
The corresponding line is displayed.

 The projections of the 3D point(s) must already exist on the selected support. 

  
Angle or normal to curve
 
●     Select a reference Curve and a 

Support surface containing that 
curve.
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Creating Lines

- If the selected curve is 
planar, then the Support 
is set to Default (Plane).

- If an explicit Support 
has been defined, a 
contextual menu is 
available to clear the 
selection.

 ●     Select a Point on the curve.

●     Enter an Angle value.

A line is displayed at the 
given angle with respect to 
the tangent to the 
reference curve at the 
selected point. These 
elements are displayed in 
the plane tangent to the 
surface at the selected 
point. 
You can click on the 
Normal to Curve button 
to specify an angle of 90 
degrees. 
Proposed Start and End 
points of the line are 
shown. 

●     Specify the Start and End points of the new line.
The corresponding line is displayed.
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Creating Lines

●     Click the Repeat object after OK if 
you wish to create more lines with 
the same definition as the currently 
created line. 
In this case, the Object Repetition 
dialog box is displayed, and you key 
in the number of instances to be 
created before pressing OK.

As many lines as indicated in the dialog 
box are created, each separated from 
the initial line by a multiple of the 
angle value.

 

You can select the Geometry on Support check box if you want to create a geodesic 
line onto a support surface. 
The figure below illustrates this case.

 

Geometry on support option not 
checked

Geometry on support option checked
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Creating Lines

 
This line type enables to edit the line's parameters. Refer to Editing Parameters to find 
out how to display these parameters in the 3D geometry.

Tangent to curve
 
●     Select a reference Curve and a 

point or another Curve to define the 
tangency. 
❍     if a point is selected (mono-

tangent mode): a vector tangent 
to the curve is displayed at 
the selected point.

❍     If a second curve is selected (or a 
point in bi-tangent mode), you 
need to select a support plane. 
The line will be tangent to both 
curves.

 - If the selected curve is a 
line, then the Support is 
set to Default (Plane).

- If an explicit Support 
has been defined, a 
contextual menu is 
available to clear the 
selection.

 When several solutions are 
possible, you can choose 
one (displayed in red) 
directly in the geometry, or 
using the Next Solution 
button.
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Creating Lines

Line tangent to curve at a given point Line tangent to two curves

●     Specify Start and End points to define the new line.
The corresponding line is displayed.

 

Normal to surface 
 
●     Select a reference Surface and a 

Point.
A vector normal to the surface is 
displayed at the reference point. 
Proposed Start and End points of 
the new line are shown.
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Creating Lines

●     Specify Start and End points to 
define the new line.
The corresponding line is displayed.

Bisecting 
 
●     Select two lines. Their bisecting line 

is the line splitting in two equals 
parts the angle between these two 
lines. 

●     Select a point as the starting point 
for the line. By default it is the 
intersection of the bisecting line and 
the first selected line.
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Creating Lines

 

●     Select the support surface onto 
which the bisecting line is to be 
projected, if needed.

●     Specify the line's length in relation to 
its starting point (Start and End 
values for each side of the line in 
relation to the default end points).
The corresponding bisecting line, is 
displayed.

●     You can choose between two 
solutions, using the Next Solution 
button, or directly clicking the 
numbered arrows in the geometry.

3.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.
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Creating Lines

●     Regardless of the line type, Start and End values are specified by entering 
distance values or by using the graphic manipulators.

●     Start and End values should not be the same.

 ●     Select the Length Type: 
❍     Length: the line will be defined according to the Start and End points values

❍     Infinite: the line will be infinite

❍     Infinite Start Point: the line will be infinite from the Start point

❍     Infinite End Point: the line will be infinite from the End point

By default, the Length type is selected.
The Start and/or the End points values will be greyed when one of the Infinite 
options is chosen.

●     Check the Mirrored extent option to create a line symmetrically in relation to the 
selected Start point.

●     In most cases, you can select a support on which the line is to be created. In this 
case, the selected point(s) is projected onto this support.

●     You can reverse the direction of the line by either clicking the displayed vector or 
selecting the Reverse Direction button (not available with the point-point line 
type).
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Creating an Axis

 Creating an Axis

This task shows you how to create an axis feature.

 Open the Axis1.CATPart document.

1.  Click the Axis icon  .

The Axis Definition dialog box appears.

2.  Select an Element where to create the axis.

 

This element can be:
●     a circle or a portion of circle

●     an ellipse or a portion of ellipse

●     an oblong curve

●     a revolution surface or a portion of revolution surface

Circle
 

●     Select the direction (here we chose the yz plane), when 
not normal to the surface.

●     Select the axis type:
❍     Aligned with reference direction

❍     Normal to reference direction

❍     Normal to circle

      
 

 Aligned with reference directionNormal to reference direction Normal to circle
 

Ellipse
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Creating an Axis

 
●     Select the axis type:

❍     Major axis

❍     Minor axis

❍     Normal to ellipse

       
 

 Major axis Minor axis           Normal to ellipse
 

Oblong Curve
 

 
●     Select the axis type:

❍     Major axis

❍     Minor axis

❍     Normal to oblong

      
 

 Major axis Minor axis           Normal to oblong
 

Revolution Surface
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Creating an Axis

 

The revolution surface's axis is 
used, therefore the axis type 
combo list is disabled.

The axis can be displayed in the 3D geometry, either infinite or limited to the geometry block of the 
input element. This option is to be parameterized in Tools -> Options -> Shape -> Generative 
Shape Design -> General.
To have further information, please refer to the General Settings chapter in the Customizing section.

 
3.  Click OK to create the axis.

The element (identified as Axis.xxx) is added to the specification tree.
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Creating Polylines
 This task shows how to create a polyline, that is a broken line made of several 
connected segments.
These  linear segments may be connected by blending radii.
Polylines may be useful to create cylindrical shapes such as pipes, for example.

 
Open the Spline1.CATPart document.

 
1.  Click the Polyline icon .

The Polyline Definition 
dialog box appears.

2.  Select several points in a 
row.
Here we selected Point.1, 
Point.5, Point.3 and Point.2 
in this order.

The resulting polyline 
would look like this: 
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3.  From the dialog box, select 
Point.5, click the Add After 
button and select Point.6.

4.  Select Point.3 and click the 
Remove button.

The resulting polyline 
now looks like this: 

5.  Still from the dialog box select Point.5, click the Replace button, and select 
Point.4 in the geometry.

The added point automatically becomes the current point in the dialog 
box. 

6.  Click OK in the dialog box to 
create the polyline.

The element (identified as Polyline.
xxx) is added to the specification 
tree.

●     The polyline's orientation depends on the selection order of the points.

●     You can re-order selected points using the Replace, Remove, Add, Add After, and 
Add Before buttons.

●     You cannot select twice the 
same point to create a polyline. 
However, you can check the 
Close polyline button to 
generate a closed contour.
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Creating Planes

 
This task shows the various methods for creating planes:

 

●     offset from a plane

●     parallel through point

●     angle/normal to a 
plane

●     through three points

●     through two lines

●     through a point and 
a line

●     through a planar 
curve

●     normal to a curve

●     tangent to a surface

●     from its equation

●     mean through points

 

 Open the Planes1.CATPart document.

 
1.  Click the Plane icon  .

The Plane Definition dialog box appears.

2.  Use the combo to choose the desired Plane type.

 
Once you have defined the plane, it is represented by a red square symbol, which you 
can move using the graphic manipulator.

Offset from plane

●     Select a reference Plane then 
enter an Offset value.

A plane is displayed offset from the 
reference plane.
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Use the Reverse Direction button 
to  reverse the change the offset 
direction, or simply click on the 
arrow in the geometry.

      
●     Click the Repeat object after OK if you 

wish to create more offset planes . 
In this case, the Object Repetition dialog 
box is displayed, and you key in the number 
of instances to be created before pressing 
OK.

As many planes as indicated in the 
dialog box are created (including 
the one you were currently 
creating), each separated from the 
initial plane by a multiple of the 
Offset value. 

 

Parallel through point 

●     Select a reference Plane and a 
Point.

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugplane3D.htm (2 of 11)10/21/2004 4:53:41 AM



Creating Planes

A plane is displayed parallel to the 
reference plane and passing 
through the selected point.

Angle or normal to plane 

●     Select a reference Plane and a 
Rotation axis.
This axis can be any line or an 
implicit element, such as a 
cylinder axis for example. To 
select the latter press and hold 
the Shift key while moving the 
pointer over the element, then 
click it.

●     Enter an Angle value.
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A plane is displayed passing 
through the rotation axis. It is 
oriented at the specified angle to 
the reference plane. 

●     Click the Repeat object after OK if you wish to create more planes at an angle 
from the initial plane. 
In this case, the Object Repetition dialog box is displayed, and you key in the 
number of instances to be created before pressing OK.

As many planes as indicated in the 
dialog box are created (including 
the one you were currently 
creating), each separated from the 
initial plane by a multiple of the 
Angle value.

Here we created five planes at an 
angle of 20 degrees.

 This plane type enables to edit the plane's parameters. Refer to Editing Parameters to 
find out how to display these parameters in the 3D geometry.

Through three points 

●     Select three points.
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The plane passing through the 
three points is displayed. You can 
move it simply by dragging it to 
the desired location.

Through two lines 

●     Select two lines.

The plane passing through the two 
line directions is displayed.
When these two lines are not 
coplanar, the vector of the second 
line is moved to the first line 
location to define the plane's 
second direction. 
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Check the Forbid non coplanar lines button to specify that both lines be in the 
same plane.

Through point and line 

●     Select a Point and a Line.

The plane passing through the 
point and the line is displayed. 
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Through planar curve 

●     Select a planar Curve.

The plane containing the curve is 
displayed.

Tangent to surface 

●     Select a reference Surface and 
a Point.
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A plane is displayed tangent to the 
surface at the specified point.

Normal to curve 

●     Select a reference Curve.

●     You can select a Point. By 
default, the curve's middle point 
is selecte.
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A plane is displayed normal to the 
curve at the specified point. 

Mean through points 

●     Select three or more points to 
display the mean plane through 
these points.

It is possible to edit the plane by 
first selecting a point in the dialog 
box list then choosing an option to 
either:
●     Remove the selected point

●     Replace the selected point by 
another point.
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Equation 

●     Enter the A, B, C, D 
components of the Ax + By + 
Cz = D plane equation.

 

Select a point to position the plane 
through this point, you are able to 
modify A, B, and C components, 
the D component becomes grayed.

 

Use the Normal to compass 
button to position the plane 
perpendicular to the compass 
direction.

Use the Parallel to screen button 
to parallel to the screen current 
view.
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3.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.
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Creating Planes Between Other Planes
 
This task shows how to create any number of planes between two existing planes, in 
only one operation:

 Open the Planes1.CATPart document.

 
1.  Click the Planes Repetition icon  .

The Planes Between dialog box appears.

2.  Select the two planes between which the new 
planes must be created.

3.  Specify the number of planes to be created between the two selected planes.

4.  Click OK to create the planes.

The planes (identified as Plane.xxx) are added to the 
specification tree.

 
Check the Create in a new Open Body button to create a new Open Body containing 
only the repeated planes.
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Creating Circles
 This task shows the various methods for creating circles and circular arcs: 

●     center and radius

●     center and point

●     two points and radius

●     three points

●     bitangent and radius

●     bitangent and point

●     tritangent

●     center and tangent

 Open the Circles1.CATPart document.

 
1.  Click the Circle icon .

The Circle Definition dialog box 
appears. 

2.  Use the combo to choose the desired 
circle type.

Center and radius 
 
●     Select a point as circle Center.

●     Select the Support plane or surface where 
the circle is to be created.

●     Enter a Radius value.

Depending on the active Circle Limitations 
icon, the corresponding circle or circular arc is 
displayed.
For a circular arc, you can specify the Start 
and End angles of the arc.

 
If a support surface is selected, the circle lies on the plane tangent to the surface at the selected point.
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Start and End angles can be specified by entering values or by using the graphic manipulators.
     

Center and point 
 
●     Select a point as Circle center.

●     Select a Point where the circle is to be 
created.

●     Select the Support plane or surface where 
the circle is to be created.

The circle, which center is the first selected 
point and passing through the second point or 
the projection of this second point on the 
plane tangent to the surface at the first point, 
is previewed. 

Depending on the active Circle Limitations 
icon, the corresponding circle or circular arc is 
displayed.
For a circular arc, you can specify the Start 
and End angles of the arc.

      

Two points and radius 
 
●     Select two points on a surface or in the 

same plane.

●     Select the Support plane or surface.

●     Enter a Radius value.

The circle, passing through the first selected 
point and the second point or the projection of 
this second point on the plane tangent to the 
surface at the first point, is previewed. 

Depending on the active Circle Limitations 
icon, the corresponding circle or circular arc is 
displayed. 
For a circular arc, you can specify the trimmed 
or complementary arc using the two selected 
points as end points. 

You can use the Second Solution button, to 
display the alternative arc.
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Three points 
 
●     Select three points where the circle is to be 

created.

Depending on the active Circle Limitations 
icon, the corresponding circle or circular arc is 
displayed. 
For a circular arc, you can specify the trimmed 
or complementary arc using the two of the 
selected points as end points.

 
3.  In each of the methods above, you can select the Geometry on Support check box if you want 

the circle to be projected onto a support surface.

In this case just select a support surface. 

 
    

Bi-tangent and radius 
 
●     Select two Elements (point or curve) to which the circle is to be tangent.

●     Select a Support surface.

If one of the selected inputs is a planar curve, then the Support is set to Default (Plane).
If an explicit Support needs to be defined, a contextual menu is available to clear the selection in order 
to select the desired support.

This automatic support definition saves you from performing useless selections.

 ●     Enter a Radius value.

●     Several solutions may be possible, so click in the region where you want the circle to be.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is 
displayed. 
For a circular arc, you can specify the trimmed or complementary arc using the two tangent 
points as end points. 

    

Bi-tangent and point 
 
●     Select a point or a curve to which the circle is to be tangent.

●     Select a Curve and a Point on this curve.

●     Select a Support plane or planar surface.

The point will be projected onto the curve.

If one of the selected inputs is a planar curve, then the Support is set to Default (Plane).
If an explicit Support needs to be defined, a contextual menu is available to clear the selection in order 
to select the desired support.

This automatic support definition saves you from performing useless selections.
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Creating Circles

 

●     Several solutions may be possible, so click in the region where you want the circle to be.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is 
displayed. 

Complete circle
For a circular arc, you can choose the trimmed or complementary arc using the two tangent points as end 
points.

Trimmed circle Complementary trimmed circle
     

Tri-tangent 
 
●     Select three Elements to which the circle is 

to be tangent.

●     Select a Support planar surface.

If one of the selected inputs is a planar curve, 
then the Support is set to Default (Plane).
If an explicit Support needs to be defined, a 
contextual menu is available to clear the 
selection in order to select the desired support.
This automatic support definition saves you 
from performing useless selections.
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 ●     Several solutions may be possible, so select 
the arc of circle that you wish to create.

Depending on the active Circle Limitations 
icon, the corresponding circle or circular arc is 
displayed. The first and third elements define 
where the relimitation ends. 
For a circular arc, you can specify the trimmed 
or complementary arc using the two tangent 
points as end points.

     
 Center and tangent

There are two ways to create a center and 
tangent circle:

 

 

1.  Center curve and radius

●     Select a curve as the Center Element.

●     Select a Tangent Curve.

●     Enter a Radius value.

 

2.  Line tangent to curve definition

●     Select a point as the Center Element.

●     Select a Tangent Curve.

If one of the selected inputs is a planar curve, then the Support is set to Default (Plane).
If an explicit Support needs to be defined, a contextual menu is available to clear the selection in order 
to select the desired support.

This automatic support definition saves you from performing useless selections.

The circle center will be located either on the center curve or point and will be tangent to tangent curve.

Please note that only full circles can be created.
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4.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.
When several solutions are possible, click the Next Solution button to move to another arc of circle, or 
directly select the arc you want in the 3D geometry.

 
Parameters can be edited in the 3D geometry. To have further information, please refer to the Editing 
Parameters chapter.
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Creating Splines
 
This task shows the various methods for creating spline curves.

 Open the Spline1.CATPart document.

 
1.  Click the Spline icon  . 

The Spline Definition dialog box appears. 

2.  Select two or more points where the spline is to pass.

An updated spline is visualized each time a point is 
selected. 

 

3.  It is possible to edit the spline by first selecting a point in the dialog box list then choosing a button to either: 

●     Add a point after the selected point

●     Add a point before the selected point

●     Remove the selected point

●     Replace the selected point by another point.

4.  You can select  the Geometry on support check box, and 
select a support (plane, surface),  if you want the spline to be 
projected onto a support surface.

It is better when the tangent directions belong to the 
support, that is when a projection is possible.

In this case just select a surface or plane. 

In the  figure above,  the spline was created
on a planar support grid. 
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5.  Click on the Add Parameter button to display further options. 

6.  To set tangency conditions onto any point of the spline, select 
the point and click on Tangent Dir. 

There are two ways of imposing tangency and curvature constraints:

1.  Explicit: select a line or plane to which the tangent on the 
spline is parallel at the selected point

2.  From curve: select a curve to which the spline is tangent at the 
selected point.

Use the Remove Tgt., Reverse Tgt., or Remove Cur. to manage the different imposed tangency and curvature constraints.
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Spline with a tangency constraint on endpoint (tension = 2) Spline with reversed tangent

7.  To specify a curvature constraint at any point of the spline, once a tangency constraint has been set, indicate a 
curvature direction and enter a radius value:

The curvature direction is projected onto a plane normal to the tangent direction.
If you use the Create line contextual menu, and want to select the same point as a point already used to define the tangent 
direction, you may have to select it from the specification tree, or use the pre-selection navigator.

Spline with tangency constraint Spline with tangency constraint 
and curvature constraint

 (radius = 50mm)

Spline with tangency constraint and curvature 
constraint 

(radius = 2mm)

Note that for the Points Specifications, you must enter your information in the following order:
●     Tangent Dir. (tangent direction)

●     Tangent Tension

●     Curvature Dir. (curvature direction)

●     Curvature Radius (to select it, just click in the field).

The fields become active as you select values.

8.  Click OK to create the spline. 

The spline (identified as Spline.xxx) is added to the specification tree.
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●     To add a parameter to a point, select a line in the Points list. This list is highlighted.
You have two possibilities:

1.  extended parameters
2.  select any line or plane for the direction.

 ●     Use the Close Spline option to create a closed curve, provided the geometric configuration allows it

Spline with Close Spline option unchecked Spline with Close Spline option checked

 

 
[ Back ] [ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/wfsugbt0102.htm (4 of 4)10/21/2004 5:02:32 AM



Creating a Helix

Creating a Helix
 
This task shows the various methods for creating helical 3D curves, such as coils and 
springs for example.

 
Open the Helix1.CATPart document.

1.  Click the Helix icon 

.

The Helix 
Curve 
Definition 
dialog box 
appears.

2.  Select a starting point and an axis.

3.  Set the helix parameters:
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●     Pitch: the distance 
between two revolutions 
of the curve

You can define 
the evolution 
of the pitch 
along the helix 
using a law.

1.  Click the Law button 
to display the Law 
Definition dialog box.

2.  Choose type of law to 
be applied to the 
pitch: It can stay 
Constant, or evolve 
according to a S 
type law.

For the S type 
pitch, you 
need to define 
a second pitch 
value. The 
pitch distance 
will vary 
between these 
two pitch 
values, over 
the specified 
number of 
revolutions.
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3.  The Law Viewer 
allows you to:
- visualize the law 
evolution and the 
maximum and 
minimum values,
- navigate into the 
viewer by panning 
and zooming (using 
to the mouse),
- trace the law 
coordinates by using 
the manipulator,
- change the viewer 
size by changing the 
panel size
- reframe on by 
using the viewer 
contextual menu
- change the law 
evaluation step by 
using the viewer 
contextual menu 
(from 0.1 (10 
evaluations) to 0.001 
(1000 evaluations)).

4.  Click OK to return to 
the Helix Curve 
Definition dialog box.

 

 ●     Height: the global height of the helical curve, in the case of a constant pitch type helix

●     Orientation: defines the rotation direction (clockwise or counter clockwise)

●     Starting Angle: defines where the helical curve starts, in relation to the starting point.
This parameter can be set only for the Constant pitch only.

●     Taper Angle: the radius variation from one revolution to the other. It ranges from -
90° to 90° excluded. 
For a constant radius, set the taper angle to 0.

●     Way: defines the taper angle orientation.
Inward: the radius decreases
Outward: the radius increases.
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●     Profile: the curve used 
to control the helical 
curve radius variation. 
The radius evolves 
according to the distance 
between the axis and the 
selected profile (here the 
orange curve).
Note that the Starting 
point must be on the 
profile.

 ●     Starting Angle: defines where the helical curve starts, in relation to the starting point.
This parameter can be set only for the Constant pitch only.

4.  Click the Reverse Direction button to invert the curve direction.

5.  Click OK to create 
the helix.

The helical 
curve 
(identified as 
Helix.xxx) is 
added to the 
specification 
tree.

 
Parameters can be edited in the 3D geometry. To have further information, please refer 
to the Editing Parameters chapter.
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Creating  Corners 
 
This task shows you how to create a corner between two curves or between a point and a curve.

 
Open the Corner1.CATPart document.

 
1.  Click the Corner icon  .

The Corner Definition dialog box appears. 

2.  Select a curve or a point as first reference 
element.

3.  Select a curve as second reference 
element.
The corner will be created between these 
two references.

4.  Select the Support surface. It can be a 
surface or a plane. Here we selected the zx 
plane.

The resulting corner is a curve seen as an arc of 
circle lying on a support place or surface.

 
The reference elements must lie on this support, as well as the center of the circle defining the 
corner.

5.  Enter a Radius value.
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The Corner On Vertex check box enables you to create a corner by selecting a point or a curve as 
Element 1 (Element 2 is grayed as well as the Trim Element 1 and 2 options).

6.  Select the Support surface. 

The example above shows a corner defined by a point as Element 1

7.  Several solutions may be possible, so click 
the Next Solution button to move to 
another corner solution, or directly select 
the corner you want in the geometry.

Not all four solutions are always 
available, depending on the support 
configuration (if the center of one of 
the corners does not lie on the 
support for example). 
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8.  You can select  the Trim elements check 
box if you want to trim and assemble the 
two reference elements to the corner.

The elements can be trimmed and assembled 
individually.

9.  Click OK to create the corner.

The corner (identified as Corner.xxx) is added to 
the specification tree.

 When the selected curves are coplanar, the default support is the background plane. However, you 
can explicitly select any support.

 You can edit the rotated element's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.
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Creating Connect Curves
 
This task shows how to create connecting curves between two existing curves.

Open the Connect1.CATPart document.

 1.  Click the Connect Curve icon  

.

The Connect Curve Definition 
dialog box appears.

2.  Select a first Point on a curve 
then a second Point on a 
second curve.
The Curve fields are 
automatically filled.
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3.  Use the combos to specify the desired Continuity type: Point, Tangency or 
Curvature.

4.  If needed, enter tension values in the example below the tension is set to 3 
whenever we illustrate a curvature or tangency continuity).

The connect curve is displayed between the two selected points according to the 
specified continuity and tension values.

Connect curve with point continuity at 
both points

Connect curve with point continuity at one 
point

and tangent continuity at the other

Connect curve with point continuity at 
one point

and curvature continuity at the other

Connect curve with tangent continuity at one 
point

and curvature continuity at the other
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Connect curve with curvature 
continuity at both points

Connect curve with tangent continuity at both 
points

5.  An arrow is displayed at each extremity of the curve. You can click the arrow to 
reverse the orientation of the curve at that extremity.

A graphic manipulator also allows you to modify the tension at the extremity of the 
connect curve, rather than in the dialog box.

6.  You can select  the Trim 
elements check box if you 
want to trim and assemble the 
two initial curves to the connect 
curve.

7.  Click OK to create the connect curve.

The curve (identified as Connect.xxx) is added to the specification tree. 
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Creating Projections 
 This task shows you how to create geometry by projecting one or more elements onto 
a  support. The projection may be normal or along a direction.
You can project: 
●     a point onto a surface or wireframe support

●     wireframe geometry onto a surface support

●     any combination of points and wireframe onto a surface support.

Generally speaking, the projection operation has a derivative effect, meaning that 
there may be a continuity loss when projecting an element onto another. If the initial 
element presents a curvature continuity, the resulting projected element presents at 
least a tangency continuity. If the initial element presents a tangency continuity, the 
resulting projected element presents at least a point continuity.

Open the Projection1.CATPart document.

1.  Click the Projection icon  .

The Projection Definition dialog 
box appears.

   

2.  Select the element to be Projected.

You can select several elements 
to be projected.  In this case, the 
Projected field indicates: x 
elements
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3.  Select the Support element. 

4.  Use the combo to specify the direction 
type for  the projection:

●     Normal: the projection is done normal to 
the support element.

●     Along a direction: you need 
to select a line to take its 
orientation as the translation 
direction or a plane to take its 
normal as the translation 
direction.

You can also specify the direction 
by means of X, Y, Z vector 
components by using the 
contextual menu on the 
Direction field.

  

7.  Click OK to create the projection element.

The projection (identified as Project.xxx) is added to the specification tree. 

●     Whenever several projections are possible, you can select the Nearest Solution 
check box to keep the nearest projection.
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The following capabilities are available: Stacking Commands and Selecting Using Multi-
Output.

Multi-selection is available. Refer to Editing a List of Elements to find out how to 
display and manage the list of selected elements.
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Creating Intersections 

This task shows you how to create wireframe geometry by intersecting elements.

You can intersect:

●     wireframe elements

●     surfaces

●     wireframe elements and a surface.

Open the Intersection1.CATPart document.

 
1.  Click the Intersection icon .

 The Intersection Definition dialog box 
appears as well as the Multi-Selection dialog 
box allowing to perform multi-selection. 

 

2.  Select the two elements to be intersected.
The intersection is displayed.

 Multi-selection is available on the first selection, meaning you can select several elements to be 
intersected, but only one intersecting element.

3.  Choose the type of intersection to be displayed: 

●     A Curve: when intersecting a curve with another one

 

●     Points: when intersecting a curve with another one
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●     A Contour: when intersecting a solid element with a 
surface

●     A Face: when intersecting a solid element with a 
surface (we increased the transparency degree on the 
pad and surface)

4.  Click OK to create the intersection element.

This element (identified as Intersect.xxx) is added to the specification tree. 

This example shows the line resulting
from the intersection of a plane and a surface

This example shows the curve resulting
from the intersection of two surfaces

Two options can be defined to improve the preciseness of the intersection.

Open the Intersection2.CATPart document.

 ●     The Extrapolate intersection on first element check box enables you to perform an extrapolation on the first 
selected element, in the case of a surface-surface intersection. In all the other cases, the option will be grayed.
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 Intersection without the Extrapolation option checked Intersection with the Extrapolation option checked
 ●     The Intersect non-secant line segments check box enables you to perform an intersection on two non-cutting 

lines. In all the other cases, the option will be grayed.

 

 Intersection between the light green line and the blue 
line: the intersection point is calculated after the blue line 

is extrapolated

Intersection between the pink line and the blue line: the 
intersection is calculated as the mid-point of minimum 

distance between the two lines

●     Avoid using input elements which are tangent to each other since this may result in geometric instabilities in the 
tangency zone.

●     If you intersect closed surfaces, they need to be created in two different open bodies.

 
The following capabilities are available: Stacking Commands and Selecting Using Multi-Output.
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Creating Surfaces
Wireframe and Surface allows you to model both simple and complex surfaces using 
techniques such as extruding, lofting and sweeping.

Two creation modes are available: either you create geometry with its history or not. 
Geometry with no history is called a datum. Please refer to Creating Datums for more 
information.

 Create extruded surfaces: select a profile, specify the extrusion direction, the start and 
end limits.

Create surfaces of revolution: select a profile and a rotation axis, and key in an angle

 
Create spherical surfaces: select the center point of the sphere, the axis-system 
defining the meridian and parallel curves, and define the angular limits of the spherical 
surface

Create cylindrical surfaces: select the center point of the circle and specify the 
extrusion direction.

 Offset surfaces: select a surface, specify the offset value and choose the offset 
direction

 Create swept surfaces: select a guide curve, a planar profile, optionally a spine and 
second guide curve, and  position the profile

 Create filling surfaces: select curves/surface edges to form a closed boundary and 
specify the continuity type

Creating lofted surfaces: select one or two planar section curves, optionally guide 
curves and a spine

Creating blended surfaces: select two curves, and possibly their support, specify the 
tension, continuity, closing point and coupling ratio, if needed.
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Creating Extruded Surfaces
 
This task shows how to create a surface by extruding a profile along a given direction.

 
Open the Extrude1.CATPart document.

 
1.  Click the Extrude icon .

The Extruded Surface Definition 
dialog box appears. 

2.  Select the profile to be extruded and 
specify the desired extrusion direction.

You can select a line to take its 
orientation as the extrusion direction 
or a plane to take its normal as 
extrusion direction. 

 

You can also specify the direction by 
means of X, Y, Z vector components 
by using the contextual menu on the 
Direction area.
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3.  Enter numerical values or use the graphic 
manipulators to define the start and end 
limits of the extrusion.

4.  You can click the Reverse Direction 
button to display the extrusion on the other 
side of the selected profile.

5.  Click OK to create the surface.

The surface (identified as Extrude.
xxx) is added to the specification 
tree. 
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Creating Revolution Surfaces 
 
This task shows how to create a surface by revolving a planar profile about an axis.

 
Open the Revolution1.CATPart document.

 
1.  Click the Revolve icon  .

The Revolution Surface Definition 
dialog box appears. 

 

2.  Select the Profile and a line indicating 
the desired Revolution axis.

3.  Enter angle values or use the graphic 
manipulators to define the angular limits 
of the revolution surface.
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4.  Click OK to create the surface.

The surface (identified as Revolute.xxx) is 
added to the specification tree. 

●     There must be no intersection between the axis and the profile. However, if the 
result is topologically consistent, the surface will still be created.

●     If the profile is a sketch containing an axis, the latter is selected by default as the 
revolution axis. You can select another revolution axis simply by selecting a new 
line.

 
Parameters can be edited in the 3D geometry. To have further information, please 
refer to the Editing Parameters chapter.
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Creating Spherical Surfaces
 This task shows how to create surfaces in the shape of a sphere.
The spherical surface is based on a center point, an axis-system defining the meridian 
& parallel curves orientation, and angular limits.

 
Open the Sphere1.CATPart document.

 
1.  Click the Sphere icon  from the 

Extrude-Revolution toolbar.

The Sphere Surface Definition 
dialog box is displayed. 

2.  Select the center point of the sphere.

3.  Select an axis-system.

This axis-system determines the 
orientation of the meridian and 
parallel curves, and therefore of 
the sphere. 

By default, if no axis-system has 
been previously created in the 
document, the axis-system is 
the document xyz axis-system. 
Otherwise the default axis-
system is the current one.
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4.  Click Apply to preview the surface.

5.  Modify the Sphere radius and  the 
Angular Limits as required. 
Here we choose -90° and 90° for the 
parallel curves, and 240° and 0° for 
the meridian curves, and left the radius 
at 20 mm.

 Parallel angular limits are comprised within the -90° and 90° range.
Meridian angular limits are comprised within the -360° and 360° range.

6.  Click OK to create the surface.

The spherical surface (identified as Sphere.xxx) is added to the specification tree.

You can also choose to create a whole 

sphere. In this case, simply click the  icon 

from the dialog box to generate a complete 
sphere, based on the center point and the 
radius. The parallel and meridian angular 
values are then grayed.

 
Parameters can be edited in the 3D geometry. To have further information, please 
refer to the Editing Parameters chapter.
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 Creating Cylindrical Surfaces

 
This task shows how to create a cylinder by extruding a circle along a given direction.

 Open the Cylinder1.CATPart document.

 
1.  Click the Cylinder icon  .

The Cylinder Surface Definition dialog box 
appears. 

 2.  Select the Point that gives the center of the circle to be extruded and specify the desired Direction of the 
cylinder axis.

You can select a line to take its orientation as the direction or a plane to take its normal as direction. 

You can also specify the direction by means of X, Y, Z vector components by using the contextual menu 
on the Direction area.

3.  Select the Radius of the cylinder.

4.  Enter values or use the graphic manipulators to define the start and end limits of the extrusion.

 

 5.  You can click the Reverse Direction button to display the direction of the cylinder on the other side of the 
selected point or click the arrow in the 3D geometry.

6.  Click OK to create the surface.

The surface (identified as Cylinder.xxx) is added to the specification tree.
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Creating Offset Surfaces

This task shows how to create a surface by offsetting an existing surface.

Open the Offset1.CATPart document.

 

1.  Click the Offset icon  .

The Offset Surface 
Definition dialog box 
appears. 

2.  Select the surface to be 
offset. 

3.  Specify the offset by entering 
a value or using the graphic 
manipulator.

4.  An arrow indicates the 
proposed direction for the 
offset.

The offset surface is 
displayed normal to the 
reference surface. 

5.  Click Apply to previews the 
offset surface.

The offset surface is 
displayed normal to the 
reference surface. 
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Depending on the geometry configuration and the offset value, an offset may not be 
allowed as it would result in a debased geometry. In this case, you need to decrease 
the offset value or modify the initial geometry.

You can display the 
offset surface on the 
other side of the 
reference surface by 
clicking either the 
arrow or the Reverse 
Direction button. 

6.  Check the Both sides button 
to generate two offset 
surfaces, one on each side of 
the reference surface.

7.  Click OK to create the surfaces.

The surfaces (identified as Offset.xxx) are added to the specification tree. 

●     Use the Repeat object after OK 
checkbox to create several offset 
surfaces, each separated from 
the initial surface by a multiple of 
the offset value.
Simply indicate in the Object 
Repetition dialog box the number 
of instances that should be 
created and click OK.
Remember however, that when 
repeating the offset it may not be 
allowed to create all the offset 
surfaces, if it leads to debased 
geometry.
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●     Would the value be 
inconsistent with the 
selected geometry, a 
warning message is 
displayed, along 
with a warning sign 
onto the geometry. 
If you move the 
pointer over this 
sign, a longer 
message is 
displayed to help 
you continue with 
the operation.

Furthermore, the 
manipulator is locked, 
and you need to 
modify the value within 
the dialog box and click 
Apply.

The options set in the dialog box are retained when exiting then returning to the 
Offset function.

 
Parameters can be edited in the 3D geometry. To have further information, please 
refer to the Editing Parameters chapter.
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Creating Filling Surfaces
 
This task shows how to create fill surfaces between a number of boundary segments.

Open the Fill1.CATPart document.

 
1.  Click the Fill icon .

The Fill Surface Definition dialog box 
appears.

2.  Select curves or surface edges to form a closed 
boundary.

You can select a support surface for each curve or edge. In this case continuity will be 
assured between the fill surface and selected support surfaces.

3.  Use the combo to specify the desired continuity 
type between any selected support surfaces and 
the fill surface: Point or Tangent.

The fill surface is displayed within the 
boundary. 
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4.  You can edit the boundary by first selecting an element in the dialog box list then choosing a 
button to either:

●     Add a new element after or before the selected one

●     Remove the selected element

●     Replace the selected element by another curve

●     Replace the selected support element by another support surface

●     Remove the selected support element.

 
This point should lie within the area delimited by the selected curves. If not, the results may be 
inconsistent.

6.  Click OK to create the fill surface.

The surface (identified as Fill.xxx) is added to the specification tree.

 

 

 

Filling surface with specified supports Filling surface with passing point (P2 only)

 

 ●     The selected curves or surfaces edges can now intersect. 
Therefore a relimitation of the intersecting boundaries is 
performed to allow the creation of the fill surface. 

Two consecutive boundaries must have only one intersection.
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 ●     The selected 
curves or 
surfaces edges 
can have non-
coincident 
boundaries. 
Therefore, an 
extrapolation is 
performed to 
allow the 
creation of the 
fill surface. 

The distance 
between non-
coincident 
boundaries must 
be smaller than 
0.1mm.
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Creating Swept Surfaces
 
This task shows how to create a swept surface that uses an explicit profile.

You can create a swept surface by sweeping out a profile in planes normal to a spine 
curve while taking other user-defined parameters (such as guide curves and reference 
elements) into account. 

You can sweep an explicit profile:

●     along one or two  guide curves (in this case the first guide curve is 
used as the spine)

●     along one or two guide curves while respecting a spine.

The profile is swept out in planes normal to the spine.

In addition, you can control the positioning of the profile while it is being swept by 
means of a  reference surface. 

The profile position may be fixed with respect to the guide curve (positioned profile) 
or user-defined in the first sweep plane (CATIA P2 only). 

Open the Sweep1.CATPart document.

1.  Click the Sweep icon  .

The Swept Surface 
Definition dialog box 
appears.
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2.  Select the planar profile to be 
swept out, that is the circle.

3.  Select a guide curve.

4.  If needed, select a spine.
If no spine is selected, the guide curve is implicitly used as the spine.

5.  If needed, select a second guide curve.
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 Within the Second guide tab, you 
can also specify anchor points for 
each guide. These anchor points are 
intersection points between the 
guides and the profile's plane or the 
profile itself, through which the 
guiding curves will pass.  

There are two anchoring types:
●     Two points: select an anchor 

point on each guide curve
If the profile is open, these points 
are optional and the extremities 
of the profile are used.

●     Point and direction: select an 
anchor point on Guide Curve 1 
and an anchor direction.
In each sweeping plane, the 
default x-axis is aligned with the 
two guide curves.

You can define relimiters (points or 
planes) in order to longitudinally 
reduce the domain of the sweep, if 
the swept surface is longer than 
necessary for example. 

Besides is an example with a plane 
as Relimiter 1.
When there is only one relimiter, 
you are able to choose the direction 
of the sweep by clicking the green 
arrow.

●     Relimiters can be selected on a 
closed curve (curve, spine, or 
default spine). In that case, you 
are advised to define points as 
relimiters, as plane selection may 
lead to unexpected results due to 
multi-intersection.

●     You can stack the creation of the 
elements by using the contextual 
menu available in either field. 
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●     In the Smooth sweeping section, 
you can check: 
❍     the Angular correction option 

to smooth the sweeping motion 
along the reference surface.  
This may be necessary when 
small discontinuities are 
detected with regards to the 
spine tangency or the reference 
surface's normal. The 
smoothing is done for any 
discontinuity which angular 
deviation is smaller than 0.5 
degree, and therefore helps 
generating better quality for 
the resulting swept surface.

❍     the Deviation from guide(s) 
option to smooth the sweeping 
motion by deviating from the 
guide curve(s).

6.  If you want to control the position of the profile during the sweep, you can 
select a reference surface. You can impose a reference angle on this surface.

7.  Click OK to create the swept 
surface.

The surface (identified 
as Sweep.xxx) is added 
to the specification tree. 

Generally speaking, the sweep operation has a derivative effect, meaning that there 
may be a continuity loss when sweeping a profile along a spine. If the spine presents 
a curvature continuity, the surface presents at least a tangency continuity. If the 
spine presents a tangency continuity, the surface presents at least a point continuity.

 
Parameters can be edited in the 3D geometry. To have further information, please 
refer to the Editing Parameters chapter.
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Creating Multi-section Surfaces
 
This task shows how to create a multi-section surface.

You can generate a multi-section surface by sweeping one or two planar section curves along a computed or user-
defined spine. The surface can be made to respect one or more guide curves.

 Open the Loft1.CATPart document.

 
1.  Click the Multi-sections surface icon .

The Multi-section Surface Definition dialog box appears. 

2.  Select one or two planar section curves.

These sections (two at maximum) may be tangent to support surfaces, provided they are not parallel.
Closed section curves can have point continuity at each closing point. 

3.  If needed, select one or more guide curves.

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/wfsugbt0205.htm (1 of 7)10/21/2004 5:04:47 AM

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/samples/Loft1.CATPart


Creating Multi-section Surfaces

4.  In the Spine tab page, select the Spine check box to use an automatically computed spine or select a curve to 
impose that curve as the spine. 

5.  It is possible to edit the multi-section surface 
reference elements by first selecting a curve in the 
dialog box list then choosing a button to either:

●     remove the selected curve

●     replace the selected curve by another curve

●     add another curve.

More possibilities are available with the contextual menu 
and by right-clicking on the red text or on the object. For 
example, it is possible to remove and replace tangent 
surfaces and closing points.
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6.  Click OK to create the multi-section surface.

The surface (identified as Multi-section 
surface.xxx) is added to the specification 
tree. 

●     You can impose tangency conditions onto sections and/or guides, by specifying a direction for the tangent vector 
(selecting a plane to take its normal, for example). This is useful for creating parts that are symmetrical with respect 
to a plane. Tangency conditions can be imposed on the two symmetrical halves.
Similarly, you can impose a tangency onto each guide, by selection of a surface or a  plane (the direction is tangent 
to the plane's normal).  In this case, the sections must also be tangent to the surface.

 
●     You can create multi-section surfaces between closed section curves. These curves have point continuity at their 

closing point.
This closing point is either a vertex or an extremum point automatically detected and highlighted by the system. 
By default, the closing points of each section are linked to each other.

The red arrows in the figures below represent the closing points of the closed section curves. You can change the 
closing point by selecting any point on the curve.  

  

The surface is twisted A new closing point has been imposed
to get a non-twisted surface

  
 

●     In the Smooth parameters section, you can check: 
❍     the Angular correction option to smooth the 

lofting motion along the reference guide curves. This 
may be necessary when small discontinuities are 
detected with regards to the spine tangency or the 
reference guide curves' normal. The smoothing is 
done for any discontinuity which angular deviation is 
smaller than 0.5 degree, and therefore helps 
generating better quality for the resulting multi-
section surface.

❍     the Deviation option to smooth the lofting motion 
by deviating from the guide curve(s).
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●     The Relimitation tab lets you specify the multi-section 
surface relimitation type.
You can choose to limit the multi-section surface only 
on the Start section, only on the End section, on both, 
or on none.

 ●     when one or both are checked: the multi-section surface is limited to corresponding section

●     when one or both are when unchecked: the multi-section surface is swept along the spine: 
❍     if the spine is a user spine, the multi-section surface is limited by the spine extremities

❍     if the spine is an automatically computed spine, and no guide is selected:
the multi-section surface is limited by the start and end sections 

❍     if the spine is an automatically computed spine, and guides are selected:
the multi-section surface is limited by the guides extremities.

 

 
Multi-section surface relimitation option checked

 on both Start and End section
Multi-section surface relimitation option unchecked

 on End section only

●     Use the Planar surface detection check button (Canonical Surfaces tab) to automatically convert planar surfaces 
into planes.

 

Coupling

This task presents the two kinds of coupling during the creation of the multi-section surface: 
●     coupling between two consecutive sections

●     coupling between guides

 
Open the Loft2.CATPart document. To perform  the following scenario you will need to get some geometry locate

Coupling between two consecutive sections
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Creating Multi-section Surfaces

 This coupling is based on the curvilinear abscissa.

1.  Click the Multi-section surface icon  .

The Multi-section Surface Definition dialog box appears.

2.  Select the two consecutive sections.

3.  Click OK to create the multi-section surface.

To create a coupling between particular points, you can add guides or 
define the coupling type.
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Creating Multi-section Surfaces

Coupling between guides

This coupling is performed by the spine.
If a guide is the concatenation of several curves, the resulting multi-section surface will contain as many surfaces as 
curves within the guide.

 Several coupling types are available, depending on the section 
configuration: 
●     Ratio: the curves are coupled according to the curvilinear abscissa 

ratio.
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Creating Multi-section Surfaces

●     Tangency: the curves are coupled according to their tangency 
discontinuity points. If they do not have the same number of points, 
they cannot be coupled using this option.

 ●     Tangency then curvature: the curves are coupled according to their tangency continuity first then curvature 
discontinuity points. If they do not have the same number of points, they cannot be coupled using this option. 

●     Vertices: the curves are coupled according to their vertices. If they do not have the same number of vertices, they 
cannot be coupled using this option. 
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Creating Blended Surfaces

Creating Blended Surfaces
 This task shows how to create a blended surface, that is a surface between two 
wireframe elements, taking a number of constraints into account, such as tension, 
continuity, and so forth.
Note that curves with one edge only can be used to create blend surfaces.

 
Open the Blend1.CATPart document.

1.  Click the Blend icon  .

The Blend Definition : 
Blend dialog box appears.

2.  Successively select the first curve and its support, then the second curve and 
its support.
These can be surface edges, or any curve.
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Creating Blended Surfaces

3.  Set the continuity type using the 
Basic tab.
It defines the continuity 
connection between the newly 
created surface and the curves 
on which it lies.

The illustration above, 
shows the Tangency 
continuity, and the 
following illustrations show 
the Point and Curvature 
continuity types:
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Creating Blended Surfaces

 
Point continuity on both limits Curvature 

4.  Activate the Trim first/second 
support option, on one or both 
support surfaces to trim them by 
the curve and assemble them to 
the blend surface:

By default the blend 
surface borders are 
tangent to the support 
surface borders.

You can also specify whether and where the blend boundaries must be 
tangent to the supports boundaries:
●     Both extremities: the tangency constraint applies at both ends of the 

curve

●     None: the tangency constraint is disregarded 

●     Start extremity: the tangency constraint applies at the start endpoint 
of the curve only

●     End extremity: the tangency constraint applies at the end endpoint of 
the curve only

The Start and End extremities are defined according to the arrows in the 
blended surface's preview.
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Creating Blended Surfaces

5.  Set the tension type using the 
Tension tab.
It defines the tension of the 
blend at its limits.

It can be constant or 
linear, and can be set for 
each limit independently.

6.  Click OK. 

The surface (identified as Blend.xxx) is added to the specification tree.

●     Selecting a support is not compulsory.

●     You can create closing points using the contextual menu on the First or Second 
closing point fields in the dialog box, or using the contextual menu directly on one 
of the selected curves.

●     Use the Replace, Remove, or Reverse buttons, to manage the selected elements 
(curves, support, closing and coupling points).

●     You can also use the contextual menu on the texts displayed on the geometry to 
set the continuities, trim the supports or manage the curves and support in general.
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Performing Operations

Performing Operations on Shape Geometry
Wireframe and Surface allows you to modify your design using techniques such as trimming, 
translating and rotating. 

Join geometry: select at least two curves or surfaces to be joined.

 Heal geometry: select at least two surfaces presenting a gap to be healed.

 Untrim an element: select a split element, and click the icon.

Disassemble elements: select a multi-cell element, and choose the disassembling 
mode.

Split geometry: select the element to be split and a cutting element.

Trim geometry: select two elements to be trimmed and specify which side of  element 

Create boundary Curves: select a surface's edge, set the propagation type, and re-
define the curve limits if needed.

Extract geometry: select an element's edge or face and click the icon

Translate geometry: select an element, a translation direction (line, plane or vector), 
specify the translation distance

Rotate geometry: select an element, a line as the rotation axis, and specify the 
rotation angle

Perform a symmetry: select an element, then a point, line, or plane as reference 
element 

Transform geometry by scaling: select an element, then a point, plane, or planar 
surface as reference element, and specify the scaling ratio

Transform geometry by affinity: select an element to be transformed, specify the axis 
system characteristics, and the enter the affinity ratio values

Transform geometry into a new axis-system: select an element to be transformed, 
specify the axis system characteristics, and the enter the affinity ratio values

Create the nearest sub-element: select the Insert -> Operations -> Near menu 
item, the element made of several sub-elements, then a reference element whose 
position is close to the sub-element to be created
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Performing Operations

Extrapolate curves:  select a curve endpoint then the curve itself, specify the 
extrapolation limit (length value or limiting surface/plane), and specify the continuity 
constraints (tangent/curvature)
Extrapolate surfaces: select a surface boundary then the surface itself, specify the 
extrapolation limit (value or limiting surface/plane), and specify the extremities 
constraints (tangent/normal)
Invert geometry orientation: select the Insert -> Operations -> Invert Orientation 
menu item, then the surface or curve whose orientation is to be inverted, click the 
orientation arrow, and click Invert Orientation again to accept the inverted element.
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Joining Surface or Curves

Joining Surfaces or Curves
 
This task shows how to join at least two surfaces or two curves. 

The surfaces or curves to be joined must be adjacent.

 
Open the Join1.CATPart document.

 
1.  Click the Join  icon.

The Join Definition 
dialog box appears. 

2.  Select the surfaces or 
curves to be joined.

3.  You can edit the list of 
elements to be joined:

●     by selecting elements in the 
geometry: 

❍     Standard selection (no 
button clicked):
when you click an unlisted 
element, it is added to the 
list 
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Joining Surface or Curves

when you click a listed 
element, it is removed 
from the list

❍     Add Mode: 
when you click an unlisted 
element, it is added to the 
list 
when you click a listed 
element, it remains in the 
list

❍     Remove Mode: 
when you click an unlisted 
element, the list is 
unchanged 
when you click a listed 
element, it is removed 
from the list

●     by selecting an element in the 
list then using the Remove
\Replace contextual menu 
items.

 If you double-click the Add Mode or Remove Mode button, the chosen mode is 
permanent, i.e. successively selecting elements will add/remove them.  However if 
you click only once, only the next selected element is added or removed.
You only have to click the button again, or click another one, to deactivate the mode.

4.  Right-click the elements 
from the list and choose 
the Check Solution 
command.

This let's you check 
whether any 
element to be 
joined presents any 
intersection (i.e. at 
least one common 
point) with other 
elements prior to 
creating the joined 
surface:
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Joining Surface or Curves

The Checker dialog 
box is displayed, 
containing the list 
of domains (i.e. 
sets of connected 
cells) belonging to 
the selected 
elements from the 
Elements To Join 
list.

5.  Click Apply.

 
●     An Information message is 

issued when no intersection is 
found.

●     When an element is self-
intersecting, or when several 
elements intersect, a text is 
displayed on the geometry, 
where the intersection is 
detected.

6.  Click Cancel to return to the Join Definition dialog box.
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7.  Right-click the elements from the list and choose the Propagate command. It 
allows the selection of elements of same dimension to be added to the 
Elements To Join list.

●     The initial element to propagate cannot be a sub-element

●     Forks stop the propagation

●     Intersections are not detected

8.  Click Apply in the Join 
Definition dialog box.

The joined element 
is previewed, and 
its orientation 
displayed. Click the 
arrow to invert it if 
needed.

 The join is oriented according to the first element in the list. If you change this 
element, the join's orientation is automatically set to match the orientation of the new 
topmost element in the list.

9.  Check the Check 
tangency button to find 
out whether the elements 
to be joined are tangent. 
If they are not, and the 
button is checked, an 
error message is issued.
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10.  Check the Check 
connexity button to find 
out whether the elements 
to be joined are connex. If 
they are not, and the 
button is checked, an 
error message is issued 
indicating the number of 
connex domains in the 
resulting join.
When clicking Apply, the 
free boundaries are 
highlighted, and help you 
detect where the joined 
element is not connex.

11.  Check the Check 
manifold button to find 
out whether the resulting 
join is manifold.

 The Check manifold button is 
only available with curves.
Checking it automatically checks 
the Check connexity button.

The Simplify the result check button allows the system to automatically 
reduce the number of elements (faces or edges) in the resulting join 
whenever possible.

The Ignore erroneous elements check button lets the system ignore 
elements that would not allow the join to be created.

9.  You can also set the tolerance at which two elements are considered as being 
only one using the Merging distance.
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10.  Check the Angle Tolerance button to specify the angle value below which the 
elements are to be joined.
If the angle value on the edge between two elements is greater than the Angle 
Tolerance value, the elements are not joined. This is particularly useful to 
avoid joining overlapping elements.

 

If the edges or the faces have a 
angular threshold higher than 
the predefined value, a text is 
displayed on the geometry 
indicating the error type.
You can either deactivate the 
check box or increase the value 
of the angular threshold, or 
remove all the elements or sub-
elements that are in error.

11.  Click the Sub-Elements 
To Remove tab to display 
the list of sub-elements in 
the join.

These sub-elements 
are elements 
making up the 
elements selected 
to create the join, 
such as separate 
faces of a surface 
for example, that 
are to be removed 
from the join 
currently being 
created.

You can edit the 
sub-elements list as 
described above for 
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the list of elements 
to be joined. 

12.  Check the Create join with sub-elements option to create a second join, 
made of all the sub-elements displayed in the list, i.e. those that are not to be 
joined in the first join.
This option is active only when creating the first join, not when editing it.

13.  Click OK to create the joined surface or curve.

The surface or curve (identified as Join.xxx) is added to the specification 
tree. 

●     Sometimes elements are so close that it is not easy to see if they present a gap or 
not, even though they are joined. Check the Surfaces' boundaries option from 
the Tools -> Options menu item, General, Display, Visualization tab.

●     Once the Join.xxx element has been created, you can use the Check contextual 
menu from the specification tree. In this case however it verifies the connexity of 
all the sub-elements making up the joined surface. This is particularly useful when 
many elements have been joined, so has to highlight in the geometry which sub-
element is not connected to the other ones, thus allowing you to rework the 
geometry if needed.
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Healing Geometry
 This task shows how to heal surfaces, that is how to fill any gap that may be appearing between two 
surfaces.
This command can be used after having checked the connections between elements for example, or 
to fill slight gaps between joined surfaces.

 Open the Healing1.CATPart document.
Display the Join-Healing toolbar by clicking and holding the arrow from the Join  icon.

 
1.  Click the Healing  icon.

The Healing Definition dialog box 
appears. 

2.  Select the surfaces to be healed.

 

3.  You can edit the list of elements in the definition list:

●     by selecting elements in the geometry: 

❍     Standard selection (no button clicked):
when you click an unlisted element, it is added to the list 
when you click a listed element, it is removed from the list

❍     Add Mode: 
when you click an unlisted element, it is added to the list 
when you click a listed element, it remains in the list

❍     Remove Mode: 
when you click an unlisted element, the list is unchanged 
when you click a listed element, it is removed from the list

●     by selecting an element in the list then using the Remove\Replace contextual menu items.
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 If you double-click the Add Mode or Remove Mode button, the chosen mode is permanent, i.e. 
successively selecting elements will add/remove them.  However, if you click only once, only the 
next selected element is added or removed.
You only have to click the button again, or click another one, to deactivate the mode.

4.  From the Parameters tab, define the distance below which elements are to be healed, that is 
deformed so that there is no more gap, using the Merging distance as described in Joining 
Geometry.
Elements between which the gap is larger than the indicated value are not processed.

In our example, we increase it to 1mm. 

You can also set the Distance objective, i.e. the maximum gap allowed between two healed 
elements. By default it is set to 0.001 mm, and can be increased to 0.1 mm.

5.  Click OK to create the healed surfaces.

The surface (identified as Heal.
xxx) is added to the specification 
tree. 

●     Check the Surfaces' boundaries option from the Tools -> Options menu item, General -> 
Display -> Visualization tab to display the boundaries. This may be especially useful when 
selecting, and also to identify gaps.

●     Provided the Tangent mode is active, you 
can retain sharp edges, by clicking the 
Sharpness tab, and selecting one or more 
edges.
You can edit the list of edges as described 
above for the list of elements to be healed.

●     The Sharpness angle allows to redefine 
the limit between a sharp angle and a flat 
angle. This can be useful when offsetting 
the resulting healed geometry for 
example.  By default this angle value is set 
to 0.5 degree.
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●     In some cases,  depending on the 
geometry configuration and the set 
parameters, the Multi-Result Management 
dialog box is displayed. 
Click No or refer to Creating the Nearest 
Entity of a Multiple Element.

When the healing failed, the update error 
dialog box appears.
Click OK to improve the geometry.

The erroneous elements are displayed on the 
geometry.

The Visualization tab enables you to better 
understand the discontinuities in the model 
and the results of the healing action.

It lets you define the way the messages are 
displayed on the smoothed element. 
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You can choose to see:
 
●     All the messages, that is to say the 

messages indicating where the 
discontinuity remains as well as those 
indicating where the discontinuity type has 
changed (in point (><) and tangency (^))

●     only the messages indicating where the 
discontinuity is Not corrected and still 
remains

●     None of the messages

You can also choose to see: 
 
●     Display information interactively: only 

the pointers in the geometry are displayed, 
above which the text appears when passing 
the pointer 
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Healing Geometry

●     Display information sequentially: only 
one pointer and text are displayed in the 
geometry, and you can sequentially move 
from one pointer to another using the 
backward/forward buttons
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Restoring a Surface

In this task you will learn how to restore the limits of a surface when it has been split 
using the Break   icon (see Splitting Geometry).

Open the Untrim1.CATPart document.

1.  Click the Untrim icon  in the Join-Healing 

Modification toolbar.

The Untrim dialog box is displayed. 

2.  Select the surface which limits should be 
restored.

The dialog box is updated accordingly. 

3.  Click OK in the dialog box.

A progression bar is displayed, while the surface is restored.
It automatically disappears once the operation is complete (progression at 
100%).  
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Restoring a Surface

 

The initial surface is automatically restored.

 
The restored surface or curve is identified as Surface Untrim.xxx or Curve Untrim.xxx.

If the surface has been trimmed several times, it is the initial surface which is 
restored. To partially untrim the surface, you need to use the Undo command right 
after the trim.

 

 
[ Back ] [ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/wfsugbt0412.htm (2 of 2)10/21/2004 5:05:34 AM



Disassembling Elements

Disassembling Elements

In this task you will learn how to disassemble multi-cell bodies into mono-cell bodies.

Open the Disassembling1.CATPart document, or any document containing a multi-cell 
element.

1.  Select the element to be disassembled.
You can select only an edge of a surface, the 
system recognizes the whole element to be 
disassembled.

Here we selected the join made of three 
elements, each made of several cells.

2.  Click the Disassemble icon  in the Join-

Healing toolbar.

The Disassemble dialog box is displayed.
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Disassembling Elements

3.  Choose the disassembling mode: 

●     All Cells: all cells are disassembled, i.e. for all the 
selected element, a separate curve is created for each 
cell.

●     Domains Only: elements are partially disassembled, i.
e. each element is kept as a whole if its cells are 
connex, but is not decomposed in separate cells. A 
resulting element can be made of several cells. 

In the illustrations, we have colored the resulting 
curves for better identification.

Results when disassembling 
all cells

(seven curves are created)

Results when disassembling 
domains only

(three curves are created)

4.  Click OK in the dialog box.

A progression bar is displayed, while the surface is being disassembled.
It automatically disappears once the operation is complete (progression at 
100%). 
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Disassembling Elements

The selected element is disassembled, that is to say independent elements are created, that 
can be manipulated independently.

Multi-selection is available.
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Splitting Geometry

 This task shows how to split a surface or wireframe element by means of a cutting element.
You can split: 

●     a wireframe element by a point, another wireframe element or a surface

●     a surface by a wireframe element or another surface.

 
Open the Split1.CATPart document.

1.  Click the Split icon .

The Split Definition dialog box appears. 

 2.  Select the element to be split.

 

You should make your selection by clicking on the 
portion that you want to keep after the split.

3.  Select the cutting element.

A preview of the split appears. You can 
change the portion to be kept by selecting 
that portion. 

You can also select the portion to be kept 
by clicking the Other side button. 
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Splitting Geometry

You can select several cutting elements. In that case, note that the selection order is important as the area to be split is 
defined according to the side to be kept in relation to current splitting element. 

In the illustrations below, the top-left line is the first splitting element. In the left illustration it defines an area that  
intersects with the other three  splitting curves, and in the illustration to the right, these three elements are useless to 
split the area defined by the first splitting element.

Would you need to remove, or replace, one of these cutting elements, select it from the list and click the Remove or 
Replace button.

The Elements to remove and Elements to keep options allows to define the portions to be removed or kept when 
performing the split operation. 
●     Click in the field of your choice to be able to select the elements in the 3D geometry.

●     Right-click in the field either to clear the selection or display the list of selected elements.

Only the selected element is removed.
All other elements are kept.

The selected elements are kept.
All other elements are removed.

●     You must select sub-elements as elements to keep or 
to remove; otherwise, a warning message is issued.
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Splitting Geometry

 ●     You can also select a point to define the portion to 
keep or to remove. 

A contextual menu is available on the Elements to 
remove and Elements to keep fields.

 

You do not need to select elements to keep if you already selected elements to remove and vice-versa.

4.  Click OK to split the element.

The created element (identified as Split.
xxx) is added to the specification tree. 

●     Check the Keep both sides option to retain the other side of the split element after the operation. In that case it 
appears as aggregated under the first element.

●     Check the Intersection computation button to 
create an aggregated intersection when performing 
the splitting operation. This element will be added to 
the specification tree as Intersect.x 

●     Uncheck the Automatic extrapolation button if do 
not you want the automatic extrapolation of the 
cutting curve. 
If the Automatic extrapolation button is 
unchecked, an error message is issued when the 
cutting element needs to be extrapolated, and the 
latter is highlighted in red in the 3D geometry.
To be able to split the surface, check the Automatic 
extrapolation button.

This option is available in the case of a split surface/
curve or surface/surface.

●     When splitting a wire (curve, line, sketch and so forth) by another wire, you can select a support to define the area 
that will be kept after splitting the element. It is defined by the vectorial product of the normal to the support and the 
tangent to the splitting element. 
This is especially recommended when splitting a closed wire. 

The non disconnected elements of the element to cut are kept in the result of the split.
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Splitting Geometry

 

Splitting with no support selected: first solution Splitting with no support selected: second solution

Splitting with a selected support (xy plane): first solution Splitting with a selected support (xy plane): second solution

●     You can create a Join as the splitting element, by right-clicking in the Cutting Elements field and choosing the Create 
Join item.

If you split a surface and you keep both sides by joining the resulting splits, you cannot access the internal sub-elements 
of the join: indeed, splits result from the same surface and the cutting elements are common.

Avoid splitting geometry when the intersection between 
the element to cut and the cutting element is merged 
with an edge of the element to cut.
In that case, you can use the Elements to remove and 
Elements to keep options to remove the positioning 
ambiguity.

   
Splitting surface/curve or surface/surface

The following steps explain how split a surface by a curve or another surface.

Split surface/curve

1.  First, the cutting element (the curve) is laid down the surface.
2.  Then, the result of step 1 is tangentially extrapolated in order to split the surface correctly (as shown in following 

figure). However, when this extrapolation leads to the intersection of the cutting element with itself prior to fully 
splitting the initial element, an error message is issued as there is an ambiguity about the area to be split.  
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Splitting Geometry

If the cutting element does not reach the free edges of the element to cut, an extrapolation in tangency is performed 
using the part of the cutting element that lays down the surface.

Split surface/surface

Open the Split2.CATPart document.

1.  First, an intersection (the green wire) is created 
between the two elements (the surfaces).

2.  Then, the result of the intersection is automatically 
extrapolated in tangency up to the closest free edges 
of the element to cut.
The result of the extrapolation is used as the cutting 
element and the split is created.

Please note that it is not the cutting element which is 
extrapolated but the result of the intersection.

If the result of the split is not what was expected, it is also possible to manually extrapolate the cutting element with the 
extrapolate feature before creating the split.
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Splitting Geometry

1.  Extrapolate the cutting element (the red surface) in 
order to fully intersect the element to cut.

2.  Then, use the extrapolated surface as the cutting 
element to split the surface.

Avoid using input elements which are tangent to each other since this may result in geometric instabilities in the tangency 
zone.

In case surfaces are tangent or intersect face edges, please process as follow in order to avoid indeterminate positioning. 

Use the border edge of the cutting surface to split the 
element to cut:

1.  Delimit the boundary of the cutting surface
2.  Project this boundary onto the surface to split
3.  Use this projection as the cutting element

Steps 2 and 3 may be optional if the tangency constraint 
between the two surfaces has been clearly defined by the 
user during the surface creation.
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Splitting Geometry

The following cases should be avoided when possible 
(especially when the tangency constraint between the two 
surfaces has not been clearly defined by the user during the 
surface creation), as the result of the positioning is likely to 
be indeterminate and the result of the intersection to be 
unstable.  
  

 
When these cases cannot be avoided, it is recommended, 
first to create the intersection between the two surfaces, 
then to split the element to cut with the resulting 
intersection. Doing so, the position can be properly defined 
but the instability of the result relating to the intersection 
remains. 
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Creating Boundary Curves
 
This task shows how to create the boundary curve of a surface.

Open the Boundaries1.CATPart document.

1.  Click the Boundary icon .

The Boundary Definition 
dialog box appears. 

 

2.  Use the combo to choose the Propagation type:

●     Complete boundary: the selected edge is propagated around the entire surface 
boundary.

●     Point continuity: the selected edge is propagated around the surface boundary 
until a point discontinuity is met.

●     Tangent continuity: the selected edge is propagated around the surface boundary 
until a tangent discontinuity is met.

●     No propagation: no propagation or continuity condition is imposed, only the 
selected edge is kept.

You can now select the propagation 
type before selecting an edge.

 

 3.  Select a Surface edge.

The boundary curve is displayed 
according to the selected 
propagation type.
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Creating Boundary Curves

 

 No propagation Tangent continuity
   

 

 Point continuity Complete boundary
   
 4.  You can relimit the boundary curve by means of two elements.

If you relimit a closed curve by means of only one element, a point on curve curve for 
example, the closure vertex will be moved to the relimitation point, allowing this point 
to be used by other features.

 5.  Click OK to create the boundary curve.

The curve (identified as Boundary.xxx) is added to the specification tree.

●     If you select the surface directly, 
the Propagation type no longer is 
available, as the complete 
boundary is automatically 
generated. 
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Creating Boundary Curves

 

Provided the generated 
boundary curve is 
continuous, you can still 
select limiting point to 
limit the boundary. 

 

Using the arrows you 
can then invert the 
limited boundary. 

If you select a curve which has an open contour, the Propagation type becomes 
available: choose the No Propagation type and select the curve again. The extremum 
points will define the boundary curve.

 ●     You cannot copy/paste a boundary from a document to another. If you wish to do 
so, you need to copy/paste the surface first into the second document then create 
the boundary.
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Extracting Geometry

 
This task shows how to perform an extract from elements (curves, points, solids, and 
so forth). 

This may be especially useful when a generated element is composed of several non-
connex sub-elements. Using the extract capability you can generate separate elements 
from these sub-elements, without deleting the initial element.
 
Open the Extract1.CATPart document.

 1.  Select an edge or the face of an element.

The selected element is highlighted. 

 
2.  Click the Extract icon .

The Extract Definition dialog 
box is displayed. 

 3.  Choose the Propagation type: 

 

●     Point continuity: the extracted 
element will not have a hole.
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Extracting Geometry

 

●     Tangent continuity: the extracted 
element will be created according to 
tangency conditions. 

●     Curvature continuity: the extracted 
element will be created according to 
curvature conditions.

Define a Curvature Threshold value. 
For a curvature discontinuity: the value 
is a ratio between 0 and 1 which is 
defined as follows:

if ||Rho1-Rho2|| / ||Rho2|| < (1-r)/r 
where Rho1 is the curvature vector on 
one side of the discontinuity, Rho2 the 
curvature vector on the other side, and 
r the ratio specified by the user;
then the discontinuity is smoothed. 

For example, r=1 corresponds to a 
continuous curvature and r=0.98 to the 
model tolerance (default value). A 
great discontinuity will require a low r 
to be taken into account.

The extracted element must be a wire.

This option is only available with 
Generative Shape Design 2, it is not 
available with Wireframe and Surface.

 

●     No propagation: only the selected 
element will be created.
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Extracting Geometry

 4.  Click OK to extract the element.  

 The extracted element (identified as Extract.xxx) is added to the specification tree.
  

When the result of an extract is not connex (during creation or edition) due to naming 
ambiguity, you can now select the part to keep to solve the ambiguity.

 

●     If you extract an edge that you want to 
propagate, and there is an ambiguity 
about the propagation side, a warning 
is issued and you are prompted to 
select a support face. In this case, the 
dialog box dynamically updates and the 
Support field is added.

 ●     The Complementary mode option, 
once checked, highlights, and therefore 
selects,  the elements that were not 
previously selected, while deselecting 
the elements that were explicitly 
selected.

 ●     In the current model, if you select an element using the Tangent or Point continuity 
as the Propagation type, a warning is issued and you have to select No propagation 
instead.

●     If the selected element has a support face and is not a surface, even though the 
Complementary mode option is checked, the Complementary mode will not be taken 
into account for the extraction and the option will therefore be inactive. After the 
extraction, the option will be available again.

●     Check the Federation button to generate groups of elements belonging to the 
resulting extracted element that will be detected together with the pointer when 
selecting one of its sub-elements.  For further information, see Using the Federation 
Capability.

●     Multi-selection is available. Refer to Selecting Using Multi-Output.

●     You cannot copy/paste an extracted element from a document to another. If you 
wish to do so, you need to copy/paste the initial element first into the second 
document then perform the extraction.
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Extracting Geometry
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Trimming Geometry

 Trimming Geometry 

 
This task shows how to trim two surfaces or two wireframe elements.

 
Open the Trim1.CATPart document.

 
1.  Click the Trim icon .

The Trim Definition dialog box 
appears. 

2.  Select the two surfaces or two 
wireframe elements to be trimmed.

A preview of the trimmed 
element appears. You can 
change the portion to be kept 
by selecting that portion.

You can also select the 
portions to be kept by clicking 
the Other side of element 1 
and Other side of element 
2 buttons. 
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Trimming Geometry

3.  Click OK to trim the surfaces or 
wireframe elements.

The trimmed element 
(identified as Trim.xxx) is 
added to the specification 
tree. 

●     You should make your selections by clicking on the portions that you want to keep after 
the trim.

●     Please refer to the Splitting Geometry chapter in the case surfaces intersect face edges. 

In case the elements to be trimmed are tangent, you are advised to use the Elements to 
remove and Elements to keep options to define the portions to be kept or removed.
●     Click in the field of your choice to be able to select the elements in the 3D geometry.

●     Right-click in the field either to clear the selection or display the list of selected 
elements.

Only the selected portion is removed.
All other elements are kept.

Only the selected portions is kept.
All other elements are removed.
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Trimming Geometry

 

●     You can also select a point to define the 
portion to keep or to remove. 

A contextual menu is available on the 
Elements to remove and Elements 
to keep fields.

●     You do not need to select elements to keep if you already selected elements to remove 
and vice-versa.

  

●     When trimming wires (curve, line, sketch and so forth) by another wire, you can select 
a support to define the area that will be kept after trimming the element. It is defined 
by the vectorial product of the normal to the support and the tangent to the trimming 
element.

This is especially recommended when trimming a closed wire.

In our example, the Sketch composed of 
two lines (Sketch.11) is trimmed by the 
circle (Sketch.10).

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugtrimGSD.htm (3 of 4)10/21/2004 5:06:16 AM
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Resulting trimmed element without 
support selection

Resulting trimmed element with support 
selection

●     Check the Result simplification button to allow the system to automatically reduce 
the number of faces in the resulting trim whenever possible.

●     Check the Intersection computation 
button to create a completely 
independent element when performing 
the trimming operation. In that case it 
appears as a separate Intersect.xxx 
element in the specification tree.

●     Uncheck the Automatic extrapolation 
button if you do not want the automatic 
extrapolation of the elements to trim. 
If the Automatic extrapolation 
button is unchecked, an error message 
is issued when the elements to trim 
need to be extrapolated, and the latter 
are highlighted in red in the 3D 
geometry.
 

 

To be able to trim the two surfaces or 
wireframe elements, check the Automatic 
extrapolation button.
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 Rotating Geometry
 
This task shows you how to rotate geometry about an axis.

Open the Transform1.CATPart document.

 
1.  Click the Rotate icon .

 

 The Rotate Definition dialog 
box appears as well as the 
Multi-Selection dialog box 
allowing to perform multi-
selection. 

2.  Select the Element to be rotated.

3.  Select a line as the rotation Axis.

4.  Enter a value or use the drag 
manipulator to specify the rotation 
Angle.

5.  Click OK to create the rotated element.

The element (identified as Rotate.xxx) is added to the specification tree.

●     Use the Creation or Modification checkboxes to modify the translation behavior:
❍     Creation is the default behavior when creating a translated element

❍     Modification enables to modify only the translated element and put the original 
element in no show.
Therefore, if this option is checked, the Hide/Show initial element button and 
Repeat object after OK checkbox are grayed.

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugrotateGSD.htm (1 of 2)10/21/2004 5:06:21 AM

http://pop.dia.uniroma3.it/catia/online/cfysa_C2/samples/Transform1.CATPart


Rotating Geometry

 
●     The original surface is unchanged.

●     Use the Repeat object after OK 
checkbox to create several rotated 
surfaces, each separated from the initial 
surface by a multiple of the Angle 
value.
Simply indicate in the Object Repetition 
dialog box the number of instances that 
should be created and click OK.

 
●     You can select an axis system as the Element to be translated, providing it was 

previously created.

The element is identified as Translate.xxx in the specification tree, 

however the associated icon is the axis system's .

●     You can edit the rotated element's parameters. Refer to Editing Parameters to find 
out how to display these parameters in the 3D geometry.

●     The following capabilities are available: Stacking Commands,  Selecting Using Multi-
Output, Measure Between and Measure Item.
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Translating Geometry

 Translating Geometry
 
This task shows you how to translate one, or more, point, line or surface element.

Open the Translate1.CATPart document.

 
1.  Click the Translate icon .

 The Translate Definition 
dialog box appears as 
well as the Multi-
Selection dialog box 
allowing to perform 
multi-selection.

2.  Select the Element to be translated.

3.  Select the Vector Definition.

Direction, distance

1.  Select a line to 
take its 
orientation as the 
translation 
direction or a 
plane to take its 
normal as the 
translation 
direction.

You can 
also specify 
the 
direction by 
means of X, 
Y, Z vector 
components 
by using 
the 
contextual 
menu on 
the 
Direction 
field. 
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Translating Geometry

2.  Specify the 
translation 
Distance by 
entering a value 
or using the 
spinners.

Point to Point

1.  Select the Start 
point.

2.  Select the End 
point.

Coordinates
1.  Define the X, Y, 

and Z coordinates.
In the example 
besides, we chose 
50mm as X, 0mm 
as Y, and -100 as 
Z.

4.  Click OK to create the translated element.

The element (identified as Translate.xxx) is added to the specification tree.
The original element is unchanged.

  
●     Use the Hide/Show initial element button to hide or show the original element for the translation.

 ●     Use the Repeat object after OK 
checkbox to create several 
translated surfaces, each 
separated from the initial surface 
by a multiple of the Distance 
value.
Simply indicate in the Object 
Repetition dialog box the number 
of instances that should be 
created and click OK.
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●     Use the Creation or Modification checkboxes to modify the translation behavior:
❍     Creation is the default behavior when creating a translated element

❍     Modification enables to modify only the translated element and put the original element in no show.
Therefore, if this option is checked, the Hide/Show initial element button and Repeat object after 
OK checkbox are grayed.

 
●     The elements to be translated are kept next time you enter the command and you change the vector 

definition.

●     You can select an axis system as the Element to be translated, providing it was previously created.
The element is identified as Translate.xxx in the specification tree, however the associated icon is the 

axis system's .

 
Parameters can be edited in the 3D geometry. To have further information, please refer to the Editing 
Parameters chapter.
The following capabilities are available: Stacking Commands, Selecting Using Multi-Output, Measure 
Between and Measure Item.
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 Performing a Symmetry on Geometry 
 
This functionality is P2 for FreeStyle Shaper, Optimizer, and Profiler.

 
This task shows you how to transform geometry by means of a symmetry operation.

Open the Transform1.CATPart document.

 
1.  Click the Symmetry icon .

 

The Symmetry Definition 
dialog box appears as well 
as the Multi-Selection 
dialog box allowing to 
perform multi-selection. 

2.  Select the Element to be transformed by symmetry.

3.  Select a point, line or plane as Reference element.

The figure below illustrates the 
resulting symmetry when the line is 

used as reference element.

The figure below illustrates the resulting 
symmetry when the point is used as reference 

element. 
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Performing a Symmetry on Geometry

4.  Click OK to create the symmetrical element.

The element (identified as Symmetry.xxx) is added to the specification tree.

●     Use the Creation or Modification checkboxes to modify the translation behavior:
❍     Creation is the default behavior when creating a translated element

❍     Modification enables to modify only the translated element and put the original 
element in no show.
Therefore, if this option is checked, the Hide/Show initial element button and 
Repeat object after OK checkbox are grayed.

 
●     The original element is unchanged.

 
●     The following capabilities are available: Stacking Commands and Selecting Using 

Multi-Output.
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Transforming Geometry by Scaling 
 
This task shows you how to transform geometry by means of a scaling operation.

Open the Transform1.CATPart document.

 
1.  Click the Scaling icon .

 The Scaling 
Definition dialog box 
appears as well as 
the Multi-Selection 
dialog box allowing 
to perform multi-
selection. 

2.  Select the Element to be transformed by scaling.

3.  Select the scaling Reference point, plane or planar surface.

4.  Specify the scaling Ratio by entering a value or using the drag manipulator.

The figure below illustrates the 
resulting scaled element when 
the plane is used as reference 

element (ratio = 2).

The figure below illustrates the resulting scaled 
element when the point is used as reference 

element (ratio = 2).

5.  Click OK to create the scaled element.

The element (identified as Scaling.xxx) is added to the specification tree.
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●     Use the Creation or Modification checkboxes to modify the translation behavior:
❍     Creation is the default behavior when creating a translated element

❍     Modification enables to modify only the translated element and put the original 
element in no show.
Therefore, if this option is checked, the Hide/Show initial element button and 
Repeat object after OK checkbox are grayed.

 
●     The original element  is unchanged.

●     Use the Repeat object after 
OK checkbox to create several 
scaled surfaces, each 
separated from the initial 
surface by a multiple of the 
initial  Ratio value.
Simply indicate in the Object 
Repetition dialog box the 
number of instances that 
should be created and click OK.

 
●     The following capabilities are available: Stacking Commands and Selecting Using 

Multi-Output.
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Transforming Geometry by Affinity
 
This task shows you how to transform geometry by means of an affinity operation.

Open the Transform1.CATPart document.

 
1.  Click the Affinity icon .

 

 The Affinity Definition dialog box 
appears as well as the Multi-
Selection dialog box allowing to 
perform multi-selection.

2.  Select the Element to be transformed by affinity.

3.  Specify the characteristics of the Axis system to be used for the affinity 
operation:*

●     the Origin (Point.1 in the figures below)

●     the XY plane (the XY plane in the figures below)

●     the X axis (Line.1 in the figures below).

4.  Specify the affinity Ratios by entering the desired X, Y, Z values.

The figure below illustrates the resulting affinity
with ratios X = 2, Y =1 and Z=1.
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Transforming Geometry by Affinity

The figure below illustrates the resulting affinity
with ratios X = 2, Y =1 and Z=2.

The figure below illustrates the resulting affinity
with ratios X = 2, Y =2.5 and Z=2
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Transforming Geometry by Affinity

5.  Click OK to create the affinity element.

The element (identified as Affinity.xxx) is added to the specification tree.

●     Use the Creation or Modification checkboxes to modify the translation behavior:
❍     Creation is the default behavior when creating a translated element

❍     Modification enables to modify only the translated element and put the original 
element in no show.
Therefore, if this option is checked, the Hide/Show initial element button and 
Repeat object after OK checkbox are grayed.

●     The original element is unchanged.

●     The following capabilities are available: Stacking Commands and Selecting Using 
Multi-Output.
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Transforming Elements
From an Axis to Another

 This task shows you how to transform geometry positioned according to a given axis 
system into a new axis system. The geometry is duplicated and positioned according 
to the new axis system. One or more elements can be transformed at a time, using 
the standard multi-selection capabilities.
See also Defining an Axis System.

Open the Transform2.CATPart document.

 
1.  Click the Axis To Axis icon .

 The Axis to Axis Definition dialog 
box appears as well as the Multi-
Selection dialog box allowing to 
perform multi-selection.

2.  Select the Element to be transformed 
into a new axis system.
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Transforming Elements From an Axis to Another

3.  Select the initial (Reference) axis 
system, that is the current one.

4.  Select the Target axis system, that is 
the one into the element should be 
positioned.

5.  Click OK to create the transformed element.
New geometry is now positioned into the new axis system.

The element (identified as Axis to axis transformation.xxx) is added to the 
specification tree.
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Transforming Elements From an Axis to Another

●     Use the Creation or Modification checkboxes to modify the translation behavior:
❍     Creation is the default behavior when creating a translated element

❍     Modification enables to modify only the translated element and put the original 
element in no show.
Therefore, if this option is checked, the Hide/Show initial element button and 
Repeat object after OK checkbox are grayed.

●     You can choose to display only the elements resulting from the transformation using 
the Hide/Show Initial Element button.

●     Use the contextual menus on the dialog box fields to create elements as needed.

●     A contextual menu is also available to manage the list of selected elements.

The following capabilities are also available: Stacking Commands and Selecting Using 
Multi-Output.
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Creating the Nearest Entity
of a Multiple Element

 
This task shows you how to create the nearest entity of an element that is made up 
from several sub-elements.

 
Open the Near1.CATPart document.

 1.  Select the Insert -> 
Operations -> Near  
command.

The Near Definition 
dialog box appears. 

2.  Select the element that is made up from several sub-elements.

3.  Select a reference element whose position is close to the sub-element that you 
want to create.

This example shows a parallel curve 
comprising three sub-elements.

This example shows the sub-element that is 
nearest to the reference point.

4.  Click OK to create the element.

This element (identified as Near.xxx) is added to the specification tree.
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Nearest Sub-element

 The Near Definition dialog box is automatically displayed, when a non-connex element 
is detected at creation time so that you can directly choose which element should be 
created.

 
 

[ Back ] [ Up ] [ Next ]
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Extrapolating Curves

Extrapolating Curves
 
This task shows you how to extrapolate a curve.

 
Open the Extrapolate2.CATPart document.

 
1.  Click the Extrapolate icon .

The Extrapolate Definition 
dialog box appears. 

2.  Select an endpoint on  a curve.

3.  Select the curve to be Extrapolated:

●     entering the value of the extrapolation Length.
In Curvature mode, this length actually is the distance on the tangent 
extrapolation at which a plane normal to the curve is located. This plane is used to 
split the extrapolated curve.

●     selecting a limit surface or plane.

4.  Specify Continuity conditions:

●     Tangent: the extrapolation side is tangent to the curve at the selected endpoint.

●     Curvature: the extrapolation side complies with the curvature of the selected 
curve.
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Extrapolating Curves

Extrapolation in Curvature mode Extrapolation in Tangent mode

If needed, and provided you are working in with a tangency continuity, and the  initial 
curve lies on a plane or surface, you can select this support. In this case the 
extrapolated curve lies on the surface too, and is relimited by the support boundary.

Extrapolation without support Extrapolation with a support

 

5.  Click OK to create the extrapolated curve.

The Curve (identified as Extrapol.xxx) is added to the specification tree.
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Extrapolating Surfaces
 
This task shows you how to extrapolate a surface boundary.

 
Open the Extrapolate1.CATPart document.

1.  Click the Extrapolate icon .

The Extrapolate Definition dialog box 
appears.

2.  Select a surface Boundary.

3.  Select the surface to be Extrapolated.

4.  Specify the Limit of the extrapolation by either:

●     entering the value of the extrapolation length

●     selecting a limit surface or plane

●     using the manipulators in the geometry.

5.  Specify the Continuity type:

●     Tangent

●     Curvature

Tangent Curvature
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6.  Specify Extremities conditions between the extrapolated surface and the support surface. 

●     Tangent: the extrapolation sides are tangent to the edges adjacent to the surface boundary.

●     Normal: the extrapolation sides are normal to the original surface boundary.

Tangent Normal

7.  Select the Tangency propagation type to 
propagate the extrapolation to the boundary's 
adjacent edges.

8.  Select the Assemble result check box if you want the extrapolated surface to be assembled to the support 
surface.

9.  Click OK to create the extrapolated surface.

The surface (identified as Extrapol.xxx) is added to the 
specification tree.

The Internal Edges option enables to determine a privileged direction for the extrapolation. You can select one or 
more edges (in the following example we selected the edge of Surface.1) that will be extrapolated in tangency. You 
can also select a vertex once you have selected an edge in order to give an orientation to the extrapolation.

You can only select edges in contact with the boundary.
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No edges selected One selected edge

The Internal Edge option is only available with the Generative Shape Design product but not with the Wireframe and 
Surface product.

You can extrapolate several elements at a time. In this case, refer to Editing a List of Elements to find out how to 
display and manage the list of selected elements.

The Up to element Type, the Extremities, Internal Edges, and Assemble result options are not available with 
the Curvature continuity type.

 

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugextrapolsurfaces.htm (3 of 3)10/21/2004 5:07:29 AM



Inverting the Orientation of Geometry

Inverting the Orientation of Geometry 
 
This task shows you how to easily invert the orientation of a surface or curve.

 
Open any document containing wireframe or surface type element.

 
1.  Select the Insert -> Operations ->  Invert Orientation... command.

2.  Select the surface or curve whose 
orientation is to be inverted.
An arrow is displayed on the geometry 
indicating the orientation of the element 
and the Invert Definition dialog box is 
displayed.

2.  Click the arrow to invert the orientation of the element, or click the Click to 
Invert button.

3.  Click OK to accept the inverted element.

The element (identified as Inverse.xxx) is added to the specification tree.

 Once the orientation is inverted, the Click to Invert button changes to Reset Initial 
whether you changed the orientation using the button itself, or the arrow.
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Using Tools

Using Tools
The Wireframe and Surfaces workbench provides powerful tools to help you manage your 
surfaces and wireframe geometry. 

Display Parents and Children: Select the feature under 
study, the Tools -> Parent / Children... command and 
use the diverse contextual commands to display parents 
and children.
Scan the part and define local objects: Select the the Edit -
> Scan or Define in Work Object... command, click the 
buttons to move from one local feature to the other, then 
the Exit button.

Update your design: select the element and click the icon 
or use the contextual menu
 Define an axis-system: set the origin and X, Y, and Z 
directions

Work with a support: click the icon and select a plane or 
surface as support element.

 Snap on a point: snap to the nearest intersection point 
when working with a support 

Create Datums: click the icon to deactivate the History 
mode

Create constraints: select the element to be constrained, 
and set the specific options.

Edit geometry: double-click on the element in the tree and 
modify its parameters 

Create elements from an external file: key in space 
coordinates of elements into an Excel file containing 
macros, then run the macro.

Select implicit elements: Press and hold the Shift key while 
clicking the element to which the implicit element belongs.

 Copy and paste: select the element(s) to be copied, click 
the Copy icon, select the target Open Body, then click the 
Paste icon.

Delete geometry: select the element, choose the Delete 
command, set the deletion options

Manage open bodies: select an open body in the 
specification tree, use the Insert -> Open Body menu 
command, or Remove Open Body or Change body 
contextual menus.
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Show/Hide open bodies or their contents: right-click an 
open body and use the Hide/show contextual command, or 
use the Hide/Show contextual command on a specific 
element while another command is running. 

Check connections between surfaces: select the surfaces, 
and set the analysis type and parameters

 Check connections between curves: select two curves, 
specify the type of analysis (distance, tangency, 
curvature) and set the analysis parameters.
Repeat objects: select an object, choose the Object 
Repetition...menu item and key in the number of object 
instances
Stack commands: right-click an editable field, choose the 
contextual menu item allowing the creation of another 
element.

 
Edit parameters: Select xxx1.object -> Edit Parameters 
from the contextual menu and modify the parameters.

 
Select using multi-selection: select one or more elements 
through the Multi-Selection dialog box and validate you 
modification to return to the current command
Select Using multi-output: select several elements, click 
OK. The Multi Output feature appears in the specification 
tree, grouping elements
Analyze using parameterization: select the Tools -> 
Parameterization Analysis... command and define a 
filter for your query

Apply a material: select an object, click the icon, and 
select a material.

 
[ Back ] [ Up ]

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/wfsugbt0300.htm (2 of 2)10/21/2004 5:07:49 AM

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugparameterization.htm


Parents and Children

Parents and Children
 The Parent and Children command enables you to view the genealogical relationships 
between the different components of a part.  

It also shows links to external references and explicitly provides the name of the 
documents containing these references.

If the specification tree already lets you see the operations you performed and re-
specify your design, the graph displayed by the Parent and Children capability proves to 
be a more accurate analysis tool. We recommend the use of this command before 
deleting any feature.

 Open the Parent_R9.CATPart document.

 1. Select the feature of interest, that is Pad1.
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Parents and Children

2. Select the Tools -> Parent/Children... command (or the Parent/Children... 
contextual command). 

A window appears containing a graph. This graph shows the relationships between 
the different elements constituting the pad previously selected.

 If you cannot see the element of interest in the specification tree because you have 
created a large number of elements, right-click this element in the graph then select 
the Center Graph contextual command: the element will be more visible in the 
specification tree.

3. Position the cursor on Pad 1 and select the Show All Children contextual 
command.  

You can now see that Sketch 2 and Sketch 3 have been used to create two 
additional pads.

Here is the exhaustive list of the diverse contextual commands allowing you to hide 
parents and children. These commands may prove quite useful whenever the view is 
overcrowded. 
●     Show Parents and Children

●     Show Children

●     Show All Children

●     Hide Children

●     Show Parents

●     Show All Parents

●     Hide Parents

 4. Position the cursor on Sketch.1 and select the Show Parents and Children 
contextual command. 

We can see that Sketch.1 has been created on xy plane. 
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Parents and Children

 Moreover, you can see that it is a published element.

5. Now, select EdgeFillet1 in the graph.

The application highlights the fillet in the specification tree, in the graph and in the 
geometry area.

6.Position the cursor on EdgeFillet1 and select the Show Parents and Children 
contextual command.

The parent Pad.1 is displayed.

 
●     Double-clicking on the components alternately shows or hides parents and children.

 

  
●     The Edit contextual command can be accessed from any element. For example, right-

click EdgeFillet.1 and select Edit. The Edge Fillet dialog box appears. You can then 
modify the fillet. When done, the  Edge Fillet dialog box closes as well as the Parents 
and Children window close and the fillet is updated.

 
7.

Close the window and select MeasureEdge3 from the specification tree.
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Parents and Children

 8.Select the Tools -> Parent/Children... command.

The graph that displays shows Pad.2 as MeasureEdge3's parent.

 

 

9.Select the Show All Parents contextual command.

Sketch.2 as Pad.2's parent is now displayed. In turn, Sketch.2's own parent Pad.1 
is displayed and so on.
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Updating Your Design
 This task explains how and when you should update your design.

The point of updating your design is to make the application take your last operation 
into account. Indeed some changes to geometry or a constraint may require 
rebuilding the part. To warn you that an update is needed, CATIA displays the update 
symbol next to the part name and displays the corresponding geometry in bright red.

To update a part, the application provides two update modes: 
●     automatic update, available in Tools -> Options -> Shape, General tab. If 

checked, this option lets the application update the part when needed.

●     manual update, available in Tools -> Options -> Shape, General tab, it lets 

you control the updates of your part. You simply need to click the Update icon  

whenever you wish to integrate modifications. 

 
1.  To update the part, click the Update icon .

A progression bar indicates the evolution of the operation. 

 

You can cancel the undergoing update by clicking the Cancel button available in the 
Updating... dialog box.
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Updating Your Design

●     Keep in mind that some operations such as confirming the creation of features 
(clicking OK) do not require you to use the update command. By default, the 
application automatically updates the operation.

●     The Update capability is also available via Edit -> Update and the Update 
contextual command. 

●     To update the feature of your choice, just select that feature and use the Local  
Update contextual command.

●     Besides the update modes, you can also choose to visualize the update on the 
geometry as it is happening by checking the Activate Local Visualization option 
from the Tools -> Options -> Shape, General tab.

In this case, as soon as you have clicked the Update icon :

1.  the geometry disappears from the screen
2.  each element is displayed as it is updated, including elements in 

No Show mode. Once they have been updated, they remain in No 
Show mode.

Interrupting Updates
 This task explains how to update a part and interrupt the update operation on a given 
feature by means of a useful message you previously defined.

 Open any document containing geometric elements.

 1.  Right-click an element from the specification tree and choose the Properties 
contextual menu item.

The Properties dialog box is displayed. 

2.  From the Mechanical tab, check the Associate stop update option.
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Updating Your Design

3.  Enter the text to be displayed when the updating process will stop when 
reaching this element.

4.  Click OK to confirm and close the dialog box.

The Stop Update.1 feature is displayed in the 
specification tree, below the element for which it 
was defined.

5.  Whenever it is needed, click the Update icon  to update the whole part.

The updating process stops after having updated the element selected 
above, and issues the message as has been defined earlier:

6.  Click Yes or No, depending on what you intend to do with the geometry created 
based on the selected element.

 Would you no longer need this capability, you can: 
●     right-click the element for which the stop was defined, choose the Properties 

contextual command and check the Deactivate stop update option from the 
Mechanical tab: the update will no longer at this element.
You notice that when the capability is deactivated, the Stop Update icon changes 
to:  in the specification tree.

●     right-click Stop Update.1 from the specification tree, and choose the Delete 
contextual command.
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Defining an Axis System
This task explains how to define a new three-axis system locally. There are two ways 
of defining it: either by selecting geometry or by entering coordinates.

Open the PowerCopyStart1.CATPart document.

1.  Select the Insert -> Axis System  
command or click the Axis System 

icon .

The Axis System Definition dialog 
box is displayed.

An axis system is composed of an origin point and three orthogonal axes.
It can be right or left-handed. This information is displayed within the Axis System 
Definition dialog box.
You can choose from different types of axis system: 

●     Standard: defined by a point of origin and 
three orthogonal directions (by default the 
current directions of the compass)

Here only the point was selected and nothing 
specified for the axes.
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●     Axis rotation: defined as a standard axis 
system and a angle computed from a 
selected reference

Here the Y axis was set to the standard axis 
system Y axis, and a 15 degrees angle was set 
in relation to an edge parallel to the X axis.

      

●     Euler angles: defined by three angle values 
computed from the initial X, Y, and Z 
directions

Here, the Angle 2 and Angle 3 were set to 30 
degrees. 

2.  Select the point as shown to position the origin of the axis system you wish to 
create. The application then computes the remaining coordinates. Both 
computed axes are then parallel to those of the current system. The axis system 
looks like this:
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Defining an Axis System

3.  If you are not satisfied with x axis, for instance click the X axis field and select a 
line to define a new direction for x axis.

The x axis becomes colinear with this line.

●     It can be a line created along the surface 
edge, for example, using the Create Line 
contextual menu on the selection field, and 
selecting two surface vertices.
Similarly you can create Points, and Planes.

●     You can also select the Rotation contextual 
menu, and enter an angle value in the X Axis 
Rotation dialog box.

4.  Click the y axis in the geometry to reverse it.
Checking the Reverse button next to the Y Axis field reverses its direction too.
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5.  You can also define axes through 
coordinates. Right-click the Z Axis field 
and select the Coordinates contextual 
command. The Z Axis dialog box appears.

6.  Key in X = -1, retain the Y and Z 
coordinates, and click Close.

The axis system is modified 
accordingly, and is now left-handed.

7.  Click More to display the More... dialog box.

The first rows contains the coordinates of the origin point. The coordinates 
of X axis are displayed in the second row. The coordinates of Y and Z axis 
are displayed in the third and fourth row respectively.

As you are defining your axis system, the application detects if its axes are orthogonal 
or not. Inconsistencies are revealed via the Update diagnosis dialog box.
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8.  Uncheck the Current option if you do not want to set your axis as the reference. 
The absolute axis at the bottom right of the document then becomes the current 
three axis system.

9.  Click OK.

The axis system is created. It is displayed in the 
specification tree. 
When it is set as current, it is highlighted as 
shown aside.
If you create a point using the coordinates method and an axis system is already 
defined and set as current, the point's coordinates are defined according to current the 
axis system. As a consequence, the point's coordinates are not displayed in the 
specification tree.
Local axes are fixed. If you wish to constrain them, you need to isolate them (using 
Isolate contextual command) before setting constraints otherwise you would obtain 
over-constrained systems.
 The display mode of the axes is different depending on whether the three-axis system 
is  right-handed or left-handed and current or not. 

THREE-AXIS SYSTEM CURRENT AXIS DISPLAY MODE

right-handed yes solid

right-handed no dashed

left-handed yes dotted

left-handed no dot-dashed
 Right-click Axis System.1 from the specification tree and select the Axis System.1 
object -> Set as current contextual command. Axis System.1 is now current. You 
can then select one of its plane, to define a sketch plane for example.

Editing an Axis System

You can edit your axis system by double-clicking it and entering new values in the 
dialog box that appears. You can also use the compass to edit your axis system. 

Note that editing the geometrical elements selected for defining the axes or the origin 
point affects the definition of the axis system accordingly.

Right-clicking Axis System.Xobject in the specification tree lets you access the 
following contextual commands:
●     Definition...:redefines the axis system

●     Isolate: sets the axis system apart from the geometry

●     Set as Current/Set as not Current: defines whether the axis system is the reference 
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or not.
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Working with a Support
 This task shows how to create a support. It may be either a plane or a surface.
This will allow you to automatically reference a surface or plane as the supporting 
element whenever you need one, when creating Lines for example. You will no longer 
have to explicitly select the support element.
It will also allow you to create reference points on the fly on the support, whenever 
you need a reference point to create other geometric elements.

Open the WorkOnSupport1.CATPart document.

Creating a support from a 
surface

 1.  Click the Work on Support 

icon  .

The Work on Support 
dialog box appears. 

2.  Select the surface to be used as support element.

If a plane is selected, a grid is displayed to facilitate visualization. 

3.  Select a point.

By default the surface's 
midpoint is selected.

4.  Click OK in the dialog box. 

The element (identified as WorkingSupport.xxx) is added to the specification tree.
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5.  Click the Point icon  .

The Point definition 
dialog box is displayed. 
The Reference Point field 
is automatically filled in 
with the point selected 
when defining the 
currently active working 
support.

Creating a support from a plane
 

1.  Click the Work on Support icon  .

2.  Select the plane to be used as support element.

The Work on Support dialog box is displayed, allowing you to define the 
plane: 
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By default, the Grid type is set to Cartesian, to define a Cartesian plane.

A grid can also be displayed to facilitate visualization. You can hide it by checking the 
Hide grid option.

3.  Select a point, as the support plane's origin.

By default the plane's origin is selected. Beware of the plane representation not being 
located at the plane's origin. In this case, the default point, really is displayed at the 
origin and therefore not necessarily onto the plane representation.

4.  Define the First direction scale (H for horizontal), by setting Primary spacing 
and Graduations values.

5.  If needed, select a direction to specify the H direction.
You can right-click in the editable field to display the contextual menu and 
define the direction (by defining its vector, creating a line, and so forth).

6.  If you wish, you can define another scale for the Second direction scale (V for 
vertical), thus allowing distortions of the grid. Check the Allow distortions 
option to activate the Primary spacing and Graduations fields of the second 
direction.

7.  Check the Shade grid plane option to visualize the support plane as a solid 
geometric element.
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This is possible only if the View mode is adequate.

8.  Check the Position grid plane parallel to screen to reset the grid 
visualization parallel to the screen.

9.  Click OK in the dialog box. 

The element (identified as WorkingSupport.xxx) is added to the specification 
tree.

By default the last created working 
support is displayed in red in the 
specification tree.
Use the Set As Current/Set As Not 
Current contextual menu, or the  

Working Supports Activity  

icon, to define which is the default 
current support that will be 
automatically selected when entering 
a command that requires a working 
support.
Use the Get Features on Support contextual menu on the working support features 
to retrieve the features created from a single or a multi-selection works on support. 
As a result, the retrieved features are selected in the current editor and highlighted in 
the specification tree, therefore allowing you to use them more easily. 

 

●     Regardless of the type of working support created (surface or plane) once you 
choose to work on the support, you can directly click onto the support to create 
points. This capability is available with commands such as point, line, spline, and 
polyline, and most commands where you need to select point as inputs.

●     Working supports can be edited, updated, or deleted just as any other feature.

●     Click the Snap to point  icon to snap the point being created onto the nearest 

intersection point on the grid.

●     Features created using a support 
are now aggregated under the 
parent command that created them 
and put in no show in the 
specification tree.
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Creating Datums 
 This task shows how to create geometry with the History mode deactivated.
 In this case, when you create an element, there are no links to the other entities that 
were used to create that element.

1.  Click the Create Datum icon  to deactivate the History mode.

It will remain deactivated until you click on the icon again. 

If you double-click this icon, the Datum mode is permanent. You only 
have to click again the icon to deactivate the mode. 

A click on the icon activates the Datum mode for the current or the next 
command. 

 
The History mode (active or inactive) will remain fixed from one session to another: it 
is in fact a setting.
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Creating Constraints

This task shows how to set geometric constraints on geometric elements. 

Such a constraint  forces a limitation. For example, a geometric constraint might 
require that two lines be parallel. 

 
To set a constraint between elements:

1.  Multi-select the 
two or three 
elements to be 
constrained.

2.  Click the 
Constraint with 
dialog box icon 

 . 

The Constraint 
Definition dialog box 
appears indicating the 
types of constraint you 
can set between the 
selected elements.  

3.  Select an available option to specify that the corresponding constraint is to be 
made.

4.  Click OK.

The corresponding constraint symbol appears on the geometry.

 
 
To set a geometric constraint on a single element:
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1.  Select the 
element to be 
constrained.

2.  Click the 
Constraint icon 

.

The corresponding 
constraint symbol 
appears on the 
geometry.
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Editing Surface and Wireframe Definitions
 
This task shows how to edit the definition of an already created geometric element.

 1.  Activate the Definition dialog box of the element that you want to edit in one of 
the following ways:

●     Select the element then choose the xxx.object -> Definition 
command from the contextual menu

●     Select the element then choose the Edit -> xxx.object -> Definition 
command

●     Double-click on the element identifier in the specification tree.

2.  Modify the definition of the element by selecting new reference elements or by 
entering new values.

3.  Click OK to save the new definition. 
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Selecting Implicit Elements

Selecting Implicit Elements
 There are many ways of selecting geometrical elements, either in the geometry as 
described in the Infrastructure User's Guide,  Selecting Objects section, or in the 
specification tree. 

However, specific to wireframe and surface elements are some implicit elements, such 
as the axis of a cylinder, or the vertex of a cone for example,  participating in the 
creation of a feature yet not directly selectable as a separate element.

This task shows how to select these implicit elements.
 
Open the Cylinder1.CATPart document.

 
1.  Click the Spline icon  

and successively select 
the four points.

The Spline 
Definition dialog 
box looks like this:

2.  Select Point.3 from the list, to impose a tangency constraint on this point. 

Note that you cannot select the cylinder's surface. 
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Selecting Implicit Elements

3.  Press and hold the Shift 
key, then move the 
pointer over the cylinder. 
The cylinder's axis is 
automatically detected as 
a selectable element to 
indicate a direction, and 
displayed.

4.  Click anywhere on the 
cylinder's surface, still 
holding the Shift key 
pressed down.

The tangency 
constraint 
direction, based on 
the cylinder's axis, 
is displayed at the 
selected point.

5.  Click OK to create the 
spline tangent to the 
cylinder at the selected 
point.
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Creating Elements From An External File

Creating Elements From An External File

You can create points, curves, and lofted surfaces from a Microsoft ®  Excel 
spreadsheet containing macros, and in which you define: 

●     the points space coordinates

●     the points through which the curves pass

●     the curves used as profiles for the lofted surface

Only Excel sheets created with Excel 97 and subsequent versions are supported.
Therefore this capability is available with WindowsTM only.

Open any .CATPart document containing an Open Body (automatically created when 
entering the Wireframe and Surface Design workbench).

1.  Open the PointSplineLoftFromExcel.xls file from the Samples directory into 
Excel, and enable the macros.

The document looks like this:
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Creating Elements From An External File

It contains: 
●     instructions, such as StartLoft and EndLoft, StartCurve and EndCurve between 

which other instructions or numerical data are given. 

●     numerical data that are point space coordinates: X, Y, Z respectively from the left to 
the right

●     a final End instruction

In the above example, a loft is to be created based on three curves. The first and 
second curve pass through four points, and the third curve passes through five points.

The elements will be created from top to bottom, i.e. the four points of the first curve 
will be created, then the curve itself, then the points making up the second curve and 
the latter itself, and so forth.

You can add rows to create more elements or delete rows to edit elements or delete 
them (point), then save the spreadsheet.
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Creating Elements From An External File

2.  From Excel, 
select the Tools 
-> Macro -> 
Macros menu 
item.

The Macro 
dialog box 
is 
displayed. 

3.  Select the  
Feuil1.Main 
macro and click 
Run. 

The User Info dialog 
box is displayed. 

4.  Key in the type of element to be generated: 

●     1: to generate only the point(s)

●     2: to generate the points and the curve(s)

●     3: to generate the points, curves and lofted surface(s)

5.  Click OK.

The elements (points, curves, and lofted surface) are created in the 
geometry. The specification tree is updated accordingly. 
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The Wireframe and Surface workbench needs not to be loaded, provided a CATIA 
session is running and a .CATPart document is loaded.
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Copying and Pasting

Copying and Pasting
 
This task shows how to copy and paste open body entities in your part design.

 1.  Select the elements that you want to copy either directly in the part geometry 
or in the specification tree.

2.  Select the Edit > Copy command.

3.  Click the Open Body entity in the tree where you want to paste the selected 
elements.

4.  Select the Edit > Paste command.
The elements are then copied into the target Open Body.

●     The identifiers of copied elements are incremented with respect to the original 
elements.

●     The original elements and copied elements can be edited independently.

●     A few elements cannot be copied/pasted as such. They need their parent element 
to be copied as well. This is the case with boundaries, and extracts, for example.
In this case, you may also consider using PowerCopies.
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Deleting Geometry

Deleting Surfaces and Wireframe Geometry
 
This task shows how to delete geometry from your design.

1.  Select the entity you want to 
delete. 

2.  Select the Delete command 
either from the the Edit menu 
or the contextual menu.

The Delete dialog box 
appears. 

3.  Set your desired options for managing the deletion of Parent and Child entities.

Two options are available: 

1.  Delete exclusive parents: deletes the geometry on  which the 
element was created. This geometry can be deleted only if it is 
exclusively used for the selected element

2.  Delete all children: deletes the geometry based upon the 
element to be deleted, in other words, dependent elements

4.  Click OK to confirm the deletion.
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Managing Open Bodies

Managing Open Bodies 
in the Specification Tree

 This task shows how to manage the specification tree. This involves:

●     inserting open body entities

●     removing open body entities

●     changing body

An open body enables to reorganize the specification tree when it becomes too 
complex or too long. You can put any element you wish in the open body, it does not 
have to be structured in a logical way.

●     You can insert and manipulate open bodies in the specification tree in much the 
same way as you manage files in folders.

●     These management functions have no impact on the part geometry.

●     You should refer to the Copying and Pasting section for information about how open 
bodies can be used in a part edition context.

●     When loading the Generative Shape Design workbench, an Open Body 
automatically becomes the current body. 
This also means that only the results of the Part Body, i.e. the result of all the 
operations performed on geometry, is visible and not any intermediate state of the 
Part Body.

Open any .CATPart document containing OpenBodies.
You can also open the OpenBodies1.CATPart document.

Inserting an Open Body

1.  In the specification tree, select the branch of your choice. 
This branch will be considered as a child of the new open body and can be an 
open body or a feature.
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Managing Open Bodies

2.  Select the Insert -> Open Body menu command.

The result is immediate. CATIA displays this new Open_body.x, 
incrementing its name in relation to the pre-existing bodies, in the 
specification tree. It is underlined, indicating that it is the active open 
body.

Removing an Open Body
This is only possible when the father location of the open body is another open body.

1.  Right-click the desired open body then select the Remove Open Body 
contextual command.
The open body is removed and its constituent entities are included in the father 
open body.

Moving an open body to a new body

1.  Right-click the desired open body in the 
specification tree and select the Change Body 
command from the contextual menu.
The Change Body dialog box appears.

2.  Select the new body where the open body is to 
be located.

3.  Click OK to move the open body to the new 
body.
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Hiding/Showing Open Bodies

Hiding/Showing Open Bodies
and Their Contents

 This task shows how to use the Hide/Show command on different level of open bodies 
and for different purposes. Indeed you can:  
●     hide/show complete open bodies

●     hide/show contextually on any element making up the open body

Open any .CATPart document containing OpenBodies.
You can also open the OpenBodies1.CATPart document.

Hiding/Showing an Open Body

1.  In the specification tree, select the open body you wish to hide/show

2.  Right-click to display the contextual menu and choose the Hide/show command.

The open body is hidden, if it was visible, or becomes visible, if it was hidden.

Visible open body Hidden open body

Hiding or Showing an open body as a whole can also be done using the Hide/Show 

 icon.

 
Hiding/Showing Contents of an Open Body
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Hiding/Showing Open Bodies

 This contextual menu allows you to hide/show all features in an open body (even 
sketches), whether current or not.

1.  In the specification tree, 
select the open body whose 
solid elements you want to 
hide/show.

2.  Right-click and choose 
Open_Body.x object -> 
Show components 
contextual command to 
restore the view if the 
elements were hidden, or 
Open_Body.x object -> 
Hide components contextual 
command to hide visible 
elements. 

Visible contents Hidden contents

It is advised to use this method to hide contents of an open body, rather than using 
the Hide/Show contextual command: indeed when a body is in show, its contents 
are as well. This method enables to quickly show an element of an open body.

      

Hiding or Showing an open body as a whole can also be done using the Hide/Show 

 icon.

Hiding/Showing an 
element of an Open Body
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This contextual menu allows you to 
hide/show an element of the current 
body, while using a command:

1.  Click the Line icon  and 

select two points to create a 
line.

2.  Right-click the element to be 
hidden from the specification 
tree or the geometry, and 
choose the Hide/Show 
contextual command.

The selected element is 
hidden without exiting 
the currently active 
command.

3.  Click OK in the Line dialog box 
to create the line.

Repeat the operation on the element again to re-display it.
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Checking Connections Between Surfaces

Checking Connections Between Surfaces

This task shows how to analyze how two surfaces are connected, following a blend, 
match, or fill operation for example.
Three types of analyses are available.

❍     Distance: the values are expressed in millimeters

❍     Tangency: the values are expressed in degrees

❍     Curvature: the values are expressed in percentage.

Open the ConnectChecker1.CATPart document.

1.  Select both surfaces to be 
analyzed.

2.  Click the Connect 

Checker icon  in the 

Shape Analysis toolbar.

The Connect 
Checker dialog box 
is displayed as well 
as another dialog 
box showing the 
color scale and 
identifying the 
maximum and 
minimum values 
for the analysis 
type. 
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Checking Connections Between Surfaces

Check the Internal edges option if you want to analyse the internal connections
By default, the check box is unchecked.

  

 

3.  Choose the analysis type to be performed: Distance, Tangency or Curvature.

4.  Set the Maximum gap above which no analysis will be performed. All elements 
apart from a greater value than specified in this field are considered as not being 
connected, therefore do not need to be analyzed.
Be careful not to set a Maximum gap greater than the size of the smallest 
surface present in the document.
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Checking Connections Between Surfaces

5.  Check the analysis results 
on the geometry.

Here we are 
analyzing the 
distance between 
the surfaces. Each 
color section 
indicates on the 
geometry the 
distance between 
the surfaces.

From the Connect Checker dialog box, you can choose a number of visualization and 
computation options: 
●     the comb: that is the spikes corresponding to the distance in each point

●     the envelope: that is the curve connecting all spikes together

●     Information: that is the minimum and maximum values

Finally, the scaling option lets you define the visualization of the comb. In 
automatic mode the comb size is zoom-independent and always visible on 
the screen, otherwise you can define a coefficient multiplying the comb 
exact value.

6.  Check the Information 
button:

Two texts are 
displayed on the 
geometry localizing 
the minimum and 
maximum values of 
the analysis as 
given in the 
Connect Checker 
dialog box.
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Checking Connections Between Surfaces

You can also 
choose the 
discretization, that 
is the numbers of 
spikes in the comb 
(check the Comb 
option to see the 
difference):

●     Coarse: 15 
spikes are 
displayed

●     Medium: 30 
spikes are 
displayed

●     Fine: 45 spikes 
are displayed.

The Full result is only available with the Generative Shape Design product. 

The number of selected elements and the number of detected connections are 
displayed below the color range.

7.  Click the Quick... button 
to obtain a simplified 
analysis taking into 
account tolerances (either 
distance, tangency, or 
curvature).

The comb is no 
longer displayed.
The Connect 
Checker dialog box 
changes to this 
dialog box.

You can use the 
check button to 
switch from one 
analysis type to 
another.
The Maximum 
gap and 
information are 
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Checking Connections Between Surfaces

retained from the 
full analysis.
The maximum 
deviation value is 
also displayed on 
the geometry.

You can check the Overlapping button to highlight  where, on the 
common boundary, the two surfaces overlap. In this case the other 
analysis types are deactivated.

In P1 mode, only the quick analysis is available.

8.  Use the spinners to 
define the tolerances.

For example, the 
red area indicates 
all points that are 
distant of more 
than 0.1 mm.

The maximum 
deviation values on 
the current 
geometry are 
displayed to the 
right of the dialog 
box.

9.  Click OK to create the analysis.

The analysis (identified as Surface Connection Analysis.x) is added to the 
specification tree (P2 only).

This allows the automatic update of the analysis when you modify any of 
the surfaces, using the control points for example.
If you do not wish to create the analysis, simply click Cancel.
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●     You can edit the color range in both dialog boxes by double-clicking the color range 
manipulators (Connect Checker) or color areas (Quick Violation Analysis) to display 
the Color chooser.

●     If you wish to edit the Connection Analysis, simply double-click it from the 
specification tree.

●     If you no longer need the Connection Analysis, right-click Connection Analysis in 
the specification tree, and choose Delete.

●     The curvature difference is calculated with the following formula:

(|C2 -  C1|) / ((|C1 + C2|) / 2)

The result of this formula is between 0% et 200%.

●     You can analyze internal 
edges of a surfacic element, 
such as a Join for example, 
by selecting only one of the 
initial elements:

●     You can create an analysis on an entire open body simply by selecting it in the 
specification tree.
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Checking Connections Between Curves

Checking Connections Between Curves
This task shows how to analyze how two curves are connected, following a blend, or 
match operation for example.
Four types of analyses are available.

❍     Distance: the values are expressed in millimeters

❍     Tangency: the values are expressed in degrees

❍     Curvature: the values are expressed in percentage

❍     Overlapping: the system detects overlapping curves

Open the ConnectChecker2.CATPart document.

1.  Select both curves to be 
analyzed.

2.  Click the Curve Connect 

Checker icon  in the 

Shape Analysis toolbar.

The Connect 
Checker dialog box 
is displayed. At the 
same time a text is 
displayed on the 
geometry, 
indicating the value 
of the connection 
deviation.

You can choose the 
type of analysis to 
be performed using 
the combo: 
distance, tangency 
or curvature.

 

In P1 mode, only this mode is available (no quick mode available).
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This step is P2 only for 
Wireframe and Surface. 

3.  Press the Quick button.

The dialog box 
changes along with 
the text on the 
geometry.. 
With our example, 
the text in the 
geometry 
disappears because 
the distance 
between the two 
curves is smaller 
than the set 
Distance value.

4.  Check the Tangency 
button:

A text is displayed 
on a green 
background (as 
defined by default 
for the Tangency 
criterion) to 
indicate that the 
Tangency criterion 
is not respected, 
because the first 
text displayed is 
the one for which 
the set tolerance is 
not complied with. 
You can then 
increase the 
Tangency value, or 
modify the 
geometry to 
comply with your 
needs. 
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5.  Similarly, if you check the 
Curvature value, the 
displayed text indicates 
that the curvature 
between the two 
analyzed curves is 
greater than the set 
value.

6.  Modify the tolerance 
values, or the geometry 
to comply with the 
tolerances. 

For example, if you 
modify the Tangency 
value to set it to 16 
degrees, the geometry 
instantly reflects the 
compliance with the new 
value. 

The maximum deviation values on the current geometry are displayed to the right of 
the dialog box.

7.  Click OK to create the analysis.

The analysis (identified as Curve Connection Analysis.x) is added to the 
specification tree.
This allows the automatic update of the analysis when you modify any of 
the curves, using the control points for example (see Editing Curves Using 
Control Points).
If you do not wish to create the analysis, simply click Cancel.

●     Double-click the Curve Connection Analysis from the specification tree to edit it.

●     You can analyze internal 
edges of a element, such as 
a Join for example, by 
selecting only one of the 
initial elements:
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●     Use the Overlapping mode to highlight  where, on the common boundary, the two 
curves overlap.
When the Overlapping button  is checked, other analysis types are deactivated.
In Full mode, a text is displayed indicating whether the curves overlap.

The Overlapping mode is not available with the Wireframe and Surface product.

●     The curve connection checking analysis is permanent in P2 mode only, i.e. it is 
retained in the specification tree for later edition and on the geometry till you reset 
or delete it, whereas in P1 mode, it is present at a time, but not retained when 
exiting the command.
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Repeating Objects
 This task shows how to create several instances of objects as you are currently 
creating one object.
This command is available for: 

●     points on a curve

●     lines at an angle or normal to a curve

●     planes at an angle

●     offset planes

●     offset surfaces

●     or when performing a translation, a rotation or a scaling on an object.

 
1.  Select an object, as listed above. 

2.  Click the Object Repetition  icon or 

select the Insert -> Advanced 

Replication Tools -> Object 

Repetition... menu item.

The Object Repetition dialog box is 
displayed. 

3.  Key in the number of instances of the object you wish to create.

4.  Check the Create in a new open body if you want all object instances in a 
separate Open Body.
A new Open Body will be created automatically.

If the option is not checked the instances are created in the current Open 
Body.

5.  Click OK.
The object is created as many times as required in the Object Repetition 
dialog box.
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Repeating Objects

 See each specific object creation for further details on the  what parameter is taken 
into account for the repetition.
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Stacking Commands

Stacking Commands

This task shows how to stack commands, that is create another basic object in the current 
command without leaving it.

Let's take an example with the Line functionality.

Open a new Part document.

1.  Click the Line icon  .

The Line Definition dialog box appears.

2.  Use the combo to choose the desired line 
type.

Here we chose the Point-Point line type: 
two points are required to create the line.

As no point already exits, you will have to create them.

 

3.  Right-click the Point 1 field.

4.  Select Create Point from the contextual 
menu.

 The Point Definition dialog box displays.
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Stacking Commands

5.  Use the combo to choose the desired point 
type.
Here we chose the On Plane type.

6.  Choose the Plane.

7.  Click OK.

 The Point Definition dialog box closes and you return to the Plane Definition dialog box.
The Point.1 field is valuated with the point you just created.

 8.  Right-click the Point 2 field.

9.  Repeat steps 4 to 7.

 The Point Definition dialog box closes and you 
return to the Plane Definition dialog box.
The Point.2 field is valuated with the point you just 
created and a line is previewed between Point 1 
and Point 2.

 10.  Click OK to create the line.

Features created using stacked commands are now 
aggregated under the parent command that 
created them and put in no show in the 
specification tree.
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Editing Parameters

Editing Parameters

This task shows how to view dimensions in the 3D geometry when creating or editing a feature. 

This command is available on the following commands:

 
Operator Type Sub- Type Parameter displayed

Circle Center and Radius Radius, Start Angle, End Angle

Center and Point  Start Angle, End Angle

Two Points and 
Radius

Radius

Bitangent and 
Radius

 Radius

Center and Tangent Point as center element Radius

Corner   Radius

Curve Parallel   Constant (Offset Distance)

Diabolo   Draft Angle

Extrapolate Length  Length, Limit Type

Extrude   Length 1, Limit 1
Length 2, Limit 2 

Helix   Taper Angle, Starting Angle

Line Angle/Normal to 
Curve

 Angle

Point-Point

 

Length : Start, End
Infinite Start Point: End
Infinite End Point: Start
Infinite: /

Point-Direction

Angle-Normal to 
Curve

Tangent to Curve
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Normal to Surface

Bisecting

Offset   Offset Value

Plane Angle/Normal to 
Plane

Angle (Angle/Normal to Plane and Angle/
Normal to Curve)

Offset from Plane  Length, Offset Distance

Point Coordinates  Length, X, Y, Z coordinates

On Curves  Length, Length

On Plane  Length, H, V

On Surface  Length, Distance

Polyline   Radius, Radius at point

Reflect Line   Angle

Revolve   Angle1, Angle2

Rotate   Rotation Angle

Shape Fillet Bi-Tangent Fillet  Radius

Sphere   Parallel Start Angle, Parallel End Angle, 
Meridian Start Angle, Meridian End Angle

Radius, Radius

Spiral End Angle

Sweep Explicit Sweep  Angle

Linear Sweep Two Limits Length1, Length2

With Reference Surface Angle, Length1, Length2

With Reference Curve Angle, Length1, Length2

With Draft Direction Angle, Length1, Length2

Translate Distance and 
Direction

 Distance
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Editing Parameters

     

Create any of the features above.
Let's take an example by performing a rotation. 

1.  Once you selected the inputs to create the rotated 
element, click Preview to display the associated 
parameters in the 3D geometry.

2.  Double-click the angle value in the 3D geometry.

The Parameter Definition dialog box appears.
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3.  Use the spinners to modify the value.

The display automatically updates and the object is 
modified accordingly.

You can also modify the angle value using the Angle 
manipulators.

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugparameters.htm (4 of 5)10/21/2004 5:11:01 AM



Editing Parameters

●     To display the parameters' values, you need to click the Preview button. Otherwise, only manipulators are displayed.

●     To edit the parameters once the feature is created, select it in the specification tree, right-click xxx.1object -> Edit 
Parameters from the contextual menu.

 
●     If you want the parameters to be kept permanently, check the Parameters of features and constraints option in Tools -> 

Options -> Infrastructure -> Part Infrastructure -> Display.
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Selecting Using Multi-Selection

This capability enables you to perform multi-selection of elements and validate the 
selection.
It is available with the following functionalities:

●     translate

●     project

●     axis transformation

●     rotate

●     symmetry

●     scaling

●     affinity

●     intersection

●     extract

●     develop

Select one of the commands above: the definition dialog 
box displays, as long as the Tools Palette toolbar.

1.  Choose the selection type:

●     Select : enables you to select elements or deselect elements in the 3D 

geometry or in the specification tree. 
Use the Ctrl key to select several elements, and the Shift key to deselect already 
selected elements. 

 
●     Selection Trap : enables you to select elements by drawing a trap.

Elements must be entirely located inside the trap to be selected.

 
●     Intersecting Trap : enables you to select elements by drawing a trap.

Elements can either be located inside the trap or be intersected by the trap to be 
selected.
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●     Polygon Trap : enables you to select elements by drawing a closed polygon.

Any element inside the polygon will be selected.

 
●     Paint Stroke Trap : enables you to select elements by drawing a paint stroke 

across them.

 The Tools Palette closes and you go back to definition dialog box.

Multi-selection is available when editing a single feature: double-click it in the 
specification tree to display the Tools Palette and perform multi-output selection.

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugmultiselection.htm (2 of 2)10/21/2004 5:11:59 AM



Creating Projections

Creating Projections 
 This task shows you how to create geometry by projecting one or more elements onto 
a  support. The projection may be normal or along a direction.
You can project: 

●     a point onto a surface or wireframe support

●     wireframe geometry onto a surface support

●     any combination of points and wireframe onto a surface support.

Generally speaking, the projection operation has a derivative effect, meaning that 
there may be a continuity loss when projecting an element onto another. If the initial 
element presents a curvature continuity, the resulting projected element presents at 
least a tangency continuity. If the initial element presents a tangency continuity, the 
resulting projected element presents at least a point continuity.

Open the Projection1.CATPart document.

1.  Click the Projection icon  .

 The Projection Definition dialog 
box appears as well as the Multi-
Selection dialog box allowing to 
perform multi-selection.
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Creating Projections

2.  Select the element to be Projected.

You can select several elements 
to be projected.  In this case, the 
Projected field indicates: x 
elements

3.  Select the Support element. 

4.  Use the combo to specify the direction 
type for  the projection:

●     Normal: the projection is done normal to 
the support element.
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●     Along a direction: you need to select a 
line to take its orientation as the translation 
direction or a plane to take its normal as 
the translation direction.

You can also specify the direction by means of 
X, Y, Z vector components by using the 
contextual menu on the Direction field.

●     Whenever several projections are possible, you can select the Nearest Solution 
check box to keep the nearest projection.
The nearest solutions are sorted once the computation of all the possible solutions 
is performed.

●     You can smooth the element to be projected 
by checking either: 
❍     None: deactivates the smoothing result

❍     G1 : enhances the current continuity to 
tangent continuity

❍     G2 : enhances the current continuity to 
curvature continuity

●     You can specify the maximum deviation for 
G1 or G2 smoothing by entering a value or 
using the spinners. 

If the element cannot be smoothed 
correctly, a warning message is issued.

Moreover, a topology simplification is 
automatically performed for G2 vertices: 
cells with a curvature continuity are merged.

 

7.  Click OK to create the projection element.

The projection (identified as Project.xxx) is added to the specification tree. 
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The following capabilities are available: Stacking Commands and Selecting Using Multi-
Output.
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Selecting Using Multi-Output
This capability enables to keep the specification of a multi-selection input in a single 
operation.
It is available with the following functionalities:
●     Intersections

●     Projections

●     Extracting

●     All transformations: translation, rotation, symmetry, scaling, affinity and axis to axis

●     Developed wires (Generative Shape Optimizer)

Let's take an example using the Projection and Translation functionalities.

Open the Multi-Output1.CATPart document.

1.  Click the Projection icon  .

The Projection Definition dialog box 
appears, as long as the Tools Palette 
toolbar.

2.  Select Translate.1 as first element to 
be Projected.
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 2.  Click the bag icon  to display the 
elements list.
The Projected dialog box opens.

3.  Select as many elements as you 
need for your projection. 

4.  Click Close to return to the 
Projection Definition dialog box.

The number of selected 
elements is displayed 
Projected field.

Use the Remove and Replace buttons to 
modify the elements list.

     

2.  Select Extrude.1 as the Support 
element. 

3.  Select Normal as Projection type.

4.  Click OK to create the projection 
elements.

 

The projection is identified as Multi 
Output.1 (Project) in the specification tree.

The created elements are aggregated 
under Multi Output.1.

You can create several multi-outputs in the specification tree, each one grouping one 
type of elements.
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5.  Click the Translate icon .

The Translate Definition dialog 
box appears. 

  

 

6.  Select Element.1 and Element.2 as 
the Element to be translated.

7.  Select Direction, distance as the 
Vector Definition.

8.  Select Extract.2 as the Direction.

9.  Select -50mm as the Distance.

10.  Click OK to create the translated 
element.

The translation is identified as Multi 
Output.2 (Translate) in the specification 
tree and appears below Multi Output.1. 

The created elements are aggregated 
under Multi Output.2.
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When one or several features are in error under a multi-output (during creation or 
edition), an error message is issued after clicking Preview or OK and displays all 
features in error.
You are able to manually delete or deactivate the feature(s) in error. When editing the 
multi-output, deactivated features are not automatically activated.

   
●     Multi-selection is available when editing a single feature: double-click it in the 

specification tree and click the bag icon to replace it or add new elements.

 ●     Multi-outputs and elements aggregated under a multi-output can be edited 
separately, simply by double-clicking it in the specification tree. Elements can be 
modified (added, replaced, or removed): the corresponding multi-output 
automatically updates.

Unshared features are aggregated under the parent command that created them and 
put in no show in the specification tree.
Shared features are not aggregated under the parent command.

 ●     The Datum capability is available. If an element is in error, it cannot be created as a 
datum element; only elements that could be generated from the multi selection are 
created.
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Applying a Material

 This task explains how to apply a pre-defined material as well as to interactively re-
position the mapped material.

A material can be applied to: 
●     a PartBody, Surface, Body or OpenBody (in a .CATPart document).

Note: you can apply different materials to different instances of a same 
CATPart. 

●     a Product  (in a .CATProduct document)

●     instances of a  .model, .cgr, .CATPart (in a .CATProduct document).

 
Within a CATProduct, you should not apply different materials to different instances of 
a same Part because a material is part of the specific physical characteristics of a Part. 
Therefore, this could lead to inconsistencies.

Materials applied to .CATPart, .CATProduct and .cgr documents can now be saved in 
ENOVIAVPM. 
For detailed information on ENOVIAVPM, refer to the ENOVIAVPM User's Guide.

Open the ApplyMaterial.CATProduct document. 

 
Select the View ->Render Style->Apply Customized View command to make sure 
that the "Shading" and "Materials" options are on. The Custom View Modes dialog box 
is not displayed if it has been previously activated during the session.
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1.  Select the element on which the material should be applied. 

 

Note: you can also apply a material simultaneously to several elements. 
To do so, simply select the desired elements (using either the pointer or 
the traps) before applying the material.

 

2.  Click the Apply Material icon . 

The Library dialog box opens. It contains several pages of sample 
materials from which to choose. Each page is identified by a material 
family name on its tab (each material being identified by an icon) if you 
select the Display icons mode... 

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugapplymaterial.htm (2 of 11)10/21/2004 5:13:57 AM



Applying a Material

 

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugapplymaterial.htm (3 of 11)10/21/2004 5:13:57 AM



Applying a Material

 ...or each page is identified by a material family name in a pulldown list if 
you select the Display list mode:
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Note that clicking the Open a material library  icon opens the File 
Selection dialog box which lets you navigate through the file tree to your 
own material libraries. 
You can, of course, use the default library (see What You Should Know 
Before You Start in this guide) by choosing "Default Material Catalog".
The pulldown list will display the list of previously opened material 
libraries. 
Note: when you reopen the dialog box, the last chosen material library 
will be placed on top of the list and used by default unless you select 
another one.

3.  Select a material from any family, by a simple click. 

 Once a material is selected, you can drag and drop or copy/paste it onto 
the desired element directly from the material library.

You can also double-click a material or click it once then select the 
Properties contextual menu to display its properties for analysis purposes. 

4.  Click the Link to file checkbox if you want to map the selected material as a 
linked object and have it automatically updated to reflect any changes to the 
original material in the library. 

Two different icons (one with a white arrow  and one without ) 
identify linked and non-linked materials respectively in the specification 
tree.

Note: You can edit linked materials. Doing so will modify the original 
material in the library. If you want to save changes made to the original 
material, use the File->Save All command. 

 

When no object is selected in the specification tree, you can select the 
Edit->Links... command to identify the library containing the original 
material. You can then open this library in the Material Library 
workbench if desired.
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You can also use the Paste Special... command to paste material as a 
linked object. You can copy both unlinked and linked materials. You can, 
for example, paste a linked material on a different element in the same 
document as well as on an element in a different document. For more 
information, see Copying & Pasting Using Paste Special... in this guide. 

5.  Click Apply Material to map the material onto the element. 

The selected material is mapped onto the element and the specification 
tree is updated. In our example, the material was not mapped as a linked 
object. 

 

A yellow symbol may be displayed to indicate the material inheritance 
mode. For more information, refer to Setting Priority between Part and 
Product in this guide. 

Material specifications are managed in the specification tree: all mapped 
materials are identified. To edit materials (for more information, see 
Modifying Materials), simply right-click the material and select Properties 
from the contextual menu or double-click the material. You can also run 
searches to find a specific material in a large assembly (for more 
information, see Finding Materials in this guide) as well as use copy & 
paste or drag & drop capabilities.
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Unless you select in the specification tree the desired location onto 
which the material should be mapped, dragging & dropping a material 
applies it onto the lowest hierarchical level (for instance, dragging and 
dropping onto a part will apply the material onto the body and not 
onto the part itself).

However, note that a material applied onto a body has no impact on 
the calculation of the part physical properties (mass, density, etc.) 
since only the physical properties of the part, and not those of the 
body, will be taken into account.

 

 

6.  Click OK in the Library dialog box. 

The object looks the following way: 

 

Note: applying materials to elements affect the physical and mechanical 
properties, for example the density, of elements. 

7.  Right-click the material just mapped in the specification tree and choose the 
Properties item. 

The Properties dialog box is displayed:

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugapplymaterial.htm (7 of 11)10/21/2004 5:13:57 AM



Applying a Material

 

 

8.  Choose the Rendering tab to edit the rendering properties you applied on the 
element. 

9.  If necessary; change the material size to adjust the scale of the material relative 
to the element. 
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10.  Click OK in the Properties dialog box, when you are satisfied with the material 
mapping on the element. 

Note: Appropriate licenses are required to use the Analysis and Drafting 
tabs. 

 

If you are working in "Materials" visualization mode (i.e. Materials 
option is checked in the Custom View Modes panel) with no material 
applied to your object, this object will be visualized using default 
parameters which only take into account the color defined in the 
object graphic properties. 
As a consequence, an object with no mapped material will appear as if 
made of matte plastic, non-transparent and without any relief.

 

11.  Use the 3D compass to interactively position the material: 

Note that material positioning with the 3D compass is only possible in the 
Rendering, Product Structure, Part Design and DMU Navigator 
workbenches.

 

●     Select the material in the specification tree:

The compass is automatically snapped and the mapping 
support (in this case, a cylinder) appears, showing the 
texture in transparency.
If necessary, zoom in and out to visualize the mapping 
support which reflects the material size.
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●     Pan and rotate the material until satisfied with the result. You can:
❍     Pan along the direction of any axis (x, y or z) of the compass (drag 

any compass axis)

❍     Rotate in a plane (drag an arc on the compass)

❍     Pan in a plane (drag a plane on the compass)

❍     Rotate freely about a point on the compass (drag the free rotation 
handle at the top of the compass):

 

 ●     Use the mapping support handles to stretch the material texture along 
u- and v- axes (as you can do it with the slider in the Scale U, V fields 
displayed in the Texture tab):
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 For more information on manipulating objects using the 3D compass, 
refer to the Version 5 Infrastructure User's Guide.  

 

 

 

http://pop.dia.uniroma3.it/catia/online/cfyug_C2/cfyugapplymaterial.htm (11 of 11)10/21/2004 5:13:57 AM



Advanced Tasks

Advanced Tasks
The advanced tasks you will perform in the Wireframe and Surface Design workbench 
include managing higher level entities than single geometric elements, that is the 
PowerCopies.

Managing PowerCopies
Measure Tools

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/wfsugat0000.htm10/21/2004 5:14:03 AM



Managing PowerCopies

Managing Power Copies

 Create PowerCopies: Select the Insert -> Advanced Replication Tools -> 
PowerCopy Creation command, select the elements making up the PowerCopy from 
the specification tree, define a name for the PowerCopy and its reference elements 
then choose an icon for identifying it.

 Instantiate PowerCopies: Select the Insert -> Instantiate From Document 
command, select the document or catalog containing the  powercopy, complete the 
Inputs within the dialog box selecting adequate elements in the geometric area.

 
[ Up ] [ Next ]
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Creating Power Copies
 This task shows how to use create PowerCopy elements, to be reused later.
A PowerCopy is a set of features (geometric elements, formulas, constraints and so 
forth) that are grouped in order to be used in a different context, and presenting the 
ability to be completely redefined when pasted.
This PowerCopy captures the design intent and know-how of the designer thus enabling 
greater reusability and efficiency.

Open the PowerCopyStart1.CATPart document.

 
1.  Click the PowerCopy Creation  icon, or select the Insert ->Advanced 

Replication Tools -> PowerCopy Creation menu item.
The PowerCopy Definition dialog box is displayed. 

2.  Select, from the specification tree, the elements to be included in the PowerCopy. 

The 
PowerCopy 
Definition 
dialog box is 
automatically 
filled with 
information 
about the 
selected 
elements.  

3.  Define the 
PowerCopy as you 
wish to create it:

The 
Definition 
tab lets you 
assign a 
name to the 
PowerCopy 
and presents 
its 
components 
in the 3D 
viewer.
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The Inputs 
tab lets you 
rename the 
reference 
elements 
making up 
the 
PowerCopy.

You can do 
that for 
clarification 
purposes as 
to their 
roles,  by 
selecting the 
elements in 
the viewer 
and entering 
a new name 
in the Name 
field.
In this 
example, we 
renamed all 
three 
elements 
and in 
brackets you 
still can read 
the 
elements' 
default name 
based on 
their type.

The 
Parameters 
tab lets you 
define which 
of the 
parameter 
values used 
in the 
PowerCopy 
you will be 
able to 
modify at 
instantiation 
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time.

Simply check 
the 
Published 
button.

Use the 
Name field 
to give a 
more explicit 
name to the 
element.

The 
Documents 
tab shows 
the complete 
path and role 
of Design 
tables that 
are 
referenced 
by an 
element 
included in 
the Power 
Copy.

The Icon tab 
lets you 
modify the 
icon 
identifying 
the 
PowerCopy 
in the 
specifications 
tree. A 
subset of 
icons is 
available 
from the 
Icon choice 
button.
If you 
click ... the 
Icon Browser 
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opens, giving 
you access 
to all the 
graphic icons 
installed with 
the CATIA 
software. 

Use the 
Grab screen 
button to  
capture an 
image of the 
PowerCopy 
to be stored 
with its 
definition in 
the catalog.

Use the Remove preview button to delete the image captured with the Grab screen 
button.

4.  Click OK to create the PowerCopy.

The PowerCopy is displayed close to the top of the specification tree.

●     Double-click the PowerCopy in the specification tree to display the PowerCopy 
Definition dialog box and edit its contents.

●     A formula is automatically included in a Power Copy definition when all its parameters 
are included.
Otherwise, i.e. if at least one parameter is not selected as part of the Power Copy, you 
have to manually select the formula to make it part of the definition. If you do so, all 
the formula's parameters that have not been explicitly selected, are considered as 
inputs of the Power Copy.
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[ Up ] [ Next ]
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Instantiating Power Copies
 This task shows how to instantiate PowerCopies once they have been created as described in Creating  PowerCopies.
There are two ways to do this: 

1.  using the PowerCopy Instantiation menu item
2.  using a catalog

Furthermore, the use of the Replace viewer, regardless of the instantiation type, is detailed.

Open the PowerCopyDestination1.CATPart document.

Using the menu item: 
 

1.  Click the PowerCopy Instantiation  icon or select the Insert -> Instantiate From Document menu item.

The File Selection dialog box is displayed allowing you to navigate to the document or catalog where the  power 
copy is stored.

2.  Select the document containing the Powercopy, and 
click Open.
Here we selected the PowerCopyStartResults1.
CATPart document.

The Insert Object dialog box is displayed.

Use the Reference list to choose the correct 
PowerCopy when several have been defined in 
the document.

3.  Complete the Inputs within the dialog box by 
selecting the adequate element in the geometric 
area.
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4.  If needed, click on the Use identical name button to automatically select all the elements with the same name.
This is especially useful when the input is the same one repeated several time.

5.  You can also click on the Parameters button to 
display the Parameters dialog box and modify 
values.
Here we increased the Radius1 value to 25 mm.

6.  Use the Create formulas button to automatically 
create a formula on every parameters with the same 
name provided there are any.

7.  Click OK.

 The Documents button lets you access the list of documents (such as design tables) pointed by one of the elements 
making up the Power copy. 
If there are documents, the Documents dialog box opens and you can click the Replace button to display the File 
Selection dialog box and navigate to a new design table to replace the initial one.
When no document is referenced, the Documents button is grayed within the Insert Object dialog box.

8.  Click OK to create the PowerCopy instance.

The PowerCopy is instantiated in context, 
meaning its limits are automatically re-defined 
taking into account the elements on which it is 
instantiated.

●     When instantiating from the same document, use the PowerCopy object -> Instantiate contextual menu to 
display the Insert Object dialog box directly.

●     The  icon is always grayed when instantiating Power Copies. It is available with User Features and allows you to 

create and modify URLs.
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Using the Replace Viewer

In some cases, when instantiating a powercopy, the replacing element does not present the same sub-elements as the 
replaced element. Therefore you need to clearly indicate in a specific dialog box, the Replace Viewer, how to rebuild the 
geometry from the replacing element. In the following example, the replacing sketch does not have the same number of 
vertices as the initial sketch, and you are prompted to indicate on what edge the filleted surfaces are to be created.

Open the PowerCopyReplace1.CATPart document.

 
1.  Expand the PowerCopy entry in the specification tree, right-click the PowerCopy.1 feature,  and choose 

PowerCopy.1 object ->  Instantiate command.

2.  Select Sketch.2 to replace Sketch.1.
The Replace Viewer is displayed, showing to the left the initial sketch and the edges selected to create the two 
fillets in the initial geometry, and to the right the replacing sketch on which you are prompted to specify edges.

3.  Select the edges on the replacing sketch.
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Instantiating PowerCopy

4.  Click OK in the Replace Viewer.

5.  Select the XY plane, or click the Use Identical Name to select it as the needed plane.

6.  Click OK in the Insert Object dialog box.
The PowerCopy is instantiated and the filleted surfaces are computed as per the selection in the Replace Viewer.

Make sure to select the edges as proposed in the Replace 
Viewer. For example, you cannot invert Edge.1 and Edge.2 
if Edge.3 remains where specified in the example above. 
Otherwise, the system will not be able to re-build the 
geometry based on these specifications, and the Update 
Diagnosis dialog box will be displayed prompting you to 
edit the geometry.

A new panel now allows you to select alternate document access methods. 
See Opening Existing Documents Using the Browse Panel in CATIA Infrastructure User Guide.

 

 
[ Back ] [ Up ]
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Measure Tools

Measure Tools
You can create a link between a measure and a parameter (length or angle) using two 
methods:

Measure distances and angles: Right-click the appropriate field, select Measure 
Between, set the measure type and mode, then select two entities.
Measure properties: Right-click the appropriate field, select Measure Item, set the 
measure type and mode, then select an item.

[ Back ] [ Up ]
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Measuring Distances & Angles between Geometrical Entities 
This task explains how to measure minimum or maximum distances and, if applicable, angles between 
geometrical entities (points, surfaces, edges, vertices and entire products).
Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, LOCK.model, 
NOZZLE1.model, NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.model, TRIGGER.model and 
VALVE.model. 

They are to be found in the online documentation filetree in the common functionalities sample folder cfysa
\samples.
Restriction: Neither Visualization Mode nor cgr files permit selection of individual vertices.

Note: In the No Show space, this command is not accessible.
 1. Click the Measure Between  icon. 

In DMU, you can also select Analyze-> Measure Between from the menu bar.

The Measure Between dialog box appears.
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Measuring Distances & Angles between Geometrical Entities

By default, minimum distances and if applicable, angles are measured.

By default, measures made on active products are done with respect to the product axis system. 
Measures made on active parts are done with respect to the part axis system. 
Note: This distinction is not valid for measures made prior to Version 5 Release 8 Service Pack 1 where 
all measures are made with respect to the absolute axis system.  

You can also measure distances and angles with respect to a local V5 axis system. 

A Keep Measure option in the dialog box lets you keep the current and subsequent measures as features. 
This is useful if you want to keep the measures as annotations for example. 
Note: This option is not available in the Drafting workbench.

Some measures kept as features are associative and can be used to valuate parameters or in formulas.

In the Drafting workbench, measures are done on-the-fly. They are not persistent. This means that they 
are not associative and cannot be used as parameters.

The Measure Item command  is accessible from the Measure Between dialog box. 

In DMU, the Measure Thickness command is also accessible from the Measure Between dialog box. For 
more information, see the DMU Space Analysis User's Guide.

 
P1-Only Functionality

In P1, the Measure Tools toolbar appears. 
This toolbar has two icons:

 

●     Measure Dialogs : lets you show or hide the associated dialog box.

●     Exit Measure : lets you exit the measure. This is useful when the dialog box is hidden.

2. Select the desired measure type.  

Notice that the image in the dialog box changes 
depending on the measure type selected.

 

 

Defining Measure Types
●     Between (default type): measures distance and, if applicable, angle between selected items.

●     Chain: lets you chain measures with the last selected item becoming the first selection in the next 
measure.

●     Fan: fixes the first selection as the reference so that you always measure from this item.

3. Set the desired mode in the Selection 1 and Selection 2 mode drop-down list boxes.
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Measuring Distances & Angles between Geometrical Entities

Defining Selection 1 & Selection 2 Modes
●     Any geometry (default mode): measures distances and, if applicable, angles between defined 

geometrical entities (points, edges, surfaces, etc.). 
Note: The Arc center mode is activated in this selection mode.

This mode recognizes the axis of 
cylinders and lets you measure the 
distance between two cylinder axes for 
example. 

●     Any geometry, infinite: measures distances and, if applicable, angles between the infinite geometry 
(plane or line) on which the selected geometrical entities lie. The Arc center mode is activated and this 
mode also recognizes cylinder axes. For all other selections, the measure mode is the same as any 
geometry.

Any geometry, infinite Any geometry

●     Picking point: measures distances between points selected on defined geometrical entities. Always 
gives an approximate measure.

●     Point only: measures distances between points. Dynamic highlighting is limited to points.

●     Edge only, Surface only: measures distances and, if applicable, angles between edges and surfaces 
respectively. Dynamic highlighting is limited to edges or surfaces and is thus simplified compared to 
the Any geometry mode. All types of edge are supported.

●     Picking axis: measures distances and, if applicable, angles between an entity and an infinite line 
perpendicular to the screen.
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Measuring Distances & Angles between Geometrical Entities

Simply click to create infinite line 
perpendicular to the screen. 

●     Intersection: measures distances between intersection points between two edges or an edge and a 
surface. In this case, two selections are necessary to define selection 1 and selection 2 items.

●     Edge limits: measures distances between endpoints or midpoints of edges. Endpoints only are 
proposed on curved surfaces.

●     Arc center: measures distances between the centers of arcs.

●     Center of 3 points arc: measures distances between the centers of arcs defined by 3 points.

To define arc center, click three points 
on the geometry. 

Note: The resulting measure will 
always be approximate.

●     Coordinate: measures distances between coordinates entered for selection 1 and/or selection 2 items.

4. Set the desired calculation mode in the Calculation mode drop-down list box.

Defining the Calculation Mode
●     Exact else approximate (default mode): measures access exact data and wherever possible true values 

are given. If exact values cannot be measured, approximate values are given (identified by a ~ sign).

●     Exact: measures access exact data and true values are given. Note that you can only select exact 
items in the geometry area or specification tree.
In certain cases, in particular if products are selected, a warning dialog box informs you that the exact 
measure could not be made. 

●     Approximate: measures are made on tessellated objects and approximate values are given (identified 
by a ~ sign).

Note: You can hide the display of the ~ sign using the Tools -> Options command (General ->  
Parameters and Measure -> Measure Tools).

5. Click to select a surface, edge or vertex, or an entire product (selection 1).
Notes: 
●     The appearance of the cursor has changed to assist you.

●     Dynamic highlighting of surfaces, points and vertices, etc. helps you locate items to click on.
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Measuring Distances & Angles between Geometrical Entities

6. Click to select another surface, edge or vertex, or an entire product (selection 2).

A line representing the minimum distance vector is drawn between the selected items in the geometry 
area. Appropriate distance values are displayed in the dialog box. 

By default, the overall minimum distance and angle, if any, between the selected items are given in the 
Measure Between dialog box.
The number of decimal places, the display of trailing zeros and limits for exponential notation is 
controlled by the Units tab in the Options dialog box (Tools ->Options, General ->Parameters and 
Measure). For more information, see the Infrastructure User's Guide.

7. Select another selection and, if desired, selection mode.
8. Set the Measure type to Fan to fix the first selection so that you can always measure from this item.
9. Select the second item.
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Measuring Distances & Angles between Geometrical Entities

10.Select another item.

Using the Other Selection... command in the contextual menu, you can access the center of spheres.
11.If necessary, adjust the presentation of the measure:

You can move the lines and text of the measure.

The Properties command (Graphics tab) lets you change the fill color and transparency as well as the 
color, linetype and thickness of measure lines. 

Note: You cannot vary transparency properties, the current object is either the selected color or 
transparent.

Customizing Your Measure

You can, at any time, customize the display of the 
results in both the geometry area and the dialog 
box. To do so, click Customize... in the Measure 
Between dialog box and set your display in the 
Measure Between Customization dialog box. 

Note: Measuring minimum distance, maxium 
distance and maximum distance from 1 to 2 are 
mutually exclusive options. Each time you change 
option, you must make your measure again.

Point 1 and point 2 give the coordinates of the two 
points between which the distance is measured.

  

Measuring Maximum Distance

You can also measure the maximum distance between two surfaces, two volumes or a surface and a 
volume.

Distance is measured normal to the selection and is always approximate.  Two choices are available:
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Measuring Distances & Angles between Geometrical Entities

  ●     Maximum distance from 1 to 2: gives the maximum distance of all distances measured from selection 
1.
Note: This distance is, in general, not symmetrical.

  

  ●     Maximum distance: gives the highest maximum distance between the maximum distance measured 
from selection 1 and the maximum distance measured from selection 2.

  Note: All selection 1 (or 2) normals intersecting selection 1 (or 2) are ignored.
  

 12.Click Customize... and check the appropriate maximum distance option in the Measure Between 
Customization dialog box, then click OK.

 13.Make your measure.
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Measuring Distances & Angles between Geometrical Entities

Measuring in a Local Axis System

For this part of the task, you will need a V5 axis system.
14.Click Customize... and check Minimum distance, Point 1 and Point 2 options in the Measure Between 

Customization dialog box, then click OK.
15.Check the Other Axis option in the dialog box.
16.Select a V5 axis system in the specification tree or geometry area.
17.Make your measure.

Same measure made with respect to absolute axis system:
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●     All subsequent measures are made with respect to the selected axis system. To change the axis 
system, click the Other Axis field and select another axis system. To return to the absolute axis 
system, uncheck the Other Axis option.

●     This type of measure is associative: if you move the axis system, the measure is impacted and can be 
updated.

18.Click OK when done. 

If you checked the Keep Measure option in the 
Measure Between dialog box, your measures are 
kept as features and your specification tree will 
look something like this if measures were made on 
the active product.
Or like this, if measures were made on the active 
part. 

Note: If the product is active, any measures on 
parts are placed in No Show.

Some measures kept as features are associative. In 
Design Mode, if you modify a part or move a part in 
a product structure context and the measure is 
impacted, it will be identified as not up-to-date in 
the specification tree. You can then update it locally 
have it updated automatically. 

When measures are used to valuate parameters, 
an associative link between the measure and 
parameter is created. Measures can also be used in 
formulas.

Editing Measures

In addition to editing the presentation of the measure, you can also edit the measure itself and change 
one of the selections on which it was based. This is particularly useful in design mode where you no 
longer have to redo your measure. 
You can also change selections that no longer exist because they were deleted.
●     Double-click the measure in the specification tree or geometry area.

●     Make new selections.

Notes:
You can change selection modes when making new selections.
For invalid measures where one selection has been deleted, you only have to replace the 
deleted selection.
For all other measures, repeat all selections.

●     Click OK when done. 

Creating Geometry

A Create Geometry option in the dialog box lets you create the points and line corresponding to the 
minimum distance result in a part.
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Measuring Distances & Angles between Geometrical Entities

Sectioning Measure Between Results

Having made and kept your measure, select it then click the Sectioning  icon to section measure 

results. The plane is created parallel to the direction defined by the measure and sections entities 
selected for the measure only. All section plane manipulations are available.

Note: You may need an appropriate license to access the Sectioning command.
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Measuring Properties 
 This task explains how to measure the properties associated to a selected item (points, edges, 
surfaces and entire products). 

This command lets you choose the selection mode, the calculation mode and axis system 
when measuring properties.

Note: In the No Show space, this command is not accessible.
Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, 
LOCK.model, NOZZLE1.model, NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.
model, TRIGGER.model and VALVE.model. 

They are to be found in the online documentation filetree in the common functionalities 
sample folder cfysa\samples.

 
Restriction: Neither Visualization Mode nor cgr files permit selection of individual vertices.

 1. Switch to Design Mode (Edit ->Representations ->Design Mode).

2. Set View -> Render Style to Shading with Edges.

Note: You cannot use this command, if Shading only is selected.
3. Click the Measure Item  icon. 

In DMU, you can also select Analyze -> Measure Item from the menu bar.

The Measure Item dialog box appears.
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By default, properties of active products are measured with respect to the product axis 
system. Properties of active parts are measured with respect to the part axis system. 
Note: This distinction is not valid for measures made prior to Version 5 Release 8 Service 
Pack 1 where all measures are made with respect to the absolute axis system. 

You can also measure properties with respect to a local V5 axis system. 

The Keep Measure option lets you keep current and subsequent measures as features. This 
is useful if you want to keep measures as annotations for example.
Note: This option is not available in the Drafting workbench.

Some measures kept as features are associative and can be used to valuate parameters or 
in formulas.
In the Drafting workbench, measures are done on-the-fly. They are not persistent. This 
means that they are not associative and cannot be used as parameters.
The Measure Between command is accessible from 
the Measure Item dialog box. Simply click one of the 
Measure Between icons in the Definition box to 
switch commands. 

In DMU, the Measure Thickness command is also 
accessible from the Measure Item dialog box. For 
more information, see the appropriate task in the 
DMU Space Analysis User's Guide.

P1-Only Functionality

In P1, the Measure Tools toolbar appears. 
This toolbar has two icons:

 

●     Measure Dialogs : lets you show or hide the associated dialog box.

●     Exit Measure : lets you exit the measure. This is useful when the dialog box is hidden.

4. Set the desired measure mode in the Selection 1 mode drop-down list box.

Defining the Selection 1 Mode
●     Any geometry (default mode): measures the properties of the selected item (point, 

edge, surface or entire product).

●     Point only: measures the properties of points. Dynamic highlighting is  limited to points.

●     Edge only: measures the properties of edges. All types of edge are supported.

●     Surface only: measures the properties of surfaces.

In the last three modes, dynamic highlighting is limited to points, edges or surfaces 
depending on the mode selected, and is thus simplified compared to the Any geometry 
mode.
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Measuring Properties

 ●     Angle by 3 points: measures the angle between two lines themselves defined by three 
points.

  To define lines, select three existing 
points in the geometry area or in the 
specification tree.
Note: You cannot select picking points.
Smart selection is offered. This means 
that a sphere or circle, for example, are 
seen as points.

The resulting angle is always positive. It 
is measured in a counterclockwise 
direction and depends on the order in 
which points were selected as well as 
your viewpoint (the normal to the plane 
is oriented towards you).

  

  ●     Thickness (DMU only): measures the thickness of an item. For more information, see the 
appropriate task in the DMU Space Analysis User's Guide.

5. Set the desired calculation mode in the Calculation mode drop-down list box.

Defining the Calculation Mode
●     Exact else approximate (default mode): measures access exact data and wherever 

possible true values are given. If exact values cannot be measured, approximate values 
are given (identified by a ~ sign).

●     Exact: measures access exact data and true values are given. Note that you can only 
select exact items in the geometry area or specification tree.
In certain cases, in particular if products are selected, a warning dialog box informs you 
that the exact measure could not be made. 

●     Approximate: measures are made on tessellated objects and approximate values are 
given (identified by a ~ sign).
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Measuring Properties

Note: You can hide the ~ sign using the Tools -> Options command (General -
>Parameters and Measure ->Measure Tools).

6. Click to select the desired item.

Note: The appearance of the cursor has changed to assist you. 

The dialog box gives information about the selected item, in our case a surface and 
indicates whether the result is an exact or approximate value. The surface area is also 
displayed in the geometry area.

7. Click Customize... in the Measure Item dialog box to see the properties the system can 
detect for the various types of item you can select. By default, you obtain:
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Measuring Properties

Note: The center of gravity of surfaces is visualized by a point. In the case of non planar 
surfaces, the center of gravity is attached to the surface over the minimum distance.

8. Set the display of results in both the geometry area and the Measure Item dialog box as 
follows, then click Apply.

The Measure Item dialog box is updated and now gives the surface perimeter. 

Note: Visualization mode does not permit the measure of surface perimeter.
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9. Try selecting other items to measure associated properties.

10.If necessary, adjust the presentation of the measure:
You can move the lines and text of the measure.
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The Properties command (Graphics tab) lets you change the fill color and transparency as 
well as the color, linetype and thickness of measure lines. 

Note: You cannot vary transparency properties, the current object is either the selected 
color or transparent.

11.Click an edge: 

The system detects whether the edge is a line, curve or arc, taking model accuracy into 
account and displays the properties as set in the Measure Item Customization dialog box.

Note: If the angle of an arc is less than 0.125 degrees, only the arc length is displayed in 
the geometry area. The angle and radius are not displayed.

12.Click Plane (under Surface) in the Measure Item 
Customization dialog box, then click OK.

 13.Click a planar face to obtain the equation of the plane.

A plane is recognized and is identified in the dialog box. The equation of a plane is: Ax + 
By + Cz + D=0.
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Measuring Properties

 

●     The Measure Item command lets you access the radius of an exact cylinder or sphere.

●     The Measure Item command also recognizes ellipse-type conic sections. 

●     Using the Other Selection... command in the contextual menu, you can access the axis 
of a cylinder as well as the center of a sphere to, for example, measure between two 
cylinder axes.

●     The number of decimal places, the display of trailing zeros and limits for exponential 
notation is controlled by the Units tab in the Options dialog box (Tools-> Options, 
General-> Parameters and Measure). For more information, see the Infrastructure 
User's Guide.

Measuring Properties in a Local Axis System

For this part of the task, you will need a V5 axis system. 
14.Check the Other Axis option in the Measure Item dialog box.
15.Select a V5 axis system in the specification tree or geometry area.
16.Make your measure.

Measure made with respect to local axis system: Same measure made with respect to 
absolute axis system:
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●     All subsequent measures are made with respect to the selected axis system. To change 
the axis system, click the Other Axis field and select another axis system. To return to 
the main axis system, uncheck the Other Axis option.

●     This type of measure is associative: if you move the axis system, the measure is 
impacted and can be updated.

17.Click OK when done. 

If you checked the Keep Measure option in the 
Measure Item dialog box,  your measures are kept 
as features and your specification tree will look 
something like this if properties of the active product 
were measured.

Or like this, if properties were those of the active 
part. 

Note: If the product is active, any measures made 
on the active part are placed in No Show.

Some measures kept as features are associative. In 
Design Mode, if you modify a part or move a part in 
a product structure context and the measure is 
impacted, it will be identified as not up-to-date in 
the specification tree. You can then update it locally 
have it updated automatically. 

When measures are used to valuate parameters, an 
associative link between the measure and parameter 
is created. Measures can also be used in formulas.
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Editing Measures

In addition to editing the presentation of the measure, you can also edit the measure itself 
and change the selection on which it was based. This is particularly useful in design mode 
where you no longer have to redo your measure. 
You can also change selections that no longer exist because they were deleted.
●     Double-click the measure in the specification tree or geometry area.

●     Make a new selection.

Note:
You cannot change the selection 1 mode. If you selected a curve, you must 
make a selection of the same type, i.e. another curve.

●     Click OK when done. 

Creating Geometry

A Create Geometry option in the dialog box lets you create the points and line 
corresponding to the minimum distance result in a part.
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Workbench Description

Workbench Description
This section describes the menu and icon commands that are specific to the Wireframe and 
Surface workbench, which is shown below.

You can click the hotspots on this image to see the related documentation. 

 

Menu Bar
Wireframe Toolbar
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Surfaces Toolbar
Operations Toolbar
ReplicationToolbar

Tools Toolbar
Analysis Toolbar
Measure Toolbar

Selection Filter Toolbar
Specification Tree 
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Menu Bar

Wireframe and Surface Menu Bar
Here we will present the various menus and menu commands that are specific to Wireframe 
and Surface Version 5.

Start File Edit View Insert Tools Windows Help

Tasks corresponding to general menu commands are described in the Infrastructure User's 
Guide.

 

Edit
Please note that most of the Edit commands available here are common facilities offered 
with the Infrastructure.

The specific Wireframe and Surface Edit commands depend on the type of object being 
edited:  Open Body or other entity.

  Command... Description...

Undo Cancels the last action

Repeat Repeats the last performed action

Update See Updating Your Design

Cut
Copy
Paste

See Copying and Pasting

Paste 
Special...

See Using the Paste Special... 
Command

Delete Deletes selected geometry

Search... Allows searching and selecting objects
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Menu Bar

Selection Sets
Define 
Selection Sets
Find Owning 
Selection Sets

Allows to define and modify selected 
objects as sets

Links Manages links to other documents

Properties Allows displaying and editing object 
properties

Scan or 
Define in 
Work Object

See Scanning the Part

Edit Inputs... Allows to edit the object inputs and 
parameters

Change 
Body...

Moving an Open Body to a new Open 
Body

AutoSort Allows to reorder the Open Body's 
children according to the logical 
construction order

Reorder 
Children

See Editing Definitions

Show 
Components Hiding/Showing Open Bodies and 

Their ContentsHide 
Components
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Menu Bar

Create Group Allows creating groups. Refer to 
Generative Shape Design User's 
Guide - Basic Tasks - Managing 
Groups

Reset 
Properties

Allows resetting object properties

Insert

For... See...

Sketcher... Refer to the Sketcher User's Guide.
Open body See Managing Open Bodies

Axis System Allows the creation of local axis-
system

Wireframe Insert > Wireframe

Surfaces Insert > Surfaces

Operations Insert > Operations

Analysis Insert > Analysis

Advanced 
Replication Tools

Insert > Advanced Replication 
Tools

Document 
Template 
Creation...

Allows the creation of part 
templates. Refer to the chapter 
Creating a Part Template in the 
Product Knowledge Template 
User's Guide.

Instantiate From 
Document...

Instantiating PowerCopies

Insert -> Wireframe
For... See...

Point... Creating Points

Line... Creating Lines

Axis... Creating an Axis

Polyline... Creating Polylines

Plane... Creating Planes
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Menu Bar

Projection... Creating Projections

Intersection... Creating Intersections

Circle... Creating Circles

Corner... Creating Corners

Connect Curve... Creating Connect Curves

Spline... Creating Splines

Helix... Creating Helices

Insert -> Surfaces
For... See...
Extrude... Creating Extruded Surfaces

Revolve... Creating Revolution Surfaces

Sphere... Creating Spherical Surfaces

Cylinder... Creating Cylindrical Surfaces

Offset... Creating Offset Surfaces

Sweep... Creating Swept Surfaces

Fill... Creating Filling Surfaces

Loft... Creating Lofted Surfaces

Blend... Creating Blend Surfaces

Insert -> Operations
For... See...

Join... Joining Geometric Elements

Healing... Healing Geometry
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Menu Bar

Untrim...  

Disassemble... Disassembling Surfaces

Split... Splitting Geometry

Trim... Trimming Geometry

Boundary... Creating Boundary Curves

Extract... Extracting Geometry

Translate... Translating Geometry

Rotate... Rotating Geometry

Symmetry... Performing Symmetry on Geometry

Scaling... Transforming Geometry by Scaling

Affinity... Transforming Geometry by Affinity

Axis To Axis...
Transforming Elements from an Axis 
to Another

Invert Orientation
Inverting the Orientation of 
Geometry

Near...
Creating Nearest Entity of a Multiple 
Element

Extrapolate...
Extrapolating Curves and 
Extrapolating Surfaces

Insert -> Analysis
For... See...
Connect Checker Checking Connections Between 

Surfaces

Curve Connect 
Checker

Checking Connections Between Curves

 

Insert -> Advanced Replication Tools
For... See...

Object Repetition... Repeating Objects
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Menu Bar

Points Creation 
Repetition...

Multiple Points

Planes Between... Creating Planes Between Other 
Planes

PowerCopy 
Creation...

Creating PowerCopies

Save In Catalog... Saves powercopies into a catalog

 

Tools
Please note that most of the Tools commands available here are common facilities offered 
with the Infrastructure.

Specific Wireframe and Surface Tools commands are described in the present document.

 Command... Description...

Formula... Allows editing parameters and 
formula.

Image Allows capturing images.

Macro Allows recording, running and 
editing macros.

Show
Hide

Hiding/showing open bodies and 
their contents

In Work Object See Scanning the Part

Parameterization 
Analysis

See Analyzing Using 
Parameterization

Parent/
Children...

Allows viewing the parents and 
children of a selected object.

Work on Support See Working with a Support

Snap to point See Working with a Support

Open Catalog... Allows the opening of catalogs, for 
PowerCopies for example
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Menu Bar

External View... Allows specifying a feature as a reference 
for other products/applications. Refer to 
the chapter Managing Open Bodies in 
the Generative Shape Design User's 
Guide

Customize... Allows customizing the workbench.

Visualization 
Filters... Allows to manage layer filters.

Options Allows customizing settings.

  
[ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/wfsugwd0400.htm (7 of 7)10/21/2004 5:17:55 AM



Wireframe Toolbar

Wireframe Toolbar
This toolbar contains the following tools for creating wireframe geometry. 

 

  

See Points

See Multiple Points

See Lines

See Axis

See Polylines

See Planes

See Projections

See Intersections

See Circles

See Corners

See Connect curves

See Splines

See Helix
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Surfaces Toolbar

Surfaces Toolbar
This toolbar contains the following tools for creating surface geometry.

See Extruded Surfaces

See Surfaces of Revolution

 See Spherical Surfaces

See Cylindrical Surfaces

See Offset Surfaces

See Swept Surfaces

See Filled Surfaces

See Lofted Surfaces

See Blend Surfaces
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Operations Toolbar

Operations Toolbar 
This toolbar contains the following tools for performing operations on surface and wireframe 
elements.

 

 See Joining Geometry 

 See Healing Geometry

 See Restoring a Surface

 See Disassembling Surfaces

See Splitting Geometry

See Trimming Geometry

See Boundary Curves

See Extracting Geometry

See Translating Geometry 

See Rotating Geometry 

See Performing a Symmetry on Geometry 

See Transforming Geometry by Scaling 

See Transforming Geometry by Affinity

See Transforming elements into a new axis-system

See Extrapolating Curves and Extrapolating Surfaces
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Operations Toolbar
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ReplicationToolbar

Replication Toolbar 
This toolbar contains the following tools to help you model your part designs.

See Repeating Objects

See Multiple Points

See Creating Planes Between Other Planes

 See Creating PowerCopies

 See Instantiating PowerCopy
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Tools Toolbar

Generic Tools Toolbar
These toolbars contain the following tools to help you design and analyze your parts.

See Updating Your Design 

See Axis-System

See Working with a Support 

See Working with a Support 

See Working with a Support

See Creating Datums

 See Instantiating PowerCopies

See Instantiating PowerCopies

See Checking Connections Between Surfaces

 See Checking Connections Between Curves

 See Inverting the Orientation of Geometry
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Analysis Toolbar

Analysis Toolbar
These toolbars contain the following tools to help you apply materials onto surfaces for 
analysis purposes.

See Applying Materials Onto Surfaces
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Measure Toolbar

Measure Toolbar
This toolbar contain the following tools to help you create a persistent and associative link 
between a measure and a parameter.

   

 

See Measuring Minimum 
Distances and Angles

See Measuring Properties

See Measuring Inertia
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Selection Filter Toolbar

Selection Filter Toolbar
This toolbar contains the following tools to help you manage sub-geometry selection.

See Selecting using A Filter
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Specification Tree

Specification Tree
Within the Wireframe And Surface workbench, you can generate a number of elements that 
are identified in the specification tree by the following icons.

Further information on general symbols in the specification tree are available in Symbols 
Used in the Specification Tree.

Sketch Join

Point Healing

Multiple Points Surface

Line Split

Axis Trim

Polyline Boundary

Plane Extract

Projection Translate

Intersection Rotate

Circle Symmetry

Corner Scaling

Connect Curve Affinity

Spline Axis To Axis

Helix Near

Extrude Extrapolate

Revolve Inverse

Sphere Multiple Planes
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Specification Tree

Cylinder Multi-Output

Offset Open Body

Sweep Power Copy

Fill Working support

Multi-sections Surfaces Surface Connection Analysis

Blend Curve Connection Analysis
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Glossary

Glossary 

           

A
affinity An operation in which an element is transformed by applying X, Y, 

Z affinity ratios with respect to a reference axis system.

C 
child A status defining the hierarchical relation between a feature or 

element and another feature or element. 

constraint A geometric or dimension relation between two elements.

E 
extruded surface A surface that is obtained by extruding a profile along a specified 

direction. 

F 
feature A component of a part. 

J 
join An operation in which adjacent curves or adjacent curves can be 

joined.

L 
lofted surface A surface that is obtained by sweeping one or more planar section 

curves along a spine, which may be automatically computed or 
user-defined. The surface can be made to follow one or more guide 
curves.

O 
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Glossary

offset surface A surface that is obtained by offsetting an existing surface a 
specified distance.

P 
parent A status defining the hierarchical relation between a feature or 

element and another feature or element.

part A 3D entity obtained by combining different features. It is the 
content of a CATPart document.

part body A component of a part made of one or several features.

profile An open or closed shape including arcs and lines.

R 
revolution surface A surface that is obtained by revolving a profile around an axis.

rotate An operation in which an element is rotated by a specified angle 
about an given axis.

S 
scaling An operation that resizes an element to a percentage of its initial 

size.

sketch A set of geometric elements created in the Sketcher workbench. 
For instance, a sketch may include a profile, construction lines and 
points.

split An operation in which one element is cut by another element.

swept surface A surface obtained by sweeping a profile in planes normal to a 
spine curve while taking other user-defined parameters (such as 
guide curves and reference elements) into account.

symmetry An operation in which an element is transformed by means of a 
mirror symmetry with respect to a reference plane, line or point.

T
translate An operation in which an element is displaced a specified distance 

along a given direction.

trim An operation in which two element cut each other mutually.
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Glossary

W
wireframe element Elements such as points, lines or curves that can be used to 

represent the outline of a 3D object.
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Index

Index 

                  

A
Affinity

command  
analyzing

curve connection  

surface connection  
anchor point

sweep  

Apply Material command  
applying

material  
axis

command  

creating  
Axis System

command  
Axis To Axis

command  

B
bisecting

lines  
bi-tangent and point

circles  
bi-tangent and radius

circles  
Blend

command  
blended surfaces
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Index

creating  

blending  
boundaries

creating  
Boundary

command  

C
Change Body

command  
checking connections

curves  

surfaces  
Circle

command  
circles

bi-tangent and point  

bi-tangent and radius  

point center and radius  

three points  

tri-tangent  

two points  

two points and radius  
Close Surface

command  
Command

Show  

Show Components   
command

Affinity  

Axis  

Axis System  

Axis To Axis  
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Index

Blend  

Boundary  

Change Body  

Circle  

Close Surface  

Connect Checker  

Connect Curve  

Constraint  

Constraint with dialog box  

Copy  

Corner  

Curve Connect Checker  

Cylinder  

Definition  

Delete  

Disassemble  

Extract  

Extrapolate   

Extrude  

Fill  

Healing  

Helix  

Hide  

Hide Components   

Insert Open Body  

Intersection  

Invert Orientation  

Join   

line  

Loft  

Measure Between  
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Index

Measure Item  

Object Repetition  

offset  

Parent Children  

Paste  

plane  

Planes Repetition  

point  

Point & Planes Repetition  

Polyline  

PowerCopy Creation  

PowerCopy Instantiation  

Projection  

Remove Open Body  

Revolve  

Rotate  

Scaling  

Sphere  

Spline  

Split  

stacking  

Sweep   

Symmetric  

Translate  

Trim  

Untrim  

Update  

Work on Support  
commands

Apply Material  

Edit-Links  
Connect Checker
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Index

command  
Connect Curve

command  
connecting

curves  
connecting curves

creating  
Constraint

command  
Constraint with dialog box

command  
constraints

creating   
contents of an open bodies

hiding   

showing   
contextual command

Show Parents and Children  
contextual menu item

Show All Children  
Copy

command  
copying

elements  
Corner

command  
corners

creating  

curves  
coupling

loft  
creating

blended surfaces  

boundaries  

circles  
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Index

circular arcs  

connecting curves  

constraints   

corners  

curves  

cylinder  

datum  

elements by affinity  

elements by intersection  

elements by projections  

elements by rotation  

elements by scaling  

elements by symmetry  

helical curves  

multiple points  

planes   

points  

polylines   

Power Copies  

spheres  

splines  

surfaces         

wireframe elements  
Curve Connect Checker

command  
curve connection

analyzing  
curves

checking connections  

connecting  

corners  

creating  

http://pop.dia.uniroma3.it/catia/online/wfsug_C2/wfsugix.htm (6 of 17)10/21/2004 5:21:02 AM



Index

extrapolating  

helical  

joining  
Cylinder

command  
cylinder

creating  

D
datum

creating  
defining

local axis-system  

supports  
Definition

command  
Delete

command  
deleting

surfaces  

wireframe elements  
Disassemble

command  
disassembling

elements  
distance and angle between geometrical entities and points

measuring  

E
editing

elements   

Edit-Links command  
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Index

element orientation  
elements

copying  

disassembling  

editing   

pasting  

repeating  

symmetric  

translating   
elements by affinity

creating  
elements by intersection

creating  
elements by projections

creating  
elements by rotation

creating  
elements by scaling

creating  
elements by symmetry

creating  

external reference  
Extract

command  
extracting

faces  

propagation  

wireframe elements  
Extrapolate

command   
extrapolating

curves  

surfaces  
Extrude
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Index

command  
extruding

surfaces  

F
faces

extracting  
Fill

command  

filling between elements  

H
Healing

command  
healing

surfaces  
helical

curves  
helical curves

creating  
Helix

command  
Hide

command  
Hide Components

command   
hiding

contents of an open bodies   

open bodies  

I
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Index

Insert Open Body

command  
inserting

open bodies  
instantiating

Power Copies  

intersecting  
Intersection

command  
Invert Orientation

command  
inverting

orientation  

J
Join

command   
joining

curves  

surfaces   

L
line

command  

creating  
lines

bisecting  
link

material  

Link to file option  
local axis-system

defining  
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Index

Loft

command  
loft

coupling  

lofted surfaces  

M
managing

open bodies   

Power Copies  
mapping

material  
material

applying  

link  

mapping  

positioning  

properties  
measure

tools  

Measure Between command  

Measure Item command  
measuring

distance and angle between geometrical entities and points  

properties  
modifying

splines  
moving

open bodies  
multi-output

selecting  
multiple points

creating  
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Index

multi-selection  

O
Object Repetition

command  
offset

command  

offset surfaces  
open bodies

hiding  

inserting  

managing   

moving  

removing  

showing  
orientation

inverting  

P
parameters

edit  
Parent Children

command  
Paste

command  
pasting

elements  
plane

command  

creating  

support  
planes
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Index

creating   
Planes Repetition

command  
point

command  

creating  
Point & Planes Repetition

command  
point center and radius

circles  
points

creating  
Polyline

command  
polylines

creating   
positioning

material  
Power Copies

creating  

instantiating  

managing  
Power Copy

replacing element  
PowerCopy Creation

command  
PowerCopy Instantiation

command  

projecting  
Projection

command  
propagation

extracting  
properties

material  
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Index

measuring  

R
Remove Open Body

command  
removing

open bodies  
repeating

elements  

Replace Viewer  
replacing element

Power Copy  
restoring

surfaces  

revolution surfaces  
Revolve

command  
Rotate

command  

rotating  

S
Scaling

command  

scaling  
select

multi-selection  
selecting

multi-output  
Show

Command  
Show All Children
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Index

contextual menu item  
Show Components

Command   
Show Parents and Children

contextual command  
showing

contents of an open bodies   

open bodies  
Sphere

command  
spheres

creating  
Spline

command  
splines

creating  

modifying  
Split

command  
splitting

elements  
stacking

command  
stopping

updating  
support

plane  

surface  
supports

defining  
surface

support  
surface connection

analyzing  
surfaces
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Index

checking connections  

creating         

deleting  

extrapolating  

extruding  

healing  

joining   

restoring  

untrimming  
Sweep

command   
sweep

anchor point  

swept surfaces   
Symmetric

command  
symmetric

elements  

T
three points

circles  
Translate

command  
translating

elements   
Trim

command  
trimming

elements  
tri-tangent

circles  
two points
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Index

circles  
two points and radius

circles  

U
Untrim

command  
untrimming

surfaces  
Update

command  
updating

stopping  

updating  

W
wireframe elements

creating  

deleting  

extracting  
Work on Support

command  
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Sheetmetal Design

  

Preface
Using This Product
More Information

What's New?

Getting Started
Entering the Workbench
Defining the Parameters
Creating the First Wall
Creating the Side Walls
Creating a Cutout
Creating Automatic Bends
Extracting Drawings from the Sheet Metal Part

Basic Tasks
Managing the Default Parameters

Editing the Sheet and Tool Parameters
Modifying the Bend Extremities
Defining the Bend Corner Relief
Computing the Bend Allowance

Creating walls
From a Sketch
From an Existing Solid
Tangent Walls
From an Edge

Extruding
Isolating Walls
Creating Rolled Walls
Creating Bends

Manually Creating Bends from Walls
Generating Bends Automatically
Conical Bends
Bends From Line

Creating Swept Walls
Creating a Flange
Creating a Hem
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Sheetmetal Design

Creating a Tear Drop
Creating a Swept Flange
Redefining Swept Wall Limits
Displaying Swept Walls Axes

Unfolding

Folded/Unfolded View Access

Concurrent Access
Pockets

Creating a Cutout
Splitting Geometry

Stamping
Standard Features

Creating a Point Stamp
Creating a Flanged Hole
Creating a Curve Stamp
Creating a Surface Stamp
Creating a Bridge
Creating a Louver
Creating a Stiffening Rib

Creating User-defined Stamping Features
Punch and Die
Opening and Cutting faces
Editing User-Defined Stamps

Patterning
Rectangular Patterns
Circular Patterns
User-Defined Patterns

Corner Relief
Redefining a Corner Relief
Creating a Local Corner Relief

Creating Corners
Creating Chamfers
Mapping Elements
Saving As DXF
Reference Elements

Creating Points
Creating Lines
Creating Planes

Advanced Tasks
Integration with Part Design
Integration With Weld Design
Designing in Context

Designing in Context
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Sheetmetal Design

Modifying the Design
PowerCopies Management

Creating PowerCopies
Instantiating PowerCopies
Saving PowerCopies

Browsing the Sheet Metal Catalog
Looking For Sheet Metal Features

Working with the New SheetMetal Design Workbench
Creating Walls

Creating Walls from a Sketch
Creating Tangent Walls
Creating Walls From An Edge

Extruding
Creating Rolled Walls
Creating Bends on Walls

Manually Creating Bends from Walls
Creating Bends From a Line

Aggregating Bodies
Creating Swept Walls

Creating a Flange
Creating a Hem
Creating a Tear Drop
Creating a Swept Flange
Redefining Swept Wall Limits
Display swept walls axes in drafting sheets

Creating a Hole
Creating a Cutout
Stamping

Creating Standard Stamping Features
Creating a Flanged Hole
Creating a Bead
Creating a Circular Stamp
Creating a Surface Stamp
Creating a Bridge
Creating a Flanged Cutout
Creating a Stiffening Rib
Creating a Curve Stamp
Creating a Louver

Creating User-defined Stamping Features

Punch and Die

Opening and Cutting faces

Editing User-Defined Stamps
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Patterning

Creating Rectangular Patterns

Creating Circular Patterns

Creating User-Defined Patterns
Creating a Local Corner Relief
Creating Corners
Creating Chamfers
Mapping Elements

Saving As DXF
Integration with Part Design

Integration With Weld Design

Workbench Description
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NEW Sheet Metal Design
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Customizing Standard Files
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Preface

The Sheet Metal Design workbench is a new generation product offering an intuitive 
and flexible user interface. It provides an associative feature-based modeling making 
it possible to design sheet metal parts in concurrent engineering between the 
unfolded or folded part representation.

Sheet Metal Design offers the following main functions:
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Sheetmetal Design

●     Associative and dedicated Sheet Metal feature based modeling

●     Concurrent engineering between the unfolded or folded part representation

●     Access to company defined standards tables

●     Dedicated drawing capability including unfolded view and specific settings.

All sheetmetal specifications can be re-used by the Knowledge Advisor workbench to 
capture corporate knowledge and increase the quality of designs.

Natively integrated, Sheet Metal Design offers the same ease of use and user 
interface consistency as all V5 applications.
As a scalable product, Sheet Metal Design can be used in cooperation with other 
current or future companion products in the next CATIA generation such as Assembly 
Design and Generative Drafting. The widest application portfolio in the industry is 
also accessible through interoperability with CATIA Solutions Version 4 to enable 
support of the full product development process from initial concept to product in 
operation.

Using This Product
More Information 

 

http://pop.dia.uniroma3.it/catia/online/CATIAfr_C2/sheugCATIAfrs.htm (5 of 5)10/21/2004 5:28:55 AM



Preface

Preface

The Sheet Metal Design workbench is a new generation product offering an intuitive and 
flexible user interface. It provides an associative feature-based modeling making it possible 
to design sheet metal parts in concurrent engineering between the unfolded or folded part 
representation.

Sheet Metal Design offers the following main functions:

●     Associative and dedicated Sheet Metal feature based modeling

●     Concurrent engineering between the unfolded or folded part representation

●     Access to company defined standards tables

●     Dedicated drawing capability including unfolded view and specific settings.

All sheetmetal specifications can be re-used by the Knowledge Advisor workbench to capture 
corporate knowledge and increase the quality of designs.

Natively integrated, Sheet Metal Design offers the same ease of use and user interface 
consistency as all V5 applications.
As a scalable product, Sheet Metal Design can be used in cooperation with other current or 
future companion products in the next CATIA generation such as Assembly Design and 
Generative Drafting. The widest application portfolio in the industry is also accessible 
through interoperability with CATIA Solutions Version 4 to enable support of the full product 
development process from initial concept to product in operation.

Using This Product
More Information 
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Using This Product

Using This Product
This guide is intended for the user who needs to become quickly familiar with the CATIA 
Version 5 Sheet Metal Design product. The user should be familiar with basic Version 5 
concepts such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-
step tutorial "Getting Started".

The next sections deal with the handling of more detailed capabilities of the product.

This guide also includes a guide intended for the user of the New Sheet Metal Design 
product. You will find more information in the Working with the New SheetMetal Design 
Workbench section.

[ Up ] [ Next ]
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More Information

Where to Find More Information
Prior to reading this book, we recommend that you read the Infrastructure User's Guide.

The Part Design User's Guide, the Assembly Design User's Guide and the Generative Drafting 
User's Guide may prove useful.

Finally, you can read the Sheet Metal Production User's Guide to find out more about that 
product and to fully use the interoperability between the two products.

Conventions
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What's New?

What's New?
This table identifies what new or improved capabilities have been documented in Version 5 
Release 12 of the Sheet Metal Design and the NEW Sheet Metal Design workbenches. 

There is no new or improved capabilities in Version 5 Release 12 of the CATIA Sheet Metal 
Design workbench.
 

NEW Sheet Metal Design

New Functionalities

Creating Tangent Walls

Creating Rolled Walls

Creating Bends From a Line

Aggregating Bodies

Displaying Swept Walls Axes

Creating a Louver

Saving As DXF

Integration With Weld Design
 

Enhanced Functionalities

Editing the Sheet and Tool Parameters
You can now set the bend radius value with a radius=0 using the DIN standard
 

Creating Rectangular Patterns
Creating Circular Patterns
Creating User-Defined Patterns

You can now duplicate a stamp without fillet
 

Manually Creating Bends from Walls
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What's New?

You can now create a bend on a flange or on a stamp
You can now create a bend with a radius=0 
 

Creating Walls From an Edge
You can now create a wall from an edge on a flange and on a stamp
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Getting Started

Getting Started
Before getting into the detailed instructions for using Version 5 CATIA - Sheet Metal Design, 
the following tutorial provides a step-by-step scenario demonstrating how to use key 
functionalities.

The main tasks proposed in this section are: 

Entering the Workbench
Defining the Parameters
Creating the First Wall
Creating the Side Walls

Creating a Cutout
Creating Automatic Bends

Extracting Drawings from the Sheet Metal Part 

 
 

All together, these tasks should take about 15 minutes to complete.
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Entering the Workbench

Entering the Sheet Metal Workbench

The Sheet Metal Design functions are available when you are in the Part environment. 
Several functions are integrated from the Part Design workbench.

This task shows how to enter the workbench.

 Choose the Mechanical Design -> Sheet Metal Design item from the Start menu.
The Sheet Metal toolbar is displayed and ready to use.
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Entering the Workbench

You may add the Sheet Metal Design workbench to your Favorites, using the Tools -
> Customize item. For more information, refer to the Infrastructure User's Guide.

 
[ Up ] [ Next ]
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Defining the Parameters

Defining the Sheet Metal Parameters

This task shows you how to configure the sheet metal parameters.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed. 

2.  Enter 1mm in the Thickness field.

3.  Enter 5mm in the Default Bend Radius field.

4.  Select the Bend Extremities tab.
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Defining the Parameters

5.  Select Tangent in the Bend Extremities combo list.

An alternative is to select the bend type in the graphical combo list.

6.  Click OK to validate the parameters and close the dialog box.
The Sheet Metal Parameters feature is added in the specification tree.

The other two tabs are not used in this scenario.

 

 
[ Back ] [ Up ] [ Next ]
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Creating the First Wall

Creating the First Wall

This task shows how to create the first wall of the Sheet Metal Part.

1.  Click the Sketcher icon  then select the xy plane.

2.  Select the Profile icon .

3.  Sketch the contour as shown below:

4.  Click the Exit workbench icon  to return to the 3D world.

The sketch remains selected.
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Creating the First Wall

5.  Click the Wall icon .

The Wall Definition dialog box opens.

By default, the Material Side is set to the top.

6.  Click OK.
The Wall.1 feature is added in the specification tree

The first wall of the Sheet Metal Part is known as the Reference wall.
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Creating the First Wall
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Creating the Side Walls

Creating the Side Walls

This task shows you how to add other walls to the Sheet Metal part.

1.  Click the Wall on Edge icon .

The Wall On Edge Definition dialog box 
opens.

2.  Select the left edge.

3.  Enter 50mm in the Value field.
The application previews the wall.

By default, the material side is such that it ensures a continuity with the reference 
profile. If needed, invert it using the Reverse side button, or clicking the arrow.
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Creating the Side Walls

4.  Click the Reverse Position button to Invert the sketch profile.

5.  Click OK.
The wall is created and the Wall On Edge.1 feature is displayed in the 
specification tree:

6.  Select the right edge.

7.  Click the Wall on Edge icon  again.

The Wall On Edge Definition dialog box opens with the parameters previously 
selected.

8.   Invert the sketch profile and click OK to validate.

9.  Click the Wall on Edge icon  
again.

10.  Select the front edge.
The Wall Definition dialog box opens 
with the parameters previously 
selected.

11.  Enter 30mm in the Value field and 
10mm in the Limit1 and Limit2 
fields, then invert the sketch profile.

12.  Press OK to validate.
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Creating the Side Walls

The final part looks like this: 

 
 

[ Back ] [ Up ] [ Next ]
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Creating a Cutout

Creating a Cutout

In this task, you will learn how to: 
●     open a sketch on an existing face

●     define a contour in order to create a cutout.

1.  Select Wall On Edge.2 from the 
geometry area to define the 
working plane.

2.  Click the Sketcher icon .

3.  Click the Elongated Hole icon  to create the contour.

To access the oblong profile, click 
the black triangle on the 
Rectangle icon.
It displays a secondary toolbar.

4.  Click to create the first point and 
drag the cursor.

5.  Click to create the second point.
The first semi-axis of the profile is 
created.

6.  Drag the cursor and click to create 
the third point.
The second semi-axis is created 
and the oblong profile is displayed.
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Creating a Cutout

7.  Click the Exit workbench icon  to return to the 3D world.

8.  Select the Cutout icon .

The Pocket Definition 
dialog box is displayed and 
a cutout is previewed with 
default parameters. 

9.  Set the Type to Up to last option to define the limit of your cutout.

This means that the application will limit the cutout onto the last possible face, 
that is the opposite wall.

10.  Click OK.

This is your cutout:
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Creating a Cutout
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Creating Automatic Bends

Creating the Bends Automatically

This task shows how to create the bends automatically.

 1.  Click the 
Automatic 
Bends 

icon .

The bends are 
created.

CATIA displays the bends creation in the specification tree: 
Automatic Bends.1

The Sheet Metal part 
looks like this:

 
 

[ Back ] [ Up ] [ Next ]
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Extracting Drawings from the Sheet Metal Part

Extracting Drawings
from the Sheet Metal Part

This task shows how to create the Sheet Metal Part views in the Generative Drafting workbench.

The Sheet Metal part is displayed.

1.  Click  or select File -> New...

2.  Select the Drawing type and click OK.

The Generative Drafting workbench is launched.
The New Drawing dialog box opens.

3.  Click OK.

For more information about this workbench, refer to Generative Drafting User's Guide. 

4.  The drawing sheet appears.

5.  Tile the windows horizontally using the Window -> Tile Horizontally menu item.

6.  Select the Unfolded View icon  in the Projections toolbar from Generative Drafting 

Workbench.
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Extracting Drawings from the Sheet Metal Part

This icon is added to the Projections toolbar provided the Sheet Metal workbench is present.

7.  Choose the xy plane in the Sheet Metal specification tree.
The unfolded view is displayed with the bends axes and limits.

Eventually, the Drafting sheet looks like this:
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Extracting Drawings from the Sheet Metal Part
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Basic Tasks

Basic Tasks
The Basic Tasks section explains how to create and modify various kinds of features.

 
Managing the Default Parameters

Creating walls
Extruding

Isolating Walls
Creating Rolled Walls

Creating Bends
Creating Swept Walls

Unfolding
Pockets

Stamping
Patterning

Corner Relief
Creating Corners

Creating Chamfers
Mapping Elements

Saving As DXF
Reference Elements 
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Managing the Default Parameters

Managing the Default Parameters

This section explains and illustrates how to use or modify various kinds of features.
The table below lists the information you will find.

Using Sheet Metal Design assumes that you are in a CATPart document.

 

Edit the parameters: select the Parameters tab et the wall thickness and bend radius 
values.

Modify the bend extremities : select the Bend Extremities tab and choose a 
predefined bend type. 

Define the bend corner relief: select the Bend Corner Relief tab and choose a 
predefined corner relief type. 

Define the bend allowance: select the Bend Allowance tab and define the allowance 
value (K factor).

 
[ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt0100.htm10/21/2004 8:13:23 AM



Editing the Sheet and Tool Parameters

Editing the Sheet and Tool Parameters

This section explains how to change the different sheet metal parameters needed to create your first feature.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed.

2.  Change the Thickness if needed.

 3.  Change the Minimum Bend Radius if needed.
The Minimum Bend radius defines the minimum internal radius allowing the creation of a bend. If the bend has a radius smaller than the one defined here, it will not be created.

You can set the value to 0 to create bend with no radius. If using the DIN standard, the KFactor automatically sets to 0 as well.

This option only relevant with the NEW SheetMetal Design workbench.

4.  Change the Default Bend Radius if needed.
The Default Bend Radius corresponds to the internal radius and is linked by default to the creation of the bends.

Convention dictates that the inner angle between the two elements is used to define the bend.
It can vary from 0° to 180° exclusive. This angle is constant and the bend axis is rectilinear.

This option is only relevant with the NEW SheetMetal Design workbench.

5.  Click OK to validate the Sheet Metal Parameters.

 
The Standard field displays the Standard to use with the part, if implemented. The name of this standard file is defined in a Design Table.
When the Check all the bend radii button is checked, and you click OK in the Sheet Metal Parameters dialog box, existing bend radii are checked and a list displays flanges or bends that do not use the minimum Bend Radius value 
as defined in step 3. Therefore, they will not be modified.
Parameters can be defined in a Design Table. To do so, press the Sheet Standards Files... button to access to the company defined standards, if need be. For more information, refer to the Customizing Standard Files section.

All parameters hereafter, or only some of them, can be defined in this Design Table:
 Sheet Metal Parameters Column associated in the Design Table Definition

Standard in Sheet Metal 
Parameters SheetMetalStandard sheet reference name

Thickness Thickness sheet thickness
Minimum Bend Radius MinimumBendRadius minimum bend radius
Default Bend Radius DefaultBendRadius default bend radius
K Factor KFactor neutral fiber position
Radius Table RadiusTable path to the file with all available radii

Whenever both Radius Table and Default Bend Radius are defined in the Design Table, only the Radius Table will be taken into account for the bend creation.

 Standard Names For Holes Column associated in the Design Table Definition
Clearance Hole ClearanceHoleStd path to the Clearance Hole Standard file
Index Hole IndexHoleStd path to the Index Hole Standard file
Manufacturing Hole ManufacturingHoleStd path to the Manufacturing Hole Standard file
Fastener Hole FastenerHoleStd path to the Fastener Hole Standard file

 Standard Names For Stamps Column associated in the Design Table Definition
Flanged Hole ExtrudedHoleStd path to the Flanged Hole Standard file
Bead BeadStd path to the Bead Standard file
Circular Stamp CircularStampStd path to the Circular Stamp Standard file
Surface Stamp SurfaceStampStd path to the Surface Stamp Standard file
Flanged CutOut FlangedCutoutStd path to the Flanged CutOut Standard file
Curve Stamp CurveStampStd path to the Curve Stamp Standard file

 When a parameter refers to a path, another sub-Design Table will be associated to the corresponding feature.
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Editing the Sheet and Tool Parameters

 
1. Here is an example for the use of a bend allowance table:

 Main Sheet Metal Parameters Design Table
 

 Radius Table For Thickness 2 
This table defines available all bend radii for a thickness of 2 mm. A design table will be created on the Default Bend Radius of the Sheet Metal Parameters and on the Radius of each bend.

 

 Bend Table for Thickness 2 and Bend Radius 1
Whenever a bend is created, a radius table will be associated. If the configuration "Bend Radius = 1mm" is selected,  a new design table (the Bend Table) will be created from BendTableT2R1.xls in order to compute the bend 
allowance.
According to the open angle, the bend deduction will be read in the Allowance column or interpolated if necessary.

 

 
2. Here is an example for the use of a hole standard file:

 Main Sheet Metal Parameters Design Table
 

 Hole Standard 
Whenever a hole is created, a design table will associate its radius with a standard name.

 

 
3. Here is an example for the use of a stamp standard file:

 Main Sheet Metal Parameters Design Table
 

Whenever a stamp is created, a design table will associate its dimension with a standard name.
     
 

●     Surface Stamp

     
 

●     Curve Stamp
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Editing the Sheet and Tool Parameters

     
 

●     Circular Stamp

     
 

●     Bead

     
 

●     Bridge

     
 

●     Flanged Cutout

     
 

●     Extruded Hole
(or Flanged Hole in the NEW SheetMetal Design workbench)

     
 

●     Stiffening Rib
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Modifying the Bend Extremities

Modifying the Bend Extremities

This section is only available with the SheetMetal Design products.

This section explains how to change the bend extremities.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed.

The second tab concerns the bend extremities.

A combo box displays the six possible axial 
relimitations for the straight bend:

These options can also be accessed through 
the pop-up button:

 

●     Minimum with no relief: the bend 
corresponds to the common area of the 
supporting walls along the bend axis.

●     Square relief: a square relief is added to 
the bend extremity. The L1 and L2 
parameters can be modified if need be.

●     Round relief: a round relief is added to 
the bend extremity. The L1 and L2 
parameters can be modified if need be.

●     Linear: the unfolded bend is split by two 
planes going through the corresponding 
limit points (obtained by projection of the 
bend axis onto the edges of the 
supporting walls).
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Modifying the Bend Extremities

●     Tangent: the edges of the bend are 
tangent to the edges of the supporting 
walls.

●     Maximum: the bend is calculated 
between the furthest opposite edges of 
the supporting walls.
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Defining the Bend Corner Relief

Defining the Bend Corner Relief

This section is only available with the SheetMetal Design products.

This section explains how to change the bend corner relief.

Open the CornerRelief01.CAPTPart model from the samples directory.
Within the Tools -> Options -> General -> Parameters -> Knowledge tab, check 
the Load Extended Language Libraries option.

1.  Click the Sheet Metal 

Parameters icon .

The Sheet Metal 
Parameters dialog 
box is displayed.

The third tab concerns 
the bend corner relief.

By default, no corner relief is created when a bend is created. Check the Automatic 
corner relief creation option to activate this creation every time a bend is created.

Three corner relief types are available. Select the icon corresponding to the requested 
type:

●      : 
square: the square corner relief is created using the 
bend limits. Its dimensions are defined by the width of 
the unfolded bends.

●      : 
circular: its center is located at the intersection of 
the bend axes. For that option, a radius is proposed 
by default. It is equal to the bend radius + the 
thickness. To change it: 
●     Select Formula -> Deactivate from the 

contextual menu of the input field and enter a new 
value,

●     click on the  button and entering a new formula.
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Defining the Bend Corner Relief

●      :
triangular: the triangular relief is created from the 
intersection point of the inner bend limits towards the 
intersection points of the outer bend limits with each 
wall. 

The corner relief is not previewed during its creation.

The corner relief is taken into account in the unfolded view.
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Defining the Bend Corner Relief

●     For better result, you should select the Maximum Bend Extremities option when 
creating corner relief.

●     These parameters are applied to each corner relief created or to be created, except 
to those with that have been redefined, or the locally defined corner relieves.
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Computing the Bend Allowance

Computing the Bend Allowance

This section explains the calculations related to folding/unfolding operations.

1.  Click the SheetMetal Parameters 

icon .

The Sheet Metal Parameters 
dialog box is displayed.

The fourth tab concerns the bend 
allowance.

 ●     Bend Allowance

 The bend allowance corresponds to the unfolded bend width.

 
 

bend < 90° bend > 90° 
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Computing the Bend Allowance

 L is the total unfolded length
A and B the dimensioning lengths as defined on the above figure. They are 
similar to the DIN definition.

 ●     K Factor

 Physically, the neutral fiber represents the limit between the material compressed area 
inside the bend and the extended area outside the bend. Ideally, it is represented by 
an arc located inside the thickness and centered on the bend axis. 

The K factor defines the neutral fiber 
position:

W = α * (R + k * T)

where:

W is the bend allowance
R the inner bend radius
T the sheet metal thickness
α the inner bend angle in radians.

If β is the opening bend angle in degrees:

α = π * (180 - β) / 180

When you define the sheet metal parameters, a literal feature defines the default K 
Factor and a formula is applied to implement the DIN standard. This standard is 
defined for thin steel parts. Therefore the K Factor value ranges between 0 and 0.5.

The DIN definition for the K factor slightly differs. 

W = α * (R + k' * T/2)
Therefore k' = 2 * k and ranges from 0 to 1.

 This formula can be deactivated or modified by right-clicking in the K factor field and 
choosing an option from the contextual menu. It can be re-activated by clicking the 
Apply DIN button. Moreover, the limit values can also be modified.
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Computing the Bend Allowance

 When a bend is created, its own K Factor literal is created. 
Two cases may then occur:

a.  If the Sheet Metal K Factor has an activated formula using the default bend 
radius as input parameter, the same formula is activated on the bend K Factor 
replacing the default bend radius by the local bend radius as input.

b.  In all other cases, a formula "equal to the Sheet Metal K Factor" is activated on 
the local bend K Factor.
This formula can also be deactivated or modified.

 ●     Bend Deduction

 When the bend is unfolded, the sheet metal deformation is thus represented by the 
bend deduction V, defined by the formula:

L = A + B + V
(refer to the previous definitions). 

Therefore the bend deduction is related to the K factor using the following formula:

V = α * (R + k * T) - 2 * (R + T) * tan ( min(π/2,α) / 2)

 This formula is used by default. However, it is possible to define bend tables on the 
sheet metal parameters. These tables define samples: thickness, bend radius, open 
angle, and bend deduction. In this case, the bend deduction is located in the 
appropriate bend table, matching thickness, bend radius, and open angle. If no 
accurate open angle is found, an interpolation will be performed. 

 When updating the bend, the bend deduction is first computed using the previously 
defined rules. Then the bend allowance is deduced using the following formula:

W = V + 2 * (R + T) * tan ( min(π/2,α) / 2)

When the bend deduction is read in the bend table, the K factor is not used.
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Creating walls

Creating Walls
 

This section explains and illustrates different methods to create walls.

Create walls from an existing Part: click the icon, and select a face of a wall

Create a wall from a sketch: use the sketcher to define the profile, and set the 
material side.
Create a wall tangent to another one: select a profile coincident with an existing wall, 
and select the wall to which it should be tangent

 Create a wall from an edge: select a wall edge, set the height, limits, angle, then the 
sketch and material sides

 
[ Back ] [ Up ] [ Next ]
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From a Sketch

Creating Walls from a Sketch

This task shows how to create a wall from a sketch.

You must be in the Sheet Metal Workbench, with a .CATPart document open, and you 
must have defined the Sheet Metal parameters. 
Set the sketcher grid to H = 100mm and V = 100mm, using the Tools -> Options, 
Mechanical Design -> Sketcher, Sketcher tab.

1.  Click the Sketcher icon  then select the xy plane.

2.  Select the Profile icon .

3.  Sketch the contour as shown below:

4.  Click the Exit workbench icon  to return to the 3D world.
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From a Sketch

5.  Click the Wall icon .

The Wall Definition dialog box opens.

By default, the Material Side is set to the top.

6.  Click OK.
The Wall.1 feature is added in the specification tree.

The first wall of the Sheet Metal Part is known as the Reference wall.

●     Click the sketcher icon  from the Wall Definition dialog box, if you wish to 

directly edit the selected sketch. When exiting the sketcher, you then go back to the 
wall creation step, without having to reactivate the Wall icon.
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From a Sketch

This is also very useful if you have 
selected an edge from a wall and 

clicked the Wall icon . 

In this case, the sketcher is 
automatically activated and the plane 
defined as being the selected edge's 
plane. 

You can then directly draw a sketch, 
then exit the sketcher and return to 
the wall creation step. 

●     You can directly create a wall with a hole, by selecting a sketch with an inner 
contour (the contours must not intersect):

  

Sketch with inner contour Resulting wall

Note however, that the emptied area is part of the wall and is not a 
separate cutout that can be edited.
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From an Existing Solid

Creating Walls From an Existing Part

This functionality is only available with SheetMetal Design.

This task illustrates how to create a Sheet Metal part using an existing Part, that is 
recognizing the thin part shapes of the Part as created using the  Part Design 
workbench or from a CATIA Version 4 Solid for example.

Open the WallScenario1.CATPart document from the samples directory.

The document contains a Part created in the Part  Design workbench and it looks like 
this:

1.  Click the Walls Recognition icon .
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From an Existing Solid

2.  Click any face to be the reference wall.

The Walls Recognition Definition dialog 
box is displayed. 

3.  Choose the Wall creation mode: 

●     Part body recognition: the whole 
solid is processed and walls are 
created wherever possible

●     Only selected faces: only explicitly 
selected faces of the solid are 
processed and the corresponding walls 
are created.

The Reference wall is indicated in the Walls Recognition Definition dialog box for 
information only (it is grayed out).

4.  Select faces as the Compulsory walls.
These are faces from which the walls are to be generated when there might be 
an ambiguity. For example, if the initial part is a box, you will need to select two 
opposite inner faces and outer faces on the other two sides of the box, in order 
to avoid overlapping when generating the walls. 

5.  Set the Internal profiles recognition mode: 

●     As cut out wall: generates walls with inner contours (no cutout feature is 
generated)

●     One cut out by wall: regardless of how many pockets there are on a face of the 
solid, only one cutout feature is generated per wall

●     One cut out by profile: for each inner contour on the sketch-based solid,  a cutout 
feature is generated

●     None: whether there are pockets on the solid faces, or not, no cutout feature is 
created in the resulting SheetMetal features.

The Generate Bends check button allows the automatic creation of bends as the walls 
are being created, wherever applicable.
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From an Existing Solid

6.  Click Apply.

The walls are generated 
from the Part Design 
geometry.

The Walls Recognition.1 
feature is added to the tree 
view. 

At the same time, the Sheet Metal parameters are created, deduced from the 
Part geometry.

7.  Select the icon  to display the 

sheet metal parameters:

●     the Thickness is equal to 1mm

●     the Bend radius is twice the 
thickness value

●     the Bend Extremities field is set to 
Square relief.

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt0201.htm (3 of 4)10/21/2004 8:14:12 AM
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You can modify a few of these parameters 
The Thickness parameter cannot be modified because it is based, like the bend 
extremities and radius, on the initial solid geometry . However you can modify these 
parameters (bend radius and bend extremities) to be taken into account for sheet 
metal features other than the "recognized" ones.
The bend allowance, being used to unfold the part, and the corner relief affect all 
features, and therefore can be edited even for "recognized" features.

8.  Click OK in the Sheet Metal Parameters when all parameters have been redefined 
where needed.

The solid is now a Sheet Metal part. All the features are displayed in the specification 
tree.
●     Once the solid has been converted to a Sheet Metal part, you can create bends as 

with any other Sheet Metal part, or modify/add Sheet Metal features to complete the 
design.

●     Uncheck the Generate Bends button, if you do not wish bends to be created 
automatically.
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Tangent Walls

Creating Tangent Walls

This task shows how to create a wall tangent to a planar part of another wall or of a 
flange. This capability will then allow this tangent wall to be seen when unfolding the 
part, even though there is no bend linking it to its tangent support, provided this 
support is unfoldable too.

Open the TangentWall1.CATPart document from the samples directory.

1.  Select a face of an existing wall and click the Sketcher icon .

Here we selected the flange's planar face.

2.  Select the Profile icon  and sketch the contour as shown below.

You can also select Sketch.2 from the specification tree.

3.  Using the Constraint Defined in Dialog box icon, set coincidence constraints 
between the edges where the support and sketch are to coincide.

4.  Click the Exit workbench icon  to return to the 3D world.
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Tangent Walls

5.  Make sure the sketch is still active, 

then click the Wall icon .

The Wall Definition dialog 
box opens. 

Note the orientation of the wall to be 
created.

6.  Click inside the Tangent to field, 
then select the wall to which the 
new wall has to be tangent.

Here, you need to select the 
planar face of the flange.

Note that the orientation automatically changes to conform to the material orientation 
already defined on the support wall.

7.  Click OK.
The wall is created and a Wall.xxx 
feature is added in the 
specification tree.
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Tangent Walls

8.  Click the Unfold icon .

The tangent wall is unfolded as a wall linked by a bend to another wall, would be.

If you want to create the wall on a wall that cannot be unfolded, the system issues a 
warning and prevents you from creating the tangent wall.
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Creating Walls From An Edge

This task shows how to create walls from edges of an existing wall. This function is used to 
create a box in an easy and quick way from an existing reference wall.

At least one wall must already exist.

Open the Wall1.CATPart document from the samples directory.

1.  Click the Wall on Edge icon 

 and select an edge of an 

existing wall.  

The Wall On Edge 
Definition dialog box is 
displayed together with 
a preview of the wall. 

2.  Define the type of wall to be 
created by specifying the 
Reference, that is:

●     the Height of the wall: that is the 
orthogonal projection from the top 
of the wall on edge to the 
reference wall.
Select the  icon to define the 
height of the wall from the bottom 
of the reference wall or the  
icon to define the height of the 
wall from the top of the reference 
wall.
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From an Edge

●     the Length of the wall: that is the 
absolute value of the wall on edge 
without bend.

●     the limits of the wall: Limit 1 and Limit 2. These texts only indicate on which side a given 
limit is. They are not precisely on the limit spots. The actual locations of the limits are 

defined with the     icons and an input distance that is taken into account 
respectively from the inner side of an existing bend, the inner side of an existing wall or 
the outer side of an existing wall. 

●     the angle of the wall: by default it is perpendicular to the plane containing the edge. You 
may modify it according to your needs. it is updated dynamically on the screen.

This preview gives information about: 

●     the Sketch Profile: by default, if you pick an edge on the top of the reference wall, the 
direction of the wall is upwards, if you pick an edge on the bottom of the reference wall 
the direction of the wall is downwards. 

Preview with top edge selected Preview with bottom edge selected

You can invert the 
sketch's position, and 
therefore the wall's,  
using the Reverse 
Position button. 
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From an Edge

Preview with bottom edge selected and sketch profile 
inverted

●     the material side: by default the 
material side is proposed so as to 
keep a continuity with the 
reference profile. 

However, you can 
change it by clicking the 
red arrow or the 
Reverse Side button.  

3.  Check the Clearance option 
to offset the wall on edge from 
the selected edge. 

The entered value is the 
radius of the bend on 
this edge. 

Wall on edge with clearance Wall on edge without clearance

Note that the reference wall remains unchanged when changing the bend radius value. It is 
the Wall on Edge's length that is affected.
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4.  You can also choose to create the wall with or without a bend by checking the With 
Bend option.

●     If there is no wall from which a limit can be computed, the reference element is the edge 
of the reference wall.

●     A wall on edge is defined by the 
selected edge (reference edge). 
When the reference edge is 
modified, by adding any feature 
that shortens the edge (a bend to 
an adjacent wall on edge or a 
cutout for example) the wall on 
edge based on this reference edge 
is recomputed.
To avoid this you may:  
❍     create the bend manually on 

the wall modifying the edge 
used as the reference to  create 
the other wall

❍     reorder the creation of walls to 
postpone the creation of the 
modifying feature

 
●     Both limits are computed with the same reference icon.

●     The bend is not previewed, even if the option With Bend is checked. However it will be 
created.

●     The selected options are modal and will be proposed to create the next wall.

●     Walls on edge being contextual features, if you break the profiles continuity by inverting 
the material side of a wall, you may have to manually re-specify all features based upon 
the modified one, even if they are not directly connected to the modified wall, in order to 
update the part afterwards.

This is the case when 
creating a wall on edge 
from another wall on 
edge, for example:
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●     If you invert the material side of 
the reference wall on which the 
first wall on edge has been 
created, both walls on edge are 
relocated (as if you were flipping 
the geometry):

●     If you invert the material side of 
the first wall on edge (and not the 
material side of the reference 
wall), the second wall on edge is 
relocated. Indeed, its specification 
being relative to the first wall on 
edge, when its input data (i.e. the 
edge selected on the first wall on 
edge) is modified, the second wall 
on edge is rebuilt at a new 
location. 

5.  Click OK in the Wall On Edge Definition dialog box.

A WallOnEdge.x element is created in the specification tree.

●     A WallOnEdge.x element can be edited: double-click it in the graphic area or in the 
specification tree to display its creation dialog box and modify the parameters described 
above, including the edge from which it is created. However, the sketch of a wall on edge 
cannot be edited directly.

●     Would you need to edit the sketch of a wall on edge, you have to isolate it first. See 
Isolating Walls.

●     You can cut or copy and paste a wall on edge. 

●     If you cut and paste a wall on edge with children elements, these children elements are 
lost. This may result in update errors.

●     You cannot undo an Isolate action after having modified the wall.

●     Isolating a wall on edge erases all updating data.
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Extruding

Extruding

This task explains how to create a wall by extrusion.

You must have defined the Sheet Metal parameters.
A model is available in the Extrude1.CATPart from the samples directory.

1.  Click the Extrusion icon .

2.  Select a sketch.

The Extrusion Definition dialog box is 
displayed. 

Several types of extrusion are available:  
●     Dimension : the requested input data are a sketch and a dimension,

●     Up to plane or Up to surface: a plane or a surface are input as limit to the 
extrusion. These functions are used to create walls that are not rectangular.

3.  Edit the Length1 and Length2 to set both extremities, for option Dimension.
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Extruding

4.  Define the options as needed:

●     Check the option Mirrored extent to extent the material on both sides of the 
sketch.  In that case, only Length1 can be edited. 

 

This option is only available if the type is set to Dimension.

●     Check Symmetrical thickness to create thickness inside and outside the sketch.
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●     Push Invert Material Side to invert the direction of the creation of the material.

 

5.  Click OK.

The walls corresponding to the selected sketch are created according to 
the specified options, and added to the specification tree.

●     When the extrusion is the first Sheet Metal feature of the Part, the reference wall is 
the first wall created based on the first segment of the sketch.

●     For option Up to Surface, while the wall end that is limited by the surface has the 
shape of the surface, its thickness does not fit the surface. It is a "rectangular" 
polygon defined by the first edge that comes into contact with the surface.
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Extruding

 
●     Such an extrusion can also be performed on a 

sketch made of lines and arcs of circle, provided 
there are no tangency discontinuities between the 
different elements. 
However, in this case: 
❍     the Up to plane or Up to surface capabilities 

are not available, 

❍     you cannot isolate such an extrusion,

❍     if the element of the extruded sketch connected 
to the part is an arc of circle, the extrusion will 
not display in the unfolded view. To avoid this, 
prefer to create a User Defined Flange or 
remove the arc of circle of the extruded sketch 
and create a bend to connect the extrusion to 
the part.

●     Extrusion walls can be edited and/or isolated.

The sketch may not be closed. 
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Isolating Walls

This task explains how to isolate a wall. This is possible in two cases: 

1.  after having created walls by extrusion (see Extruding in SheetMetal Design or 
Extruding in New SheetMetal Design)

2.  after having created a wall on edge (see Creating Walls from an Edge).

You must have defined the Sheet Metal parameters.
A model is available in the Extrude2.CATPart from the samples directory.
If you use the New SheetMetal Design, open the NEWExtrude2.CATPart document.

Isolating Extruded Walls

1.  Right-click the Extrusion.1 feature and 
choose the Extrusion.1 object -> Isolate 
contextual menu item.

The Extrusion Isolate dialog box is 
displayed.  

2.  Select one of the wall of the extrusion to be 
isolated.

The selected wall is highlighted in the 
geometry.
This wall is the reference wall, 
meaning that it can be modified and 
the other walls will take the 
modification into account. On the 
other hand if the other walls are 
modified the reference wall is an 
anchoring wall, and modifications will 
be made around it. 

The Extrusion Isolate dialog box is 
updated.
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Isolating Walls

3.  Click OK in the dialog box.

The walls of the extrusion have been isolated, each with its own sketch. 
Yet coincidence constraints are automatically generated between the 
isolated walls. 

 

The extrusion's initial sketch is retained (Sketch.1 in the example above).

4.  Double-click the sketch of the reference wall 
(here Sketch.3) and modify it by increasing 
its length.
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5.  Exit the Sketcher using the Exit icon .

The Part is updated.

You can note that the wall that was 
adjacent to the pad, now lies on it, as 
it is the reference wall that was 
modified.

However, had you modified the sketch 
of the wall lying on the pad 
(Sketch.4), moving it further away 
from Wall.2 as shown here to the 
right, the updated pad would not take 
the gap between the walls into 
account.

The resulting part looks like this 
(Wall.3 has been modified but still 
coincides with Wall.2):
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Isolating Walls on Edge

1.  Right-click the wall on edge and choose the Wall On Edge contextual menu 
item.

The wall on edge is then changed to a standard wall, as you can see from 
the specification tree. 

 

You can then edit its sketch if needed.

In the present case, the wall on edge 
had been created with a bend. 
Therefore when isolating this wall from 
the reference wall, the bend is created 
as a separate feature that can be 
edited as well.

The angle value between the two walls 
is displayed for edition.

●     You cannot undo an Isolate action after having modified the wall.

●     Isolating a wall on edge erases all updating data.
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Creating Rolled Walls

Creating Rolled Walls

This task shows how to create rolled walls (such as pipes, open pipes with flange, etc.).

You must have defined the Sheet Metal parameters, and have a sketch available, in 
the form of an circular arc.
The part is available in the Rolledwall1.CATPart from the samples directory.

1.  Click the Extrusion icon .

2.  Select the circular sketch.

3.  Make sure the type is set to Dimension.

4.  Length 1 and Length 2 indicate the location 
of Limit 1 and Limit 2.

5.  Define the options as needed (the length being down to -50 mm):
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Creating Rolled Walls

●     Check the option Mirrored extent to extend the 
material on both sides of the sketch. In that case, 
only Length1 can be edited.

●     Check Symmetrical thickness to create thickness 
inside and outside the sketch.

●     Push Invert Material Side to invert the direction 
of the creation of the material.

6.  Click OK in the dialog box to create the rolled 
wall:
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The rolled wall is a particular extrusion: 
●     the input sketch is either a circular arc or a closed circle,

●     the creation type is always Dimension.

The sketch may be open. In that case, you can define where the opening should be.

The sketch may be closed. In that case, you have no control on the opening location.

The only operations you can combine with a rolled wall in a Sheet Metal model are 
flanges and cutouts. 

No other elements (standard wall, bend,...) are allowed.
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Creating Bends

Creating Bends on Walls
 

This section explains and illustrates different methods to create bends on walls. Bends can 
only be created between walls, whether manually or automatically, and not between any 
other Sheet Metal features, such as stamps for example.

Create bends from wall: select the two walls, set the bend radius value, the bend 
extremities, and specify the use of corner relief
Generate bends automatically: select the part, then a reference wall

Create conical bends: select the part, and choose a reference wall

Create flat bends: select a sketch, set the creation mode and limiting option, set the 
radius and angle in relation to the selected sketch.
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Manually Creating Bends from Walls
This task explains two ways to create bends between walls in the Sheet Metal part.
These bends can be created on non-connex walls, and with a constant radius value.

Open the BendExtremities01.CATPart document from the samples directory.

1.  Select the Bend icon .

The Bend Definition dialog 
box opens.

Note that the Radius field is in gray because it is driven by a formula when editing the 
sheetmetal parameters: at that time, you cannot modify the value.

2.  Select Wall.2 and Wall.5 in the specification tree.
The Bend Definition dialog box is updated.

3.  Right-click the Radius field and 
select Formula -> Deactivate 
from the contextual menu to 
change the value.
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4.  Enter 4mm for the Radius and click 
Preview.

The bend is previewed, along 
with its orientation 
symbolized by arrows. The 
Left and Right texts further 
indicate this orientation and 
are useful to define different 
bend extremities. 

5.  Click the More>> button to display further options: 

You can define:  
●     the left and right extremity settings (see also extremities definition settings)

●     the corner relief definition settings

●     and the bend allowance settings.

6.  Within the Left Extremity tab, 
choose the Mini with round relief 
bend extremity type, deactivate the 
L1  and L2 length formulas, and set 
them to 6mm and 3mm 
respectively.
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Manually Creating Bends from Walls

7.  Click the Right Extremity tab, and 
choose the Curved shape type.

8.  Click Preview to visualize the left 
and right extremities.

9.  Click OK in the Bend Definition 
dialog box.

The Bend (identified as 
Cylindrical Bend) is created 
with the specified extremity 
types and is added to the 
specification tree. 

●     The extremities and the corner relief defined with the current dialog box will apply locally 
and prevail over any other global definition.

●     Be careful when creating bends with square or round relief. Depending on the geometry 
configuration, this can lead to removing more matter than you would expect. Indeed, a 
corner relief being computed on the whole intersection of the elements involved (bends or 
bend/wall), in the following configuration, the matter is removed till the end of the wall.

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt0202.htm (3 of 4)10/21/2004 8:15:36 AM



Manually Creating Bends from Walls

Bend with no relief Bend with square relief
In this case, it is best to replace the bend corner relieves with cutouts (identified 
in red in the figure below) that will act as corner relieves removing matter to the 
part.
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Generating Bends Automatically

Generating Bends Automatically

This functionality is only available with SheetMetal Design.

This task explains how to automatically generate bends between walls in the Sheet 
Metal part. You can first create all the bends, then modify the parameters for any of 
the generated bends.
However, when an ambiguity arises, that is when more than two bends end on the 
same vertex, the bends are not automatically generated. You then need to create 
them manually, so as to explicitly select the walls between which the bends are to be 
created.

Open the BendExtremities01.CATPart document from the samples directory.

1.  Select the Automatic Bends icon .

The bends are created. 
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Generating Bends Automatically

2.  Double-click the bend 
of interest: Bend.4
The Bend Definition 
dialog box opens.

3.  Right-click the Radius 
field: the contextual 
menu appears.

4.  Deactivate the formula:
you can now change 
the value.

5.  Enter 4mm for the 
Radius and click 
Preview.

Bend.4 is 
modified. 

6.  Click the More button to display further options: 
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Generating Bends Automatically

You can re-define:  
●     the left and right extremity settings (see also extremities definition settings)

●     the corner relief definition settings

●     and the bend allowance settings.

7.  Within the Left 
Extremity tab, choose 
the Mini with round 
relief bend extremity 
type, deactivate the 
L1  and L2 length 
formulas, and set them 
to 6mm and 3mm 
respectively.

8.  Click the Right 
Extremity tab, and 
choose the Curved 
shape type.

9.  Click OK in the Bend Definition dialog box.

The bend is modified with the specified options
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Generating Bends Automatically

The extremities and the corner relief defined with the current dialog box will apply 
locally and prevail over any other global definition.
 Push the more button to display:

●     the extremities definition settings,

●     the corner relief definition settings, 

●     and the bend allowance settings.
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Conical Bends

Creating Conical Bends

This functionality is only available with SheetMetal Design.

This task explains how to generate conical bends between two walls in the Sheet Metal 
part.
These bends are different from the standard bend in that they allow different radius 
values at each end of the bend.

Open the ConicalBend1.CATPart document from the samples directory.

1.  Select the Conic Bend icon .

The Conic Bend Definition dialog box opens.

2.  Select Wall.1 and Wall.2 in the specification 
tree or in the geometry.
The Bend Definition dialog box is updated, and 
arrows are displayed indicating the walls 
orientation.

You can click on the arrow to invert them 
if needed.

The LIM1 and LIM2 texts indicate the 
endpoints for the bend.
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Conical Bends

3.  Enter the radius values for each end of the conical bend.
If the difference between the specified radius values does not allow the 
generation of a cone with an angle greater than 1 degree, a warning is issued 
prompting you to increase one of the radii.
Click OK in the Warning dialog box, and increase/decrease the radius values.

By default, Radius 2 is twice Radius 1.

4.  Click More... to display further options.

5.  Choose the bend extremities:

●     Mini with no relief: the shortest possible bend is created, and presents no relief

●     Curve shaped: the bend is created keeping the tangency continuity with the 
support walls.

●     Maximum: the bend is calculated between the furthest opposite edges of the 
supporting walls.
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Conical Bends

6.  Click OK.

The Bend is created. 

●     The two walls must be connected by the edge of their internal faces.

●     The Angle field is locked. It indicates the angle value between the two walls 
between which the bend is computed.

●     Should you choose the Curve shaped extremity option, the bend would look like 
this:
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Bends From Line

Creating Bends From a Line

This task explains how to generate bends based on a line (also called flat bends). A wall 
and a bend are created.

Open the FlatBend1.CATPart document from the samples directory.

1.  Select the reference wall then the 

Bend From Flat icon .

The Bend From Flat Definition 
dialog box opens.

2.  Select a sketch (Sketch.3 here).
This sketch must necessarily be a line.

3.  You can choose the line extrapolation option:

●      the line is extrapolated up to the wall edge (Bend From Flat Until)

●      the line is not extrapolated, and the bend is limited to the line's length (Bend 
From Flat Length)

The Radius value is the one defined when editing the sheetmetal 
parameters:
Right-click the Radius field and select Formula -> Deactivate from the 
contextual menu to change the value.
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Bends From Line

4.  Set the angle value between the generated wall and the reference wall.

5.  Click OK to create the bend.

     
●     When creating such a bend on a reference 

wall (first wall), an arrow indicates which 
part is to be folded. Click this arrow to 
invert the side that will be bent.

 

●     Such bends cannot be created, if the 
section to be folded already intersects the 
part. 

 ●     Bends from line should be performed on end walls, or prior to creating further walls 
on the bent one.

●     Perform the bend before creating the stamping features, as stamps are not retained 
when the part is folded with the bend.
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Creating Swept Walls

Creating Swept Walls
 

This section explains and illustrates how to create and use various kinds of swept walls, i.e. 
walls based on a given contour that is swept along a spine.

Create a flange: select a spine, and set the radius, length, and angle values.

Create a hem: select a spine, and set the radius, and  length values.

Create a tear drop: select a spine, and set the radius, and  length values.

Create a swept flange: select a spine, and a user-defined profile

Redefine swept walls limits: choose the Relimited type, and select a point lying on 
the spine or a plane normal to the spine and intersecting it as limits

Display swept walls axes in drafting sheets: open a CATDrawing document, click the 
Unfolded View icon, and select a plane

Selecting the Spine
Whatever the type of the swept wall you wish to create, you first need to select one or more 
contiguous edges to make up the spine along which the contour, either pre- or user-defined, 
is to be swept. You can:

●     manually select one, or more, edge(s)

Selection without propagation Resulting flange without propagation
    
●     select  one edge and click the Tangency Propagation button: all contiguous and tangent 

edges are selected. In this case, would you need to remove one edge, you need to 
manually select it. Remember that only extremity edges can be removed without breaking 
the continuity between edges.
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Creating Swept Walls

Selection with propagation Resulting flange with propagation
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Creating a Flange

Creating a Flange

This task explains how to generate a flange from a spine and a profile.

Open the SweptWall01.CATPart document from the samples directory.

1.  Select the Flange icon .

  

The Flange Definition dialog box 
opens. 

2.  Select the edge as shown in red.
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Creating a Flange

3.  Enter 2mm in the Radius field,
10mm in the Length field and 120° for 
the Angle.

4.  Click the More button to display the Bend Allowance tab allowing you to locally 
redefine the bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field 
and choosing Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet 
Metal Parameters.

5.  Click OK to create the flange.
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Creating a Flange

The feature is added to the specification tree.

●     Use the Tangency Propagation button to select all tangentially contiguous edges 
forming the spine (see Selecting the Spine).

●     You can redefine the flange limits by choosing the Relimited option (see Redefining 
Swept Walls Limits).
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Creating a Hem

Creating a Hem

This task explains how to generate a hem from a spine and a profile.

The SweptWall01.CATPart document is still open from the previous task.
If not, open the SweptWall02.CATPart document from the samples directory.

1.  Select the Hem icon  in the Swept Walls 

sub-toolbar.

The Hem Definition dialog box opens.

2.  Select the edges as shown in red.
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Creating a Hem

3.  Enter 2mm in the Radius field, and 3mm in the 
Length field.

4.  Click the More button to display the Bend Allowance tab allowing you to 
locally redefine the bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field 
and choosing Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet 
Metal Parameters.

5.  Click OK to create the hem.
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Creating a Hem

The feature is added to the specification tree.

●     Use the Tangency Propagation button to select all tangentially contiguous edges 
forming the spine (see Selecting the Spine).

●     You can redefine the hem limits by choosing the Relimited option (see Redefining 
Swept Walls Limits).
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Creating a Tear Drop

Creating a Tear Drop

This task explains how to generate a tear drop from a spine and a profile.

The SweptWall01.CATPart document is still open from the previous task.
If not, open the SweptWall03.CATPart document from the samples directory.

1.  Select the Tear Drop icon  in the Swept 

Walls sub-toolbar.

The Tear Drop Definition dialog box 
opens.

2.  Select the edge as shown in red.
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Creating a Tear Drop

3.  Enter 3mm in the Radius field, and 8mm in the 
Length field.

4.  Click the More button to display the Bend Allowance tab allowing you to 
locally redefine the bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field 
and choosing Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet 
Metal Parameters.

5.  Click OK to create the tear drop.
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Creating a Tear Drop

The feature is added to the specification tree.

 

●     Use the Tangency Propagation button to select all tangentially contiguous edges 
forming the spine (see Selecting the Spine).

●     You can redefine the hem limits by choosing the Relimited option (see Redefining 
Swept Walls Limits).
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Creating a Swept Flange

Creating a Swept Flange 

This task explains how to generate a swept flange from a spine and a user-defined 
profile.

The SweptWall01.CATPart document is still open from the previous task.
If not, open the SweptWall04.CATPart document from the samples directory.

1.  Using the Sketcher , define a profile in the yz plane as shown below:

Then quit the Sketcher, using the Exit icon .

2.  Select the Swept Flange icon in the Swept 

Walls sub-toolbar.

The User Defined Flange Definition dialog 
box opens. 

3.  Select the edge and the profile, as shown in red.
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Creating a Swept Flange

The dialog box looks like this:

4.  Click the More button to display the Bend Allowance tab allowing you to 
locally redefine the bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field 
and choosing Formula -> Deactivate before editing the value.

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt0603.htm (2 of 3)10/21/2004 8:17:56 AM



Creating a Swept Flange

In this case, the new K Factor value overrides the value set in the Sheet 
Metal Parameters.

5.  Click OK to create the swept flange.

The feature is added in the specification tree.

 

●     Use the Tangency Propagation button to select all tangentially contiguous edges 
forming the spine (see Selecting the Spine).

●     You can redefine the hem limits by choosing the Relimited option (see Redefining 
Swept Walls Limits).
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Redefining Swept Wall Limits

Redefining Swept Wall Limits

This task explains how to redefine the spine's limits when creating any type of swept 
walls, using existing geometric elements: points lying on the spine or intersecting 
planes.

Open the SweptWall01.CATPart document.

1.  Select the Flange icon .

The Flange Definition dialog box opens. 

2.  Using the combo list, choose the Relimited 
type.

The Flange Definition dialog box is 
updated and now displays two Limit 
fields. 

3.  Select the spine.
Here we select a single edge. See also 
Selecting the Spine.
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Redefining Swept Wall Limits

4.  Successively select the two limiting elements. 
Here we select a point lying on the spine as 
the first selecting element, and a plane 
intersecting the spine as the second limiting 
element.

Make sure intersecting elements are normal to the spine, and they intersect it only 
once.

5.  Specify the swept wall values.
In the example of the flange you set the Radius, Length and Angle values. You 
may also click More >> to display further options. See Creating a Flange. 

6.  Click OK.

The swept wall is created within the limits on the spine.
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Displaying Swept Walls Axes

Displaying Swept Wall Axes
This task explains how to generate an unfolded view of a part with swept wall in a 
drawing sheet including the axes of planar hems, tear drops, and flanges are displayed 
within the drawing.

Open the SweptWall01.CATPart document from the samples directory. 

If you use the NEW Sheet Metal Design, open the NEWSweptWall1.CATPart document.

 Make sure that the Generate axis button is checked in the Tools -> Options -> 
Mechanical Design -> Drafting -> View tab, prior to generating a view in a .
CATDrawing document.

1.  Click  or select File -> New...

2.  Select the Drawing type and click OK.

3.  Click OK.

For more information about this workbench, refer to Generative Drafting User's Guide.
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Displaying Swept Walls Axes

4.  The drawing sheet appears.

5.  Tile the windows horizontally using the Window -> Tile Horizontally menu 
item.

6.  Select the Unfolded View icon  in the Projections toolbar from Generative 

Drafting Workbench.

This icon is added to the Projections toolbar provided the NEW Sheet Metal 
workbench is present.

7.  Choose the xy plane in the Sheet Metal specification tree.
The unfolded view is displayed with the planar swept wall axes.
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Unfolding

Unfolding
Unfolded Sheet Metal parts can be displayed in two ways:

Folded/Unfolded View Access
Concurrent Access

 
Each Sheet Metal feature is created in a given view: folded, or unfolded. Editing a 
feature must be done in its definition view. If not, a message is automatically issued, 
prompting you to change views, before editing the feature.
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Folded/Unfolded View Access

Folded/Unfolded View Access

This task shows how to unfold the part. 

1.  Click the Unfold icon .

The part is unfolded according to the reference wall plane or web, as 
shown below. 

2.  Click this icon  again to refold the part for the next task.

●     In Sheetmetal Design, bend limits and stamping are now displayed in the unfolded 
view. However, cutouts created on stamps are not.

●     When designing in context, if a CATProduct document contains several Sheetmetal 
parts, only one part can be visualized in the unfolded view at a time.
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Concurrent Access

Concurrent Access

This functionality is P2 for Sheetmetal Design.

This task explains how to display the Sheet Metal part in two windows: one with the folded view, one 
with the unfolded view. Any modification in one window is displayed in the other window.

1.  Click the Multi-view icon .

The part is unfolded in a second window.  

2.  Choose the Window -> Tile Horizontally menu item.

Both windows are tiled. Activate the window in which you want to work. 
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Concurrent Access

●     Any modification in one view is taken into account in the other view enabling the user to make 
modifications in the best possible context.

●     In the multi-view mode as in the standard unfolded view, all constraints are displayed in the 
geometrical views.

●     Once in the Multi-view mode, the standard icon Unfold is not longer available.

●     The Multi-view function is not available from a standard unfolded view.

●     Only parts with bends can be unfolded.

●     Cutting faces and open faces are not displayed in Multi-view mode (Sheetmetal Design)
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Pockets

Pockets
Creating a Cutout
Splitting Geometry

 
[ Back ] [ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt1600.htm10/21/2004 8:19:05 AM



Creating a Cutout

Creating a Cutout
This task explains how to create a cutout in a wall.
Creating a cutout consists in extruding a profile and removing the material resulting from the 
extrusion.

Open the Cutout1.CATPart document.

1.  Click the Cutout icon .

2.  Select a profile.

        
 

The Pocket Definition dialog box is displayed and 
CATIA previews a cutout with default parameters. 

 
Once the sketch is selected, you can modify it by clicking the Sketcher icon .

3.  Select the type.
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Creating a Cutout

Several limit types are available: 

●     Dimension: the cutout depth is defined by the specified value

●     Up to next: the limit is the first face the application detects while extruding the profile. This face 
must stops the whole extrusion, not only a portion of it, and the hole goes through material.

●     Up to last: the last face encountered by the extrusion is going to limit the cutout

●     Up to plane: the cutout is limited by the selected plane

●     Up to surface: the cutout is limited by the selected surface

When an Offset value is required, it is the distance between the limiting element and the top face 
of the cutout, if the latter does not result in a complete hole through the material.

The LIM1 and LIM2 texts in the geometry area indicate the top and bottom limits of the cutout.

●     The Reverse Side option lets you choose between removing the material defined within the 
profile, which is the application's default behavior, or the material surrounding the profile. 

●     The Reverse Direction option allows you to invert the direction of the extrusion pointed by the 
arrow.

4.  Click OK in the Pocket Definition dialog box.

The cutout is created. 

You may want to fold or unfold the part prior to creating the cutout, depending on the selected 
profile and the expected results. Selecting the same profile, the resulting cutout when created in the 
unfolded view is seen above, while below, the cutout was created in folded view.
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Creating a Cutout

However, you also have to be careful when designing the Part, not to create the cutout in the 
unfolded view as this may lead, when folding the part, to completely or partially removing another 
section of the Part. It is best, whenever possible, to create the wall based on a sketch integrating 
the shape of the cutout.

Cutout removing material Cutout not removing material based on wall's 
sketch modification

4.  Click More>> to display the maximum information.

●     You can define 'Limit2' as the second limit by 
using the same options as for Limit 1 
(Dimension, Up to last, up to plane, up to 
surface). 

●     You can choose between a direction normal to 
the profile or define a new direction by 
selecting geometry in the Reference field.

●     You can choose the cutout to be normal to the 
sheet metal part: check the Activation button 
and define the sheet metal side.
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Creating a Cutout

5.  Select the Support (here we chose the wall)

May you want to create a cutout on an overlapping element or a bend with radius=0, either choose 
the top skin of the element, or unfold the part to create the cutout.

●     Refer to the Component Catalog Editor documentation to have further information on how to use 
catalogs.

●     Refer to the Create a Pocket task in the Part Design User's Guide for further details on how to 
create cutouts.
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Splitting Geometry

Splitting Geometry

This functionality is only available with SheetMetal Design.

This task shows how to create a split normal to a sheet metal part by means of a 
cutting surface.

Open the Split1.CATPart document.

1.  Click the Split icon .

The Split dialog box appears. 

2.  Select the Splitting Surface.

3.  Select the Reference Side of the 
element to split.

 

The red arrow shows the side to keep
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Splitting Geometry

4.  Click the Inverse Side button to keep the other side.

5.  Click Apply to preview the split: the 
side to be removed is highlighted in 
green. 
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Splitting Geometry

6.  Click OK to split the element.

The created element 
(identified as Split.xxx) is 
added to the specification tree.
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Splitting Geometry

You can create a split using the unfolded view of the part.
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Stamping

Stamping
This section explains and illustrates how to create and use various kinds of stamps.

●     Stamps must be created on walls, or walls on edge, except for the stiffness rib that 
is to be created on a bend. 

●     If a stamp is created over the limit between several supports, such as walls, bends, 
and so forth, this stamp is not visible on the unfolded view.

●     When unfolding a part, only the largest imprint of the stamp is retained on the 
stamped wall.

●     Stamps cannot be created on an unfolded part.

Standard Features
Creating User-defined Stamping Features
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Standard Features

Creating Standard Stamping Features
 

This section explains and illustrates how to create and use various kinds of stamps.
The table below lists the information you will find.

Create a point stamp: select a point on a face, and set the stamping parameters. 

Create an extruded hole: select a point on a face, and set the stamping parameters. 

Create a curve stamp: select a sketch, and set the stamping parameters. 

Create a surface stamp: select a sketch, and set the stamping parameters. 

Create a bridge: select a point on a face, set the stamping parameters, and select an 
edge to give the bridge orientation. 

Create a louver: select a sketch, and set the stamping parameters. 

Create a stiffness rib: select the external surface of a bend, and set the stamping 
parameters. 
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Creating a Point Stamp

Creating a Point Stamp

This task shows you how to create a point stamp by specifying the punch geometrical parameters.

Open the Stamping.CATPart document from the samples directory.

1.  Click the Point Stamp icon .

2.  Select a point on the top face. 

A grid is displayed to help you position 
the point stamp.

The Point Stamp Definition dialog box opens, providing default values.

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

●     Diameter D

4.  Click Apply to preview the point stamp.
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Creating a Point Stamp

 5.  Click OK to validate.

The point stamp (identified as Point Stamp.xxx) is created and the specification tree is updated 
accordingly.

 

Check the No radius option to deactivate the 
Radius R1 and R2 values, and to create the bridge 
stamp without a fillet.
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Creating a Flanged Hole

Creating an Extruded Hole

This task shows you how to create an extruded hole by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.
If not, open the Stamping8.CATPart document.

1.  Click the Extruded Hole icon .

2.  Select the surface where you want to 
place the hole.

A grid  is displayed to help you 
position the flanged hole and the 
Flanged Hole Definition dialog box 
opens, providing default values.

3.  Change the value in the different 
fields, if needed:

●     Height H

●     Radius R

●     Angle A

●     Diameter D

4.  Click Apply to preview the flanged hole.

5.  Click OK to validate. 

The extruded hole (identified as Extruded Hole.xxx) is created and the specification tree is updated 
accordingly.
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Creating a Flanged Hole

Check the No radius option to deactivate 
the Radius R1 and R2 values, and to create 
the point stamp without a fillet.
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Creating a Curve Stamp

Creating a Curve Stamp

This task shows you how to create a curve stamp by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.
If not, open the Stamping3.CATPart document from the samples directory.

1.  Click the Curve Stamp icon .

2.  Select Sketch-for-Curve-Stamp, the curve previously defined. 

The Curve Stamp Definition dialog box opens, providing default values.

3.  Change the value in the different fields, if needed:

●     Height H: the total height

●     Radius R1: the outer bend radius

●     Radius R2: the outer bend radius

●     Angle A: the stamping draft angle 

●     Length L: the stamps' maximum width

4.  Click Apply to preview the curve stamp.

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt0716.htm (1 of 3)10/21/2004 8:20:31 AM

http://pop.dia.uniroma3.it/catia/online/sheug_C2/samples/Stamping.CATPart
http://pop.dia.uniroma3.it/catia/online/sheug_C2/samples/Stamping3.CATPart


Creating a Curve Stamp

5.  Click OK to validate.

The curve stamp (identified as Curve Stamp.xxx) is created and the specification tree is updated accordingly.

●     Check the No radius option to deactivate the Radius R1 and 
R2 values, and to create the curve stamp without a fillet.

 ●     Check the Obround option to round off the edges of the curve 
stamp.
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Creating a Curve Stamp

 

Obround option checked Obround option unchecked
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Creating a Surface Stamp

Creating a Surface Stamp

This task shows you how to create a surface stamp by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.
If not, open the Stamping4.CATPart document from the samples directory.

1.  Click the Surface Stamp icon .

2.  Select Sketch-for-Surface-Stamp, the profile previously defined. 

The Surface Stamp Definition dialog box opens, providing default values.

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

4.  Click Apply to preview the surface stamp.

5.  Click OK to validate.

The surface stamp (identified as Surface Stamp.xxx) is created and the specification tree is 
updated accordingly.
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Creating a Surface Stamp

 

Check the No radius option to deactivate the 
Radius R1 and R2 values, and to create the 
surface stamp without a fillet.
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Creating a Bridge

Creating a Bridge

This task shows you how to create a bridge by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.
If not, open the Stamping5.CATPart document from the samples directory.

1.  Click the Bridge icon .

2.  Select a point on the top face where you want to place the bridge.

The Bridge Definition dialog box opens, providing default values. 

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

●     Length L1

●     Length L2

4.  Select an edge to give the direction of 
the bridge.
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Creating a Bridge

5.  Click Apply to preview the bridge.

 6.  Click OK to validate.

The bridge (identified as Bridge.xxx) is created and the specification tree is updated accordingly.

 

Check the No radius option to deactivate the 
Radius R1 and R2 values, and to create the 
bridge stamp without a fillet.
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Creating a Louver

Creating a Louver 

This task shows you how to create a louver by specifying the punch geometrical parameters.

Open the Stamping6.CATPart document from the samples directory.

1.  Click the Louver icon .

2.  Select Sketch-for-Louver, a profile previously defined on Wall.2. The Louver Definition dialog box opens, 
providing default values.

The louver opening face is represented in the sketch by the element that does not present any tangency continuity 
with the other lines/curve segments of the sketch. In case there are several non-continuous elements, the first one 
is used as the opening face.

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A1

●     Angle A2

4.  Click Apply to preview the louver.

5.  Click OK to validate.

The louver (identified as Louver.xxx) is created and the specification tree is updated accordingly.
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Creating a Louver

Check the No radius option to deactivate the Radius 
R1 and R2 values, and to create the louver stamp 
without a fillet.
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Creating a Stiffening Rib

Creating a Stiffening Rib

This task shows you how to create a stiffness rib by specifying the punch geometrical parameters.

Open the Stamping7.CATPart document from the samples directory.

1.  Click the Stiffness Rib icon .

2.  Select the external surface of Bend.1, where you want to place a stiffener.
Note that the stiffener will always be centered on the bend radius, wherever the point may be along the 
curve.

A grid is displayed.

The Stiffening Rib Definition dialog box opens, providing default  values.

3.  Change the value in the different 
fields, if needed:

●     Radius R1

●     Radius R2

●     Angle A

●     Length L

4.  Click Apply to preview the stiffness 
rib.

5.  Click OK to validate.

The stiffening rib (identified as Stiffnening Rib.xxx) is created and the specification tree is updated 
accordingly.
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Creating a Stiffening Rib

Check the No radius option to deactivate the Radius R1 and R2 values, and to create the stiffening rib without a 
fillet.
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Creating User-defined Stamping Features

Creating User-Defined Stamping Features
Two user-defined stamping features are available: 

 Create a punch and a die:  define the punch and die features, select a wall, choose the punch and die as 
stamping elements, select an edge on the wall and give an angle for orientation purposes.

 Open and cut faces : define the punch, select a wall, define the cutting faces and opening faces of the punch, 
select an edge on the wall and give an angle for orientation purposes.

 Edit a user-defined stamp: double-click the existing stamp and change its type, or select, or remove cutting and 
opening faces

What You Should Know 

In both tasks illustrating either a stamp based on a punch and a die, or a punch with cutting and opening faces, the 
punch positioning is defined as below: 

Defining the Punch in Relation to the Wall to be Stamped

The punch is defined within the absolute 
(default) axis-system of the .CATPart 
document. (o, x, y, z) is the axis associated 
with the punch. The punching direction on the 
punch (Dp) must be equal to z.

The punching direction on the wall (Dw) is 
normal to the selected wall face, and is 
oriented from the selected wall face towards 
the opposite face.

The punch is applied matching Dp on Dw and matching the punch's (x, y) plane onto the selected wall face:
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Creating User-defined Stamping Features

Defining the Die in Relation to the Wall to be Stamped
This is useful only when defining a punch a die, and does not apply to punches with cutting and opening faces.

The die is also defined within the absolute 
(default) axis-system of the .CATPart 
document. (o, x, y, z) is the axis associated 
with the punch. The punching direction on the 
die (Dd) must be equal to z. 

The illustration is a section view of the die.

The die is applied matching Dd on Dw and matching the die's (x, y) plane onto the selected wall face:
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Punch and Die

Punch and Die

This task explains how to create a stamp from punch and die features. 

First, you will define a punch and a die in Part Design, in the absolute axis-system.
Then, in a Sheet Metal part, you will bring the punch and the die features (and their axis system) to a point 
you have selected. If necessary, you will define a rotation of the axis system from a reference line.

This user-defined stamping can not be combined with the Opening and Cutting Faces approach.

All .CATParts are available from the samples directory (PunchDie1.CATPart, Punch1.CATPart and Die1.CATPart 
or NEWPunchDie1.CATPart, NEWPunch1.CATPart and NEWDie1.CATPart for New SheetMetal Design)

1.  Start the Part Design application.

2.  Insert a PartBody (menu Insert -> Body) to define the punch.

3.  Enter the sketcher  select the yz plane, 

and draw the profile of the punch, and a 
rotation shaft.

 

The punch must be oriented as 
described in Defining the Punch in 
Relation to the Wall to be Stamped.

4.  Return to the 3D space and create the punch 

using the Shaft icon .

5.  Repeat from step 2 to step 4 to define the die, making sure that it is oriented as described in Defining 
the Die in Relation to the Wall to be Stamped.
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Punch and Die

6.  Return to the Sheet Metal application, and if needed, use the Define In Work Object on the PartBody 
containing the wall to be stamped.

7.  Click the User Stamping icon  from the Stamping tool bar and select a wall or a face where the 

stamping is to be created. 
This wall or face is used to define the stamping location and direction, by matching the punch's origin to 
the selected point on the wall.

The User Defined Stamp Definition dialog box is displayed:

8.  Make sure the With die  icon is pressed 

down and select the Punch feature from the 
specification tree.

The punch's positioning is previewed in 
the geometry.
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Punch and Die

9.  Select the Die feature, and click Apply. 

The die's positioning is previewed in the 
geometry as well.

10.  Check the No Fillet button is you do not wish the stamp to be filleted, or set the radius value if you wish 
the stamp to be filleted. 

Stamp without fillet Stamp with fillet

11.  If needed, define the stamp's positioning on the selected wall by choosing:

●     a Reference for rotation: by default, it is the sketch axis, but you can also select any line or 
edge on the wall.

●     a Rotation angle value: you can either enter a value in the dialog box, or use the manipulator 
in the geometry to define this value.

●     a new Origin point on the wall to coincide with the punch's point of origin.

This is especially useful for non-circular stamps, but you can very well create the stamp as is, 
without further positioning.

12.  Click OK to validate and create the stamping.
By default the Punch and Die parts are set in No Show mode when clicking OK to create the stamp on 
the wall. 
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Punch and Die

●     Radius is the radius of the bend between the stamping and the wall.

●     Punch and Die are the bodies you have defined previously. If the punch and the die are in another CATPart 
document, activate this document before clicking the punch or the die.

●     If you select two reference lines in addition to the plane, this will create two editable constraints to position 
the stamping. These constraints are editable.

 ●     A user-defined stamping can be edited (punch, die, position, constraints)

●     If you enter a punch and a die, the stamping is 
the difference of the shape of both feature.
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Punch and Die

●     You may create a user-defined stamping from a 
punch only. The stamping will be the offset of the 
punch. 

●     If you create a stamping on an edge, you will 
have a section view of the stamping.

●     Only the stamping sketch is displayed in unfolded 
views.

 

●     The punch and die bodies can be defined in the 
Sheet Metal part  where the stamping is to be 
created (see PunchDie1.CATPart in the samples 
directory).

In this case, make sure you select the 
Define In Work Object on the 
PartBody containing the wall to be 
stamped, prior to actually creating the 
stamp.

or as two separate Part Design parts (Punch1.CATPart and Die1.CATPart from the samples 
directory)
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Punch and Die

In this case, when selecting the punch or die feature, the system automatically copies this feature into the .
CATPart document into which the wall to be stamped is located.
A link is retained between the initial punch or die feature and its copy.
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Opening and Cutting faces

Opening and Cutting Faces

This task explains how to create a stamp from a punch feature with cutting and 
opening  faces. 

First, you will define a punch in Part Design, in the absolute axis system.
Then, in a Sheet Metal part, you will bring the punch feature (and its axis system) to a 
point you have selected. If necessary, you will define a rotation of the axis system 
from a reference line.

This user-defined stamping can not be combined with the Punch and Die approach.

All CATParts are available from the samples directory (OpenFaces1.CATPart and 
CuttingFaces1.CATPart or NEWOpenFaces1.CATPart and NEWCuttingFaces1.CATPart 
for New SheetMetal Design )

1.  Start the Part Design 
application.

2.  Insert a PartBody (menu 
Insert -> Body) to define the 
punch.

3.  Enter the sketcher  select 

the yz plane, and draw the 
profile of the punch.

4.  Return to the 3D space and 
create the punch using the pad 

icon  and the fillet icon .

  

The punch must be oriented as described in Defining the Punch in Relation to the Wall 
to be Stamped.

●     The punch can be defined in the Sheet Metal part where the stamping is to be 
created or in another part.
In this case, when selecting the punch feature, the system automatically copies it 
into the .CATPart document into which the wall to be stamped is located.
A link is retained between the initial punch feature and its copy.

●     If you define a punch with cutting faces, they should come below the sheet.
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Opening and Cutting faces

5.  Return to the Sheet Metal application, and if needed, use the Define In Work 
Object on the PartBody containing the wall to be stamped.

6.  Click the User Stamping icon  from the Stamping tool bar and select a wall 

or a face where the stamping is to be created. 
This wall or face is used to define the stamping location and direction, by 
matching the punch's origin to the selected point on the wall.

The User Defined Stamp Definition dialog box is displayed, along with a 
grid that will help you position the punch.

7.  Click the With cut-out and opening  icon.
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Opening and Cutting faces

8.  Select the punch (Body.2).

The punch is previewed 
on the wall.

9.  Select both top faces of the 
oblong features of the part 
(Pad.2 and Pad.3).  

The Faces for cut-out 
field is updated in the 
dialog box, and now 
reads: 2 Faces. 

10.  Click the Faces for opening 
field and select the lateral faces 
of the punch (Pad.1).

11.  Click Apply.

The stamp is previewed with the 
opening faces:

12.  Check the No Fillet button is you do not wish the stamp to be filleted, or set the 
radius value if you wish the stamp to be filleted. 
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Opening and Cutting faces

13.  If needed, define the stamp's positioning on the selected wall by choosing:

●     a Reference for rotation: by default, it is the sketch axis, but you can also select 
any line or edge on the wall.

●     a Rotation angle value: you can either enter a value in the dialog box, or use the 
manipulator in the geometry to define this value.

●     a new Origin point on the wall to coincide with the punch's point of origin.

This is especially useful for non-circular stamps, but you can very well create the 
stamp as is, without further positioning.

14.  Click OK to validate and create the stamping. 

The stamp is automatically set in No Show mode. 

 

Stamping with opening faces
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Opening and Cutting faces

 

Stamping with opening and cutting faces

●     Radius is the radius of the bend between the stamping and the wall.

●     Punch is the body you have defined previously. If the punch is in another CATPart 
document, activate this document before clicking the punch.

●     The Faces for cut-out and Faces for opening faces must be picked on the 
punch, not on the wall. 
If the punch is located into another .CATPart document, these faces must be picked 
on the copy of the punch where the wall to be stamped is located.

If you select two reference lines in addition to the plane, this will create two editable 
constraints to position the stamping. These constraints are editable.

 ●     A user-defined stamping can be edited (punch, die, position, constraints)

●     Check the No radius option to deactivate the Radius R1 value, and to create the 
stamp without a fillet.
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Editing User-Defined Stamps

This task explains how to edit a user-defined stamp, that is: 

●     to change its type

●     add or remove cutting and opening faces 

Any .CATParts containing a user-defined stamp.

1.  Double-click the existing user-defined stamp from the specification tree.

The User Defined Stamp Definition dialog box is displayed. 
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2.  Change stamp type using the icons:

●     If you change from With die to With cut-out and opening, the Die feature no 
longer is selected, and you need to select Faces for cut-out and/or Faces for 
opening.

●     If you change from With cut-out and opening to With die, the punch faces no 
longer are selected and you may select a die feature if you wish (it is not 
compulsory).

Basically, only the punch remains selected.

If you are working with a cutting punch (With cut-out and opening option) you may 
want to add or remove some cutting or opening faces:

3.  Click in the Faces for cut-out field then:

●     select a face in the geometry to add it to the already selected cutting faces

●     select an already selected face to remove it from the cutting faces

●     use the Clear selection contextual menu to remove all cutting faces that have 
been previously selected. 

4.  Similarly, click in the Faces for opening field then:

●     select a face in the geometry to add it to the already selected opening faces

●     select an already selected face to remove it from the opening faces

●     use the Clear selection contextual menu to remove all opening faces that have 
been previously selected. 

5.  Modify any other parameter as needed.

6.  Click OK in the User Defined Stamp Definition dialog box to take these 
modifications into account.

The stamp is updated accordingly.
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Patterning
This section explains and illustrates how to create various kinds of patterns on Sheet Metal 
parts.

Create rectangular patterns: select the element to be duplicated, set the patterning 
type, and its parameters, and the reference direction
Create circular patterns: select the element to be duplicated, set the axial reference  
parameters, the reference direction, and possibly the crown definition
Create user-defined patterns: select the element to be duplicated, and the positioning 
sketch and anchor point 

To know more about patterns, refer to Part Design User's Guide.
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Creating Rectangular Patterns
In this task, you are going to create rectangular cutouts according to a pattern.
These features make the creation process easier.
In the NEW SheetMetal Design, you can only duplicate cutouts, holes, and stamps 
(except stiffening rib), 

even stamps without fillet (radius=0)

 These features must lie on a unique and planar wall.
     

Open the RectangularPattern1.CATPart 
document from the Samples/sheet metal 
directory.
If you use the NEW Sheet Metal Design, open 
the NEWRectangularPattern1.CATPart 
document.
The Sheet Metal part looks like this:

1.  Select the rectangular cutout you want to 
duplicate.

2.  Click the Rectangular Pattern icon .

The Rectangular Pattern Definition dialog box is displayed. Each tab is 
dedicated to a direction to define the location of the duplicated feature. 
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Rectangular Patterns

3.  Set the specification for the First 
Direction by selecting the first edge 
(Edge.2) as shown, to specify the first 
direction of creation.
An arrow is displayed on the wall. 

The Reverse button enables to 
modify the direction.
You can also click the arrow in the 
3D geometry.

4.  Keep the Instances & Spacing options 
to define the parameters.
Choosing these parameters types dims 
the Length field because the application 
no longer needs this specification to 
space the instances.

You can set the duplication parameters by choosing the number of instances, the 
spacing between instances, or the total length of the zone filled with instances.
Three options are available: 

1.  Instances & Length: the spacing between instances is 
automatically computed based on the number of instances and the 
specified total length

2.  Instances & Spacing: the total length is automatically computed 
based on the number of instances and the specified spacing value

3.  Spacing & Length: the number of instances is automatically 
computed to fit the other two parameters.

For each of these cases only two fields are active, allowing you to define 
the correct value.

If you set Instances & Length or Spacing & Length parameters, note 
that you cannot define the length by using formulas.

Patterns should not go beyond the model.
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5.  Enter 2 as the number of instances you wish to obtain in the first direction.

6.  Define the spacing along the grid: enter 30mm.

Defining the spacing along the grid and the length of your choice, would make the 
application compute the number of possible instances and space them at equal 
distances.

7.  Now, click the Second Direction tab to 
define the other parameters.

Note that defining a second direction is not 
compulsory. Creating a rectangular pattern 
defining only one direction is possible.

8.  Select the second edge (Edge.3), as 
shown, to define the second direction.

9.  Keep the Instances & Spacing option: 
enter 8 and 10 mm in the appropriate 
fields.

Additional cutouts have been aligned 
along this second direction.

10.  Click OK to repeat the cutouts.

After the update, the Sheet Metal part looks 
like this:
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11.  Select this icon  to unfold the part:

The pattern is updated on the unfolded view.

 
12.  Click the More>> button to display further options.
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 The Simplified representation option lets you lighten the pattern geometry, when 
more than 10 instances are generated in one direction. What you need to do is just 
check the option, and click Preview. The system automatically simplifies the geometry:

You can also specify the instances you do not 
want to see by double-clicking the dots. These 
instances are then represented in dashed lines 
during the pattern definition and then are no 
longer visible after validating the pattern 
creation. The specifications remain unchanged, 
whatever the number of instances you view. 
This option is particularly useful for patterns 
including a large number of instances.
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Creating Circular Patterns
In this task, you are going to create circular cutouts according to a pattern.
These features make the creation process easier.

In the NEW SheetMetal Design, you can only duplicate cutouts, holes, and stamps (except stiffening rib), 

even stamps without fillet (radius=0)

 These features must lie on a unique and planar wall.
     

Open the CircularPattern1.CATPart document from the 
Samples/sheet metal directory.
If you use the NEW Sheet Metal Design, open the 
NEWCircularPattern1.CATPart document.
The Sheet Metal part looks like this:

1.  Select the circular cutout you want to duplicate.

2.  Click the Circular Pattern icon .

The Circular Pattern Definition dialog box 
is displayed.

3.  Define the Axial Reference by choosing the 
Parameters type, and reference direction.
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●     Instance(s) & total angle: the number of patterns as 
specified in the instances field are created, in the 
specified direction, and evenly spread out over the total 
angle.

●     Instance(s) & angular spacing: the number of 
patterns as specified in the instances field are created in 
the specified direction, each separated from the 
previous/next one of the angular angle value.
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●     Angular spacing & total angle: as many patterns as 
possible are created over the total angle, each 
separated from the previous/next one of the angular 
angle value.

●     Complete crown: the number of patterns as specified 
in the instances field are created over the complete 
circle (360°). 

 If you set Instance(s) & total angle or Angular spacing & total angle parameters, note that you cannot 
define the length by using formulas.

4.  Click the Reference element and select the element defining the rotation axis.
Here select the face on which lies the circular cutout.

●     To define a direction, you can select an edge or a planar face.
Should you select the face of a wall, the rotation axis would be normal to that face.

●     Click the Reverse button to inverse the rotation direction.
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Now you are going to add a crown to this pattern.

5.   Click the Crown Definition tab, and choose which 
parameters you wish to define the crown.

This figure may help you define these 
parameters:

 ●     Circle(s) and crown thickness: you define the number of circles and they are spaced out evenly over the 
specified crown thickness

●     Circle(s) and circle spacing: you define the number of circles and the distance between each circle, the 
crown thickness being computed automatically

●     Circle(s) spacing and crown thickness: you define the distance between each circle and the crown thickness, 
and the number of circles is automatically computed.

For example, using the values described 
above for the Angular spacing & total 
angle option, you could define the crown as: 

Note that one of the pattern is created beyond the wall.  

You can delete instances of your choice when creating or 
editing a pattern. To do so, just select the points 
materializing instances in the pattern preview.

The instance is deleted, but the point remains, as you may 
wish to click it again to add the instance to the pattern 
definition again.
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6.  Click the More>> button to display further options:

Using these options, you can change the position of the 
selected cutout within the crown. For example, if you set 
the Row in angular direction parameter to 4, this is 
what you obtain: the initially selected cutout is the fourth 
instance, based on the rotation direction, of the pattern.

Typically, in this case, you might want to edit the pattern 
and click again the instance that you removed above, to 
get a full pattern.

●     The Simplified representation option lets you lighten the pattern geometry, when more than 10 
instances are generated in one direction. What you need to do is just check the option, and click Preview. 
The system automatically simplifies the geometry:
You can also specify the instances you do not want to see by double-clicking them . These instances are 
then represented in dashed lines during the pattern definition and then are no longer visible after validating 
the pattern creation. The specifications remain unchanged, whatever the number of instances you view. 
This option is particularly useful for patterns including a large number of instances.

●     When checking the Radial alignment of instances, all instances have the same orientation as the original 
feature. When unchecked, all instances are normal to the lines tangent to the circle.

7.  Click OK to create the pattern.
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Creating User-Defined Patterns
The User Pattern command lets you duplicate a feature, such as a sketch, a cutout, a 
stamp, or any other feature as many times as you wish at the locations of your choice.
Locating instances consists in specifying anchor points. These points are sketches.
In the NEW SheetMetal Design, you can only duplicate cutouts, holes, and stamps 
(except stiffening rib), 

even stamps without fillet (radius=0)

 These features must lie on a unique and planar wall.
    

Open the UserPatterns1.CATPart document from the samples directory.
If you use the NEW Sheet Metal Design, open the NEWUserPatterns1.CATPart 
document.

1.  Select the feature to be duplicated.
Here we selected the cutout. 

2.  Click the User Pattern 

icon .

The User Pattern 
Definition dialog 
box is displayed.

3.  Select 'Sketch 9' in the 
specification tree and 
click Preview.
The sketch contains the 
points you need to locate 
the duplicated cutouts. 

By default, the application positions each instance with respect to the center of gravity 
of the element to be duplicated. To change this position, use the anchor field: click the 
anchor field and select a  vertex or a point.
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User-Defined Patterns

4.  Click inside the Anchor 
field and select the point 
(Point.1) to indicate a 
new reference location.

5.  You can then click the 
points corresponding to 
the pattern instances to 
be removed.

6.  Click OK in the User 
Pattern Definition dialog 
box.

Cutouts are 
created at the 
points of the 
sketch.

Would you need to unfold the part using the  icon, you would notice that the 

pattern is updated.
Please be careful concerning the content of the sketch selected to locate the instances 
of the User Pattern. The sketch should only include the points locating the instances of 
the selected reference feature. Therefore it is useful to create a point as "Construction 
Element" corresponding to the reference feature (in case of constraints for example), 
so that the instances are different from this feature.
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Corner Relief

Corner Relief
This section explains and illustrates different methods to create corner relieves on bends.

Redefine an automatic corner relief: double-click an automatic corner relief, edit its 
parameters in the dialog box
Create a local corner relief: select two or more bends, the corner relief type and 
parameters

See also Bend Corner Relief parameters settings. 
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Redefining an Automatic Corner Relief

This task explains how to redefine automatic corner relieves on a Sheet metal part.

Open the CornerRelief01.CAPTPart model from the samples directory.
If you use the New SheetMetal Design workbench, open the NEWCornerRelief01.
CATPart document. 

1.  Double-click the bend on which the 
corner relief you want to redefine is 
located.

It may be easier to double-click 
it from the specification tree. 

The Bend Definition dialog box is 
displayed. 

2.  Click the More button and select the Bend Corner Relief tab.

This tab is similar to the Corner Relief tab of Sheet Metal Parameters 
dialog box. 
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Redefining a Corner Relief

3.  Choose a new corner relief type, and 
click OK to validate. 

This definition will apply to the 
current corner relief, and will 
prevail over any other corner 
relief definition you may enter 
through the Sheet Metal 
Parameter dialog box. 
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Creating A Local Corner Relief
This task explains how to define a corner relief locally on a set of bends.
Depending on the number of bends involved, not all types of corner relief are available.
Open the CornerRelief02.CATPart document from the samples directory.
The part needs to be unfolded prior to creating the corner relief.

1.  Click the Corner Relief icon .

The Corner Relief Definition dialog 
box  is displayed. 

       

2.  Select the supports on which a corner 
relief should be created.

By default the User Corner Relief  is active in the Corner Relief Definition 

dialog box.

3.  Select the sketch, directly in the 
document.

As soon as the sketch has been selected the 
sketcher icon is displayed in the dialog box 
allowing you to edit the selected sketch, if 
needed.
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4.  Click OK in the Corner Relief Definition 
dialog box.

        

5.  Fold the part to check the corner relief in 
3D.

You can use the Catalog icon  to open the Catalog Browser.

For more information on catalogs, please refer to the Component Catalog Editor documentation.

If you choose another corner relief type, the scenario maybe slightly different:

●     circular: by default the corner 
relief center is located at the 
intersection of the bend axes.

You can select a point as the 
circle's center.

A radius is proposed by default. It is equal to the bend radius + the thickness. You 
can change it by: 
●     Selecting Formula -> Deactivate from the contextual menu of the input field 

and enter a new value,

●     or clicking on the  button and entering a new formula.
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Unfolded circular corner relief Folded circular corner relief

●     square: the square corner relief  is created using the bend limits. Its dimensions are 

defined by the width of the unfolded bends.

Available between two bends only.

 
Unfolded square corner relief Folded square corner relief

●     triangular: the triangular corner relief  is created from the intersection point of the 

inner bend limits towards the intersection points of the outer bend limits with each wall. 

Available between two bends only.
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Unfolded triangular corner relief Folded triangular corner relief

Only the User-defined and Circular corner relief type allow the selection of more than two bends.
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Creating Corners

This task shows how to create one or more corner(s)  on a Sheet Metal part, that is to 
round off sharp edges, much like a fillet between two faces of a Part Design Body.
This corner creation operation can be performed indifferently on the folded or 
unfolded view, and only one support (i.e. the corner when previewed should not lie 
over two supports).

 Open the Corners1.CATPart document.

1.  Click the Corner icon .

The Corner Definition dialog box is 
displayed. 

2.  Set the radius value.

3.  Choose the type of edge you wish to round 
off: 

●     using the Select All button: all convex or 
concave edges, or all edges of both types

●     any edge manually selected

By default both buttons are checked, to allow the 
selection of any edge type whether manually or 
automatically.

●     Once you have selected an edge, you can no longer modify this option, unless you 
cancel the selection.

●     If you check the Convex Edge(s) button and you select a concave edge, a 
warning is issued indicating that you did not select an edge corresponding to the 
active type.
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4.  With only the Convex Edge(s) button 
checked, select a sharp edge on a part.

As soon as you selected one edge, the 
dialog box is updated and the Select 
All button changes to Cancel 
Selection.

The corner is previewed on the edge, 
with the current radius value.

5.  Click Cancel Selection, make sure that both Convex Edge(s) and Concave 
Edge(s) buttons are checked, then click the Select All button.

All sharp edges of the part are selected, the Select All button taking into 
account the chosen type (convex, concave, or both) and the corners 
previewed.
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6.  Click OK in the dialog box.

All sharp edges of the part are rounded off to create smooth corners.
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To deselect an edge, simply click it again. For quick selection in a complex part, you 
can select all edges with the Select All check button, then deselect one or two edges.

●     When you select an edge that is not sharp, such as the edge between a wall and a 
bend for example, a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges (whether concave, convex, 
or both) present at the time. If when modifying the Sheet Metal part, new edges 
are created, these will not be automatically rounded off.
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Creating Chamfers

This task shows how to create one or more chamfer(s)  on a Sheet Metal part, that is 
to cut off, or fill in sharp edges of Sheet Metal parts.
This chamfer creation operation can be performed indifferently on the folded or 
unfolded view, and only one support (i.e. the chamfer when previewed should not lie 
over two supports).

 
Open the Corners1.CATPart document.

1.  Click the Chamfer icon .

The Chamfer Definition 
dialog box is displayed. 

2.  Choose the chamfer Type:

●     Thickness chamfer : to be 

able to select edges that represent 
the thickness of the part

●     Welding chamfer : to be able 

to select edges that represent the 
area of the part where it can be 
welded to another part.
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With the Thickness chamfer type only, you can choose the type of edge you wish to 
chamfer: 
●     using the Select All button: all convex or concave edges, or all edges of both types

●     any edge manually selected

By default both buttons are checked, to allow the selection of any edge type whether 
manually or automatically.
●     Once you have selected an edge, you can no longer modify this option, unless you 

cancel the selection.

●     If you check the Convex Edge(s) button and you select a concave edge, a 
warning is issued indicating that you did not select an edge corresponding to the 
active type.

3.  Select a sharp edge on a part.

The chamfer is previewed on the edge.

As soon as you selected one edge, the dialog box is updated and the Select All 
button changes to Cancel Selection.

4.  Choose a chamfer Mode. You can either enter:

●     a length value and an angle: the 
length is computed on one side of 
the edge and the angle from the 
chamfer's limit on the same side

●     two lengths: these lengths are 
computed from the selected edge 
on both sides.

You can use the Reverse button to inverse all edges' side, on which the values are 
taken into account;
Use the arrow displayed on each edge to locally invert only one edge.

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt1502.htm (2 of 4)10/21/2004 8:47:29 AM



Creating Chamfers

5.  Click Cancel Selection then, make sure that both Convex Edge(s) and 
Concave Edge(s) buttons are checked,  and click the Select All button.

All sharp edges of the part are selected, the Select All button taking into 
account the chosen type (convex, concave, or both) and the chamfers 
previewed.

6.  Click OK in the dialog box.

All sharp edges of the part are cut off or filled in. 
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To deselect an edge, simply click it again. For quick selection in a complex part, you 
can select all edges with the Select All button, then deselect one or two edges.

●     When you select an edge that is not sharp, such as the edge between a wall and a 
bend for example, a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges (whether concave, convex, 
or both) present at the time. If when modifying the Sheet Metal part, new edges 
are created, these will not be automatically chamfered.
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Mapping Elements

 
This task shows how to create curves or points from a sketch (as designed using the 
Sketcher) or from existing curves or points,  onto a Sheet Metal part; and to fold/unfold 
it, just as other Sheet Metal elements. 
This is especially useful when: 
●     you want to generate a logotype

●     you want to define an area for chemical milling

●     you want to create a cutout (pocket) to solve the overlapping of walls for example (the 
overlapping can be checked with the Sheet Metal Production product).

 Open the Mapping1.CATPart document.
If you use the New SheetMetal Design, open the NEWMapping1.CATPart document.

1.  Click the Sketcher icon , 

select the wall onto which the 
curve should lie, and draw the 
sketch you wish.
This is the sketch that will be 
mapped onto the part.

2.  Exit the Sketcher .

The 3D part looks like this:
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Mapping Elements

 3.  Make sure the sketch is selected, 
and click the Fold/Unfold 

Points or Curves icon  .

The Elements To Map 
definition dialog box is 
displayed.
It indicates which elements 
have been selected for 
mapping.

 You can manage the list of elements:
●     to remove an element, select it from the list and use the Clear selection 

contextual menu

●     to add an element,  select it directly in the geometry.
Order in the list does not matter. 

4.  Select the Mapping Context, that is the element of the part on which the curve 
should be generated when folding or unfolding.

The Mapping Context is not necessarily the support element on which the element to be 
mapped has been drawn. Indeed, by default, the Mapping Context is the last Sheet 
Metal feature that has been created or modified, that is the current feature in the 
specification tree.

5.  Click OK.
A curve is created and added in the specification tree.

  

Folded view of the curve mapping Unfolded view of the curve mapping
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Mapping Elements

●     You can select several sketches/curves/points to be mapped at a time.

●     Mapped curves can be created across several walls and bends.
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Saving As DXF

Saving As DXF
 
This task shows how save the generated geometry as a DXF document.

If working in the NEW SheetMetal Design workbench, this task is new.

 1.  Click the Save As 

DXF icon .

The Select a 
DXF file 
dialog box is 
displayed 
allowing you 
to navigate to 
the correct 
location. 

2.  Indicate the correct path and file name (we saved it as PartSavedAsDXF.dxf).

3.  Click Save.

The geometry has been saved, and can be imported as a DXF file in any system supporting 
this type.

4.  Close the CATPart Document.

5.  Click File -> Open.

6.  From the File 
Selection dialog box, 
choose the .dxf file 
type, then select the 
saved part 
(PartSavedAsDXF.
dxf).
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Saving As DXF

7.  Click Open.

     

The New 
Drawing 
dialog box is 
automatically 
displayed 
because the .
dxf type is 
recognized as 
being a 
drafting type.

8.  Click OK in the New 
Drawing dialog box.

The unfolded view of the part is created within the CATDrawing document.
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Saving As DXF

Note that the axes of  bends and planar hems, tear drops, or flanges are automatically 
displayed on the drawing.

 
Refer also to DXF/DWG Settings.
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Reference Elements

Reference Elements
You can create wireframe elements within the Sheet Metal Design workbench:

Create points: click this icon, choose the point creation type, and specify parameters

Create lines: click this icon, choose the line creation type, and specify parameters

Create planes: click this icon, choose the plane creation type, and specify parameters
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Advanced Tasks

Advanced Tasks
The Advanced Tasks section explains how to use further functions that may not be as 
common as the ones described in the Basic Tasks section, as well as the integration of 
the Sheet Metal Design workbench and elements with other workbenches.

 
Integration with Part Design
Integration With Weld Design

Designing in Context
PowerCopies Management

Browsing the Sheet Metal Catalog
Looking For Sheet Metal Features 
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Integration with Part Design

Integration With Part Design

You can open the Stiffener1.CATPart document from the samples directory to replay 
the scenario.
If you use the NEW SheetMetal Design workbench, open the NEWStiffener1.CATPart 
document.

In a CATPart document, you may have Part Design features and Sheet Metal features 
according to the following rules:

●     Part Design features can be created before Sheet Metal features.

●     a Part Design feature can also be created after Sheet Metal features as 
long as the part is in folded view.

●     in the unfolded view, the Part Design feature will not be displayed.

●     it is no longer possible to create Sheet Metal features after this last Part 
Design feature in folded view.

1.  Create two walls with an Automatic or Cylindrical Bend.

2.  Switch to Part Design workbench.

3.  Launch the Sketcher and draw an oblique line in the yz plane.

4.  Click the icon  to create a Stiffener.
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Integration with Part Design

5.  Switch to the Sheet Metal workbench.

6.  Click the Unfold icon .

The stiffener is not displayed on the unfolded view.

To add a new Sheet Metal feature and switch to the Sheet Metal Design workbench, 
select the Bend for example and right-click the Define In Work Object item.
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Integration with Part Design

The new Sheet Metal feature will be added after the Bend but before the Stiffener.
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Integration With Weld Design

 Integration With Weld Design
You can open the Integration.CATProduct document from the samples directory to replay the scenario.
If you use the New SheetMetal Design workbench, open the NEWIntegration.CATProduct document.

In a CATProduct document, you may have Weld Design features and Sheet Metal features according to the 
following rules:

●     Weld Design features are created after Sheet Metal features.

●     in the unfolded view, the Weld Design feature will not be displayed.

●     it is no longer possible to create Sheet Metal features after this last Weld Design feature.

1.  Create two walls.

2.  Switch to Weld Design workbench.

 3.  Create a weld (in our scenario, we create a Single-V Butt weld)

To add a new Sheet Metal feature and switch to the Sheet Metal Design workbench, select any of the two 
walls and make it current.

 
The new Sheet Metal feature will be added after the Bend but before the Stiffener.
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Integration With Weld Design
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Designing in Context

Designing in Context
This section explains and illustrates how to create and use various kinds of features.
The table below lists the information you will find.

Design in context: from a CATProduct document, create a new CATPart document, and 
create a complete SheetMetal Part.
Modify the design: modify another part from another document and update the SheetMetal 
Part.
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Designing in Context

Designing in Context

This task explains how to create a Sheet Metal part in an Assembly context.

Open the Scenario2.CATProduct document from the samples directory.
If you use the New SheetMetal Design, open the NEWScenario2.CATProduct document.

You are in Assembly 
Design workbench.

The document contains two parts.

1.  Right-click Product1 in the 
specification tree and select 
Components -> New 
Part...

Provided the Manual 
Input option is 
checked in Tools -> 
Options -> 
Infrastructure -> 
Product Structure, 
Product Structure 
tab, the Part Number 
dialog box is 
displayed:
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Designing in Context

2.  Enter Part3 in the New 
part Number field and click 
OK.
A New Part dialog box 
proposes two locations to 
define the origin point.
For more information, refer 
to Inserting a  New Part, in 
the Basic Tasks of the 
Product Structure User's 
Guide.

 

3.  Click No to locate the part origin according to the Product1 origin point.

Make sure you are in Design Mode:
●     Select Product1

●     Choose Edit -> Representations ->Design Mode

4.  Expand the tree and activate the Part3 Part body by double-clicking. 
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Designing in Context

5.  Switch to Sheet 
Metal Design 
workbench.

6.  Select the SheetMetal parameters icon  to create the Sheet Metal characteristics for 
the part: 

●     1mm for the Thickness

●     3mm for the Bend radius

●     Linear for the Bend extremities

and click OK.

7.  Choose the Tools -> Options -> Mechanical Design -> Part Design, General tab and 
check the Keep link with selected object option, then click OK.

8.  Click the Sketcher icon  and select the zx plane.

9.  Select the Profile icon .

 10.  Sketch the contour and set the constraints as shown below:

 

●     5mm between the Sheet 
Metal vertical walls and 
each pad

●     0mm between the Sheet 
Metal horizontal walls and 
each pad top

●     0mm between the last 
point of the Sheet Metal 
sketch and the right pad 
side.

11.  Click the Exit icon  to return to the 3D world.

12.  Select the Extrusion icon .
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Designing in Context

13.  Select the Sheet Metal 
profile.
The Extrusion Definition 
dialog box appears.

14.  Enter 70mm for Length1 
then click OK.

The Material Side should be set to 
the outside.

15.  Select the Automatic Bends icon .

The bends are created.

The new features are 
shown in the 
specification tree: 
●     Extrusion.1 with 

five walls

●     Automatic 
Bends.1 with four 
bends.

The Sheet Metal part looks like 
this:

 
[ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt0301.htm (4 of 4)10/21/2004 8:48:58 AM



Modifying the Design

Modifying the Design

In this task, you are going to modify the height and the sketch of Pad.1.

The Scenario2.CATProduct document is open from the previous task.
If not, open the Scenario2_2.CATProduct document from the samples directory.

1.  Double-click Part1\PartBody\Pad.1 in 
the specification tree.

The dialog box is displayed. 

2.  Enter 40mm for the Length and click OK.
The pad is updated.

3.  Double-click Part3 and Update the Sheet Metal part using the Update   icon.

4.  Double-click Part1\Pad.1\Sketch.1.

5.  Modify the sketch:
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Modifying the Design

6.  Click the Exit icon  to return to the 3D 

world.

The constraints are respected. 

After the Part3 update, the document looks like this:
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PowerCopies Management

Managing Power Copies

 Create PowerCopies: Select the Insert ->Advanced Replication Tools -> 
PowerCopy Creation command, select the elements making up the PowerCopy from 
the specification tree, define a name for the PowerCopy and its reference elements 
then choose an icon for identifying it.

 Instantiate PowerCopies: Select the Insert -> Instantiate From Document 
command, select the document or catalog containing the  powercopy, complete the 
Inputs within the dialog box selecting adequate elements in the geometric area.

 Save PowerCopies into a Catalog: Select the PowerCopy from the specification tree, 
select the Insert -> Advanced Replication Tools -> PowerCopy Save In 
Catalog... command, enter the catalog name and click Open.
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Creating PowerCopies

Creating PowerCopy Features

This task shows how to use create PowerCopy elements, to be reused later.
A PowerCopy is a set of features (geometric elements, formulas, constraints and so forth) that 
are grouped in order to be used in a different context, and presenting the ability to be re-
specified according to the context when pasted.
This PowerCopy captures the design intent and know-how of the designer thus enabling greater 
reusability and efficiency.

Open the PowerCopyStart.CATPart document.

1.  Select the Insert ->Advanced Replication Tools -> PowerCopy Creation menu item.
The PowerCopy Definition dialog box is displayed. 

2.  Select, from the specification tree, the elements to be included in the PowerCopy. 

The 
PowerCopy 
Definition 
dialog box is 
automatically 
filled with 
information 
about the 
selected 
elements. 

3.  Define the PowerCopy as you wish to create it:

The Definition tab lets you assign a name to the PowerCopy and presents its 
components in the 3D viewer.
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Creating PowerCopies

The Inputs tab lets you 
rename the reference 
elements making up the 
PowerCopy.

You can do that for clarification purposes as to their roles,  by selecting the elements in the 
viewer and entering a new name in the Name field.
In this example, we renamed all three elements and in brackets you still can read the elements' 
default name based on their type.

The Parameters tab lets 
you define which of the 
parameter values used in 
the PowerCopy you will 
be able to modify at 
instantiation time.

Simply check the Published button.

Use the Name field to give a more explicit name to the element.

The 
Documents 
tab shows 
the complete 
path and role 
of Design 
tables that 
are 
referenced 
by an 
element 
included in 
the Power 
Copy.
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Creating PowerCopies

The Icon tab lets you 
modify the icon 
identifying the 
PowerCopy in the 
specifications tree. 

A subset of icons is available from the Icon choice button.
If you click ... the Icon Browser opens, giving you access to all the graphic icons installed with 
the CATIA software.

Use the Grab screen 
button to  capture an 
image of the PowerCopy 
to be stored with its 
definition in the catalog 
(see Saving PowerCopies 
into a Catalog).

Use the Remove preview button to delete the image captured with the Grab screen button.

4.  Click OK to create the PowerCopy.

The PowerCopy is displayed close to the top of the specification tree.

●     Double-click the PowerCopy in the specification tree to display the PowerCopy Definition 
dialog box and edit its contents.

●     A formula is automatically included in a Power Copy definition when all its parameters are 
included.
Otherwise, i.e. if at least one parameter is not selected as part of the Power Copy, you have 
to manually select the formula to make it part of the definition. If you do so, all the formula's 
parameters that have not been explicitly selected, are considered as inputs of the Power 
Copy.
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Creating PowerCopies
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Instantiating PowerCopies

Instantiating PowerCopy Features

This task shows how to instantiate PowerCopies once they have been created as described in Creating  
PowerCopies.
There are three ways to do this: 

1.  using the contextual menu
2.  using the Insert -> Instantiate From Document menu item
3.  using a catalog

The PowerCopyStart.CATPart document is still open from the previous task, otherwise, 0pen the 
PowerCopyStartResults1.CATPart document.

Using the Contextual Menu Item: 

1.  Select the PowerCopy feature from the specification tree.

2.  Right-click to display the contextual menu, and choose the PowerCopy.1 object -> instantiate 
menu item. 

The Insert Object dialog box is displayed. 

3.  Complete the Inputs within the dialog box by 
selecting the adequate element in the 
geometric area.

You need to click the arrow to invert 
the First Edge orientation.
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Instantiating PowerCopies

 Check the Repeat option to be able to repeat the instantiation.
In this case, once you have clicked OK in  the Insert Object dialog box, the latter remains open, the 
PowerCopy's Inputs are listed and ready to be replaced by new inputs, as described above.
Modified parameters using Parameters button are retained as well for the next instantiation.
To exit the command, you then need to uncheck the Repeat button or click Cancel.

5.  You can also click on the Parameters button 
to display the Parameters dialog box and 
modify values, if needed.

6.  Use the Create formulas button to 
automatically create a formula on every 
parameters with the same name provided 
there are any.

7.  Click OK in the Parameters dialog box.

 The Documents button lets you access the list of documents (such as design tables) pointed by one of 
the elements making up the Power copy. 
If there are documents, the Documents dialog box opens and you can click the Replace button to display 
the File Selection dialog box and navigate to a new design table to replace the initial one.
When no document is referenced, the Documents button is grayed within the Insert Object dialog box.

8.  Click OK to create the PowerCopy instance.

The PowerCopy is instantiated in 
context, meaning its limits are 
automatically re-defined taking into 
account the elements on which it is 
instantiated.

Using the Insert Menu: 

1.  Select the Insert -> Instantiate From Document menu item.
The Select PowerCopy dialog box is displayed allowing you to navigate to the document or 
catalog where the  power copy is stored.
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Instantiating PowerCopies

 

2.  Select the document containing the Powercopy.

The Insert Object dialog box is displayed.

Use the Reference list to choose the correct PowerCopy when several have been defined in 
the document.

3.  Continue the instantiation as described in Using the Contextual Menu item, step 3.

Using the catalog: 

You need to have a catalog available, created either:
●     using the Catalog capability, see the Infrastructure User's Guide.

●     using the Insert -> Advanced Replication Tools -> PowerCopy Save In Catalog... menu item.

1.  Click the  icon.

If accessing a catalog for the first time, you need to navigate to the catalog location. This location 
is stored in the settings for faster access later on.

2.  Select the catalog containing the PowerCopy you wish to instantiate.

3.  Select the PowerCopy to be instantiated, then you can:

●     drag and drop it onto the reference element

●     double-click the PowerCopy 

●     or right-click on the PowerCopy in the dialog box and use the Instantiate contextual menu.

From then on, you instantiate the PowerCopy as described Using the Contextual Menu item, step 3.
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Instantiating PowerCopies

●     You can only instantiate a PowerCopy if the PowerCopy itself and the features making it up have been 
created in the current view mode: i.e. you will be able to instantiate a PowerCopy created in 3D mode, 
only on a feature in 3D mode, not on an unfolded feature.

●     The  icon is always grayed when instantiating Power Copies. It is available with User Features and 

allows you to create and modify URLs.
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Saving PowerCopies

Saving PowerCopy Features

This task shows how to use store Power Copy elements into a catalog, for later use as 
described in Instantiating a PowerCopy Feature.

Open the PowerCopyStartResults1.CATPart document.

1.  Select the PowerCopy from the specification tree for example.

2.  Choose the 
Insert -> 
Advanced 
Replication 
Tools -> 
(PowerCopy) 
Save In 
Catalog... menu 
item.
The Catalog 
Save dialog box 
is displayed: 

●     When creating a 
catalog for the first 
time, click the ... 
button to display the 
Open dialog box, and 
navigate to the 
location where you 
wish to create a 
catalog.
Then simply key in 
the catalog name and 
click Open.
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Saving PowerCopies

●     If you wish to add a PowerCopy to an existing catalog, simply activate the Update an 
existing catalog option in the Catalog Save dialog box

By default, the Catalog Save dialog box recalls the catalog accessed last.

3.  Click OK.

The PowerCopy has been stored in the catalog.
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Browsing the Sheet Metal Catalog

Browsing the Sheet Metal Catalog

Open the CornerRelief03.CATPart document from the samples directory.

In this case, the Catalog Browser opens, and lets you choose from a number of 
sketches.

 

1.  Select a sketch and click OK in the Catalog Browser.

You return to the Corner Relief Definition 
dialog box, that has been updated with the 
Sketcher icon.
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Browsing the Sheet Metal Catalog

2.  Click the sketcher icon, and move the 
sketch to position it properly in relation 
to the part. 

 

 

3.  Click OK, and check the part in a 
folded view.
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Looking For Sheet Metal Features

Looking For Sheet Metal Features

This task shows how to use the Search capabilities on Sheet Metal Features, in order 
to detect any specific kind of feature.

Open the PowerCopyStart.CATPart document.

1.  Select the Edit ->  Search menu item.

The Search dialog box is displayed. 

2.  From the Type Workbench list choose Sheet Metal.

You can then display the list of Sheet Metal features from the Type list: 
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Looking For Sheet Metal Features

3.  Select the type of feature you wish to find within the open .CATPart document, 
and click Search.

The list of all elements of the selected type is displayed in the Objects 
found field:

You can select an element from the list, it will be highlighted in the geometry area.
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Looking For Sheet Metal Features

To find out more on the search capabilities, refer to Selecting Using the Search... 
Command (General Mode) and Selecting Using the Search... Command (Favorites and 
Advanced Modes) from the Infrastructure User's Guide.
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Working with the New SheetMetal Design Workbench

Working with the New
SheetMetal Design Workbench

On the current level, you can access SheetMetal Design, SheetMetal Production, and 
NEW SheetMetal Design workbenches. However you can only access to the 
SheetMetal Design and SheetMetal Production functionalities.
To access the NEW SheetMetal Design functionalities, you need to set the following 
variables:
●     SMD_NEW_WORKBENCH_ACCESS set to 1 enables the access to the NEW 

SheetMetal Design functionalities (SheetMetal Design and SheetMetal Production 
functionalities are still available),

●     SMD_OLD_WORKBENCH_HIDE set to 1 disables the access to both SheetMetal 
Design and SheetMetal Production functionalities, therefore allowing the access 
only to the NEW SheetMetal Design functionalities.

  

This chapter lists the functionalities available with the NEW SheetMetal Design 
workbench whose behavior or interface slightly differs from the Sheet Metal Design 
workbench.

When functionalities are strictly identical to the SheetMetal Design workbench, a link 
to the corresponding CATPart or CATProduct to be opened in the NEW SheetMetal 
Design workbench is added in the file.
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Creating Walls from a Sketch

Creating Tangent Walls

Creating Walls From An Edge

Extruding

Creating Rolled Walls

Creating Bends on Walls

Manually Creating Bends from Walls

Creating Bends From a Line

Aggregating Bodies

Creating Swept Walls
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Creating a Hem

Creating a Tear Drop

Creating a Swept Flange

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugin0000.htm (1 of 2)10/21/2004 8:50:07 AM



Working with the New SheetMetal Design Workbench

Redefining Swept Wall Limits
Display swept walls axes in drafting sheets

Creating a Hole

Creating a Cutout

Stamping

Creating Standard Stamping Features

Creating a Flanged Hole

Creating a Bead

Creating a Circular Stamp

Creating a Surface Stamp

Creating a Bridge

Creating a Flanged Cutout

Creating a Stiffening Rib

Creating a Curve Stamp

Creating a Louver

Creating User-defined Stamping Features

Punch and Die

Opening and Cutting faces

Editing User-Defined Stamps

Patterning

Creating Rectangular Patterns

Creating Circular Patterns

Creating User-Defined Patterns

Creating a Local Corner Relief

Creating Corners

Creating Chamfers

Mapping Elements

Saving As DXF
Integration with Part Design

Integration With Weld Design
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Creating Walls

Creating Walls
This section explains and illustrates different methods to create walls.

Create a wall from a sketch: use the sketcher to define the profile, and set the 
material side.

Create a wall tangent to another one: select a profile coincident with an existing wall, 
and select the wall to which it should be tangent

 Create a wall from an edge: select a wall edge, set the height, limits, angle, then the 
sketch and material sides

[ Up ] [ Next ]
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Creating Walls from a Sketch

Creating Walls from a Sketch

This task shows how to create a wall from a sketch.

You must be in the Sheet Metal Workbench, with a .CATPart document open, and you 
must have defined the Sheet Metal parameters. 
Set the sketcher grid to H = 100mm and V = 100mm, using the Tools -> Options, 
Mechanical Design -> Sketcher, Sketcher tab.

1.  Click the Sketcher icon  then select the xy plane.

2.  Select the Profile icon .

3.  Sketch the contour as shown below:

4.  Click the Exit workbench icon  to return to the 3D world.
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Creating Walls from a Sketch

5.  Click the Wall icon .

The Wall Definition dialog box opens.

By default, the Material Side is set to the top.

6.  Click OK.
The Wall.1 feature is added in the specification tree.

The first wall of the NEW Sheet Metal Part is known as the Reference wall.

●     Click the Sketcher icon  from the Wall Definition dialog box, if you wish to 

directly edit the selected sketch. When exiting the sketcher, you then go back to the 
wall creation step, without having to reactivate the Wall icon.
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Creating Walls from a Sketch

This is also very useful if you 
have selected an edge from a 
wall and clicked the Wall 

icon . 

In this case, the sketcher is 
automatically activated 
displaying a square sketch 
constrained to the plane 
perpendicular to the support of 
the selected edge.

You can then directly draw a 
sketch, then exit the sketcher 
and return to the wall creation 
step. 

    
●     You can directly create a wall with a hole, by selecting a sketch with an inner contour 

(the contours must not intersect):
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Creating Walls from a Sketch

  

Sketch with inner contour Resulting wall
Note however, that the emptied area is part of the wall and is not a 
separate cutout that can be edited.
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 Creating Tangent Walls

This task shows how to create a wall tangent to a planar part of another wall or of a 
flange. This capability will then allow this tangent wall to be seen when unfolding the 
part, even though there is no bend linking it to its tangent support, provided this 
support is unfoldable too.

Open the NEWTangentWall1.CATPart document.

1.  Select a face of an existing wall and click the Sketcher icon .

Here we selected the flange's planar face.

2.  Select the Profile icon  and sketch the contour as shown below.

You can also select Sketch.2 from the specification tree.

3.  Using the Constraint Defined in Dialog box icon, set coincidence constraints 
between the edges where the support and sketch are to coincide.

4.  Click the Exit workbench icon  to return to the 3D world.
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Creating Tangent Walls

5.  Make sure the sketch is still active, 

then click the Wall icon .

The Wall Definition dialog 
box opens. 

Note the orientation of the wall to be 
created.

6.  Click inside the Tangent to field, 
then select the wall to which the 
new wall has to be tangent.

Here, you need to select the 
planar face of the flange.

Note that the orientation automatically changes to conform to the material orientation 
already defined on the support wall.

7.  Click OK.
The wall is created and a Wall.xxx 
feature is added in the 
specification tree.
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Creating Tangent Walls

8.  Click the Unfold icon .

The tangent wall is unfolded as a wall linked by a bend to another wall, would be.

If you want to create the wall on a wall that cannot be unfolded, the system issues a 
warning and prevents you from creating the tangent wall.
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Creating Walls From An Edge
This task shows how to create walls from edges of an existing wall. This function is used to 
create a box in an easy and quick way from an existing reference wall.

At least one wall must already exist.

Open the NEWWall1.CATPart document from the samples directory.

1.  Click the Wall on Edge icon 

 and select an edge of an 

existing wall.  

The Wall On Edge 
Definition dialog box is 
displayed together with 
a preview of the wall. 

2.  Define the type of wall to be 
created by specifying the 
Reference, that is:

●     the Height of the wall: that is the 
orthogonal projection from the top 
of the wall on edge to the 
reference wall.
Select the  icon to define the 
height of the wall from the bottom 
of the reference wall or the  
icon to define the height of the 
wall from the top of the reference 
wall.
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Creating Walls From An Edge

●     the Length of the wall: that is the 
absolute value of the wall on edge 
without bend.

 3.  You can now relimit the wall 
by selecting planes for the 
First and Second Limit:

●     type:
❍     Undefined reference

❍     Up To Plane

●     Offset

●     Plane 

As a consequence, the generated 
wall is not necessarily rectangular.  

   
 4.  Define the angle of the wall: by default it is perpendicular to the plane containing the 

edge. You may modify it according to your needs. it is updated dynamically on the 
screen.

This preview gives information about: 

●     the Sketch Profile: by default, if you pick an edge on the top of the reference wall, the 
direction of the wall is upwards, if you pick an edge on the bottom of the reference wall 
the direction of the wall is downwards. 

Preview with top edge selected Preview with bottom edge selected
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Creating Walls From An Edge

You can invert the 
sketch's position, and 
therefore the wall's,  
using the Reverse 
Position button. 

Preview with bottom edge selected and sketch profile 
inverted

●     the material side: by default the 
material side is proposed so as to 
keep a continuity with the 
reference profile. 

However, you can 
change it by clicking the 
red arrow or the 
Reverse Side button.  

5.  Check the Clearance option 
to offset the wall on edge from 
the selected edge. 

The entered value is the 
radius of the bend on 
this edge. 
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Creating Walls From An Edge

Wall on edge with clearance Wall on edge without clearance
    

Note that the reference wall remains unchanged when changing the bend radius value. It is 
the Wall on Edge's length that is affected.

6.  You can also choose to create the wall with or without a bend by checking the With 
Bend option.

●     If there is no wall from which a limit can be computed, the reference element is the edge 
of the reference wall.

●     A wall on edge is defined by the 
selected edge (reference edge). 
When the reference edge is 
modified, by adding any feature 
that shortens the edge (a bend to 
an adjacent wall on edge or a 
cutout for example) the wall on 
edge based on this reference edge 
is recomputed.
To avoid this you may:  
❍     create the bend manually on 

the wall modifying the edge 
used as the reference to  create 
the other wall

❍     reorder the creation of walls to 
postpone the creation of the 
modifying feature

 ●     Both limits are computed with the same reference icon.

●     The bend is not previewed, even if the option With Bend is checked. However it will be 
created.

●     The selected options are modal and will be proposed to create the next wall.
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Creating Walls From An Edge

●     Walls on edge being contextual features, if you break the profiles continuity by inverting 
the material side of a wall, you may have to manually re-specify all features based upon 
the modified one, even if they are not directly connected to the modified wall, in order to 
update the part afterwards.

This is the case when 
creating a wall on edge 
from another wall on 
edge, for example:

●     If you invert the material side of 
the reference wall on which the 
first wall on edge has been 
created, both walls on edge are 
relocated (as if you were flipping 
the geometry):

●     If you invert the material side of 
the first wall on edge (and not the 
material side of the reference 
wall), the second wall on edge is 
relocated. Indeed, its specification 
being relative to the first wall on 
edge, when its input data (i.e. the 
edge selected on the first wall on 
edge) is modified, the second wall 
on edge is rebuilt at a new 
location. 

7.  Click OK in the Wall On Edge Definition dialog box.

A WallOnEdge.xxx element is created in the specification tree.

●     A WallOnEdge.x element can be edited: double-click it in the graphic area or in the 
specification tree to display its creation dialog box and modify the parameters described 
above, including the edge from which it is created. However, the sketch of a wall on edge 
cannot be edited directly.

●     Would you need to edit the sketch of a wall on edge, you have to isolate it first. See 
Isolating Walls.

●     You can cut or copy and paste a wall on edge. 
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Creating Walls From An Edge

●     If you cut and paste a wall on edge with children elements, these children elements are 
lost. This may result in update errors.

●     You cannot undo an Isolate action after having modified the wall.

●     Isolating a wall on edge erases all updating data.

   

Creating a Wall On Edge on a 
flange or a stamp

 

Open the NEWWall3.CATPart 
document.
Let's take an example with a user 
flange.

 

1.  Click the Wall on Edge icon 

 and select the edge of the 

user flange.  

 

 

2.  Click OK in the Wall on Edge 
Definition dialog box to create 
the wall on edge on the user 
flange.
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Extruding

Extruding

This task explains how to create a wall by extrusion.

You must have defined the Sheet Metal parameters.
A model is available in the NEWExtrude1.CATPart from the samples directory.

1.  Click the Extrusion icon .

2.  Select a sketch.

The Extrusion Definition dialog box 
is displayed. 

Several types of extrusion are available:  
●     Dimension : the requested input data are a sketch and a dimension,

●     Up to plane or Up to surface: a plane or a surface are input as limit to the 
extrusion. These functions are used to create walls that are not rectangular.

3.  Edit the Length1 and Length2 to set both extremities, for option Dimension.

By default, the Length1 value is positive.
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Extruding

The sketch you selected appears in the Selection field

You can now edit it by clicking the Sketcher icon  if you wish to modify it.

4.  Define the options as needed:

●     Check the option Mirrored extent to extent the material on both sides of the 
sketch. In that case, only Length1 can be edited. 

 

This option is only available if the type is set to Dimension.

●     Check Symmetrical thickness to create thickness inside and outside the sketch.

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt1110.htm (2 of 4)10/21/2004 8:50:36 AM
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●     Push Invert Material Side to invert the direction of the creation of the material.

 

5.  Click OK.

The walls corresponding to the selected sketch are created according to 
the specified options, and added to the specification tree.

●     When the extrusion is the first Sheet Metal feature of the Part, the reference wall is 
the first wall created based on the first segment of the sketch.

●     For option Up to Surface, while the wall end that is limited by the surface has the 
shape of the surface, its thickness does not fit the surface. It is a "rectangular" 
polygon defined by the first edge that comes into contact with the surface.
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Extruding

 
●     Such an extrusion can also be performed on 

a sketch made of lines and arcs of circle, 
provided there are no tangency 
discontinuities between the different 
elements. 
However, in this case: 
❍     the Up to plane or Up to surface 

capabilities are not available, 

❍     you cannot isolate such an extrusion,

❍     if the element of the extruded sketch 
connected to the part is an arc of circle, 
the extrusion will not display in the 
unfolded view. To avoid this, prefer to 
create a User Defined Flange or remove 
the arc of circle of the extruded sketch 
and create a bend to connect the 
extrusion to the part.

●     Extrusion walls can be edited and/or isolated.

The sketch may not be closed, and must contain at least a line.
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 Creating Rolled Walls

This task shows how to create rolled walls (such as pipes, open pipes with flange, etc.).

You must have defined the Sheet Metal parameters, and have a sketch available, in the 
form of an circular arc.
The part is available in the Rolledwall1.CATPart from the samples directory.

1.  Click the Rolled Walls icon .

2.  Select the circular sketch.

3.  Make sure the type is set to Dimension.

4.  Length 1 and Length 2 indicate the 
location of Limit 1 and Limit 2.

5.  Define the options as needed (the length being down to -50 mm):

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugbt1120.htm (1 of 4)10/21/2004 8:50:55 AM

http://pop.dia.uniroma3.it/catia/online/sheug_C2/samples/Rolledwall1.CATPart


Creating Rolled Walls

●     Check the option Mirrored extent to extend 
the material on both sides of the sketch. In 
that case, only Length1 can be edited.

●     Check Symmetrical thickness to create 
thickness inside and outside the sketch.

●     Push Invert Material Side to invert the 
direction of the creation of the material.

6.  Click OK in the dialog box to create the 
rolled wall.

 
Unfold Reference

 Two symmetrical faces are generated so that the rolled wall can be unfolded.
To do so, click the unfold icon .
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Creating Rolled Walls

 You can unfold the rolled wall using three different references:
 

●     Start point

 

●     End point

 

●     Middle point

  
The rolled wall is a particular extrusion, indeed the input sketch is either a circular arc 
or a closed circle.

The sketch may be open. In that case, you can define where the opening should be.
The opening angle must be at least 0.5 degree.

The sketch may be closed. In that case, you have no control on the opening location.

The only operations you can combine with a rolled wall in a Sheet Metal model are 
flanges and cutouts. 
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Creating Rolled Walls

No other elements (standard wall, bend,...) are allowed.
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Creating Bends on Walls
 

This section explains and illustrates different methods to create bends on walls. Bends can 
only be created between walls and not between any other Sheet Metal features, such as 
stamps for example.

Create bends from wall: select the two walls, set the bend radius value, the bend 
extremities, and specify the use of corner relief
Create flat bends: select a sketch, set the creation mode and limiting option, set the 
radius and angle in relation to the selected sketch.

[ Back ] [ Up ] [ Next ]
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Manually Creating Bends from Walls

Manually Creating Bends from Walls
This task explains two ways to create bends between walls in the Sheet Metal part.
These bends can be created on non-connex walls, and with a constant radius value.

Open the NEWBendExtremities01.CATPart document.

1.  Select the Bend icon .

The Bend Definition dialog 
box opens.

Note that the Radius field is in gray because it is driven by a formula when editing the 
sheetmetal parameters: at that time, you cannot modify the value.

2.  Select Wall.2 and Wall.5 in the specification tree.
The Bend Definition dialog box is updated.

3.  Right-click the Radius field and 
select Formula -> Deactivate 
from the contextual menu to 
change the value.

You can set the Radius value to 0.
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Manually Creating Bends from Walls

4.  Enter 4mm for the Radius and click 
Preview.

The bend is previewed, along 
with its orientation 
symbolized by arrows. The 
Left and Right texts further 
indicate this orientation and 
are useful to define different 
bend extremities. 

5.  Click the More>> button to display further options: 

You can define:  
●     the left and right extremity settings (see also extremities definition settings)

●     the corner relief definition settings

●     and the bend allowance settings.

6.  Within the Left Extremity tab, 
choose the Mini with round relief 
bend extremity type, deactivate the 
L1  and L2 length formulas, and set 
them to 6mm and 3mm 
respectively.
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Manually Creating Bends from Walls

7.  Click the Right Extremity tab, and 
choose the Curved shape type.

8.  Click Preview to visualize the left 
and right extremities.

9.  Click OK in the Bend Definition 
dialog box.

The Bend (identified as 
Cylindrical Bend) is created 
with the specified extremity 
types and is added to the 
specification tree. 

●     The extremities and the corner relief defined with the current dialog box will apply locally 
and prevail over any other global definition.

●     Be careful when creating bends with square or round relief. Depending on the geometry 
configuration, this can lead to removing more matter than you would expect. Indeed, a 
corner relief being computed on the whole intersection of the elements involved (bends or 
bend/wall), in the following configuration, the matter is removed till the end of the wall.
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Manually Creating Bends from Walls

Bend with no relief Bend with square relief
In this case, it is best to replace the bend corner relieves with cutouts (identified 
in red in the figure below) that will act as corner relieves removing matter to the 
part.

Creating a Bend on a flange or a 
stamp

 

Open the NEWBendExtremeties02.CATPart 
document.
Let's take an example with a surface 
stamp.
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Manually Creating Bends from Walls

1.  Select the Bend icon .

The Bend Definition dialog box 
opens.

2.  Select the surface stamp's face as 
Wall 1.

3.  Select Wall.3 in the specification 
tree as Wall.2.

 

3.  Click OK in the Bend Definition 
dialog box to create the bend on 
the surface stamp.

To deselect a wall, simply click on another wall available in the part.

The stamp must be open, contain a planar face, and have a radius higher than 0.
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 Creating Bends From a Line

This task explains how to generate bends based on a line (also called flat bends). A wall 
and a bend are created.

Open the NEWFlatBend1.CATPart document.

1.  Select the reference wall then the 

Bend From Flat icon .

The Bend From Flat Definition 
dialog box opens.

2.  Select a profile (Sketch.2 here) 
containing one or several lines.
This sketch must necessarily be a line.

Selected lines appear in the 
Lines combo list.
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Creating Bends From a Line

3.  You can choose the line extrapolation option:

 Axis 

 BTL (Bent Tangent Line): line corresponding to the limits of the bend's fillet

 IML (Inner Mold Line): line created by intersecting the internal surfaces of the 

bend (before filleting) and the wall

 OML (Outer Mold Line): line created by intersecting the bend support and a plane 

perpendicular to the wall and normal to the OML.

The Radius and the KFactor values are the 
one defined when editing the sheetmetal 
parameters:
Right-click the Radius or the KFactor field 
and select Formula -> Deactivate from 
the contextual menu to change the value.

 You can set the Radius value to 0.

4.  Set the angle value between the 
generated wall and the reference wall.

5.  Click OK to create the bend.
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Creating Bends From a Line

●     When creating such a bend on a 
reference wall (first wall), an arrow 
indicates which part is to be folded. Click 
this arrow to invert the side that will be 
bent.

 

 ●     Bends from line should be performed on end walls, or prior to creating further walls 
on the bent one.

●     Perform the bend before creating the stamping features, as stamps are not retained 
when the part is folded with the bend.
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 Aggregating Bodies
 

This task shows you, when creating a bend, to aggregate, under the current body 
containing a wall, the created bend as well as the body containing the second wall.

Open the NEWBendExtremities03.CATPart document.

 
This capability is available with the Bend and Bend From Flat functionalities.
Let's take an example with the Bend.

1.  In the specification tree, define 
Wall.2 (in Body.1) as current: right-
click and select Define In Work 
Object from the contextual menu.

 

 

2.  Select the Bend icon .

The Bend Definition dialog box 
opens.
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Aggregating Bodies

 

3.  Select Wall.2 and Wall.3 in the 
specification tree.
The Bend Definition dialog box is 
updated.

 

4.  Click Preview to visualize the bend.

5.  Click OK in the Bend Definition dialog 
box.

 

The Bend (identified as Cylindrical Bend.x) 
is created and added to the specification 
tree. 

You can see that it appears under the 
Body.1 node and aggregates Body.2 
containing Wall.3.
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Aggregating Bodies

You can perform the same operation by defining PartBody as the current object and 
selecting Wall.1 and Wall.2 as inputs. PartBody contains the cylindrical bend, that 
aggregates Body.1 (itself containing Wall.2).
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Creating Swept Walls

Creating Swept Walls
 

This section explains and illustrates how to create and use various kinds of swept walls, i.e. 
walls based on a given contour that is swept along a spine.

Create a flange: select a spine, and set the radius, length, and angle values.

Create a hem: select a spine, and set the radius, and  length values.

Create a tear drop: select a spine, and set the radius, and  length values.

Create a swept flange: select a spine, and a user-defined profile

Redefine swept walls limits: choose the Relimited type, and select a point lying on 
the spine or a plane normal to the spine and intersecting it as limits

Display swept walls axes in drafting sheets: open a CATDrawing document, click the 
Unfolded View icon, and select a plane

Selecting the Spine
Whatever the type of the swept wall you wish to create, you first need to select one or more 
contiguous edges to make up the spine along which the contour, either pre- or user-defined, 
is to be swept. You can:

●     manually select one, or more, edge(s)

Selection without propagation Resulting flange without propagation
    
●     select  one edge and click the Tangency Propagation button: all contiguous and tangent 

edges are selected. In this case, would you need to remove one edge, you need to 
manually select it. Remember that only extremity edges can be removed without breaking 
the continuity between edges.
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Creating Swept Walls

Selection with propagation Resulting flange with propagation
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Creating a Flange

Creating a Flange 

This task explains how to generate a flange from a spine and a profile.

Open the NEWSweptWall01.CATPart document from the samples directory.

1.  Select the Flange icon 

.

  

The Flange 
Definition dialog 
box opens. 

2.  Select the edge as shown in red.
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Creating a Flange

3.  Enter 2mm in the 
Radius field,
10mm in the Length 
field and 120° for the 
Angle.

4.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the 
bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field and choosing 
Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet Metal 
Parameters.

5.  Click OK to create the flange.
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Creating a Flange

The feature is added to the specification tree.

●     Use the Remove All button to remove the selected edge(s).

●     Use the Propagate button to select all tangentially contiguous edges forming the spine (see 
Selecting the Spine).

●     You can redefine the flange limits by choosing the Relimited option (see Redefining Swept Walls 
Limits).
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Creating a Hem

This task explains how to generate a hem from a spine and a profile.

The NEWSweptWall01.CATPart document is still open from the previous task.
If not, open the NEWSweptWall02.CATPart document from the samples directory.

1.  Select the Hem icon 

 in the Swept 

Walls sub-toolbar.

The Hem 
Definition dialog 
box opens.

2.  Select the edges as shown in red.
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Creating a Hem

3.  Enter 2mm in the 
Radius field, and 3mm 
in the Length field.

4.  Click the More button to display the Bend Allowance tab allowing you to locally 
redefine the bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field and 
choosing Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet Metal 
Parameters.

5.  Click OK to create the hem.
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Creating a Hem

The feature is added to the specification tree.

●     Use the Remove All button to remove the selected edge(s).

●     Use the Propagate button to select all tangentially contiguous edges forming the spine 
(see Selecting the Spine).

●     You can redefine the flange limits by choosing the Relimited option (see Redefining 
Swept Walls Limits).
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Creating a Tear Drop

Creating a Tear Drop

This task explains how to generate a tear drop from a spine and a profile.

The NEWSweptWall01.CATPart document is still open from the previous task.
If not, open the NEWSweptWall03.CATPart document from the samples directory.

1.  Select the Tear Drop icon  in the Swept 

Walls sub-toolbar.

The Tear Drop Definition dialog box 
opens.

2.  Select the edge as shown in red.
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Creating a Tear Drop

3.  Enter 3mm in the Radius field, and 8mm in the 
Length field.

4.  Click the More button to display the Bend Allowance tab allowing you to 
locally redefine the bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field 
and choosing Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet 
Metal Parameters.

5.  Click OK to create the tear drop.
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Creating a Tear Drop

The feature is added to the specification tree.

●     Use the Tangency Propagation button to select all tangentially contiguous edges 
forming the spine (see Selecting the Spine).

●     You can redefine the tear drop limits by choosing the Relimited option (see 
Redefining Swept Walls Limits).
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Creating a Swept Flange

Creating a Swept Flange 

This task explains how to generate a swept flange from a spine and a user-defined 
profile.

The NEWSweptWall01.CATPart document is still open from the previous task.
If not, open the NEWSweptWall04.CATPart document from the samples directory.

1.  Select the Swept Flange icon in the Swept 

Walls sub-toolbar.

The User Defined Flange Definition 
dialog box opens. 

 2.  Using the Sketcher icon , define a profile in the yz plane as shown below:

Then quit the Sketcher, using the Exit icon .

3.  Select the edge and the profile, as shown in red.

http://pop.dia.uniroma3.it/catia/online/cfyugwalls_C2/cfyugsweptflangeNEW.htm (1 of 4)10/21/2004 9:04:29 AM

http://pop.dia.uniroma3.it/catia/online/cfysa_C2/samples/NEWSweptWall01.CATPart
http://pop.dia.uniroma3.it/catia/online/cfysa_C2/samples/NEWSweptWall04.CATPart


Creating a Swept Flange

The dialog box looks like this:

4.  Click the More button to display the Bend Allowance tab allowing you to 
locally redefine the bend allowance settings. 
You may need to deactivate the formula using the contextual menu on the field 
and choosing Formula -> Deactivate before editing the value.
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Creating a Swept Flange

In this case, the new K Factor value overrides the value set in the Sheet 
Metal Parameters.

5.  Click OK to create the swept flange.

The feature is added in the specification tree.
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Creating a Swept Flange

●     Use the Remove All button to remove the selected edge(s).

●     Use the Propagate button to select all tangentially contiguous edges forming the 
spine (see Selecting the Spine).

●     You can redefine the flange limits by choosing the Relimited option (see Redefining 
Swept Walls Limits).
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Redefining Swept Wall Limits

Redefining Swept Wall Limits
This task explains how to redefine the spine's limits when creating any type of swept 
walls, using existing geometric elements: points lying on the spine or intersecting 
planes..

Open the SweptWall01.CATPart document.

 Let's take en example with the Flange (SheetMetal Design). This task can also be 
performed in the New SheetMetal Design as well as

1.  Select the Flange icon .

The Flange Definition dialog box opens. 

2.  Using the combo list, choose the Relimited 
type.

The Flange Definition dialog box is 
updated and now displays two Limit 
fields. 

3.  Select the spine.
Here we select a single edge. See also 
Selecting the Spine.
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Redefining Swept Wall Limits

4.  Successively select the two limiting elements. 
Here we select a point lying on the spine as the 
first selecting element, and a plane intersecting 
the spine as the second limiting element.

Make sure intersecting elements are normal to the spine, and they intersect it only 
once.

5.  Specify the swept wall values.
In the example of the flange you set the Radius, Length and Angle values. You 
may also click More >> to display further options. See Creating a Flange. 

6.  Click OK.

The swept wall is created within the limits on the spine.
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Creating a Hole

This task shows you how to create a hole, that consists in removing material from a 
body.

Open the Hole1.CATPart document.

1.  Click the Hole icon .

The Hole definition dialog box 
opens.

2.  Select the Point that will be the center of the hole.
It can be either a sketch containing one or more points, or a point, or several 
points. The points must be on the same support.

●     The point can be selected anywhere in the geometry, not necessarily on a surface. In 
that case, an orthogonal projection will be performed.

●     You can also directly click the surface: a point will be created under the pointer. 

●     To deselect a point, click it in the specification tree. 

3.  Select the Support object where the hole will be positioned.

●     The support can be different from the support where the point lies. In that case, an 
orthogonal projection will be performed.
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Creating a Hole

The hole is previewed with 
default parameters.

4.  Define the value for the diameter of the hole in the Diameter field.

If you change the Diameter value using the spinners, the preview of the hole 
automatically updates. However, if you enter a value directly in the field, you need to 
click the Apply button to update the preview.

5.  Click OK to validate.

The hole (identified as Hole.xxx) is created and the specification tree is updated 
accordingly.

Holes can be created on the flattened part and on bends.

To have further information on Standard Files..., please refer to the Customizing 
section.
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Creating a Cutout

Creating a Cutout
This task explains how to create a cutout in a wall.
Creating a cutout consists in extruding a profile and removing the material resulting from the 
extrusion.

Open the NEWCutout1.CATPart document.

1.  Click the Cutout icon .

2.  Select a profile.

       
 

The Pocket Definition dialog box is displayed and 
CATIA previews a cutout with default parameters. 

 
Once the sketch is selected, you can modify it by clicking the Sketcher icon .

3.  Select the type.

Several limit types are available: 

●     Dimension: the cutout depth is defined by the specified value

●     Up to next: the limit is the first face the application detects while extruding the profile. This face 
must stops the whole extrusion, not only a portion of it, and the hole goes through material.

●     Up to last: the last face encountered by the extrusion is going to limit the cutout

●     Up to plane: the cutout is limited by the selected plane

●     Up to surface: the cutout is limited by the selected surface
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Creating a Cutout

When an Offset value is required, it is the distance between the limiting element and the top face 
of the cutout, if the latter does not result in a complete hole through the material.

The LIM1 and LIM2 texts in the geometry area indicate the top and bottom limits of the cutout.

●     The Reverse Side option lets you choose between removing the material defined within the 
profile, which is the application's default behavior, or the material surrounding the profile. 

●     The Reverse Direction option allows you to invert the direction of the extrusion pointed by the 
arrow.

4.  Click OK in the CutOut Definition dialog box.

The cutout is created. 

You may want to fold or unfold the part prior to creating the cutout, depending on the selected 
profile and the expected results. Selecting the same profile, the resulting cutout when created in the 
unfolded view is seen above, while below, the cutout was created in folded view.
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Creating a Cutout

However, you also have to be careful when designing the Part, not to create the cutout in the 
unfolded view as this may lead, when folding the part, to completely or partially removing another 
section of the Part. It is best, whenever possible, to create the wall based on a sketch integrating 
the shape of the cutout.

Cutout removing material Cutout not removing material based on wall's 
sketch modification

4.  Click More>> to display the maximum information.

The Direction is already selected (Sketch.3). If 
not, it must be set as normal to the profile.

5.  Select the Support (here we chose the wall)
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Creating a Cutout

May you want to create a cutout on an overlapping element or a bend with radius=0, either choose 
the top skin of the element (as shown in the picture above), or unfold the part to create the cutout.

 
You can use the Catalog icon  to open the Catalog Browser.

●     Refer to the Component Catalog Editor documentation to have further information on how to use 
catalogs.

●     Refer to the Create a Pocket task in the Part Design User's Guide for further details on how to 
create cutouts.
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Stamping

Stamping
This section explains and illustrates how to create and use various kinds of stamps.

●     Stamps must be created on walls, or walls on edge, except for the stiffness rib that 
is to be created on a bend. 

●     If a stamp is created over the limit between several supports, such as walls, bends, 
and so forth, this stamp is not visible on the unfolded view.

●     When unfolding a part, only the largest imprint of the stamp is retained on the 
stamped wall.

●     Stamps cannot be created on an unfolded part.

Creating Standard Stamping Features
Creating User-Defined Stamping Features

 
[ Back ] [ Up ] [ Next ]
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Creating Standard Stamping Features

Creating Standard Stamping Features
 

This section explains and illustrates how to create and use various kinds of stamps.
The table below lists the information you will find.

Create a flanged hole: select a point on a face, and set the stamping parameters. 

Create a bead: select a profile, and set the stamping parameters. 

Create a circular stamp: select a point on a face, and set the stamping parameters. 

Create a surface stamp: select a sketch, and set the stamping parameters. 

Create a bridge: select a point on a face, set the stamping parameters, and select an 
edge to give the bridge orientation. 
Create a flanged cutout: select a profile, and set the stamping parameters. 

Create a stiffening rib: select the external surface of a bend, and set the stamping 
parameters. 

I_CurveStampP2.
gif 
(876 
bytes)

Create a curve stamp: select a sketch, and set the stamping parameters. 

Create a louver: select a sketch, an opening line and set the stamping parameters. 

[ Up ]
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Creating a Flanged Hole

Creating a Flanged Hole

This task shows you how to create a flanged hole by specifying the punch geometrical parameters.

Open the NEWStamping.CATPart document.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping.CATPart document.

1.  Click the Flanged Hole icon .

2.  Select the surface where you want to 
place the hole.

A grid  is displayed to help you 
position the flanged hole and the 
Flanged Hole Definition dialog box 
opens, providing default values.

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R

●     Angle A

●     Diameter D

4.  Click Apply to preview the flanged hole.

5.  Click OK to validate. 

The flanged hole (identified as Flanged Hole.xxx) is created and the specification tree is updated accordingly.
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Creating a Flanged Hole

You can use 0 as the Radius value to 
deactivate the Radius R value, and to create 
the flanged hole without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Bead

Creating a Bead

This task shows you how to create a bead, that is a local deformation in the web.

Open the NEWStamping6.CATPart document.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping6.
CATPart document.

1.  Click the Bead icon .

2.  Select the spine 
profile where 
you want to 
place the bead.

The Bead 
definition 
dialog 
box is 
displayed, 
providing 
default 
values.

3.  Change the value in the different fields, if needed:

●     Height H

●     Radius R

●     Section Radius R1 (corresponding to the cross section value)

●     End Radius R2

The Sketch is automatically set to the sketch you chose.
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Creating a Bead

The vector for the 
direction of the bead 
is shown in the model 
and a preview of the 
bead appears and a 
vector shows its 
direction.

4.  Click Apply to preview the bead.

5.  Click OK to validate.

The bead (identified as Bead.xxx) is created and the specification tree is updated 
accordingly.

The vector cannot be reverted until the bead spine is defined.

You can use 0 as the Radius value to deactivate the Radius R value, and to create the 
bead without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Bead
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Creating a Circular Stamp

Creating a Circular Stamp

This task shows you how to create a point stamp by specifying the punch geometrical parameters.

Open the NEWStamping.CATPart document from the samples directory.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping.CATPart document.

1.  Click the Circular Stamp icon .

2.  Select a point on the top face. 

A grid is displayed to help you position 
the circular stamp.

The Circular Stamp Definition dialog box opens, providing default values.

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

●     Diameter D

4.  Click Apply to preview the circular stamp.
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Creating a Circular Stamp

 5.  Click OK to validate.

The circular stamp (identified as Circular Stamp.xxx) is created and the specification tree is updated 
accordingly.

 

You can use 0 as the Radius value to deactivate the 
Radius R and Radius R2 values, and to create the 
point stamp without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Surface Stamp

Creating a Surface Stamp

This task shows you how to create a surface stamp by specifying the punch geometrical parameters.

Open the NEWStamping4.CATPart document from the samples directory.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping4.CATPart document.

1.  Click the Surface Stamp icon .

2.  Select Sketch-for-Surface-Stamp, the profile previously defined. 

The Surface Stamp Definition dialog box opens, providing default values.

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

4.  Click Apply to preview the surface stamp.

5.  Click OK to validate.

The surface stamp (identified as Surface Stamp.xxx) is created and the specification tree is 
updated accordingly.
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Creating a Surface Stamp

 

You can use 0 as the Radius value to deactivate 
the Radius R1 value, and to create the surface 
stamp without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Bridge

Creating a Bridge

This task shows you how to create a bridge by specifying the punch geometrical parameters.

Open the NEWStamping5.CATPart document from the samples directory.

1.  Click the Bridge icon .

2.  Select a point on the top face where you want to place the bridge.

The Bridge Definition dialog box opens, providing default values. 

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

●     Length L1

●     Length L2

4.  Select an edge to give the direction of 
the bridge.
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Creating a Bridge

5.  Click Apply to preview the bridge.

 6.  Click OK to validate.

The bridge (identified as Bridge.xxx) is created and the specification tree is updated accordingly.

 

You can use 0 as the Radius value to 
deactivate the Radius R value, and to create 
the bridge without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Flanged Cutout

Creating a Flanged Cutout

This task shows you how to create a flanged cutout by specifying the punch geometrical parameters.

Open the NEWStamping8.CATPart document.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping8.CATPart document.

1.  Click the Flanged Cutout icon . 

2.  Select a profile. 

The Flanged Cutout Definition dialog box is displayed, providing default values.

3.  Change the value in the different 
fields, if needed:

●     Height H

●     Radius R

●     Angle A

 

4.  Click Apply to preview the flanged cutout. 

 5.  Click OK to validate. 

 

The flanged cutout (identified as Flanged Cutout.xxx) is created and the specification tree is updated accordingly.
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Creating a Flanged Cutout

 

You can use 0 as the Radius value to deactivate the 
Radius R value, and to create the flanged cutout without 
a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Stiffening Rib

Creating a Stiffening Rib

This task shows you how to create a stiffness rib by specifying the punch geometrical parameters.

Open the NEWStamping7.CATPart document from the samples directory.

If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping7.CATPart document.

1.  Click the Stiffness Rib icon .

2.  Select the external surface of Bend.1, where you want to place a stiffener.
Note that the stiffener will always be centered on the bend radius, wherever the point may be along the 
curve.

A grid is displayed.

The Stiffening Rib Definition dialog box opens, providing default  values.

3.  Change the value in the different 
fields, if needed:

●     Length L

●     Radius R1

●     Radius R2

●     Angle A

4.  Click Apply to preview the stiffness 
rib.
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Creating a Stiffening Rib

5.  Click OK to validate.

The stiffening rib (identified as Stiffnening Rib.xxx) is created and the specification tree is updated 
accordingly.

You can use 0 as the Radius value to 
deactivate the Radius R1 value, and to 
create the stiffening rib without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Curve Stamp

This task shows you how to create a curve stamp by specifying the punch geometrical parameters.

Open the NEWStamping3.CATPart document.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping3.CATPart 
document.

1.  Click the Curve Stamp icon .

2.  Select Sketch-for-Curve-Stamp, the curve previously defined. 

The Curve Stamp Definition dialog box opens, providing default values.

3.  Change the value in the 
different fields, if needed:

●     Height H: the total 
height

●     Radius R1: the 
outer bend radius

●     Radius R2: the 
inner bend radius

●     Angle A: the 
stamping draft 
angle 

●     Length L: the 
stamps' maximum 
width

4.  Click Apply to preview the 
curve stamp.
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Creating a Curve Stamp

5.  Click OK to validate.

The curve stamp (identified as Curve Stamp.xxx) is created and the specification tree is 
updated accordingly.

●     You can use 0 as the Radius 
value to deactivate the Radius R 
and Radius R2 values, and to 
create the curve stamp without 
a fillet.

●     Check the Obround option to round off the edges of the curve stamp.

 

Obround option checked Obround option unchecked

Please refer to the Customizing Standard Files chapter to define the Standards Files.
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Creating a Curve Stamp

 

http://pop.dia.uniroma3.it/catia/online/cfyugstamp_C2/cfyugcurvestamp.htm (3 of 3)10/21/2004 9:10:50 AM



Creating a Louver

 Creating a Louver 

This task shows you how to create a louver by specifying the punch geometrical parameters.

Open the NEWStamping11.CATPart document.

1.  Click the Louver icon .

2.  Select Sketch-for-Louver, a profile previously defined on Wall.2. The Louver Definition dialog box opens, 
providing default values.

The louver opening face is represented in the sketch by the element that does not present any tangency continuity 
with the other lines/curve segments of the sketch. In case there are several non-continuous elements, the first one is 
used as the opening face.

3.  Change the value in the different fields, if 
needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A1

●     Angle A2

4.  Select an edge of the sketch as the Opening Line: it indicates the position of the opening face of the louver.

5.  Click Apply to preview the louver.

6.  Click OK to validate.

The louver (identified as Louver.xxx) is created and the specification tree is updated accordingly.
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Creating a Louver
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Creating a Local Corner Relief

Creating a Local Corner Relief

This task explains how to define a corner relief locally on a set of supports.

Open the NEWCornerRelief01.CATPart document from the samples directory.
The part needs to be unfolded prior to creating the corner relief.

1.  Click the Corner Relief icon 

.

The Corner Relief 
Definition dialog box  is 
displayed. 

2.  Select the supports on which 
a corner relief should be 
created (here we chose 
Flange.1 and Flange.2)

A notch was defined on the web profile between the two fillets' flanges; so that flanges do not 
intersect. This operation enables to prepare the web as to create the flanges that will be later used 
to define the corner relief.

●     By default the User Profile  is active in the Corner Relief Definition dialog box.
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Creating a Local Corner Relief

1.  Select the sketch, 
directly in the 3D 
geometry.

 

 As soon as the sketch has been 

selected, the Sketcher  icon is 

displayed in the dialog box allowing 
you to edit the selected sketch, if 
needed. 

The red arrow lets you choose the 
direction of matter to remove. Click 
it to reverse the direction.

The sketch must be continuous in 
tangency.

2.  Click OK in the 
Corner Relief 
Definition dialog 
box.

 You can use the Catalog icon  to open the Catalog Browser.

For more information on catalogs, please refer to the Using Catalogs chapter in the CATIA 
Infrastructure User Guide.

●     Select the Circular Profile 

 using the down arrow. 
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Creating a Local Corner Relief

1.  Define the default radius: it is equal to the bend radius + the thickness.
In our example, we defined a radius of 15 mm.

By default the corner relief center is located at the intersection of the bend axes. You 
can select a point as the circle's center. 

2.  Select the vertex 
between the two 
flanges: it will be 
the center of the 
corner relief.

3.  Click OK in the 
Corner Relief 
Definition dialog 
box.

 

The created element (identified as Corner Relief.xxx) is added to the specification tree.

3.  Fold the part to check the corner relief in 3D.
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Creating a Local Corner Relief

Folded user corner relief Folded circular corner relief

The Supports Redefinition button 
enables to redefine the supports' 
sides thus adding matter to these 
supports.
In that case, the created element 
(identified as Corner Relief.xxx) 
appears before the supports in the 
specification tree.

Please note that checking this 
button means that the corner relief 
replaces the flange's side. This side 
must therefore exists: when creating 
the flange, do not define the side as 
None.
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Creating a Local Corner Relief

Unfolded user corner relief
with redefined supports

Folded user corner relief
with redefined supports 

The image besides shows two 
flanges creating with Angle as 
support type.
The two blue dotted lines represent 
the limits of the unfolded flanges.

The creation of a corner relief with 
supports redefined will not be 
created as it is not be located within 
the limits of the unfolded flanges.
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Creating Corners
This task shows how to create one or more corner(s) on a Sheet Metal part, that is to 
round off sharp edges, much like a fillet between two faces of a Part Design Body.
This corner creation operation can be performed indifferently on the folded or unfolded 
view, and only one support (i.e. the corner when previewed should not lie over two 
supports).

 Open the Corner1.CATPart document.
If you use Aerospace SheetMetal Design, open the Corner_Aero1.CATPart document.

1.  Click the Corner icon .

The Corner Definition dialog box is 
displayed. 

2.  Set the radius value.

3.  Choose the type of edge you wish to round off: 

●     using the Select All button: all convex edges, or 
all edges of both types

●     any edge manually selected

Once you have selected an edge, you can no longer modify this option, unless you 
cancel the selection.

4.  Select a sharp edge on a part.

As soon as you selected one edge, the 
dialog box is updated and the Select All 
button changes to Cancel Selection.
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Creating Corners

The corner is previewed on the edge, 
with the current radius value.

5.  Click Cancel Selection then click the Select All button.

All sharp edges of the part are selected and the corners previewed.

6.  Click OK in the dialog box.
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Creating Corners

All sharp edges of the part are rounded off to create smooth corners.

    
To deselect an edge, simply click it again. For quick selection in a complex part, you 
can select all edges with the Select All check button, then deselect one or two edges.

    
●     When you select an edge that is not sharp, such as the edge between a wall and a 

bend for example, a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges present at the time. If when 
modifying the part, new edges are created, these will not be automatically rounded 
off.
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Creating Chamfers
This task shows how to create one or more chamfer(s)  on a Sheet Metal part, that is 
to cut off, or fill in sharp edges of Sheet Metal parts.
This chamfer creation operation can be performed indifferently on the folded or 
unfolded view, and only one support (i.e. the chamfer when previewed should not lie 
over two supports).

 Open the Corner1.CATPart document.
If you use Aerospace SheetMetal Design, open the Corner_Aero1.CATPart document.

1.  Click the Chamfer icon .

The Chamfer Definition 
dialog box is displayed. 

You can choose the type of edge you wish to chamfer: 
●     using the Select All button: all edges

●     any edge manually selected

3.  Select a sharp edge on a part.

The chamfer is previewed on the edge.

As soon as you selected one edge, the dialog box is updated and the Select All button 
changes to Cancel Selection.

4.  Choose a chamfer Mode. You can either enter:
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●     two lengths: these lengths are 
computed from the selected edge on 
both sides.
Here, we chose two lengths of 10mm.

●     a length value and an angle: the 
length is computed on one side of the 
edge and the angle from the 
chamfer's limit on the same side.
Here, we chose a length of 10mm and 
an angle of 60deg.

You can use the Reverse button to inverse all edges' side, on which the values are 
taken into account.

5.  Click Cancel Selection then click the Select All button.

All sharp edges of the part are selected, the Select All button taking into 
account the chosen type and the chamfers previewed.
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6.  Click OK in the dialog box.

All sharp edges of the part are cut off or filled in. 

     
To deselect an edge, simply click it again. For quick selection in a complex part, you 
can select all edges with the Select All button, then deselect one or two edges.

     
●     When you select an edge that is not sharp, such as the edge between a wall and a 

bend for example, a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges present at the time. If when 
modifying the part, new edges are created, these will not be automatically 
chamfered.
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Mapping Elements

Mapping Elements

 
This task shows how to create curves or points from a sketch (as designed using the 
Sketcher) or from existing curves or points,  onto a Sheet Metal part; and to fold/unfold 
it, just as other Sheet Metal elements. 
This is especially useful when: 
●     you want to generate a logotype

●     you want to define an area for chemical milling

●     you want to create a cutout (pocket) to solve the overlapping of walls for example (the 
overlapping can be checked with the Sheet Metal Production product).

 Open the Mapping1.CATPart document.
If you use the New SheetMetal Design or the Aerospace SheetMetal Design, open the 
NEWMapping1.CATPart document.

1.  Click the Sketcher icon , 

select the wall onto which the 
curve should lie, and draw the 
sketch you wish.
This is the sketch that will be 
mapped onto the part.

2.  Exit the Sketcher .

The 3D part looks like this:
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 3.  Make sure the sketch is selected, 
and click the Fold/Unfold 

Points or Curves icon  .

The Elements To Map 
definition dialog box is 
displayed.
It indicates which elements 
have been selected for 
mapping.

 You can manage the list of elements:
●     to remove an element, select it from the list and use the Clear selection 

contextual menu

●     to add an element,  select it directly in the geometry.
Order in the list does not matter. 

4.  Select the Mapping Context, that is the element of the part on which the curve 
should be generated when folding or unfolding.

The Mapping Context is not necessarily the support element on which the element to be 
mapped has been drawn. Indeed, by default, the Mapping Context is the last Sheet 
Metal feature that has been created or modified, that is the current feature in the 
specification tree.

5.  Click OK.
A curve is created and added in the specification tree.
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Mapping Elements

Folded view of the curve mapping Unfolded view of the curve mapping

●     You can select several sketches/curves/points to be mapped at a time.

●     Mapped curves can be created across several walls and bends.
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Workbench Description

Workbench Description
Sheet Metal Design

NEW Sheet Metal Design
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Sheet Metal Design

Sheet Metal Design
The Sheet Metal Design application window looks like this:
Click the hotspots to display the related documentation. 

 

Menu Bar
Sheet Metal Toolbar
Constraints Toolbar

Reference Elements Toolbar
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Sheet Metal Design

Specification Tree 
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Menu Bar

Menu Bar

The various menus and menu commands that are specific to Sheet Metal Design are 
described below.

 

Start File Edit View Insert Tools Windows Help

Tasks corresponding to general menu commands are described in the Infrastructure User's 
Guide. Refer to the Menu Bar section. 

Insert 

For... See...

 

Sketcher... Refer to Sketching in the Sketcher 
User's Guide.

Sheet Metal 
Parameters...

Managing the Default Parameters

Walls 
Recognition...

Creating Walls from an Existing Part

Wall... Creating Walls from a Sketch

Wall on Edge... Creating Walls from an Edge

Extrusion... Extruding

Bends Insert -> Bends

Swept Walls Insert -> Swept Walls

Unfold Insert -> Unfold

ShePocket Insert -> ShePocket

Stampings Insert -> Stampings

Patterns Insert -> Patterns

CornerRelief... Creating a Local Corner Relief

Corners Insert -> Corners
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Menu Bar

Mapping... Mapping Curves

Save As DXF... Saving As DXF

Constraints
Setting Constraints in the Part Design 
User's Guide

Advanced 
Replication Tools

Insert -> Replication Tools

Instantiate From 
Document...

Instantiating PowerCopy Features

Insert -> Bends
 For... See... 

Automatic Bends Generating Bends Automatically

Bend Creating Bends From Walls

Conic Bend Creating Conical Bends

Bend Generating a Bend from a Line 
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Menu Bar

Insert -> Swept Walls
For... See... 
Flange Creating a Flange

Hem Creating a Hem

Tear Drop Creating a Tear Drop

Swept Flange Creating a Swept Flange

Insert -> Unfold
For... See... 
Unfold 3D View

MultiView Concurrent Access

Insert -> ShePocket
For... See... 

Cutout... Creating a Cutout

Split... Splitting Geometry

Insert -> Stampings
For... See... 
Point Stamp Creating a Point Stamp

Extruded Hole Creating an Extruded Hole

Curve Stamp Creating a Curve Stamp

Surface Stamp Creating a Surface Stamp

Bridge Creating a Bridge

Louver Creating a Louver

Stiffening Rib Creating a Stiffening Rib

User Stamping Creating User-Defined Features

Insert -> Patterns
For... See... 
Rectangular 
Pattern

Creating Rectangular Patterns
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Menu Bar

Circular Pattern Creating Circular Patterns

User-Defined 
Pattern

Creating User-Defined Patterns

Insert -> Corners
For... See... 
Corner Creating Corners

Chamfer Creating Chamfers

 

Insert -> Replication Tools
For... See... 
PowerCopy 
Creation

Creating PowerCopy Features

PowerCopy Save 
in Catalog

Saving PowerCopy Features

 
[ Up ] [ Next ]
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Sheet Metal Toolbar

Sheet Metal Toolbar

  

See Managing Default Parameters

     

See Creating Walls from an Existing Part

See Creating Walls from a Sketch

See Creating Walls from an Edge

See Extruding

See Creating Bends

See Creating Swept Walls

     

See Unfolding the Part

     

See Pockets

See Stamping

See Patterning

See Creating a Local Corner Relief
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Sheet Metal Toolbar

See Creating Corners

See Creating Chamfers

See Curve Mapping

       

See Save As DXF

[ Back ] [ Up ] [ Next ]
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Constraints Toolbar

  

See Setting Constraints from the Part Design User's Guide

 
[ Back ] [ Up ] [ Next ]
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Constraints Toolbar

  

See Setting Constraints from the Part Design User's Guide

 
[ Back ] [ Up ] [ Next ]
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Reference Elements Toolbar

   

See Creating Points

See Creating Lines

See Creating Planes

 
[ Back ] [ Up ] [ Next ]
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Specification Tree

Specification Tree
Within the Sheet Metal Design workbench, you can generate a number of features that are 
identified in the specification tree by the following icons.

Further information on general symbols in the specification tree are available in Symbols 
Used in the Specification Tree.

 

Sheet Metal Parameters  Rectangular Pattern

Wall Circular Pattern

Wall On Edge User-Defined Pattern

Extrude Corner Relief

Automatic Bends Corner

Bend Chamfer

Conical Bend Mapping

Flat Bend Point

Flange Line

Hem Plane

Tear Drop   

User-defined Flange   

Cutout   

Split   

Point Stamp   

Extruded Hole   

Curve Stamp    

Surface Stamp    

Bridge    
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Louver    

Stiffening Rib    

User-Defined Stamp    

[ Back ] [ Up ]
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NEW Sheet Metal Design

NEW Sheet Metal Design
The NEW Sheet Metal Design application window looks like this:
Click the hotspots to display the related documentation. 

 

Menu Bar
NEW Sheet Metal Toolbar
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NEW Sheet Metal Design

Constraints Toolbar
Reference Elements Toolbar

Specification Tree
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Menu Bar

Menu Bar

The various menus and menu commands that are specific to Sheet Metal Design are 
described below.

 

Start File Edit View Insert Tools Windows Help

Tasks corresponding to general menu commands are described in the Infrastructure User's 
Guide. Refer to the Menu Bar section. 

Insert 
For... See...

 

Constraints
Setting Constraints in the 
Part Design User's Guide

Sketcher Refer to Sketching in the 
Sketcher User's Guide.

Sheet Metal 
Parameters...

Managing the Default 
Parameters

Wall... Creating Walls from a Sketch

Wall on Edge... Creating Walls from an Edge

SmdGeneralExtrudeMenuInsert -> Extrudes

Bend... Creating Bends From a Line

Swept Walls Insert -> Swept Walls

Unfold Insert -> Unfold

CutOut Creating a Cutout

Hole... Creating a Hole

Stampings Insert -> Stampings

Patterns Insert -> Patterns
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Menu Bar

CornerRelief... Creating a Local Corner Relief

Save As DXF... Saving As DXF

Corner/Chamfer Insert -> Corners

Shape Mapping... Mapping Elements

Advanced Replication 
Tools

Insert -> Replication Tools

Instantiate From 
Document...

Instantiating PowerCopy 
Features

Insert -> Extrudes
 For... See...

Extrude... Extruding

Rolled Wall... Creating Rolled Walls

Insert -> Swept Walls
For... See... 

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugwd0201.htm (2 of 4)10/21/2004 9:22:49 AM



Menu Bar

Flange Creating a Flange

Hem Creating a Hem

Tear Drop Creating a Tear Drop

Swept Flange Creating a Swept Flange

Insert -> Unfold
For... See... 
Unfold 3D View

MultiView Concurrent Access

Insert -> Stampings
For... See... 
Flanged Hole... Creating a Flanged Hole

Bead... Creating a Bead

Circular Stamp... Creating a Circular Stamp

Surface Stamp... Creating a Surface Stamp

Bridge... Creating a Bridge

Flanged CutOut... Creating a Flanged Cutout

Stiffening Rib... Creating a Stiffening Rib

Curve Stamp... Creating a Curve Stamp

User Stamp... Creating User-Defined Features

Louver... Creating a Louver

Insert -> Patterns
For... See... 
Rectangular 
Pattern

Creating Rectangular Patterns

Circular Pattern Creating Circular Patterns

User-Defined 
Pattern

Creating User-Defined Patterns

Insert -> Corners
For... See... 
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Menu Bar

Corner... Creating Corners

Chamfer... Creating Chamfers

 

Insert -> Replication Tools
For... See... 
PowerCopy 
Creation

Creating PowerCopy Features

PowerCopy Save 
in Catalog

Saving PowerCopy Features

 
[ Up ] [ Next ]
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NEW Sheet Metal Toolbar

NEW Sheet Metal Toolbar

  

See Managing Default Parameters

   

See Creating Walls from a Sketch

See Creating Walls From An Edge

See Extruding

See Creating Rolled Walls

See Creating Bends From a Line  

See Creating Swept Walls

   

See Unfolding the Part

   

See Creating a Cutout  

see Creating a Hole  

See Stamping

See Patterning

See Creating a Local Corner Relief
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NEW Sheet Metal Toolbar

See Creating Corners

See Creating Chamfers

See Mapping Elements

  

See Save As DXF

[ Back ] [ Up ] [ Next ]
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Reference Elements Toolbar

Reference Elements Toolbar

   

See Creating Points

See Creating Lines

See Creating Planes

 
[ Back ] [ Up ] [ Next ]
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Specification Tree

Specification Tree
Within the Sheet Metal Design workbench, you can generate a number of features that are 
identified in the specification tree by the following icons.

Further information on general symbols in the specification tree are available in Symbols 
Used in the Specification Tree.

 

Sheet Metal Parameters  Rectangular Pattern

Wall Circular Pattern

Wall On Edge User-Defined Pattern

Extrude Corner Relief

Rolled Wall Corner

Bend Chamfer

Flange Mapping

Hem Point

Tear Drop Line

User-defined Flange Plane

Cutout Flat Bend

Hole   

Flanged Hole

Bead   

Circular Stamp   

Surface Stamp   

Bridge    

Flanged Cutout    

Stiffening Rib    
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Specification Tree

Curve Stamp    

User-Defined Stamp    

Louver    

[ Back ] [ Up ]
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Customizing For NEW SheetMetal Design

Customizing For NEW SheetMetal Design
This section describes how to customize different settings specific to the NEW SheetMetal 
Design workbench. The settings described here deal with permanent setting customization. 

Customizing General Settings
Customizing Standard Files 
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Customizing General Settings

Customizing General Settings

This task explains how to customize the NEW Sheetmetal Design General Settings.

1.  Select the Tools -> Options menu item.
The Options dialog box appears.

2.  Click Mechanical Design category then the NEW Sheet Metal Design 
subcategory. 

The default path is displayed in the Standard Profiles Catalog Files. You can modify it 

by clicking the Browse icon .

If no catalog path has been defined prior to entering the Catalog Browser command, 
the default catalog is selected and is path automatically added to the Standard Profiles 
Catalog Files field.

[ Up ] [ Next ] 
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Customizing Standard Files

Customizing Standard Files
This section describes how to customize settings.
The task described here deals with permanent setting customizing.

Using Sheet Metal Standards Files

This task explains how to access company standards files.

Open a new document.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box opens.

2.  Select the Sheet 
Standards 
Files... button. 
The Sheet Metal 
Part Samples 
window is 
displayed.

3.  Indicate the path 
to the Sheet 
Metal table.

These files are available under .xls or .txt format.
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Customizing Standard Files

4.  Click Open.

In the 
Sheet 
Metal 
Parameters 
dialog box, 
the Design 
Table icon 

 

appears 
opposite 
the 
Thickness 
and Bend 
radius 
fields.

The parameters are now in gray, indicating that you can no longer modify the values.

5.  Click the Thickness Design Table icon  and select the line containing the 

appropriate parameters (for example Line 1).

Using the Tools -> Options -> General -> Document tab, Other Folders option, you 
can specify where the files are located. Refer to Document.
This scenario can work when the .CATPart document and all reference table files (Design & 
Radius) are located in the same directory. This directory is the current one when  the 
Design table is created, and also when the .CATPart is open.
However, generally speaking,  you must reference the complete path indicating where the 
radius table files are to be found in the RadiusTable column. In this case, regardless of the 
current directory, the correct tables are located when re-opening the .CATPart document.
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Customizing Standard Files

6.  Click OK.
The parameter values are updated in the Sheet Metal Parameters dialog box.

7.  Click the Bend 
Radius Design 

Table icon .

8.  Select line 2 and 
click OK. The 
parameter values 
are updated in 
the Sheet Metal 
Parameters 
dialog box.

9.  Create a bend.

The Bend 
Definition 
dialog box 
displays a 
design 
table for 
the Bend 
Radius.

The default 
mode, that 
is to say 
the 
formula:
Bend 
Radius = 
Part 
Radius is 
deactivated.
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Customizing Standard Files

Let's see the Bend Radius Table, using this icon . 

It shows the Bend Radius and the corresponding Bend Table. 

10.  Click OK.

If the Angle value is contained in the Bend Table, the Bend Allowance uses 
the corresponding value.
If not, the Bend Allowance is computed according to the KFactor. 

Using the Sheet Metal Design Tables:
Steps 1 to 4 are identical. 

5.  Click the Design Table icon  and select a line.

6.  Click OK.
The parameter values are updated in the Sheet Metal Parameters dialog box.
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Customizing Standard Files

 
At that time, the parameters Thickness and Bend radius are driven by the design table.
They are now in gray, indicating that you can no longer modify the values.
Note that if you create a bend, there is no design table: it's the formula which is used.

 
To disable the access to design tables:

●     Select the Tools -> Options -> Part -> Display tab and check Relations:

the Design Table icon  is displayed in the specification tree.

●     Right-click this icon: the contextual menu appears.

●     Select SheetMetal Thickness Table object -> Deactivate

The relation is no longer used but still exists.
It can be activated at any time.

 

[ Back ] [ Up ] 
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Glossary

Glossary 

       

B
bend A feature joining two walls

bend extremity Axial relimitation for a straight bend

C
corner relief A feature created at the intersection of several bends or of a bend and 

a wall allowing to remove matter so that the part can fold/unfold 
without overlapping.

cutout A feature corresponding to an opening through a feature.
The shape of the opening corresponds to the extrusion of a profile.

E
extrusion A feature created by extruding a profile and adding thickness

F
flange A feature created by sweeping a profile along a spine.

The different flanges or swept walls available are: simple and swept 
flange, hem and tear drop.

P
pattern A set of similar features repeated in the same feature or part

profile An open or closed contour including arcs and lines created by the Profile 
command in the Sketcher workbench

R
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Glossary

reference wall The first created wall; when unfolding the part, it is the fixed wall.

S

stamping A feature created by embossing sheet metal.
The different stampings available are:
point, extruded hole, curve, surface, bridge, louver and stiffening rib.

W

wall A feature created by adding thickness to a profile
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Index

Index 

                  

A
Assembly Design workbench

interoperability  
Automatic Bends

command   

automatic bends   

B
bead  
Bend

command   
bend allowance

defining  
bend corner relief

defining  

bend extremities  
bend extremities

defining  
Bend From Flat

command   
bend radius

defining   
bends

creating         
bisecting

lines  
Bridge

command  
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Index

Bridge  

bridge  
browsing

Sheet Metal catalog  

C
catalog  
Chamfer

command   
chamfers

creating   
Circular Pattern

command  

circular stamp   

clearance   
command

Automatic Bends   

Bead  

Bend   

Bend From Flat   

Bridge   

Chamfer   

Circular Pattern  

Circular Stamp   

Conic Bend  

Corner   

Corner Relief  

Corner relief  

Curve Stamp   

Cutout    

Extrusion      

Flange   
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Index

Flanged Cutout  

Flanged Hole   

Fold/Unfold Curves   

Hem   

Hole  

Isolate  

Line  

line  

Louver    

Multi Viewer  

Plane  

plane  

Point  

point  

PowerCopy Creation  

PowerCopy Instantiation  

PowerCopy Save In Catalog  

Rectangular Pattern  

Save As DXF  

Sheet Metal Parameters     

Split  

Stiffening Rib   

Surface Stamp   

Swept Flange   

Tear Drop   

Unfold  

Unfolded View  

User Pattern  

User Stamping   

Wall     

Wall on Edge   
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Index

Walls Recognition  
Commands

Search  
Conic Bend

command  

conical bends  
Corner

command   
Corner Relief

command  
corner relief

defining  

editing  

local  

corner relief  
corners

creating   
create

bead  

bridges  

circular stamp  

Corner relief  

curve stamp  

extruded hole  

flange  

flanged cutout  

hem  

Hole  

stiffness rib  

surface stamp  

swept flange  

tear drop  

creating  
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Index

creating

bends         

bridges  

chamfers   

circular stamp  

corners   

curve stamp  

curves   

cutouts   

extruded hole  

flanges  

hems  

lines  

louver  

louvers   

patterns    

planes  

points  

Power Copy  

stamps           

stiffnening rib  

surface stamp  

swept flange  

swept walls   

tear drops  

user-defined stamps  

walls            

wireframe elements  

creating bends  

creating walls  
crown

defining  

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugix.htm (5 of 13)10/21/2004 9:23:51 AM



Index

Curve Stamp   
curves

creating   
Cutout

command    

cutout  
cutouts

creating   

cutting faces  

D
defining

bend allowance  

bend corner relief  

bend extremities  

bend radius   

corner relief  

crown  

thickness   

design tables  

die stamps  

drawing   

DXF format  

E
editing

corner relief  

user-defined stamps  
elements

Sheet Metal Design   
extruded hole
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Index

create  

extruded hole   
extruded walls

isolating  
Extrusion

command      

F
Flange

command  

Flange  

Flanged Cutout  
Flanged Hole

command   
flanges

creating  

flat bends   
Fold/Unfold Curves

command   

Folding  

folding   

G
Generative Drafting

workbench   

H
Hem  
Hem

command  
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Index

hems

creating  

I
instantiating

Power Copy  
interoperability

Assembly Design workbench  

Part Design workbench   

Weld Design workbench  
Isolate

command  
isolating

extruded walls  

walls  

walls on edge  

L
Line

command  
line

command  

creating  
lines

bisecting  

creating  
local

corner relief  

Louver  
Louver

command   
louvers
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Index

creating   

M
managing

Power Copy  

Sheet Metal parameters  

manual bends   

material side       
Multi Viewer

command  

multi-viewing  

O
open faces  

P
parameters  
Part Design workbench

interoperability   

patterns  
patterns

creating    

user-defined  
Plane

command  
plane

command  

creating  
planes

creating  
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Index

Point

command  
point

command  

creating  
points

creating  
Power Copy

creating  

instantiating  

managing  

saving  
PowerCopy Creation

command  
PowerCopy Instantiation

command  
PowerCopy Save In Catalog

command  

punch   

R
Rectangular Pattern

command  

reference wall        

relief  
rolled walls

walls   

S
Save As DXF

command  
saving
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Index

Power Copy  

saving data  
Search

Commands  
searching

sheet metal features  

Sheet Metal catalog  
Sheet Metal Design

elements   

workbench  
sheet metal features

searching  
Sheet Metal Parameters

command     
Sheet Metal parameters

managing  
Split

command  
splitting

elements  
stamps

creating    

user-defined   

standard files  

Stiffening Rib  
Stiffening Rib

command  

stiffness rib  

Surface Stamp   
surface stamp

create  
Swept Flange

command  

Swept Flange  
swept flange

http://pop.dia.uniroma3.it/catia/online/sheug_C2/sheugix.htm (11 of 13)10/21/2004 9:23:51 AM



Index

creating  
swept walls

creating   

T
tangent walls   

Tear Drop  
Tear Drop

command  
tear drops

creating  
thickness

defining   

U
Unfolded View

command  

unfolded view     

Unfolding  

unfolding   
User Pattern

command  
User Stamping

command   
user-defined

patterns  

stamps   
user-defined stamps

creating  

editing  
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Index

W
Wall

command     

wall clearance   
Wall on Edge

command   

wall on edge  
walls

creating            

isolating  

rolled walls   

walls by extrusion   

walls from sketch   
walls on edge

isolating  

walls on edge   
Walls Recognition

command  
Weld Design workbench

interoperability  
wireframe elements

creating  
workbench

Generative Drafting   

Sheet Metal Design  
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Aerospace Sheetmetal Design

  

Preface
Using this Guide
Where to Find More Information

What's New?

Getting Started
Entering the Aerospace SheetMetal Design Workbench
Defining the Aerospace SheetMetal Parameters
Creating a Web from a Sketch
Creating a Surfacic Flange on a Web
Creating a First Cutout
Extracting Drawings from the Aerospace SheetMetal Design Part

User Tasks
Managing the Default Parameters

Editing the Sheet and Tool Parameters
Computing the Bend Allowance
Defining the Compensations

Creating a Web
Creating a Surfacic Flange
Creating a Joggle
Creating Swept Walls

Creating a Flange
Creating a Hem
Creating a Tear Drop
Creating a Swept Flange

Unfolding
Folded/Unfolded View Access
Concurrent Access

Creating a CutOut
Creating a Hole
Creating Stamping Features

Creating a Flanged Hole
Creating a Bead
Creating a Circular Stamp
Creating a Surface Stamp
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Aerospace Sheetmetal Design

Creating a Flanged Cutout
Creating a Stiffening Rib
Creating a Curve Stamp

Creating a Local Corner Relief
Creating Constraints
Mapping Elements
Creating Corners
Creating Chamfers
Patterning

Creating Rectangular Patterns
Creating Circular Patterns
Creating User-Defined Patterns

Reference Elements
Creating Points
Creating Lines
Creating Planes

Displaying Characteristic Curves
Looking For Aerospace SheetMetal Features
Browsing the Sheetmetal Catalog
Integration With Part Design

Workbench Description
Menu Bar
Aerospace SheetMetal Toolbar
Stampings Toolbar
Constraints Toolbar
Reference Elements Toolbar
Specification Tree

Customizing For Aerospace Sheet Metal Design
Customizing General Settings
Customizing Standards Files To Define Design Tables
Customizing Standards Files To Define Methods for Compensations

Glossary

Index

Preface
Aerospace Sheetmetal provides an associative feature-based modeling enabling to 
design sheetmetal parts in concurrent engineering between the unfolded or folded 
part representation.
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Aerospace Sheetmetal Design

Aerospace Sheetmetal allows you to define a part using predefined features. Both the 
folded geometry and the flattened geometry can be computed from the feature 
specifications.

Using this Guide
Where to Find More Information 

http://pop.dia.uniroma3.it/catia/online/CATIAfr_C2/aslugCATIAfrs.htm (3 of 3)10/21/2004 9:27:11 AM



Preface

Preface
Aerospace Sheetmetal provides an associative feature-based modeling enabling to design 
sheetmetal parts in concurrent engineering between the unfolded or folded part 
representation.

Aerospace Sheetmetal allows you to define a part using predefined features. Both the folded 
geometry and the flattened geometry can be computed from the feature specifications.

Using this Guide
Where to Find More Information 
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Using this Guide

Using this Guide
This guide is intended for the user who needs to become quickly familiar with the CATIA 
Version 5 Aerospace Sheetmetal Design product. The user should be familiar with basic 
Version 5 concepts such as document windows, standard and view toolbars.

[ Up ] [ Next ] 
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Where to Find More Information

Where to Find More Information
Prior to reading this book, we recommend that you read the Infrastructure User Guide.

The Part Design, the Assembly Design and the Generative Drafting, the Sketcher and the 
Generative Shape Design documentations may prove useful.

Finally, you can read the Sheet Metal Design (NEW) documentations to find out more about 
that product and to fully use the interoperability between these products.

Conventions 

 

[ Back ] [ Up ] 
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What's New?

What's New?
This table identifies what new or improved capabilities have been documented in Version 5 
Release 12 of the Aerospace SheetMetal Design workbench.

New Functionalities

Defining the Compensations

Customizing Standards Files To Define Methods for Compensations

Creating a Stiffening Rib

Mapping Elements

Creating Corners

Creating Chamfers

Patterning

Creating Rectangular Patterns
Creating Circular Patterns
Creating User-Defined Patterns

Integration With Part Design

Enhanced Functionalities

Creating a Surfacic Flange
A new compensation tab enables you to define compensations for joggles or flange 
sides

Creating a Joggle
You can apply compensations on a single, double, or twin joggle
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Defining the Compensations

 Defining the Compensations
This section shows how to select the appropriate method to define compensations when 
on the joggle or the flange sides.
Compensation is a modification of the standard calculation of the unfolding process in 
order to represent at best the material behavior.
You first need to define which method to apply by customizing design tables.
To do so, please refer to the Customizing Standards Files To Define Methods for 
Compensations chapter.

1.  Click the SheetMetal Parameters 

icon .

The Sheet Metal Parameters 
dialog box is displayed.

The fifth tab concerns the 
compensations.

     
 

2.  In the Joggle combo list, select the 
method as defined in the SheetMetal 
Standard files (lien):

●     None: no compensation is applied

●     Method 1 (= Method V4)

●     Method 2

If the method you chose is not the one 
defined in the SheetMetal Standard Files, a 
warning message is issued prompting you 
to select another file.
You can click the information icon to 
display a schema explaining both methods.
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Defining the Compensations

 3.  In the Flange Sides combo list, select how the sides will be computed:

●     None: no compensation is applied

●     Manual: Angle: the deformation is computed according to an angle

●     Manual: Length: the deformation is computed according to a length

 4.  Click OK in the dialog box to validate the compensations parameters.

[ Back ] [ Up ] 
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Customizing Standards Files To Define Methods for Compensations

Customizing Standards Files
To Define Methods for Compensations

This task explains how to access company standards files in order to define methods for joggle and sides compensations.

Open a new document.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box opens.

2.  Select the Sheet Standards Files... 
button. The File Selection window is 
displayed.

3.  Indicate the path to the Sheet Metal 
methods (Std_Method1.xls or 
Std_Method1_2.xls)

These files are available under .xls format.

 Two methods are available to enable the joggle compensations.
Both use Design Tables.

 
Method 1 (=Method V4)
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 The path to this file can be found in the Std_Method1.xls associate file.
  
 

Method 2
 Several files are needed.
   
 

   
 JoggleCompensation_SMax

●     If (S > 0 and S <= 1), then a = 5, b = 4, Ra = 1, Rb = 1.5

●     If (S > 6 and S <= 10), then a = 30, b = 26, Ra = 3.5, Rb = 4

●     If (S > 20), then a = 70, b = 55, Ra = 6, Rb = 7

  
 The path to this file can be found in the Std_Method1_2.xls associate file.

Std_Method1_2.xls also contains paths for each defined thickness.
   
 

  
 Here is an example of the file corresponding to a thickness of 1mm: 
  
 

  
 S corresponds to the depth of the joggle to compensate and X corresponds to the distance of the joggle from the flange side.

http://pop.dia.uniroma3.it/catia/online/bascuasl_C2/bascuasl0300.htm (2 of 3)10/21/2004 9:29:14 AM

http://pop.dia.uniroma3.it/catia/online/bascuasl_C2/images/method2_thicknessNLS.gif


Customizing Standards Files To Define Methods for Compensations

 JoggleCompensation_SfMax

●     If (S > 0 and S <= 1.5) and (X > 0 and X <= 4.5), then A = 0.55

●     If (S > 0 and S <= 1.5) and (X > 24.5), then A = 0.95

●     If (S > 1.5 and S <= 10) and (X > 4.5 et X <= 18.5), then A = 0.85

●     If (S > 10) and (X > 24.5), then A = 1.5

  
 4.  Choose the appropriate file for the desired method.

 5.  Click Open.

In the Sheet Metal Parameters dialog box, if you chose Method 2, the Design Table icon  appears opposite the 

Thickness field.

 
  
  
  
  

[ Back ] [ Up ] 
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 Patterning
This section explains and illustrates how to create various kinds of patterns on Aerospace 
Sheet Metal parts.

Create rectangular patterns: select the element to be duplicated, set the patterning 
type, and its parameters, and the reference direction

Create circular patterns: select the element to be duplicated, set the axial reference  
parameters, the reference direction, and possibly the crown definition

Create user-defined patterns: select the element to be duplicated, and the 
positioning sketch and anchor point 

    

To have further information about patterns, refer to Part Design User's Guide.

[ Back ] [ Up ] [ Next ] 
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 Creating Rectangular Patterns
In this task, you are going to create rectangular cutouts according to a pattern.
These features make the creation process easier.
You can only duplicate cutouts, holes, and stamps (except stiffening rib).
These features must lie on a unique and planar surface.

      
Open the RectangularPattern1.CATPart 
document.
The part looks like this:

1.  Select the rectangular cutout you want to 
duplicate.

2.  Click the Rectangular Pattern icon .

The Rectangular Pattern Definition dialog box is displayed. Each tab is 
dedicated to a direction to define the location of the duplicated feature. 

3.  Set the specification for the First 
Direction by selecting the first edge 
(Edge.2) as shown, to specify the first 
direction of creation.
An arrow is displayed on the flange. 

The Reverse button enables to 
modify the direction.
You can also click the arrow in the 
3D geometry.
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4.  Keep the Instances & Spacing options 
to define the parameters.
Choosing these parameters types dims 
the Length field because the application 
no longer needs this specification to 
space the instances.

You can set the duplication parameters by choosing the number of instances, the 
spacing between instances, or the total length of the zone filled with instances.
Three options are available: 

1.  Instances & Length: the spacing between instances is 
automatically computed based on the number of instances and the 
specified total length

2.  Instances & Spacing: the total length is automatically computed 
based on the number of instances and the specified spacing value

3.  Spacing & Length: the number of instances is automatically 
computed to fit the other two parameters.

For each of these cases only two fields are active, allowing you to define 
the correct value.

If you set Instances & Length or Spacing & Length parameters, note 
that you cannot define the length by using formulas.

Patterns should not go beyond the surface (this can be checked using the preview).
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5.  Enter 2 as the number of instances you wish to obtain in the first direction.

6.  Define the spacing along the grid: enter 30mm.

Defining the spacing along the grid and the length of your choice, would make the 
application compute the number of possible instances and space them at equal 
distances.

7.  Now, click the Second Direction tab to 
define the other parameters.

Note that defining a second direction is not 
compulsory. Creating a rectangular pattern 
defining only one direction is possible.

8.  Select the second edge (Edge.3), as 
shown, to define the second direction.

9.  Keep the Instances & Spacing option: 
enter 8 and 10 mm in the appropriate 
fields.

Additional cutouts have been aligned 
along this second direction.

10.  Click OK to repeat the cutouts.

After the update, the part looks like this:
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11.  Select this icon  to unfold the part:

The pattern is updated on the unfolded 
view.

 

 
12.  Click the More>> button to display further options.

 The Simplified representation option lets you lighten the pattern geometry, when 
more than 10 instances are generated in one direction. What you need to do is just 
check the option, and click Preview. The system automatically simplifies the geometry:
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You can also specify the instances you do not 
want to see by double-clicking the dots. These 
instances are then represented in dashed lines 
during the pattern definition and then are no 
longer visible after validating the pattern 
creation. The specifications remain unchanged, 
whatever the number of instances you view. 
This option is particularly useful for patterns 
including a large number of instances.

[ Up ] [ Next ] 
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 Creating Circular Patterns
In this task, you are going to create circular cutouts according to a pattern.
These features make the creation process easier.
You can only duplicate cutouts, holes, and stamps (except stiffening rib).
These features must lie on a unique and planar surface.
Open the CircularPatterns1.CATPart document.
The part looks like this:

1.  Select the circular cutout you want to duplicate.

2.  Click the Circular Pattern icon .

The Circular Pattern Definition dialog box 
is displayed.

3.  Define the Axial Reference by choosing the 
Parameters type, and reference direction.
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●     Instance(s) & total angle: the number of patterns as 
specified in the instances field are created, in the 
specified direction, and evenly spread out over the total 
angle.

●     Instance(s) & angular spacing: the number of 
patterns as specified in the instances field are created in 
the specified direction, each separated from the 
previous/next one of the angular angle value.

●     Angular spacing & total angle: as many patterns as 
possible are created over the total angle, each 
separated from the previous/next one of the angular 
angle value.
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●     Complete crown: the number of patterns as specified 
in the instances field are created over the complete 
circle (360°). 

 If you set Instance(s) & total angle or Angular spacing & total angle parameters, note that you cannot 
define the length by using formulas.

4.  Click the Reference element and select the element defining the rotation axis.
Here select the face on which lies the circular cutout.

●     To define a direction, you can select an edge or a planar face.
Should you select the face of a web, the rotation axis would be normal to that face.

●     Click the Reverse button to inverse the rotation direction.
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Now you are going to add a crown to this pattern.

5.   Click the Crown Definition tab, and choose which 
parameters you wish to define the crown.

This figure may help you define these 
parameters:

 ●     Circle(s) and crown thickness: you define the number of circles and they are spaced out evenly over the 
specified crown thickness

●     Circle(s) and circle spacing: you define the number of circles and the distance between each circle, the crown 
thickness being computed automatically

●     Circle(s) spacing and crown thickness: you define the distance between each circle and the crown thickness, 
and the number of circles is automatically computed.

For example, using the values described 
above for the Angular spacing & total 
angle option, you could define the crown as: 

     
Note that one of the pattern goes beyond the flange (this 
can be checked using the preview).

You can delete instances of your choice when creating or 
editing a pattern. To do so, just select the points 
materializing instances in the pattern preview.

The instance is deleted, but the point remains, as you may 
wish to click it again to add the instance to the pattern 
definition again.
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6.  Click the More>> button to display further options:

Using these options, you can change the position of the 
selected cutout within the crown. For example, if you set 
the Row in angular direction parameter to 4, this is 
what you obtain: the initially selected cutout is the fourth 
instance, based on the rotation direction, of the pattern.

Typically, in this case, you might want to edit the pattern 
and click again the instance that you removed above, to 
get a full pattern.

●     The Simplified representation option lets you lighten the pattern geometry, when more than 10 instances 
are generated in one direction. What you need to do is just check the option, and click Preview. The system 
automatically simplifies the geometry:
You can also specify the instances you do not want to see by double-clicking them . These instances are then 
represented in dashed lines during the pattern definition and then are no longer visible after validating the 
pattern creation. The specifications remain unchanged, whatever the number of instances you view. This 
option is particularly useful for patterns including a large number of instances.

●     When checking the Radial alignment of instances, all instances have the same orientation as the original 
feature. When unchecked, all instances are normal to the lines tangent to the circle.

7.  Click OK to create the pattern.

[ Back ] [ Up ] [ Next ] 
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 Creating User-Defined Patterns
The User Pattern command lets you duplicate a feature, such as a sketch, a cutout, a 
stamp, or any other feature as many times as you wish at the locations of your choice.
Locating instances consists in specifying anchor points. These points are sketches.
You can only duplicate cutouts, holes, and stamps (except stiffening rib).
These features must lie on a unique and planar surface.

Open the UserPatterns1.CATPart document.

1.  Select the feature to be duplicated.
Here we selected the cutout. 

2.  Click the User Pattern icon 

.

The User Pattern 
Definition dialog box is 
displayed.

3.  Select 'Sketch 3' in the 
specification tree and click 
Preview.
The sketch contains the points 
you need to locate the 
duplicated cutouts. 

By default, the application positions each instance with respect to the center of gravity 
of the element to be duplicated. To change this position, use the anchor field: click the 
anchor field and select a  vertex or a point.
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4.  Click inside the Anchor field 
and select the point (Point.1) 
to indicate a new reference 
location.

5.  You can then click the points 
corresponding to the pattern 
instances to be removed.

Patterns should not go beyond the 
surface (this can be checked using 
the preview).

6.  Click OK in the User Pattern 
Definition dialog box.

Cutouts are created at 
the points of the sketch.

Would you need to unfold the part using the  icon, you would notice that the 

pattern is updated.
Please be careful concerning the content of the sketch selected to locate the instances 
of the User Pattern. The sketch should only include the points locating the instances of 
the selected reference feature. Therefore it is useful to create a point as "Construction 
Element" corresponding to the reference feature (in case of constraints for example), 
so that the instances are different from this feature.
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Integration With Part Design

You can open the Integration1.CATPart document.

In a CATPart document, you may have Part Design features and Aerospace Sheet Metal 
features according to the following rules:

●     Part Design features can be created before Aerospace Sheet Metal 
features.

●     a Part Design feature can also be created after Aerospace Sheet Metal 
features as long as the part is in folded view.

●     in the unfolded view, the Part Design feature will not be displayed.

●     it is no longer possible to create Aerospace Sheet Metal features after 
this last Part Design feature in folded view.

1.  Create two walls with an Automatic or Cylindrical Bend.

2.  Switch to Part Design workbench.

3.  Launch the Sketcher and draw an oblique line in the yz plane.

4.  Click the icon  to create a Stiffener.

5.  Switch to the Aerospace Sheet Metal workbench.

6.  Click the Unfold icon .
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The stiffener is not displayed on the unfolded view.

To add a new Aerospace Sheet Metal feature, select the Flange for example and right-
click the Define In Work Object item.

The new Aerospace  Sheet Metal feature will be added after the Flange but before the 
Stiffener.
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Creating a Surfacic Flange

This section explains how to create a surfacic flange on a web, or an existing surfacic flange (in that case, their fillets must not intersect).

Open the Flange1.CATPart document.
Create a web as shown in the previous task.

Here are the different elements taken into account when creating a surfacic flange: 
●     Base Feature

●     Support

●     EOP

●     Sides and Corners

●     Process

●     Compensations  

1.  Click the Surfacic Flange icon .

The Surfacic Flange definition dialog box is displayed.

 

Base Feature
In the Base Feature tab, the Bend Radius is of Constant type. It is set to the default bend radius of the part.

2.  You can modify the fillet Radius value by changing the driving equation: click the  icon.

The Formula Editor dialog box opens, you can modify the dictionary and the parameters.

Or you may need to deactivate the formula using the contextual menu on the field and choosing Formula -> Deactivate before editing the value.

3.  Choose the web as the Base Feature.

Once you chose the base feature, the Support tab automatically displays. 
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Support

4.  In the Support tab, choose the surfacic flange's geometrical support. It can either be a 
surface, a plane or a curve.

Make sure the support is big enough to be able to later define an EOP with a length from OML.
The OML is a curve created by intersecting the flange support and a plane perpendicular to the 
web and normal to the OML.

●     Exact: the selected support is to be used for the creation of the surfacic flange.

●     Approximation:  the support surface is approximated using a ruled surface. This ruled surface is 
defined from two curves: 
❍     the OML (in light blue), computed at the intersection between the support surface and the 

web plane.

❍     a curve parallel to the OML (in pink), computed at a distance equal  to the approximation 
length 

This mode enables you to compute the maximum deviation between the support geometry and 
the approximated surface.

 

●     Angle: the support of the surfacic flange can also be defined by a line, a curve, an angle or the 
edge of a base feature. The angle is constant and you can change its value using the spinners.

You can modify the Support Length generated by the curve and the angle. By default, 
the length is set to ten times the EOP (Edge of Part) length. If the default EOP length 
is higher than 100mm, you need to modify the surface length. 

The red angle is the angle taken into account when creating the surfacic flange.
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5.  Define the vectors' directions.

The vectors show the Base Feature Direction, the Direction and the Material Direction 
according to the direction of the geometrical support of the surfacic flange. 
You can modify the directions by clicking the arrows.

 

The surfaces (or curves) used to define the support surface must be continuous in point and tangency.

     

EOP

6.  In the EOP (Edge Of Part) tab, you can define either:

●     a length from OML (Outer Mold Line): length between the curve defining the top of the surfacic 
flange and the OML,

●     an element FD (Folded): boundary element (either a surface that intersects with its surface, or 
a sketch, or a wire projected on its surface),

●     an element FP (Flat Pattern): curve or sketch defining the flattened contour of the surfacic 
flange. 

The element FP must be included within the limits of the surfacic flange support 
when folded.

7.  Click OK.

The Surfacic Flange (identified as Surfacic Flange.xxx) is created and the specification tree is updated accordingly.
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Surfacic Flange with a length from OML of 15 mm Surfacic Flange with Plane.2 (in pink) as Element FD

Surfacic Flange with EOP FP (in light blue) as Element FP Unfolded view of the Surfacic Flange with EOP FP as Element FP.
See Unfolding.

     

Sides and Corners
In the Sides and Corners tab, you can choose to define the following elements:
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 ●     sides (intersection between the Base Feature and a curve) as: 
❍     standard: they are automatically defined at the web limit and the perpendicular plans are 

kept (in this case, the user does not have to define them)

❍     none: no side computed (only the EOP will define the contour of the Flange)

❍     element FD (Folded): they are defined by a folded  geometrical element (curve, plane or 
surface). 

❍     element FP (Flat Pattern): curve defining the flattened contour of the flange.

Surfacic Flange defined with a Length from OML of 10mm, and Side 1 and 2 as Standard Surfacic Flange defined with EOP FD as Element FD, and Side 1 and 2 as None

Folded view of the Surfacic Flange with EOP FP as Element FP, Side 1 FP and Side 2 FP (in light 
brown) as Side 1 and Side 2.

See Unfolding.

Unfolded view of the Surfacic Flange with EOP FP as Element FP, Side 1 FP and 
Side 2 FP (in light brown) as Side 1 and Side 2.

See Unfolding.
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a.  The following examples show two cases of a flange defined by an EOP FP or FD and Sides as None.

There is an intersection between the EOP and the web support -> the Surfacic Flange can be 
computed

There is no intersection between the EOP and the web support -> the Surfacic 
Flange cannot be computed

b.  The following examples show two cases of a flange defined by an element FD as the EOP and Standard sides.

There is an intersection between the EOP and the side -> the Surfacic Flange can be computed There is no intersection between the EOP and the side  -> the Surfacic Flange 
cannot be computed

c.  The following examples show two cases of a flange defined by an element FP as the EOP and Standard sides.
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There is an intersection between the OML and the EOP -> the Surfacic Flange can be computed There is no intersection between the OML and the EOP -> the Surfacic Flange 
cannot be computed

d.  The following examples show three cases of a flange defined by an element FD as the side.

There is an intersection between the Element FD and the OML and between the 
side and the EOP -> the Surfacic Flange can be computed

There is an 
intersection between 
the side and the OML 
but no intersection 

between the side and 
the EOP -> the 
Surfacic Flange 

cannot be computed

There is an intersection between the side and the EOP but no intersection 
between the side and the OML -> the Surfacic Flange cannot be 

computed

e.  The following examples show three cases of a flange defined by an element FD as the side.
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There is an intersection between the side and the EOP and between the side and 
the OML -> the Surfacic Flange can be computed

There is an 
intersection between 
the side and the OML 
but no intersection 

between the side and 
the EOP -> the 
Surfacic Flange 

cannot be computed

There is an intersection between the side and the EOP but no intersection 
between the side and the OML -> the Surfacic Flange cannot be 

computed

Standard sides are calculated on the first profile of a web that did not undergo any modifications. Any modification on the web will not be taken into account to create the surfacic 
flange's sides. For example, if you create a cutout on the web, then create a surfacic flange with standard sides, the latter will be calculated from the web's profile without the 
cutout (please note that the cutout's role is not to redefine the web)
For optimization reasons, we advise you to first create a sketch with the desired shape, then create the surfacic flange.

The example above shows a Surfacic Flange with standard sides calculated from the web modified 
by a cutout (the cutout, shown in blue, is ignored)

The example above shows a Surfacic Flange with standard sides calculated from 
the web defined entirely by a sketch (shown in blue)

●     corners (profile defined between the EOP and the sides) as: 
❍     none: no corner computed (only the EOP is able to define the contour of the Surfacic Flange)

❍     corner: between the side and the EOP (defined with a radius value)
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The example above shows a Surfacic Flange defined with Sides 1 and 2 as Standard, and Corners 
1 and 2 of 10mm each.

     

 

Process
 In the Process tab, you can define the:

●     Manufacturing process:
❍     Hydropressed

❍     BrakeFormed

●     K_Factor: you can modify the K Factor as defined in the Sheet Metal Parameters dialog box by 
changing the driving equation.
Click the  icon. The Formula Editor dialog box opens, you can modify the dictionary and the 

parameters. Or you may need to deactivate the formula using the contextual menu on the field 
and choosing Formula -> Deactivate before editing the value. 

You can also choose to display the characteristic curves either on the folded view (Show Folded 
Curves), and/or on the flattened view (Show Flattened Curves) of the part.

Compensations
 In the Compensations tab, you can define compensations for the:

●     Joggle:
❍     check the Apply Compensation button when creating or editing the joggle.

See Creating a Joggle for further information.

●     Flange Sides (Side and Side 2). 
❍     Define the type:

■     None: no compensation is applied

■     Manual: Angle: the deformation is computed according to an angle

■     Manual: Length: the deformation is computed according to a length parallel to the BTL.

❍     Define the Angle in the case of a Manual: Angle compensation. A negative angle adds 
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material, and a positive angle removes material.

❍     Define the Length in the case of a Manual: Length compensation

 

 The values of the modification are the angles A1 and A2.

●     Compensations can be created either on the folded or flattened part, but they only apply on the 
flattened part.

●     Compensations can be modified independently on each flange.

●     The + sign (in yellow in the 3D geometry) shows that material will be added to the sides.
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Unfolded Surfacic Flange defined with Corners 1 and 2 of 10mm each, and no compensation for 
Side 1 and Side 2 

Unfolded Surfacic Flange defined with Corners 1 and 2 of 10mm each, a Manual: 
Angle compensation of -20deg for Side 1 and no compensation for Side 2 

 

 Unfolded Surfacic Flange defined with Corners 1 and 2 of 10mm each, a Manual: Angle 
compensation of 20deg for Side 1 and -10deg for Side 2

    

●     In the case the user does not define a flange side, the latter is automatically computed at the Web limit, perpendicular to the OML.

●     In the case no corner is defined, the side and the EOP are simply relimiting each other

●     The sides of the fillet are continuous in tangency with the contour of the web and the sides of the flange.
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Creating a Joggle

Creating a Joggle

This task explains how to create a joggle, that is a feature which causes the flange to be locally deformed.

The joggle is a feature which cannot exist alone, it is always defined on a flange.

Open the Joggle1.CATPart document. 

Create a flange as shown in the previous task.

1.  Click the Joggle icon .

 

2.  Select the flange as the support.

The Support of the joggle is not automatically set to the last created flange.

3.  Choose a plane as the joggle plane, here we choose Plane3.

The blue curve defines the boundary of the web.

The vectors show you the joggle directions:

- The vector on the flange support determines the depth direction 

- The vector on the joggle plane determines the side on which the joggle is 
to be created

In case there are several intersections between the flange and the plane, the closest 
intersection is chosen.
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Creating a Joggle

You can click the  icon to display a schema showing the joggle parameters to be 

defined.

4.  You can modify the following parameters of the joggle by clicking the up and down arrows.

●     depth: offset from the support surface (shown as dotted lines)

The dotted lines must remain inside the blue curve.

●     runout: length of the offset, between the original surface of the flange and the new surface (joggle)

●     clearance: length added to the offset at the joggle starting plane

●     start radius: fillet between the runout and the flange

●     end radius: fillet between the runout and the offset

5.  Click OK.

The joggle (identified as Joggle.xxx) is created and the specification tree is updated accordingly. 

●     If you modify the depth, the runout adjusts automatically.

●     You can reverse the runout direction either by clicking the red arrow or by clicking the Invert Runout Dir button in the dialog box. 

●     You can reverse the depth direction either by clicking the red arrow or by clicking the Invert Depth Dir button in the dialog box.
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Creating a Joggle

Applying Compensations
 You can apply compensations when creating the flange or editing the joggle.

Compensations can be created either on the folded or flattened part, but they only apply on the flattened part.

Open the Joggle2.CATPart document for a single joggle, Joggle.3CATPart for a twin joggle, and Joggle4.CATPart for a double joggle.

Standard Files must have been previously imported and a method for compensations defined.

1.  Double-click the flange supporting the joggle to edit it.

2.  In the Compensations tab, click the Apply Compensations button.

 
On a single joggle

  

 

 Unfolded single joggle without compensations Unfolded single joggle 
with compensations 
relying on Method 1

Unfolded single joggle with compensations relying on Method 2

  
 

On a twin joggle
  

 

 Unfolded twin joggle without compensations Unfolded twin joggle 
with compensations 
relying on Method 1

Unfolded twin joggle with compensations relying on Method 2
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Creating a Joggle

  
 

On a double joggle
  

 

 Unfolded double joggle without compensations Unfolded double joggle 
with compensations 
relying on Method 1

Unfolded double joggle with compensations relying on Method 2
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Getting Started

Getting Started
Before getting into the detailed instructions for using Version 5 CATIA - Aerospace Sheet 
Metal Design, the following tutorial provides a step-by-step scenario demonstrating how to 
use key functionalities.

The main tasks proposed in this section are: 

Entering the Aerospace SheetMetal Design Workbench
Defining the Aerospace  SheetMetal Parameters

Creating a Web from a Sketch
Creating a Surfacic Flange on a Web

Creating a First Cutout
Extracting Drawings from the Aerospace SheetMetal Design Part

 
 
All together, these tasks should take about 20 minutes to complete.
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Entering the Aerospace SheetMetal Design Workbench

Entering the Aerospace SheetMetal Design 
Workbench

The Aerospace Sheet Metal Design functions are available when you are in the Part 
environment. Several functions are integrated from the Part Design workbench.

This task shows how to enter the workbench.
 Choose the Mechanical Design -> Aerospace Sheet Metal Design item from the 
Start menu.
The Aerospace Sheet Metal toolbar is displayed and ready to use.
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Entering the Aerospace SheetMetal Design Workbench

    
You may add the Aerospace Sheet Metal Design workbench to your Favorites, using 
the Tools -> Customize item. For more information, refer to the Infrastructure User's 
Guide.

 If you wish to use the whole screen space for the geometry, remove the specification 
tree clicking off the View -> Specifications Visible menu item or pressing F3.
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Defining the Aerospace  SheetMetal Parameters

Defining the Aerospace SheetMetal Design 
Parameters

This task shows you how to configure the Aerospace SheetMetal parameters.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed. 

2.  Enter 1mm in the Thickness field.

3.  Enter 5mm in the Default Bend Radius field.

4.  Select the Bend Extremities tab.
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Defining the Aerospace  SheetMetal Parameters

5.  Select Tangent in the Bend Extremities combo list.

An alternative is to select the bend type in the graphical combo list.

6.  Click OK to validate the parameters and close the dialog box.
The Sheet Metal Parameters feature is added in the specification tree.

The other two tabs are not used in this scenario.
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Creating a Web from a Sketch

Creating a Web from a Sketch

This section explains how to create a web.

The web is the main feature of an Aerospace Sheetmetal part: there is always one 
(and only one) web.

1.  Click the Sketcher icon .

2.  Select the xy plane.

3.  Click the Rectangle icon  in the Profile toolbar to create the contour of the 

web.

 

4.  Click to create the 
first point and drag 
the cursor. 

5.  Click to create the 
second point: the 
rectangle profile is 
displayed.

6.  Click the Exit 

workbench  to 

return to the 3D 
world.

 

7.  Click the Web icon 

.

The Web 
definition 
dialog box is 
displayed.
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Creating a Web from a Sketch

 

8.  Select the sketch you 
just created as the 
support of the web.
A preview of the web 
appears.

9.  Click OK to create 
the web.

 

 

Here is the 
web.

You can click the Sketcher 

icon  to edit the sketch.
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Creating a Web from a Sketch
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Creating a Surfacic Flange on a Web

Creating a Surfacic Flange on a Web

This section explains how to create a flange on a web, that is a feature which enables 
to stiffen the part.

The web is still open from the previous task.

1.  Click the 
Surfacic 

flange icon .

The 
Surfacic 
Flange 
definition 
dialog 
box is 
displayed.

 

 2.  Choose the web 
as the Base 
Feature.

3.  Choose the yz 
plane as 
support.
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Creating a Surfacic Flange on a Web

 

4.  Click Preview 
to see the 
surfacic flange.

 5.  Click OK to 
create the 
surfacic flange.

Here is 
the 
surfacic 
flange.
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Creating a First Cutout

Creating a CutOut

In this task, you will learn how to: 
●     open a sketch on an existing face

●     define a contour on the face in order to create a cutout.

You can create a cutout defined either by a sketch or an open geometry.  

The flange is still open from the previous task.

1.  Select the surface from the geometry area to define the working plane.

2.  Click the Sketcher icon .

3.  Click the Elongated Hole icon  to create the contour.

To access the oblong 
profile, click the black 
triangle on the Rectangle 
icon.
It displays a secondary 
toolbar.

4.  Click to create the 
first point and drag 
the cursor.

5.  Click to create the 
second point.
The first semi-axis of 
the profile is created.

6.  Drag the cursor and 
click to create the 
third point.
The second semi-axis 
is created and the 
oblong profile is 
displayed.
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Creating a First Cutout

7.  Click the CutOut icon 

.

 The CutOut Definition 
dialog box is displayed and 
a cutout is previewed with 
default parameters.

The vectors show the side 
and the direction of the 
cutout.
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Creating a First Cutout

8.  Select the Dimension type to define the limit of your cutout.

 9.  Click Ok.

Here is your 
cutout.
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Extracting Drawings from the Aerospace SheetMetal Design Part

Extracting Drawings from the
 Aerospace SheetMetal Design Part

This task shows how to create the Aerospace SheetMetal Design Part views in the Generative Drafting 
workbench.

The Sheet Metal part is displayed.

1.  Click  or select File -> New...

2.  Select the Drawing type and click OK.

The Generative Drafting workbench is launched.
The New Drawing dialog box opens.

3.  Click OK.

For more information about this workbench, refer to Generative Drafting User's Guide. 

4.  The drawing sheet appears.

5.  Tile the windows horizontally using the Window -> Tile Horizontally menu item.

6.  Select the Unfolded View icon  in the Projections toolbar from Generative Drafting Workbench.

This icon is added to the Projections toolbar provided the Sheet Metal workbench is present.

7.  Choose the xy plane in the Sheet Metal specification tree.
The unfolded view is displayed with the bends axes and limits.
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Extracting Drawings from the Aerospace SheetMetal Design Part

Eventually, the Drafting sheet looks like this:
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User Tasks

User Tasks
Managing the Default Parameters

Creating a Web
Creating a Surfacic Flange

Creating a Joggle
Creating Swept Walls

Unfolding
Creating a CutOut
Creating a Hole

Creating Stamping Features
Creating a Local Corner Relief

Creating Constraints
Mapping Elements
Creating Corners

Creating Chamfers
Patterning

Reference Elements
Displaying Characteristic Curves

Looking For Aerospace SheetMetal Features
Browsing the Sheetmetal Catalog

Integration With Part Design
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Managing the Default Parameters

Managing the Default Parameters
This section explains and illustrates how to use or modify various kinds of features.
The table below lists the information you will find.

Using Aerospace Sheetmetal Design assumes that you are in a CATPart document.

 

Edit the parameters: select the Parameters tab and define the element thickness and 
bend radius values.

Compute the bend allowance: select the Bend Allowance tab and define the allowance 
value (K factor).

Define the compensations: select the Compensations tab ans define the compensations 
for the joggle and the sides.

Please refer to the Customizing chapter to define the Sheet Standards Files.
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Editing the Sheet and Tool Parameters

Editing the Sheet and Tool Parameters

This section explains how to change the different sheet metal parameters needed to create your first feature.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed.

2.  Change the Thickness if needed.

 3.  Change the Minimum Bend Radius if needed.
The Minimum Bend radius defines the minimum internal radius allowing the creation of a bend. If the bend has a bend radius smaller than the one defined here, it will not be created.

4.  Change the Default Bend Radius if needed.
The Default Bend Radius corresponds to the internal radius and is linked by default to the creation of the flanges.

You can set the value to 0 to create bend with no radius. If using the DIN standard, the KFactor automatically sets to 0 as well.

Convention dictates that the inner angle between the two elements is used to define the bend.
It can vary from 0° to 180° exclusive. This angle is constant and the bend axis is rectilinear.

5.  Click OK to validate the Sheet Metal Parameters.

 
The Standard field displays the Standard to use with the part, if implemented. The name of this standard file is defined in a Design Table.
When the Check all the bend radii button is checked, and you click OK in the Sheet Metal Parameters dialog box, existing bend radii are checked and a list displays flanges or bends that do not use the minimum Bend Radius value 
as defined in step 3. Therefore, they will not be modified.

Parameters can be defined in a Design Table. To do so, press the Sheet Standards Files... button to access to the company defined standards, if need be. For more information, refer to the Customizing Standard Files section.

All parameters hereafter, or only some of them, can be defined in this Design Table:
 Sheet Metal Parameters Column associated in the Design Table Definition

Standard in Sheet Metal 
Parameters SheetMetalStandard sheet reference name

Thickness Thickness sheet thickness
Minimum Bend Radius MinimumBendRadius minimum bend radius
Default Bend Radius DefaultBendRadius default bend radius
K Factor KFactor neutral fiber position
Radius Table RadiusTable path to the file with all available radii

Whenever both Radius Table and Default Bend Radius are defined in the Design Table, only the Radius Table will be taken into account for the bend creation.

 Standard Names For Holes Column associated in the Design Table Definition
Clearance Hole ClearanceHoleStd path to the Clearance Hole Standard file
Index Hole IndexHoleStd path to the Index Hole Standard file
Manufacturing Hole ManufacturingHoleStd path to the Manufacturing Hole Standard file
Fastener Hole FastenerHoleStd path to the Fastener Hole Standard file

 Standard Names For Stamps Column associated in the Design Table Definition
Flanged Hole ExtrudedHoleStd path to the Flanged Hole Standard file
Bead BeadStd path to the Bead Standard file
Circular Stamp CircularStampStd path to the Circular Stamp Standard file
Surface Stamp SurfaceStampStd path to the Surface Stamp Standard file
Flanged CutOut FlangedCutoutStd path to the Flanged CutOut Standard file
Curve Stamp CurveStampStd path to the Curve Stamp Standard file

 When a parameter refers to a path, another sub-Design Table will be associated to the corresponding feature.
 

1. Here is an example for the use of a bend allowance table:
 Main Sheet Metal Parameters Design Table
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Editing the Sheet and Tool Parameters

 

 Radius Table For Thickness 2 
This table defines available all bend radii for a thickness of 2 mm. A design table will be created on the Default Bend Radius of the Sheet Metal Parameters and on the Radius of each bend.

 

 Bend Table for Thickness 2 and Bend Radius 1
Whenever a bend is created, a radius table will be associated. If the configuration "Bend Radius = 1mm" is selected,  a new design table (the Bend Table) will be created from BendTableT2R1.xls in order to compute the bend 
allowance.
According to the open angle, the bend deduction will be read in the Allowance column or interpolated if necessary.

 

 
2. Here is an example for the use of a hole standard file:

 Main Sheet Metal Parameters Design Table
 

 Hole Standard 
Whenever a hole is created, a design table will associate its radius with a standard name.

 

 
3. Here is an example for the use of a stamp standard file:

 Main Sheet Metal Parameters Design Table
 

Whenever a stamp is created, a design table will associate its dimension with a standard name.
    
 

●     Surface Stamp

    
 

●     Curve Stamp
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Editing the Sheet and Tool Parameters

 

●     Circular Stamp

    
 

●     Bead

    
 

●     Flanged Cutout

    
 

●     Flanged Hole

    
 

●     Stiffening Rib
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Computing the Bend Allowance

Computing the Bend Allowance

This section explains the calculations related to folding/unfolding operations.

1.  Click the SheetMetal Parameters 

icon .

The Sheet Metal Parameters 
dialog box is displayed.

The fourth tab concerns the bend 
allowance.

 
Bend Allowance

 The bend allowance corresponds to the unfolded bend width.

 
 

bend < 90° bend > 90° 
 L is the total unfolded length

A and B the dimensioning lengths as defined on the above figure. They are 
similar to the DIN definition.

 ●     K Factor
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Computing the Bend Allowance

 Physically, the neutral fiber represents the limit between the material compressed area 
inside the bend and the extended area outside the bend. Ideally, it is represented by 
an arc located inside the thickness and centered on the bend axis. 
The K factor defines the neutral fiber 
position:

W = α * (R + k * T)

where:

W is the bend allowance
R the inner bend radius
T the sheet metal thickness
α the inner bend angle in radians.

If β is the opening bend angle in degrees:

α = π * (180 - β) / 180

When you define the sheet metal parameters, a literal feature defines the default K 
Factor and a formula is applied to implement the DIN standard. This standard is 
defined for thin steel parts. Therefore the K Factor value ranges between 0 and 0.5.
The DIN definition for the K factor slightly differs. 

W = α * (R + k' * T/2)
Therefore k' = 2 * k and ranges from 0 to 1.

 This formula can be deactivated or modified by right-clicking in the K factor field and 
choosing an option from the contextual menu. It can be re-activated by clicking the 
Apply DIN button. Moreover, the limit values can also be modified.

      
 When a bend is created, its own K Factor literal is created. 

Two cases may then occur:

a.  If the Sheet Metal K Factor has an activated formula using the default bend 
radius as input parameter, the same formula is activated on the bend K Factor 
replacing the default bend radius by the local bend radius as input.

b.  In all other cases, a formula "equal to the Sheet Metal K Factor" is activated on 
the local bend K Factor.
This formula can also be deactivated or modified.

 
Bend Deduction
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Computing the Bend Allowance

 When the bend is unfolded, the sheet metal deformation is thus represented by the 
bend deduction V, defined by the formula:

L = A + B + V
(refer to the previous definitions). 

Therefore the bend deduction is related to the K factor using the following formula:

V = α * (R + k * T) - 2 * (R + T) * tan ( min(π/2,α) / 2)

 This formula is used by default. However, it is possible to define bend tables on the 
sheet metal parameters. These tables define samples: thickness, bend radius, open 
angle, and bend deduction. In this case, the bend deduction is located in the 
appropriate bend table, matching thickness, bend radius, and open angle. If no 
accurate open angle is found, an interpolation will be performed. 

     
 When updating the bend, the bend deduction is first computed using the previously 

defined rules. Then the bend allowance is deduced using the following formula:

W = V + 2 * (R + T) * tan ( min(π/2,α) / 2)

When the bend deduction is read in the bend table, the K factor is not used.
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Creating a Web

Creating a Web

This section explains how to create a web.

Open the Web1.CATPart document.

1.  Click the Web icon .

The Web definition dialog box is displayed.

 2.  In the Support field, select the support geometry in the specification tree. It can either be:

●     a plane (example from the Web from open geometry open body)

The Material Direction is displayed, perpendicular to the 
geometrical support. You can reverse the direction by clicking 
the arrow.

 

●     a closed sketch (example from the Web from closed 
sketches open body).

In our example, there are two closed 
sketches: the web will be calculated on 
the smallest part of the second sketch.

The Material Direction is displayed, 
perpendicular to the geometrical support. 
You can reverse the direction by clicking 
the arrow.
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Creating a Web

 

 
You can click the Invert Material Dir button to reverse the material direction of the web.

3.  In the Boundary field, in the case of an open geometry, select the elements that limit the support geometry. It can either be:

●     a list of elements (curves, surfaces, or planes)

●     one or more sketches

The elements must be selected consecutively.

 
They are displayed in the Boundary frame, in the order you chose them, as well as in the 3D geometry.
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Creating a Web

 When a closed profile can be built, a light preview of the web is available. Otherwise, click Preview.
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Creating a Web

 You can modify the selection by selecting an existing limit and using the following buttons to: 
●     add a limit after the selected limit (Add After)

●     add a limit before the selected limit (Add Before)

●     replace a limit (Replace)

●     remove a limit (Remove)

●     remove all limits (Remove All)

●     select several limits to modify the existing limit (Multiple Sel). This option is available once you have selected Add After: the 
Limits to Add dialog box appears to let you select the limits.

 Once you have modified the selection, a light preview is available. You can click the Preview button to display the result of the web.

When the contour is defined by a list of geometrical elements, the following operations are performed:

●     the curves are projected on the web geometrical support

●     the surfaces are intersected with the web geometrical support

4.  Click OK.

The web (identified as Web.xxx) is created and the specification tree is updated accordingly.
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Creating a Web

Features are aggregated under the web (identified as Web.xxx) so that they 
can be selected for a later use.

The sketches are aggregated under the web (identified 
as Web.xxx). Sketch.1 is displayed in No Show mode 

as it was only used to create the web.

 

[ Back ] [ Up ] [ Next ] 

http://pop.dia.uniroma3.it/catia/online/aslug_C2/aslugbt0100.htm (5 of 5)10/21/2004 9:36:58 AM



Creating Swept Walls

Creating Swept Walls
This section explains and illustrates how to create and use various kinds of swept walls, i.e. 
walls based on a given contour that is swept along a spine.

Create a flange: select a spine, and set the radius, length, and angle values.

 Create a hem: select a spine, and set the radius, and  length values.

 Create a tear drop: select a spine, and set the radius, and  length values.

Create a swept flange: select a spine, and a user-defined profile

Redefine swept walls limits: choose the Relimited type, and select a point lying on the 
spine or a plane normal to the spine and intersecting it as limits

Selecting the Spine
Whatever the type of the swept wall you wish to create, you first need to select one or more 
contiguous edges to make up the spine along which the contour, either pre- or user-defined, 
is to be swept. You can:

●     manually select one, or more, edge(s)

Selection without propagation Resulting flange without propagation

●     select  one edge and click the Tangency Propagation button: all contiguous and tangent 
edges are selected. In this case, would you need to remove one edge, you need to 
manually select it. Remember that only extremity edges can be removed without breaking 
the continuity between edges.
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Creating Swept Walls

Selection with propagation Resulting flange with propagation
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Unfolding

Unfolding
Unfolded Aerospace Sheet Metal parts can be displayed in two ways:

Folded/Unfolded View Access
Concurrent Access

  
Each Aerospace Sheet Metal feature is created in a given view: folded, or unfolded. 

Editing a feature must be done in its definition view. If not, a message is automatically 
issued, prompting you to change views, before editing the feature.
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Creating a CutOut

Creating a Cutout

This task explains how to create a cutout.
Creating a cutout consists in extruding a profile and removing the material resulting 
from the extrusion. 

You can create a cutout defined either by a sketch or an open geometry.  

Open the Cutout1.CATPart document.

1.  Click the CutOut 

icon .

2.  Select a profile.

 

The CutOut Definition 
dialog box is displayed 
and a cutout is previewed 
with default parameters.

The vectors show the side 
and the direction of the 
cutout.
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Creating a CutOut

 
Once the sketch is selected, you can modify it by clicking the Sketcher icon .

3.  Select the type.

Several limit types are available: 

●     Dimension: the cutout depth is defined by the value measured along the direction.

The depth corresponds to the web thickness.
Please refer to Editing the Sheet and Tool Parameters.

●     Up to next: the limit is the first face the application detects while extruding the 
profile. This face must stops the whole extrusion, not only a portion of it, and the 
hole goes through material.

●     Up to last: the application will limit the cutout onto the last possible face 
encountered by the extrusion.

9.  Select the profile you created using the sketcher (here Sketch.2).
It can be either a sketch containing one or more shapes, a wire, or a part.

●     The Reverse Side option lets you choose between removing the material defined 
within the profile, which is the application's default behavior, or the material 
surrounding the profile. 

●     The Reverse Direction option allows you to invert the direction of the extrusion 
pointed by the arrow.

10.  Click OK.

The cutout (identified as Cutout.xxx) is created and the specification tree is updated 
accordingly.
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Creating a CutOut

11.  Click More>> to 
display the 
maximum 
information.

The Direction 
is already 
selected 
(Sketch.2). If 
not, it must 
be 
perpendicular 
to the web.

12.  Select the Support (here we chose the web).

Once the Reference Direction and the Objects Support fields are filled in, the 
selection can be modified but cannot be cleared.

Cutouts can be created directly on the unfolded view of the part.

You can use the Catalog icon  to open the Catalog Browser.
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Creating a CutOut

May you want to create a cutout on an overlapping element or a bend with radius=0, 
either choose the top skin of the element (as shown in the picture above), or unfold 
the part to create the cutout.

 ●     Refer to Component Catalog Editor documentation to have further information on 
how to use catalogs.

●     Refer to the Create a Pocket task in the Part Design User's Guide for further details 
on how to create cutouts.
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Creating a Hole

Creating a Hole

This task shows you how to create a hole, that consists in removing material from a 
body.

Open the Hole1.CATPart document.

1.  Click the Hole icon 

.

The Hole 
definition 
dialog box 
opens.

2.  Select the Point that will be the center of the hole.
It can be either a sketch containing one or more points, or a point, or several 
points.

●     The point can be selected anywhere in the geometry, not necessarily on a surface. 
In that case, an orthogonal projection will be performed.

●     You can also directly click the surface: a point will be created under the pointer. 

●     To deselect a point, click it in the specification tree. 

3.  Select the Support object where the hole will be positioned.

●     The support can be different from the support where the point lies. In that case, an 
orthogonal projection will be performed.
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Creating a Hole

The hole is 
previewed 
with default 
parameters.

4.  Select hole type:

●     Clearance: defined with a center (point) and a radius

●     Index: used to measure and validate parts

●     Manufacturing: used for manufacturing (for example to fasten a part 
on an equiment

●     Fastener: used as a rivet

Hole types do not affect the hole geometry.

5.  Define the value for the diameter of the hole in the Diameter field.

If you change the Radius value using the spinners, the preview of the hole 
automatically updates. However, if you enter a value directly in the field, you need to 
click the Apply button to update the preview.

6.  Click OK to validate.

The hole (identified as Hole.xxx) is created and the specification tree is updated 
accordingly.
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Creating a Hole

●     To have further information on Standard Files..., please refer to the Customizing 
section.

Holes can be created on the flattened part and on the bend in case of a flange.
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Creating Stamping Features

Creating Stamping Features
This section explains and illustrates how to create and use various kinds of stamps.
The table below lists the information you will find.

 Create a flanged hole: select a point on a face, and set the stamping parameters. 

Create a bead: select a profile, and set the stamping parameters. 

Create a circular stamp: select a point on a face, and set the stamping parameters. 

 Create a surface stamp: select a sketch, and set the stamping parameters. 

Create a flanged cutout: select a profile, and set the stamping parameters. 

Create a stiffening rib: select the external surface of the bend, and set the stamping 
parameters.
Create a curve stamp: select a sketch, and set the stamping parameters. 
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Creating Constraints

Creating Constraints

This task shows how to set geometric constraints on geometric elements. 

Such a constraint  forces a limitation. For example, a geometric constraint might 
require that two lines be parallel.

To set a 
constraint  
between elements:

1.  Multi-select two or 
three elements to 
be constrained.

2.  Click the 
Constraint 
defined in dialog 

box icon .

The Constraint Definition 
dialog box appears 
indicating the types of 
constraint you can set 
between the selected 
elements.

3.  Select one of the available options to specify that the corresponding constraint 
should be made.

4.  Click OK.

The corresponding constraint  symbol appears on the geometry.
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Creating Constraints

To set a constraint 
on a single 
element:

1.  Select the element 
to be constrained.

2.  Click the 
Constraint icon 

.

  
The corresponding 
constraint  symbol 
appears on the geometry.
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Reference Elements

Reference Elements
You can create wireframe elements within the Aerospace Sheetmetal Design workbench:

Create points: click this icon, choose the point creation type, and specify parameters

Create lines: click this icon, choose the line creation type, and specify parameters

Create planes: click this icon, choose the plane creation type, and specify parameters
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Displaying Characteristic Curves

Displaying Characteristic Curves

This task shows you how to manage characteristic curves. 
Characteristic curves are displayed in the folded view of the part, as well as in the 
flattened view. They can be selected, though not edited, and be used as a support (to 
create points for example), 

A surfacic flange or a stamp with a fillet must be created.

 The following curves can be computed:
●     OML: Outer Mold Line

Intersection between external surfaces of the feature (before filleting) and the part

●     IML: Inner Mold Line
Intersection between internal surfaces of the feature (before filleting) and the part
Computed only on a hydropressed flange

●     BTL: Bent Tangent Line
Limits of the fillet

 They must be computed on the following features:
●     Surfacic Flange: the following curves are computed on both folded and flattened 

view (as defined in the Process tab of the Surfacic Flange Definition dialog box)
❍     BTL (two BTL for each limit of the fillet)

❍     OML

❍     IML

●     Stamps with an internal cutout (flanged hole, flanged cutout, etc): the following 
curves are computed on both folded and flattened view
❍     BTL on the base feature 

❍     IML (in no show in the folded view)

❍     OML (in no show in the folded view)

●     Stamps without an internal cutout (bead, curve stamp, etc): the following 
curve is computed on both folded and flattened view
❍     BTL on the base feature

Open the CharacteristicCurves1.CATPart document.

 Here is an example with two surfacic flanges, a bead and a flanged hole.
All characteristic curves are put in show in the following images.

Characteristic curves computed on the folded view
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Displaying Characteristic Curves

Characteristic curves computed on the flattened view
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Displaying Characteristic Curves

   

If you want to edit and modify a curve color, select it in the 3D geometry, right-click 
and choose the Properties contextual command. In the Properties dialog box, select 
the Graphic tab to access the graphic properties of the curve.
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Looking For Aerospace SheetMetal Features

Looking For Aerospace SheetMetal Features

This task shows how to use the Search capabilities on Aerospace SheetMetal Features, 
in order to detect any specific kind of feature.

Open the PowerCopyStart.CATPart document.

1.  Select the Edit ->  Search menu item.

The Search dialog box is displayed. 

2.  From the Type Workbench list choose Sheet Metal.

You can then display the list of Aerospace Sheet Metal Design features 
from the Type list: 
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Looking For Aerospace SheetMetal Features

3.  Select the type of feature you wish to find within the open .CATPart document. 
Here we chose Joggle.

4.  Click Search.

The list of all elements of the selected type is displayed in the Objects 
found field:

You can select an element from the list, it will be highlighted in the geometry area.

To find out more on the search capabilities, refer to Selecting Using the Search... 
Command (General Mode) and Selecting Using the Search... Command (Favorites and 
Advanced Modes) from the Infrastructure User's Guide.
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Browsing the Sheetmetal Catalog

Browsing the SheetMetal Catalog
This task explains how to browse the SheetMetal catalog and instantiate its components. The 
catalog enables to store the available profiles, therefore providing a method to position the 
profile in the part. 
This command is available with the CutOut and the Corner Relief functionalities.  

Let's take an example with the CutOut functionality.
For more information on catalogs, please refer to the Using Catalogs chapter in the CATIA 
Infrastructure User Guide.

Open the CutOut1.CATPart document.

1.  Once in the 
CutOut 
Definition dialog 
box, click the 
Catalog icon 

.

The 
Catalog 
Browser 
is 
displayed.

2.  Double-click a family from the list to display its components.
Here we chose the UserFeature_Family.
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Browsing the Sheetmetal Catalog

3.  Click a 
component to 
see its preview.
Here we chose 
Slot_Contour.

4.  Click the Table>> button to show/hide the catalog descriptions and keywords. By 
default, the table is hidden.

5.  Instantiate the 
component by 
double-clicking 
it.
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Browsing the Sheetmetal Catalog

The Insert Object dialog box is displayed.

6.  Select the 
required inputs: 
plane, point, 
and axis.

7.  Click Preview to 
see the 
resulting profile 
in the 3D 
geometry.

8.  Click OK in the 
Insert dialog box
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Browsing the Sheetmetal Catalog

The selected profile 
appears in the 
Selection field.

6.  Click OK.

The created element (identified as Cutout.xxx) is added to the specification tree.

You may need to reverse the direction of the cutout to create it.

Once the profile is instantiated in the default catalog, its path is automatically set in the 
Standard Profiles Catalog Files field.
See Customizing General Settings.

 A new panel now allows you to select alternate document access methods. 
See Opening Existing Documents Using the Browse Panel in CATIA Infrastructure User Guide.
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Workbench Description

Workbench Description
The Aerospace Sheet M etal Design application window looks like this:
Click the hotspots to display the related documentation. 
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Workbench Description

Menu Bar
Aerospace SheetMetal Toolbar

Stampings Toolbar
Constraints Toolbar

Reference Elements Toolbar
Specification Tree 
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Menu Bar

Menu Bar

The various menus and menu commands that are specific to Aerospace Sheetmetal Design 
are described below.

 

Start File Edit View Insert Tools Windows Help

Tasks corresponding to general menu commands are described in the Infrastructure User's 
Guide. Refer to the Menu Bar section. 

Edit 

The Edit menu lets you manipulate selected objects. Refer to the Infrastructure User's Guide 
and Part Design User's Guide. 

View 

The View menu lets you view document contents  Refer to the Infrastructure User's Guide.

The Search capability is available.

 

Insert 
For... See...

ContainerSketcherMenu Refer to the Sketcher User's 
Guide.

Sheet Metal 
Parameters...

Managing the Default 
Parameters

Web... Creating a Web

Surfacic Flange... Creating a Surfacic Flange

Joggle... Creating a Joggle

Swept Walls Insert -> Swept Walls

Fold/Unfold views 
management

Insert -> Unfold
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Menu Bar

CutOut... Creating a Cutout

Hole... Creating a Hole

Stampings Insert -> Stampings

Corner Relief... Creating a Local Corner 
Relief

Shape Mapping Mapping Elements

Corner/Chamfer Insert -> Corner/Chamfer

Pattern Insert -> Pattern

Constraint Setting Constraints in the 
Part Design User's Guide

Insert -> Swept Walls
 For... See... 

Flange Creating a Flange

Hem Creating a Hem

Tear Drop Creating a Tear Drop

User Flange Creating a Swept Flange

Insert -> Unfold
For... See... 
Unfold... Folded/Unfolded View Access

Multi Viewer... Concurrent Access
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Menu Bar

Insert -> Stampings
For... See... 
Flanged Hole... Creating a Flanged Hole

Bead... Creating a Bead

Circular Stamp... Creating a Circular Stamp 

Surface Stamp... Creating a Surface Stamp

Flanged CutOut... Creating a Flanged Cutout

Curve Stamp... Creating a Curve Stamp

Stiffening Rib... Creating a Stiffening Rib

 Insert -> Corner/Chamfer
 For... See...

Corner... Creating Corners

Chamfer... Creating Chamfers

Insert -> Pattern
 For... See...

Rectangular 
Pattern...

Creating Rectangular Patterns

Circular Pattern... Creating Circular Patterns

User Pattern... Creating User-Defined Patterns
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Aerospace SheetMetal Toolbar

Aerospace  SheetMetal Toolbar

  The Aerospace Sheet Metal Toolbar contains the following tools:

  

  

 See Managing the Default Parameters

 See Creating a Web

 See Creating a Flange

 See Creating a Joggle

 See Creating Swept Walls

 See Unfolding the Part

 See Creating a Cutout

 See Creating a Hole

 See Creating Stamping Features

 See Creating a Corner Relief

 See Mapping Elements  

 
See Creating Corners
See Creating Chamfers
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Aerospace SheetMetal Toolbar

 See Creating Patterns
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Stampings Toolbar

Stampings Toolbar
The Stampings toolbar contains the following tools:
 

   
     See Creating a Flanged Hole

  See Creating a Bead

 See Creating a Circular Stamp

  See Creating a Surface Stamp

 See Creating a Flanged Cutout

 See Creating a Stiffening Rib

 See Creating a Curve Stamp
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Constraints Toolbar

Constraints Toolbar

  The Constraints Toolbar contains the following tools:

 

  

  
See Setting Constraints from the Part Design User's Guide
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Reference Elements Toolbar

Reference Elements Toolbar

  The Reference Elements Toolbar contains the following tools:

 

   

 See Creating Points

 See Creating Lines

 See Creating Planes
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Specification Tree

Specification Tree
Within the Aerospace Sheetmetal Design workbench, you can generate a number of features 
that are identified in the specification tree by the following icons.

Further information on general symbols in the specification tree are available in Symbols 
Used in the Specification Tree.

Sketch Corner Relief

Sheet Metal Parameters Mapping

Web Corner

Flange Chamfer

Joggle Rectangular Pattern

Flange Circular Pattern

Hem User-Defined Pattern

Tear Drop Point

Swept Flange Line

Cutout Plane

Hole   

Flanged Hole   

Bead   

Circular Stamp   

Surface Stamp   

Flanged Cutout   
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Specification Tree

Curve Stamp   

Stiffening Rib   
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Customizing For Aerospace Sheet Metal Design

Customizing For Aerospace Sheet Metal 
Design

This section describes how to customize different settings specific to the Aerospace Sheet 
Metal Design workbench. The settings described here deal with permanent setting 
customization. 

Customizing General Settings
Customizing Standard Files To Define Design Tables

Customizing Standards Files To Define Methods for Compensations 
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Customizing General Settings

Customizing General Settings

This task explains how to customize the Aerospace Sheetmetal Design General 
Settings.

1.  Select the Tools -> Options menu item.
The Options dialog box appears.

2.  Click Mechanical Design category then the Aerospace Sheetmetal 
Design subcategory. 

The default path is displayed in the Standard Profiles Catalog Files. You can modify it 

by clicking the Browse icon .

If no catalog path has been defined prior to entering the Catalog Browser command, 
the default catalog is selected and is path automatically added to the Standard 
Profiles Catalog Files field.
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Customizing Standards Files To Define Design Tables

Customizing Standards Files
To Define Design Tables

This section describes how to customize settings.
The task described here deals with permanent setting customizing.

Using Sheet Metal Standards Files

This task explains how to access company standards files in order to access and define design tables.

Open a new document.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box opens.

 

2.  Select the Sheet 
Standards 
Files... button. 
The File Selection 
window is 
displayed.

3.  Indicate the path 
to the Sheet Metal 
table.

These files are available under .txt format or .xls format (only for NT and Windows)

4.  Click Open.

In the 
Sheet Metal 
Parameters 
dialog box, 
the Design 
Table icon 

 

appears 
opposite 
the 
Thickness 
and Bend 
radius fields.
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Customizing Standards Files To Define Design Tables

The parameters are now in gray, indicating that you can no longer modify the values.

5.  Click the 
Thickness Design 

Table icon  

and select the line 
containing the 
appropriate 
parameters (for 
example Line 1).

 
Using the Tools -> Options -> General -> Document tab, Other Folders option, you can specify where the 
files are located. Refer to Document.
This scenario can work when the .CATPart document and all reference table files (Design & Radius) are located in 
the same directory. This directory is the current one when  the Design table is created, and also when the .
CATPart is open.
However, generally speaking,  you must reference the complete path indicating where the radius table files are to 
be found in the RadiusTable column. In this case, regardless of the current directory, the correct tables are 
located when re-opening the .CATPart document.

6.  Click OK.
The parameter values are updated in the Sheet Metal Parameters dialog box.

7.  Click the Bend 
Radius Design 

Table icon .

8.  Select line 2 and 
click OK. The 
parameter values 
are updated in the 
Sheet Metal 
Parameters dialog 
box.

9.  Create a flange.

The Flange 
definition 
dialog box 
reflects the 
modification 
for the 
Radius.

The default 
mode, that 
is to say 
the formula:
Bend 
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Customizing Standards Files To Define Design Tables

Radius = 
Part 
Radius is 
deactivated.

Using the Sheet Metal Design Tables:
Steps 1 to 4 are 
identical. 

5.  Click the Design 

Table icon  

and select a line.

6.  Click OK.
The parameter values are updated in the Sheet Metal Parameters dialog box.

 
At that time, the parameters Thickness and Bend radius are driven by the design table.
They are now in gray, indicating that you can no longer modify the values.
Note that if you create a bend, there is no design table: it's the formula which is used.

 
To disable the access to design tables:

●     Select the Tools -> Options -> Part -> Display tab and check Relations: the Design Table icon  is 

displayed in the specification tree.

●     Right-click this icon: the contextual menu appears.

●     Select SheetMetal Thickness Table object -> Deactivate 

The relation is no longer used but still exists. It can be activated at any time.
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Glossary

Glossary

          

B
bead A local deformation in the web or a flange.

C
corner relief A feature defined on two flanges, which forms a corner. 

It relimits the two flanges and redefines the outer contour of the web 
between the two flanges.

cutout A feature corresponding to an opening through a feature.
The shape of the opening corresponds to the extrusion of a profile.

D
depth Dimension specifying the geometry of a bead or a joggle.

E
edge of part Element (usually a curve), which defines the length/height of a flange.

F
feature Characteristic form. Features are used to define a part.

flange A feature along the outer section of the web or an existing flange. It is 
used to connect to another product or to stiffen the part.

J
joggle Feature which causes the flange to be locally deformed.

Usually because the skin which is connected to the web is locally enforced 
by a strip or stringer (L or T profile).
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Glossary

K
K factor Determines the computation of the unfolded length of flanges.

P
pattern A set of similar features repeated in the same feature or part.

W
web Main constituent of a hydroformed part. Many other features (flanges, 

holes, etc.) are defined onto this feature.
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A
Aerospace SheetMetal Design features  

B
bead  
bend allowance

defining   

bend extremities  
bend radius

defining   
bisecting

lines  
browse

catalog  

C
catalog  
chamfer

command  
chamfers

creating  
circular pattern

command  

circular stamp  
command

Bead  

Chamfer  
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Circular Pattern  

Circular Stamp  

Constraint  

Constraint Defined in Dialog Box  

Corner  

Corner relief  

Curve Stamp  

Cutout  

Flange  

Flanged Cutout  

Flanged Hole  

Fold/Unfold Curves  

Hem  

Hole  

Joggle  

Line  

Multi Viewer  

Plane  

Point  

Rectangular Pattern  

Search  

Sheet Metal Parameters     
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Surface Stamp  
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Tear Drop  
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Web  
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defining  
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command  
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Generative Drafting

workbench  
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Part Design workbench  
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command  
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Sheetmetal Production

The V5 Sheet Metal Production is a product offering an intuitive and flexible user 
interface.
   
Natively integrated, Sheet Metal Production offers the same ease of use and user 
interface consistency as all V5 applications.
   
As a scalable product, Sheet Metal Production can be used in cooperation with other 
current or future companion products in the next CATIA generation such as 
SheetMetal Design and Generative Drafting. The widest application portfolio in the 
industry is also accessible through interoperability with CATIA Solutions Version 4 to 
enable support of the full product development process from initial concept to product 
in operation.

Using This Product
More Information
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Preface

Preface
The V5 Sheet Metal Production is a product offering an intuitive and flexible user interface.
   
Natively integrated, Sheet Metal Production offers the same ease of use and user interface 
consistency as all V5 applications.
   
As a scalable product, Sheet Metal Production can be used in cooperation with other current 
or future companion products in the next CATIA generation such as SheetMetal Design and 
Generative Drafting. The widest application portfolio in the industry is also accessible 
through interoperability with CATIA Solutions Version 4 to enable support of the full product 
development process from initial concept to product in operation.

Using This Product
More Information

http://pop.dia.uniroma3.it/catia/online/sh1ug_C2/sh1ugpr01.htm10/21/2004 6:08:43 PM



Using This Product

Using This Product
This guide is intended for the user who needs to become quickly familiar with the Sheet 
Metal Production product. The user should be familiar with basic Version 5 concepts such as 
document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-
step tutorial "Getting Started".

The next sections deal with the handling of more detailed capabilities of the product.
[ Up ] [ Next ] 
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More Information

Where to Find More Information
Prior to reading this book, we recommend that you read the Infrastructure User's Guide.

The Part Design User's Guide, the Assembly Design User's Guide, and the Sheet Metal 
Design User's Guide may also prove useful.

Conventions

[ Back ] [ Up ] 

http://pop.dia.uniroma3.it/catia/online/sh1ug_C2/sh1ugpr03.htm10/21/2004 6:09:01 PM



What's New?

What's New?
There is no new or improved capabilities in Version 5 Release 12 of the CATIA Sheet Metal 
Production.
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Getting Started

Getting Started

Before getting into the detailed instructions for using Version 5 Sheet Metal Production, the 
following tutorial provides a step-by-step scenario demonstrating how to use key functionalities.

The main tasks proposed in this section are: 

Entering The Workbench
Recognizing Walls

Using the Bending Wizard
Unfolding the Part

Checking Overlapping
Saving As DXF 

 
 
All together, these tasks should take about 15 minutes to complete.
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Entering The Workbench

Entering The Workbench
 
The Sheet Metal Production functions are available when you are in the Part environment. 

 
This task shows how to load a document and enter the Sheet Metal Production workbench.

 
Open the GettingStartedProduction.CATPart document.

Choose the Mechanical Design -> Sheet Metal Production item from the Start menu.
The Sheet Metal Production workbench is displayed and ready to use.
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Recognizing Walls

Recognizing Walls
 
This task shows how to automatically create walls from an existing solid.

 

1.  Click the Walls Recognition icon 

2.  Select a surface as the reference wall.
We selected the top surface.

The Wall Recognition 
Definition dialog box is 
displayed. 

3.  Choose the Wall creation mode: 

●     Part body recognition: the whole 
solid is processed and walls are 
created wherever possible

●     Only selected faces: only explicitly 
selected faces of the solid are 
processed and the corresponding 
walls are created.

The Reference wall is indicated in the Walls Recognition Definition dialog box for 
information only (it is grayed out).

4.  Do not select any face as the Compulsory walls.

5.  Choose the  As cut out wall option as the Internal profiles recognition mode. 
This means that only walls with inner contours are generated, and not walls and 
cutout features.

6.  Uncheck the Generate Bends button to avoid creating bends automatically.

7.  Click OK.

The walls are generated from the geometry.

The Walls Recognition.1 feature is added to the tree view. 
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Recognizing Walls

At the same time, the Sheet Metal parameters are created, deduced from the Part 
geometry.

8.  Double-click Sheet Metal 
Parameters.1 in the Specification 
Tree.
The Sheet Metal Parameters 
dialog box is displayed.

9.  Select the Bend Extremities tab 
and choose Maximum.

10.  Click OK.
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Using the Bending Wizard

Using the Bending Wizard
 
This task shows how to automatically create bends from the generated walls.

 
1.  Click the Bending Wizard  icon .

Bends are previewed.

Bends that can be created are 
displayed and computed.

 
In case an ambiguity arise on a bend, it would be displayed in red.

The bends are created and the specification tree 
updated accordingly.
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Using the Bending Wizard
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Unfolding the Part

Unfolding the Part

This task shows how to unfold the part.

 
1.  Click the Unfold icon .

The part is immediately unfolded.

 
To return to the 3D  view, simply click the Unfold icon  again.
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Checking Overlapping

Checking Overlapping
 
This task shows how check the overlapping of different areas of the unfolded part.

 
1.  Click the Check Overlapping icon .

In this case, a message is issued 
indicating that no overlapping is 
detected. 

2.  Click OK in the dialog box.

 
To find out more on overlaps, refer to Checking Overlapping. 
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Saving As DXF

Saving As DXF
 
This task shows how to save the generated geometry as a DXF document.

 
Open the SaveAsDXF01.CATPart Document.

 1.  Click the Save 
As DXF icon 

 .

The 
Select a 
Dxf file 
dialog 
box is 
displayed 
allowing 
you to 
navigate 
to the 
correct 
location. 

2.  Indicate the correct path and file name.

3.  Click Save.

The geometry has been saved as a DXF type file.
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User Tasks

User Tasks
The User Tasks section explains how to create and modify various kinds of features.
The table below lists the information you will find.

 
Recognizing Walls

Using the Bending Wizard
Checking Features

Unfolding
Saving As DXF 
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Recognizing Walls

Recognizing Walls

This task shows how to create a Sheet Metal part based on an existing Part, that is 
recognizing the thin part shapes of the Part as created using the  Part Design 
workbench or from a CATIA Version 4 Solid for example.

 Open the RecognizeWalls01.CATPart document from the samples directory.
This document contains a part created in the Part Design workbench and looking like 
this:

 

1.  Click the Walls Recognition icon .
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Recognizing Walls

The Walls Recognition Definition 
dialog box is displayed. 

3.  Choose the Wall creation 
mode: 

●     Part body recognition: the whole 
solid is processed and walls are 
created wherever possible

●     Only selected faces: only explicitly 
selected faces of the solid are 
processed and the corresponding 
walls are created.

The Reference wall is indicated in the Walls Recognition Definition dialog box for 
information only (it is grayed out).

4.  Select faces as the Compulsory walls.
These are faces from which the walls are to be generated when there might be 
an ambiguity. For example, if the initial part is a box, you will need to select 
two opposite inner faces and outer faces on the other two sides of the box, in 
order to avoid overlapping when generating the walls. 

5.  Set the Internal profiles 
recognition mode: 

●     As cut out wall: generates walls 
with inner contours (no cutout 
feature is generated)
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Recognizing Walls

●     One cut out by wall: regardless 
of how many pockets there are on 
a face of the solid, only one cutout 
feature is generated per wall

●     One cut out by profile: for each 
inner contour on the sketch-based 
solid,  a cutout feature is generated

●     None: whether there are pockets 
on the solid faces, or not, no cutout 
feature is created in the resulting 
SheetMetal features.
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Recognizing Walls

The Generate Bends check button allows the automatic creation of bends as the 
walls are being created, wherever applicable.

6.  Click OK to generate the walls, and bends if any.

Walls are automatically generated from the Part Design geometry.

 Open the RecognizeWalls02.CATPart 
document from the samples directory.
This part contains a filleted CATIA V4 
solid presenting different orientations. 

 

1.  Click the Walls Recognition icon .

2.  Click any face of the part as the reference wall.
The Wall Recognition Definition dialog box is displayed. 

3.  Make sure the Generate Bends button is checked.
It allows the automatic creation of bends, wherever applicable, as the walls are 
being created, .

Walls and bends, due to the presence of fillets in the initial part, are 
automatically generated.
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Recognizing Walls

 Note that once the part has been transformed into Sheet Metal features, the Sheet 
Metal Parameters are also created in the specification tree. 

Double-click the Sheet Metal Parameters entry from the specification tree to see them.
The Thickness parameter cannot be modified because it is based, like the bend 
extremities and radius, on the initial solid geometry . However you can modify these 
parameters (bend radius and bend extremities) to be taken into account for sheet 
metal features other than the "recognized" ones.
The bend allowance, being used to unfold the part, and the corner relief affect all 
features, and therefore can be edited even for "recognized" features.

 
Uncheck the Generate Bends button, if you do not wish bends to be created 
automatically.
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Using the Bending Wizard

Using the Bending Wizard
 
This task shows how to automatically create bends onto existing walls.

 
Open the BendingWizard01.CATPart document from the samples directory.

 

1.  Click the Bending Wizard icon 

The bends are created. 

 
Open the BendingWizard02.CATPart document from the samples directory.

 

1.  Click the Bending Wizard icon 

The bends cannot be created as there 
is an ambiguity because too many 
bends would overlap. 
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Using the Bending Wizard

The Auto Bend Definition dialog box is 
displayed indicating how many 
inconsistencies have been detected, 
and the number of walls not yet 
connected by a bend (Unconnected 
walls).

Orphan walls are walls that are not 
connected to any other wall.

2.  Explicitly select the bends that should be 
created. They are immediately previewed 
and the dialog box reflects your selection.

 

3.  Click OK in the dialog box to create the bends. 
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Checking Features

Checking Features
This section gives you tools to check the Sheet Metal Part prior to production:

Check overlapping: click the icon to highlight the overlapping areas, then click Apply to 
create a curve.
Check bend radius: click the icon to generate the list of bends not using the default bend 
radius parameter value.
Check feature fold/unfold visibility: click the icon to generate the list of Sheet Metal 
features that are not visible in the unfolded view.
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Checking Overlapping

Checking Overlapping
 This task shows how check the overlapping of different areas of the part. This is 
usually done when the part has been designed, bends created and the part is unfolded.
Overlapping between areas of the part are highlighted.
 
Open the Overlap01.CATPart document from the samples directory.

 
1.  Click the Unfold icon  to unfold the part.

2.  Click the Check Overlapping icon .

The area with the overlapping is 
highlighted in red. 

The Overlapping Detection dialog box is displayed 
indicating how many overlaps are present on the 
analyzed part.

3.  Click Apply.
A curve is generated. This curve can then be used to solve the overlapping, by 
redesigning the involved feature's sketches or specifications.

4.  Click OK.
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Checking Overlapping

Generated curve on unfolded view Generated curve on folded view
      

 
When no overlapping is detected, the Overlapping 
Detection dialog box indicates so:
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Checking Bend Radius

Checking Bend Radius
 This task shows how check the bends of a Sheet Metal part, i.e. to detect the bends 
that do not use the default bend radius parameter value, thus allowing the production 
teams to choose the correct tools to process the part.
 
Open the BendRadius01.CATPart document from the samples directory.

 1.  Double-click the Sheet Metal Parameters from the specification tree.

From the Sheet Metal 
Parameters dialog box you 
can see that the standard 
bend radius for the current 
document is 4mm. 

2.  Click Cancel in the Sheet Metal Parameters dialog box.

3.  Click the Check Bend Radius icon .

The bends whose radius 
value is different than the 
standard value as defined in 
the Sheet Metal Parameters 
dialog box, Parameters tab, 
are highlighted.
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Checking Bend Radius

Furthermore, a list of these 
bends is displayed in a dialog 
box.

3.  Click OK.

 If you display the Sheet Metal Parameters dialog box and that a bend differ from the 
set value, clicking OK will automatically highlight the bend involved and display the 
Bend Radius Check dialog box.
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Checking Feature Fold/Unfold Visibility

Checking Feature Fold Visibility
 This task shows how to check the fold/unfold visibility of a Sheet Metal Part. Indeed in 
some cases, you can notice that a few features are no longer visible once the part is 
unfolded.
This capability gives you the list of these elements.

 
Open the TangentWall1.CATPart document from the samples directory.

 
1.  Click the Check Feature icon .

 The list of the features that will 
not be visible is you unfold the 

part, using the Unfold icon  

is displayed in the dialog box.

2.  Click OK to exit the list.

Folded part with all features visible Unfolded part with features not visible
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Unfolding

Unfolding
 
This task shows how unfold/fold a part.

 
Open the Unfold1.CATPart document from the samples directory.

 
1.  Click the Unfold icon .

2.  Click the Unfold icon  again to return to the 

view of the folded part.
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Saving As DXF

Saving As DXF
 
This task shows how save the generated geometry as a DXF document.

 
Open the SaveAsDXF01.CATPart document from the samples directory.

 1.  Click the Save As 

DXF icon .

The Select a 
Dxf file 
dialog box is 
displayed 
allowing you 
to navigate to 
the correct 
location. 

2.  Indicate the correct path and file name (we saved it as PartSavedAsDXF.dxf)..

3.  Click Save.

The geometry has been saved, and can be imported as a DXF file in any system supporting 
this type.

4.  Close the CATPart Document.

5.  Click File -> Open.

6.  From the File 
Selection dialog box, 
choose the .dxf file 
type, then select the 
saved part 
(PartSavedAsDXF.
dxf).
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Saving As DXF

7.  Click Open.

The New 
Drawing 
dialog box is 
automatically 
displayed 
because the .
dxf type is 
recognized as 
being a 
drafting type.

8.  Click OK in the New 
Drawing dialog box.

The unfolded view of the part is created within the CATDrawing document.
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Saving As DXF

Note that the axes of  bends and planar hems, tear drops, or flanges are automatically 
displayed on the drawing.

 
Refer also to DXF/DWG Settings.

 

 
[ Back ] [ Up ] 

http://pop.dia.uniroma3.it/catia/online/sh1ug_C2/sh1ugbt0500.htm (3 of 3)10/21/2004 6:11:08 PM

http://pop.dia.uniroma3.it/catia/online/bascuitf_C2/bascuitf0300.htm


Workbench Description

Workbench Description
The Sheet Metal Production Version 5 application window looks like this:
Click the hotspots to display the related documentation. 

 

Menu Bar
Toolbars

Specification Tree

http://pop.dia.uniroma3.it/catia/online/sh1ug_C2/sh1ugwd0000.htm10/21/2004 6:11:17 PM



Menu Bar

Sheet Metal Production Menu Bar 

The various menus and menu commands that are specific to Sheet Metal Production Version 
5 are described below.

 

Start File Edit View Insert Tools Windows Help

Tasks corresponding to the Start, File, Edit, View, Tools, Windows and Help menu commands 
are described in the Infrastructure User's Guide. 

Insert

For... See... 

Unfold... See Unfolding

Walls 
Recognition...

See Recognizing Walls

Bending 
Wizard...

See Using the Bending Wizard

Check 
Overlapping...

See Checking Overlapping

Check Bends 
radius

See Checking Bend Radius

Check Feature See Checking Feature Fold/Unfold Visibility

Save As DXF... See Saving As DXF

 
[ Up ] [ Next ] 
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Tool Bars

Toolbars
 

The Sheet Metal Production Version 5 tool bars look like this: 

  

    

See Unfolding the Part

See Recognizing Walls

See Using the Bending Wizard 

 See Checking Overlapping

See Checking Bend Radius

See Checking Feature Fold/Unfold Visibility

See Saving As Dxf

[ Back ] [ Up ] [ Next ] 
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Specification Tree

Specification Tree
Within the Sheet Metal Production workbench, you can generate a number of Sheet Metal 
Features that are identified in the specification tree by the following icons.

Further information on general symbols in the specification tree are available in Symbols 
Used in the Specification Tree.

Sheet Metal Parameters Point Stamp

Walls Extruded Hole

Wall On Edge Curve Stamp

Flange Surface Stamp

Hem Bridge

Tear Drop Louver

User-defined Flange Stiffening Rib

Automatic Bends User-Defined Stamp

Bends from the Wizard Cutout

Bend Rectangular Pattern

Circular Pattern

 
[ Back ] [ Up ] 
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Glossary

Glossary

B

bend A feature joining two walls
bend extremity Axial relimitation for a straight bend

C

cutout A feature corresponding to an opening through a feature.
The shape of the opening corresponds to the extrusion of a profile.

E

extrusion A feature created by extruding a profile and adding thickness

F

flange A feature created by sweeping a profile along a spine.
The different flanges or swept walls available are:
simple and swept flange, hem and tear drop.

P

pattern A set of similar features repeated in the same feature or part
profile An open or closed contour including arcs and lines created by the Profile command 

in the Sketcher workbench

R

reference wall The first created wall; when unfolding the part, it is the fixed wall.

S

stamping A feature created by embossing sheet metal.
The different stampings available are:
point, extruded hole, curve, surface, bridge, louver and stiffening rib.

W
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Glossary

wall A feature created by adding thickness to a profile
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Index

Index 

           

A

analyzing 

parts   

automatic bends    

B

bend radius 

checking  
Bending Wizard 

command   
bends 

creating    

C

Check Overlapping 

command   
checking 

bend radius  

feature visibility  

overlapping   
command 

Bending Wizard   

Check Overlapping   

Features Check  

Radius Check  

Save As DXF   
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Index

Unfold   

Walls Recognition   
creating 

bends    

walls  

D

DXF format   

F

feature visibility 

checking  
Features Check 

command  
folding 

parts   

O

overlapping 

checking   

P

parts 

analyzing   

folding   

unfolding   
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Index

R

Radius Check 

command  

reference wall  

S

Save As DXF 

command   

saving data   

Sheet Metal parameters  
Sheet Metal Production 

workbench  

U

Unfold 

command   
unfolding 

parts   

W

walls 

creating  
Walls Recognition 

command   
workbench 

Sheet Metal Production  
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3D Functional Tolerancing & Annotation

  

Preface

Using this Guide

Where to Find More Information

Conventions

What's New

Getting Started

Entering the 3D Functional Tolerancing & Annotation Workbench

Choosing the Standard

Creating Annotation Texts

Creating Simple Datum

Creating Datum Targets

Creating a Geometrical Tolerance

Filtering Annotations

Disabling 3D Annotations

Accessing the Set Properties

Basic Tasks

Choosing a Standard

Using the Tolerancing Advisor

Introducing the Tolerancing Advisor

Dimensioning and Tolerancing Threads using the Tolerancing Advisor

Tolerancing Body in White

Creating Datum and Datum Targets

Creating Dimensions and Associated Datum

Creating a Datum Reference Frame

Tolerancing Body in White Holes

Tolerancing Body in White Surface

Creating Annotations

Creating Texts

Creating Flag Notes

Adding an Attribute Link
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3D Functional Tolerancing & Annotation

Creating Datum

Creating Datum Targets

Creating Geometrical Tolerances

Creating Roughness Symbols

Creating Isolated Annotations

Creating Dimensions

Creating Basic Dimensions

Creating Coordinate Dimensions

Creating Stacked Dimensions

Creating Cumulated Dimensions

Creating Curvilinear Dimensions

Generating Dimensions

Instantiating a Note Object Attribute

Creating a Partial Surface

Creating a Deviation

Creating a Correlated Deviation

Creating a Distance Between Two Points

Managing Annotations

Selecting Annotation/Annotation Plane

Displaying Annotation in the Normal View

Moving Annotations

Transferring Existing Annotations

Transferring Annotations During Creation

Grouping Annotations During Creation

Grouping Annotations Automatically

Grouping and Ordering Annotations

Making the Position of a Text Associative

Making the Orientation of a Text Associative

Mirroring Annotations

Clipping Annotations Plane

Marking Non-semantic Annotations

Setting Annotation Parallel to Screen

Replacing a Datum Reference Frame

Using 3D Grid

Managing Annotation Leaders

Adding Leaders and Using Breakpoints

Editing the Shape of an End Manipulator

Moving the End Manipulator of a Leader
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Adding the All Around Symbol

Setting Perpendicular a Leader

Adding an Interruption Leader

Managing Graphical Properties

Setting Basic Graphical Properties

Setting Advanced Graphical Properties

Setting Graphical Properties as Default

Copying Graphical Properties

Filtering Annotations

Using Annotation Filter

Creating a Tolerancing Capture

Displaying a Tolerancing Capture

Creating a Camera

Managing Tolerancing Capture Options

Using Capture Management

View/Annotation Planes

Using a View/Annotation Plane

Creating a Projection View/Annotation Plane

Creating a Section View/Annotation Plane

Creating a Section Cut View/Annotation Plane

Creating an Aligned Section View/Section Cut

Creating an Offset Section View/Section Cut

Activating a View/Annotation Plane

Editing View/Annotation Plane Properties

Managing View/Annotation Plane Associativity

Advanced Tasks

Creating Note Object Attribute

Note Object Attribute From a Text

Note Object Attribute From a Ditto

Storing a Note Object Attribute into a Catalog

Managing Annotation Connection

Using the Scope Range

Adding Geometry

Adding Component

Re-specifying Geometry Canonicity

Reporting Annotations

Generating a Check Report

Customizing the Reporting
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Annotation Associativity

Querying 3D Annotations

Creating an Automatic Default Annotation

Managing Power Copies

Creating Power Copy

Instantiating Power Copy

Saving Power Copy into a Catalog

Providing Constructed Geometry for 3D Annotations

Creating an Automatic Constructed Geometry

Managing Constructed Geometry

Workbench Description

Menu Bar

Insert Views/Annotation Planes Menu

Insert -> Annotations Menu

Insert -> Advanced Replication Tools Menu

Annotations Toolbar

Dimension Properties Toolbar

Reporting Toolbar

Style Toolbar

Text Properties Tool Bar

Position and Orientation Toolbar

Views/Annotation Planes Toolbar

Check Toolbar

Note Object Attribute Toolbar

3D Grid Toolbar

Grouping Toolbar

Capture Toolbar

Geometry for 3D Annotations Toolbar

Deviations Toolbar (Compact)

Workshop Description

Workbench Toolbar

Capture Visualization Toolbar

Capture Options Toolbar

Camera Toolbar

Customizing for 3D Functional Tolerancing & Annotation

Tolerancing

Display

Constructed Geometry
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3D Functional Tolerancing & Annotation

Preface
3D Functional Tolerancing & Annotation is a new-generation product which lets you 
easily define and manage 3D tolerance specifications and annotations directly on 3D 
parts or products.

The intuitive interface of the product provides an ideal solution for new application 
customers in small and medium-size industries, looking to reduce reliance on 2D 
drawings, and increase the use of 3D as the master representation for driving from 
design to manufacturing engineering process.

Annotations in 3D Functional Tolerancing & Annotation can be extracted, using the 
annotation plane concept in the Generative Drafting product. 

The product elements can be reviewed using specific functionalities, which constitute 
comprehensive tools for the interpretation of tolerancing annotations. 

This manual is intended for users who need to specify tolerancing annotations on 3D 
parts or on 3D products. It assists designers in assigning the correct tolerances on 
the selected surfaces by:

●     Selecting the surfaces to be toleranced.

●     Choosing among the available options, the tolerance types, the modifiers, 
etc. The system offers a choice of options which are consistent with the 
selected surfaces.

●     Entering the tolerance value. The tolerance annotation is then created and 
displayed around the 3D geometry. It is also located and oriented in an 
annotation plane, using a standardized model (usual standards: ISO, ASME / 
ANSI).

As a consequence, designers do not need to wonder whether the tolerancing syntax is 
correct, because this syntax is directly elaborated with regard to the chosen 
tolerancing standards (ISO, ASME / ANSI). 

Designers are ensured that their tolerancing schema is consistent with the part 
geometry. They do not need to be tolerancing experts, having in mind all the complex 
standardized tolerancing rules. Moreover, the tolerancing specifications will remain 
consistent whatever the geometrical modifications are. 

See Reference Information for further detail.

Note that 3 workbenches are available depending on whether you are working on a 
part (Functional Tolerancing and Annotation workbench), a product (Product 
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3D Functional Tolerancing & Annotation

Functional Tolerancing and Annotation workbench) or a process (Process Tolerancing 
and Annotation workbench). This guide is intended for users of all 3 workbenches, as 
the functionalities available are exactly the same from one workbench to another. 
However, note that the scenarios provided in this guide use parts (CATPart 
documents) as examples.  

Using this Guide
Where to Find More Information

Conventions
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Preface

Preface
3D Functional Tolerancing & Annotation is a new-generation product which lets you easily 
define and manage 3D tolerance specifications and annotations directly on 3D parts or 
products.

The intuitive interface of the product provides an ideal solution for new application 
customers in small and medium-size industries, looking to reduce reliance on 2D drawings, 
and increase the use of 3D as the master representation for driving from design to 
manufacturing engineering process.

Annotations in 3D Functional Tolerancing & Annotation can be extracted, using the 
annotation plane concept in the Generative Drafting product. 

The product elements can be reviewed using specific functionalities, which constitute 
comprehensive tools for the interpretation of tolerancing annotations. 

This manual is intended for users who need to specify tolerancing annotations on 3D parts or 
on 3D products. It assists designers in assigning the correct tolerances on the selected 
surfaces by:

●     Selecting the surfaces to be toleranced.

●     Choosing among the available options, the tolerance types, the modifiers, etc. The 
system offers a choice of options which are consistent with the selected surfaces.

●     Entering the tolerance value. The tolerance annotation is then created and 
displayed around the 3D geometry. It is also located and oriented in an annotation 
plane, using a standardized model (usual standards: ISO, ASME / ANSI).

As a consequence, designers do not need to wonder whether the tolerancing syntax is 
correct, because this syntax is directly elaborated with regard to the chosen tolerancing 
standards (ISO, ASME / ANSI). 

Designers are ensured that their tolerancing schema is consistent with the part geometry. 
They do not need to be tolerancing experts, having in mind all the complex standardized 
tolerancing rules. Moreover, the tolerancing specifications will remain consistent whatever 
the geometrical modifications are. 

See Reference Information for further detail.

Note that 3 workbenches are available depending on whether you are working on a part 
(Functional Tolerancing and Annotation workbench), a product (Product Functional 
Tolerancing and Annotation workbench) or a process (Process Tolerancing and Annotation 
workbench). This guide is intended for users of all 3 workbenches, as the functionalities 
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available are exactly the same from one workbench to another. However, note that the 
scenarios provided in this guide use parts (CATPart documents) as examples.  

Using this Guide
Where to Find More Information

Conventions
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Using this Guide

Using this Guide
 

This guide is intended for the user who needs to become quickly familiar with the Functional 
Tolerancing and Annotation, Product Functional Tolerancing and Annotation and Process 
Tolerancing and Annotation workbenches.

Note that the functionalities available are exactly the same from one workbench to another, 
even though the scenarios provided in this guide use parts (CATPart documents) as 
examples.  

Before reading this guide, the user should be familiar with basic Version 5 concepts such as 
document windows, standard and view toolbars. 

To get the most out of this guide, we suggest you start reading and performing the step-by-
step tutorial Getting Started. Once you have finished, you should move on to the next 
sections, where you will find detailed explanations regarding the handling of the product. 
You can also take a look at the Workbench Description section describing the workbench. 

To perform the scenarios, you will use sample documents contained in the C:\Program Files
\Dassault Systemes\Bxxdoc\English\online\fdtug\samples folder (where xx in Bxxdoc stands 
for the current release number). For more information on accessing sample documents, 
refer to Accessing Sample Documents in the Infrastructure User's Guide.

[ Up ] [ Next ]
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Where to Find More Information

Where to Find More Information
Prior to reading this book, we recommend that you read Infrastructure User's Guide.

Part Design User's Guide as well as Generative Drafting User's Guide may prove useful too.
Certain conventions are used in V5 documentation to help you recognize and understand 
important concepts and specifications.

[ Back ] [ Up ] [ Next ]
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Conventions

Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you 
recognize and understand important concepts and specifications. The following text 
conventions may be used:
  The titles of CATIA documents appear in this manner throughout the text.
  File -> New identifies the commands to be used.

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button, whenever you read

Select (menus, commands, geometry in graphics area, ...)
Click (icons, dialog box buttons, tabs, selection of a location in the 
document window, ...)
Double-click
Shift-click
Ctrl-click
Check (check boxes)
Drag
Drag and drop (icons onto objects, objects onto objects)

Drag
Move

Right-click (to select contextual menu)

Graphic conventions are denoted as follows:
indicates the estimated time to accomplish a task.

indicates a target of a task.

indicates the prerequisites.

indicates the scenario of a task.

indicates tips

indicates a warning.

indicates information.
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indicates basic concepts.

indicates methodological information.

indicates reference information.

indicates information regarding settings, customization, etc.

indicates the end of a task.

indicates functionalities that are new or enhanced with this Release.
Enhancements can also be identified by a blue-colored background in the left-
hand margin or on the text itself.

indicates functionalities that are P1-specific.

indicates functionalities that are P2-specific.

indicates functionalities that are P3-specific.

allows you to switch back the full-window viewing mode.

 
These icons in the table of contents correspond to the entries or mode.

"Site Map".

"Split View" mode.

"What's New".

"Preface".

"Getting Started".

"Basic Tasks".

"User Tasks" or the "Advanced Tasks".

"Workbench Description".

"Customizing".

"Reference".
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"Methodology".

"Glossary".

"Index".
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What's New

What's New?

New Functionalities

Managing view/annotation plane associativity
You can now make views associative to the geometry so that any modification applied 
to the geometry or to the axis system will be reflected in the view definition.

Aligned section view and section cut support
You can now define aligned section views and section cuts ready for 2D extraction.

Offset section view and section cut support
You can now define offset section views and section cuts ready for 2D extraction.

Thread dimensioning and tolerancing
You can now tolerance thread features.

Coordinate dimensions
You can now create coordinate dimensions based on the coordinates of selected points.

Stacked dimensions
You can now create stacked dimensions by selecting several geometrical elements.

Cumulated dimensions
You can now create cumulated dimensions by selecting several geometrical elements.

Curvilinear length dimensions
You can now create and manage curvilinear length dimensions in 3D. A curvilinear 
length dimension measures the overall length of a curve.

Isolated annotations
You can now create and manage isolated annotations, i.e. annotations that are not 
linked to any geometry. Isolated annotations are non-semantic.

Enhanced Functionalities

Query, filter and search using Part Design feature or Generative Shape Design feature
You can now query, filter and search for 3D annotations by selecting any Part Design 
or Generative Shape Design feature in the specification tree. 
For more information on using search, refer to the Infrastructure User's Guide.

Creating annotations by selecting Part Design feature or Generative Shape Design feature
You can now select the geometry on which a 3D annotation has to be created by 
selecting any Part Design or Generative Shape Design feature in the specification tree. 
All 3D annotations support this capability:
- Texts
- Flag notes
- Datum
- Datum targets
- Geometrical tolerances
- Roughness symbols
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What's New

- Note Object Attributes
Generative Dimension enhancements

The Generative Dimension command now supports Part Design chamfer features, 
thread features and threaded hole dimensions.

New text frame
A new text frame is now available: parallelogram.

Customizing Settings

Section cut and section view associativity to 3D geometry
A new setting now lets you create views that will be associative to the geometry 
selected during their creation. In this case, any modification applied to the geometry 
or to the axis system will be reflected in the view definition.

View/Annotation Plane Display settings moved to a new tab
View/Annotation Plane Display settings have been moved from the Display tab to the 
new View/Annotation Plane tab.

Annotations in specification tree
A new setting now lets you specify where 3D annotation features should be displayed 
in the specification tree: under the annotation set node (as is the case today), under 
the Part Design and Generative Shape Design feature nodes, or under the view 
(annotation plane) node.

Annotation parameters in specification tree
A new setting now lets you specify that you want to display the annotation 
parameters under the annotation feature node. In this case, the annotation will be 
modifiable by directly editing its parameters.
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Getting Started

 

Before we discuss the detailed instructions for using the Functional Tolerancing & 
Annotations or the Product Functional Tolerancing & Annotations workbench, the 
following scenario aims at giving you a feel for what you can do.
You just need to follow the instructions as you progress.

 The Getting Started section is composed of the following tasks:

 

Entering the 3D Functional Tolerancing & Annotation Workbench
Choosing the Standard

Creating Annotation Texts
Creating Simple Datum
Creating Datum Targets

Creating a Geometrical Tolerance
Filtering Annotations

Disabling 3D Annotations
Accessing the Set Properties

This scenario should take about 15 minutes to complete. 

 Eventually, the toleranced part will look like this:
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Entering the 3D Functional Tolerancing & Annotation Workbench

Entering the 3D Functional Tolerancing & 
Annotation Workbench

This task shows you how to enter the workbench and open the document you need for 
performing this tutorial.

1.  Select the Start -> Mechanical Design -> Functional Tolerancing & Annotation 
command to launch the workbench.

The 3D Functional Tolerancing & Annotation workbench is opened.
The commands are available in the toolbar to the right of the application window. 

2.  Open the Tolerancing_Annotations_01 CATPart document.

This is what you get:

To know how to use the commands available in the Standard and View toolbars 
located in the application window border, please refer to Infrastructure User's Guide 
Version 5.
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Entering the 3D Functional Tolerancing & Annotation Workbench

[ Up ] [ Next ]
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Choosing the Standard

Choosing the Standard

This task shows you how to set the standard you need for tolerancing your part.

You must choose a standard before creating the first annotation in a document. See 
also Standards.

1.  Select the Tools -> Options command.
The Options dialog box is displayed

2.  Click Mechanical Design then Functional Tolerancing in the left-hand 
column.
See Tolerancing setting for further detail.

3.  If not still done, set ASME as the standard to be used in the tutorial. 

 

4.  Click OK to validate and close the dialog box.

Note that this choice of standard must be expressed prior to specifying any 
tolerance. After any creation in the workbench, the standard may be modified 
but the corresponding syntax and semantic variation will not be taken into 
consideration.
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Creating Annotation Texts

Creating Annotation Texts

This task shows you how to create two textual annotations related to the 3D 
geometry of the part.

If you wish to improve the highlight of the geometry selection, select the Tools-
>Options... command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Click the face as shown to define the surface and the location for the arrow 
head of the leader line.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtuggs03.htm (1 of 5)10/21/2004 6:16:56 PM



Creating Annotation Texts

2.  Click the Text icon:  

The Text Editor dialog box is now displayed. 

3.  Enter "Surface treatment"  in the dialog box.

4.  Click OK to end the text creation.

The text is displayed in the 3D space in an annotation plane. 
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Creating Annotation Texts

The textual annotation identified as Text.1 is added to the specification tree.
Note also that the application creates a projected view as shown in the tree. 
This view is automatically created when any view have been created yet or 
any existing view cannot be re-use.

 

Any front view created corresponds to an annotation plane (called "Front view 
annotation plane" too in the workbench).
If no annotation plane still exists, one is by default created when specifying 
the first annotation. 

5.  To create another text annotation, select the inner cylindrical face:

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtuggs03.htm (3 of 5)10/21/2004 6:16:56 PM



Creating Annotation Texts

6.  Click the Text icon: 

7.  Enter "Surface 2" in the dialog box and click OK.

You have created a second textual annotation in the same front view.
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Creating Annotation Texts

For more about textual annotations, refer to Specifying textual annotations.
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Creating Simple Datum

Creating Simple Datum

This task shows you how to create a simple datum on a surface.  

Datum elements are involved in geometric tolerancing specifications. For instance, 
when specifying an orientation or a position tolerance, you need to refer to datum 
elements for the specification. 

1.  Select the attachment surface to be specified as datum.

2.  Click the Datum Feature icon:  

The Datum Feature Modification dialog box that appears displays "A" as 
the default identifier. 
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Creating Simple Datum

3.  Click OK to create the datum if the identifier corresponds to your choice.

The datum feature is created in a specific annotation plane. The "Datum" 
entity is added to the specification tree. The datum is a 3D annotation without 
any semantic link to the geometrical tolerancing. 

The display of this datum label corresponds to the ANSI normative reference.

4.  Select the datum and drag it. You can notice that it remains in the annotation 
plane.
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Creating Simple Datum
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Creating Datum Targets

Creating Datum Targets

This task shows you how to create three datum targets.

1.  Select the face as shown.

2.  Click the Datum Target icon:  

3.  In the dialog box that appears, click  the diameter icon.
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Creating Datum Targets

4.  Enter 8 in the field opposite and enter "A1" in the field to the left.

5.  Click OK to validate.

You have created a datum target on datum plane A. The datum target 
corresponds to a 8mm-diameter surface. The name of the target is "A1".

6.  Repeat the previous steps to specify two additional datum targets: A2 and A3.
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Creating Datum Targets
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Creating a Geometrical Tolerance

Creating a Geometrical Tolerance 

This task shows you how to create a geometrical tolerance directly on the 3D 
geometry.
Geometrical tolerances are specifications included in a tolerance frame.

1.  Select the front planar surface as shown:

2.  Click the Geometrical Tolerance icon:  

A message window appears informing you that you cannot use the active 
view. Therefore, the application is going to display the annotation in an 
annotation plane normal to the selected face.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtuggs05.htm (1 of 4)10/21/2004 6:17:17 PM



Creating a Geometrical Tolerance

3.  Click OK to close the message window.

The Geometrical Tolerance dialog box is displayed.

To create a geometrical tolerance you need to specify one geometric 
tolerancing symbol and fill in the tolerance value field.  

When fulfilling the second line "Spec 2...", a second geometrical tolerance will 
be created.
Both tolerancing specifications will be displayed as grouped.

4.  Set the perpendicularity symbol to define the tolerance.

5.  Enter the value of the tolerance: 0.5 and insert the Maximum Material 
Condition symbol modifier

6.  Enter A as reference.
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Creating a Geometrical Tolerance

Modifiers are not displaying in tolerance and reference fields and appear with 
a "|" character.

7.  Click OK.

The geometrical tolerancing annotation is attached to the 3D part. The 
geometrical tolerance entity is added to the specification tree. 

You have specified a perpendicularity of the front planar surface regarding to 
A datum surface. This toleranced surface shall be in 0.5-wide tolerance zone, 
on which an  Maximum Material Condition (MMC) is applied.
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Creating a Geometrical Tolerance
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Filtering Annotations

Filtering Annotations 

This task shows you how to filter the display of annotations. These filtering options lets you focus on 
your area of investigation.

1.  Click the Filter icon:  

The Filter dialog box is displayed.

2.  Set the Filter choice field to "By sub-type".

3.  Set the Simple Datum sub-type.

Checking the Refine filter option filters out tolerances still filtered. 

4.  Click Apply.

The Number of selected tolerances field displays "1". 
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Filtering Annotations

The only datum you created in this tutorial is consequently displayed attached to the 
geometry. 

5.  Click Cancel to cancel the operation and perform the rest of the scenario.

All annotations are visible again.
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Disabling 3D Annotations

Disabling 3D Annotations 

This task shows you how to disable the annotations you created. 

1.  Click the List Annotation Set  Switch On/Switch Off icon:  

The Annotation Set Switch On/Off dialog box is displayed. 

 

2.  Click Part1 then the Disable All button.

3.  Click OK in the dialog box.

The annotations are disabled in the geometry.

The specification tree no longer displays them.
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Disabling 3D Annotations

4.  Click the List Annotation Set  Switch On/Switch Off icon  again to restore the previous state.

5.  Click Part1 then the Enable All button.
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Accessing the Set Properties

Accessing the Set Properties

This task shows you how to access the set properties and edit the set name.

1.  Select Annotation Set.1 in the specification tree.

2.  Right-click and select the Properties contextual command.

3.  Click Tolerancing & Annotations tab.

The dialog box that appears displays information about the set, namely:

 The selected set name: as displayed in the specification tree

 The standard used: ANSI

 The number of specifications: you have created seven specifications.

 The detail of these specifications: you have created two textual 
annotations, three datum targets, one GD&T and one datum.
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Accessing the Set Properties

4.  Click the Feature Properties tab (if not available, click More) and enter a 
new name in the Feature Name field.
For instance, enter New Set.
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Accessing the Set Properties

5.  Click OK to validate and close the dialog box.

The new name is displayed in the specification tree.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtuggs06.htm (3 of 4)10/21/2004 6:17:36 PM



Accessing the Set Properties
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Basic Tasks

Basic Tasks
3D Functional Tolerancing & Annotation allows you to perform the following basic tasks:

Choosing a Standard
Using the Tolerancing Advisor

Tolerancing Body in White
Creating Annotations
Managing Annotations

Managing Annotation Leaders
Managing Graphical Properties

Filtering Annotations
View/Annotation Planes
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Choosing a Standard

Choosing a Standard   

This task shows you how to set the standard you need for tolerancing your part or 
assembly.

You must choose a standard before creating the first annotation in a document. See 
also Standards.

1.  Select the Tools -> Options command.
The Options dialog box is displayed

2.  Click Mechanical Design then Functional Tolerancing in the left-hand 
column.

 The Default standard at creation option provides four conventional 
standards:

 ASME (American Society for Mechanical Engineers)

 ANSI (American National Standards Institute)

 ISO (International Organization for Standardization) 

 JIS (Japanese Industrial Standard) 

 and three CATIA-CADAM standards:

 CCDANSI (CATIA-CADAM American National Standards Institute)

 CCDISO (CATIA-CADAM International Organization for Standardization) 

 CCDJIS (CATIA-CADAM Japanese Industrial Standard) 

 See Tolerancing setting for further detail.

3.  Click OK to validate and close the dialog box.

Note that this choice of standard must be expressed prior to specifying any 
tolerance. After any creation in the workbench, the standard may be modified but 
the corresponding syntax and semantic variation will not be taken into consideration.
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Choosing a Standard

[ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0600.htm (2 of 2)10/21/2004 6:20:42 PM



Using the Tolerancing Advisor

Using the Tolerancing Advisor 

Introducing the Tolerancing Advisor: get started with the Tolerancing Advisor.

 
Dimensioning and Tolerancing Threads using the Tolerancing Advisor: see how the 
Tolerancing Advisor lets you create dimensions and tolerances for threads.
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Introducing the Tolerancing Advisor

Introducing the Tolerancing Advisor  

This task introduces the Tolerancing Advisor.

The Tolerancing Advisor lets you create allowed annotations according to the selected 
geometrical element or existing annotation.

Allowed annotations are:
●     Semantic and non semantic annotations (Text, Roughness, Flag note). See 

Tolerancing Settings.

●     Datum.

●     Datum target.

●     Datum reference frame.

Open the Tolerancing_Annotations_01 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Click the Tolerancing Advisor icon:  

The Semantic Tolerancing Advisor dialog box appears.
This is the minimal appearance for this dialog box because no geometrical 
element or annotation has been selected and no datum reference frame has been 
created yet.
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Introducing the Tolerancing Advisor

2.  Select the surface as shown on the part.

The Semantic Tolerancing Advisor dialog box is updated according to the 
selected surface. 
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Introducing the Tolerancing Advisor

The Commands frame contains all the semantic annotations that will be created 
in relation with the selected element and the geometrical feature type.

 The Commands frame contains a combo list for all capabilities applying for the 
selection. 

3.  Click the Text with Leader icon (One surface):  

4.  Enter Milling in the Text Editor dialog box when it appears.

5.  Click OK in the dialog box.

The annotation text  is created.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0701.htm (3 of 4)10/21/2004 6:20:54 PM



Introducing the Tolerancing Advisor

The Semantic Tolerancing Advisor dialog box is updated. 

The Text with Leader icon is orange-colored: 
This color inform you that an annotation has been created; you can still create 
other annotations.

6.  Click Close in Semantic Tolerancing Advisor dialog box.
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Dimensioning and Tolerancing Threads using the Tolerancing Advisor 

 Dimensioning and Tolerancing Threads using the 
Tolerancing Advisor  

This task shows how to create dimensions and tolerances for threads using the Tolerancing Advisor.

For a general introduction of the Tolerancing Advisor, refer to Introducing the Tolerancing Advisor.

Open the Tolerancing_Annotations_12 CATPart document.

1.  Click the Thread Representation Creation icon:  The Thread Representation 
Creation dialog box is displayed.

2.  Select Thread.1 in the specification tree. 

 

 The Thread Representation Creation dialog box is updated to indicate that the 
thread representation will be created for the selected thread.
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Dimensioning and Tolerancing Threads using the Tolerancing Advisor 

In the case of numerous threads, selecting the All threads option lets you create the 
thread representations of all of them.

3.  Click OK to validate and exit the dialog box. The geometrical representation of the thread is 
displayed in the geometry, and an item is created in the specification tree.

 

 
4.  Click the Tolerancing Advisor icon:  The Semantic Tolerancing Advisor dialog box is 

displayed.

5.  Select the median 3/4 circle arc which symbolizes the thread helical surface. 
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Dimensioning and Tolerancing Threads using the Tolerancing Advisor 

The Semantic Tolerancing Advisor dialog box is updated according to the selected 
element. 

6.  Click the Diameter icon.

 The thread diameter dimension is previewed and the Limit of Size Definition dialog 
box is displayed, offering the following options:
●     Pitch: lets you display the pitch value in the thread dimension.

●     Tol class: lets you define and display the tolerance class value in the thread 
dimension.

7.  Select both the Pitch and the Tol class options.

8.  In the Tol class drop-down list, select 6g as the tolerance class value.
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Dimensioning and Tolerancing Threads using the Tolerancing Advisor 

 

 9.  Click OK to validate. The thread diameter dimension is created.

10.  Back in the Semantic Tolerancing Advisor dialog box, multi-select (using the Ctrl key, for 
example) the 3/4 circle arcs which symbolize the thread starting and ending planes.

Once again, the Semantic Tolerancing Advisor dialog box is updated according to 
the selected elements. 

11.  Click the Distance Creation icon.
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Dimensioning and Tolerancing Threads using the Tolerancing Advisor 

The thread length dimension is previewed and the Limit of Size Definition dialog box 
is displayed, offering the following options:
●     Numerical values: lets you define the Upper Limit and optionally the Lower Limit 

(provided you uncheck the Symetric Lower Limit option). 

●     Tabulated values: lets you define fitting tolerances. Refer to Normative 
References for more information: ISO 286, ANSI B4.2.

●     Single limit: lets you enter a minimum or maximum tolerance value. Use the 
Delta / nominal field to enter a value in relation to the nominal diameter value. For 
example, if the nominal diameter value is 10 and if you enter 1, then the tolerance 
value will be 11.

 12.  Select the Tabulated values option.

 

 13.  Click OK to validate. 

14.  When a dialog box appears, informing you that the annotation will be created on another 
view, click OK. The thread length dimension is created. 

15.  Back in the Semantic Tolerancing Advisor dialog box, select the 3/4 circle arc which 
symbolizes the thread starting plane.
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Dimensioning and Tolerancing Threads using the Tolerancing Advisor 

 

 16.  Click the Semantic Datum icon.

 

 The Datum Definition dialog box is displayed.

17.  Leave the options as is, and click OK to validate. The datum feature is created. 

Note that the 3/4 circle arcs which symbolize the thread starting and ending planes 
are recognized as planar surfaces, which means that you can tolerance them just like 
any other planar surface. At this stage, you create other tolerances (such as flatness 
for example) using the icons available in the Semantic Tolerancing Advisor dialog 
box.

 18.  Click Close in the Semantic Tolerancing Advisor dialog box. The thread dimensions and 
tolerances are displayed in the geometry as well as in the specification tree.
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Dimensioning and Tolerancing Threads using the Tolerancing Advisor 
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Tolerancing Body in White

Tolerancing Body in White
The tasks described in the following scenario are meant to be performed step by step.

Creating Datum and Datum Targets
Creating Dimensions and Associated Datum

Creating a Datum Reference Frame
Tolerancing Body in White Holes

Tolerancing Body in White Surface 
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Creating Datum and Datum Targets

Creating Datum and Datum Targets

This task shows you how to create datum and datum targets on body in white surfaces.

Open the Tolerancing_Annotations_06 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Right-click the Datum scheme capture and select Set Current form the 
contextual menu: all created annotations will be added to this capture as long as 
it is current.

 
2.  Click the Tolerancing Advisor icon:  

The Semantic Tolerancing Advisor dialog box appears.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0801.htm (1 of 8)10/21/2004 6:21:28 PM

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/samples/Tolerancing_Annotations_06.CATPart


Creating Datum and Datum Targets

3.  Select the four surfaces as shown on the part. The last selected surface will 
support the datum.

The Semantic Tolerancing Advisor dialog box appears.
The buttons and options available in the dialog box depend on your selection.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0801.htm (2 of 8)10/21/2004 6:21:28 PM



Creating Datum and Datum Targets

4.  Click the Semantic Datum icon (N surfaces):  

The datum is created.

The Datum Definition dialog box appears.
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Creating Datum and Datum Targets

5.  Click Add in the Datum Definition dialog box.

The Datum Target dialog box appears. Keep the options as is.

 6.  Select the target points as shown on the part.
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Creating Datum and Datum Targets

You do not have to click OK in the Datum Target dialog box, selecting another 
point automatically validates the datum target creation.
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Creating Datum and Datum Targets

7.  Click OK in the last Datum Target dialog box to end the datum target creation.

The Datum Definition dialog box is updated.
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Creating Datum and Datum Targets

8.  Click OK in the Datum Definition dialog box.

The datum and datum targets are created in the geometry and specification tree.
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Creating Datum and Datum Targets

9.  Do not close the Semantic Tolerancing Advisor dialog box to perform the next 
task.
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Creating Dimensions and Associated Datum

Creating Dimensions and Associated Datum

This task shows you how to create dimensions and associated datum on body in white 
surfaces.

Five hole types are available for tolerancing:

 Cylindrical hole.

 Elongated hole.

 Rectangular hole with angular corners.

 Rectangular hole with rounded corners.

 Other hole from previous.

1.  Select the hole edge as shown on the part. 

The Semantic Tolerancing Advisor dialog box is updated.
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Creating Dimensions and Associated Datum

2.  Click the Diameter icon (One surface):  

The Limit of Size Definition dialog box appears. Keep options as is.

3.  Click the OK in the dialog box.

The dimension is created.
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Creating Dimensions and Associated Datum

4.  Click the Semantic Datum icon (One surface):  

The Datum Definition dialog box appears.

5.  Click the OK in the dialog box.

The datum is added to the dimension.
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Creating Dimensions and Associated Datum

6.  Select the two hole edges as shown on the part. 

The Semantic Tolerancing Advisor dialog box is updated.
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Creating Dimensions and Associated Datum

7.  Click the Distance Creation icon (Tab/Slot):  

The Limit of Size Definition dialog box appears. Keep options as is.

8.  A message box appears: click OK.

9.  Click the OK in the dialog box.

The dimension is created.
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Creating Dimensions and Associated Datum

10.  Click the Semantic Datum icon (Tab/Slot):  

The Datum Definition dialog box appears.

11.  Click the OK in the dialog box.

The datum is added to the dimension. 
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Creating Dimensions and Associated Datum

The dimensions and datum are created in the geometry and specification tree.

12.  Do not close the Semantic Tolerancing Advisor dialog box to perform the next 
task.
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Creating a Datum Reference Frame

Creating a Datum Reference Frame  

This task shows you how to create a datum reference frame on body in white 
surfaces.

1.  Click the Add button in the Semantic Tolerancing Advisor dialog box .

The Datum Reference Frame dialog box appears. 

2.  Select the each datum and specify its box as is. 
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Creating a Datum Reference Frame

3.  Click the OK in the dialog box.

The Semantic Tolerancing Advisor dialog box is updated. 

The datum reference frame is created in the specification tree.
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Creating a Datum Reference Frame

4.  Do not close the Semantic Tolerancing Advisor dialog box to perform the 
next task.

[ Back ] [ Up ] [ Next ]
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Tolerancing Body in White Holes

Tolerancing Body in White Holes

This task shows you how to create geometrical tolerances on body in white holes.

1.  Right-click the Datum scheme capture and select Unset Current form the 
contextual menu, right-click the Hole positioning capture and select Set 
Current form the contextual menu.

 2.  Select the datum reference frame in the Semantic Tolerancing Advisor dialog 
box.

3.  Select the whole hole edges as shown on the part. 
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Tolerancing Body in White Holes

The Semantic Tolerancing Advisor dialog box is updated. Note the geometric 
feature type: Elongated Pin/Hole.

4.  Click the Position with DRF Specification icon:  
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Tolerancing Body in White Holes

The Geometrical Tolerance dialog box appears. Keep options as is.

5.  Click the OK in the dialog box.
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Tolerancing Body in White Holes

The geometrical tolerances is created.

The geometrical tolerances is created in the specification tree.

 6.  Select the datum reference frame in the Semantic Tolerancing Advisor dialog 
box.

7.  Select the whole hole edges as shown on the part. 
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Tolerancing Body in White Holes

The Semantic Tolerancing Advisor dialog box is updated. Note the geometric 
feature type: Non cylindrical Pin/Hole.

8.  Click the Position with DRF Specification icon:  

The Geometrical Tolerance dialog box appears. Keep options as is.

9.  Click the OK in the dialog box.

The geometrical tolerance is created.
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Tolerancing Body in White Holes

The geometrical tolerance is created in the specification tree.

10.  Do not close the Semantic Tolerancing Advisor dialog box to perform the next 
task.

 
[ Back ] [ Up ] [ Next ]
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Tolerancing Body in White Surface

Tolerancing Body in White Surface

This task shows you how to create geometrical tolerances on a body in white surface.

1.  Right-click the Hole positioning capture and select Unset Current form the 
contextual menu, right-click the Surface positioning capture and select Set 
Current form the contextual menu.

 2.  Select the datum reference frame in the Semantic Tolerancing Advisor dialog 
box.

3.  Select the surface as shown on the part. 
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Tolerancing Body in White Surface

The Semantic Tolerancing Advisor dialog box is updated. Note the geometric 
feature type: One surface.

4.  Click the Profile of a Surface icon:  
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Tolerancing Body in White Surface

The Geometrical Tolerance dialog box appears.

5.  Set the numerical value to 0.5 mm.

6.  Select the Tolerance Zone tab and check the Shifted Profile Tolerance icon.
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Tolerancing Body in White Surface

7.  Click the OK in the dialog box.

The geometrical tolerance is created.
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Tolerancing Body in White Surface

The geometrical tolerance is created in the specification tree.

 8.  Right-click the Surface positioning capture and select Unset Current form the 
contextual menu.
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Creating Annotations

Creating Annotations 

Creating Texts: click this icon, select a face and enter your text in the dialog box.

Creating Texts: click this icon, select a face and enter your text in the dialog box.

 Creating Texts: click this icon, select a face and enter your text in the dialog box.

 Creating Flag Notes: click this icon, select the object you want to represent the 
hyperlink, enter a name for the hyperlink and the path to the destination file.

Creating Flag Notes: click this icon, select the object you want to represent the 
hyperlink, enter a name for the hyperlink and the path to the destination file.

Add an Attribute Link: display the Manage Hyperlink or Text Editor dialog box, 
enter the text you need, select the annotation in the geometry area, right-click and 
select the Attribute Link contextual command. Select the appropriate geometry to 
access the parameter of interest, and select the parameter you wish to attach in the 
Attribute Link dialog box.

Create Datum Elements: click this icon, select the attachment surface and the 
anchor point of the datum feature, then enter the label in the dialog box .

Create Datum Targets: click this icon, select a face and enter your value and 
symbols in the dialog box.

Create Geometrical Tolerance: click this icon, select the element and define 
characteristics and values for Line 1 and/or Line2.

Create Roughness Symbol: click this icon, select the element and define roughness 
characteristics.

 Creating Isolated Annotations: click an annotation creation icon, and click anywhere 
in the free space.

Create Dimensions: click this icon, select a geometrical element.

Create Basic Dimension: click this icon, select the context.

Create Coordinate Dimensions: click this icon, specify whether you want to create a 
2D or a 3D coordinates dimension, and then select a vertex, a point (on a curve, on 
a plane, a coordinate), a line center or a point on a curve.

Create Stacked Dimensions: click this icon, and select the elements to include within 
the stacked dimensions system.
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Creating Annotations

Create Cumulated Dimensions: click this icon, and select the elements to include 
within the cumulated dimensions system.

Creating Curvilinear Dimensions: click this icon, select a curve or an edge, and 
optionally choose a representation mode (offset, parallel, linear).

Instantiate a Note Object Attribute: click this icon, select a Note Object Attribute, 
select a geometrical element.

 Create a Partial Surface: click this icon, select the restricted surface, select the 
restricting surface.

Create a Deviation: click this icon, select the component, select the point to define 
an annotation. 

Create a Correlated Deviation: click this icon, select the component, select the set of 
point to define a correlated annotation. 

Create a Distance Between Two Points: click this icon, select the parent component, 
select the start and end points to define a distance between two points annotation.

[ Back ] [ Up ] [ Next ]
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Creating Texts

Creating Texts 

This task shows you how to create an annotation text.

Three kinds of text may be created:
●     Text with Leader

●     Text

●     Text parallel to screen

A text is assigned an unlimited width text frame. 
You can set  graphic properties (anchor point, text size and justification) either 
before or after you create the free text.
See Setting Basic Graphical Properties.
You can change any text to another kind at any time.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Activate the Projected View.2 annotation plane. 

2.  Click the Text with Leader icon:  

3.  Select the face as shown to define a location for the arrow end of the leader.
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Creating Texts

This scenario illustrates the creation of a text by selecting geometry, 
but you can also select any Part Design or Generative Shape Design 
feature in the specification tree. In this case, the created annotation will 
not be attached to the selected feature, but to its geometrical elements 
at the highest level.

If the active view is not valid, a message appears informing you that you 
cannot use the active view.
This means that the annotation will be displayed in an annotation plane 
normal to the selected face.
For more information, see View/Annotation Planes.

The Text Editor dialog box appears. 

4.  Enter your text, for example "New Annotation" in the dialog box.
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Creating Texts

5.  Click OK to end the text creation. You can click anywhere in the geometry 
area too.

The text appears in the geometry. 
The text (identified as Text.xxx) is added to the specification tree. 

 The leader is associated with the element you selected. If you move either the 
text or the element, the leader stretches to maintain its association with the 
element. 

 Moreover, if you change the element associated with the leader, application 
keeps the associativity  between the element and the leader. 

 Note that using the Text Properties toolbar, you can define the anchor point, 
text size and justification. 
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Creating Texts

 
6.  Click the Text icon:  

7.  Select the face as shown.

8.  Enter your text, for example "New Annotation 2" in the dialog box and click 
OK.

The text appears in the geometry. 
The text (identified as Text.xxx) is added to the specification tree. 
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Creating Texts

9.  Click the Text Parallel to Screen icon:  

10.  Select the face as shown.
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Creating Texts

11.  Enter your text, for example "New Annotation 3" in the dialog box and click 
OK.

The text appears in the geometry.  
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Creating Texts

See also Setting Annotation Parallel to Screen. 

The texts (identified as Text.xxx and its text between brackets) are added to 
the specification tree in the Notes group.

You can move a text using either the drag capability. See Moving Annotations.
Note also that you can resize the manipulators. 
For more information, refer to Customizing for 3D Functional Tolerancing & 
Annotations.

[ Up ] [ Next ]
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Creating Flag Notes

Creating Flag Notes 

This task shows you how to create an annotation flag note.

A flag note allows you to add links to your document and then use them to jump to a 
variety of locations, for example to a marketing presentation, a text document or a 
HTML page on the intranet.
You can add links to models, products and parts as well as to any constituent 
elements.

Two kinds of flag note may be created:
●     Flag note with Leader

●     Flag note

A flag note is assigned an unlimited width text frame. 
You can set  graphic properties (anchor point, text size and justification) either 
before or after you create the free text.
See Setting Basic Graphical Properties.
You can change any flag note to another kind at any time.
You can specify a hidden text to the flag note.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Activate the Projected View.2 annotation plane. 

 
2.  Click the Flag Note with Leader icon:  
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Creating Flag Notes

3.  Select the face as shown to define a location for the arrow end of the leader.

This scenario illustrates the creation of a flag note by selecting 
geometry, but you can also select any Part Design or Generative Shape 
Design feature in the specification tree. In this case, the created 
annotation will not be attached to the selected feature, but to its 
geometrical elements at the highest level.

If the active view is not valid, a message appears informing you that you 
cannot use the active view.
Therefore, the application is going to display the annotation in an annotation 
plane normal to the selected face.
For more information, see View/Annotation Planes.

The Flag Note Definition dialog box appears.
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Creating Flag Notes

 You may specify the flag note's name link in the Name field.

 You may specify one or several links associated with the flag note in the URL 
field clicking the Browse... button.

 In the Link to File or URL list  you can see the list of links.

 To activate one of them, select it and click the Go to button.

 To remove one of them, select it and click the Remove button.

 To edit one of them, select it and click the Edit button.

 Clicking the More>> button lets you define a hidden text which is displayed 
with the list of links in a tooltip when the mouse pointer stays on the flagnote.

 You can write your text or import it from a text file.

 You can leave the field blank.
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Creating Flag Notes

4.  Define the flag note:

❍     the name: New Annotation

❍     a link: www.3ds.com

❍     a hidden text: Go to the world of 3DS
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Creating Flag Notes

5.  Click OK to end the flag note creation. You can click anywhere in the 
geometry area too.

The flag note appears in the geometry, the tooltip containing the URL and the 
hidden text is displayed when the mouse pointer stays on the flag note.
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Creating Flag Notes

The leader is associated with the element you selected. If you move either the 
text or the element, the leader stretches to maintain its association with the 
element.

 Moreover, if you change the element associated with the leader, the 
associativity  between the element and the leader is kept.

 Note that using the Text Properties toolbar, you can define the anchor point, 
text size and justification.

6.  Click the Flag Note icon:  

7.  Select the face as shown.
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Creating Flag Notes

8.  Enter your flag note name, for example "New Annotation 2" in the dialog box, 
specify a link and click OK.

The flag note appears in the geometry.
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Creating Flag Notes

The flag notes (identified as Flag Note.xxx and its name between brackets) 
are added to the specification tree in the Notes group.

You can move a flag note using the drag capability. See Moving Annotations.
Note also that you can resize the manipulators. For more information, refer to 
Customizing for 3D Functional Tolerancing & Annotations.

[ Back ] [ Up ] [ Next ]
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Adding an Attribute Link

Adding an Attribute Link

This task shows you how to add an attribute link parameter to a text while you are creating 
this annotation.
Note that the operating mode described here is valid for Text or a Flag Note.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category then the Navigation tab and 
check the option Highlight faces and edges.

1.  Double-click the annotation text to edit it.

The Text Editor dialog box appears. 
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Adding an Attribute Link

2.  Take care to un-select the text into the Text Editor dialog box and put the cursor 
after the white space at the end of the text.

3.  Right-click the annotation in the geometry area and select the Attribute Link 
contextual command (the annotation is not highlighted!). 

4.  Select Part 1 in the Specification Tree to access all parameters defined for the part.
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Adding an Attribute Link

The Attribute Link dialog box appears. 

5.  Select Length as the parameter you wish to attach.

6.  Click OK to close the Attribute Link dialog box.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0105.htm (3 of 6)10/21/2004 6:26:14 PM



Adding an Attribute Link

The value "50mm" now appears both in the Text Editor dialog box and in the 
annotation.
You cannot edit this value in this dialog box but you can delete it. 

7.  Click OK to confirm the operation and close the dialog box.

The parameter is attached to the textual annotation. 

8.  Double-click Length to edit the parameter: enter 70 mm in the Edit Parameter 
dialog box which appears and click OK.

If you wish to display the Parameters node, select the Tools->Options... command.
In the Infrastructure category, select the Part Infrastructure sub-category then 
the Display tab and check the option Parameters .
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Adding an Attribute Link

If you wish to display the parameter' value, select the Tools->Options... command.
In the General category, select the Parameters and Measure sub-category then 
the Knowledge tab and check the option With value.

9.  Un-select the annotation.

The new value is displayed in the annotation text. 
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Adding an Attribute Link

8.  If you need to cut the relationship between "70mm" as displayed in the Text.1 and 
Length, right-click the annotation and select the Isolate Text contextual command.
You can then edit "70mm".

Attaching an attribute to a textual annotation is possible when editing this annotation.

[ Back ] [ Up ] [ Next ]
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Creating Datum

Creating Datum 

This task shows you how to specify a datum element.
See Datum Principles for more information.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Activate the Projected View.1 annotation plane.

2.  Click the Datum Element icon:  

3.  Select the attachment surface of the datum feature.

This scenario illustrates the creation of a datum element by selecting 
geometry, but you can also select any Part Design or Generative Shape 
Design feature in the specification tree. In this case, the created 
annotation will not be attached to the selected feature, but to its 
geometrical elements at the highest level.
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Creating Datum

The Datum Feature dialog box displays with D as default identifier. 

4.  Click OK to create the datum if the identifier corresponds to your choice.

The datum feature is created in a specific annotation plane.
The "Datum" entity (identified as Simple Datum.xxx) is added to the 
specification tree.  
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Creating Datum

The datum is only a 3D annotation without any semantic link to the 
geometrical tolerancing.

5.  Select the datum and drag it anywhere. You can notice that it remains in the 
annotation plane.
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Creating Datum

6.  Release the datum.

To edit a datum, double-click the datum, enter the new label in the Datum 
Feature Modification dialog box that is displayed, and click OK. The 
modification is simultaneously taken into account.

 Two datum elements must not have the same label. A datum label must be 
unique to ensure that tolerance specifications are consistent.

[ Back ] [ Up ] [ Next ]
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Creating Geometrical Tolerances 

This task will show you how to create a geometrical tolerance annotation.

Before performing the task, here are a few principles you should be familiar with: 
●     Principles and Fundamental Rules for Geometrical Tolerancing

●     Geometric Tolerancing

●     Symbols for Geometrical Tolerances

●     Symbols for Modifiers

Open the Tolerancing_Annotations_04 CATPart document.

1.  Select the Projected View.2 annotation plane.

2.  Click the Geometrical Tolerance icon:  

3.  Select the face as shown.
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Creating Geometrical Tolerances

This scenario illustrates the creation of a geometrical tolerance by 
selecting geometry, but you can also select any Part Design or 
Generative Shape Design feature in the specification tree. In this case, 
the created annotation will not be attached to the selected feature, but 
to its geometrical elements at the highest level.

The Geometrical Tolerance dialog box appears.
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Creating Geometrical Tolerances

This dialog box allows you to:
●     Specify as many specification lines as you want (with the Up and Down 

arrows).

●     Insert several modifiers anywhere in a tolerance or a reference.

●     Add notes upper and lower the set of specification.

3.  Set the parallelism symbol to define the tolerance.

4.  Enter the value of the tolerance: 0.5 and insert the Least Material 
Condition symbol modifier.

5.  Enter A as reference.

6.  Specify the upper and lower notes.

Modifiers are not displaying in tolerance and reference fields and appear with 
a "|" character.

7.  Click OK to confirm the operation and close the dialog box.

The geometrical tolerancing annotation is attached to the part. 
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Creating Geometrical Tolerances

The geometrical tolerance entity (identified as Geometrical Tolerance.xxx) is 
added to the specification tree in the Geometrical Tolerances group.

[ Back ] [ Up ] [ Next ]
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Creating Roughness Symbols

Creating Roughness Symbols 

This task shows you how to create a roughness symbol annotation.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Select the Projected View.1 annotation plane. 

2.  Click the Roughness icon:  

3.  Select the surface as shown on the part.

This scenario illustrates the creation of a roughness symbol by selecting 
geometry, but you can also select any Part Design or Generative Shape Design 
feature in the specification tree. In this case, the created annotation will not be 
attached to the selected feature, but to its geometrical elements at the highest 
level.
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Creating Roughness Symbols

The Roughness Symbol Editor dialog box appears. 

 

4.  Select Ra symbol and enter a value: 0.8
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Creating Roughness Symbols

5.  Click OK.

The roughness symbol is created without a leader. To add one, see Adding Leaders and 
Using Breakpoints. 

[ Back ] [ Up ] [ Next ]
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Creating Isolated Annotations

 Creating Isolated Annotations

This task shows you how to create isolated annotations, i.e. annotations that are not 
linked to any geometry.

You can create the following types of isolated annotations:
●     Text

●     Text with Leader

●     Text Parallel to Screen

●     Flag Note

●     Flag Note with Leader

●     Datum Element

●     Datum Target

●     Geometrical Tolerance

●     Roughness

●     Note Object Attribute (Instantiated from Catalog Browser)

Open the Tolerancing_Annotations_04 CATPart document.

1.  Activate the Projected View.1 annotation plane.

2.  Click an annotation creation icon, for example the Text icon: 

3.  Click anywhere in the free space (not on the geometry).

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0120.htm (1 of 3)10/21/2004 6:45:37 PM

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/samples/Tolerancing_Annotations_04.CATPart


Creating Isolated Annotations

The Text Editor dialog box is displayed. 

4.  Type your text and then click OK.

 

The text is created in the specified annotation plane. You can now select it 
and drag it anywhere: it will remain in the annotation plane.
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Creating Isolated Annotations

 The note entity, Text.4, is added to the specification tree. A specific 
mask identifies this annotation as being isolated.

 

●     Creating isolated dimensions is not possible.

●     Isolated annotations are not semantic. You cannot convert them to semantic 
annotations. 

●     If you add a leader to an isolated annotation, or if you create an isolated 
annotation with leader (such as a text with leader or a flag note with leader), this 
leader will not be associative.

[ Back ] [ Up ] [ Next ]
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Creating Dimensions

Creating Dimensions 

This task shows you how to create a dimension annotation. See Dimension Units 
reference for dimension's unit display.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Activate the Projected View.2 annotation plane. 

2.  Click the Dimensions icon:  

3.  Select the surface as shown on the part.
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Creating Dimensions

4.  Click anywhere to create it.

The dimension is created. 
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Creating Dimensions

5.  Drag the dimension.

6.  In the Dimension Properties toolbar, select TOL_NUM2 in the Tolerance 
Description combo box, and +-0.5 in the Tolerance combo box (the 
dimension is still selected).

The Dimension Properties toolbar displays five combo boxes:

 ●     Line Type to select the dimension line attachment.

●     Tolerance Description to display the tolerance according to a 
standard.

●     Tolerance to valuate the tolerance dimension.

●     Numerical Display Description to set the numerical tolerance 
display.

●     Precision to set the tolerance precision.
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Creating Dimensions

Tolerances are displayed with the dimension. 

[ Back ] [ Up ] [ Next ]
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Creating Basic Dimensions

Creating Basic Dimensions  

This task shows you how to create basic dimensions. These reference dimensions 
are used to define the location or the size of a geometrical element, from existing or 
new dimensions, and related to a specific context.

This command allows you to create basic dimensions from the four following 
contexts:
●     Restricted areas, where basic dimensions define the restricted area dimensions 

and location.

●     Datum targets, where basic dimensions define the datum target location from 
another datum target or geometrical elements.

●     Datum reference frames, where basic dimensions define the datum reference 
frame location from reference elements or representing constructed geometry.

●     Geometrical tolerances, where basic dimensions define the toleranced element 
location from references in the reference frame.

Open the Tolerancing_Annotations_03 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Double-click the Projected View.3 to activate it. 
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Creating Basic Dimensions

2.  Click the Basic Dimension icon:  

 3.  Select the Restricted Area.1 partial area. 

The Framed Dimensions Management dialog box appears.
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Creating Basic Dimensions

4.  Select dimensions as shown on the part.

The dimension is converted into a basic dimension when clicking.
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Creating Basic Dimensions
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Creating Basic Dimensions

The Framed Dimensions Management dialog box is updated. The validity 
of each converted annotation is checked.

During the conversion, converted annotations remain selected in the 
specification tree, the geometry area and the dialog box.
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Creating Basic Dimensions

 

5.  Click Start creation mode in the Framed Dimensions Management dialog 
box.

6.  Select edges as shown on the part.
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Creating Basic Dimensions

The basic dimension is pre-created.

7.  Click in the free space to create the basic dimension.
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Creating Basic Dimensions

 

8.  Click End creation mode in the Framed Dimensions Management dialog 
box.

9.  Select Basic Dimension.1 in the Framed Dimensions Management dialog 
box, and click Remove.

The basic dimension has been removed.
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Creating Basic Dimensions

10.  Click OK in the Framed Dimensions Management dialog box.

[ Back ] [ Up ] [ Next ]
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Creating Coordinate Dimensions

 Creating Coordinate Dimensions 

This task shows how to create a coordinate dimension based on the coordinates of a 
selected point. See Dimension Units for more information on dimension unit display.

Open the Tolerancing_Annotations_06 CATPart document.

1.  Activate the Projected View.2 annotation plane. 

 

2.  Click the Coordinate Dimensions icon.  

3.  Right-click anywhere to display the contextual menu.

❍     2D Coordinates lets you create 2D (x, y) coordinate dimensions in the 
active view axis system.

❍     3D Coordinates lets you create 3D (x, y, z) coordinate dimensions in the 
part/product axis system.

For the purpose of this scenario, make sure 3D Coordinates is selected.

 

 4.  Select a point as shown below.
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Creating Coordinate Dimensions

 

You can select the following elements: a vertex, a point (on a curve, on 
a plane, a coordinate), a line center or a point on a curve.

 The dimension is created.

5.  Drag the dimension to position it as wanted.
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Creating Coordinate Dimensions

Once a coordinate dimension has been created, you cannot change its type (i.e. you 
cannot turn a 2D coordinate dimension into a 3D coordinate dimension, and vice-
versa).

[ Back ] [ Up ] [ Next ]
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Creating Stacked Dimensions

 Creating Stacked Dimensions 

This task shows how to create stacked dimensions. See Dimension Units for more 
information on dimension unit display.

Open the Tolerancing_Annotations_10 CATPart document.

 Select Tools -> Options. In the Mechanical Design category, select the 
Functional Tolerancing & Annotation sub-category, then the Dimension tab 
and check Align stacked dimension values.

1.  Activate the Projected View.1 annotation plane. 

 

2.  Click the Stacked Dimensions icon.  

3.  Select the first element.
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Creating Stacked Dimensions

 4.  Select the second element.

 

You just created a first dimension within the stacked dimensions 
system. You can then proceed to create as many dimensions as 
necessary.

5.  Select, one after the other, the third, fourth and fifth elements to create three 
additional dimensions within the stacked dimensions system. 

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0117.htm (2 of 4)10/21/2004 6:46:57 PM



Creating Stacked Dimensions

6.  Click in the free space to validate and end the dimension creation. You can 
notice that the stacked dimension values are aligned.
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Creating Stacked Dimensions

You can set the dimension properties in the Dimension Properties toolbar as 
described in Creating Dimensions.

[ Back ] [ Up ] [ Next ]
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 Creating Cumulated Dimensions 

This task shows how to create cumulated dimensions. See Dimension Units for more 
information on dimension unit display.

Open the Tolerancing_Annotations_10 CATPart document.

 Select Tools -> Options. In the Mechanical Design category, select the 
Functional Tolerancing & Annotation sub-category, then the Dimension tab 
and check Align cumulated dimension values and optionally select 
Automatically add a funnel.

1.  Activate the Projected View.1 annotation plane. 

 

2.  Click the Cumulated Dimensions icon.  

3.  Select the first element.
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Creating Cumulated Dimensions

 4.  Select the second element.

 

You just created a first dimension within the cumulated dimensions 
system. You can then proceed to create as many dimensions as 
necessary.

5.  Select, one after the other, the third, fourth and fifth elements to create three 
additional dimensions within the cumulated dimensions system. 
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Creating Cumulated Dimensions

6.  Click in the free space to validate and end the dimension creation. You can 
notice that the cumulated dimension values are aligned.

 

You can set the dimension properties in the Dimension Properties toolbar as 
described in Creating Dimensions.

[ Back ] [ Up ] [ Next ]
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 Creating Curvilinear Dimensions 

This task shows how to create curvilinear dimensions. A curvilinear dimension 
measures the overall length of a curve. See Dimension Units for more information 
on dimension unit display.

Open the Tolerancing_Annotations_11 CATPart document.

1.  Click the Curvilinear Dimensions icon.  

2.  Select a curve or an edge as shown below.

 

With an Electrical Harness Installation license, you can also select 
starting and ending points, planar faces or splines, which lets you 
define the total length of several harness routing curves. For more 
information on how the 3D Tolerancing and Annotations workbench 
integrates to the Electrical Harness product, refer to the Electrical 
Harness Installation User's Guide.
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Creating Curvilinear Dimensions

 The dimension is previewed. By default, the dimension line is linear.

 

 4.  Right-click to display the contextual menu.

5.  Select a representation mode for the dimension line: 

●     Offset displays the dimension line as an offset curve of the 
projection of the measured curve. 

●     Parallel displays the dimension line as a parallel curve of the 
projection of the measured curve.

●     Linear displays the dimension line as a straight line, parallel to the 
direction defined by the limit points of the measured curve.

Select Offset for example. The dimension line is modified accordingly.
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Creating Curvilinear Dimensions

 

 6.  Optionally drag the dimension line and/or the dimension value to position 
them as wanted.
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Creating Curvilinear Dimensions

 7.  Click in the free space to validate and end the dimension creation. The semi-
arc symbol displayed over the dimension value symbolizes a curvilinear length 
dimension. You can now handle the dimension just like any other dimension.
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Creating Curvilinear Dimensions

 

 

More about curvilinear dimensions
●     You can set the dimension properties in the Dimension Properties toolbar as 

described in Creating Dimensions.

●     The curvilinear length symbol is defined in the standards.

●     You cannot measure only part of a curve.

●     In some cases, depending on the curve and on the offset value, the offset 
representation mode cannot be computed (because the dimension line cannot 
intersect with itself along the curve): you will not be able to position the 
dimension further than a certain limit.

●     You cannot change the dimension line representation mode after the dimension 
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Creating Curvilinear Dimensions

has been created.

[ Back ] [ Up ] [ Next ]
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Generating Dimensions

Generating Dimensions 

This task shows you how to generate dimensions automatically.

This command allows you to generate the following dimensions:
●     Some or all hole dimensions from a hole parameters (except if these parameters cannot be 

associated with an existing geometrical element to generate dimensions: diameter of a tapered hole 
out of the part, depth for a blind hole setting a "through hole", etc.)

●     Pad/Pocket length; if two limits are defined, two dimensions will be generated between the sketch 
plane and each limiting face, and sketch constraints.

●     Multi-Pad/Multi-Pocket lengths, and sketch constraints.

●     Shaft/Groove distance constraints that are parallel or perpendicular to the shaft/groove axis 
direction,
distance between shaft/groove axis and point and/or straight line and/or circle (arc or complete) as 
a half dimension diameter if the shaft/groove is not complete (value of the single angle or total of 
the 2 less than 360°), as regular diameter if the shaft/groove is complete, angle, and sketch 
constraints.

●     Part Design Chamfer features; dimensions are generated according to the Part Design chamfer 
feature definition: for a chamfer with a length x length definition, the dimension format will be 
distance x distance, whereas for a chamfer with a length x angle definition, the dimension format 
will be distance x angle dimension. However, you should be aware of the fact that if tolerances are 
applied to chamfer parameters, only the tolerance applied to the first parameter will be generated. 
Chamfer dimensions cannot be edited, but they can be modified via the Dimension Properties 
toolbar and the Edit Properties command.

●     Part Design Thread features; thread diameter, depth and pitch parameter dimensions can be 
generated. Dimension generation automatically generates a thread symbolic representation. Note 
that:
- any tolerance attached to the pitch or diameter parameter will not be generated. 
- generating a pitch parameter dimension requires the generation of the corresponding thread 
diameter parameter dimension.
- if the thread is not a metric one, the prefix will be a diameter symbol instead of the letter M.

 Remember that:
●     Dimensions are associated with the design of a part, including the Mean Dimension behavior.

●     When parameter tolerances are still defined, they are set to the dimension tolerances.

●     Modifying dimension tolerances modifies the parameter tolerances and vice-versa.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category then the Navigation tab and check the 
option Highlight faces and edges.
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Generating Dimensions

1.  Activate the Projected View.2 annotation plane. 

2.  Click the Generative Dimension icon:  

The Generate 3D Tolerancing Dimensions dialog box appears.

3.  Select the hole as shown on the part.
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Generating Dimensions

The hole parameter is displayed  in the dialog box.

Also, the hole parameter is shown on the part.
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Generating Dimensions

4.  Select the Diameter parameter in the dialog box. You can also select the parameter on the 
geometry.

5.  Click OK in the dialog box.

The diameter dimension is created.
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Generating Dimensions

6.  Drag the dimension. 

7.  Right-click the dimension and select Edit Generative Parameter from the contextual menu. 
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Generating Dimensions

The Parameter Definition dialog box appears.
This dialog box allows you to modify the hole parameter and edit the part.

7.  Set the value to 41mm and click OK. 

The part turns red because it has been modified but not updated.
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Generating Dimensions

8.  Click the Update icon:    

The part's hole and diameter dimension are modified.

9.  Right-click the dimension and select Edit Generative Parameter from the contextual menu 
again. 

10.  Right-click in the value field and select the Add Tolerance... from contextual menu. 
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Generating Dimensions

The Tolerance dialog box appears.
This dialog box allows you to modify the hole parameter tolerances.

11.  Set the tolerances to 0.5 and -0.5 

Tolerances are displayed on the dimension.

12.  Click OK in the Tolerance and Parameter Definition dialog boxes.
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Generating Dimensions

13.  Modify the tolerances in the Dimension Properties toolbar to +-0.25.

Tolerances are updated on the dimension.

The parameter's tolerances are also updated.

[ Back ] [ Up ] [ Next ]
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Instantiating a Note Object Attribute

Instantiating a Note Object Attribute

This task will show you how to instantiate a Note Object Attribute (NOA) annotation 
and modify its comments and hyperlinks.
See Creating Note Object Attribute task and Note Object Attribute concept.

Open the Tolerancing_Annotations_01 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Click the Display with Browser icon:  

The Catalog Browser dialog box appears. 

2.  Click the Open File icon and select for the Component catalog document.
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Instantiating a Note Object Attribute

3.  Double-click the Note Object Attribute component family item.

4.  Double-click the Note Object Attribute Using 2D Component component 
item.

5.  Select the surface as shown on the part.

This scenario illustrates the instantiation of a note object attribute by 
selecting geometry, but you can also select any Part Design or 
Generative Shape Design feature in the specification tree. In this case, 
the created annotation will not be attached to the selected feature, but 
to its geometrical elements at the highest level.
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Instantiating a Note Object Attribute

The Note Object Attribute Instance dialog box appears. The hidden text 
specified with the note object attribute is not modifiable. To unlock it, see 
Creating from a 2D Component; in this case, the dialog box is enabled.

 

6.  Click OK.
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Instantiating a Note Object Attribute

The Note Object Attribute is instantiated.
To customize its graphic properties see Managing Graphical Properties. 

7.  Double-click the Note Object Attribute Using Text component item in the 
Catalog Browser dialog box.

8.  Select the surface as shown on the part.
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Instantiating a Note Object Attribute

The Note Object Attribute Instance dialog box appears. The hidden text 
specified with the note object attribute is modifiable. To lock it, see Creating 
from a Text; in this case, the dialog box is disabled.

9.  Click OK.

The Note Object Attribute is instantiated. 
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Instantiating a Note Object Attribute

7.  Double-click the Note Object Attribute.2.

The Note Object Attribute Edition dialog box appears. 

8.  Enter the following text to modify the hidden text: This is the first instance 
of this Note Object Attribute
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Instantiating a Note Object Attribute

9.  Click Create/Define hyperlinks.

The Manage Hyperlink dialog box appears.

10.  Add the following link: http://www.3ds.com

11.  Click OK in the Manage Hyperlink dialog box.

12.  Click OK in the Note Object Attribute Instance dialog box.
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Instantiating a Note Object Attribute

[ Back ] [ Up ] [ Next ]
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Creating a Partial Surface

Creating a Partial Surface 

This task shows you how to create a partial surface annotation.

A partial surface annotation allows user to define a delimited surface to be 
toleranced.
The surface may be defined using Generative Shape Design workbench.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Click the Partial Surface icon:  

The Partial Surface dialog box appears.

2.  Select the restricted surface as shown on the part.
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Creating a Partial Surface

3.  Select the restricting surface as shown on the part.
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Creating a Partial Surface

4.  Click  OK in  the Partial Surface dialog box .

The Restricted Area.1 is created.

[ Back ] [ Up ] [ Next ]
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Creating a Deviation

Creating a Deviation   

This task will show you how to create a deviation annotation on a part or product. 
This annotation is used in the Tolerance Analysis of Deformable Assembly 
workbench.

●     A deviation annotation represents a specified or measured point according to a 
statistics law.

●     The deviation annotation of an assembly component is contained in its annotation 
set:
❍     For a leaf assembly component, deviation annotations represent the input 

annotations or initial annotations.

❍     For a parent assembly component, deviation annotations represent the output 
annotations or annotations to be verified.

●     A deviation annotation is always associated with a datum reference frame.

●     This datum reference frame must be:
❍     isostatic at least.

❍     associated with the assembly component where the deviation is created.

Open the Tolerancing_Annotations_09.CATPart document.

1.  Click the Deviation icon  in the Deviations toolbar.

The Deviation Definition dialog box appears. You can notice that the 
Component field is automatically filled with the part name.
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Creating a Deviation

In a CATProduct document, you will need to select the assembly component.

2.  Select the deviation's datum reference frame, in this case Datum Reference 
Frame.3.

3.  Select a point or a vertex. For the purpose of this scenario, select Point.3.
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Creating a Deviation

 4.  Set Z as the normal direction.

 

5.  Click the Statistic Law tab to select and define the desired law.
Six laws and their parameters are available: Normal, Uniform, Constant, 
Pearson, Poisson and Snedecor. For more information, refer to Statistic Laws.

6.  Click the Analysis tab to select and define the desired analysis.
Two analyses are available:

❍     Local: the deviation annotations are taken into account where they are 
defined only

❍     Global: the deviation annotations are interpolated on the part or the 
product.

7.  Click OK. The deviation annotation is created.
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Creating a Deviation
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Creating a Correlated Deviation

Creating a Correlated Deviation   

This task will show you how to create a correlated deviation annotation on an 
assembly component. This annotation is used in the Tolerance Analysis of 
Deformable Assembly workbench.

A correlated deviation annotation may be created on an assembly component.
A correlated deviation annotation represents specified or measured points according 
to a statistics law.
The correlated deviation annotation of an assembly component is contained in its 
annotation set.

 For a leaf assembly component or a support, correlated deviation annotations 
represent the input annotations or initial annotations.

 For a parent assembly component, correlated deviation annotations represent 
the output annotations or annotations to be verified.

A correlated deviation annotation is already associated with a datum reference 
frame.

This datum reference frame must:

Be isostatic at least.

Be associated with the assembly component where the deviation is created.

Clicking the Generate Points command in the Deviation Definition dialog box to 
generate default annotation points. These points are typical points where the 
component is the more flexible.

Open the document.

1.  Click the Correlated Deviation icon:  

2.  Select the assembly component.

In a CATPart document the Component field is automatically updated with 
the part number.

The Correlated Deviation Definition dialog box appears.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0114.htm (1 of 2)10/21/2004 6:49:23 PM



Creating a Correlated Deviation

In the Statistic Law tab you can select a measurement file to define the 
correlated deviation law.
When no measures file in the Statistics Law field is specified, each point of 
the correlated deviation is created according to a normal law with a mean of 
1mm and a standard deviation of 0.1mm.

In the Analysis tab you can select and define the desired analysis.
Two analyses are available:

Local, the deviation annotations are take into account where they are 
defined only.

Global, the deviation annotations are interpolated on the part or the 
product.

3.  Select the correlated deviation's datum reference frame.

4.  Click OK to create the correlated deviation annotation.
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Creating a Distance Between Two Points

Creating a Distance Between Two Points   

This task will show you how to create a distance between two points annotation 
between two points of an assembly component or two assembly components. This 
annotation is used in the Tolerance Analysis of Deformable Assembly workbench.

Distance between two points annotation represents a distance to be checked 
between two points.
The distance between two points annotation of an assembly component is contained 
in the component's annotation set.
Distance between two points annotation represent the an output annotation or an 
annotation to be verified.

 A distance between two points annotation is already associated with a positioning 
system or a datum reference frame.

This datum reference frame must:

Be isostatic at least.

Be associated with the assembly component where the deviation is created.

Open the document.

1.  Click the Distance Between Two Points icon:  

2.  Select the assembly component.

The Distance Between Two Points dialog box appears.
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Creating a Distance Between Two Points

In the Statistic Law tab you can select and define the desired law.
Six laws and their parameters are available: Normal, Uniform, Constant, 
Pearson, Poisson and Snedecor. See Statistic Laws.

3.  Select the distance between two points' datum reference frame.

4.  Select the start point.

5.  Select the end point.

6.  Click OK to create the distance between two points annotation.

 
[ Back ] [ Up ]

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0115.htm (2 of 2)10/21/2004 6:49:38 PM



Managing Annotations

Managing Annotations
 

Select Annotation/Annotation Plane: select annotations according of an annotation 
plane or annotation planes of a set of annotations.

 Display Annotation in the Normal View: click this icon and select an annotation.

Move a Textual Annotation: select the annotation and drag it to the desired location, 
or edit the entry fields from the Orientation and Position toolbar.

Transfer Existing Annotations: select the annotation, right-click to select the Transfer 
to View/Annotation Plane contextual command and select a new annotation plane.

Transfer Annotations During Creation: select the annotation, right-click to select the 
Transfer to View/Annotation Plane contextual menu item and select a new 
annotation plane.

Group Annotations: click the annotation icon you need for creating a new annotation, 
select the annotation to which you want to attach the new annotation and confirm 
the creation.

 Grouping Annotations Automatically: select a set of annotation and click this icon.

 Grouping and Ordering Annotations: click this icon, select the reference annotation, 
select the reference to be grouped.

 
Make the Position of a Text Associative: right-click the slave text and select the 
Annotation Links -> Create Positional Link contextual menu item, then select the 
master text.

Make the Orientation of a Text Associative: right-click the slave text and select the 
Annotation Links -> Create Orientation Link contextual menu item, then select the 
master text.

Mirror Annotations: click this icon, the reversed annotations are mirrored.

Clip Annotations Plane: click this icon, the part is clipped by the annotation plane.

 Mark Non-semantic Annotations: select or not the option.

Set Annotation Parallel to Screen: select an annotation and activate this option.

 
Replace a Datum Reference Frame: select a reference frame annotation and select a 
new datum.

Use 3D Grid: click this icon and select an annotation.
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Managing Annotations
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Selecting Annotation/Annotation Plane

Selecting Annotation/Annotation Plane

This task shows you how to select the annotations of an annotation plane and the 
annotation plane of an annotation.

Open the Tolerancing_Annotations_05 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Right-click the Projection View.1 annotation plane and select Select 
Annotations from the contextual menu.

 All the annotations of the Projection View.1 annotation plane are selected in 
the geometry and the specification tree.
The selected annotation plane is not activated and you can select several 
annotation planes to perform the command.
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Selecting Annotation/Annotation Plane
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Selecting Annotation/Annotation Plane

2.  Right-click the Text.1 annotation and select Select Views/Annotation 
Plane from the contextual menu.

 The annotation plane of the Text.1 annotation is selected in the geometry 
and the specification tree.
The selected annotation plane is not activated and you can select several 
annotations from different annotation planes to perform the command.
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Selecting Annotation/Annotation Plane
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Selecting Annotation/Annotation Plane
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Displaying Annotation in the Normal View

Displaying Annotation in the Normal View

This task shows you how to display an annotation plane in the normal view.
The operating mode described here applies to annotation plane, annotation and any 
planar element too.

Open the Tolerancing_Annotations_05 CATPart document.

1.  Select the Projection View.2 annotation plane.

2.  Select the Normal View icon:  

The annotation plane is displayed in the normal view. 
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Displaying Annotation in the Normal View
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Moving Annotations

Moving Annotations 

This task shows you two ways of moving a text annotation: by drag and drop, then 
by using coordinates. The operating mode described here applies to datum 
elements, datum targets and geometrical tolerances.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Select the annotation text.
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Moving Annotations

2.  Drag it to the desired location.
Note that you can stretch or reduce the frame too.

3.  Move it using coordinates: enter the value of your choice in the X, Y field 
from the Orientation and Position toolbar, then enter another value to 
define the rotation A field.
You can set the increment of your choice to define the rotation angle.
For more information, refer to Customizing for 3D Functional Tolerancing & 
Annotations.

This is what you can obtain. 
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Moving Annotations
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Transferring Existing Annotations

Transferring Existing Annotations 

This task first  shows you how to transfer an existing textual annotation from one 
view to another.
The operating mode described here applies to datum elements, datum targets and 
geometrical tolerances too.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Select the text (or its leader line).

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0206.htm (1 of 3)10/21/2004 6:51:10 PM

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/samples/Tolerancing_Annotations_04.CATPart


Transferring Existing Annotations

2.  Right-click to select the Transfer to View/Annotation Plane contextual 
menu. 

3.  Select Projected View.2 in the tree or in the geometry. You can perform the 
operation on non-active views only.

The textual annotation is transferred to the new view. 
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Transferring Annotations During Creation

Transferring Annotations During Creation 

This task first  shows you how to transfer the annotation you are creating to another 
view.
The operating mode described here applies to datum elements, datum targets and 
geometrical tolerances too.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Select the Projected View.2 annotation plane. 

2.  Select the face as shown to define a location for the arrow end of the leader.
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Transferring Annotations During Creation

3.  Click the Text with Leader icon:  

4.  Enter your text, for example "New Annotation" in the Text Editor dialog box 
and click OK.

5.  Select the Projected View.3 annotation plane to which you want to transfer 
"New Annotation".
This annotation plane (or view) must be an existing one.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0209.htm (2 of 3)10/21/2004 6:51:31 PM



Transferring Annotations During Creation

The annotation is transferred. 
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Grouping Annotations During Creation

Grouping Annotations During Creation 

This task shows you how to group an annotation you are creating to an existing 
annotation.
Groups of annotations can gather as many annotations as you wish.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Click the Text with Leader icon:  

2.  Select "Surface Treatment" as the annotation to which you want to attach the 
annotation you are going to specify.

3.  Enter the text "Grouped Text" in the Text Editor dialog box and click OK.
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Grouping Annotations During Creation

The two annotation text are grouped. 

If you need to edit the group properties, multi-select the annotations and use 
the Properties contextual command.
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Grouping Annotations Automatically

Grouping Annotations Automatically  

This task shows you how to group automatically annotations.

You can select as many annotations as you want.
Selected annotations must associated with the same geometrical elements.
According to the standard annotations are grouped with an specific order. 

Open the Tolerancing_Annotations_04 CATPart document.

1.  Select Surface Treatment as the first annotation to be grouped.

2.  Multi-select Surface as the second annotation to be grouped.
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Grouping Annotations Automatically

3.  Click the Automatic Grouping icon:  

Annotations are grouped. 
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Grouping and Ordering Annotations

Grouping and Ordering Annotations  

This task shows you how to group manually and order annotations.

You must select one by one annotations to be grouped.
Reference and selected annotations must be associated with the same geometrical 
elements.
According to the standard annotations are grouped with an specific order.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Click the Manual Grouping icon:  

2.  Select Surface Treatment (Text.1) as the reference annotation.

3.  Select Surface (Text.2) as the slave annotation to be grouped.
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Grouping and Ordering Annotations

The Positioning dialog box appears. Text.1 is the active reference 
annotation.

 There are six settings:

 Align Bottom the selected annotation according to the reference.

 Align Top the selected annotation according to the reference.

 Align Right the selected annotation according to the reference.

 Align Left the selected annotation according to the reference.

 Center Horizontally the selected annotation according to the 
reference.
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Grouping and Ordering Annotations

 Set the Offset between the selected annotation and the reference.

Annotations are grouped according to the dialog box settings: Align Bottom 
and 0mm O.
Text.1 reference annotation is orange framed. 

4.  Click the Align Top icon in the Positioning dialog box. 

Surface (Text.2) is aligned to the top of Surface Treatment (Text.1).
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Grouping and Ordering Annotations

5.  Set the Offset to 5mm in the Positioning dialog box. 

Surface (Text.2) is aligned to the top of Surface Treatment (Text.1).
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Grouping and Ordering Annotations

6.  Select Other Surface (Text.3) as the new slave annotation.

Text.2 the previous slave annotation becomes the new active reference 
annotation in the Positioning dialog box.
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Grouping and Ordering Annotations

Text.2 reference annotation is orange framed. Text.3 annotation is the 
grouped annotation.
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Making the Position of a Text Associative

Making the Position of a Text Associative 

This task shows you how to set a positional link between a text and another element.
This allows you to move several annotations in only one interaction.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Right-click the slave text (text itself, frame or leader) and select the Annotation 
Links -> Create Positional Link contextual menu. 

2.  Select the master text (text itself, frame or leader). 
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Making the Position of a Text Associative

An information popup appears to warn you that the slave text is now at the 
master elevation.  

Master and slaves texts must belong to the same active view and associated 
geometrical element. 

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0207.htm (2 of 5)10/21/2004 6:54:12 PM



Making the Position of a Text Associative

3.  Move the master text: both texts are moving and their distance remains the 
same.

4.  Now, if you move the slave text you selected, only this annotation is moved.
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Making the Position of a Text Associative

To delete the associativity, right-click the slave text and select the Annotation 
Links -> Delete Positional Link contextual menu. 

5.  Right-click the slave text and select the Annotation Links -> Query Object 
Links contextual menu. 
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Making the Position of a Text Associative

The Query Object Panel dialog box appears.

It show that a positional link has been created between this annotation and 
Text.2 annotation.
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Making the Orientation of a Text Associative

Making the Orientation of a Text Associative 

This task shows you how to set a orientation link between a text and another 
element.
This allows you to rotate several annotations in only one interaction.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Right-click the slave text (text itself, frame or leader) and select the 
Annotation Links -> Create Orientation Link contextual menu. 

2.  Select the master text (text itself, frame or leader). 
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Making the Orientation of a Text Associative

An information popup appears to warn you that the slave text is now at the 
master elevation.

Master and slaves texts must belong to the same active view and associated 
geometrical element. 
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Making the Orientation of a Text Associative

3.  Select the Free rotation icon:  

4.  Rotate the master text: both texts are rotating with the same angle.
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Making the Orientation of a Text Associative

5.  Now, if you rotate the slave text you selected, this annotation is not rotated.

To delete the associativity, right-click the slave text and select the 
Annotation Links -> Delete Orientation Link contextual menu. 
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Making the Orientation of a Text Associative
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Mirroring Annotations

Mirroring Annotations 

This task shows you how to mirror reversed annotation relative to the screen view.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Turn the part to show annotations reversed.

2.  Click the Mirror Annotations icon  

All reversed annotations are mirrored.
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Mirroring Annotations
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Clipping Annotations Plane

Clipping Annotations Plane 

This task shows you how to clip a part according to the annotation plane in relation 
to its normal.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Activate the Projected View.2 annotation plane. 

2.  Click the Clipping Plane icon  

The part is clipped according to the annotation plane in relation to its normal. 
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Clipping Annotations Plane
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Marking Non-semantic Annotations

Marking Non-semantic Annotations

This task shows you how to mark non-semantic annotations with a wavy red line in 
the specification tree and geometry.
It allows you to graphically distinguish non-semantic annotations (datum, datum 
targets, geometric tolerances, dimensions) from semantic one, see Concepts.

Open the Tolerancing_Annotations_03 CATPart document.

The specification tree looks like this:

The geometry looks like this:
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Marking Non-semantic Annotations

1.  Check the Mark non-semantic annotation option. See Display setting.

The Geometrical Tolerance.1 annotation is a non-semantic annotation and 
so it is marked in the specification tree and the geometry: 
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Marking Non-semantic Annotations
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Setting Annotation Parallel to Screen

Setting Annotation Parallel to Screen

This task shows you how to set an annotation text parallel to screen.
The operating mode described here applies to text, flagnote and note object 
attribute too.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Right-click the annotation text and select Properties from the contextual 
menu, and click the Display tab. 
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Setting Annotation Parallel to Screen

2.  Check Parallel to Screen option. 

3.  Click the OK. 

The text is now parallel to the screen. 
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Setting Annotation Parallel to Screen

4.  Move and rotate the part.. 

The text is always parallel to the screen and its size is constant for any point 
of view or zoom value. 
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Setting Annotation Parallel to Screen

[ Back ] [ Up ] [ Next ]
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Replacing a Datum Reference Frame

Replacing a Datum Reference Frame

This task shows you how to replace a datum reference frame in an annotation.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Right-click the annotation and select the Replace Datum Reference Frame 
contextual command.  

2.  Select the Datum Reference Frame.2 (B) in the specification tree.
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Replacing a Datum Reference Frame

The datum reference frame is replaced. 

[ Back ] [ Up ] [ Next ]
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Using 3D Grid

Using 3D Grid   

This task shows you how to use the 3D grid to position the annotations of an 
annotation view.
See Display settings to customize the grid.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Select the annotation.

2.  Click the Display 3D Grid icon:  

The 3D grid appears. 
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Using 3D Grid

3.  Drag anywhere the annotation.
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Using 3D Grid

While the Snap to Point icon is deactivated , the annotation may be 
moved without any connection to the grid.

4.  Click the Snap to Point icon:  

5.  Drag anywhere the annotation.

The annotation snaps to each point of the grid according to its anchor point. 
See Text Properties Toolbar. 

You may temporarily reverse the Snap to Point status pressing the Shift key.

[ Back ] [ Up ]
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Managing Annotation Leaders

Managing Annotation Leaders

 Adding Leaders and Using Breakpoint

 Editing the Shape of an End Manipulator

 Moving the End Manipulator of a Leader

 Adding the All Around Symbol

 Setting Perpendicular a Leader

 Adding an Interruption Leader
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Adding Leaders and Using Breakpoints

Adding Leaders and Using Breakpoints 

This task shows you how to add: 

 A leader to an annotation.

 A breakpoint on the created leader.

 A leader from the created breakpoint.

You can add a leader to geometrical elements associated with the annotation only.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation 
tab and check the option Highlight faces and edges.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Right-click the annotation text and select Add Leader from the contextual 
menu. 
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Adding Leaders and Using Breakpoints

2.  Click the face as shown to begin the leader (arrow end).

Then new leader appears. 
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Adding Leaders and Using Breakpoints

3.  If needed, position the leader at the desired location by dragging it.

4.  To add a breakpoint, select the manipulator at the extremity of the arrow 
end and select the Add a Breakpoint from the contextual command.
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Adding Leaders and Using Breakpoints

The breakpoint appears as yellow diamond. You can select it and drag the 
leader. 
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Adding Leaders and Using Breakpoints

5.  To add a leader from the breakpoint, select the breakpoint and select the 
Add an Extremity contextual command. 

This command is only available for text and flag note annotations. 
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Adding Leaders and Using Breakpoints

6.  Click the face as shown to begin the leader (arrow end).

The leader appears. 

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0901.htm (6 of 7)10/21/2004 7:03:38 PM



Adding Leaders and Using Breakpoints

[ Up ] [ Next ]
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Editing the Shape of an End Manipulator

Editing the Shape of an End Manipulator

This task shows you how to edit the shape of an end manipulator of an annotation.

You can edit the shape of end manipulators only.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation 
tab and check the option Highlight faces and edges.

1.  Click the annotation text.
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Editing the Shape of an End Manipulator

2.  Right-click the end manipulator and select Symbol Shape from the 
contextual menu.
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Editing the Shape of an End Manipulator

3.  For instance, select the Crossed Circle shape and un-select the annotation.

 You obtain this result. 

[ Back ] [ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0902.htm (3 of 3)10/21/2004 7:03:54 PM



Moving the End Manipulator of a Leader

Moving the End Manipulator of a Leader

This task shows you how to move the end manipulator of a leader.

You can move a end manipulator of a leader on geometrical elements associated 
with the annotation only, a yellow line plots the route on them where the end 
manipulator is moveable.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation 
tab and check the option Highlight faces and edges.

1.  Click the annotation text.
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Moving the End Manipulator of a Leader

2.  Select the end manipulator to be moved.

3.  Drag the end manipulator along the yellow line.
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Moving the End Manipulator of a Leader

4.  Release the end manipulator.

 You obtain this result. 
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Moving the End Manipulator of a Leader
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Adding the All Around Symbol

Adding the All Around Symbol

This task shows you how to add the All Around symbol to an annotation.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation 
tab and check the option Highlight faces and edges.

1.  Click the annotation text.
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Adding the All Around Symbol

 2.  Right-click any manipulator and check All Around from the contextual menu.

3.  Un-select the annotation.

 You obtain this result. 
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Adding the All Around Symbol
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Setting Perpendicular a Leader

Setting Perpendicular a Leader

This task shows you how to set perpendicular an annotation leader to its associated 
geometrical element.

You can set the leader perpendicularity during the creation using the Leader 
associativity to the geometry option.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation 
tab and check the option Highlight faces and edges.

1.  Click the annotation text.
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Setting Perpendicular a Leader

 2.  Right-click the end manipulator and select Switch to perpendicular leader 
from the contextual menu.

 You obtain this result. 
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Setting Perpendicular a Leader

3.  Drag the annotation.

 The annotation leader still perpendicular to any associated geometrical 
element with the annotation. 
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Setting Perpendicular a Leader

 4.  To cancel this behavior, right-click the end manipulator and select Switch to 
orientation free leader from the contextual menu.

 The annotation leader orientation is free again.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0905.htm (4 of 5)10/21/2004 7:04:58 PM



Setting Perpendicular a Leader
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Adding an Interruption Leader

Adding an Interruption Leader

This task shows you how to add an interruption leader.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Click the annotation text.
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Adding an Interruption Leader

 2.  Right-click the end manipulator and select Add an Interruption from the 
contextual menu.

 3.  Indicate the start point of the interruption on the leader.
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Adding an Interruption Leader

 4.  Indicate the end point of the interruption on the leader.

 The interruption is created.
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Adding an Interruption Leader

 

To remove the interruption, right-click the end manipulator and select 
Remove Interruptions from the contextual menu.
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Managing Graphical Properties

Managing Graphical Properties

Set Basic Graphical Properties: select the annotation then the desired options from 
the Text Properties toolbar.

Set Advanced Graphical Properties: select the annotation, the Edit-> Properties 
command and enter the parameters of your choice to edit the font and the text.

Set Graphical Properties as Default: select the annotation and right-click to select the 
Set as Default contextual command

Copy Graphical Properties: multi-select the textual annotations which graphic 
properties are to be modified, click this icon, and select the text to be used as the 
graphic reference.
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http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0400.htm10/21/2004 7:05:18 PM



Setting Basic Graphical Properties

Setting Basic Graphical Properties 

This task shows you how to set graphical properties from the Text Properties toolbar for a textual 
annotation.
Note that the operating mode described here is also valid for datum, datum targets and geometrical 
tolerances.

Open the Tolerancing_Annotations_04 CATPart document.

 Set the Application Default Properties or User Default Properties option in the Style toolbar if needed.

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category, then the Navigation tab, and check the option 
Highlight faces and edges.

1.  Select the annotation text.

2.  Select the Bold and Italic options from the Text Properties toolbar.
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Setting Basic Graphical Properties

The text is modified accordingly. 

3.  De-select the text.

The Bold and Italic options are de-selected too.

4.  Set the Font Size to 7 mm from the Text Properties toolbar.

5.  Create a new text and enter the following text: Surface (See Creating an Annotation Text).

The text is created accordingly.
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Setting Basic Graphical Properties

Annotation texts inherit from pre-selected options in the Text Properties toolbar when created with 
the Application Default Properties or User Default Properties option selected in the Style toolbar.

[ Up ] [ Next ]
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Setting Advanced Graphical Properties

Setting Advanced Graphical Properties 

This task shows you how to set graphical properties from the Properties dialog box 
for a textual annotation.
Note that the operating mode described here is valid for datum elements, datum 
targets and geometrical tolerances too.

Open the Tolerancing_Annotations_04 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Select the annotation text.
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Setting Advanced Graphical Properties

2.  Right click and select the Properties contextual menu.

3.  Select the Font tab and set the Character Ratio to 50%.

The Font tab is dedicated to several options defining the font.
These options are the same as the ones available from the Text Properties 
toolbar, except for the color you can assign.

4.  Click Apply.

The text is modified accordingly. 
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Setting Advanced Graphical Properties

5.  Select the Text tab and set the Thickness option to 2.00 mm to make the 
leader more visible.

The options available let you edit the position of your text as well as the 
leader properties but not the arrow, see Editing the Shape of an End 
Manipulator.

6.  Click OK.

The text leader is modified accordingly.
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Setting Graphical Properties as Default

Setting Graphical Properties as Default 

This task shows you how to set graphical properties as default properties.
Note that the operating mode described here is also valid for datum, datum targets 
and geometrical tolerances.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Select the text.

2.  Right-click and select the Set as Default contextual option.

The Set as Default command record the graphical properties regardless of 
the selected option in the Style toolbar.
Default graphical properties before the first use of the command are 
application default properties.
See Text Graphical Properties.

3.  Select the Original Properties option in the Style toolbar.
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Setting Graphical Properties as Default

4.  Create a new text and enter the following text: Original + Press Enter + 
Properties
See Creating an Annotation Text.

The text appears in the geometry and takes only the application default 
properties.  

5.  Select the User Default Properties option in the Style toolbar.
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Setting Graphical Properties as Default

6.  Create a new text and enter the following text: User Default + Press Enter + 
Properties

The text appears in the geometry and takes the application default properties 
and the Text: Line Spacing property from the first text. 

7.  Select the Only User Default Properties option in the Style toolbar.
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Setting Graphical Properties as Default

8.  Create a new text and enter the following text: Only User Default + Press 
Enter + Properties

The text appears in the geometry and takes all the application properties from 
the first text: Text: Line Spacing, Font: Color and Style. 

The leader color is never taken into account.
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Setting Graphical Properties as Default

[ Back ] [ Up ] [ Next ]
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Copying Graphical Properties

Copying Graphical Properties 

This task shows you how to copy the graphical properties of a text to other existing 
texts.

Note that the operating mode described here applies to datum, datum targets and 
geometrical tolerances too.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Select the text which graphical properties which are to be modified.

2.  Click the Copy Object Format icon  

3.  Select the text to be used as the graphic reference for the texts you selected.
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Copying Graphical Properties

The graphical properties assigned to the text used as the reference are now 
copied onto the selected text to be modified.
See Text Graphical Properties.

The leader color and anchor point are take into account. 
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Copying Graphical Properties
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Filtering Annotations

Filtering Annotations

 Use Annotation Filter: click the icon and specify the filter options.

 Create an Annotation Capture: click the icon to create the capture.

Display a Capture: right-click a capture and select Display Capture command from 
the contextual menu.

 Create a Camera: click the icon to create the camera.

Manage Capture Options: set capture options.

 Use Capture Management: right-click one or several annotations and select Capture 
Management command from the contextual menu.
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Using Annotation Filters

Using Annotation Filters  

This task shows you how to filter the display of annotations. 

You can filter annotations display though the following features:
●     Views/annotation planes

●     Annotation sets

●     Geometrical elements

●     3D annotations

●     Any Part Design feature

●     Any Generative Shape Design feature

●     Restricted areas

In the case of Part Design or Generative Shape Design features, only the annotations that are 
directly or indirectly applied to the geometrical elements which compose the feature will be 
displayed when applying the filter. In the case of restricted areas, only the annotations that are 
directly or indirectly applied to the geometrical elements which compose the restricting part of the 
restricted area will be displayed when applying the filter.

Open the Tolerancing_Annotations_04 CATPart document.

1.  Click the Filter icon:  

The Filter dialog box is displayed.
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Using Annotation Filters

You can filter the display of annotations in the 3D viewer using the following criteria:
●     All

●     None

●     By type: non semantic

●     By sub-type: text, datum, datum targets, geometrical tolerances 

●     By feature (Part Design or Generative Shape Design feature) or geometrical element

●     By capture

The default filter, All, displays all the geometrical tolerance annotations.

The Results area provides the following information:
●     Number of specified tolerances attached to the 3D model

●     Number of tolerances selected according to the choice indicated in the two previous fields

However, when default tolerances are specified, the number of tolerances displayed attached 
to the model does not correspond to the number of tolerances effectively specified. The 
default tolerance annotation is displayed once and the default tolerance specification is 
applied to several entities. These several specific toleranced entities are considered in the 
count of the Tolerances in the document field.

2.  Set the Filter choice field to "By sub-type".

3.  Set the Simple Datum sub-type. The Number of selected tolerances field displays "2".
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Using Annotation Filters

Checking the Refine filter option filters out tolerances still filtered.  

4.  Click Apply. Only simple datum are displayed.

5.  Click Cancel to cancel the operation. All annotations are visible again.

[ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugbt0301.htm (3 of 3)10/21/2004 7:08:07 PM



Creating a Tolerancing Capture

Creating a Tolerancing Capture  

This task shows you how to create a tolerancing capture. 

The purpose of capture features is to provide in 3D the views/sheets of 2D drawings 
flexibility for annotation display organization. It allows you to organize the display of 
3D annotations the way you want.
You can, for instance, create capture for:

 Functional part area.

 Specifications answering to given functional requirements.

 2D view equivalent.

 2D sheet equivalent.

 etc.

Open the Tolerancing_Annotations_05 CATPart document.

1.  Click the Capture icon:  

The Capture Definition dialog box is displayed.

2.  Click Ok.

The Capture.4 is created and displayed in the specification tree.
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Creating a Tolerancing Capture

You are now in the Tolerancing & Annotation Captures workshop. 

2.  Click the Exit from capture icon:  

You are back in the Functional Tolerancing & Annotations workbench.

To edit a capture, double-click the capture in the specification tree.
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Displaying a Tolerancing Capture

Displaying a Tolerancing Capture 

This task shows you how to display a tolerancing capture.
See Managing Capture Options.

Open the Tolerancing_Annotations_05 CATPart document.

The geometry looks like this. 

The specification tree looks like this. 
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Displaying a Tolerancing Capture

1.  Right-click the All Texts capture and select Display Capture command from 
the contextual menu.

The geometry and specification tree look like this:

 The geometry is zoomed and rotated.

 All annotations are hidden except notes.

 Projection View.1 is hidden.
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Displaying a Tolerancing Capture

2.  Right-click the Angularity capture and select Display Capture form the 
contextual menu.

The geometry and specification tree look like this:

The geometry is moved and rotated.

Annotation planes are hidden.

Only the datum and the geometrical tolerance are shown.
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Managing Tolerancing Capture Options 

This task shows you how to manage tolerancing capture options in existing capture.

Open the Tolerancing_Annotations_05 CATPart document.

1.  Double-click the Initial State capture.

You are now in the Tolerancing & Annotation Captures workshop.

The geometry and specification tree are displayed according to the capture 
options.
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Managing Tolerancing Capture Options

2.  Select in the Camera combo box the Camera 3.

A camera is associated with the capture. See Creating a Camera.
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You can re-use cameras created in the document with another workbench.

3.  Click the Clipping Plane icon  

A clipping plane is associated with the capture.
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Managing Tolerancing Capture Options

4.  Click the Active View State icon  , to associate the current annotation 
plane with the capture.

5.  Click the Current State icon   and exit the workshop.

Now, all the new annotations or annotation planes are associated with this 
capture while it is activated.

This option is also available by right-clicking a capture in the Functional  
Tolerancing & Annotation workbench and selecting Set Current or Unset 
Current commands from the contextual menu.
You can associate annotations and/or an annotation plane to one or several 
captures without edit them.
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Creating a Camera

Creating a Camera

This task shows you how to create a camera in the tolerancing workshop.
This command is available for any workbenches from the View -> Named Views... 
menu.

Open the Tolerancing_Annotations_05 CATPart document.

1.  Move and rotate the part like this.

2.  Select the Named views icon  

3.  Click Add in the Named Views dialog box which appears.

The Camera 5 is created.
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Creating a Camera

4.  Select the * right camera  the Named Views dialog box and click Apply.

The part move and rotate according to the camera. 

5.  Select the Camera 5 camera and click Apply.

The part is moved and rotated according to the created camera.
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Creating a Camera

6.  Click OK.
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Using Capture Management 

This task shows you how to use the Capture Management command.

This command allows you to:

 ●     Associate one or several annotations or annotation planes with one or several captures.

●     Disassociate one or several annotations from one or several captures.

 Annotations may be managed from existing captures in the document or its parent documents.

Open the Tolerancing_Annotations_05 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category then the Navigation tab and check 
the option Highlight faces and edges.

1.  Right-click the All Texts capture and select Display Capture command from the 
contextual menu.

The geometry is displayed according to the capture options.
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Using Capture Management

2.  Create two new texts (See Creating an Annotation Text).

 3.  Select the two new texts, right-click one of them and select Capture Management 
command from the contextual menu.
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Using Capture Management

 The Capture Management dialog box appears.

 

 The Available list displays the list of existing captures in the document and parent 
documents, where you can associate the selected annotations.
The Displayed in list displays the list of captures where ALL the selected annotations are 
still associated with.

4.  Select All Texts in the Available list and click the right-arrow.

5.  Click OK in the Capture Management dialog box.
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 The new texts are now associated with the All Texts capture only. See Displaying a 
Tolerancing Capture.
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View/Annotation Planes

 Use a View/Annotation Plane: view/annotation plane description.

Create a Projection View/Annotation Plane: click this icon and select a planar element.

Create a Section View/Annotation Plane: click this icon and select a planar element.

Create a Section Cut View/Annotation Plane: click this icon and select a planar 
element.

Create an Offset Section Cut/View: click this icon and define or select a cutting 
profile.

Create an Aligned Section Cut/View: click this icon and define or select a cutting 
profile.

Activate a View/Annotation Plane: double-click the desired view/annotation plane.

Edit View/Annotation Plane Properties: right-click the view/annotation plane, and 
select the Properties contextual command.

 
Manage View Associativity: right-click the view/annotation plane, and select the 
Manage associativity contextual command.
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Using a View  

In this section, you will learn about the different types of views. They are of two 
kinds:
●     Views/annotation planes are specified around the geometry for automatically 

generating the corresponding views, sections and cuts of the 2D drawing.

●     Extraction views are particular kinds of views, specifically aimed at preparing 2D 
extraction.

Views/Annotation Planes
 The views/annotation planes are by default displayed in the 3D with a dashed frame 

that is resized to always frame all the annotations that are linked to it.

When the view/annotation plane is active (the preferred view to receive newly 
created annotations), its origin and axis system is also displayed and the dashed 
frame is also resized to frame the axis system origin.

Note that when creating a new view/annotation plane by selecting a planar surface, 
the origin that is chosen is the part/product origin. If you want to choose the origin 
(and the axis orientation) of the view, you have to select an existing axis system 
while creating.

Note also that the position and orientation coordinates of a given annotation that 
are displayed in the Position And Orientation toolbar and in the Position region 
of the Text tab page of the annotation properties are expressed in the view axis 
system.

 You can control the 3D display of the dashed frame of a view by modifying its 
Display View Frame property. See Editing View/Annotation Plane Properties.

 

 You can also control the display of the active axis system by using the option 
Current view axis display. For more information, see 3D Annotations 
Infrastructure settings and/or Functional Tolerancing & Annotation settings in Tools 
-> Options.
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Using a View/Annotation Plane

 Three types of annotations planes are available:
●     Projection View/Annotation Plane

●     Section View/Annotation Plane

●     Section Cut View/Annotation Plane

 
Projection View/Annotation Plane 

A projection view/annotation plane allows you to manage 3D annotations:
●     Located in planes both parallel to this view/annotation plane and in the 

background and foreground spaces bounded by this view/annotation plane (or in 
any plane of the direction of planes defined by this view/annotation plane),

●     Related to the geometry finding an intersection with this view/annotation plane,

●     Lying on/belonging to this view/annotation plane.

This view/annotation plane allows you to specify a particular view/annotation plane 
for generating embedded 2D front/projection views, in the Generative Drafting 
workbench, during the 2D extraction of the 3D part and of the 3D annotations. 

 Annotations can be translated along the z axis of its local coordinate system.
Negative and positive z values can be used to define the translation, since the 
projection view/annotation plane will be used for the extraction of front views in the 
Generative Drafting workbench.

 See Creating a Projection View/Annotation Plane.

 
Section View/Annotation Plane 

A section view/annotation plane allows you to manage 3D annotations:
●     Located in planes both parallel to this view/annotation plane and in the 

background space bounded by this view/annotation plane,

●     Related to the geometry finding an intersection with this view/annotation plane,

●     Lying on/belonging to this view/annotation plane.

This view allows you to specify a particular annotation for generating embedded 2D 
section views, in the Generative Drafting workbench, during the 2D extraction of the 
3D part and of the 3D annotations. 

 Annotations can be translated along the z axis of its local coordinate system.
Only negative z values can be used to define the translation, since the section view/
annotation plane will be used for the extraction of section views in the Generative 
Drafting workbench.

 See Creating a Section View/Annotation Plane.

http://pop.dia.uniroma3.it/catia/online/cfyugfdt_C2/cfyugfdtbt0101.htm (2 of 4)10/21/2004 7:10:55 PM



Using a View/Annotation Plane

 
Section Cut View/Annotation Plane 

A section cut view/annotation plane allows you to manage 3D annotations:
●     Only related to the geometry finding an intersection with this view/annotation 

plane,

●     Related to the geometry finding an intersection with this view/annotation plane.

This view allows you to specify a particular annotation for generating embedded 2D 
section views, in the Generative Drafting workbench, during the 2D extraction of the 
3D part and of the 3D annotations. 

 Annotations cannot be translated along the z axis of its local coordinate system 
(z=0), since the section cut view/annotation plane will be used for the extraction of 
section cuts in the Generative Drafting workbench.

 See Creating a Section Cut View/Annotation Plane.

Extraction Views
Extraction views are particular kinds of views. They specifically aimed at preparing 
the following types of views for 2D extraction:
●     aligned section views/section cuts

●     offset section views/section cuts 

Extraction views are made up of several annotation planes (of the same type). You 
can create annotations in each view/annotation plane making up the extraction 
view. You will then be able to extract this extraction view to 2D in the Generative 
Drafting workbench, as well as all annotations defined in each component section 
view.

Extraction views, no matter their type, use a cutting profile as cutting plane. 

Aligned section views/section cuts

An aligned section view/aligned section cut is created from a cutting profile defined 
from non parallel planes. In order to include in a section certain angled elements, 
the cutting plane may be bent so as to pass through those features. The plane and 
feature are then imagined to be revolved into the original plane.

Aligned section views are made up of several section views/annotation planes, as 
described in Section View/Annotation Plane above. 

Aligned section cuts are made up of several section cut views/annotation planes, as 
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Using a View/Annotation Plane

described in Section Cut View/Annotation Plane above. 

Offset section views/section cuts

Offset section views/offset section cuts let you show several features that do not lie 
in a straight line by offsetting or bending the cutting plane, which is often desirable 
when sectioning through irregular objects.

Offset section views are made up of several section views/annotation planes, as 
described in Section View/Annotation Plane above. 

Offset section cuts are made up of several section cut views/annotation planes, as 
described in Section Cut View/Annotation Plane above. 

[ Up ] [ Next ]
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Creating a Projection View/Annotation Plane   

This task shows you how to create a projection view /annotation plane.
See Using a View for more information.
See also Creating a Section View/Annotation Plane, Creating a Section Cut View/
Annotation Plane.

Open the Common_Tolerancing_Annotations_01 CATPart document.

1.  Click the Projection View icon:  

2.  Select the face as shown.

You have to select a planar element only to perform this command.

The projection view is created.
Projection views are represented by a blue reference axis, its normal axis is 
red until you create an annotation, and are identified as Projection View.3 
in the specification tree. 
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Creating a Projection View/Annotation Plane

3.  Right-click the annotation plane in the geometry or in the specification tree 
and select the Invert Normal contextual menu. 

The projection view normal is reversed. 
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Creating a Section View/Annotation Plane 

This task shows you how to create a section view /annotation plane.
See Using a View for more information.
See also Creating a Projection View/Annotation Plane, Creating a Section Cut View/
Annotation Plane.

Open the Common_Tolerancing_Annotations_01 CATPart document.

1.  Click the Section View icon:  

2.  Select the face as shown.

You have to select a planar element only to perform this command.

The section view is created.
Section views are represented by a green reference axis, its normal axis is 
red until you create an annotation, and are identified as Section View.1 in 
the specification tree.
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Creating a Section Cut View/Annotation Plane 
 

This task shows you how to create a section cut view /annotation plane.
See Using a View for more information.
See also Creating a Projection View/Annotation Plane, Creating a Section View/
Annotation Plane.

Open the Common_Tolerancing_Annotations_01 CATPart document.

1.  Click the Section Cut View icon:  

2.  Select the face as shown.

You have to select a planar element only to perform this command.
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Creating a Section Cut View/Annotation Plane

The section cut view is created.
Section views are represented by a yellow reference axis, its normal axis is 
red until you create an annotation, and are identified as Section Cut View.1 
in the specification tree.
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 Creating an Offset Section View/Section Cut  

This task shows you how to create an offset section view or an offset section cut using a cutting 
profile as cutting plane. Offset section views/section cuts are specifically aimed at preparing views 
for 2D extraction.

See Using a View for more information.

Offset section views/offset section cuts let you show several features that do not lie in a straight 
line by offsetting or bending the cutting plane, which is often desirable when sectioning through 
irregular objects.

Open the Common_Tolerancing_Annotations_03 CATPart document.

1.  Click the Offset Section View/Section Cut icon:   The Section View Creation dialog box 
is displayed.

2.  Specify the type of view that you want to create: Section View or Section Cut. For the 
purpose of this scenario, select Section Cut.

3.  Select the profile that will be used as cutting plane. You can only select a sketch which is 
valid for the type of view to be created.

Note that, at this stage, you can also click the sketch icon  to sketch a new profile 
to use as cutting plane. 
For more information on using this method, you can refer to Creating an Aligned 
Section View/Section Cut: the procedure is similar when creating offset section views/
section cuts.
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Creating an Offset Section View/Section Cut

 The offset section cut is previewed: it is made up of two distinct section cut views/
annotation planes.

 4.  Click the Invert Normal button to invert the normal of the offset section cut: this actually 
inverts the normal of the two section cut views/annotation planes that make up the offset 
section cut.
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 5.  Click OK in the Section View Creation dialog box. 

 

 The offset section cut is now created and listed in the specification tree; it cannot be 
activated. Each section cut/annotation plane that make it up can be activated and 
behaves like a regular section cut/annotation plane. Each section cut is associative to 
the sketched line that defines it.
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Creating an Offset Section View/Section Cut

 

 You can now start creating annotations in each section cut of the offset section cut. If 
you then extract the view to 2D in the Generative Drafting workbench, all the 
annotations defined in each component view will be generated.

 6.  Optionally, right-click Offset Section Cut.1 in the specification tree and select Invert Normal 
in the contextual menu if you want to invert the normal of the offset section cut: this actually 
inverts the normal of all the section cuts/annotation planes that make up the offset section 
cut.

You cannot perform the following operations for the component section views/section cuts of an 
offset section view/section cut: Delete, Invert Normal and Manage Associativity.
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 Creating an Aligned Section View/Section Cut  

This task shows you how to create an aligned section view or an aligned section cut using a cutting 
profile as cutting planes. Aligned section views/section cuts are specifically aimed at preparing 
views for 2D extraction.

See Using a View for more information.

An aligned section view/aligned section cut is created from a cutting profile defined from non 
parallel planes. 

Open the Common_Tolerancing_Annotations_03 CATPart document.

1.  Click the Aligned Section View/Section Cut icon:   The Section View Creation 
dialog box is displayed.

2.  Specify the type of view that you want to create: Section View or Section Cut. For the 
purpose of this scenario, select Section View.

3.  Click the sketch icon  to sketch a new profile that will be used as cutting plane. 

Note that, at this stage, you can also select an existing sketch, if one is available; in 
this case, you can only select a sketch which is valid for the type of view to be 
created. For more information on using this method, you can refer to Creating an 
Offset Section View/Section Cut: the procedure is similar when creating aligned 
section views/section cuts.

 4.  Select a planar surface.
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Creating an Aligned Section View/Section Cut

 The application switches to the Sketcher workbench to let you sketch the cutting 
profile.

 
5.  Click the Profile icon: 

6.  Sketch your cutting profile as shown here.
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You can constrain the sketch lines in order to ensure their position according to some 
features of the part.

 
7.  When you are done, click the Exit workbench icon  to exit the Sketcher workbench. The 

newly created sketch, Sketch.16, is now selected in the Profile field of the Section View 
Creation dialog box.

 

 Clicking the Invert Normal button lets you invert the normal of the aligned section 
view: this actually inverts the normal of the section views/annotation planes that 
make up the aligned section view.
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 8.  Click OK. The aligned section view is now created and listed in the specification tree; it 
cannot be activated. It is made up of three distinct section views/annotation planes, each of 
which can be activated and behaves like a regular section view/annotation plane. Each view 
is associative to the sketched line that defines it.

 

 You can now start creating annotations in each section view of the aligned section 
view. If you then extract the aligned section view to 2D in the Generative Drafting 
workbench, all the annotations defined in each component view will be generated.

 9.  Optionally, right-click Aligned Section View.1 in the specification tree and select Invert 
Normal in the contextual menu if you want to invert the normal of the aligned section view: 
this actually inverts the normal of all the section views/annotation planes that make up the 
aligned section view.

●     The Invert Normal contextual command is only available if there is no annotation attached to 
any component view of the aligned section view/section cut.

●     You cannot perform the following operations for the component sections views/section cuts of an 
aligned section view/section cut: Delete, Invert Normal and Manage Associativity.
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Activating a View/Annotation Plane

Activating a View/Annotation Plane 

When a tolerancing set includes several annotation planes, to activate a plane, you 
either double-click it or use the Activate View contextual command. 

Open the Common_Tolerancing_Annotations_01 CATPart document.

The active annotation plane is orange-colored in the specification tree.

The active annotation plane frame is orange-colored in the geometry and its 
reference axis appears.

1.  Double-click the Projection View.1 annotation plane. 
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Activating a View/Annotation Plane

The Projection View.1 is orange-colored in the specification tree. 

The Projection View.2 frame is orange-colored in the geometry and its 
reference axis appears.
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Editing View/Annotation Plane Properties

Editing View/Annotation Plane Properties 

This task shows you how to rename an annotation plane and hide its frame.

Open the Common_Tolerancing_Annotations_01 CATPart document.

1.  Right-click the Projection View.1 annotation plane and select the 
Properties contextual command. 

2.  Select the View tab in the Properties dialog box which is displayed.

To rename the annotation plane, enter the new name in the Prefix field.

Check/uncheck the Display view frame option to show/hide the view/
annotation plane frame.

 

3.  Click OK to confirm and close the dialog box.
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 Managing View/Annotation Plane Associativity 

This task shows you how to manage view/annotation plane associativity, by changing the 
definition plane of a view. 

When views are associative to the geometry, any modification applied to the geometry or to the 
axis system is reflected in the view definition. 

Open the Common_Tolerancing_Annotations_02 CATPart document.

1.  Right-click the Section View.1 annotation plane, and select the Manage associativity 
contextual command.  The Manage View Associativity dialog box is displayed, indicating 
that the view is currently associative to User Surface.1.

 

 2.  You have two possibilities:

❍     If you want to disassociate the view from the geometry, uncheck the Set view 
associative to geometry field. In this case, you will then be able to modify the 
geometry or the axis system without changing the view definition. 

❍     If you want to associate the view to another geometry, select a planar face or an axis 
system. 

For the purpose of this scenario, select the face as shown below to associate the view to 
another geometry.
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Managing View/Annotation Plane Associativity

 

 The Manage View Associativity dialog box is updated, indicating that the view will 
now be associative to User Surface.2.

 

 3.  Click OK. The Section View.1 annotation plane is now associative to the specified surface. 
If you move the view definition plane or modify the axis system, the view will be re-
defined accordingly.
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Managing View/Annotation Plane Associativity

Limitation

When extracted to 2D (using the View from 3D command in the Generative Drafting 
workbench), views from 3D are currently not associative to the geometry of the 3D view. So, if 
you modify the geometry of a 3D view, the definition of the corresponding 2D view will not be 
modified at the next update, even if the 3D view is associative to the geometry. This limitation 
should be fixed in an upcoming release.

[ Back ] [ Up ]
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Advanced Tasks

Advanced Tasks
3D Functional Tolerancing & Annotation allows you to perform the following advanced tasks:

Creating Note Object Attribute
Managing Annotation Connection

Re-specifying Geometry Canonicity
Reporting Annotations

Annotation Associativity
Managing Power Copies

Providing Constructed Geometry for 3D Annotations
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Creating Note Object Attribute

Creating Note Object Attribute 
 

 Note Object Attributes (NOA) lets you create a customized annotation from a text or 
a 2D component.

When extracting a Note Object Attribute to 2D, frames are not generated.

 Note Object Attribute From a Text: click this icon, select a geometry then enter a 
text.

 Note Object Attribute From a Ditto: click this icon, select a geometry then select a 
2D component from a catalog.

 Store a Note Object Attribute into a Catalog: create a new catalog, select the Note 
Object Attribute.

[ Up ] [ Next ]
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Note Object Attribute From a Text

Note Object Attribute From a Text  

This task shows you how to create a Note Object Attribute from a text.
See Instantiating a Note Object Attribute task and Note Object Attribute concept.

Open the Tolerancing_Annotations_01 CATPart document.

Check the option allowing you to create a Note Object Attribute.
See Tolerancing setting.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Click the Note Object Attribute icon:  

2.  Select the surface as shown on the part.

This scenario illustrates the creation of a note object attribute by 
selecting geometry, but you can also select any Part Design or 
Generative Shape Design feature in the specification tree. In this case, 
the created annotation will not be attached to the selected feature, but 
to its geometrical elements at the highest level.
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Note Object Attribute From a Text

The Note Object Attribute Reference dialog box appears.
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Note Object Attribute From a Text

3.  Select Text in Graphical representation and enter the following texts:

●     The type of the Note Object Attribute: Note Object Annotation 
from a Text

●     The text: 3D Annotation

●     A hidden text: This is a Note Object Annotation made from a 
text
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Note Object Attribute From a Text

The Comments and URLs editable on instances check button allows user 
to modify the Hidden Text data during Note Object Attribute instantiation or 
modification.

4.  Click Create/Define hyperlinks.

The Manage Hyperlink dialog box appears.
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Note Object Attribute From a Text

You can add one or several links to a Note Object Attribute to describe it for 
example.

5.  Enter the following link: http://www.3ds.com

6.  Click OK in the Manage Hyperlink dialog box.

The link has been added to the Note Object Attribute and you can retrieve this 
dialog box and the comments by double-clicking the annotation in the 
geometry or in the specification tree, in the Note Object Attribute Edition 
dialog box.

7.  Click OK in the Note Object Attribute Reference dialog box.

The Note Object Attribute is created. 
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Note Object Attribute From a Text

8.  Double-click the annotation in the geometry or in the specification tree.

The Note Object Attribute Instance dialog box appears.
You can edit the link added to the Note Object Attribute and the comments. 

9.  Click Cancel.
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Note Object Attribute From a Text

[ Up ] [ Next ]
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Note Object Attribute From a Ditto

Note Object Attribute From a Ditto  

This task shows you how to create a Note Object Attribute from a ditto (a 2D 
component in a drawing).
See Instantiating a Note Object Attribute task and Note Object Attribute concept.

 Two behaviors of Note Object Attribute created from a 2D component are available 
from the Stick Ditto perpendicularly to geometry option in the Note Object 
Attribute Reference dialog box.

 ●     Unchecked, the 2D component is instantiated with a frame and a leader.

 ●     Checked, the 2D component is instantiated without frame or leader and its 
origin point is stuck and set on the selected geometry. Its normal is defined 
by the V axis of the 2D component.

When the Note Object Attribute orientation is modified, text contained in the 2D 
component follows or not according to the text orientation reference.

 To modify the orientation reference properties, right-click the text and select the 
Properties... command.
In the Text tab, select the Reference in the Orientation category: Sheet or 
View/2D Component

 ●     With the Sheet option, the text does not follow the Note Object Attribute 
orientation.

 ●     With the View/2D Component option, the text follows the Note Object 
Attribute orientation.

Open the Tolerancing_Annotations_01 CATPart document.

Check the option allowing you to create a Note Object Attribute.
See Tolerancing setting.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.
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Note Object Attribute From a Ditto

1.  Click the Note Object Attribute icon:  

2.  Select the surface as shown on the part.

The Note Object Attribute Reference dialog box appears.
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Note Object Attribute From a Ditto

3.  Select Ditto in Graphical representation and enter the following texts:

 The type of the Note Object Attribute: Note Object Annotation from a 2D 
Component

 A hidden text: This is a Note Object Annotation made from a 2D 
component
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Note Object Attribute From a Ditto

The Comments and URLs editable on instances check button allows user 
to modify the Hidden Text data during Note Object Attribute instantiation or 
modification.

4.  Click Choose Ditto / Detail.

The Catalog Browser dialog box appears. 

5.  Browse and select for the Component document.
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Note Object Attribute From a Ditto

6.  Double-click the Ditto component family item.

7.  Select the 2D Component.2 component item.

8.  Click OK in the Catalog Browser dialog box.

9.  Click OK in the Note Object Attribute Reference dialog box .

The Note Object Attribute is created. 
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Note Object Attribute From a Ditto

When a text is created in a 2D component, by default is orientation is 
associated with the sheet. In this case, when the Note Object Attribute 
orientation change the text do not follow the new orientation.
To perform the text association orientation select the text in the 2D context, 
then right-click in the contextual menu Properties. In the Properties dialog 
box, 

 
10.  Click the Note Object Attribute icon: 

11.  Select the surface as shown on the part.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugat0602.htm (6 of 9)10/21/2004 7:16:15 PM



Note Object Attribute From a Ditto

The Note Object Attribute Reference dialog box appears.

12.  Select Ditto in Graphical representation and enter the following texts:

 The type of the Note Object Attribute: Note Object Annotation 

13.  Check the Stick Ditto perpendicularly to geometry option 
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Note Object Attribute From a Ditto

14.  Click Choose Ditto / Detail.

The Catalog Browser dialog box appears. 

15.  Select the 2D Component.1 component item.

16.  Click OK in the Catalog Browser dialog box.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugat0602.htm (8 of 9)10/21/2004 7:16:15 PM



Note Object Attribute From a Ditto

17.  Click OK in the Note Object Attribute Reference dialog box .

The Note Object Attribute is created. 

[ Back ] [ Up ] [ Next ]
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Storing a Note Object Attribute into a Catalog

Storing a Note Object Attribute into a Catalog 
 

This task shows you how to store a Note Object Attribute into a catalog to be re-
instantiated by user in another document.

Open the NoteObjectAttribute CATPart document.

1.  Create a new catalog document: File -> New: CatalogDocument

2.  Check that Chapter.1 is activated in the catalog tree.

3.  Click the Add Family icon: 

The Component Family Definition dialog box appears. 
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Storing a Note Object Attribute into a Catalog

4.  Click OK.

The Component Family Definition is added to the chapter. 

5.  Double-click the Component Family to activate it.

6.  Click the Add Component icon:  

The Description Definition dialog box appears. 
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Storing a Note Object Attribute into a Catalog

7.  Click Select external feature command and select the Note Object 
Attribute from 2D component  from the specification tree or the geometry.

8.  Click OK.

The Note Object Attribute is added to the catalog. 
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Storing a Note Object Attribute into a Catalog

[ Back ] [ Up ]
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Managing Annotation Connection

Managing Annotation Connection
 

 Manage annotation connection offers to create, delete, modify or rename geometrical 
elements or user surfaces of an existing annotation: 

Use the Scope Range: select the Geometry Connection Management command and 
select an annotation.

Add Geometry: select the Geometry Connection Management command and select 
an annotation.

Add Component: select the Geometry Connection Management command and 
select an annotation.

 
[ Back ] [ Up ] [ Next ]
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Using the Scope Range

Using the Scope Range

This task shows you how to use the scope range when using the connection management and check the 
validity of the reconnected annotations according to the selected scope option.

Open the Tolerancing_Annotations_03 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category then the Navigation tab and check the option 
Highlight faces and edges.

1.  Right-click the annotation as shown on the part and select the Associated Geometry -> Geometry 
Connection Management from the contextual menu. 

The Connection Management dialog box appears.
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Using the Scope Range

2.  Check that Unique option is activated in Scope Range.
The geometry connection modification will only affect the selected annotation.

3.  Right-click Geometric Component.1 in the Graph of Geometrical Links as shown and select the 
Reconnect contextual menu. 

4.  Select the surface as shown on the part.
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Using the Scope Range

The Connection Management dialog box displays:

 The selected annotation

 The effect type

 The initial validity of the selected annotation

 The current validity of the selected annotation after the reconnection.

5.  Click the Check Validity command to check the new geometry component validity relative to the 
selected annotation.
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Using the Scope Range

6.  Click OK.

The annotation is now connected to the new surface

The connection of the annotation on the new geometrical element is computed according to its local 
axis, not with the point where you make the selection.

7.  Close the part document, re-open it and redo step 1 to 5 with the Local option in Scope Range.
The geometry connection modification will only affect all the annotation that are directly applied to the 
User Surface.2 feature.

The Connection Management dialog box displays now the selected annotation and all annotations 
related with it.
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Using the Scope Range

The validity status is KO for the Datum Reference Frame.1 and Position surfacic profile.1 
annotations because they will not have any meaning if the modification is applied.

8.  Click OK.

The annotations are now connected on the new surface.

9.  Close the part document, re-open it and redo step 1 to 5 with the Global option in Scope Range.
The geometry connection modification will only affect all the annotation that are directly or indirectly 
applied to the User Surface.1 feature.
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Using the Scope Range

The validity status is KO for the Linear Size.1, Datum Reference Frame.1 and Position surfacic 
profile.1 annotations because they will not have any meaning if the modification is applied.

10.  Click OK.

The annotations are now connected on the new surface and the dimension annotation is turned to 
invalid because it has no more meaning for the new geometry.

[ Up ] [ Next ]
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Adding Geometry

Adding Geometry

This task shows you how to add geometry to the user surface of an annotation.
See 3D Annotations and Annotation Planes concept.

Open the Tolerancing_Annotations_02 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category then the Navigation tab and check the option 
Highlight faces and edges.

1.  Right-click the annotation as shown on the part and select the Associated Geometry ->Geometry 
Connection Management from the contextual menu. 

The Connection Management dialog box appears.
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Adding Geometry

2.  Check that Unique option is activated in Scope Range. 

3.  Right-click User Surface.13 in the Graph of Geometrical Links as shown and select the Add 
Geometry from the contextual menu. 

It will add a new geometric component to the user surface User Surface.13 feature and prompt you to 
select the new geometrical element to be linked to the annotations.

4.  Select the surface as shown on the part.
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Adding Geometry

The Connection Management dialog box displays the new added geometry to the structure: 
Geometric Component.1 

5.  Click the Check Validity command to check the new geometry component validity relative to the 
selected annotation.
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Adding Geometry

6.  Click OK.

The two geometric components are now link to the annotation. 

7.  Right-click the annotation again and select the Geometry Connection Management contextual menu.

8.  Right-click Geometric Component.2 in the Graph of Geometrical Links as shown and select the 
Delete contextual menu.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugat0702.htm (4 of 6)10/21/2004 7:20:14 PM



Adding Geometry

9.  Click the Check Validity 

The Connection Management dialog box displays the updated structure. 

10.  Click OK.

Only one geometric component is now linked to the annotation.
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Adding Geometry

[ Back ] [ Up ] [ Next ]
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Adding Component

 Adding Component

This task shows you how to add a user surface to the group of surfaces of an annotation.
See 3D Annotations and Annotation Planes concept.

Open the Tolerancing_Annotations_02 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category then the Navigation tab and check the option 
Highlight faces and edges.

1.  Right-click the annotation as shown on the part and select the Associated Geometry ->Geometry 
Connection Management from the contextual menu. 

The Connection Management dialog box appears.
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Adding Component

2.  Check that Unique option is activated in Scope Range. 

3.  Right-click Group of Surfaces.8 in the Graph of Geometrical Links as shown and select the Add 
Component contextual menu. 

It will add a new component to the group of surfaces Group of Surfaces.10 feature and prompt you to 
select the new geometrical element to be linked to the annotations.

4.  Select the hole surface as shown on the part.
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Adding Component

The Connection Management dialog box displays the new connected geometry: Geometric 
Component.1 

5.  Click the Check Validity command to check the new geometry component validity relative to the 
selected annotation.
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Adding Component

6.  Select Group of Surfaces.8 in the Graph of Geometrical Links as shown and select Current option 
in Geometry Highlight.

This option shows you the current group of surfaces of the selected annotation after the modification. 
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Adding Component

7.  Select now Initial option in Geometry Highlight.

This option shows you the initial group of surfaces of the selected annotation before the modification. 

Options in Geometry Highlight are always applied to the selection in the Graph of Geometrical 
Links.

8.  Click OK.

The four geometric components are now linked to the annotation. 
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Adding Component

9.  Right-click the annotation again and select the Geometry Connection Management contextual menu.

10.  Right-click Geometric Component.1 in the Graph of Geometrical Links as shown and select the 
Rename contextual menu. 

The Rename dialog box appears.

11.  Enter the new name: Hole Surface and Click OK.

The feature has been renamed.
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Adding Component

12.  Click OK.
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Re-specifying Geometry Canonicity

Re-specifying Geometry Canonicity 

This task shows how to re-define a complex edge into a cylindrical surface and apply 
a size tolerance to the previous redefined geometry.

Re-specifying geometry canonicity offers to re-define user surface or group of 
surface properties to avoid recognition problem when selecting a geometry. You can 
re-define the geometry through an existing annotation only.

Open the Tolerancing_Annotations_07 CATPart document.

1.  Click the Tolerancing Advisor icon:  

2.  Select the complex edge as shown on the part.

 

 The Semantic Tolerancing Advisor dialog box appears. Note that no 
command related to a cylindrical surface is displayed.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugat0300.htm (1 of 6)10/21/2004 7:22:11 PM

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/samples/Tolerancing_Annotations_07.CATPart


Re-specifying Geometry Canonicity

 

3.  Click the Text with Leader icon (One surface):  

4.  Enter Hole in the Text Editor dialog box field when appears.

5.  Click OK in the Text Editor dialog box and Close in the Semantic 
Tolerancing Advisor dialog box.

6.  Right-click the annotation as shown on the part and select the Associated 
Geometry -> Geometry Canonicity Re-specification from the contextual 
menu. 
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Re-specifying Geometry Canonicity

 The Canonicity Redefinition dialog box appears.

 

7.  Select the Redefined by geometry option.
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Re-specifying Geometry Canonicity

8.  Select the line as shown on the part as axis line associated with the cylindrical 
surface definition.

 

 The Canonicity Redefinition dialog box is updated.
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Re-specifying Geometry Canonicity

9.  Select the Feature of Size option, the Size field is now enabled and set its 
value to 20mm (We "know" the cylindrical diameter) and click OK.

 The annotation is now attached to the axis.

 

 
10.  Click the Tolerancing Advisor icon: , the annotation is still selected.

 The Semantic Tolerancing Advisor dialog box displays now command 
related to a cylindrical surface.
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Re-specifying Geometry Canonicity

11.  Click the Diameter icon (One surface):  

12.  Click OK in the Limit of Size Definition dialog box when appears.

 The diameter dimension annotation is created.

 

13.  Click Close in the Semantic Tolerancing Advisor dialog box.
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Reporting Annotations

Reporting Annotations

Generate a Check Report: click this icon to generate the report.

 Customize the Reporting: click this icon and select the desired options.
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Generating a Check Report

Generating a Check Report 

This tasks shows you how to generate a report checking whether tolerancing rules are respected or not. 
These rules depend on the standard you are using. See Tolerancing settings.

Open the Tolerancing_Annotations_02 CATPart document.

1.  Make sure the options Html and Both are activated in the Tolerancing Rule Settings dialog box.
For more information, refer to Customizing the Reporting.

2.  Click the Report icon  

The application generates the report in the browser you usually use and displays it onscreen using 
the options as specified in the Custom Report command.

The file provides you with the path of the CATPart document you are using and the date of 
generation. In our example, all the rules are respected as mentioned by the green symbols and the 
100% success message.

3.  Click any rule name to obtain detailed information

4.  To generate the other type of report, use the Customize Report  command to set the options File 
and Both. 

5.  Click the Report icon 

The application generates the report. 
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Generating a Check Report

Note that you cannot edit tolerancing rules.

[ Up ] [ Next ]
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Customizing the Reporting

Customizing the Reporting 

The data logged in the generated report as well as the report format depend on the 
rule base settings. This task explains how to specify these settings.

Open any document.

1.  Click the Custom Report icon  

The Tolerancing rule's base settings dialog box appears. 

 Output Format option:
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Customizing the Reporting

 Html: to generate the report in html format.

 File: to generate the report in text format.
In this mode, the Description Length and the Show results options 
are activated by default.

 Description Length option:

 Long: to insert the Help message specified at the check creation.

 Short: if you do not need the Help message.

 Visualization type option:

 Passed: to include in the report only information about the features for 
which the checks are valid.

 False: to include in the report only information about the features for 
which the checks are invalid.

 Both: to include in the report information about all the features on 
which a check has been applied.

 Show Results option:

 By Rule: to organize your report data by rule in the file.

 By Object: to organize your report data by object.

 By Rule: State to organize your report data by rule state.

 Others option:

 Traces: to display the steps of the solve process.

 Automatic Complete: to perform an initialization and a solve 
operation on the objects whenever the part is updated.

 Automatic Optimized: to perform a new solve on the last changes.

 Manual Solve: to perform a manual solve.

2.  Click OK to apply the settings to the rule base.

Unless you want to modify the check report characteristics, you don't have to 
re-specify the settings each time you generate a report.
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[ Back ] [ Up ]
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Annotation Associativity

Annotation Associativity
Different types of associativity characterize the 3D Functional Tolerancing and Annotation 
workbench, such as associativity between the 3D part and the navigation tree for example.

Annotation associativity lets you highlight the geometrical element, Part Design feature or 
Generative Shape Design feature that is related to an annotation. You can turn an 
annotation into the default annotation.

 

Query 3D Annotations: activate or deactivate this icon.

Create an Automatic Default Annotation: click this icon, select the annotation.

[ Back ] [ Up ] [ Next ]
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Querying 3D Annotations

Querying 3D Annotations 

This task shows you how to highlight the geometrical element, Part Design feature or Generative Shape 
Design feature that is related to an annotation, and vice-versa. This enables you to know the relationships 
between annotations and geometry.

You can activate/deactivate the highlight via the 3D Annotation Query Switch On/Switch Off icon:  

 This icon is activated by default when opening the workbench for the first time.

Selecting a 3D annotation will highlight:
●     The 3D annotation itself.

●     All the geometric element that are components of the tolerancing feature (user surface or group of user 
surfaces) it is applied to.

●     All the construction geometry attached to the tolerancing feature and all its components.

●     All the framed (basic) dimensions that are related to the specification.

●     All the datum feature annotations that are related to the specification (for semantic geometric tolerance 
only).

Selecting a geometrical element will highlight:
●     The geometrical element itself.

●     All the annotations that are applied (directly or indirectly) to it.

●     All the framed (basic) dimensions that are related to the corresponding specifications.

●     All the datum feature annotations that are related to the specifications (for semantic geometric tolerance 
only).

Selecting a Part Design or Generative Shape Design feature or a restricted area in the specification tree will 
highlight:
●     The feature itself.

●     All the annotations that are applied (directly or indirectly) to all its geometrical components.

●     All the framed (basic) dimensions that are related to the specification.

●     All the framed (basic) dimensions that are related to the corresponding specifications.

●     All the datum feature annotations that are related to the specifications (for semantic geometric tolerance 
only).

Open the Tolerancing_Annotations_02 CATPart document, and make sure that the 3D Annotation Query 
Switch On/Switch Off icon  is activated.

 

 To improve the highlight of the geometry selection, select the Tools->Options... command.
In the General category, select the Display sub-category then the Navigation tab and check the option 
Highlight faces and edges.
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Querying 3D Annotations

1.  Select the annotation as shown:

This location specification is defined on a pattern of holes. Any toleranced hole of the pattern is then 
highlighted.

Any toleranced face hole of the pattern is then highlighted. 
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Querying 3D Annotations

2.  Select the yellow manipulator and start dragging the arrow head.

A yellow temporary trace is displayed. It corresponds to the intersection between the annotation 
plane and the corresponding toleranced elements. This trace defines all the possible positions for the 
arrow head that are semantically correct for the selected tolerancing annotation.

In our example, the toleranced elements are a group of five holes, this is why we obtain five yellow 
traces:
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Querying 3D Annotations

3.  For example, drag and drop the arrow head on another trace to the right. You can obtain this:

4.  Now, select Pad.2 in the specification tree. As you can see, the pad is highlighted in the geometry 
area, as well as all annotations which are applied to it. 

This functionality is demonstrated here using a Part Design feature, but it is also available for 
Generative Shape Design features.
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Querying 3D Annotations

 

You can add the 3D Annotation Query Switch On/Switch Off command to another workbench via 
Tools -> Customize. For more information, refer to the Customizing Toolbars and Workbenches chapter 
in the Infrastructure User's Guide.

[ Up ] [ Next ]
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Creating an Automatic Default Annotation

Creating an Automatic Default Annotation 

This task shows you how to apply an existing annotation to several geometrical 
elements of a part by making it the default annotation.

Open the Tolerancing_Annotations_03 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Select the Insert -> Annotations -> Default Annotation menu.

2.  Select the Position surfacic profile.1 annotation as shown
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Creating an Automatic Default Annotation

The Default Annotation dialog box appears.

3.  Select Automatic in the Default Annotation dialog box, All faces option in 
the combo box and click OK.
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Creating an Automatic Default Annotation

 

The annotation is now applied to all the faces of the part. 
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Creating an Automatic Default Annotation

According to the selected annotation you will find the following option in the combo 
box.

Annotation and Tolerance types Options

Roughness
Non-semantic Geometrical Dimension and Tolerance
Text
Flagnote
Note Object Attribute (NOA)

All faces
Planar faces
Cylindrical faces
Spherical faces
Non-canonical faces
Fillet faces

Profile of a surface with Datum Reference Frame All faces
Planar faces
Cylindrical faces
Spherical faces
Non-canonical faces
Fillet faces

Profile of a surface without Datum Reference Frame All faces
Planar faces
Cylindrical faces
Spherical faces
Non-canonical faces
Fillet faces

Flatness Planar faces
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Creating an Automatic Default Annotation

Generator straightness Cylindrical faces

Cylindricity Cylindrical faces

Circularity Cylindrical faces

Radius size Cylindrical faces
Spherical faces
Fillet faces

Diameter size Cylindrical faces
Spherical faces

[ Back ] [ Up ]
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Managing Power Copies

Managing Power Copies

Create Power Copy: select the Insert ->Advanced Replication Tools -> 
Powercopy Creation command,
select the elements making up the Power Copy from the specification tree,
define a name for the Power Copy and its reference elements then choose an icon for 
identifying it.

 Instantiate Power Copy: select the Insert -> Instantiate From Document... 
command,
select the document or catalog containing the Power Copy ,
complete the Inputs within the dialog box selecting adequate elements in the 
geometric area.

 Save Power Copy into a Catalog: select the Power Copy from the specification tree,
select the Insert -> Advanced Replication Tools -> Save In Catalog... 
command,
enter the catalog name and click Open.

 
[ Back ] [ Up ] [ Next ]
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Creating Power Copy

Creating Power Copy 

This task shows how to create Power Copy elements, to be reused later.

A Power Copy is a set of features (geometric elements, formulas, constraints, annotations 
and so forth) that are grouped in order to be used in a different context, and presenting 
the ability to be completely redefined when pasted.
This Power Copy captures the design intent and know-how of the designer thus enabling 
greater reusability and efficiency.

Open the PowerCopy1.CATPart document.

1.  Select the Insert ->Advanced Replication Tools -> Powercopy Creation 
command.

The Powercopy Definition dialog box appears.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugat0201.htm (1 of 8)10/21/2004 7:25:36 PM

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/samples/PowerCopy1.CATPart


Creating Power Copy

2.  Select the following elements making up the PowerCopy from the specification 
tree. 

The Powercopy Definition dialog box is updated.
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Creating Power Copy

3.  Select the Inputs tab.

4.  Select the Geometric Component.1 input and rename it into Primary Datum 
Feature.
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Creating Power Copy

5.  Repeat the operation with others inputs like this.
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Creating Power Copy

6.  Select the Parameters tab.

7.  Select the Geometric Component.1 parameters and check Publish Name to 
rename it into Primary Datum Label.
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Creating Power Copy

8.  Repeat the operation with the following parameters like this.
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Creating Power Copy

9.  Click OK in the Powercopy Definition dialog box.

The Powercopy.1 is created.
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[ Up ] [ Next ]
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Instantiating Power Copy

Instantiating Power Copy 

This task shows how to instantiate Power Copies once they have been created.
See Creating Power Copy.

Open the Tolerancing_Annotations_01 CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Select the Insert -> Instantiate From Document... command. 

2.  Select select PowerCopy2.CATPart from file selection dialog box.

The Insert Object dialog box appears. Primary Datum Feature is pre-
selected.
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Instantiating Power Copy

3.  Select the surface as shown. 
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Instantiating Power Copy

The Primary Datum Feature is associated with this surface.

The next input Secondary Datum Feature is pre-selected in the Insert 
Object dialog box.
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Instantiating Power Copy

4.  Select the surface as shown. 
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Instantiating Power Copy

The Secondary Datum Feature is associated with this surface.
The next input Tertiary Datum Feature is pre-selected in the Insert Object 
dialog box.

5.  Select the surface as shown. 

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugat0202.htm (5 of 9)10/21/2004 7:25:53 PM



Instantiating Power Copy

The Tertiary Datum Feature is associated with this surface.
The next input Toleranced Feature is pre-selected in the Insert Object 
dialog box.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugat0202.htm (6 of 9)10/21/2004 7:25:53 PM



Instantiating Power Copy

6.  Select the surface as shown. 

The Toleranced Feature is associated with this surface.
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Instantiating Power Copy

7.  Click the Parameters in the Insert Object dialog box. 

The Parameters dialog box appears.

8.  Change parameters as shown. 

9.  Click OK in the Parameters and Insert Object dialog boxes. 
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Instantiating Power Copy

Annotations are created.

[ Back ] [ Up ] [ Next ]
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Saving Power Copy into a Catalog

Saving Power Copy into a Catalog 

This task shows how to store PowerCopy elements into a catalog.

Open the PowerCopy2.CATPart document.

1.  Select the Power Copy.1.

2.  Select the Insert -> Advanced Replication Tools -> Save In Catalog...  
command.

The Catalog save dialog box appears.

3.  Click OK in the Catalog save dialog box. 
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Saving Power Copy into a Catalog

When creating a catalog for the first time, click the ... button to display the 
Open dialog box, and navigate to the location where you wish to create a 
catalog. 

Then simply key in the catalog name and click Open.

If you wish to add a PowerCopy to an existing catalog, simply activate the 
Update an existing catalog option in the Catalog save dialog box.

By default, the Catalog save dialog box recalls the catalog accessed last.

[ Back ] [ Up ]
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Providing Constructed Geometry for 3D Annotations

Providing Constructed Geometry for 3D 
Annotations

 
These functionalities provide the capability to query and manage the constructed 
geometry that is associated to a tolerancing feature (User surface and Group of 
surfaces features).

 

Constructed geometry (such as center point, axis, median plane, gage plane, etc) is 
very often used in order to define the theoretical dimensions of parts or products 
(framed dimensioning).
These constructed elements do represent the tolerancing feature (User surface and 
Group of surfaces features) and are used to define the tolerance zone position of 
geometrical tolerances, the related position of the datums of a datum reference 
frame, the size and position of a partial surface or a datum target.
The capability that is described here allows either managing constructed geometry 
that has been manually created by the user.

 The existing geometry is the represented geometry, the constructed geometry is the 
representing geometry.

Create an Automatic Constructed Geometry: click this icon, select the context.

Manage Constructed Geometry: click this icon, select the represented geometry then 
the representing geometry.
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Creating an Automatic Constructed Geometry

Creating an Automatic Constructed Geometry  

This task shows you how to create an automatic constructed geometry.

Creating an automatic constructed geometry allows you to create associative 
wireframe geometry according to the context or represented geometry. The lifecycle 
of an automatic constructed geometry is managed by the application.

 The following constructed geometry elements are available: 
●     Line

●     Point

●     Plane

●     Cylinder

●     Circle

Open the Tolerancing_Annotations_08.CATPart CATPart document.

 To improve the highlight of the geometry selection, select the Tools->Options... 
command.
In the General category, select the Display sub-category then the Navigation tab 
and check the option Highlight faces and edges.

1.  Click the Constructed Geometry Creation icon:  

 2.  Select the surface as shown.
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Creating an Automatic Constructed Geometry

 

 The Constructed Geometry Creation dialog box appears.

Double-clicking any automatically constructed geometry displays this dialog 
box.
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Creating an Automatic Constructed Geometry

 3.  Check Axis and Plane as geometries to be generated and click OK in the 
dialog box.

 The axis and the plane are created in the geometry. See also Constructed 
Geometry options for graphic properties and limits.
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Creating an Automatic Constructed Geometry

 In the specification tree, an open body dedicated to the constructed geometry 
is added.

 

 
4.  Click the Constructed Geometry Management icon:  

 5.  Select the surface as shown.
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Creating an Automatic Constructed Geometry

 

 The Constructed Geometry Management dialog box appears and displays 
the two created geometries and their creation mode.

 

 6.  Click OK.

[ Up ] [ Next ]
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Managing Constructed Geometry

Managing Constructed Geometry  

This task shows you how to manage constructed geometry.
This functionality allows you to: 

 Create a manual constructed geometry. See also Creating an Automatic 
Constructed Geometry.

 Associate/disassociate an existing geometry as constructed geometry (or 
representing geometry) of a tolerancing feature (User surface and Group of 
surfaces) with another existing geometry as represented geometry.

 You can associate an existing constructed geometry (or representing 
geometry) with another existing geometry. In this case, the constructed 
geometry previous association is removed, then associated with the new 
selection.

 An existing geometry cannot be its constructed geometry (or representing 
geometry) and represented geometry at the same time.

 Query the direct or inherited constructed geometry of a given tolerancing 
feature.

 Remove existing constructed geometry, but not its indirect representing 
geometries.

 One or several representing geometries may be referenced by a represented 
geometry, but a representing geometry element can be referenced by only 
one represented geometry.

Creating a manual constructed geometry allows you to associate an existing 
geometry as constructed geometry of a tolerancing feature (User surface and Group 
of surfaces). The lifecycle of an automatically constructed geometry is not managed 
by the application.

 For this, you can select:
●     A 3D annotation: the corresponding tolerancing feature is retrieved.

●     A geometrical element: the corresponding tolerancing feature is retrieved or 
created.

Open the Tolerancing_Annotations_08.CATPart CATPart document.

1.  Click the Constructed Geometry Management icon:  
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Managing Constructed Geometry

 2.  Select the datum.

 

 The Constructed Geometry Management dialog box appears.

 

 3.  Select the reference plane as shown to define the gage plane of the related 
surface of the annotation.
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Managing Constructed Geometry

 

 The Constructed Geometry Management dialog box is updated, the 
constructed geometry is created in manual mode: the associativity is 
managed by the user.

 

 4.  Click OK in the dialog box.

 
5.  Click the Constructed Geometry Management icon:  
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Managing Constructed Geometry

 6.  Re-select the previous datum.

 

 7.  Click Indirect representing in the dialog box.

 The Constructed Geometry Management dialog box displays the indirect 
representing of the previously created constructed geometry (Plane.1 is a 
representing geometry element, named User Surface.5, of the selected 
reference plane in step 3).
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Managing Constructed Geometry

 8.  Click OK in the dialog box.
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Workbench Description
The 3D Functional Tolerancing & Annotations workbench looks like this (move the mouse over 
the various toolbars; the enlarged image and corresponding description will pop-up):

 

Workbench Description
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Menu Bar

Menu Bar
This section presents the main menu bar available when you run the application and before 
creating or opening a document:

Start File Edit View Insert Tools Windows Help

Insert
For... See...

Views/
Annotation 
Planes

Insert -> Views/Annotation Planes 
Menu

Annotations Insert -> Annotations Menu

Advanced 
Replication Tools

Insert -> Advanced Replication Tools 
Menu

Instantiate From 
Document...

Instantiating Power Copy

[ Up ] [ Next ]
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Insert Views/Annotation Planes Menu

Insert -> Views/Annotation Planes Menu
This section presents the Insert -> Views/Annotation Planes menu:

 

For... See...

Projection View 
Creating a Projection View/
Annotation Plane

Section View 
Creating a Section View/
Annotation Plane

Section Cut 
Creating a Section Cut View/
Annotation Plane

Offset Section 
View/Section Cut 

Creating an Offset Section 
View/Section Cut

Aligned Section 
View/Section Cut 

Creating an Aligned Section 
View/Section Cut

[ Up ] [ Next ]
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Insert -> Annotations Menu

Insert -> Annotations Menu
This section presents the Insert -> Annotations menu:

For... See...

Text with Leader Creating a Textual 
Annotation

Flag Note with 
Leader  

Creating Flag Notes

Datum Specifying Datum

Datum Target Specifying Datum Targets

Geometrical 
Tolerance 

Specifying Geometrical 
Tolerances

Roughness Creating Roughness Symbol

Dimensions Creating Dimensions

Note Object 
Attribute 

Creating Note Object 
Attribute 

Add Leader Adding Leaders and Using 
Breakpoint

Geometry 
Connection 
Management

Managing Annotation 
Connection

Default Annotation Creating an Automatic 
Default Annotation 
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Insert -> Advanced Replication Tools Menu

Insert -> Advanced Replication Tools Menu
This section presents the Insert -> Advanced Replication Tools menu:

 

For... See...

PowerCopy 
Creation... 

Creating Power Copy

Save in Catalog... Saving Power Copy into a Catalog
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Annotations Toolbar

Annotations Toolbar 

 See Introducing the Tolerancing Advisor 

 Jump to Texts Sub-Toolbar

 Jump to Flag Notes Sub-Toolbar

See Specifying Datum 

See Specifying Datum Targets 

See Specifying Geometrical Tolerances 

See Creating Roughness Symbol 

See Creating Basic Dimensions 

Jump to Dimensions Sub-Toolbar

See Generating Dimensions 

Texts Sub-Toolbar

 See Creating Texts 

 See Creating Texts 

 See Creating Texts 

Flag Notes Sub-Toolbar
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Annotations Toolbar

 See Creating Flag Notes 

 See Creating Flag Notes 

Dimensions Sub-Toolbar

See Creating Dimensions 

See Creating Cumulated Dimensions 

See Creating Stacked Dimensions 

 See Creating Coordinate Dimensions 

See Creating Curvilinear Dimensions 

[ Back ] [ Up ] [ Next ]
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Dimension Properties Toolbar

Dimension Properties Toolbar 

See Creating Dimensions 

See Dimension Tolerance Display 

See Tolerance Display 

See Dimension Numerical Display , see Dimension Units reference.

See Precision Display 
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Reporting Toolbar

Reporting Toolbar 

 Jump to Reports Sub-Toolbar

Reports Sub-Toolbar

 See Generating a Check Report 

 See Customizing the Reporting 
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Style Toolbar

Style Toolbar 

See Defining Default Properties 

See Copying Graphic Properties 
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Text Properties Tool Bar

Text Properties Toolbar 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 

See Setting Graphic Properties 
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Text Properties Tool Bar

See Setting Graphic Properties 
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Position and Orientation Toolbar

Position and Orientation Toolbar 

See Moving Annotations 

See Moving Annotations 

See Moving Annotations 

See Moving Annotations 
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Views/Annotation Planes Toolbar

Views/Annotation Planes Toolbar 

Jump to Views Sub-Toolbar

Views Sub-Toolbar

See Creating a Projection View/Annotation Plane 

See Creating a Section View/Annotation Plane 

 See Creating a Section Cut View/Annotation Plane 

See Creating an Offset Section View/Section Cut 

See See Creating an Aligned Section View/Section Cut 
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Check Toolbar

Visualization Toolbar 

 See Disabling 3D Annotations 

 See Managing Associativity Between Elements 

 See Using Annotation Filter 

 See Mirroring Annotations 

 See Clipping Annotations Plane 
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Note Object Attribute Toolbar

Note Object Attribute Toolbar 

 See Creating Note Object Attribute 
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3D Grid Toolbar

3D Grid Toolbar 

 See Using 3D Grid 

 See Using 3D Grid 
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Grouping Toolbar

Grouping Toolbar 

 See Grouping Annotations Automatically 

 See Grouping and Ordering Annotations 
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Capture Toolbar

Capture Toolbar 

 See Creating an Annotation Capture: 
This command open the Tolerancing & Annotation Captures workshop.
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Geometry for 3D Annotations Toolbar

Geometry for 3D Annotations Toolbar 

See Creating a Partial Surface 

 Jump to Geometry for 3D Annotations Sub-Toolbar

See Managing Annotation Connection 

Geometry for 3D Annotations Sub-Toolbar

 See Creating an Automatic Constructed Geometry 

 See Managing Constructed Geometry 

See Dimensioning and Tolerancing Threads using the Tolerancing Advisor 
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Deviations Toolbar (Compact)

Deviations Toolbar (Compact) 

Jump to Deviations Sub-Toolbar (Extended)

Deviations Sub-Toolbar (Extended)

 See Creating a Deviation 

 See Creating a Correlated Deviation  

See Creating a Distance Between Two Points 
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Workshop Description
The Tolerancing & Annotation Captures workshop looks like this (move the mouse over image's 
links and have the enlarged image and corresponding description pop up):

Workbench Toolbar
Capture Visualization Toolbar

Capture Options Toolbar
Camera Toolbar 
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Workbench Toolbar

Workbench Toolbar 

 See Creating an Annotation Capture 
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Capture Visualization Toolbar

Capture Visualization Toolbar 

 See Managing Associativity Between Elements 

 See Filtering Annotations  

 See Mirroring Annotations 
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Capture Options Toolbar

Capture Options Toolbar 

See Managing Capture Options 

 See Managing Capture Options 

 See Managing Capture Options 

 See Managing Capture Options 
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Camera Toolbar

Camera Toolbar 

 See Creating a Camera 
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Customizing for 3D Functional Tolerancing & Annotation

Customizing for 3D Functional Tolerancing & 
Annotation  

This section describes the different types of setting customization you can perform in 3D 
Functional Tolerancing & Annotations using the Tools -> Options command. 

All tasks described here deal with permanent setting customization.
Tolerancing
Display
Constructed Geometry
Manipulators
Dimension
Annotation
Tolerance Values
View/Annotation Plane 
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Tolerancing

Tolerancing  

This task will show you how to customize 3D Functional Tolerancing & Annotation 
tolerancing settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Tolerancing tab.

The Tolerancing tab appears, displaying five categories of options:

Tolerancing Standard  

 Default standard at creation

Defines the default standard at creation. 

Provides four conventional standards:
●     ASME: American Society for Mechanical Engineers

●     ANSI: American National Standards Institute

●     ISO: International Organization for Standardization

●     JIS: Japanese Industrial Standard

Also provides three CATIA-CADAM standards:
●     CCDANSI: CATIA-CADAM American National Standards Institute

●     CCDISO: CATIA-CADAM International Organization for 
Standardization
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Tolerancing

●     CCDJIS: CATIA-CADAM Japanese Industrial Standard

Semantic Control  

 Always try to upgrade non-semantic tolerances and dimensions

 Defines automatic upgrade of a non-semantic annotation during its 
creation to a semantic annotation. If it can be upgradeable to a 
semantic annotation only.

 Non-semantic tolerance creation allowed

 Defines whether non-semantic tolerances creation is allowed or not.

 Non-semantic dimension creation allowed

 Defines whether non-semantic dimensions creation is allowed or not.

Leader associativity to the geometry  

 Free

 Specifies that leader annotations are freely positioned relative to their 
geometrical elements.

 Perpendicular

 Specifies that leader annotations are positioned perpendicular to their 
geometrical elements.

Rotation  
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Tolerancing

 Rotation snap angle

 Defines an angle value for rotating elements. This option is used to 
rotate text elements (text, frame, or leader).

 Automatic snapping

 Defines whether the rotation will be snapped to the angle value or not.

Note Object Attribute  

 Allow Note Object Attribute creation

 Defines whether note object attribute may be created by user or not. 
Enable or disable the icon and menu item.
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Display

Display  

This task will show you how to customize 3D Functional Tolerancing & Annotation 
display settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Display tab.

The Display tab appears, displaying the following categories of options:

Non-Semantic  

 Mark non-semantic annotations

 Defines whether non-semantic annotations (datum elements, datum 
targets, geometrical tolerances, linear and angular dimensions) are 
marked with a wavy red line in the specification tree and in the 
geometry. 

Grid  

Display
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Display

Defines whether the grid is displayed.

Snap to point

Defines whether annotations are snapped to the grid's point. 

Allow Distortions

Defines whether grid spacing and graduations are the same horizontally 
and vertically. 

H Primary spacing

Defines the grid's horizontal spacing. 

H Graduations

Defines the grid's horizontal graduations.

V Primary spacing

Defines the grid's vertical spacing (available only if Allow Distortions is 
checked).

V Graduations

Defines the grid's vertical graduations (available only if Allow 
Distortions is checked).

Annotations in Specification Tree  
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Display

 Under Geometric Feature nodes

Defines that 3D annotations should be displayed under the geometric 
feature nodes in the specification tree. This lets you view 3D 
annotations under the Part Design or GSD feature nodes to which they 
are applied.

Under View/Annotation Plane nodes

Defines that 3D annotations should be displayed under the view/
annotation plane nodes in the specification tree. This lets you view 3D 
annotations under the view node to which they are linked.

Under Annotations Set node

Defines that 3D annotations should be displayed under the annotation 
set node in the specification tree.

 

Partial Surface  
 

 Apply Settings

 Defines whether the following settings are applied while creating a 
partial surface feature.

 Surface Color

 Defines the surface color of the partial surface. 

 Edge Type

 Defines the edge type of the partial surface's border. 

 Edge Thickness

 Defines the edge thickness of the partial surface's border.
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Display

 Edge Color

 Defines the edge color of the partial surface's border.

Annotation Parameters  
 

 Display parameters under annotation feature node

Defines that knowledge parameters (such as tolerance values, datum 
label, etc.) of annotations should be displayed under the annotation 
feature node in the specification tree; also defines that feature 
parameters of dimensions (accessible through the Edit Generative 
Parameter command) should be displayed under the dimension 
feature node in the specification tree.

Note that in order to have the value of the parameters displayed in the 
specification tree, you need to select the With value knowledge setting 
in Tools -> Options -> General -> Parameters and Measure -> 
Knowledge tab.

 

Surface Normal  
 

 Display for shifted profile tolerance

 Defines whether the normal of all the selected surfaces are displayed, 
or not, when a shifted profile tolerance is specified or queried.
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Constructed Geometry

Constructed Geometry   

This task will show you how to customize 3D Functional Tolerancing & Annotation 
tolerances settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Constructed Geometry tab.

The Constructed Geometry tab appears, displaying three categories of 
options:

Graphic Properties  

 Surface color

 Defines the constructed geometry surface color for plane and cylinder.

 Curve type

 Defines the constructed geometry curve type.
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Constructed Geometry

 Curve thickness

 Defines the constructed geometry curve thickness.

 Curve color

 Defines the constructed geometry curve color.

 Point type

 Defines the constructed geometry point type.

 Point color

 Defines the constructed geometry point color.

 Apply settings

 Defines whether all the graphic properties settings are applied or not.

Limits  

 All around overrun

 Defines the minimal limit between the constructed geometry and its 
related geometry.

Automatic Creation  

 Center point

 Defines whether all the center point's constructed geometry is 
automatically created or not, for circle center, sphere center.

 Center axis

 Defines whether all the center axis's constructed geometry is 
automatically created or not, for cylinder, cone.
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Constructed Geometry

 Center plane

 Defines whether all the center plane's constructed geometry is 
automatically created or not, for slot.
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Manipulators

Manipulators  

This task will show you how to customize 3D Functional Tolerancing & Annotation 
manipulators settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Manipulators tab.

The Manipulators tab appears, displaying two categories of options:

Manipulators  

 Reference size

 Defines the annotation manipulator's size.

 Zoomable

 Defines whether the annotation manipulator is zoomable or not.

Dimension Manipulators  
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Manipulators

 Modify overrun

 Defines whether overrun extension lines can be modified during 
creation or modification, or not.

 Modify blanking

 Defines whether blanking can be modified during creation or 
modification, or not.

 Insert text before

 Defines whether a text before can be inserted during creation or 
modification, or not.

 Insert text after

 Defines whether a text after can be inserted during creation or 
modification, or not.

 Move value

 Defines whether only the value can be moved during creation or 
modification, or not.

 Move dimension line

 Defines whether only the dimension line can be moved during creation 
or modification, or not.

 Move dimension line secondary part
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Manipulators

 Defines whether only the dimension line  secondary part can be moved 
during creation or modification, or not.
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Dimension

Dimension   

This task will show you how to customize 3D Functional Tolerancing & Annotation 
dimension settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Dimension tab.

The Dimension tab appears, displaying two categories of options:

Dimension Creation  

Dimension following the mouse

 Defines whether the dimension line is positioned according to the cursor, 
following it dynamically during the creation process or not.

End dimension creation at line-up

 Defines whether a dimension aligned to another automatically ends the 
command or not.

Constant offset between dimension line and geometry

 Defines whether the distance between the created dimension and the 
geometry remains the same when you move the geometry or not.
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Dimension

Default dimension line/geometry distance

 Defines the value at which the dimension is created from the geometry.
If you create associativity between the dimension and the geometry, you 
can define the value at which the dimension will remain positioned.

By default, dimension circles on their

 Defines the dimension you will create between a circle and another element 
will be either on the circle center or on the circle edge.

Move  

Activate Snapping

 Defines whether the dimension will be snapped on the grid and/or the 
dimension value will be located at its default position between symbols (it 
will work only if the cursor is between the symbols) or not.

Move only selected sub-part

 Defines whether only a dimension sub-part (text, line, etc...) will be moved 
or not.
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Annotation

Annotation   

This task will show you how to customize 3D Functional Tolerancing & Annotation 
annotation settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Annotation tab.

The Annotation tab appears, displaying two categories of options:

Annotation Creation  

 Annotation following the mouse (Ctrl toggles)

 Defines whether the annotation is positioned according to the cursor, 
following it dynamically during the creation process or not.

Geometrical Tolerance  

 Extension line length

 Defines the extension line length between the geometrical frame and 
the its leader.

http://pop.dia.uniroma3.it/catia/online/bascufdt_C2/bascufdt0500.htm (1 of 2)10/21/2004 7:41:04 PM



Annotation
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Tolerances

Tolerances  

This task will show you how to customize 3D Functional Tolerancing & Annotation 
tolerances settings.

1.  Select Tools -> Options... 

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the Tolerances tab.

The Tolerances tab appears, displaying three categories of options:

Angular Size  

 Default upper tolerance value

 Defines the default upper tolerance value for angular size.

 Symmetric lower limit

 Defines whether the default lower tolerance value is symmetric in 
relation to the default upper tolerance value.

 Default lower tolerance value

 Defines the default lower tolerance value for angular size, disable when 
Symmetric lower limit is checked.
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Tolerances

 Numerical value increment

 Defines the increment for angular size numerical value.

Linear Size  

 Default upper tolerance value

 Defines the default upper tolerance value for linear size.

 Symmetric lower limit

 Defines whether the default lower tolerance value is symmetric in 
relation to the default upper tolerance value.

 Default lower tolerance value

 Defines the default lower tolerance value for linear size, disable when 
Symmetric lower limit is checked.

 Numerical value increment

 Defines the increment for linear size numerical value.

 Default tabulated value

 Defines the default tabulated for linear size.

Geometrical  
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Tolerances

 Default numerical value

 Defines the default numerical for geometrical tolerance.

 Numerical value increment

 Defines the increment for the to geometrical tolerance numerical value.

 Precision

 Defines the geometrical tolerance precision after the numerical 
separator.

 Separator

 Defines the geometrical tolerance symbol used as numerical separator.

 Display trailing zeros

 Defines whether "0"s complete the number of digit displayed after the 
separator, according to the precision, or not.

 Display leading zeros

 Defines whether the "0" before the numerical separator, when value is 
less than 1, is displayed or not.
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View/Annotation Plane

 View/Annotation Plane  

This task will show you how to customize 3D Functional Tolerancing & Annotation 
view/annotation plane settings.

1.  Select Tools -> Options...

The Options dialog box appears.

2.  Click the Mechanical Design category.

3.  Click the 3D Functional Tolerancing & Annotation subcategory.

4.  Click the View/Annotation Plane tab.

The View/Annotation Plane tab appears, displaying the following 
categories of options:

View/Annotation Plane Associativity   

 Create views associative to geometry

 Creates views associative to the geometry, so that views and their 
annotations are automatically updated when the geometry is modified. 

View/Annotation Plane Display   
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View/Annotation Plane

 Current view axis display

 Defines whether the active annotation plane axis system is displayed. 

 Zoomable

 Defines whether the annotation plane axis is zoomable.

 Visualization of the profile in the current view

 Defines whether the view/annotation plane profile on the part/product 
is displayed or not. 
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Reference Information

Reference Information
This section contains reference information about 3D Functional Tolerancing & Annotations 
workbench.

Normative References
Principles and Fundamental Rules for Geometrical Tolerancing

Geometrical Tolerancing
Symbols for Geometrical Tolerances

Symbols for Modifiers
Datum Principles

Concepts
Standards
Properties

Dimension Units
Statistic Laws 
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Normative References

Normative References

 The table below provides a list of normative references.

ANSI B4.2-
1978

Preferred Metric Limits and Fits

ASME Y14.5M-
1994

Dimensioning and tolerancing - Revision of ANSI Y14.5M-1982

ASME A standard is being developed on DIGITAL MODELING. This 
project will cover the representation of dimensioning and 
tolerancing annotations in the 3D space. 

ISO Standards are being developed for the specification of 
dimensioning and tolerancing annotation in the 3D space.

ISO 406-1987 Technical drawings -- Tolerancing of linear and angular 
dimensions

ISO 286 ISO system of limits and fits

ISO 1101-1983 Geometrical tolerancing. Tolerancing of form, orientation, 
location and run-out

ISO/FDIS 1101-
1998

Geometrical product specification (GPS). Geometrical 
Tolerancing - Generalities, definitions, symbols, indication on 
drawings. 

Final Draft International Standard (FDIS). Revision of ISO 1101-
1983. 

Note: The new ISO 1101 standard will be published in october 
2000 and will replace ISO 1101-1983.

ISO 1660-1987 Technical drawings. Dimensioning and tolerancing of profiles

ISO 2692-1988 Technical drawings. Geometrical tolerancing. Maximum material 
principle

ISO 2692 Amd 
1-1992

Technical drawings. Geometrical tolerancing. Maximum material 
principle- Amendment 1: Least material requirement

ISO 5458-1998 Geometrical Product Specifications (GPS). Geometrical 
tolerancing  - Positional tolerancing
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Normative References

ISO 5459-1981 Technical drawings. Geometrical tolerancing. Datums and datum 
systems for geometrical tolerances 

Under revision

ISO/DIS 5459-
1

Geometrical product specification (GPS). Datums for geometrical 
tolerancing. Part 1: General terms and definitions, 1998-10-15, 
Committee Draft. (Revision of ISO 5459-1981)Draft 
International Standard (DIS)

ISO/DIS 5459-
2

Geometrical product specification (GPS). Datums for geometrical 
tolerancing. Part 2: Datums and datum-systems; explanations 
and indication 1998-10-15, Committee Draft. (Revision of ISO 
5459-1981) 

Draft International Standard (DIS)

ISO 8015-1985 Technical drawings. Fundamental tolerancing principle

ISO 10578-
1992

Technical drawings. Tolerancing of orientation and location. 
Projected tolerance zone 

ISO 10579-
1993

Technical drawings. Dimensioning and Tolerancing. Non-rigid 
parts 

ISO 14660-1 Geometrical product specification (GPS). Geometric features. 
Part 1: General terms and definitions

ISO 14660-2 Geometrical product specification (GPS). Geometric features. 
Part 2: Extracted median line of a cylinder and a cone; 
extracted median surface; local size of an extracted feature

ISO/TS 17450-
1999

Geometrical product specification (GPS). Model for geometric 
specification and verification.
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Principles and Fundamental Rules for Geometrical Tolerancing

Principles and Fundamental Rules for 
Geometrical Tolerancing

All the dimension, form, orientation and position specifications (either on a 
geometric feature or on a geometric feature group of a part) are independent (see 
ISO 8015). 

The dimensions of the features and their geometry are independent, regarding the 
form, the orientation and the position (see ISO 8015).

Each dimension shall have a tolerance, except for the dimensions specially identified 
as reference, maximum, minimum, or stock (commercial stack size). The tolerance 
may be applied directly to the dimension (or indirectly in case of basic dimensions), 
indicated by a general note, or located in a supplementary block of the drawing 
format, see ANSI Y14.1, ASME Y14.5M-1994).

Dimensioning and tolerancing shall be complete so there is full understanding of the 
characteristics of each feature. Neither scaling (measuring the size of a feature 
directly from an engineering drawing) nor assumption of a distance or size is 
permitted, except as follows: non-dimensioned drawings, such as loft, printed 
wiring, templates, and master layouts prepared an stable material, are excluded 
provided the necessary control dimensions are specified, (ASME Y14.5M-1994).
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Geometrical Tolerancing

 

 

Geometrical Tolerance is the general term applied to the category of tolerances 
used to control form, profile, orientation, location and runout, (ASME Y14.5M-1994).

True Geometrical Counterpart represents the theoretically perfect boundary (virtual 
condition or actual mating envelope) or best-fit (tangent) plane of a specified 
datum feature, (ASME Y14.5M-1994).

The geometrical tolerancing is divided into four types (by both ISO and ASME/
ANSI):

 Form tolerances,

 Orientation tolerances,

 Location or position tolerances,

 Runout tolerances.

Geometrical tolerance objective is the boundary of spaces in which the toleranced 
feature has to be located with regards to the specified datums or datum system, to 
meet the tolerance specification. These particular tolerances allow to limit either 
actual feature defects or fitted features, with respect to nominal characteristics, and 
without considering the features' dimensions.

Geometrical tolerancing is based on three feature types:

 Tolerance features: a toleranced feature is an actual feature (point, line, 
surface, except for projected tolerance), or a fitted or a constructed feature. 
If the toleranced feature corresponds to a group, then each component of the 
group has the same nature, and the toleranced feature is a toleranced 
feature group.

 Tolerance zone: a tolerance zone is a space (either surface or volume), 
bounded by one or several nominal features. That space defines the 
toleranced feature location in order to satisfy the tolerance specification, (see 
ISO 1101). When the geometrical tolerance applies on a feature group, then 
one tolerance zone is linked to one feature.

 Datum elements or datum systems.

Even if the Geometrical Tolerance creation is accomplished without any semantic 
links, we recommend you to specify datum elements and then declare your 
geometrical tolerancing with references.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugrf0300.htm (1 of 2)10/21/2004 7:42:29 PM



Geometrical Tolerancing

[ Back ] [ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugrf0300.htm (2 of 2)10/21/2004 7:42:29 PM



Symbols for Geometrical Tolerances

Symbols for Geometrical Tolerances 

 

 

The list of available symbols for geometrical tolerances.

Tolerances Characteristics Symbol Datum needed

Form Straightness No

Flatness  No

Roundness No

Cylindricity No

Profile any line No

Profile any surface No

Orientation Parallelism Yes

Perpendicularity Yes

Angularity Yes

Profile any line Yes

Profile any surface Yes

Location Position Yes or no

Concentricity (for center points) Yes

Coaxiality (for axis) Yes

Symmetry Yes

Profile any line Yes

Profile any surface Yes

Run-out Circular run-out Yes
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Total run-out Yes
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Symbols for Modifiers 

 

 

The list of available symbols for modifiers.

Least Material Condition Symbols

Maximum Material Condition 
(MMC)

Least Material Condition 
(LMC)

Tangent plane

Regardless of Feature of Size 
(RFS)

Free State

Projected Tolerance zone
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Datum Principles

 
Datum Elements and Datum Systems

Datum elements and datum systems are only specified in case of geometrical 
tolerancing (not on dimensional tolerancing and except on form tolerancing). You 
can specify simple datum elements,  common datum elements, datum targets or 
specified datum systems.

The toleranced feature is positioned relatively with the tolerance zone, and this set 
is positioned relatively with the datum or the datum system. These related 
positions will be specified using basic dimensions and they are displayed or not.

For more information about datum constitution and specification, see ISO 5459, 
ASME Y15.5M and ISO 1101.

Datum System Composition

When the identifiers are specified separately in each frame of the tolerance frame, 
the datum elements represent a datum system. A hierarchy is established between 
the datum elements. Reference A is the primary datum and reference B is the 
secondary datum. The datum system fitting would be performed first on datum A, 
then on datum B, with respect to A.  By the way, a tertiary datum can also be 
specified.

 The datum elements have to be fitted successively (following their 
specification order) with respect to the hierarchy for the measurement 
computations.

When only one identifier is specified in the tolerance frame, the datum is a 
single datum.

When two identifiers separated by a dash are specified in the tolerance frame, the 
datum is a common datum. The two datum elements are to be considered 
simultaneously. The datum system fitting would be performed in the meantime on 
datum A and on datum B (both datum elements have to be fitted simultaneously 
for measurement computations).
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These symbols represent two specifications in the meantime: A | B and B | A.

When the identifiers are specified separately in the same frame of the tolerance 
frame, no hierarchy is established between the datum elements.

 This notation only exists in ISO. However, the ISO recommends not using 
this specification any longer.

Two measurement computations have to be performed: the datum elements 
have to be fitted successively following their specification order and following 
the opposite specification order.

Datum writing rules

A capital letter is used to identify the datum element in the tolerance frame. The 
datum triangle may be filled or non-filled.

When the datum triangle is placed on the outline of the element or on its extension 
line, the datum element represents the surface itself or the 2D representation of 
the surface, which is a line.

When the datum triangle is placed in the alignment of the dimension line, the 
datum element represents the median element (usually an axis or a median plane).

When the datum triangle points directly on a median element, the datum element 
represents either the median element itself (usually an axis or a median plane) or 
the resulting median element of the collection of the considered elements.

The tolerance frame may also be related to the datum element using a leader line.

When the tolerance frame is related to one datum element through a leader line, 
the datum identifier may be omitted in the tolerance frame.
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Concepts

3D Annotation and Annotation Plane

Non-semantic and Semantic Usage

Note Object Attribute 
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3D Annotations and Annotation Planes

  3D annotations are dimensions, tolerances, notes, text or symbols displayed in 3D 
according to the same type of 2D annotations defined by standards (ISO, ASME, 
ANSI, JIS, DYN...).

A 3D annotation is always linked to a user surface or a group of surfaces.

A 3D annotation is displayed in 3D following the orientation of a particular plane 
called Annotation Plane.
Two types of 3D annotation are available: Semantic 3D Annotation and Non-
semantic 3D Annotation.

Non-semantic 3D Annotations

3D annotations that are not defined in ISO or ASME/ANSI standards:

 Text

 Flagnote

 Note Object Attribute (NOA)

3D annotations where only their graphical attributes are take into account.
There is no control on attribute values.
There is no control of consistency regarding the geometry on which it is applied 
and the other annotations.
There is no control of the syntax regarding the standard in use.

 Roughness

 Datum

 Datum target

 Geometrical tolerance

 Dimension

Semantic 3D Annotations

3D annotations on which attribute values, consistency with geometry and syntax 
are controlled.
The annotation validity is warranted along the life cycle application to be re-used 
and well understood by other applications like tolerance analysis, inspection, 
manufacturing, assembly process...
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 Roughness

 Datum

 Datum target

 Datum reference frame

 Geometrical tolerance

 Dimension

User Surface

Depending the way the parts or products have been designed the surface the user 
wants to consider can be made of one or several geometrical elements.

Group of Surfaces

A group of surfaces is a set of user surface or group of surfaces. It is used to 
modelized Tab/Slot, Profile and Pattern features as defined in standards.

Annotation Planes

Annotation planes are the 3D equivalent of 2D views. They contain the 3D 
annotation or define their orientation.
Three types of Annotation planes are available: Projection View, Section View and 
Section Cut.

In Projection View Annotation Plane, 3D annotations may be:

 Located in planes parallel to this annotation plane and in the background 
and foreground spaces bounded by this annotation plane.

 Related to the geometry finding an intersection with this annotation plane.

 Lying on/belonging to this annotation plane.

In Section View Annotation Plane, 3D annotations may be:

 Located in planes parallel to this annotation plane and in the background 
space bounded by this annotation plane.

 Related to the geometry finding an intersection with this annotation plane.

 Lying on/belonging to this annotation plane.

In Section Cut Annotation Plane, 3D annotations may be:
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 Only related to the geometry finding an intersection with this annotation 
plane.

 Only lying on/belonging to this annotation plane.
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Non-semantic and Semantic Usage

  The goal of the Functional Tolerancing & Annotation product is to fully covered the 
ISO or ASME/ANSI standards semantic and syntax definitions. Non-semantic 3D 
annotation can be used in case of Functional Tolerancing & Annotation lacking 
capabilities or company usage of symbols and syntax that are not covered by 
standards.

The following Semantic 3D Annotations are available:

Datum

Datum target

Toleranced dimensions applied to Features of Size:.

Circle

Sphere

Cylinder

Tab/Slot

Angular Tab/Slot

Elongated Hole

Rectangular Hole

Framed dimensions (basic dimensions) as defined in standards are not yet 
supported as semantic in Functional Tolerancing & Annotation.
In this case use non-semantic dimensions.

According to ISO and ASME/ANSI standards, framed dimensions (basic 
dimensions) are used to define:

Position and orientation of the tolerance display.

Position, size and orientation of partial surfaces and datum targets.

Position and orientation of Datum Reference Frame.
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Note Object Attribute 

  

Purpose
The Note Object Attribute purpose feature is to provide a way to define user types 
of 3D annotations and to define their 3D display.

Usage
The recommended usage for such Note Object Attribute feature is the following:

The administrator defines all the company types of Note Object Attribute and 
stores them in a dedicated catalog:

 Finish Data (paint, special processes)

 Surface treatment types

 Grain Direction

 Key Characteristics

 Electrical Bonding Location and Specification

 Part Marking Location and Specification

 Process Data (Specification for processes)

 ...

 The administrator turns off the Note Object Attribute creation setting (see 
Tolerancing setting) to lock it in order to forbid the creation of new Note 
Object Attribute types by users.

Users instantiate from the catalog the types of Note Object Attribute they 
want to specify.

Filtering
You can filter by type of Note Object Attribute the 3D annotations by using the 
filter command.
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Standards

Standards
Standards (such as ISO, JIS, ANSI, ASME, etc. or company standards) specify the properties 
and styles of tolerancing and annotation elements such as dimensions, annotations, etc. so 
that they will be applied to all elements of a given type within a single part or product, as 
well as in all parts or products which use the same parent standard.

Standards are managed by an administrator. Each standard is defined in an XML file, which 
makes it possible to customize globally the appearance and behavior of tolerancing and 
annotation elements. 

Standards in the 3D Functional Tolerancing and Annotation workbench are those used and 
customized in the Drafting workbenches: they are 2D standards, transposed to 3D. As they 
are defined for the Drafting workbenches, some standard parameters apply only to Drafting 
applications. However, a great number of parameters apply to both the 3D Functional 
Tolerancing and Annotation and Drafting workbenches.

The values of the parameters in the file are taken into account when the first Functional 
Tolerancing and Annotation view is created, based on the current parent standard. Once the 
first view has been created, modifying the standard file will not affect this CATPart 
document. 

For more information on standards and their administration, refer to the User Tasks > 
Administration Tasks chapter in the Interactive Drafting User's Guide. Also refer to 
Dimension Tolerance Display and to Dimension Numerical Display in this guide.
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Dimension Tolerance Display

 Dimension tolerance display formats are listed below. These formats are available 
in the Properties dialog box, Tolerance tab. 
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Name Display Description

No tolerance 
displayed.

Numerical 
superimposed 
(small).

Numerical 
superimposed with 
trailing zeros 
(large).

Numerical 
superimposed 
(small).

Numerical 
superimposed with 
trailing zeros 
between 
parentheses 
(small).

Numerical 
superimposed 
(large).

Numerical resolved, 
superimposed.

Alphanumerical 
single value (large).
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Alphanumerical 
double value side-
by-side (large).

Alphanumerical 
double value 
superimposed 
(small).

Numerical 
superimposed 
(small).

Numerical 
superimposed 
(large).

Numerical 
superimposed with 
trailing zeros 
between 
parentheses (large).

Alphanumerical 
single value (large).

Alphanumerical 
double value 
superimposed 
(small).

Alphanumerical 
single value (large).

Alphanumerical 
single value (large).
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Alphanumerical 
single value (small).

Alphanumerical 
double value 
superimposed 
(small).

Alphanumerical 
single value 
(medium).

Alphanumerical 
double value 
superimposed 
(medium).

Alphanumerical 
single value (large) 
and numerical 
superimposed 
between 
parentheses 
(small).

Alphanumerical 
single value (large) 
and numerical 
superimposed 
between 
parentheses (large).

Numerical resolved, 
side-by-side.
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Dimension Numerical Display

 Dimension numerical display formats are listed below. These formats are available 
in the Properties dialog box, Value tab. 

Name Display Description

Millimeters with dot.

Millimeters with 
comma.

Inches with trailing 
zeros.

http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugrf0502.htm (1 of 4)10/21/2004 7:44:06 PM



Dimension Numerical Display

Inches with unit 
display.

Millimeters with trailing 
zeros.

Millimeters with dot.

Inches with unit display

Feet and Inches with 
unit display

Microns.

Millimeters.

Centimeters.

Meters.
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Kilometers.

Inches.

Feet and Inches.

Degrees, Minutes, 
Seconds with dot.

Degrees, Minutes, 
Seconds with comma.

Degrees, Minutes, 
Seconds with dot and 

Radians.

Degrees with decimal 
format.

Degrees, Minutes, 
Seconds with dot.
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Grades.
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Properties

Text Graphical Properties: apply graphical properties to a text.

Text Properties Toolbar: apply graphical properties to a text

Semantic Numerical Display Properties: set semantic numerical display.
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Text Properties Toolbar 

Set the text appearance in a text  annotation from the options available in the Text Properties toolbar.
Note that the operating mode described here is valid for datum elements, datum targets and geometrical 
tolerances too.

These properties are:

 Font Name: changes the font of text

 Font Size: changes the font size of text

 Bold: changes the weight of text, toggles between normal and heavy (bold).

 Italic: changes the angle of text, toggles between normal and slanted (italic)

 Underline: adds a line under the text.

 Strikethrough: adds a line through the middle of the text.

 Overline: adds a line above the text.

 Superscript: raises the text above the normal text line.

 Subscript: lowers the text below the normal text line.

 Left Justify: aligns multiple lines of text along the left edge of the text frame.

 Center Justify: aligns multiple lines of text in the center of the text frame.

 Right Justify: aligns multiple lines of text along the right edge of the text frame

 
Anchor Point: changes the position of the point that connects the text to the drawing or to an element.
There are nine possibilities:

 Along the top of the text: left, center, or right.

 Along the vertical center of text: left, center or right.

 Along the bottom of the text: left, center, or right.

 Frame: draws a single-line frame around the text. The frame size can be variable, or fixed.

 
Insert Symbol: inserts several symbol types including geometrical tolerancing ones especially in the 
text editor.

Font Name
Select the font.
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Font Size
Select the size.

Bold
Select or unselect the icon.

Italic
Select or unselect the icon.

Underline
Select the icon.

Strikethrough
Select the icon.

Overline
Select the icon.

Superscript
Select the icon.

Subscript
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Select the icon.

Left Justify
Select the icon.

Center Justify
Select the icon.

Right Justify
Select the icon.

Anchor Point
Select the icon.

Frame
Select the icon. You can choose to create each frame with either a variable or a fixed size. For a 

rectangular frame, for example, the icon  represents the variable-size frame, and the icon  
(with the padlock) represents the fixed-size frame. 
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Insert Symbol
Select the symbol.
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Text Graphical Properties 

Take into account according to the options set in the Style and Text Properties 
toolbars and/or using the Copy Object Format command and/or Set as Default 
command.
See Managing Graphical Properties.

Properties Application 
Default 

Properties

User Default 
Properties

Only User 
Default 

Properties

Font Font Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Style Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Size Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 UnderLine Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Color Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Ratio Yes Application 
Default

Set as Default Set as Default

 Strikethrough Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Superscript Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Subscript Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Overline Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

Text Frame Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Color Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Thickness Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Line Type Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Anchor point Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Anchor Line Yes Application 
Default

Application 
Default

Set as Default
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 Line Spacing Yes Application 
Default

Set as Default Set as Default

 Line Spacing Mode Yes Application 
Default

Set as Default Set as Default

 Justification Yes Text Properties 
Toolbar

Set as Default Set as Default

 Word wrap Yes Application 
Default

Set as Default Set as Default

 Reference Yes Application 
Default

Set as Default Set as Default

 Orientation Yes Application 
Default

Set as Default Set as Default

 Angle Yes Application 
Default

Set as Default Set as Default

 Mirroring Yes Application 
Default

Set as Default Set as Default

 Auto flip Yes Application 
Default

Set as Default Set as Default

Graphic Color Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Linetype Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Thickness Yes Text Properties 
Toolbar

Text Properties 
Toolbar

Set as Default

 Pickable No Application 
Default

Application 
Default

Application 
Default
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Semantic Numerical Display Properties 

Set the numerical display of any semantic geometrical tolerance containing 
numerical values.
These properties are available for an annotation set or any semantic geometrical 
tolerance.
Default settings are defined from the selected standard and the annotation set 
properties. 

 They are applied when creating a semantic geometrical tolerance,
right-click the annotation set then  Properties -> Tolerancing & 
Annotations tab.

 These settings can be individually modified for each semantic geometrical 
tolerance,
right-click the semantic geometrical tolerance then  Properties -> 3D 
Annotation tab.

There are four properties:

 Precision: defines the number of digit displayed after the separator.

 Separator: defines the symbol used as numerical separator.

 Display leading zeros: displays or not the "0" before the separator when value 
is less than 1.

 Display trailing zeros: displays or not "0" to complete the number of digit 
displayed after the separator according to the precision.

Default settings according to the ISO standard

In the following examples we start from the ISO default settings.

Precision
Set the precision to 0.001 
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According to the unchecked Display trailing zeros setting only the effective 
digit after the separator are displayed.

Separator
Change the separator symbol for the . (dot)

Display leading zeros
Uncheck the Display leading zeros setting.

According to the unchecked setting the "0" is removed before the separator.

Display trailing zeros
Check the Display trailing zeros setting.
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According to the setting "0" are added to complete the precision format.
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Annotation Set Detail Properties 

Display the annotation set detail properties: select Properties -> Tolerancing & 
Annotations tab

There are four properties: 

 Set Name: displays the annotation set name.

 Standard: displays the annotation set standard.

 Specifications: displays the number of annotations contain in the annotation 
set.

 Specifications Detail: displays and quantifies the annotations types and sub-
types.
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Types Sub-Types

Datum Simple Datum
Datum System
Datum Target
Datum Reference Frame

Form Straightness
Axis Straightness
Flatness
Circularity
Cylindricity
Profile of any line
Profile of any surface
Pattern location

Size Linear Size
Angular Size
Chamfer Dimension
Basic dimension
Second Linear Size

Position Orientation and 
Runout

Parallelism
Perpendicularity
Angularity
Position
Concentricity
Symmetry
Profile of any line with Datum 
Reference Frame
Profile of any surface with Datum 
Reference Frame
Total runout
Circular runout

Non Semantic Text
Flag Note
Note Object Attribute
Datum
Geometrical Tolerance
Datum Target
Weld
Dimension

Roughness
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Dimension Units

 
Default Dimension Unit When Creating an Annotation Set

 The default dimension unit is defined by the standard default numerical formats for 
length and angle, see Tolerancing option for standard selection:

 1.  Select Tools -> Standards...

 2.  In the Standards Definition dialog box, select Drafting category and the 
Standard_Name.xml file according to the selected standard.

 3.  Select Standard -> Standard_Name -> General -> 
DefaultNumericalFormatLength to see the default length format for the 
selected standard
and/or
select Standard -> Standard_Name -> General -> 
DefaultNumericalFormatAngle to see the default angle format for the 
selected standard.

 If no standard has been defined, the dimension unit is set by the Length unit in the
Tools -> Options -> General -> Parameters and Measure, Units tab.

 
Modifying the Default Dimensions Unit

 To modify default dimensions unit you can:

 ●     Set the Numerical Display Description combo unit in the Dimension Properties 
Toolbar.

●     Set the Length (or Angle) unit in the Tools -> Options -> General -> 
Parameters and Measure, Units tab, in this case the Numerical Display 
Description combo is updated according to the Length (or Angle) unit.

[ Back ] [ Up ] [ Next ]
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Statistic Laws

 
Statistic laws are used to characterize deviation annotations. interpret annotation 
tolerance in a deviation annotation. These deviation annotations can be directly 
specified by the user or generated from a annotation's tolerance translation.

 
For a statistical analysis, an annotation tolerance is interpreted as random 
variable or variate.

 
For a determinist analysis, the mean of the annotation tolerance  is used as 
determinist value.

 Normal Law: describe the Normal probability law equations.

 Uniform Law: describe the Uniform probability law equations.

 Constant Law: describe the Constant probability law equations.

 Pearson Law: describe the Pearson probability law equations.

Poisson Law: describe the Poisson probability law equations.

Snedecor Law: describe the Snedecor probability law equations.
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Normal Law

Normal Law  

 The Normal law is parameterized by a mean  (unit: millimeter) and a standard 
deviation  (unit: millimeter). Another name for the Normal law is Gaussian law.

 

 Let's take  a random variable following the Normal law, then:

 is distributed according to the following density of probability:

 

With mean:

 

With variance:

 

With standard deviation:
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Uniform Law

Uniform Law  

 The Uniform law is parameterized by a lower limit  (unit: millimeter) and a upper 
limit  (unit: millimeter). Another name for the Uniform law is Rectangular law.

 

 Let's take  a random variable following the Uniform law, then:

 is distributed according to the following density of probability, where:

 

With mean:

 

With variance:

 

With standard deviation:
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Constant Law

Constant Law  

 The Constant law is parameterized by a constant  (unit: millimeter). 

 

 Let's take  a random variable following the Constant law, then:

 is always equals to the constant:

 

With mean:

 

With variance:

 

With standard deviation:

 

[ Back ] [ Up ] [ Next ]

http://pop.dia.uniroma3.it/catia/online/cfyugtaa_C2/cfyugtaarf0103.htm10/21/2004 7:47:02 PM



Pearson Law

Pearson Law  

 The Pearson law is parameterized by  (no unit). Another name for the Pearson law 
is Chi-squared law.
If  random variables  follows the Normal law with mean 0 and 

variance 1, then:

 

 

 Let's take  a random variable following the Pearson law, then:

 is distributed according to the following density of probability, where:

 

And where  is a Gamma function.

With mean:

 

With variance:

 

With standard deviation:
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Poisson Law  

 The Poisson law is parameterized by  (unit: millimeter).

 

 Let's take  a random variable following the Poisson law, then:

 is distributed according to the following density of probability, where:

 

With mean:

 

With variance:

 

With standard deviation:
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Snedecor Law  

 The Snedecor law is parameterized by two non-dimensional numbers  and .

 

 Let's take  a random variable following the Snedecor law of parameters  and , 
then  can be expressed in terms of two random variables ,  following Pearson 
law respectively of parameter ,  as:

 

 is distributed according to the following density of probability, where:

 

With mean:

 

With variance:

 

With standard deviation:
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Glossary  

           

A
 

Associated Derived Feature
Center point, axis or median plane derived from one or 
more associated integral features (ISO 14660).

Associated Integral Feature
Feature of perfect form associated to the extracted 
integral feature in accordance with specified 
conventions (ISO 14660).

 

C
 

Common Datum
Datum based on two or more surfaces considered 
simultaneously (ISO/CD 5459-1:1998).

 

D
 

Datum

 

A theoretically exact point, axis, or plane derived from 
the true geometric counterpart of a specified datum 
feature. A datum is the origin from which the location 
or geometric characteristics of features of a part are 
established, (ASME Y14.5M-1994).

Situation feature used to define the position and/or 
orientation of a tolerance zone or to define the position 
and/or the orientation of the virtual conditions (in the 
case of the complementary requirements, e.g 
maximum material requirement), (ISO/CD 5459-1:1998
(E)).
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Datum System
Ordered list of at least two datums and at most three 
datums, which may be single or common datums, (ISO/
CD 5459-1:1998(E)). 

Note: A datum-system is used to define the position 
and/or orientation of a tolerance zone or to define the 
position and/or the orientation of the virtual condition 
(in the case of complementary requirements, e.g 
maximum material requirement).

(Datum) Target
A specified point, line, or area on a part used to 
establish a datum, (ASME Y14.5M-1994).

Portion of an integral feature (surface) which can be a 
point, a line or an area and which is used for 
establishing a datum, (ISO/CD 5459-1:1998(E)).

Datum Feature 
An actual feature of a part that is used to establish a 
datum, (ASME Y14.5M-1994).

Derived Feature
Center point, median line or median surface from one 
or more integral features (ISO 14660)

Examples:

1- The center of a sphere is derived feature obtained 
from the sphere, which is an integral feature.

2 -The median line of a cylinder is a derived feature 
obtained from the cylindrical surface, which is an 
integral feature.

 

E
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Extracted Derived Feature
Center point, median line or median surface derived 
from one or more extracted integral features (ISO 
14660).

Note: For convenience:

- the derived median line of an extracted cylindrical 
surface is called an extracted median line (see ISO 
14660-2).

- the derived median surface of 2 opposite extracted 
planar surfaces is called an extracted median surface 
(see ISO 14660-2).

Extracted Integral Feature
Approximated representation of the real (integral) 
feature, obtained by extracting a finite number of 
points from the real (integral) feature performed in 
accordance with specified conventions. (ISO 14660)

Note: This representation is defined according to the 
required function of the feature. Several such 
representations may exist for each real (integral) 
feature.

 

F
 

Feature
The general term applied to a physical portion of a part, 
such as a surface, pin, tab, hole or slot, (ASME Y14.5M-
1994).

Geometric feature, point, line or surface, (ISO 14660-1).
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Feature of Size
Geometric shape defined by a linear or angular 
dimension which is a size(ISO 14660)

Notes

1- The features of size can be a cylinder, a sphere, two 
parallel opposite surfaces, a cone or a wedge.

2-  In standards such as ISO 286-1 and ISO/R 1938 the 
terms plain workpiece and single features are used with 
a meaning close to "feature size".

 

G
 

Geometric Feature
Point, line or surface (ISO 14660).

 

I
 

Integral Feature
Surface or line on a surface (ISO 14660)

Note: An integral feature is intrinsically defined.

 

N
 

Nominal integral feature
Theoretically exact integral feature as defined by a 
technical drawing or by other means (ISO 14660).

Nominal Derived Feature
Center point, axis or median plane derived from one or 
more nominal integral features (ISO 14660)

Note: On the technical drawing nominal derived 
features are mostly represented by chain lines (dash-
dotted lines).
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R
 

Real (integral) Feature
Integral feature part of a real surface of a workpiece 
limited by the adjacent real (integral) features (ISO 
14660). 

Note: No real derived feature exist.

Real Surface of a Workpiece
Set of features which physically exist and separate the 
entire workpiece from the surrounding medium (ISO 
14660).

Restricted Surface
Portion of an integral feature (surface) which is an area 
and which is used for establishing a datum (ISO/CD 
5459-1:1998)

Note: the area of a restricted surface is relatively large 
compared with the complete surface.

 

S
 

Single Datum
Datum based on one surface considered alone (ISO/CD 
5459-1:1998).

Situation Feature
Ideal feature which is a point, a straight line, a plane or 
a helix, from which the position and/or the orientation 
of a feature can be defined (ISO/CD 5459-1:1998)

Note: Situation features are defined by and are 
characteristics of the class of surface involved.

Surface class
Group of surfaces having the same degree of freedom 
for which the surfaces are unvarying, (ISO/CDIS 5459-
1:1998(E)).

 

T
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Tolerance zone
Space limited by one or several geometrically perfect 
lines or surfaces, and characterized by a linear 
dimension, called a tolerance (ISO/FDIS 1101:2000
(E))
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Numerics
3D Annotations

non-semantic  

semantic  

3D Grid  

A
Annotation

correlated deviation  

deviation  

distance between two points  
annotation

disabling   

enabling  

filter  

group and order  

group automatically  

group during creation  

group manually  

isolated  

querying  

specifying  

transferring during creation  

transferring existing  
Annotation Links

Create Orientation Link  

Create Positional Link  
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Delete Orientation Link  

Delete Positional Link  

Query Object Links  

ASME  

ASME Y14.5M-1994  

B
basic dimensions  

blue reference axis  
breakpoint

add an extremity  

create  

C
capture

Capture Management  

create  

display  

manage  
command

3D Annotation Query Switch On/Switch Off  

Activate View  

Active View State  

Add Component  

Add Family  

Add Leader   

Aligned Section View/Section Cut     

Anchor Point  

Automatic Grouping   

Basic Dimension   
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Bold  

Capture     

Capture Management  

Center Justify  

Check Validity    

Clipping Plane     

Constructed Geometry Creation  

Constructed Geometry Management    

Coordinate Dimensions   

Copy Object Format   

Correlated Deviation  

Correlated Deviations  

Create Constructed Geometry  

Create/Define hyperlinks   

Cumulated Dimensions   

Current State  

Curvilinear Dimensions   

Custom Report   

Datum    

Datum Feature  

Datum Target    

Default Annotation  

Deviation  

Deviations  

Dimension Line  

Dimensions    

Disabling 3D Annotations  

Display 3D Grid  

Display Capture   

Display Grid  

Distance Between Two Points   

Enable/Disable Tolerancing Sets by List   
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Exit from Capture   

Filter    

Flag Note    

Flag Note with Leader   

Font Name  

Font Size  

Frame  

Free rotation  

Front View  

Generative Dimension   

Geometrical Tolerance     

Geometry Canonicity Re-specification  

Geometry Connection Management     

Horizontal Position  

Insert Symbol  

Instantiate From Document  

Invert Normal  

Italic  

Left Justify  

Manage associativity  

Manage Constructed Geometry  

Managing Associativity Between Elements   

Manual Grouping   

Mirror Annotations    

Named views   

Normal View  

Note Object Attribute     

Numerical Display Description  

Offset Section View/Section Cut   

Orientation  

Overline  

Partial Surface   
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Position along Normal Axis  

PowerCopy Creation  

Powercopy Creation  

Precision  

Projection View   

Properties    

Report   

Right Justify  

Roughness    

Save In Catalog  

Save in Catalog  

Section Cut  

Section Cut (Annotation Plane)  

Section Cut View  

Section View   

Section View (Annotation Plane)  

Select Annotations  

Select Camera  

Select Views/Annotation Plane  

Set Current  

Snap to Point   

Stacked Dimensions   

Strikethrough  

Style  

Subscript  

Superscript  

Text     

Text Parallel to Screen   

Text with Leader     

Thread Representation Creation  

Tolerance  

Tolerance Description  
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Tolerancing Advisor     

Underline  

Unset Current  

Vertical Position  

common datum  
Constructed geometry

automatic creation  

create   

manage  

manual creation  
contextual command

Add a Breakpoint  

Add an Extremity  

Add an Interruption  

Add Tolerance  

All Around  

Annotation Links      

Attribute Link  

Create Orientation Link  

Create Positional Link  

Delete Orientation Link  

Delete Positional Link  

Edit Generative Parameter  

Query Object Links  

Remove Interruptions  

Replace Datum Reference Frame  

Set as Default  

Switch to orientation free leader  

Switch to perpendicular leader  

Symbol Shape  

Transfer to View/Annotation Plane  

coordinate dimensions  

cumulated dimensions  
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D
datum

creating  
datum reference frame

creating  

datum system  

datum target  

datum triangle  

default tolerance  

dimensions  
dimensions

basic  

coordinate  

cumulated  

curvilinear  

stacked  

dot  

E
extraction views

aligned section view/section cut  

offset section view/section cut  

F
filtering annotations  
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G
Geometrical Tolerance   

geometrical tolerances  
Geometry Connection Management

add component  

add geometry  

check validity    

delete  

geometry highlight  

reconnect  

rename  

scope range  

green reference axis  

I
identifier  
introducing

Tolerancing Advisor  

ISO  

ISO 10578-1992  

ISO 10579-1993  

ISO 1101-1983  

ISO 14660-1  

ISO 14660-2  

ISO 1660-1987  

ISO 2692 Amd 1-1992  
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http://pop.dia.uniroma3.it/catia/online/fdtug_C2/fdtugix.htm (8 of 15)10/21/2004 7:47:52 PM



Index

ISO/DIS 5459-2  

ISO/FDIS 1101-1998  

ISO/TS 17450-1999  

isolated annotations  

L
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leader

creating  

M
manage

capture  

managing view/annotation plane associativity  

manipulator  

modifiers  

N
Non-semantic 3D Annotations  

normative references  
Note Object Attribute

concept  

editing  

filtering  
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From text  

hyperlinks   

instantiate  

Store into a catalog  
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Scope Range  

P
Power copy
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saving into catalog  
properties

advanced text  

Annotation Set Detail  

basic text  

copy  

group  
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Set as Default  

setting  
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Text Properties toolbar  
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querying 3D annotations  
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