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Overview
Welcome to the Automotive Body in White Fastening User's Guide !
This guide is intended for users who need to become quickly familiar with the product. 
 
This overview provides the following information: 

●     Automotive Body in White Fastening in a Nutshell 

●     Before Reading this Guide 

●     Getting the Most Out of this Guide 

●     Accessing Sample Documents 

●     Conventions Used in this Guide 

Automotive Body in White Fastening in a Nutshell
The Automotive Body in White Fastening application is a product dedicated to the design of 
Automotive Body In White Fasteners. It supports welding technologies and mechanical clinching, 
along with Adhesives, Sealers, and Mastics.

For each of these general fastening technologies, specific Fastening process codes along with their 
matching relevant parameters can be set-up in an Application Parameters Start-Up file. This file can 
be fully customized by the customer, according to company or industry specific standards 
requirements. Its feature-based approach offers both a highly structured and intuitive design 
environment.

Fasteners can be gathered so that to connect specific contact zones of the parts to join. You can 
create, edit and delete spot like fasteners.

In addition to placing the fasteners, reports can be issued from the application in order to list: data 
can be exported (respectively imported) to a neutral ASCII text format, providing opening with 
customer legacy systems.

As a scalable product, Automotive Body in White Fastening can be used in cooperation with other 
products such as Assembly Design and Generative Shape Design. 

Before Reading this Guide
Before reading this guide, you should be familiar with basic Version 5 concepts such as document 
windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure 
User's Guide that describes generic capabilities common to all Version 5 products. It also describes 
the general layout of V5 and the interoperability between workbenches.

You may also like to read the following complementary product guides: 

●     Part Design,

●     Assembly Design,

●     Generative Shape Design



Getting the Most Out of this Guide 
To get the most out of this guide, we suggest that you start reading and performing the step-by-step 
Getting Started tutorial. 

Once you have finished, you should move on to the Basic Tasks and Advanced Tasks sections, which 
deal with handling all the product functions. 

The Workbench Description section, which describes the Automotive BiW Fastening workbench, and 
the Customizing section, which explains how to set up the options, will also certainly prove useful. 

Navigating in the Split View mode is recommended. This mode offers a framed layout allowing direct 
access from the table of contents to the information.

Accessing Sample Documents 
To perform the scenarios, sample documents are provided all along this documentation. For more 
information on accessing sample documents, refer to Accessing Sample Documents in the 
Infrastructure User's Guide.

 

 

http://arbre1dsy/spuCXR14/Doc/online/bascuabf_C2/bascuabf0000.htm


Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary



Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document 
window, ...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

New Functionality

Measure Tools

Enhanced Functionalities

Getting Started

Customizing the BiW Fastening Application Standard File 
New discretization parameter for curvebeads
New Shape Definition attributes for BiW fasteners: Shank, Shank with Head, Shank with Head 
and Foot

Defining Symbols
New symbols: 136, 137, 138, 139

Setting up a CATIA Reference Product with BiW Fastening Parameters 
New design rules: Joined thickness normal alignment, Maximum/Minimum thickness ratio, 
Spot center distance to flange edge, Spot border distance to flange edge, Diameter overhang

Basic Tasks

Creating SpotPoints
The ''On Support Surface'' location method is replaced by ''On Surface'' to support the 
location of a spotpoint on any selected surface belonging to a product component of the BiW 
joint
You can select a circle when using the On Surface, On Point and Explicit location methods
Using the Bitangent Circle Center location method, if the curves are non coplanar, the center 
of gravity is computed 
New K Axis option to define the orientation of the spotpoint
It is now possible to associate an annotation to a spotpoint
It is now possible to assign a layer to a spot fastener
It is now possible to apply visualization filters on spot fasteners

Creating Mechanical SpotPoints
New process type: rivet

Creating Curvebeads
New location method: Intersect
New parameters: K axis orientation and discretization
It is now possible to associate an annotation to a curvebead
It is now possible to assign a layer to a spot fastener
It is now possible to apply visualization filters on spot fasteners

Creating Structural Reports
New attributes: Layer number, K flag, I flag, X, Y, Z coordinates, normal reference, and 
tangent vector
Deactivating features are no longer reported

Creating Flat Reports
A new version of the flat report is available

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm#hj-V5R14
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm#hj-V5R14quatro
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm#hj-V5R14cinque
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm#hj-V5R14six
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm#hj-V5R14ter
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm#hj-V5R14bis
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0520.htm#hj-V5R14bis


New attributes: Layer number, X, Y, Z coordinates, normal reference, and tangent vector
Deactivated features are no longer reported

Exporting
New attributes: Layer number, K flag, I flag, X, Y, Z coordinates, normal reference, and 
tangent vector
Discretization value when exporting a curvebead
Deactivated features are no longer reported

Isolating Features
You can now isolate all elements from the parameters in the specification tree

Advanced Tasks

Running the Fastening Rules Analysis
New rules: Thicknesses normals alignment, Maximum/Minimum thickness ratio, Fastener 
center distance to flange edge, Fastener border distance to flange edge, Diameter overhang

Integration With Drafting
New 2D symbols associated to 3D symbols

Customizing

General Settings
New option to allow the creation of unsaved data from Enovia

BiW Fastening Application Display User Settings 
New Fastener axis orientation parameters to be displayed in the 3D geometry

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0520.htm#hj-V5R14ter
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0520.htm#hj-V5R14


Getting Started
The following tutorial aims at giving you a feel of what you can do with Automotive Body in 
White Fastening. It provides a step-by-step scenario showing you how to use key capabilities.

The tasks proposed in this section are:

Customizing the BiW Fastening Application Standard File
Adding a New Process Type

Defining Symbols
Entering the Workbench

Setting up a CATIA Reference Product with BiW Fastening Parameters

 

All together these tasks should take 20 minutes to complete.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfuggs06.htm


Customizing the BiW Fastening Application
Standard File 

The Automotive BiW Fastening Application natively supports  the most common BiW  joining 
process categories: Welding, Adhesive, Sealant, and BiW Mechanical. An additional  
"Unspecified" Process Category is supplied in order to classify specific technologies that do not 
belong to the application natively supported process categories.
For each general process category, specific fastening process codes along with their matching 
relevant parameters can be set-up in the Application Parameters Start-Up standard file named 
GBF_STD.
Here are the steps to customize the standard file:

●     Locating the CATIA BiW Fastening Application Standard file in the CATIA run-time 
environment

●     Customizing the BiW Fastening Application Standard GBF_STD.xls  file

●     What can be modified?

●     Saving the GBF_STD excel file and keeping its name

  

Locating the CATIA BiW Fastening Application 
Standard file in the CATIA run-time environment  
The "GBF_STD" Standard  file is located  according to the reffiles/GbfStandards path from 
CATIA run time view root directory (intel_a for Windows, aix_a for IBM UNIX, irix_a for SGI 
UNIX, solaris_a for SUN Unix, hpux_a for HP UNIX). Two extensions are provided for this file: 

●     .xls  for  Windows Operating System run time usage

●     .txt  for  UNIX operating system run time usage

For example, you will find in the directory: 
MyCompanyRootRuntimeview/intel_a/reffiles/GbfStandards, the following files:

●     GBF_STD.xls which is the master file that can be edited with the Excel Windows Editor

●     GBF_STD.txt  which must be generated from the master GBF_STD.xls file using the Save as 
*.txt command in Excel

Customizing the BiW Fastening Application 
Standard GBF_STD.xls file   

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/images/ABF_STDNLS.xls
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/images/ABF_STD.txt


The  GBF_STD.xls standard file can be customized by the company data administrator, 
according to his company or industry specific standards requirements.
This file features two columns: 

●     the first column identifies the parameter name

●     the second column specifies the list of possible values of the identified parameter : value1, 
<value2>,  value3. (brackets <>, specify the default value: i.e. value2 is the default value 
of the previous list)

Rows are divided into six chapters delimited by excel row cells and filled in different colors. 
●     The first chapter (light green fill-in) specifies the list of CATIA application parameters 

supported whatever the fastener process category can be. This chapter is itself subdivided 
into three sections: 

❍     A: CATIA V5 BiW Fastening Application parameters
■     Number of digits for fixed-length

❍     B: CATIA V5 BiW Joint and Joint Body Parameters

❍     C: CATIA V5 BiW  Fastener parameters 
■     1. Life Cycle parameters

■     2. Fastener type parameters

■     3. Fastener Parameters

●     The five additional chapters enable to set-up the list of the fasteners parameters 
respectively for each specific process type and for each supported process category: 

❍     Welding (yellow  fill-in)

❍     Adhesive (cyan fill-in)

❍     Sealant (magenta fill-in)

❍     BiW Mechanical (green fill-in)

❍     Unspecified (brown fill-in)

These chapters are themselves subdivided into sections C-1, C-2, C-3.

What can be modified?  

Pre-defined values of each BiW Fastening general parameter 
identified in the sections C-2, C-3 of chapter 1

 

Modifying the list of values (column 2) for each row parameter of Chapter 1, you can 
customize: 

●     the applicable process categories (PCATS parameter) value list:  WLD (Welding), ADH 
(Adhesive), SEA (Sealant), BWM  (BiW Mechanical), U (Unspecified Process Category).
For example, you can narrow this list to:  WLD, BWM if you plan to use only Welding and 
BiW mechanical fastening technologies.



 
●     the list of applicable fastener types (FTY parameter):

❍     SpotPoint

❍     SpotProjection

❍     CurveBead

 

Note that if you do not set up the Fastener Types in the standard file, then the 
corresponding Fastener commands will be appear grayish meaning that they 
cannot be activated.

 

●     the assigned color for 
each process category 
(WLD_Color 
parameter, ADH_Color 
parameter, 
transparent, etc...).

WLD_Color TRANSPARENT

   

 

●     the assigned symbol 
to thickness count if 
necessary:

❍     By default, the 
code 111 is 
assigned to 1T 
Thickness Count -

> 

❍     By default, the 
code 151 is 
assigned to 2T 
Thickness Count -

> 

❍     By default, the 
code 113 is 
assigned to 3T 
Thickness Count -

> 

❍     By default, the 
code 114 is 
assigned to 4T 
Thickness Count -

> 

Please refer to the 
Symbols table for the 
available list of symbols.

// Set-up the attached symbol to Thickness Count  
> NTH_1_SYM 111
NTH_2_SYM 151
NTH_3_SYM 113
NTH_4_SYM 114



 

●     the list of possible process categories for each fastener (SpotPoint_PCA parameter): this list 
must be set up as a subset of the PCATS parameter values.
For example, you can narrow the list to WLD if you plan to use only Spot Welding 
technologies.

 

●     the lists of possible process types values for each process category (PCAName_PTYPS 
parameter). For instance: 

❍     the list of Welding process types (WLD_PTYPS parameter): <21>;14;141;52;UNSW

●     the list of possible values of each CATIA BiW Fastener attribute: 
❍     robustness ( ROB parameter):  A,B,C,D,U

❍     regulation  (REG parameter): A,B,C,D,U

❍     finish (FIN parameter ): A,B,C,D,U

❍     material (MAT parameter):  MAT1, MAT2, etc.
For each fastener attribute, you can choose your own set of code values (except for the 
discretization).
For example, you can choose to customize: 

■     the list of values of the robustness attributes to: A,B,C,D,E,U

■     the list of values of the regulation attributes to : A,B

 
●     the specific "relevant" 

value for each 
classification 
parameters: 
Robustness, Finish, 
Regulation, etc. and 
assign to this value a 
Symbol Mark Code:

❍     Example1: Assign 
Mark code "1" to 
Robustness 
parameter value 
C.

❍     Example2: Assign 
Mark code "1" to 
Finish parameter 
value A

 
ROB_C_SYMO1

FIN_A_SYMO 1



 Each attribute value (A, B, etc) is the coded value of the attribute as it will be stored in the 
Data Model.

You can provide a end user translation for each parameter coded value in the CATIA NLS 
resource file CATBfmAttributesNLS.txt . In this file, each parameter coded value is identified by 
a key built by concatenating the name of the parameter and the coded value, separated by the 
"_" string separator. The translation of the parameter is provided by setting the parameter 
value key to its translation text.
For example the line: ROB_A = "Critical" provides the end-user with the "Critical" translation of 
the coded value A of the Robustness parameter (ROB).

The CATBfmAttributesNLS.txt file is located in your runtime environment in 
MyCompanyRootRunTimeView/intel_a/resources/msgcatalog.

 
You must not remove any parameter belonging to the Chapter 1 rows.

 
The list of pre-defined fastener process type parameters belonging 
to chapters 2 to 6 

 You can modify this list, either by:
●     modifying the list of values for each row containing the pre-defined specific fastener 

process type parameters, or

●     removing the pre-defined specific fastener process type parameters you are not interested 
in, or

●     adding your company specific fastener process type parameters consistently with the list of 
process type values set up in Chapter 1

  
Let's take an example for a spotpoint of Process Category = Welding and Process Type = 
Resistance. You can set: 

●     the list of specific process types code values (SpotPoint_WLD_PTY parameter): 
<21>;14;141;52;UNSW
In this list, the code value <21> matches the ISO code for Resistance Welding.

●     the list of the applicable standard attributes (SpotPoint_21_APAT parameter): you can 
specify the list of attributes you consider as relevant for this process type. The attributes 
strings must be chosen among the CATIA list: ROB;REG;FIN;GFL;IFL;MID. 
For a curve fastener, its discretization parameter (DIS) is an added applicable attribute.

●     the applicability or the non applicability of an add-on material (SpotPoint_21_AMAT 
parameter).

●     the list of possible Shape Definition values (ASDF) of each parameter. The attribute strings 
must be chosen among the values: PT3 (3DPoint);HSP (Hemisphere);SH 
(Shank);SHH(Shank with Head);SHF(Shank with Head and Foot).

●     the list of possible string code values of each parameter (SpotPoint_21_ROB, 
SpotPoint_21_REG, etc). For a curve fastener, its discretization parameter 
(CurveBead_PTY_DIS values) must be chosen among the SAG and STEP values.

●     the assignment of a graphic symbol  (SpotPoint_21_SYM parameter)
Refer to the Symbols table for the available list of symbols.



Saving the GBF_STD excel file and keeping its 
name   

●     The data administrator saves this excel file by keeping its original name (GBF_STD.xls  file 
for WINDOWS or GBF_STD.txt  (Tab delimiter) for UNIX) and extension (.xls), as the name 
will be recognized by the application.

●     On Unix, the GBF_STD.txt file must be generated from the master GBF_STD.xls file or by 
using the Save as *.txt command in Excel.

Here is an example of how to add a new process type named "MyWldType" for a Welding 
SpotPoint. 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfuggs06.htm


Adding a New Process Type  

This task shows how to add a new process type named "MyWldType" for a Welding SpotPoint.

1.  Add MyWLDType value in the list of the Welding Process Type possible values of the WLD_PTYPS parameter in the Section C-2, 

Chapter 1 (light-green fill-in). 

// Set-Up Welding Process Types   reference Codes 

WLD_PTYPS <21>;14;141;52;UNSW;MyWLDType 

2.  Add MyWLDType value in the list of the Welding Process Type possible values for a Welding SpotPoint of the SpotPoint_WLD_PTY 

parameter in the section C-2, Chapter 2  (Welding Section, yellow fill-in)

// SECTION C-2: WELDING FASTENER Type PARAMETERS  

//   

//Set-Up Welding Process Types for Each applicable CATIA V5 BiW Fastener 
Shape Type ISO Norm  reference Codes 

SpotPoint_WLD_PTY <21>;14;141;52;UNSW;MyWLDType 

3.  Define which Fastener parameters are applicable to this SpotPoint and their values in the Section C-3, Chapter 2 (Welding Fastener 

Parameters Section, yellow fill-in).

 

Please refer to the Symbols table to have further information on existing symbols.

4.  In addition, you have the possibility to translate the coded value MyWLDType. You can provide this translation by modifying the 

CATBfmAttributesNLS.CATNls files located in resources/msgcatalog/

Here is an example using English.
In the appropriate file, add PTY_MyWLDType key like this:
// Process Type Attribute Code Values
// -------------------------------------------------------------------------------
PTY_14   = "TIG (14)";
PTY_141  = "TIG (141)";
PTY_21   = "Resistance (21)";
PTY_52   = "Laser (52)";
PTY_MyWLDType = "My Process Type Name";
//
PTY_UNSW = "Unspecified Welding";

5.  Check the modifications in CATIA V5: import this standard and create a Welding SpotPoint, with the added process Type 

MyProcessTypeName.

file:///E|/www/spuCXR14/AbfEnglish/abfug.doc/src/abfuggs04.htm


Defining Symbols 

The following table lists all the symbols used in the Automotive Body In White Fastening 
workbench.

Symbol Value

100

101

110

111

112

113

114

121

122

123

124

125

131

132

133

134

135

136

137

138

139

140

141

142



151

152

153

154

161

162

171

172

173

200

201

211

221

231

241

251

301

311

321

331

341



Entering the Workbench 
The first task will show you how to enter the Automotive BiW Fastening workbench.

The only pre-requisite for this task is to have a current CATIA V5 session running.

1.  Choose Automotive BiW Fastening from the Start -> Shape menu, or click the Automotive BiW Fastening 

icon  from the Welcome to CATIA V5 dialog box.

The Automotive BiW Fastening workbench is displayed and ready to use.

The workbench looks like this:

If you wish to use the whole screen space for the geometry, remove the specification tree clicking off the View -> 
Specifications Visible menu item or pressing F3.



Setting up a CATIA Reference Product
with BiW Fastening Parameters  

It is essential to define Automotive BiW Fastening parameters in a product in order to create 
BiW features within this product. This task shows you how to set up the Automotive BiW 
Fastening parameters in a reference product. Nevertheless, Automotive BiW Fastening 
parameters are automatically defined when you create BiW Features (BiW Joint, BiW Joint Body 
BiW Fasteners) in a reference product.

1.  Click the Automotive BiW Fastening Parameters  icon.

The Automotive BiW Fastening Parameters dialog box is displayed.

 



2.  Click the Import button to import the default standard file.

The application standard file appears in the BiW Fasteners Set-Up Standard window.
 

 
You can set up BiW Fastening rules:

 

Naming Rules 
 

 You can define a naming rule to automatically name fasteners that will be further created. 
The naming rule consists in an alphanumerical prefix followed by a numerical part (the 
"number"), then by another alphanumerical suffix. The  number has a fixed length as defined 
in the default standard file.

 
3.  Key in the naming rule's Prefix string. Each fastener's name will start with this prefix. 

A default prefix, Joint Element. is proposed.

4.  Key in the naming rule's Suffix string. Each fastener's name will end with this suffix. 



 
Prefix and suffix strings can contain blanks.

 
5.  Define the naming rule's Start number using the spinners.

Modifying this number automatically resets the Next number field that shows what the 

name of the next fastener to be created will be, if the naming rule is active.

6.  Define the Step to be added to the current number to obtain the next number.

The modification of the step does not change the value of the Next number, but will 

be effective for the computation of the next one. The Next number field displays the 

 
●     The Activate automatic naming check box allows to activate the naming rule using the 

above parameters for all fasteners to be next created.

●     The Check name uniqueness check box allows to check, each time a fastener is created 

or modified, that its name is not already defined in the product structure.

If the name is already given to another fastener, an error message is issued and you are 

prompted to manually set the ID.

 For instance, if the prefix is set to ''My Fastener'', the suffix to ''SSS'', the step to 10 and the 
start number to 100, the next fastener's name will be: ''My Fastener 01 00100 SSS''.
Note that quotes only show blanks, they will not be part of the resulting fastener's name.

Check Rules  
 



You can define design rules to automatically check parameters at creation or modification time.

 

●     The Thickness count option enables to check the number of thicknesses when creating a 

jointbody. 

This number should be not be greater than the maximum thickness count defined here.

●     The Fastener location on surface option enables to detect all fasteners that are not 

located on surfaces.

●     The Fastener normal vector with respect to the closest surface option enables to 

check the fastener's normal vector and the fastener's normal vector at the projection on 

the closest surface.

●     The Joined Thicknesses Crossing option enables to check whether the fastener crosses 

all the specified thicknesses of the jointbody.



●     The Joined thicknesses normals alignment option enables to specify an angular 

accuracy (in degree) between the normal of the joint element and those of all crossed 

thicknesses.

●     The Maximum/Minimum thickness ratio option enables to compute the maximum 

tolerance between the minimum thickness and the maximum thickness.

●     The Thickness gap option enables to check the gap value between two joined components 

crossed by a given fastener (this accounts for the thickness defined on each zone).

This value is included between a minimum and a maximum value defined here.

●     The Minimum spot spacing option enables to check the minimum spacing between two 

spotpoints.

Selecting curves is not taken into account in any case (for instance if nothing is selected).

This number should be not be less than the minimum spacing defined here.

 
●     The Spot center distance to flange edge option enables to specify a minimum distance 

(in mm) from the fastener's center location to the closest flange edge.

●     The Spot border distance to flange edge option enables to specify a minimum distance 
(in mm) from the fastener's border location to the closest flange edge.

●     The Diameter overhang distance option enables to specify a maximum overhang 
distance (in mm) of the fastener's diameter to the closest flange edge.

  
If one of the above rules fails, an error message is issued and the joint element 
cannot be created.

7.  Click OK to validate the parameters and close the dialog box.

The feature is added in the specification tree.

Had you activated all the rules, the specification tree looks like that:



  
 

●     You can edit the rules by double-clicking on one of them in the specification 
tree: the Automotive BiW Fastening Parameters opens.

●     If you expand the tree (for the Naming Rules for instance), you can edit 
the parameters associated to the rule by double-clicking them.



Basic Tasks
Creating Joints

Creating Joint Bodies
Creating Spot Fasteners

Displaying Process Category Parameters
Creating Curvebeads

Using Tools
Reporting
Exporting
Importing

Isolating Features
Transforming

Copying/Pasting elements
Renaming Features

Editing Fasteners' Properties

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0600.htm


Creating Joints  

This task enables to create a joint, that is a set of two or more parts, then edit it.

Open the Joint1.CATProduct document.

There are several ways to create a joint: 

●     select the components then click the BiW Joint  icon.

●     click BiW Joint  icon and select the components (this is the example for our scenario).

1.  Click the BiW Joint  icon from the Automotive BiW Fasteners toolbar.

 The BiW Joint Definition dialog box is displayed.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Joint1.CATProduct


 2.  Give a new name for the Assembly Joint, "New Joint.1" for example.

3.  Select First part as the first component to join.

4.  Select Second part as the second component to join.

The list displays the name of these components as well as their part number. The Part Version 

field shows possible revision numbers.

5.  Click OK to create the joint.

●     The Forecast Elements Count field allows you to define a number of fasteners this joint is 
supposed to contain for further verifications.

●     The Create Joint Body after OK button is automatically selected. Deselect it to only 
create the joint.

  
"New Joint.1" appears as an entity below the Assembly node in the specification tree. The 
name of the parts it comprises is indicated between brackets.



1.  Double-click the New Joint.1 from the specification tree.

The BiW Joint Definition dialog box is displayed.

2.  Select the component you wish to remove.

3.  Click the Remove button.

4.  Click OK in the BiW Joint Definition dialog box.

 

 The selected component is deleted from the BiW Joint Definition dialog box.

 

Removing a Component 



 

 

Replacing a Component 
1.  Double-click the New Joint.1 from the specification tree.

The BiW Joint Definition dialog box is displayed.

2.  Select the component you wish to replace.

3.  Click the Replace button.



 

 
4.  Select the new component either from the geometry area or the specification tree.

The part component has been updated in the dialog box.

5.  Click OK in the BiW Joint Definition dialog box.

 



 

Creating a joint with no components 
Open the Joint1.CATProduct document.

1.  Click the BiW Joint  icon from the Automotive BiW Fasteners toolbar.

 The BiW Joint Definition dialog box is displayed.

2.  Click OK to create the joint.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Joint1.CATProduct


 

A Warning dialog box is displayed.

3.  Click Yes in the Warning dialog box to confirm the operation.

 
When creating a duplicated Joint, the same Warning dialog box appears.

  
 

 
●     "Assembly Joint.1" appears as an entity below the Assembly node in the specification tree.

●     A mask is displayed on its icon to identify that it is not valid.



 

 

Adding Components    
Create a joint with no components for instance. 

1.  Double-click the Assembly joint.1 from the specification tree.

The BiW Joint Definition dialog box is displayed.

 



 
2.  Select the components you wish to add, for instance FirstPartA and SecondPartB either 

from the geometry or the specification tree.

The selected components are automatically displayed in the dialog box.

3.  Click OK to create the joint.

 



Creating Joint Bodies  

This task shows how to create a joint body, that is a container for joint elements.

Open the Joint1.CATProduct.

There are several ways to create joint bodies:

●     select the publications, and click the Joint Body icon . If no joint was created 

previously, it is automatically created; it links the corresponding components. The joint 
body links the selected publications.

●     select the components, and click the Joint Body icon . If no joint was created 

previously, it is automatically created; it links the corresponding components. The 
connected zones of this joint body are not specified.

●     a joint is already created: select it in the specification tree, and click the Joint Body icon 

.

●     a joint is already created. Click the Joint Body icon  and select the joint in the 

specification tree.

●     during the creation of a joint, if the Create Joint Body after OK button is selected, when 
you click OK, the BiW Joint Body Definition dialog box automatically displays (this is the 
example for our scenario).

1.  Click OK in the BiW Joint definition dialog box.

The Joint Body Definition dialog box opens.

2.  Give a new name for the Joint Body, "New Joint Body.1" for example.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Joint1.CATProduct


The List of joined Contact Zones display the Zone ID. 

4.  Define whether the zone is the Support zone.

5.  Define whether the zone is a Hem.

 The material and the thickness can be defined using the Thin Parts Attribute 
command in the Generative Shape Design workbench.
Please refer to the Applying a Thickness chapter in the Generative Shape 
Design documentation.

6.  Define the stacking and the thickness count depending on the number of joined zones.



 You can click the down arrow to display the stacking toolbar and choose the stacking type:

●     Lap

●     Hem

●     Unspecified: you are able to modify the thickness count using the spinners, depending on 

the number of joined zones

 

 The Forecast Elements Count field allows you to define a number of fasteners this joint body is 
supposed to contain for further verifications.

7.  Click OK to create the joint body.

"New Joint Body.1" appears below "New Joint.1" (created in the previous task) in the 

specification tree.

 When creating a Joint Body with one zone, a second one  is automatically 
created. You can edit the second zone and delete it if needed.

 
Managing multi-zones, whether published or not, is possible: one joint body can join several 
zones for a same component.

Removing a Zone
1.  Double-click the New Joint Body.1 from the specification tree.

The BiW Joint Body Definition dialog box is displayed.

2.  Select the zone you wish to remove.

3.  Click the Remove button to remove this zone.

A zone should be first selected in the list, and one zone at least must be connected for 

a linked component. If not, the zone can not be removed.

4.  Click OK in the BiW Joint Definition dialog box.

 
Adding an Unspecified Zone



1.  Double-click the New Joint Body.1 from the specification tree.

The BiW Joint Body Definition dialog box is displayed.

2.  Click the Add Unspec button to add an unspecified zone in the zones list for the 

selected corresponding component.

A zone should be first selected in the list.

 

Replacing a Zone
1.  Double-click the New Joint Body.1 from the specification tree.

The BiW Joint Body Definition dialog box is displayed.

2.  Select a zone to replace by another one, either by:

❍     selecting a zone published by the corresponding component in the specification tree 

or in the 3D geometry, or

❍     selecting the name of the zone in the combo list.



Creating Spot Fasteners  
Creating Welding SpotPoints
Creating Adhesive SpotPoints
Creating Sealant SpotPoints

Creating BiW Mechanical SpotPoints
Creating Unspecified SpotPoints
Creating SpotProjection Welds
Creating Multi-Selected Spots

Repeating SpotPoints
 

 When working with spot fasteners, it is possible to:

 
●     valuate spot fasteners' attributes of type ''Dimension'' from a measure. However these 

dimensions are not associative, that is to say they are not Knowledge-integrated.

●     create and associate an annotation to a spot fastener.
For further information, refer to the 3D Functional Tolerancing and Annotation 
documentation.

 

●     assign a layer to a spot fastener and published joined contact zones. A layer number is 
assigned to each published zone.
For further information, refer to the Using the Graphic Properties Toolbar chapter in the 
CATIA Infrastructure User Guide.

●     apply visualization filters, that is a group of layers, to visualize (or not) only the spot 
fasteners located on the layers in the filter.
For further information, refer to the Using Visualization Filters chapter in the CATIA 
Infrastructure User Guide.
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Creating Welding SpotPoints  

This task shows how to create a welding spotpoint.

There are several ways to create a spotpoint: 
●     a joint and a jointbody are already created: click the desired icon and select the jointbody in the 

selection tree.

●     a joint and a jointbody are already created: select the jointbody in the selection tree and click the 
desired icon (here is the example used for our scenario).

●     no jointbody is created. Select the components or the publications, and click the desired icon: a joint and 
a jointbody are created if needed.

Open the SpotPoint1.CATProduct document.

 
Make sure the SpotPoint Fastener Type is set up in the standard file.

1.  Select the jointbody in the specification tree.

2.  Click the BiW Welding SpotPoint  icon from the Welding toolbar.

The BiW SpotPoint Fastener Definition panel opens.
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3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a spotpoint is created using this standard. If not, you are able to 

define your own values for each attribute.

If the last location method is different from Explicit, the ABF application creates a specification part 

associated to the Assembly Joint if this specification part does not already exist.

file:///E|/www/spuCXR14/AbfEnglish/abfug.doc/src/abfuggs05.htm


 
4.  Define the following parameters:

●     Type

●     Functional Parameters

●     Shape 

●     Location

●     K Axis

 

Type
 

5.  Select the process type.

 

Functional Parameters
6.  Define the design parameters:

●     Robustness

●     Regulation

●     Finish

●     More>>: allows you to define the Manufacturing parameters.

 

 

Shape
 

7.  Specify the material (if neccessary).

8.  Specify the shape of the spotpoint.

9.  Define its diameter.



 

Location
 10.  Select the location:

●     On Surface

●     On Point

●     From Curve on Surface

●     Along Curve

●     Intersect

●     Bitangent Circle Center

●     Explicit

 
On Surface

 

 

 

1.  Select a surface or a point to indicate the spotpoint location. 

You can as well select a circle instead of a point: the center of the circle is computed to get the 

reference point.

The spotpoint will be created on the selected zone, which may not be a support zone of the joint 

body.

2.  Optionally select a direction.

3.  Click More>> to:

●     display the Reference Point,

●     display the Direction

●     optionally modify the distance to the reference point.



 

 
On Point

 1.  Select a point.

You can as well select a circle instead of a point: the center of the circle is computed to get the 

reference point.

2.  Click More>> to:

❍     optionally modify the reference point type (coordinates or axis origin)

❍     optionally modify the distance to the reference point

❍     optionally modify the normal vector if the reference point do not lie on the surface.



 

 
From Curve On Surface

 1.  Select a curve lying on a surface.

Most of the times, a surface is selected by default.

2.  If needed, select a surface.

You can select a published surface from the drop-down list or choose No Selection if the surface to be 
selected cannot be found and select the desired surface in the 3D geometry.

 

 

3.  Modify the offset.

4.  Modify the Reference Point (extremity or middle of the curve).

5.  Modify the distance to the reference point.

6.  Define the distance type (length or ratio)

Note that steps 2 to 6 are optional.

 

For instance, define 15mm as the offset, select the extremity as the reference point and choose a distance 

of 30mm from the reference point.



 

 The Repeat object after OK button appears in the BiW SpotPoint Fastener Definition. 
Refer to the Repeating Spots to create more spotpoints using the currently created spot 
point as reference.

 
Along Curve

 1.  Select a curve.

2.  Select the reference point (extremity or middle of the curve)

3.  Modify the distance to the reference point. 

4.  Define the distance type (length or ratio)

5.  Modify the normal vector if the reference point does not lie on the surface.

Note that steps 2 to 5 are optional.



 

 The Repeat object after OK button appears in the BiW SpotPoint Fastener Definition. 
Refer to the Repeating Spots to create more spotpoints using the currently created spot 
point as reference.

 Intersect 
 1.  Select the first and the second element.

Elements can either be two curves or a curve and a surface.

2.  Click More>> to optionally modify the normal vector if the reference elements do not lie on a 

surface.



 

 Bitangent Circle Center 
 1.  Select the first and the second curves.

They must not be parallel.

2.  Click More>> to:

❍     optionally select a support surface in the drop-down list or in the 3D geometry if the curves are 

not coplanar. In this case, the center of gravity of the circle is automatically computed.

❍     define the circle radius

❍     optionally modify the normal vector if the reference elements do not lie on a surface. 

  



 

 When several solutions are possible, click the Next Solution to move to another solution. When 

you click OK in the Bitangent Circle Center Location dialog box, the chosen spotpoint is created, 

and the next solution is proposed for creation. Click OK to create the second spotpoint, and so on 

until the last solution. You can click Cancel in the BiW SpotPoint Fastener Definition dialog box to 

only create one spotpoint or not to create any more spotpoint.

 

 
Explicit

 1.  Select a surface or a point where the spotpoint is to be created.
You can as well select a circle instead of a point: the center of the circle is computed to get the 
reference point.

2.  Click More>> to:

❍     optionally modify the spotpoint location

❍     optionally modify the normal vector if the reference point do not lie on the surface.



 
●     When the location method switches to Explicit, the specification part is automatically 

deleted if it is empty.

●     The fastener normal vector is automatically calculated if the fastener is based on a 
surface. Otherwise, the normal parameters need to be defined in the Normal Definition 
dialog box. In this case, if you do not manually define the fastener normal vector and 
validate this Joint Element, a warning panel is issued, asking you whether you wish to 
calculate it or not. 

 

K Axis
 11.  Define the orientation of the spotpoint by setting 

the K axis to either:

❍     Same as Surface Material

❍     Opposite to Surface Material

To visualize the K axis, the Fastening Axis Orientation 
Show option should be checked in Tools -> Options.

  

12.  Click OK to create the spotpoint.

The spotpoint (identified as Joint Element.xxx) is added to the specification tree, under the Joint 

Body node.

Note that:
●     the selection of geometrical elements must be done within the linked parts, except when using such 

options as Datum mode and Explicit locations.

●     when selecting a geometric specification (curve or point), it is recommended to select published 
elements in order to guaranty associativity between elements.

●     to authorize the selection of only published elements, check the following option using Tools -> Options 
-> Infrastructure -> Part Infrastructure -> General -> Only use published elements for 
external selection keeping links.

●     when the On Surface and Explicit methods are activated, the application will ignore the active Part 
Infrastructure setting Only use published elements for external selection and will enable the usage 
of non published external geometry.
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Creating Adhesive SpotPoints  

This task shows how to create a Body in White Adhesive SpotPoint.

There are several ways to create a spotpoint: 
●     a joint and a jointbody are already created: click the desired icon and select the jointbody 

in the selection tree.

●     a joint and a jointbody are already created: select the jointbody in the selection tree and 
click the desired icon (here is the example used for our scenario).

●     no jointbody is created. Select the components or the publications, and click the desired 
icon: a joint and a jointbody are created.

Open the SpotPoint1.CATProduct document.

 
Make sure the SpotPoint Fastener Type is set up in the standard file.

1.  Select the jointbody in the specification tree.

2.  Click the BiW Adhesive Point icon .

The BiW SpotPoint Fastener Definition panel opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/SpotPoint1.CATProduct


 
3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a spotpoint is created using this standard. If not, you 

are able to define your own values for each attribute.



4.  Define the spotpoint's following parameters:

●     Type

●     Functional parameters

●     Shape 

●     Location

●     K axis

5.  Click OK to create the spot point.

The spot point (identified as Joint Element.xxx) is added to the specification tree, under 

the Joint Body node.
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Creating Sealant SpotPoints  

This task shows how to create a Body in White Sealant SpotPoint.

 There are several ways to create a spotpoint:
●     a joint and a jointbody are already created: click the desired icon and select the jointbody 

in the selection tree.

●     a joint and a jointbody are already created: select the jointbody in the selection tree and 
click the desired icon (here is the example used for our scenario).

●     no jointbody is created. Select the components or the publications, and click the desired 
icon: a joint and a jointbody are created.

Open the SpotPoint1.CATProduct document.

 
Make sure the SpotPoint Fastener Type is set up in the standard file.

1.  Select the jointbody in the specification tree.

2.  Click the BiW Sealant Point icon .

The BiW SpotPoint Fastener Definition panel opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/SpotPoint1.CATProduct


 
3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a spotpoint is created using this standard. If not, 

you are able to define your own values for each attribute.



4.  Define the spotpoint's following parameters:

●     Type

●     Functional parameters

●     Shape 

●     Location

●     K axis

5.  Click OK to create the spot point.

The spot point (identified as Joint Element.xxx) is added to the specification tree, 

under the Joint Body node.
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Creating Mechanical SpotPoints  

This task shows how to create a Body in White Mechanical SpotPoint.

 There are several ways to create a spotpoint: 
●     a joint and a jointbody are already created: click the desired icon and select the joint body in the selection tree.

●     a joint and a jointbody are already created: select the jointbody in the selection tree and click the desired icon (here is the example used 
for our scenario).

●     no jointbody is created. Select the components or the publications, and click the desired icon: a joint and a jointbody are created.

Open the SpotPoint1.CATProduct document.

 
Make sure the SpotPoint Fastener Type is set up in the standard file.

1.  Select the jointbody in the specification tree.

2.  Click the BiW Mechanical Point icon .

The BiW SpotPoint Fastener Definition panel opens.

 

 
3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a spotpoint is created using this standard. If not, you are able to define your own values for each 

attribute.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/SpotPoint1.CATProduct


 
4.  Define the spotpoint's following parameters:

●     Type

●     Functional parameters

●     Shape 

●     Location

●     K axis

In our example, we used a particular Process Type: the rivet and particular shape definitions: shank, shank with head, shank with head and 

foot.

Hemisphere and Shanks definition are only available with Unspecified and Rivets process types.

O = shank base plane offset from selection point

L1 = head length
D1 = head diameter

d = shank diameter (shape diameter)
l = shank length

L2 = foot length
D2 = foot diameter

Default values:
D1 = D2 = dX2
L1 = L2 = d/3

Shank

1.  Define the Shank Base Offset.

2.  Define the Shank Length.
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1.  Define the Shank Base Offset.

2.  Define the Shank Length.
3.  Define the Head Diameter.
4.  Define the Head Length.

Shank with Head and Foot

1.  Define the Shank Base Offset.

2.  Define the Shank Length.
3.  Define the Head Diameter.
4.  Define the Head Length.
5.  Define the Foot Diameter.
6.  Define the Foot Length.

●     The Reset Defaults From Location button automatically reset the shank base offset and the shank length values according to the 
location of the spotpoint (computation of the crossed thicknesses), taking into account the gap between the crossed joined components.

●     The Reset Defaults From Diameter button automatically reset the default values of the head diameter and the head length values.

9.  Define the shank diameter.

10.  Define the spotpoint's location.

Selecting a circle to create a rivet automatically initializes the shank 
diameter.

Rivets cannot apply on non planar circles.

11.  Define the K axis:

❍     Same as Surface Material

❍     Opposite to Surface Material

Shank with Head

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm#location


12.  Click OK to create the spot point.

The spot point (identified as Joint Element.xxx) is added to the specification tree, under the Joint Body node.



Creating Unspecified SpotPoints  

This task shows how to create a Body in White SpotPoint.

There are several ways to create a spotpoint: 
●     a joint and a jointbody are already created: click the desired icon and select the joint body 

in the selection tree.

●     a joint and a jointbody are already created: select the joint body in the selection tree and 
click the desired icon (here is the example used for our scenario).

●     no joint body is created. Select the components or the publications, and click the desired 
icon: a joint and a joint body are created.

Open the SpotPoint1.CATProduct document.

 
Make sure the SpotPoint Fastener Type is set up in the standard file.

1.  Select the jointbody in the specification tree.

2.  Click the BiW SpotPoint icon .

The BiW SpotPoint Fastener Definition dialog box opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/SpotPoint1.CATProduct


3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a spotpoint is created using this standard. If not, you 

are able to define your own values for each attribute.



4.  Define the spotpoint's following parameters:

●     Type

●     Functional parameters

●     Shape 

●     Location

●     K axis

5.  Click OK to create the spotpoint.

The spotpoint (identified as Joint Element.xxx) is added to the specification tree, under 

the Assembly Joint Body node.
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Creating SpotProjection Welds  

This task shows how to create a welding spotprojection, which one of the connected zones is 
specified as a projection zone.

 There are several ways to create a spotprojection: 
●     a joint and a jointbody are already created: click the desired icon and select the jointbody 

in the selection tree.

●     a joint and a jointbody are already created: select the jointbody in the selection tree and 
click the desired icon (here is the example used for our scenario).

●     no jointbody is created. Select the components or the publications, and click the desired 
icon: a joint and a jointbody are created if needed.

Open the Projection1.CATProduct document.

1.  Select the jointbody in the specification tree.

 

 
2.  Click the BiW Welding SpotProjection   icon in the Welding toolbar from the 

Spot Welding sub-toolbar.

 

 
Make sure the SpotProjection Fastener Type is set up in the standard file.

 The BiW SpotProjection Fastener Definition dialog box opens.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Projection1.CATProduct


 

3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a spotprojection is created using this standard. If not, 

you are able to define your own values for each attribute.

4.  Define the Projection type:

●     Projection Component: specifies one of the Joints' components

●     Projection Part Number

●     Projection Zone: specifies one of the Joint Body zones and must belong to the component 
specified in the Projection Component field.



5.  Define the design of the spotprojection:

●     Robustness

●     Regulation

●     More>>: allows you to define the Manufacturing parameters.

 
The shape is necessary a 3D point.

6.  Select the location of the point: 

●     On Surface (as in our scenario)

●     On Point

●     From Curve on Surface

●     Along Curve

●     Explicit

 

For further information on the location methods, you can click the More>> button.
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7.  Click OK to create the spotprojection.

The SpotProjection (identified as Joint Element.xxx) is added to the specification tree, 

under the Joint Body node.



Creating Multi-Selected Spots  

This task shows how to create multi-selected spot fasteners.

Open the MultipleSpotPoints1.CATProduct document.

1.  Select the points located along the curve using the Ctrl key.

 

 

2.  Still holding the Ctrl key, select the joint body from the specification tree.

3.  Select the BiW Welding SpotPoint  icon.

 

 The BiW SpotPoint Fastener Definition dialog box displays as well as a preview of the reference 
spotpoint.
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5.  Click OK to validate the creation of multiple spotpoints.

Multiple spotpoints have been created.

 

 This capability is only available with the On Point, On Support Surface, and 
Explicit location options.



Repeating Spots

This task shows you how to repeat spots along a selected curve.

Open the Repeating1.CATProduct document.

1.  Double-click Joint Element.1 from the specification tree.

The BiW SpotPoint Fastener Definition dialog box opens.

2.  Select the Along Curve location.

3.  Check the Repeat after OK button to create more spot points using the currently created spot point as reference.

4.  Click OK.
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The BiW Fastener Repetition dialog box appears.

It shows:

●     the reference fastener referring to the currently created spotpoint.

●     the End Point being the extremity of the curve by default.

❍     You can choose the other extremity by clicking the Extremity button as well as selecting a point or a 

spotpoint.

❍     You can define the distance between the last created spot and its End Point in the Spacing field. By 

default the distance is computed using the Dist. To Reference value of the Reference Fastener from the 

Along Curve Location dialog box.

●     Uncheck the With end point if you do not want the last created spotpoint to be located on the end point. 
This option is automatically grayed out if the End Point is a spotpoint and as long as the spacing is 0mm.
You can manage the spacing and the end point when using the Instances parameter.

5.  Define the Parameters:

●     Instance(s): specifies the number of instances to be created and the last created spot corresponds to the curve End 
point. The spacing between two successive spots is computed.

●     Spacing: specifies the spacing value between two consecutive created spot points.

●     Instances & Spacing: specifies the number of instances as well as the spacing value. The spot points are created 
towards the end point.
In this case, spot points can be created after the end point.

6.  According to what you chose in the Parameters field, either define a value in the Instances field or in the Spacing 

one or in both of them.

When entering a value in the Instance field, the distance between two successive points is automatically calculated, spot 

points are equidistant and the last repeated spot point is positioned on the curve end point.

7.  Click OK to validate the repetition.



Instances (4) Spacing (20mm) Instances and Spacing (2 & 25mm)

 
This capability is only available with the Along Curve and the From Curve On Surface options.



Displaying Process Category Parameters 

This task shows you how to display the parameters for each process category by clicking the 
parameters icon available on every appropriate toolbar.
The dialog box displays the process category code, the imported standard (if it has been 
previously defined), and the assigned color.

 
●      Welding   

 
●      Adhesive   

 
●      Sealant   



 
●      Mechanical   

 
●      Unspecified   



Creating CurveBeads  
Creating Welding Curvebeads
Creating Adhesive Curvebeads
Creating Sealant Curvebeads

Creating Unspecified Curvebeads
Repeating CurveBeads

 

 It is possible to valuate curve fasteners' attributes of type Dimension from a measure. However 
these dimensions are not associative, that is to say they are not integrated in Knowledge. 

●     It is possible to create and associate an annotation to a curve fastener.
For further information, refer to the 3D Functional Tolerancing and Annotation 
documentation.

 

●     assign a layer to a curve fastener and published joined contact zones. A layer number is 
assigned to each published zone.
For further information, refer to the Using the Graphic Properties Toolbar chapter in the 
CATIA Infrastructure User Guide.

●     apply visualization filters, that is a group of layers, to visualize (or not) only the curve 
fasteners located on the layers in the filter.
For further information, refer to the Using Visualization Filters chapter in the CATIA 
Infrastructure User Guide.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0950.htm


Creating Welding CurveBeads 

This task shows how to create a BiW Welding CurveBead.

 There are several ways to create a curvebead: 
●     a joint and a jointbody are already created: click the desired icon and select the joint body in the selection 

tree.

●     a joint and a jointbody are already created: select the joint body in the selection tree and click the desired 
icon (here is the example used for our scenario).

●     no joint body is created. Select the components or the publications, and click the desired icon: a joint and a 
joint body are created if needed.

Open the ABF_CurveBead.CATProduct document.

 
Make sure the Curvebead Fastener Type is set up in the standard file.

1.  Select the joint body in the specification tree.

2.  Click the BiW Welding CurveBead  icon from the Welding toolbar.

 

 

The BiW CurveBead Fastener Definition dialog box 

opens.

3.  Specify whether you wish to use the existing 

standard or not.

If a standard has been imported, a curvebead 

is created using this standard. If not, you are 

able to define your own values for each 

attribute.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/ABF_CurveBead.CATProduct


If the last location method is different from Explicit, 
the ABF application creates a specification part 
associated to the Assembly Joint if this specification 
part does not already exist.

 

Type  
 

4.  Select the process type.

Functional parameters  
5.  Define the functional parameters of the curvebead:

●     Robustness

●     Regulation

●     Finish

●     More>>: allows you to define Manufacturing parameters.



 

●     Discretization Method:

❍     Unspecified: no discretization method is used. The default visualization is set in Tools -> 

Options -> General -> Display -> Performances -> 3D Accuracy.

❍     Sag: segments are defined on the curve according to the tolerance value set in the 

discretization parameter.

❍     Step:  equidistant points are created on the curve according to the value set in the 

discretization parameter.

●     Discretization Parameter: distance value for each curvebead depending on the chosen 

discretization method.

Both parameters will be used for the visualization of the curvebead and for the 

export/report.

 

Shape  
6.  Specify the material.

7.  Specify the definition: 

●     curve path

●     cylinder path

●     half cylinder path, etc.

 
8.  Define the diameter in the following cases:

●     Curve Path

●     Cylinder Pipe

●     Half Cylinder Pipe



 

 

 Curve Path  
 

 Cylinder Half Cylinder 
 

9.  Define the base and height in the following cases:

●     Diamond Pipe

●     Half Diamond Pipe

●     Rectangle Pipe

●     Half Rectangle Pipe

 

 

 Diamond Pipe Half Diamond Pipe 



 

 Rectangle Pipe Half Rectangle Pipe
   
 

Location  
 

 
10.  Select the location:

●     Along Curve

●     From Curve On Surface

●     Intersect

●     Explicit

According to the location you choose, different dialog boxes display, except when selecting the Explicit mode.
 

Along Curve
 

1.  Select the curve.

Green arrows appear in the 3D geometry to 

let you know the end and start point of the 

curvebead.

 
 



 

2.  Click the More>> button to display further 

information.

3.  From the Along Curve Location dialog box, click 

the Swap Start and End Points button to 

change the curve direction.

  

 
The Split Support Curve enables to trim the curvebead.

 

The curvebead will be created along the 
original curve.

  

 
From Curve On Surface

 

1.  Select a curve, for instance a part edge.

Most of the times, a surface is selected by 

default.

Green arrows appear in the 3D geometry to let 

you know the end and start point of the 

curvebead.

2.  If needed, select a surface.

If the surface could not be found, or if you want to 
select another surface, choose a surface in the drop-
down list. To choose an unspecified zone, select Other 
(Zone Unspec) and then select the zone in the 3D 
geometry.

 3.  Optionally modify the offset. In our example, we defined an offset of 10mm.

4.  Click the Swap Start and End Points button to change the curve direction.

5.  Click the Inverse  Offset button changes the offset curvebead position according to the original 

curvebead.



 

 
The Split Support Curve enables to trim the curvebead.

 

The curvebead will be created along the 
original curve offset.

 If several solutions are possible (for instance if there is a hole on the surfaces), you need to 
select the surface in the 3D geometry that is the closest to the curvebead to be created.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Intersect1.CATProduct


 
1.  Click the More>> button to display further 

information.

2.  Successively select two surfaces, either in the 

3D geometry or in the specification tree.

The curvebead is located at the intersection of 

the two surfaces.

 
●     You can as well select a plane as the surface.

●     Surfaces must belong to the joined components but may be different from the joint body 
zones.

 
3.  Click the Swap Start and End Points button to change the curve direction.

 
The Split Support Curve enables to trim the curvebead.

 

The curvebead will be created from the 
intersection of the two surfaces.
The curvebead's normal is the normal to the 
first selected surface at the curvebead's start 
point

 If several solutions are possible (for instance if there is a hole between the two surfaces), you 
need to select the surface in the 3D geometry that is the closest to the curvebead to be 
created.

Intersect

Open the Intersect1.CATProduct document.



 

  
 

Explicit
●     You need to select first one of the three other options (Along curve, from curve on surface, or Intersect) to 

be able to select the curve position.

●     When selecting the Explicit mode, the curve location is kept and it cannot be modified.
The curve location is then a polyline, which is recalculated according to the selected curve, and does not 
reference the specification part anymore.

When the location method switches to Explicit, the specification part is automatically deleted if 
it is empty.

●     The polyline is computed according to the discretization parameters. If it is set to Unspecified, the 
discretization value is calculated from the options defined in Tools -> Options -> General -> Display -> 
Performances -> 3D Accuracy.

●     The Isolate command has the same behavior as the Explicit method: you can select the Isolate item from 
the contextual menu once the curve is created, by right-clicking the joint element. 

K Axis
 11.  Define the orientation of the curvebead by 

setting the K axis to either:

❍     Same as Surface Material

❍     Opposite to Surface Material

To visualize the K axis, the K Axis Only option should 
be checked in Tools -> Options.

 
12.  Click OK to create the curvebead. 

The curvebead (identified as Joint Element.xxx) is added to the specification tree, under the Assembly Joint 
Body node.



 

Trimming a Curvebead
1.  Select the curvebead location. In our scenario, we selected the From Curve On Surface location.

2.  Verify that the Split Support Curve button is checked.

 
●     This option is only available with all the location methods but the Explicit location method.

●     This option must be activated to be able to define the Start and End points values.

The Repeat object after OK button appears in the BiW CurveBead Fastener Definition. Refer 
to the Repeating CurveBeads to create more curvebeads using the currently created spot point 
as reference.

 

The From Curve On Surface Location dialog box opens.

3.  Enter 0.2 for the Start point.

4.  Enter 0.7 for the End point.

   
 

5.  Click Preview in the BiW CurveBead Fastener 

Definition dialog box to preview the curvebead.

 

 

6.  Click the Swap Start and End Points button.

 The Start and End point coordinates are automatically 
recalculated and new values are displayed within the 
dialog box, but the curvebead position within the 
geometry does not change.

   

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0950.htm


The curvebead is modified with its start and end points 
recalculated.

 

7.  Click OK to create the trimmed curvebead.

 Note that:
●     the selection of the curve must be done within the linked parts, except when for the Explicit 

location method.

●     When selecting the curve (except for the Explicit location method), it is recommended to 
select published elements in order to guaranty associativity between elements.

●     to authorize the selection of only published elements, check the following option using 
Tools -> Options -> Infrastructure -> Part Infrastructure -> General -> Only use 
published elements for external selection keeping links.

●     when the On Support Surface and Explicit methods are activated, the application will 
ignore the active Part Infrastructure setting Only use published elements for external 
selection and will enable the usage of non published external geometry.



Creating Adhesive CurveBeads  

This task shows how to create a BiW Adhesive CurveBead.

 There are several ways to create a curvebead: 
●     a joint and a jointbody are already created: click the desired icon and select the joint body 

in the selection tree.

●     a joint and a jointbody are already created: select the joint body in the selection tree and 
click the desired icon (here is the example used for our scenario).

●     no joint body is created. Select the components or the publications, and click the desired 
icon: a joint and a joint body are created if needed.

Open the ABF_CurveBead.CATProduct document.

 
Make sure the Curvebead  Fastener Type is set up in the standard file.

1.  Select the joint body in the specification tree.

2.  Click the BiW Adhesive CurveBead  icon from the Adhesive toolbar.

 

 The BiW CurveBead Fastener Definition dialog box opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/ABF_CurveBead.CATProduct


3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a curvebead is created using this standard. If not, you 

are able to define your own values for each attribute.



 4.  Define the curvebead's following parameters:

●     Type

●     Functional parameters

●     Shape

●     Location

●     K Axis

●     Swapping Start and End Points

 
5.  Click OK to create the curvebead along the original curve.

The curvebead (identified as Joint Element.xxx) is added to the specification tree, under 

the Joint Body node.



Creating Sealant CurveBeads  

This task shows how to create a BiW Sealant CurveBead.

 

There are several ways to create a curvebead: 
●     a joint and a jointbody are already created: click the desired icon and select the joint body 

in the selection tree.

●     a joint and a jointbody are already created: select the joint body in the selection tree and 
click the desired icon (here is the example used for our scenario).

●     no joint body is created. Select the components or the publications, and click the desired 
icon: a joint and a joint body are created if needed.

Open the ABF_CurveBead.CATProduct document.

 
Make sure the Curvebead  Fastener Type is set up in the standard file.

1.  Select the joint body in the specification tree.

2.  Click the BiW Sealant CurveBead  icon from the Sealant toolbar.

 

 The BiW CurveBead Fastener Definition dialog box opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/ABF_CurveBead.CATProduct


3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a curvebead is created using this standard. If not, you 

are able to define your own values for each attribute.



 4.  Define the curvebead's following parameters:

●     Type

●     Functional parameters

●     Shape

●     Location

●     K Axis

●     Swapping Start and End Points

 

5.  Click OK to create the curvebead along the original curve.

The curvebead (identified as Joint Element.xxx) is added to the specification tree, under 

the Joint Body node.



Creating Unspecified CurveBeads  

This task shows how to create a BiW Unspecified CurveBead.

 

There are several ways to create a curvebead: 
●     a joint and a jointbody are already created: click the desired icon and select the joint body 

in the selection tree.

●     a joint and a jointbody are already created: select the joint body in the selection tree and 
click the desired icon (here is the example used for our scenario).

●     no joint body is created. Select the components or the publications, and click the desired 
icon: a joint and a joint body are created if needed.

Open the ABF_CurveBead.CATProduct document.

 
Make sure the Curvebead  Fastener Type is set up in the standard file.

1.  Select the joint body in the specification tree.

2.  Click the BiW CurveBead  icon from the Unspec Process toolbar.

 

 The BiW CurveBead Fastener Definition dialog box opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/ABF_CurveBead.CATProduct


3.  Specify whether you wish to use the existing standard or not.

If a standard has been imported, a curvebead is created using this standard. If not, you 

are able to define your own values for each attribute.



 4.  Define the curvebead's following parameters:

●     Type

●     Functional parameters

●     Shape

●     Location

●     K Axis

●     Swapping Start and End Points

 

5.  Click OK to create the curvebead along the original curve.

The curvebead (identified as Joint Element.xxx) is added to the specification tree, under 

the Joint Body node.



Repeating CurveBeads 

This task shows how to repeat BiW curvebeads along a selected curve. 

Open the ABF_CurveBead02.CATProduct document.

 

1.  Double-click the Joint Element.1 from the specification tree.

The BiW CurveBead Fastener Definition dialog box opens.

2.  Select the Along Curve option in the location field.

3.  Click the More>> button to define the location if the dialog box is not already displayed.

 
The Along Curve Location dialog box opens.

4.  Check the Split Support Curve button.

5.  Define the Start and End parameters, for instance enter 0 for the Start point and 0.2 for the End point.

6.  Click Close.

 

 The Repeat object after OK option, in the BiW CurveBead Fastener Definition dialog box, is now active.
 

 

7.  Check the Split Support Curve button to be able to display the BiW Fastener Repetition dialog box.

8.  Click OK.

file:///E|/www/spuCXR14/AbfEnglish/abfug.doc/src/samples/ABF_CurveBead02.CATProduct


 

The BiW Fastener Repetition dialog box opens.

It shows:

●     the reference fastener referring to the currently created spot point.

●     the End Point being the extremity of the curve by default. You can choose the other extremity by 

clicking the Extremity button as well as defining another point on the curve.

 

 

9.  Define the parameters:

●     Instance(s): defines the number of elements to be repeated. 

●     Spacing: defines the spacing between two successive elements to be repeated. As many curvebeads as 
possible are created.

●     Instances and Spacing: defines both the number and the spacing between the elements to be repeated.

10.  According to what you chose in the Parameters field, either define a value in the Instances field or in the 

Spacing one or in both of them.

When entering a value in the Instance field, the distance between two successive points is automatically 

calculated, curvebeads are equidistant and the last repeated curvebead is positioned on the curve end point.

11.  Click OK to validate the repetition.

 

 Instances (4) Spacing (15mm) Instances and Spacing (4 & 7 mm)



 The repeated curvebeads are created along the selected curve as defined in the BiW Fastener Repetition dialog 
box.

     
 

●     All repeated curvebeads are exactly the copy of the reference curvebead, therefore have 
the same length as the reference curvebead.

●     All repeated curves are located on the same curve as the reference element.

This capability is available with all the location methods but the Explicit location method.



Using Tools
Creating Features using the Datum Mode

Displaying Joined Parts in a Balloon



Creating Features Using the Datum Mode   

This task shows how to set joint bodies as unspecified and BiW features as explicit.

Open the Datum1.CATProduct document.

 
Creating Unspecified Joint Bodies  

1.  Click the Datum Mode  icon from the BiW Tools toolbar.

2.  Select a zone in FirstPartA and SecondPartB.

 

3.  Click the Joint Body  icon from the Automotive BiW Fasteners toolbar.

The BiW Joint Body Definition dialog box opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Datum1.CATProduct


 

4.  Click OK to validate the unspecified joint body creation.

5.  Double-click the joint body from the specification tree. 

The BiW Joint Body Definition dialog box opens again and you can see that its zones 
have been swapped to Unspecified.



 

 
Creating Explicit Joint Elements  

1.  Click the Datum Mode  icon from the Tools toolbar.

2.  Select a zone in FirstPartA and SecondPartB.

3.  Select the joint body from the specification tree.

4.  Select a joint element, for instance the BiW Welding SpotPoint .

The BiW SpotPoint Fastener Definition dialog box opens.

 5.  Select a location method, for instance On Surface.



 

 

6.  Click OK to create the joint element.

The spotpoint is created.

 7.  Double-click the spotpoint either from the specification tree or the geometry.



 

The BiW SpotPoint Fastener Definition dialog box opens once again and you can see 
that its location has been swapped to Unspecified.

 



●     The specification part is not deleted even if it is empty. It can be deleted 
by performing an isolate on the joint.

●     When Datum Mode is activated, the ABF application will ignore the active 
Part Infrastructure setting Only use published elements for external 
selection and will enable the usage of non published external geometry.



Displaying Joined Parts in a Balloon

This task shows you how to display the name of the joined parts in a balloon.

Open the Product0.CATProduct document and click the Display Joined Parts in a Balloon icon  from the BiW 

Tools toolbar.

 

 
Displaying Joined Parts in a Balloon from a Fastener in the 3D Geometry

1.  Point out a fastener symbol in the 3D geometry.

The instance names of the joined parts are displayed in a balloon.

Each joined part is separated by the cross symbol X.

  

 Two joined parts Four joined parts  

Displaying Joined Parts in a Balloon from a Joint, a Joint Body, or a Fastener in the 
Specification Tree

1.  Point out a joint, a joint body, or a fastener in the specification tree.

The instance names of the joined parts are displayed in a balloon.

Each joined part is separated by the cross symbol X.

From a Joint From a Joint Body From a Fastener
  

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Product0.CATProduct


 ●     The order of the joined parts in the balloon is the same as in the joint in the specification tree.

●     This command can be launched while in another command. 

The joined part numbers are not displayed.



Reporting
Creating Structural Reports

Creating Flat Reports
Reporting Using CATUtil
Reporting Using a Batch

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0520.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0530.htm
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Creating Structural Reports  

This task shows how to report data into a .html file.

A .CATProduct document must be loaded.
You can also use the ABF_AllTypeFast_01.CATProduct document.

1.  Select the objects for which you wish to generate a report. The object(s) and the parent of higher level are selected.

You can select them either in the specification tree or in the 3D geometry.

 
You can modify the selection once in the command.

2.  Click the BiW reporting icon  from the Automotive BiW Fasteners toolbar.

The Report dialog box opens. 

 The directory for the report file is the one defined in Customizing General Settings.
You can modify the path by clicking the Browse icon. The Report file dialog box displays letting you choose the file.

 

 

The dialog box enables you to customize the report through several options:
●     Sort by process: fasteners are grouped by process category and type. If a standard has been imported, the process types are 

ordered accordingly. 

●     Long report: projection results and specific process category data are added for each fastener

●     Browse once exported: the file opens in your current html browser once you click OK.

●     Translate coded values: attribute values belonging to a predefined list of codes are translated according to the NLS set-up. For 
instance if the value of the joint element's finish attribute is "B", using this option will display the translation "Class B" in the 
report.

●     Real numbers precision: corresponds to the number of decimal digits.

●     Unit: either millimeter or inch

●     Scientific notation: power of 10

●     Discretization: specify the discretization method:
❍     Polyline with sag: define the sag value used in the exported file.

❍     Polyline with step: define the value used in the exported file.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/ABF_AllTypeFast_01.CATProduct


3.  Click OK.

The progress bar shows you the remaining exported percentage.

 The CATIA BiW Fasteners report opens. It displays: 
 

●     General 
information:

❍     the date

❍     the product 
name

❍     the unit

 

●     a summary 
containing 
(number of 
features) 
fasteners sorted 
by process type 
and process 
category.

 Fasteners belonging to a same process type or process category are displayed in the same order as they appear in 
the specification tree.

 The following tables are contained into domains:
●     Joint attributes 

❍     joined components
■     Part path ID, Part Number, Version, Material

●     joint bodies
❍     BiW Body Name, Stacking, Thicknesses Count, Zone ID, Layer number for each joined contact zone, etc.

●     BiW Fasteners sorted by process type and process category (if option checked)
❍     general attributes: BiW Joint and Joint Body Names, Process Category, K Flag, I Flag, Layer number, X, Y, Z coordinates of 

the fastener's reference tangent vector (U), etc.

❍     projection attributes (only in long reports): Zone path ID, Normal and projection point coordinates, Material, Thicknesses.

●     Curvilinear fasteners discretization attributes (only in long reports)
❍     Point Count, for each point the localization coordinates (X, Y, Z), the reference normal (W) and the tangent vector (U).

●     Projection fasteners attributes (only in long reports)
❍     ID, Projection zone

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/images/Report.htm


●     You can only report BiW objects.

●     A warning message is issued in case errors occur during the report process. They are logged in a .xml file.
Refer to the Import chapter for more information.

●     One single log file is issued per structural report.

●     Deactivated features are not reported; they appear in the log file.

●     If no object is selected, all the active BiW objects as long as the sub-products are reported.

●     The products coordinates are reported relatively to the active product coordinates.

●     The header always displays the active product information even if the report is for an assembly.

●     When you have just created a feature, the latter is taken into account when clicking the BiW reporting icon. 
Expand the specification tree to ensure you selected the correct objects.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0600.htm#hj-V5R13


Creating Flat Reports  

This task shows how to report data into a flat table of tab-delimiting text.

A .CATProduct document must be loaded.
You can also use the ABF_AllTypeFast_01.CATProduct document.

1.  Select the joint elements for which you wish to generate a report. The element(s) and the parent of higher level are selected.

You can select them either in the specification tree or in the 3D geometry.

If you select a joint or a joint body, its children fasteners are highlighted in the specification tree.

 
You can modify the selection once in the command.

2.  Click the BiW flat reporting  icon from the BiW Fasteners Report sub-toolbar of the Automotive BiW Fasteners toolbar.

The Flat Report dialog box opens. 

The directory for the report file is the one defined in Customizing General Settings.
You can modify the path by clicking the Browse icon. The Flat Report file dialog box displays letting you choose the file.

 

 

The dialog box enables you to customize the report through several options:
●     Include comments: specifies that the report should start with the commented header block showing keywords description.

●     Long report: projection results and specific process category data are added for each fastener

●     Translate coded values: attribute values belonging to a predefined list of codes are translated according to the NLS set-up. For instance if 
the value of the joint element's finish attribute is "B", using this option will display the translation "Class B" in the report.

●     Real numbers precision: corresponds to the number of decimal digits.

●     Unit: specifies the unit for output length values which can either be millimeter or inch.

●     Discretization: the value affects long reports only as discretization points of curvebead are not included in short reports.
❍     Polyline with sag: define the sag value used in the exported file.

❍     Polyline with step: define the step value used in the exported file.

●     Scientific notation: power of 10.

3.  Click OK.

The progress bar shows you the remaining exported percentage.

4.  Open the .txt file.
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The file opens. It displays: 
●     one row per exported fastener containing all its attributes plus its parents ones.

●     the joint element data (ID, type, diameter, etc...). 

●     the parents data (Joint Body ID, Joint ID). 

●     the joint crossed thicknesses information (count, part number, material). 

 
Fasteners belonging to a same process type or process category are displayed in the same order as they appear in the 
specification tree.

 

 
General Structure of the Flat Report

 

 
Structure of the Commented Block
The flat report begins with an optional commented block containing the following information:

 ●     A comprehensive description of the keywords used as column titles.

 ●     Some header information such as the product name and the report date issue.

 

 ●     The column titles as keywords described above.

file:///E|/www/spuCXR14/AbfEnglish/abfug.doc/src/images/ABF_AllTypeFast_01_Flat.txt
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Version 3

 

 
Version 3.1

 

 
Version 4

 
Structure of the Results Block
The flat report contains different attributes which are spread over tab separated columns:

●     Fasteners' attributes 
❍     ID, type, diameter, layer number, etc.

●     Fasteners parents' attributes
❍     Joint and joint bodies

●     Joined contact zone attributes
❍     Path ID, thickness, material, layer number, etc.

●     Additional crossed thicknesses attributes (only in long reports)
❍     PROJ, Normal and projection point coordinates

●     Curvilinear fasteners discretization attributes (only in long reports)
❍     Point Count, for each point the localization coordinates (X, Y, Z), the reference normal (W) and the tangent vector (U) coordinates.

●     Projection fasteners attributes (only in long reports)
❍     ID, Projection zone

 

 

●     You can only report BiW objects.

●     A warning message is issued in case errors occur during the report process. They are logged in a .xml file.
Refer to the Import chapter for more information.

●     One single log file is issued per flat report.

●     Deactivated features are not reported; they appear in the log file.

●     A selection of BiW fasteners to be reported can be made prior to entering the command. This selection can be modified at 
all time within the command.

●     If no BiW entity is selected, the flat report will contain all fasteners found in the active product, including those located 
within all sub-product instances. In this case, the whole product structure is scanned recursively, starting from the active 
product.

●     The products coordinates are reported relatively to the active product coordinates.

●     The header always displays the active product information even if the report deals with an assembly.



Reporting Using CATUtil
This task shows you how to work with a batch, whose inputs are defined through a dialog box, in order to generate all types of report files 
(report, flat report, export).
A batch V5 is an non interactive program requiring an xml file that includes a parameter File (containing its inputs and outputs)

and that provides:
●     Batch process (export or report) result file (.txt or .xml formats)

●     Log output xml file

No product needs to be open.
Launch CATUtil. There are two ways to do it:

a.  Select Tools -> Utility.

b.  From a MS-DOS window, change to the default folder where the product is stored, then type the CATUtil command.

The Batch Monitor dialog box displays, listing all available batches.  

 

 
Creating a New Parameter File

1.  From the Utilities tab, right-click ABFBatchExReport and select the New parameters file contextual menu.

 

 The ABFBatchExReport dialog box opens.

 



 

2.  Select the Process Type:

❍     Export

❍     Report

❍     Flat Report

 

3.  Select a .CATProduct document as the Input Product file. The default path is the one of the CATBatch_HOME variable.

4.  Select a .txt file as the Output file.

The output file is associated to the Input Product file and its name is the same as the Input Product file.

If no output file is selected, the path is defined as in Tools -> Options -> Shape -> Automotive BiW Fastening -> General tab.

One output file is generated per reference product.

 

 Here is an example of an output file with a product and a sub-product. 

 



 
5.  Define the options.

For further information, please refer to the Export chapter.

 
Saving the Export Batch

 
Click Save to save the xml file in a directory.

The xml parameter file is automatically generated and appears as an argument for the start of the ABFBatchExReport utility.

 

 
Running the Export Batch

 From the ABFBatchExReport dialog box

 
Click Run to run the batch process.

An xml parameter is generated in a default repository.

 From the Start tab

 Right-click Run to generate the report again.

 

 
You can also generate a report using a batch with a parameter file (CATBatchXMLFile)
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The Process tab displays a status of how the process went on. 

The following information is displayed:

●     name of the batch 

●     name of the parameters file used to run the batch 

●     status of the batch ("Ended", etc.) 

●     start and end time, respectively in the "Beginning at" and "Ending at" columns 

●     return code: "0" means that the batch executed correctly, "-1" means that an error occurred

result of the batch execution (either "Succeeded" or "Failed") 

●     batch identification number

The batch ID corresponds to the directory, named after the batch ID, where the log is stored. 
In case warnings are detected, a warning log is added to the existing log file.

 8.  Right-click the ABFBatchExReport and select the Results contextual menu.

 



 
Associating an Existing Parameter File

 1.  From the Utilities tab, right-click ABFBatchExReport and select the Associate a parameters file contextual menu.

 

 

The fileBox dialog box displays.  

2.  Select an xml parameter file.

3.  Click Open.

 

 The xml parameter file appears as an argument for the start of the ABFBatchExReport utility.

 

 
Running the Export Batch

 4.  Right-click Run to generate the report again.

 

 The Process tab displays a status of how the process went on. 



Reporting Using a Batch

This task shows you how to work with a batch in order to generate all types of report files (report, flat report, export).
A batch V5 is an non interactive program which is based on an xml file that includes a parameter File (containing its inputs and outputs).

No product needs to be open.

1.  From a command window, launch the following command: CATBatch ''path of ABFExReportParam_Default.xml file'' _lic 

setting.

A default file can be found in reffiles/AbfBatchParam (intel_a for Windows, aix_a for IBM UNIX, irix_a for SGI UNIX, solaris_a for 

SUN Unix, hpux_a for HP UNIX).

 

 

This file is composed of two main parts:
●     Input Parameters

●     Output Parameters

 
Input Parameters

 

This part is itself divided into two main categories:
●     File Part: it includes:

❍     the file id (called ''Product File'' and must not be modified by the user), and

❍     the filepath (complete path of the product to be filled by the user)

●     Argument Part: it includes:
❍     the Process Type (Export (Exp), Report (RepS), Flat Report (RepF)) and the output file name, then

❍     all the export/report options.

If an option is wrong, the report is generated with a warning (except for the Process Type)

 
Output Parameters

 

It contains the export/report output directory defined by the user:
●     folder id: called ''Output Directory'' (and must not be modified by the user)

●     folderpath: directory path of the product to be filled by the user



 
A log file is open each time the batch command is launched. It is stored in the same directory as the CATBATCH_HOME variable.

This result file can either be a .txt or .html file.

 
●     If the product contains several sub-products, as many files as there are sub-products are generated. Each file name 

corresponds to a product name.

●     In case warnings are detected, a warning message is added to the existing log file:

 



Exporting  

This task shows how to export fastening data in a neutral format file (.txt for example).

A .CATProduct document must be loaded.
You can also use the ABF_AllTypeFast_01.CATProduct document.

1.  Click the Automotive BiW Fastening data export  icon.

The Export dialog box opens. 

It shows:

●     the neutral file name

●     the directory for the neutral file as defined in Customizing General Settings.

 You can modify the path by clicking the Browse icon. The Select directory dialog box displays 
letting you choose the file.

 

 
The dialog box enables you to customize the neutral file through several options:

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/ABF_AllTypeFast_01.CATProduct


●     Include additional information: projection results for example

●     Include comments: corresponds to the glossary at the beginning of the neutral file

●     Real numbers precision: corresponds to the number of decimal digits

●     Unit: either millimeter or inch

 

 

 

 

 

●     Discretization:
❍     Polyline with sag: segments are defined on the curve.

The maximum sag value calculated from the options set in Tools -> Options -> 
General -> Display -> Performances -> 3D Accuracy.

 

❍     Polyline with step: equidistant points are created on the curve.

When exporting a curvebead, the discretization value set in the Export dialog box only prevails 
if the Unspecified method is chosen. Otherwise, the value set when creating a curvebead using 
the sag or step discretization method prevails.

 
●     Scientific notation: power of 10

 
2.  Select one or more elements in the reference product to be included in the export file. 

They can be:

❍     joints: the selected joint and all its children (joint bodies and joint elements if any) 

are highlighted in the specification tree

❍     joint bodies: the selected joint body, its parent and children (joint and joint 

elements if any) are highlighted in the specification tree

❍     joint elements: the selected joint elements and its parent (joint and joint body) are 

highlighted in the specification tree

  



 You can also select several elements from two sub-products. In this case, the 
File name field is grayed out. As many export files are created as there are sub-
products. The name of each export file corresponds to the name of the sub-
product.
If no element is selected, the export applies to the whole active product.

3.  Click OK.

The progress bar shows you the remaining exported percentage. 

4.  Open the file as per the path indicated. Its name is the same as the reference 

product's. You may change it if you wish.

The format is tab separated text, allowing to open it in a spreadsheet application.

The structure of the document is the following:

●     Comments

●     Header

●     Joined parts attributes
❍     Path ID, JCPN, ZMATNAM, etc.

●     Joint attributes
❍     Joint part

❍     Joint body attributes
■     Zone attributes (ZNAM, Layer, etc.)

■     Joint element attributes (ID, Process Category, Process Type, Layer, K 
Flag, IF Flag, Reference Normal (W) and Tangent Vector (U) coordinates, 
etc.)

■     Curvilinear fasteners discretization attributes (Point Count, for each point 
the localization coordinates (X, Y, Z), the reference normal (W) and the 
tangent vector (U) coordinates.

■     Projection fasteners attributes (ID, Projection Zone)

■     INFO attributes (only in long reports: Zone Path ID, Normal and 
projection point coordinates)

■     INFO1 attribute (Length, Volume)

 One neutral file associated to the reference product is created. If the selected features belong 
to different products, there will be as many export files as there are different products.



 

Elements are displayed in the same order as they appear in the specification tree. 

 The BiW Fasteners specifications are exported, except for their links to the 3D geometry. For 

example, if the location method is Point on Surface, this specification will not show in the 

neutral file; only the coordinates of the point will be displayed. 

  

 

●     A warning message is issued in case errors occur during the export 
process.
Please refer to the Import chapter for more information.

●     One single log file is issued per export.

●     Deactivated features are not exported; they appear in the log file.

●     On a Windows workstation, you cannot export a file if it is already open.
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Importing  

This task shows how to import data from a neutral file.

A neutral file must exist.

1.  Click the Automotive BiW data import icon . 

The Import dialog box opens. 

 

The directory for the neutral file is the one defined in Customizing General Settings and is the same as the export directory.

2.  Click OK.

The progress bar shows you the remaining imported percentage.

 May the names of the joined part numbers or the root product differ from those used in the neutral file, the import process still 
goes on. If the joined part ID differs from the neutral file, the import is possible only if an associated part number is found in 
the session.
A warning message is issued when the import is over.

 

 All inconsistencies found during the import process are logged in a .xml file. The path to this file is the same as the neutral 
file's. Its ID corresponds to: ProductName(Part Number)_date(year#month#day#time)_LOG.xml
One single log file is issued per import.
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●     All BiW Fasteners have an "Explicit" location method after they have been imported. They are located only 
by their coordinates but the links to the 3D geometry are not kept.
See Exporting.

●     Rules Check is not active when importing data. 
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Isolating Features  

This task shows how to isolate joints (joints, joint bodies and joint elements) either individually 
or globally.

Open the Isolate1.CATProduct document.

 
Isolating Element by Element

1.  Right-click a joint element for instance from the specification tree and select the Joint 

Element.1 object -> Isolate contextual command.

 

2.  Double-click the joint element either from the specification tree or the geometry.

The BiW SpotPoint Fastener Definition dialog box opens.

As you can see, the joint element location has changed to explicit.

Isolating All Elements
 

1.  Right-click the Automotive BiW Fastening Parameters from the specification tree and 

select the Automotive BiW Fastening Parameters object -> Isolate Joints 

contextual command.

 
2.  Double-click a joint element of your choice either from the specification tree or the 

geometry.

The BiW SpotPoint Fastener Definition dialog box opens.

As you can see, the joint element location has changed to explicit.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Isolate1.CATProduct


 
●     The isolated element has no more specific geometry.

●     When applying this capability to a joint element, it is automatically set to 

the explicit mode.

●     When applying this capability to a joint body, all its contained joint 

elements are automatically set to the explicit mode and its zones set as 

unspecified.

●     When applying this capability to a joint, all its contained joint bodies are 

automatically set to the unspecified mode and its associated Specification 

Part is automatically destroyed.

●     When applying this capability from the parameters, all joints belonging to 

the corresponding reference product are automatically isolated.



Transforming
Creating Mirror/Copy Elements

Creating Translate/Copy Elements



Creating Mirror/Copy Elements  
This task shows how to create a Mirror/Copy element, either within the same product or two different products.

In this scenario an example with a Joint Element is given, but you can also select a Joint Body or an Assembly Joint.

Open the Joint2.CATProduct document.

 The product is displayed as shown here with one joint element created.
 

1.  Select the joint element from the specification tree.

2.  Select the Mirror Copy  icon from Transformed copies sub-toolbar of the Automotive BiW fasteners toolbar.

By default, the Target parent object is the same as the one of the Source object, here Joint Body.1.

If the source object and the target parent belong to two different products, you need to explicitly select the target parent in a product different from the source's object.

 

 
The BiW Mirror Copy dialog box opens.

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Joint2.CATProduct


 

 3.  Select a Root Product Plane or a part zone on which you wish to paste the body.

 

4.  Click OK.

The mirrored SpotPoint is created.

 

 In the above example, we selected xy as the Root Product Plane. In the above example, we selected Blend.1 as the Part plane.

 

 

5.  Double-click this new element from the specification tree.

 The BiW SpotPoint Fastener Definition dialog box opens.

 
The SpotPoint is created as explicit.



 

 

6.  Select the On Support Surface location.

7.  Select Blend.1.

8.  Click OK in the dialog box.

 The SpotPoint is relocated upon the selected surface.



 

 
●     Mirrored objects follow the same rules as pasted objects, with an additional symmetry applied on explicit coordinates of Joint Elements.

●     When the source element is a joint, the Parent target allows to multi-select parts in the target product to be reconnected.

●     When the naming rule is not active, the copied elements have the same name as the source elements.



Creating Translate/Copy Elements
This task shows how to create a Translate/Copy element, either within the same product or 
onto different products.

In this scenario an example with Joint Elements is given, but you can also select a Joint Body 
or an Assembly Joint.

Open the Translate.CATProduct document.

 The product is displayed as shown here with several joint elements created.
 

1.  Select the joint element from the specification tree.

2.  Select the Translates BiW object Copies  icon from Transformed copies sub-

toolbar of the Automotive BiW fasteners toolbar.

By default, the Target parent object is the same as the Source objects, here Joint Body.1.

If the source objects and the target parent belong to two different products, you need to 

explicitly select the target parent in a product different from the source's objects.
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The BiW Translated Copy dialog box opens.

 

 

3.  Select the Translation vectors.

You can either:

●     manually select the X, Y, and Z vectors using the spinners, or

●     select a geometrical element to initialize with the selection and provide 

a direction.

This element can either be a surface or a plane (the normal to this 

surface or plane is computed to obtain the translation direction), or a 

line or an edge (the line or edge direction gives the translation 

direction)

 4.  Define the Distance to specify the length of the translation vector. 



 

Whenever vector values are modified, the Distance value is automatically updated as the 
length of the vector, and vice-versa. Therefore the distance value is always equal to the 
corresponding vector value.

In our scenario we define a distance of 550mm.

 5.  Click the Invert button to reverse the direction vector.

 

 

6.  Click OK.

The translated joint elements are created.

 



 
When the naming rule is not active, the copied elements have the same name 
as the source elements.



Copying/Pasting Elements  

This task shows how to copy/paste elements such as Joint Elements, Joint Bodies, and Assembly 
Joints in different products.

Open the ProductA.CATProduct and the ProductB.CATProduct documents.

1.  Select Tile Vertically from the Window menu to display them both.

 

 
Copying/pasting Joints  

 

An ABF Parameters object must be created first on the target product.
See Setting up BiW Fastening Parameters.

 

2.  Right-click the source Joint you wish to copy.

3.  Select Copy from the contextual menu.
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4.  Right-click the target ABF Parameter object on which you wish to paste the Joint.

5.  Select Paste from the contextual menu.

 

A new Joint is created based on the source joint and new icons are displayed in the specification 
tree.

  



 

 Note that:
●     The Joint Bodies contained in the source Joint are also pasted onto the pasted 

Joint.

●     The pasted Joint connects parts in the target product that have the same 
instance name as parts connected by the source Joint.

●     If a part connected by the source Joint is not found in the target product 
assembly structure, then it is not referenced by the pasted Joint.

 
Copying/pasting Joints Bodies  

 
A Joint must be created first on the target product.

1.  Right-click the source Joint Body you wish to copy.

2.  Select Copy from the contextual menu.



 

 

3.  Right-click the target Joint on which you wish to paste the Joint Body.

4.  Select Paste from the contextual menu.

 

 A new Joint Body is created based on the source joint body and new icons are displayed in the 
specification tree.

  



 

 Note that:
●     The Joint Elements contained in the source Joint Body are pasted onto the 

target Joint.

●     The pasted Joint Body refers to the same zones as it is defined in the source 
Joint Body.

●     If a published zone cannot be found on the target Joint, an unspecified zone is 
created instead.

 
Copying/Pasting Joints Elements  

 
A Joint Body must be created first on the target product.

1.  Right-click the source Joint Element you wish to copy.

2.  Select Copy from the contextual menu.

 



 

3.  Right-click the target Joint Body on which you wish to paste the Joint Element.

4.  Select Paste from the contextual menu.

 

 A new Joint Element is created based on the source Joint Element and new icons are displayed 
within the specification tree.

  



 

 Note that:
●     The pasted Joint Element is explicit which means that its position is not 

specified by a geometry.

●     The source Joint Element and the pasted one have the same position 
respectively to their roots products.

●     The source Joint Element and the pasted one have the same normal vector, 
except if the pasted Joint Element is based on a surface which normal vector is 
different.

●     The pasted Joint Element is named after the target's product Naming Rule if it 
is activated. If it is not activated, the pasted Joint Element has the same name 
as the source element.



Renaming Features 

This task shows how to rename a selection of fasteners.

Open a .CATProduct document.

1.  In the specification tree or in the 3D geometry, select the fastener(s) you want to 

rename.

If you select a joint or a joint body, its children fasteners are highlighted in the 

specification tree.

2.  Click the Renames BiW Fasteners icon .

The BiW Fasteners renaming dialog box opens.

 

 
Search



 
●     Match ID: enter the string that matches an ID in the specification tree. This field may be 

empty or unchecked if you do not want to apply any selection filter.

You can use the * (star) special character to specify any sub-string.

You can use the # (pound) special character to specify a numerical sub-string: it indicates 

the location of the fastener number among all selected fasteners that match the ID.

Identification rules of the fastener number, prefix, and suffix:

❍     Field entries are case sensitive.

❍     If the fastener number cannot be found, the prefix equals the ID, the suffix is empty 

and the number is 0.

❍     If the # special character is used, its location determines the fastener number.

❍     If no # special character is used, the fastener number is the first numerical sub-string 

found in the ID.

Here is an example with a joint called Joint 32 Roof Top 1.

 

Match ID How is it interpreted?

<empty>
Prefix: ''Joint''
Number: 32
Suffix: ''Roof Top 1''

*
Prefix: ''Joint''
Number: 32
Suffix: ''Roof Top 1''

* 32 *
Prefix: ''Joint''
Number: 32
Suffix: ''Roof Top 1''

* 32 * #
Prefix: ''Joint 32 Roof Top''
Number: 1
Suffix: /

❍     Once the fastener number is computed, the prefix and the suffix are deduced as the 

surrounding sub-strings.

❍     If the numerical suffix and the fastener number follow, they cannot be deduced.

Here is an example with Joint 325689.

 

Match ID Result expected Result obtained Feedback



Joint #89
Prefix: ''Joint''
Number: 3256
Suffix: 89

Prefix: ''Joint''
Number: 325689
Suffix: /

No fastener corresponds to 
the request

Joint #
Prefix: ''Joint''
Number: 3256
Suffix: 89

Prefix: ''Joint''
Number: 325689
Suffix: /

No fastener corresponds to 
the request

To obtain a result, you need to rename the fastener as Joint 3256 89:

Joint 3256 89, 

or

Joint # 89, or

Joint # *

Prefix: ''Joint''
Number: 3256
Suffix: 89

Prefix: ''Joint''
Number: 3256
Suffix: 89

Request OK

❍     In case there are several identical sub-strings in the fastener name, the system stops 

as soon as a criterion is verified. This may lead to unpredictable results.

●     Number from: enter a number to filter out fasteners whose fastener number is lower or 

equal to the number defined here.

●     Number to: enter a number to filter out fasteners whose fastener number is higher or 

equal to the number defined here.

 
Here are various examples illustrating the Match ID behavior:

 Fastener Name
to obtain Replace Match ID

Joint Element 1
Prefix: Joint Element
Suffix: /
Number: 1

<empty>, or 
*Joint *#

Joint Element 1 xxx
Prefix: Joint Element
Suffix: xxx
Number: 1

<empty>, or
*Joint *#*

61 10 21
Prefix: 61
Suffix: 21
Number: 10

61 # 21

61 10 21
Prefix: 61 10
Suffix:/
Number: 21

*10 #

aa21aa31
Prefix: aa
Suffix: aa31
Number: 21

<empty>, or 
*aa#*



aa21aa31
Prefix: aa21aa
Suffix: /
Number: 31

aa21aa#

aa21aa31
Prefix: aa21aa
Suffix: /
Number: 31 

a*1aa#

aa21aa31
Prefix: aa21aa
Suffix: /
Number: 21

*#*

 
Replace

 
●     enter the Prefix that will replace the one initialized with the common prefix of all selected 

fasteners (only the fasteners that match the prefix to be found will be renamed).

 
●     enter the Suffix that will replace the one initialized with the common suffix of all selected 

fasteners (only the fasteners that match the suffix to be found will be renamed).

 
●     enter the Translate number value to offset the joint element number (for all selected 

fasteners, the joint element number is extracted by finding the rightmost numerical 

characters of the identifier (the result is zero if the identifier does not end with numerals), 

offsetting it by the entered value and replacing it within the identifier).

 
●     Check the Apply standard fixed length number option to replace the number ID with 

the equivalent fixed-length number as defined in the Parameters chapter.

 
Apply

 
●     Check the Current naming rule option to apply the naming rule as defined in the 

Parameters chapter.

If any of the above Replace options were checked, they are automatically unchecked.



 
3.  Click OK.

Modifications are automatically taken into account: make sure the rule is configured 

to answer your need as set previously.

 You can also change a fastener's name directly in the specification tree by 
double-clicking the fastener to edit it.



Editing Fasteners' Properties 

This task shows you how to control the display of the elements you create in the geometry 
area.

1.  Right-click a fastener in the specification tree or in the 3D geometry and select 

Properties.

The Properties dialog box opens.

 



3.  Click the Unset All button to uncheck all the options, except for the Shape 

Representation option. Similarly click the Set All button to check all options.

4.  Click the Show buttons to visualize the different options.

The same options can be chosen using the Tools -> Options command.

 If the graphic symbols (symbol and color) are already assigned to a Thickness Count or Process 
Type (for the symbol) or a Process Category (for the color) as defined in Tools -> Options, 
they cannot be modified. In that case, spinners are grayed.

If the graphic symbols are assigned to the Unspecified type, you are able to modify them using 
the combo box.

  

Note that, in visualization mode: 
●     when selecting at least one of the options contained either in the Support Contact zone 

Material Orientation or in the Contact Zones within the Properties dialog box,

●     and when selecting  Tools -> Options -> Mechanical Design -> Assembly Design -> 
General, the Automatic Switch to Design Mode option,

then all joint components are automatically switch to Design mode.

The Automatic Switch to Design Mode option must be activated to visualize the desired 
options.
If you do not wish to have all joint components automatically switch to Design mode, then 
uncheck the options mentioned above.

Refer to the Display chapter to have further information about the different options.



Advanced Tasks
Running the Fastening Rules Analysis
Searching Automotive BiW Features

Integration With Drafting
Measure Tools 



Running the Fastening Rules Analysis 

This task shows you how to launch an analysis to check the rules' compliance as defined in 
the BiW Fastening Parameters.

Open the Analysis1.CATProduct document.

1.  Click the Check icon .

The BiW Fasteners analysis dialog box opens.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Analysis1.CATProduct


 
2.  Check the rules on which you want to run the analysis.

 
●     Uniqueness of identifiers: checks that all joint elements have different names.

●     Thickness count: checks that the number of thicknesses is compliant with the number 
set in the BiW parameters.

●     Forecast fasteners count: checks that the number of joint elements the joint body is 
supposed to contain for further verifications is compliant with the number set when 
creating the joint and the jointbody.

●     Fastener location on surface: checks that joint elements are located on surfaces.

 
This rule applies for spotpoints only.

 
●     Closest surface normal vector alignment: checks the deviation angle between the 

joint element's normal vector of the joint element's normal vector at the projection on the 
closest surface.

●     Specified thicknesses crossing: checks that joint elements cross all the specified 
thicknesses of the jointbody.

 
This rule applies for spotpoints only.

●     Thicknesses normals alignment: checks that the thickness normal to the crossed 
joined components is aligned with the joint element's normal.

●     Maximum/Minimum thickness ratio: checks that the ratio between the minimum and 
the maximum thicknesses of the crossed zones is lower or equal to the maximum defined 
ratio, even if all joint elements do not intersect all the specified joined components.

 
●     In case the maximum ratio is set to 1, the rule checks that all crossed 

thicknesses are equal.

●     If one or more thicknesses are null, the ratio is infinite.

●     For curvebeads, specified crossed thicknesses are computed at the start 
location.



 
●     Thickness gap: checks that the gap value between two joined components crossed by a 

given joint element is compliant with the value set in the BiW parameters.

●     Fastener center distance to flange edge: checks that all joint elements on crossed 
surfaces intersect all specified components and computes the minimum distance from the 
fastener's center location to the closest flange edge.

●     Fastener border distance to flange edge: checks that all joint elements on crossed 
surfaces intersect all specified components and computes the minimum distance from the 
fastener's border location to the closest flange edge.

●     Diameter overhang: checks the maximum overhang of the fastener's diameter to the 
closest flange edge.

 
●     In case two or more surfaces with common edges are crossed, you need 

to perform a join so their free edges are considered as those of one 
single surface.

●     Internal edges and tangent surfaces are ignored, but holes are not.

●     For rivets, the diameter taken into account is the shank diameter.

●     The three above rules apply for spotpoints and spotprojection welds only, 
not curvebeads.

 
●     Minimum spot spacing: checks that the minimum spot spacing between two spotpoints 

is compliant with the value set in the BiW parameters.

 
This rule applies for spotpoints only.

3.  Click the Analyse button.

Besides each rule, a sign gives a feedback whether the check passed or failed.

 



 
4.  Click the red sign corresponding to the rule that failed. The corresponding check 

failure analysis window opens, along with the list of selected failing elements. You can 

select several elements in the list to highlight them in the specification tree and 3D 

geometry. 



●     The Closest surface normal vector alignment check failure report displays either "N/A" 
when no normal vector was found on the joint element (which is the case when you open 
a pre-V5R12 model) or the deviation angle between the normal vector of the joint 
element and the normal vector at the projection on the closest surface. You can then 
select the Joint Elements you want to "heal" and either with the "Apply remedial action" 
contextual menu or push button, reset the normal vector according to the normal vector 
at the projection on the closest surface.

●     The Fastener location on surface check failure report displays either "N/A" if the joint 
element cannot be projected on any surface or the distance to the closest surface. Same 
as before, applying the Remedial action on a joint element will project it on the closest 
surface.

●     The Fastener center distance to flange edge, Fastener border distance to flange edge, or 
Diameter overhang ratio check failure report displays the distance of the failed joint 
elements and highlights the closest edge involving the failure in the 3D geometry.

  

 
●     The BiW Fasteners Analysis command runs on the current selection. If 

the latter is empty, the whole product structure is taken into account. 

●     When you exit the command, elements in error are still highlighted.

●     You can right-click the highlighted element(s) to Reframe on and 
Center Graph.



Searching Automotive BiW Features 

This task shows how to use the Search capabilities on Automotive BiW Features, in order to detect any 
specific kind of feature.

Open the PowerCopyStart.CATProduct document.

1.  Select the Edit ->  Search menu item.

The Search dialog box opens. 

2.  From the Type Workbench list choose Automotive BiW Fastening.

You can then display the list of Automotive BiW Fastening from the Type list: 

3.  Select the type of feature you wish to find within the open .CATPart document. 

Here we chose BiW Fastener.

4.  Click the Search icon .

The list of all elements of the selected type is displayed in the objects found field:

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/PowerCopyStart1.CATProduct


You can select an element from the list, it will be highlighted in the geometry area.
  

To find out more on the search capabilities, refer to Selecting Using the Search... Command (General 
Mode) and Selecting Using the Search... Command (Favorites and Advanced Modes) from the 
Infrastructure User's Guide.



Integration With Drafting

This task shows you how to generate a .CATDrawing document from a .CATProduct document containing BiW spot fasteners.

Open the DraftingIntegration1.CATProduct document.

1.  Make sure the Normal Vector Orientation is defined.

Refer to the BiW Fastening Application Display User Settings chapter for more information.

 

 Make sure the Prevent generative view style creation option is deselected from Tools -> Options -> 
Mechanical Design -> Drafting -> Administration tab in order to be able to create and use generative view 
styles.

 

 Generative view styles can be customized via Tools -> Standards.
 2.  Select Tools -> Standards... then the generativeparameters Category and the Automotive BiW Fastening Generative 

Style.

 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/DraftingIntegration1.CATProduct


 3D spots will be automatically generated on the drawing view depending on the ABF Drawing extraction parameters added to 
the CATIA Standard Default Generative View Style (GVS).

The administrator must set the generative parameter ''Automotive BiW Fastening'' in the DefaultGenerativeStyle.xml so that the 
user obtains suitable drawings using generative view styles.
Please refer to the Creating a View using Generative View Styles chapter in the Generative Drafting documentation.

This DefaultGenerativeStyle.xml file is located  according to the resources/standard/generativeparameters path from CATIA run 
time view root directory (intel_a for Windows, aix_a for IBM UNIX, irix_a for SGI UNIX, solaris_a for SUN Unix, hpux_a for HP 
UNIX) or can be accessed via Tools -> Standards.

●     The Extract Location option indicates whether the spot fastener location must be extracted or not (the default value is Yes)

●     The Angular Tolerance option defines the maximum angle between the spot normal vector orientation and the direction of 

the view used for the spot extraction (the default value is 90).

●     The Include View Reverse Direction options lets you choose whether you wish to visualize the 2D reverse spots (the 

default value is No).

  



 Case A: Drafting View without associated GVS 

The 3D Spot Fasteners will be generated in this view according to the Extract parameters in Tools -> Options -> Shape -> 
Automotive BiW Fastening -> General tab (Angular Tolerance, Include View Reverse Direction) 

Case B: Drafting View with an associated GVS 

a.  Providing that the Angular Tolerance is specified (different from -1) 
The 3D Spot Fasteners will be generated in this View according to the Extract parameters in GVS (Angular Tolerance, 
Include View Reverse Direction) 

b.  Providing that the Angular Tolerance is not specified (set to -1)
The 3D Spot Fasteners will be generated in this View according to the Extract parameters in Tools -> Options -> 
Shape -> Automotive BiW Fastening -> General Tab (Angular Tolerance, Include View Reverse Direction) 

 Example 1: 
Providing that: 

●     the Angular Tolerance is different from -1 in the GVS parameters (45 for example),

●     the Include View Reverse Direction option is checked in the GVS parameters,

●     the Angular Tolerance is set to 60 in Tools -> Options (value not effective here),

●     the Include View Reverse Direction option is unchecked in Tools -> Options (value not effective here),

=> the 2D reverse spots will be generated in the Drawing document according to the GVS parameters (with Angular Tolerance 
value = 45).

Example 2:

●     Providing that: 
the Angular Tolerance is set to -1 in the GVS parameters (value not effective here),

●     the Include View Reverse Direction option is set to No in the GVS parameters (value not effective here),

●     the Angular Tolerance is 45 in Tools -> Options,

●     the Include View Reverse Direction option is checked in Tools -> Options, 

=> the 2D reverse spots will be generated in the Drawing document according to Tools -> Options parameters (with Angular 
Tolerance value = 45). 

 If the Angular Tolerance is set to 0 (through GVS or Tools -> Options -> Shape -> Automotive BiW 
Fastening -> General Tab), no 3D Spot Fastener will be generated on the Drawing View.

 
3.  Select Top View  from the Quick View toolbar. 

4.  Select File -> New from the menu bar.

The New dialog box displays.

5.  Select Drawing from the List of Types and click OK.

The New Drawing dialog box displays.

6.  Click OK.

The Generative Drafting workbench displays with a default grid.

7.  Select Window -> Tile Horizontally from the menu bar to organize your windows horizontally.

 
8.  In the drawing document, select Front View  from the View toolbar (Quick View sub-toolbar).

The Generative View Style toolbar automatically displays with the DefaultGenerativeStyle selected by default.



 

 
9.  Select the surface in the 3D document.

3D symbol spots are visualized in the 2D drawing document and their diameters are respected.

10.  Click on the drawing sheet or at the center of the blue knob to generate the view. 

 

 3D symbol spots are visualized in the 2D drawing document view and their diameters are respected (2D Spot Symbol Diameter 
= 3D Spot Diameter). Symbols are gathered together in the ABF_Symbols.CATDrawing reference file located according to the 
reffiles/GbfStandards path from CATIA run time view root directory (intel_a for Windows, aix_a for IBM UNIX, irix_a for SGI 
UNIX, solaris_a for SUN Unix, hpux_a for HP UNIX).
You do not need to save this file in the database because the file that is used is always the run time view's, should it be during 
the update process or during the drawing extraction.

  
 

You can set a fixed size for your 2D drawing spots.
Please refer to the General Settings chapter in the Customizing section.

 Here are these symbols:

2D symbol 3D symbol code

111

112

113

114

151

152

153

154

136

137

138

139

101

125

any other 3D symbol



 Measure Tools
 

You can measure the distance between fasteners using the following command:
Measuring distances and angles: Click the Measure Between icon, set the measure type and mode in the Measure 
Between dialog box, then select two entities.

You can measure properties associated to a selected fastener using the following command:

Measuring properties: Click the Measure Item icon, then select an item.

  

You must set the following parameters for both commands: 

 

●     Check the Show Shape option in Tools -> Options -> Shape -> Automotive BiW Fastening -> Display. Only 
this option must be checked.

●     Choose Any geometry as the Selection mode, and Approximate as the Calculation mode, as the fastener 

representation is a symbolic shape representation (the Exact mode is not supported).

●     Fasteners must be selected in the 3D geometry. Selecting fasteners in the specification tree is not supported.

Open the Measure1.CATProduct document.

1.  Select the Measure Between  icon. 

The Measure Between dialog box appears.

 2.  Select two fasteners in the 3D geometry.

http://arbre1dsy/spuCXR14/Doc/online/cfyugmeasure_C2/cfyugmeasurebetween.htm
http://arbre1dsy/spuCXR14/Doc/online/cfyugmeasure_C2/cfyugmeasurebetween.htm
http://arbre1dsy/spuCXR14/Doc/online/cfyugmeasure_C2/cfyugmeasureitem.htm
http://arbre1dsy/spuCXR14/Doc/online/cfyugmeasure_C2/cfyugmeasureitem.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/samples/Measure1.CATProduct


 

 Measuring between two spotpoints Measuring between two curvebeads
 Appropriate distance values are displayed both in the 3D geometry and in the dialog box. 

 

 Measuring between two spotpoints Measuring between two curvebeads

 

3.  From the Measure Between dialog box, click 

the Measure Item icon  (you can also 

select this icon from the Measure toolbar).

The Measure Item dialog box appears.

 4.  Select the fastener in the 3D geometry.

 



 Measuring a spotpoint Measuring a curvebead

 Appropriate values are displayed both in the 3D geometry and in the dialog box: coordinates for spotpoints and length 
for curvebeads.

 

 Measuring a spotpoint Measuring a curvebead

You can customize the properties you want to see displayed by clicking the Customize... option.

 5.  Click OK to exit the command.



Automotive Body In White Fastening 
Interoperability

Optimal CATIA PLM Usability for Automotive BiW Fastening



Optimal CATIA PLM Usability for
Automotive BiW Fastening 

When working with ENOVIA V5, the safe save mode ensures that you only create data in CATIA 
that can be correctly saved in ENOVIA. Therefore, in interoperability mode, some CATIA V5 
commands are grayed out / hidden in the Automotive Body In White Fastening workbench.

ENOVIA V5 offers two different storage modes: Workpackage (Document kept - Publications 
Exposed) and Explode (Document not kept). 

To ensure seamless integration, you must have both a CATIA and ENOVIA session running.

  
 Please find below the list of the Automotive Body In White Fastening commands along with 

their accessibility status in Enovia V5. In some cases, restriction rules apply to certain 
commands.

 

Command
Accessibility 
in Enovia 
LCA

Warning/Comment

Automotive BiW 
Welding Parameters Yes  

BiW Data Import No  

BiW Data Export Yes  

BiW Reporting Yes  

BiW Flat Reporting Yes  

Renaming No  

Mirror/Copy Yes If the target is not in 
Explode mode

Translate Yes If the target is not in 
Explode mode

BiW Joint No  

BiW Joint Body No  

BiW Welding 
SpotPoint No  

BiW Welding 
SpotProjection No  

BiW Welding 
CurveBead No  

Automotive BiW 
Adhesive Parameters Yes  

BiW Adhesive 
SpotPoint No  

BiW Adhesive 
CurveBead No  



Automotive BiW 
Sealant Parameters Yes  

BiW Sealant 
SpotPoint No  

BiW Sealant 
CurveBead No  

Automotive BiW 
Mechanical Fasteners 
Parameters

Yes  

BiW Clinching 
SpotPoint No  

Automotive BiW 
Unspecified Process 
Parameters

Yes  

BiW SpotPoint No  

BiW CurveBead No  

Check No  

Update No  

Activate/Deactivate No  

Isolate No  

Delete No  

Copy Yes If the target is not in 
Explode mode

 



Workbench Description
This section contains the description of the icons, menus and Historical Graph that are specific to the Automotive Body 
In White Fastening workbench, which is shown below. 

You can click the hotspots on this image to see the related documentation.

Menu Bar
Automotive BiW Fasteners Toolbar

Welding Toolbar
Adhesive Toolbar
Sealant Toolbar
Unspec Toolbar

Mechanical BiW Fasteners Toolbar
Analysis Toolbar

Tools Toolbar
Measure Toolbar
Specification Tree 



Menu Bar
This section presents the tools and commands which are available in the FreeStyle Shaper, Optimizer 
and Profiler workbenches. 
Many other operations are documented in the Infrastructure User's Guide.

 

Start File Edit View Insert Tools Windows Help

 

File 

The File menu lets you perform file creation, opening saving, printing operations 

Edit 

The Edit menu lets you manipulate selected objects. Refer to the Infrastructure User's Guide and Part 
Design User's Guide. 

View 

The View menu lets you view document contents  Refer to the Infrastructure User's Guide.

Insert 

The Insert menu lets you insert Automotive BiW Fastenings elements.
 For... See...

Object

Product Structure User's Guide

New Component

New Product

New CDM 
Component

New Part

Existing 
Component...

Document 
Template 
Creation...

Creating a Part Template in the 
Product Knowledge Template User's 
Guide

Parameters Defining the BiW Parameters

BiW Joint Creating a Joint



BiW JointBody Creating a Joint Body

BiW Welding 
SpotPoint

Insert -> BiW Welding Spot

BiW Welding 
Spot

Insert -> BiW Welding Spot

BiW Welding 
CurveBead

Creating Welding CurveBeads

BiW Adhesive 
SpotPoint

Creating Adhesive SpotPoints

BiW Adhesive 
CurveBead

Creating Adhesive CurveBeads

BiW Sealant 
SpotPoint

Creating Sealant SpotPoints

BiW Sealant 
CurveBead

Creating Sealant CurveBeads

BiW SpotPoint Creating BiW SpotPoints

BiW CurveBead Creating Unspecified CurveBeads

BiW Clinching 
SpotPoint

Creating a Clinching SpotPoint

Insert -> BiW Welding Spot
 For... See...

BiW Welding 
SpotPoint

Creating a BiW Welding SpotPoint

BiW Welding 
SpotProjection

Creating SpotProjection Welds

Tools 

The Tools menu lets you perform image capture and album management, set user preferences and 
manage macros. Refer to the Infrastructure User's Guide. 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm


For See...

Formula...

Infrastructure User's GuideImage

Macro

Utility... Reporting Using CATUtil

Customize

Infrastructure User's Guide

Visualization 
Filters...

Options...

Standards...

Conferencing

BiW Fasteners 
Import

Importing

BiW Fasteners 
Export

Exporting

BiW Fasteners 
Report

Tools -> BiW Fasteners Report

BiW Fasteners 
Rename

Renaming

BiW Fasteners 
Transform

Tools -> BiW Fasteners Transform

Display Joined 
Parts in a 
Balloon

Displaying Joined Parts in a Balloon

Tools -> BiW Fasteners Report
 For... See.

Report Reporting

Flat Report Creating Flat Reports

Tools -> BiW Fasteners Transform
 For... See.

BiW Mirror Copy Creating Mirror / Copy Elements

Translated Copy Creating Translate / Copy Elements

Window 

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0530.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0600.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0520.htm


The Window  menu lets you arrange document windows in relation one to the other. Refer to the 
Infrastructure User's Guide. 

Help 

The Help menu lets you get help on the currently active command, and the product in general. Refer 
to the Infrastructure User's Guide. 



Automotive BiW Fasteners Toolbar 

The Automotive BiW Fasteners Toolbar contains the following tools:

  

See Defining the BiW Parameters

See Importing

See Exporting

See Reporting

 See Creating Flat Reports

 See Renaming BiW Features

 See Creating Mirror/Copy Elements

See Creating a Joint

See Creating a Joint Body

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0600.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0600.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0520.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0520.htm


Welding Toolbar

The Welding Toolbar contains the following tools:

  

See Displaying the Process Category parameters

See Creating a BiW Welding SpotPoint

 See Creating SpotProjection Welds

 See Creating Welding CurveBeads

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm
http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm


Adhesive Toolbar

The Adhesive Toolbar contains the following tools:

  

See Displaying the Process Category parameters

See Creating BiW Adhesive SpotPoints

 See Creating BiW Adhesive CurveBeads



Sealant Toolbar

The Sealant Toolbar contains the following tools:

  

See Displaying the Process Category parameters

See Creating BiW Sealant SpotPoints

 
 
See Creating BiW Sealant CurveBeads



Unspec Toolbar

The Unspec Toolbar contains the following tools:

  

See Displaying the Process Category parameters

See Creating BiW SpotPoints

 See Creating BiW CurveBeads



Mechanical BiW Fasteners Toolbar

The Mechanical Toolbar contains the following tools:

  

See Displaying the Process Category parameters

See Creating a BiW Clinching SpotPoint



Analysis Toolbar

The Analysis Toolbar contains the following tool:

    

See Running the BiW Fastening Rules Analysis



Tools Toolbar

The BiW Tools Toolbar contains the following tools:

  

  
 

See Creating BiW Features Using the Datum Mode

 See Displaying Joined Parts in a Balloon 



Measure Toolbar

The Measure Toolbar contains the following tools:

 

See Measure Tools

http://arbre1dsy/spuCXR14/Doc/online/cfyugmeasure_C2/cfyugmeasurebetween.htm
http://arbre1dsy/spuCXR14/Doc/online/cfyugmeasure_C2/cfyugmeasureitem.htm


Specification Tree
Within the Automotive Body In White Fastening workbench, you can generate a number of elements 
that are identified in the specification tree by the following icons.

Parameters           Sealant SpotPoint

Joint  Sealant CurveBead

Joint Body  BiW SpotPoint

Welding SpotPoint  BiW CurveBead

Welding SpotProjection  Clinching SpotPoint

Welding CurveBead    

Adhesive SpotPoint    

Adhesive CurveBead

http://arbre1dsy/spuCXR14/Doc/online/abfug_C2/abfugbt0320.htm


Customizing
Before you start your first working session, you can customize the way you work to suit your 
habits.
This type of customization deals with permanent setting customization: these settings will not 
be lost if you end your session.

1.  Select the Tools -> Options menu item.

The Options dialog box appears. 

2.  Click the Shape category in the left-hand box.

3.  Click the Automotive Body In White workbench.

The General and the Display tabs are displayed.

 

●     The General tab lets you define the application and extract parameters, as well as the 
export and report directories.

●     The Display tab lets you define the display options.

 

4.  Set options in these tabs according to your needs. 

5.  Click OK when done.



General Settings 
 

  
 This page deals with the following settings:

●     Setting Up Parameters

●     Defining the Export Directory

●     Defining the Report Directory

●     Setting Up the Extract Parameters

●     Allowing the Creation of unsaved data from Enovia

 

Setting Up Parameters
 

 
Default Standard File

 The Default Standard File path corresponds to the path of the file where the default standards 
are stored.

You can change the path by clicking the Browse icon .

 
Automatic Standard Import

 You can automatically import the standard by clicking on the Automatic Standard Import 
check box.
If this option is activated, any BiW feature creation (BiWJoint, BiW JointBody, BiW Fastener) 
automatically imports the standard.

  By default, this option is checked.
 

Check the Standard File Consistency at Import Time
 You can also select the Check the Standard File Consistency at Import Time option to 

check the consistency of the standard values when importing the standard file (whose path is 
mentioned above)
If the standard file is not valid, it cannot be imported and an error message is issued.

  By default, this option is unchecked.
 

Defining the Export Directory



 

 The Export default directory is the directory where the export file is stored.

You can change the by clicking the Browse icon .

 

Defining the Report Directory
 

 The Report default directory is the directory where the report file is stored.

You can change the by clicking the Browse icon .

 

Setting Up Extract Parameters
 

 

 
Fixed Drawing Spot Size

 You can define a fixed size for the 2D drawing spots: check the Fixed Drawing Spot Size 
button and define a diameter value.
As a consequence, all spots in the 2D document will have this diameter, whatever their size in 
the 3D document.

  By default, this option is unchecked.
 

Angular Tolerance
 You can define a user Angular Tolerance.
  By default, this option is set to 90deg.
 

Include View Reverse Direction
 You can check the Include View Reverse Direction checkbox to visualize 2D reverse spots.
  By default, this option is unchecked.

Refer to the Drafting Integration chapter to have further information.

Allow creation Enovia unsaved data
 



 You can allow the creation of unsaved data from Enovia by clicking the Allow button.
If you do not select this option, commands will be grayed out in Enovia V5.

  By default, this option is unchecked.
 For further information, refer to the Optimal CATIA PLM Usability for Automotive BiW Fastening 

chapter.



BiW Fastening Application Display User Settings  

 

  

This page deals with the following settings:
●     3D Fasteners All Display Options

●     Shape 

●     ID

●     Fastener Parameters

●     Fastener Axis Orientation 

●     Support Contact Zone Material Orientation

●     Contact Zones

3D Fasteners All Display Options
 

Click the Unset All button to uncheck all the options, except for the Shape Representation option. Similarly click the Set All button to 

check all options.

These options apply to all the fasteners contained in the product.

 

Shape
 

Click the Show button to visualize the fastener's shape.

  By default, this option is checked.

 

ID
 

 
Click the Show button to visualize the fastener's ID.

 
 By default, this option is unchecked.

 

Fastener Parameters



 

 Click the Show button to visualize the fastener's shape.

  By default, this option is unchecked.

 
Associating a symbol to a specification

 
●     a process type (by default): the symbol is displayed according to the 

symbol code assigned to the Fastener Process Type in the standard file. 
By default, if no symbol is assigned to the process type in standard, or 

if there is no imported standard, the symbol is  (101)

●     an unspecified type (Unspec): the default symbol  is displayed. It 

can be modified through the Properties contextual command.

●     the thickness count: the symbol is displayed according to symbol code 

assigned to the Thickness Count  in the standard file.

By default, if no symbol is assigned to the thickness count in standard, 

or if there is no imported standard, the symbol is: 

for 1 thicknesses (1)

 for 2 thicknesses (2T)

 for 3 thicknesses (3T)

 for 4 thicknesses (4T)

 for more than 4 thicknesses

 

●     None: no symbol is visualized.

Once the symbol is associated with a specification, it can not longer be 
modified when editing the fastener's properties, except for the Unspecified 
type.

The example above shows that the graphic symbol is 
assigned to the Laser process type. The symbol color is 
assigned to the Welding process category.

 // Symbol Dependency from
Thickness Count  

NTH_2_SYM 151

NTH_3_SYM 113

NTH_4_SYM 114

For 1T:

For 2T: 

For 3T: 

For 4T: 

 The example above shows how to define a graphic symbol associated to a thickness count

 
Associating a color to a specification



 
●     a process category (by default): the color is displayed according to the color code assigned to the Fastener Process Category in the 

standard file.

By default, if no color is assigned to the Process Category or no standard is imported, the default color is:

Yellow for Welding
Cyan for Adhesive
Magenta for Sealant
Green for BiW Mechanical
White for Unspecified

●     an unspecified type (Unspec): the color is white whatever the Process Category.

 
●     None: no symbol color is visualized.  

In this case, the color associated with the process category will be transparent.

Once the color is associated with a specification, it can not longer be modified when editing the fastener's properties, except for the 
Unspecified type.

 
Associating marks to the specification  

 
●     Robustness

●     Regulation

●     Finish

●     None

Note that:

●     1 is for assigning a mark

●     0 is for assigning no mark

For instance assign the 1 mark code for the Robustness 
parameter and which value set by default is C: 

You will get this Mark: 

 In this case all the Fasteners with the Robustness specification will get the mark symbol.

In the Standard file, Marks are assigned by default:
●     For Robustness parameter ("Safety") enter the C value.

●     For Regulation parameter ("Norm A") enter the A value.

●     For Finish parameter ("Class A") enter the A value.

Fastener Axis Orientation

 

 

 Click the Show button to visualize the fastener's axis orientation.  

  By default, this option is unchecked.  



 

●     K Axis Only:
❍     if checked, only the K axis is visualized on the fastener's location.

❍     If unchecked, a trihedron showing the fastener's axis system (I, J, 
K) is visualized on the fastener's location.

For a curvebead, the location corresponds to the start point.

  By default, this option is checked.  

 

●     On each Discretization Point: for a curvebead, it enables to visualize 
the axis (K or I, j, K) on each discretization point.

❍     if checked: the fastener axis (K or I, j, K) is visualized on each 
discretization point of the curvebead.

❍     if unchecked, the the fastener axis (K or I, j, K) is visualized on the 
start point of the curvebead only.

In the examples beside, the Fastener Axis Orientation button is 
checked and the K Axis Only button is unchecked.

  By default, this option is unchecked.  

 Support Contact Zone Material 
Orientation

 

 Click the Show button to visualize the material orientation of the support 
contact zone.

 
 By default, this option is unchecked.

Contact Zones
  

 
Show Projected Points

 



 

Select this option to visualize the fastener's projected points.

 

 By default, this option is unchecked.

Show Material Orientation
 

 

Select this option to visualize the fastener's material orientation.

 

 By default, this option is unchecked.

Show Thickness Stack-Up Order
 

 

Select this option to visualize the fastener's thickness stack-up order.

 

 By default, this option is unchecked.

●     You can define the thickness and the material orientation for a GSD feature using the Thin Parts Attribute command in the 
Generative Shape Design workbench.
Refer to the Applying a Thickness chapter in the Generative Shape Design documentation.

●     The options listed above can also be accessed using the fasteners' properties via the contextual menu.
Refer to the Editing the Fasteners' Properties chapter.
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