Javelin

** DISCLAIMER: This document assumes that your installation of SolidWorks was originally installed using the default locations, If your
installation location for SolidWorks differs please adjust the techniques below accordingly. The procedures in the following document
require access and edits to the windows registry. Any such edits are at your own risk and should only be attempted under the advisement
and direction of your IT professional. If you are uncomfortable with executing the procedures below please seek assistance. It is advised to
back up your registry and any valued data before making any changes to the system registry. Javelin Technologies assumes no
responsibility for any consequences, unintended or otherwise resulting from changes made to the system or the system registry.

Backup Customizations and Transfer License

1. Backup existing SolidWorks Settings using the Copy Settings Wizard (Keyboard
shortcuts, menu customizations and toolbar layouts):

a. Go tothe Windows Start menu > All Programs > SolidWorks 20xx
b. Under the SolidWorks Tools folder, choose the “Copy Settings Wizard”
c. Chose the “Save Settings” option & follow the on-screen instructions

2. Backup all customized SolidWorks files (templates, weldment profiles, design library, etc). Any items that
have been customized should be copied out of the default SolidWorks directories. Consider storing
customized files in a custom location and reference the location in you new installation of SolidWorks under
the Tools menu > Options > File Locations.

3. If running a customized Toolbox on your local machine, backup the Toolbox database; default location
C:\SolidWorks Data.

4. Prior to the next steps please start SolidWorks and transfer your Activation back to the SolidWorks Server
through Help > Transfer License...
http://www.javelin-tech.com/blog/2012/03/transfer-sw-license/

5. Cleanup the SolidWorks temporary directory using the SolidWorks Rx tool under Start > All Programs >
SolidWorks 20xx > SolidWorks Tools > SolidWorks Rx. Select the System Maintenance tab:

&, SolidWorks Rx = Py
File Help
" Home & Diagnostics FTroubleshoot & System Maintenance - “&#Problem Capture [ <>
This utiity wil remove temporary SolidWorks and Windows files and perform system W
maintenance. Review and edit the locations listed, if necessary. |
Clean the SolidWorks backup directory
@@ C:\Users\<username>\AppData\TempSWBackupDirectory iﬂv

Clean the SolidWorks temporary directories
@ C:\Users\<username>\AppData\Local\Temp i
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Complete Uninstall Procedure
6. IMPORTANT: Obtain LOCAL administrative rights to the computer. Consult your IT administrator if required.

NOTE: Only having DOMAIN administrative rights will not be sufficient. Ensure you have LOCAL rights.

7. IMPORTANT: Disable User Account Controls (http://www.javelin-tech.com/bloa/2011/01/uac/)

e Windows 7:
a. Click Start and type UAC in the search bar
b. Drag the slider down to Never Notify
c. Click OK and restart your computer

e Windows 8:

Press the Windows key on the keyboard

Type “uac” to start the search (without quotations)
Select Settings under the search box on the right
Select Change User Account Control settings
Drag the slider down to Never Notify

Click OK and restart your computer
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8. IMPORTANT: Disable any anti-virus or anti-spyware programs currently in use. Consult your IT administrator
if required (http://www.javelin-tech.com/blog/2011/06/disable-antivirus/)

a. From the Windows Start menu, select or type Run and then type Services.msc
b. Browse to any anti-virus/spyware programs in the list, right click and “stop” the services

NOTE: Some antivirus programs cannot be stopped from Services. If this is the case, disable the live
protection through the program itself. In extreme cases, uninstalling the antivirus program may be
required.

WARNING: BitDefender antivirus has been known to cause instability with Windows when reinstalling the
Microsoft prerequisite programs (.NET, Visual C++, VSTA). This program cannot be stopped and needs
to be uninstalled prior to uninstalling and reinstalling Solidworks.

9. Using “Programs and Features” in the Windows Control Panel, uninstall the following programs:

a. Any add-on products (eDrawings, PDM/Works, DWGEditor, 2D Editor, etc — these may not be present)
b. Older versions of SolidWorks (if applicable)
c. Current version of SolidWorks

When uninstalling SolidwW orks:
e Be sure all products are selected to uninstall
e Click “Change” beside Advanced Options and select all options
e Right-click on the Title Bar in the Installation Manager > Installation Logging Levels > “Create
Windows Installer Logs”
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10. Using “Programs and Features” in the Windows Control Panel, uninstall the following Windows prerequisite
programs in this order:

All Microsoft Visual C++ 2005 o v i Cona - o

All Microsoft Visual C++ 2008
All Microsoft Visual C++ 2010
All Microsoft Visual C++ 2012 R -

Microsoft Visual Studio 2005 Remote Debugger e s

. . . . . ® {Microsoft Microsoft Corporation
Microsoft Visual Studio 2005 Tools for Applications 3 Mool Vi e+ 200 et (64 Mool Cororaon
L] +4 2005 Redistributable {x64) Microsoft Corporation

++ 2008 Redistributable - x54 9. 729, Microsoft Corporation
+ 2008 Redistributable - x! 1414 Microsoft Corporation

g\ )o!i§ » Control Panel » All Control Panel items » Programs and Features
W/

Control Panel Home.

Uninstall or change a program

To uninstall a program, select it from the ist and then click Uninstall, Change, or Repai.

Organize =

~oooTp

ble - X86 90307204148
ble - x36 9.0.30729,6161 Microsoft Corporation

5 | Microsoft 2010 x64

+ 2 butable - 10040219 Microsoft Corporation

8 { Microsoft Visual C+-+ 2010 x86 Redistributable - 10,0.40219 Microsoft Corporation

P Microsoft Visual Studio 2005 Remote Debugger Light (x64) - ENU Microsoft Corporation

@ Microsoft Visual Studio 2005 Tools for Applications - ENU Microsoft Corporation
“—7  Currently installed programs Total size: 115 GB

NOTE: Programs listed together for clarity

11. FOR SOLIDWORKS 2013 AND NEWER: Uninstall Visual Basic 7.1

a. Open the Command Prompt (Start > All Programs > Accessories > Right-click on Command Prompt
and “Run as Administrator”)

b. Type msiexec.exe /X{90120064-0070-0000-0000-4000000FF1CE}

& Administrator: Command Prompt = ]ﬂ |

C:\>msiexec.exe /X(90120064-0070-0000-0000-4000000FF1CE]}_

12. Using “Programs and Features” in the Windows Control Panel, uninstall the following Windows prerequisite
programs in this order:

a. Microsoft Office 2003 Web Components Q0T o i T 15| shiet PR
b. Microsoft .NET Framework 4.5.1 R
c. Microsoft .NET Framework 4 Extended VeSS ottt i 10 e o e
d. Microsoft NET Framework 4 Client Profile 2 im0 : - @
e. Bonjour Bt -

@ e

NOTE: Programs listed together for clarity
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13. Remove the Windows Registry keys relative to SolidWorks after uninstalling all products.

a. From the Windows Start menu, type regedit in the search box
b. Inthe Registry Editor, delete the keys below.

NOTE: Some of the keys listed may not be present on your system.

Under HKEY_CURRENT_USER\Software

eDrawings

SolidWorks

IMPORTANT: if you are using Enterprise PDM, DO
NOT DELETE the SolidWorks key; instead, go into
this key and delete only the IM & SolidWorks 20xx
subkeys; leaving everything else.

SolidWorks BackOffice

SRAC

Under HKEY_LOCAL_MACHINE\Software

eDrawings

SolidWorks

IMPORTANT: if you are using Enterprise PDM, DO
NOT DELETE the SolidWorks key; instead, go into
this key and delete only the IM & SolidWorks 20xx
subkeys; leaving everything else.

SolidWorks Corporation

SRAC

Under HKEY_LOCAL_MACHINE\Software\Wow6432Node

eDrawings

SolidWorks

SolidWorks Corporation
SRAC

Under HKEY_LOCAL_MACHINE\Software\Microsoft

VSTAHOST
VSTAHostConfig

8’ Registry Editor

File Edit View Favorites Help

4 & Computer
. HKEY_CLASSES_ROOT
4 -} HKEY_CURRENT_USER
AppEvents
Console
Control Panel
CounterPath
Environment
EUDC
Identities
Keyboard Layout
Network
Policies
Printers
Software
| eDrawings
J. Solidworks
| SolidWorks BackOffice
J. srac
4| HKEY_LOCAL MACHINE
» -4 BCD00000000
HARDWARE
SAM
SECURITY
SOFTWARE
eDrawings
SolidWorks
SolidWorks Corporation
Srac
Wow6432Node
>~} eDrawings
>~} SolidWorks
. SolidWorks Corporation
). Srac

NOTE: Other Registry Key Folders are Hidden for Clarity

Under HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft
e VSTAHOST
e VSTAHostConfig
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14. Delete the SolidWorks installation directory (NOTE: not all locations may be present on your system):

C:\Program Files\Common Files\eDrawings

C:\Program Files\Common Files\eDrawings<year>

C:\Program Files\Common Files\SolidWorks Installation Manager

C:\Program Files\Common Files\SolidWorks Shared

C:\Program Files (x86)\Common Files\eDrawings (64-bit operating system only)
C:\Program Files (x86)\Common Files\SolidWorks Installation Manager (64-bit operating system only)
C:\Program Files (x86)\Common Files\SolidWorks Shared (64-bit operating system only)
C:\Program Files\SolidWorks

C:\Program Files\SolidWorks Corp

C:\Program Files (x86)\SolidWorksx86 (64-hit operating system only)

C:\Program Files (x86)\SolidWorks Corp (64-bit operating system only)

C:\Program Files\SolidWorks <year> Corp or the custom location SolidWorks was installed to.
C:\SolidWorks Data - delete any duplicates like C:\SolidWorks Data (2)
*C:\ProgramData\SolidWorks

*C:\ProgramData\SolidWorks Flow Simulation

*The ProgramData folder is hidden by default. Go to the Control Panel and select Folder Options. Open the View tab and select “Show
hidden files, folders and drives” from the list.

15. If Microsoft .NET Framework errors were indicated, repair Microsoft .NET Framework 3.5.1

P20 T®

«

In the Programs and Features list, click “Turn Windows features on or off” in the left pane

Deselect “Microsoft .NET Framework 3.5.1”

Click OK and wait for the changes to be made

Return to “Turn Windows features on or off”

Select “Microsoft .NET Framework 3.5.1”
* Leave “Windows Communication Foundation HTTP Activation” and “Windows Communication
Foundation Non-HTTP Activation” deselected

Click OK and wait for the change to be made

Restart the computer

¥ ¥ Control Panel b Programs ¢ Programe md Festures » 149 § Socvth Frogroms ond Sacruny 2

Coatrol Panel Home ;
Uninstall or change a program
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N\ o /
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netwonk -
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Currently installed programs Total size: 518 G3
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16. NOTE: This step is optional and the utility is USE AT YOUR OWN RISK, but it is recommended if there are
Microsoft .NET Framework errors (as .NET Framework 3.5 is built into Windows)

Download and run the utility from the following link:
http://www. softpedia.com/progDownload/NET-Framework-Cleanup-Tool-Download-116561.html

Warning: continuing further wil make permanant chenges to your system.
You will need to reinstal any preducts that you choose to deanup. If you do
not want to proceed, press the Exit’ buticn now.

Press "View Readme’ to read a detaled desaription of what permanent
changes will be made to your system,

Press 'Cleanup Nowr' to begin deaning w the select=d product,

Procuct to dearup: | NET Framework - All versiors (Windows 7). v |

Current status: Weiting for user to press Clearup Now button

Yiaw Readma= | View Log | Clearup Now I Exit I

Use the following guide if in doubt:
http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

17. Reboot your system
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Clean Installation Procedure

For instructions on the best practices when installing SolidWorks, please refer to the appropriate installation guide
found on our FAQ webpage at http://www.javelin-tech.com/main/support/fag.htm

e SolidWorks Installation Guide Standalone License
e SolidWorks Installation Guide Network License

IMPORTANT: Enable Windows Installer Logs when installing

ger (X654 Edition] @ Restore

2 O~ Move
2R Right-click [N Nl
a  Maimize

4 -
High (Slowest)

Installation Logging Levels ’
| Désable Intemet Access Medium
v Low (Fastest, Default)
Welcome Summary ol A
Uninstall [ You have chasen to uninstall Sali v Creste Windows Instafler Logs (Slow)

Select the products that you want to uninstall. Unselected products will remain o

** Note: More information regarding the backup and restore of the windows registry may be found at the following URL:
http://support.microsoft.com/kb/322756

** Note: Detailed installation instructions may be found by accessing the Help files in the downloaded files or DVD:
<DVD Drive letter or Download directory>\sldim\lang\english directory
e nstall_guide.chm
e admindirector.chm
e sldim_download.chm
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